util-linux needs updating to 2.24.2

Bug #1012081 reported by Rachel Greenham on 2012-06-12
This bug affects 165 people
Affects Status Importance Assigned to Milestone
util-linux (Debian)
Fix Released
util-linux (Ubuntu)
Martin Pitt
Declined for Quantal by Brian Murray
Declined for Saucy by Brian Murray
Declined for Trusty by Martin Pitt

Bug Description

Applications in the default desktop - specifically gnome-disk-utility - depend on behaviour only introduced in util-linux 2.21+. Specifically if you select "Show in user interface" in mount options, it adds the mount option "x-gvfs-show" to the mount options in /etc/fstab. Mounting of this mount point then fails because the option is unrecognised.

Also reported bug from the other point of view in bug #1011257

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: util-linux 2.20.1-1ubuntu3
ProcVersionSignature: Ubuntu 3.4.0-5.11-generic 3.4.0
Uname: Linux 3.4.0-5-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.1.1-0ubuntu2
Architecture: amd64
Date: Tue Jun 12 12:38:02 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
 PATH=(custom, user)
SourcePackage: util-linux
UpgradeStatus: Upgraded to quantal on 2012-06-09 (3 days ago)

Related branches

Logan Rosen (logan) on 2012-06-12
tags: added: upgrade-software-version
Martin Pitt (pitti) wrote :

Assigning to LaMont, as he kindly agreed to update the package.

This is also needed to fix wipefs to properly clean up VFAT devices. With the current version you need to call it three times before it succeeds. This is reproduced with the udisks2 test suite, and with these manual commands:

# empty initially:
$ sudo modprobe scsi_debug
$ sudo blkid -p /dev/sdb

# create FAT:
$ sudo mkdosfs -I -n testvfat /dev/sdb
mkdosfs 3.0.12 (29 Oct 2011)
$ sudo blkid -p /dev/sdb
/dev/sdb: SEC_TYPE="msdos" LABEL="testvfat" UUID="CA17-02B3" VERSION="FAT12" TYPE="vfat" USAGE="filesystem"

# wipe it:
$ sudo wipefs -a /dev/sdb
8 bytes were erased at offset 0x36 (vfat)
they were: 46 41 54 31 32 20 20 20

# not empty yet!
$ sudo blkid -p /dev/sdb
/dev/sdb: SEC_TYPE="msdos" LABEL="testvfat" UUID="CA17-02B3" VERSION="FAT12" TYPE="vfat" USAGE="filesystem"

# wiping once more is still not sufficient
$ sudo wipefs -a /dev/sdb
1 bytes were erased at offset 0x0 (vfat)
they were: eb
$ sudo blkid -p /dev/sdb
/dev/sdb: SEC_TYPE="msdos" LABEL="testvfat" UUID="CA17-02B3" VERSION="FAT12" TYPE="vfat" USAGE="filesystem"

# wiping a third time finally works:
$ sudo wipefs -a /dev/sdb
2 bytes were erased at offset 0x1fe (vfat)
they were: 55 aa
$ sudo blkid -p /dev/sdb

$ sudo rmmod scsi_debug

Changed in util-linux (Ubuntu):
assignee: nobody → LaMont Jones (lamont)
status: New → Triaged
Changed in util-linux (Debian):
status: Unknown → New
dino99 (9d9) wrote :

Also affected on Quantal i386

gnome-session[2673]: WARNING: Failed to start app: Unable to start application: L'exécution du processus fils « /usr/lib/gnome-disk-utility/gdu-notification-daemon » has failed

and worst, /etc/fstab is automatically modified by added entry line about /dev/fd0 even if this kind of hardware does not exist on this desktop pc. This make a process loop trying to mount that ghost, and as its a root one, htop cant kill it.

tags: added: i386
Martin Pitt (pitti) wrote :

For quantal it is presumably too late now to update to a new upstream version. I split off the wipefs bug to bug 1046665.

gouri (stephane-gourichon-lpad) wrote :

This bug was reported on an upgraded system. It also happens on a fresh quantal install.

How to reproduce :
* install quantal on a new dedicated partition.
* have another partition that you want to be mounted at boot time
* from unity launcher run "disk utility" (process name is "gnome-disks")
* click on that other partition
* click on gear icons, choose "edit mount options"
* toggle "automatic mount option s" which enables the other controls (you don't need to change anything else)
* click on "validate"

gouri (stephane-gourichon-lpad) wrote :

(Continuing from comment above)

* (one may see that it also reproduces bug https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1010858 see comment 1010858#13)
* reboot. *System is now unbootable*. It stays on aubergine background, no hint.

* Rebooting in rescue mode allows to manually :
** run mount -avv
** dmesg | tail, see the problem about x-gvfs-show
** remount / read-write
** edit /etc/fstab, remove ",x-gvfs-show", save
* reboot again, problem fixed

This is a serious bug : human user does not expect to make its system unbootable just by following graphical tools and "disabling automatic mount option" for a data partitions (without changing any other settings).

Xavier Guillot (valeryan-24) wrote :

util-linux is still not upgraded to version 2.21 both in current Ubuntu Raring 13.04 and Debian Sid.

It makes me also affected by bug https://bugs.launchpad.net/ubuntu/+source/gnome-disk-utility/+bug/1011257

when I try to connect and mount an external eSATA hard drive with ext4 partition, it's not possible to access the media and I get the following error:

Error mounting /dev/sdd1 at /media/valeryan24/Verbatim: Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdd1" "/media/valeryan24/Verbatim"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sdd1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

I can mount USB key or hard drive but not the eSATA one for my backups.

dino99 (9d9) wrote :

Post #2 above was bringing some hopes, but then nothing have happened sadly. RR will be released in a few weeks now, so please dev(s), take the time to package it then update the archive.

The latest version now is 2.22.2 and again have many fixes


summary: - util-linux needs updating to 2.21+
+ util-linux needs updating to 2.22+

In case someone want to test a newer version, that ppa is having 2.22-1 (quantal)

Bryce Harrington (bryce) on 2013-03-06
Changed in util-linux (Ubuntu Raring):
milestone: none → ubuntu-13.04
dino99 (9d9) on 2013-04-26
tags: added: raring saucy
Jeremy Bicha (jbicha) wrote :

Lamont, do you still intend to work on this? It would be great to have this done in time for Ubuntu 13.10.

Götz Christ (g-christ) on 2013-08-20
summary: - util-linux needs updating to 2.22+
+ util-linux needs updating to 2.23+
dino99 (9d9) on 2013-10-30
tags: added: trusty
summary: - util-linux needs updating to 2.23+
+ util-linux needs updating to 2.24
Sworddragon (sworddragon) wrote :

From the changelog here (https://www.kernel.org/pub/linux/utils/util-linux/v2.20/v2.20.1-ChangeLog) util-linux 2.20.1 is now 26 months old. Also the milestone 13.04 has already past. Ubuntu goes LTS with 14.04 so I'm hoping that we will have an up to date version there.

Please act on this - it seems that Trusty is still with 2.20, and if the upstream report is correct, this is also the cause of the really embarrassing https://bugs.launchpad.net/ubuntu/+source/udisks/+bug/1059872 ... Really, not being able to format an USB with the default utility seems a bit strong to me.

Since this bug renders essential functionality of the application or dependencies broken, it has a priority of "high".

Changed in util-linux (Ubuntu):
importance: Undecided → High
Changed in util-linux (Ubuntu Raring):
importance: Undecided → High
Changed in util-linux (Ubuntu):
milestone: ubuntu-13.04 → none
Changed in util-linux (Ubuntu Raring):
milestone: ubuntu-13.04 → none

This bug has been assigned to LaMont Jones on 2012-06-19 (19 months ago).

Thanks Alberto --- good to see you on this. If a -proposal package is prepared for 13.10, count on me for testing.

Pieter Engelbrecht (chesedo) wrote :

I'm also willing to test for 13.10 (might just need to include instructions as I have never done this before).

Maykel Moya (mmoyar) on 2014-02-18
summary: - util-linux needs updating to 2.24
+ util-linux needs updating to 2.24.1

Any news about this ticket?

It's quite a bad news to see LTS out without this closed :/

Ivan Larionov (xeron-oskom) wrote :


Package has been converted to 3.0 (quilt) format.
Latest upstream was imported.
A lot of patches were dropped (most of them already applied to upstream, but also removed rmd160 hashpass/keys support). Others fixed.
Somehow get it compiled.

Important: do not install on production systems. I believe it doesn't work. There was big change to mount (old mount was moved to mount-deprecated and mount.c was implemented in libmount) and I haven't adjusted package to this.

Nothing tested. Just first successfully compiled version with 2.24.1.

Feel free to help :)

Phillip Susi (psusi) wrote :

I had already converted the package to 3.0 ( quilt ) format, and just disregarded any remaining patches that have not been merged upstream since it is insanely difficult to extract them from the current git repo and got it working and waiting for a few weeks for Lamont to upload it to Debian. I spoke with infinity on irc the other day who said he would make the time to review the full git repo and convert any needed patches into quilt format and get this done.

I originally raised this bug a hell of a long time ago. The gnome-disk-utility of that era had some nice functionality for end users which looked like it would work well if the version of util-linux the feature depended on was actually present.

Since that time, gnome-disk-utility has itself lost so much functionality (eg: all understanding of raid arrays, which directly affected me) that I gave up using it anyway and found out how to hack /etc/fstab into doing it directly. That being the apparent mission of gnome developers of course; to remove functionality until you can't actually do anything any more. So tbh this no longer really affects me. Years too late in getting the attention of anyone able to do anything about it.

Maybe it does though. After all just a few days ago I tried to do a nice simple task: reformat a usb stick to msdos/vfat et al. I was pressed for time, so i ran "Disks" to do it, but it completely failed. I had to do it on my mac laptop instead. So maybe this is why; as the distance between the version of util-linux gnome-disk-utility needs and the version present has stretched further apart over the years.

(I should check before i post. gnome-disks (as it now seems to be) seems to have regained some raid understanding. It was gone in some intermediate version, and that's when i'd stopped trying to use it for anything, except that usb-stick reformat, which was before the raids were set up again on this new system.)

Ivan Larionov (xeron-oskom) wrote :

So any news?

vinibali (vinibali) wrote :

Hi Ivan,
thanks for your work. For me something is bad under the hood.
Translated with Google:

Balazs @ Blaise GA- A75 - D3H usr/src/linux-headers-3.13.0-22 :/ $ sudo apt- get install util -linux
Reading package lists ... Done
Building dependency tree
Reading state information ... Done
The following packages were automatically installed and are no longer needed :
  cdrkit Brasero Brasero - gimp -help -common libexempi3 libzeitgeist -1.0- 1 -generic linux-image
They can delete the 'apt -get autoremove " command.
Suggested packages :
  util -linux- locales
The following packages have been updated :
  util -linux
1 upgraded, 0 newly installed, 0 to remove and 254 not upgraded.
The amount of data downloaded : 701 kB .
979 kB disk space will be used after the operation .
Download: 1 http://ppa.launchpad.net/xeron-oskom/util-linux/ubuntu/ trusty / main util -linux amd64 2.24.1 - 1ubuntu1 [701 kB ]
Downloaded 701 kB in 0s ( 1677 kB / s)
Preconfiguring packages ...
( Reading database ... 152982 files and directories currently installed. )
Preparing to unpack ... / util - linux_2.24.1 - 1ubuntu1_amd64.deb ...
Unpacking util -linux ( 2.24.1 - 1ubuntu1 ) over ( 2.20.1 - 5.1ubuntu18 ) ...
dpkg : error processing archive / var/cache/apt/archives/util-linux_2.24.1-1ubuntu1_amd64.deb ( - unpack ) :
 Trying to overwrite '/ bin / kill ', Which is Also in package procps 1:3.3.9 - 1ubuntu2
dpkg -deb : error : subprocess paste was killed by signal ( Broken Tubes)
Errors were encountered while processing:
 / var/cache/apt/archives/util-linux_2.24.1-1ubuntu1_amd64.deb
E: Sub -process / usr / bin / dpkg returned an error code ( 1 )
Balazs @ Blaise GA- A75 - D3H :/ $ usr/src/linux-headers-3.13.0-22

libblkid was important for me, that uses the newer version, but the util-linux is still at 2.20 :/

Ivan Larionov (xeron-oskom) wrote :

Actually I stopped my work on this package because looks like Phillip Susi already submitted updated package for debian review.


But I'm worry that there are no news about it.

Jason Staten (statianzo) wrote :

It should still be in triaged. Can't undo

Changed in util-linux (Ubuntu Raring):
status: Triaged → Fix Released
Changed in util-linux (Ubuntu Raring):
status: Fix Released → Triaged
dino99 (9d9) on 2014-05-20
tags: added: utopic
removed: quantal
Anca Emanuel (anca-emanuel) wrote :

And who is testing it ? No ppa ? No QA ?
Who is responsible for this ?

Brian Murray (brian-murray) wrote :

Raring reached End of Life in January of 2014 as such the task should be Won't Fix.

Changed in util-linux (Ubuntu Raring):
assignee: LaMont Jones (lamont) → nobody
status: Triaged → Won't Fix
Brian Murray (brian-murray) wrote :

I've also declined the Quantal nomination as it became End of Life last week.

Phillip Susi (psusi) wrote :

Adam Conrad has been working on this.

Amr Ibrahim (amribrahim1987) wrote :

According to upstream https://github.com/karelzak/util-linux, the version schema is:


             major = fatal and deep changes
             minor = typical release with new features
             maint = maintenance releases; bug fixes only
             bugfix = unplanned releases for critical/security bugs

So, I think updating 2.20.1 in trusty to 2.24.2 is safe.

summary: - util-linux needs updating to 2.24.1
+ util-linux needs updating to 2.24.2
vinibali (vinibali) wrote :

any news?

Arion Lawrence (arion-arion) wrote :

There is another use case for updated util-linux. Newer versions have 'nsenter' which makes poking at running Docker containers possible..

Changed in util-linux (Debian):
status: New → Fix Released
Ivan Larionov (xeron-oskom) wrote :

I've rebuilded 2.25-8 from debian. Looks like it somehow works. https://launchpad.net/~xeron-oskom/+archive/ubuntu/util-linux

Martin Pitt (pitti) wrote :

I prepared a merge in http://people.canonical.com/~pitti/tmp/util-linux-merge/ . Tested in a VM and on my amd64 desktop so far, will still test on current phone.

Changed in util-linux (Ubuntu):
assignee: LaMont Jones (lamont) → Martin Pitt (pitti)
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

I now also tested this on the current Touch image without any apparent regressions/problems.

Uploaded. I want to run a bunch of our autopkgtests against that version, thus I'll keep this in -proposed for a bit.

Changed in util-linux (Ubuntu):
status: In Progress → Fix Committed
tags: added: block-proposed
Martin Pitt (pitti) wrote :

I now run lots of our autopkgtests (anything which is even remotely getting close to handling mounts, partitions, cgroups, etc.), including all cloud, LXC, deboostrap etc. packages. There were only two regressions:

 * apport's tests made specific assumptions about a conffile which now got moved. Fixed in https://launchpad.net/ubuntu/+source/apport/2.14.6-0ubuntu2

 * udisks2's tests seem to have become more racy with the new version (or the race condition more apparent due to running many tests in parallel). First attempt at fixing this was in https://launchpad.net/ubuntu/+source/udisks2/2.1.3-3 which helped in local QEMU, but not yet in CI's QEMU environment. I'll still track that separately, but it's not related to util-linux (that's ntfs-3g at most, but it's really just a race condition in the test).

Apart from those, everything is green again which was green before, so I consider this sufficiently regression tested.

tags: removed: block-proposed
Launchpad Janitor (janitor) wrote :
Download full text (14.2 KiB)

This bug was fixed in the package util-linux - 2.25-8ubuntu1

util-linux (2.25-8ubuntu1) utopic; urgency=medium

  * Merge with Debian experimental.
    - This is now a non-ancient version. (LP: #1012081)
    - No longer uses /etc/blkid.tab by default, but a file in /run/.
      (LP: #1244595)
    - mkswap wipes fs signatures (LP: #1047666)
    - Fix "reatime" manpage typo (LP: #1047666)
    - wipefs properly cleans up fs signatures (LP: #1059872)
    Remaining Ubuntu changes:
    - Regularly trim SSDs automatically (core-1311-ssd-trimming):
      + Add debian/fstrim-all: Script to detect which mounted partitions
        need/support trimming, and call fstrim(8) on all of them.
        Install into /usr/sbin/.
      + Add debian/fstrim-all.8: Manpage for the above.
      + Add debian/fstrim-all.cron: Trivial shell script to call fstrim-all,
        so that admins can easily adjust/disable it. Installed as
    - Upstart support:
      + Add hwclock{-save}.upstart, and install them in debian/rules.
      + Drop initscripts dependency.
      + Drop debian/hwclock.rules and hwclock.default.
    - Add mountall-options.patch, see patch header.
    - uuid-runtime.postinst: Due to the way the uuidd account is created, it
      will get a uid/gid allocation for userns use. This isn't needed and is a
      waste of uid/gid so always clear uuidd from subuid/subgid.
  * Drop /lib/init/fstab parsing fallback in mount. Patch does not apply at
    all any more, is specific to mountall (and thus should not be relied
    upon), and not very useful; all init systems, schroot, debootstrap etc.
    mount /sys, /proc/ and friends by themselves already.

util-linux (2.25-8) experimental; urgency=medium

  * Only install linux32/64 manpages on linux-any
  * Fix uuid-runtime.postinst to skip rmdir when not needed (Closes: #757432)
  * fdisk-udeb: use dh-exec to skip sfdisk install on sparc

util-linux (2.25-7) experimental; urgency=medium

  * Mangle installed files on sparc (sfdisk)
  * Fix sparc install mangling
  * Use --disable-mountpoint instead of rm
  * Use dh-exec (>= 0.13)
  * Install mips,ppc,s390 setarch symlinks and manpages

util-linux (2.25-6) experimental; urgency=medium

  The "Jonno was here" release.

  [ Jon Severinsson ]
  * Drop changelog file from the ancient mount source package.

  [ Andreas Henriksson ]
  * util-linux: Drop all (obsolete) Replaces/Conflicts

  [ Jon Severinsson ]
  * Add Replaces/Breaks bash-completion (<< 1:2.1-3).
  * Multiple cleanups in debian/control.
  * Minor cleanup of debian/rules.
  * Use filter, not findstring, for arch matching
  * Simplify linux-only install file handling
  * Use debian/*-udeb.install files for udeb packages.
  * Fix util-linux lintian override.

  [ Andreas Henriksson ]
  * Minor uuid-runtime.postinst cleanup
  * Add d/p/cfdisk-reenable-cursor-when-quitting.patch (Closes: #755991)

util-linux (2.25-5) experimental; urgency=medium

  The "big maintainer-script cleanup" release

  * Drop debian/uuid-runtime.prerm (and related lintian override)
    - dh_installinit will automatically start and stop services as needed.
  * Drop debian/libuuid1.postin...

Changed in util-linux (Ubuntu):
status: Fix Committed → Fix Released
vinibali (vinibali) wrote :

i tried Ivan's util-linux package and the gparted, gnome disk utility are able to get the uuid from a f2fs partition. so looks like blkid is working properly.
i tried many times to compile my own util-linux, but i always had to chroot the system :)
nice job!

OK, thanks...so where's the update to trusty (LTS)?

If it's in utopic a not in Trusty, someone should start a SRU request. https://wiki.ubuntu.com/StableReleaseUpdates
But I suspect that, given that this bug has been declined for Trusty, it will be quite difficult to get through.

Coeur Noir (gerald-maruccia-e) wrote :

Bug still occurs in Ubuntu 14.04.1 freshly installed and updated.

Pradeepk (raj-pradeep-kumar) wrote :

Issue still exists in 14.04.1

Jan (jan-nielsen135) wrote :

Issue present in Linux Mint 17.1 (Ubuntu 14.04).

Ivan Larionov (xeron-oskom) wrote :

It won't be released for trusty I think. I have PPA with backported version: https://launchpad.net/~xeron-oskom/+archive/ubuntu/util-linux

But please note before usage: I won't update it or fix bugs because it's time to move to 14.10 and (soon) 15.04.

Hartwig Kolbe (kolbeb) wrote :

In 12.10 to 14.04, I was using several ntfs partitions which got auto-mounted by fstab entries, using "...uid=1000,gid=1000,x-gvfs-show,x-gvfs-name=something".
With a new PC I installed 14.04.2 64bit, and use ext4 for these shared disks.
Unfortunately, doing so had me hit by this bug. Since auto-mounting is necessary, I tried to find a solution which took me to this thread.
Well, I tried to use the updated util-linux from the above mentioned ppa by Ivan Larionov.
The fstab entries done by the gnome-disk-utility v 3.10.0 which comes with 14.04.2 are still causing problems at boot.
After some try and error I found that the entry in fstab needs to be "...comment=x-gvfs-show..." as opposed to "...x-gvfs-show..." entered by the gnome-disk-utility when "Show in user interface" is checked.

still having the problem with 14.04.3 64bit kernel 3.19.0-33. works fine with 15.10 wily kernel 3.19.0-18. also if it's time to move to 14.10 I think trusty should be updated being LTS.

Timo Ketola (2-timo) wrote :

It seems to be that this bug started to hit me too (14.04.4). USB drives are no more automatically mounted. When I insert a drive, I'm given a popup "Unable to mount ... Not authorized to perform operation". According to Disks, x-gvfs-show -option seems to be given to mount command and it doesn't accept it (tried from command line).

What I don't understand is, why this started to happen just now? I'm sure that automatic mount worked recently (unfortunately I can't remember exactly when it worked last).

Is there any workaround? Where does the x-gvfs-show -option come from in automatic mount process?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.