Mounted volume icons doubled up in launcher

Bug #1010858 reported by Rachel Greenham on 2012-06-09
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Andrea Azzarone
unity (Ubuntu)
Medium
Andrea Azzarone

Bug Description

As per screenshot (separate bug prevented grabbing just of relevant area), there are in fact only three mounted volumes; one's an internal hard drive (showing the hard drive icon), one's a blu-ray disc, one's a RAID volume (NOT showing the multi-disk icon it did in previous versions but that's a separate issue).

The problem of course is that they're all showing up twice.

They all seem to work. Nautilus sidebar doesn't show them doubled-up. Also, they're not doubled-up in unity-2d, although there's still the wrong RAID volume icon there.

There's no unity-launcher any more so I wasn't sure what exact package this relates to, hence putting against unity.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 5.12-0ubuntu3
ProcVersionSignature: Ubuntu 3.4.0-5.11-generic 3.4.0
Uname: Linux 3.4.0-5-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.1.1-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Sat Jun 9 12:24:49 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to quantal on 2012-06-09 (0 days ago)

Related branches

Omer Akram (om26er) wrote :

Unless there are steps to reproduce the problem, its relatively difficult to debug the issue. If it happens again and you find a way to reproduce the issue please let us know.

Changed in unity (Ubuntu):
status: New → Incomplete
Omer Akram (om26er) wrote :

Sorry I missed it. Is that a permanent issue. i.e. does it happen even after you log out/restart? or was it a one time issue.

Is the issue also happening in a guest session for you?

It is repeatable - ie: it persists over login sessions, over reboots
etc. Will try a login as guest, but machine is busy right now on a long
process... Wouldn't be surprised if clearing some saved state fixes it,
but would be good to know *which* state files to clear rather than
having to wipe everything.

--
Rachel

Forgot about being able to switch users for a little while there... :-)

Yes, it occurs when logged in as guest as well. As described before, mounted volumes show up twice, RAID volume doesn't have RAID icon, but what I think is an external-drive icon. (though the latter is probably a separate and less-important problem)

Also, the bluray disc i currently have mounted in my own user isn't showing up as guest; but *if* that's an issue I expect that's a separate issue.

Something to note:

The volumes I have that are showing up twice are mounted under /media but have entries in fstab - basically I want them to show up in launcher/nautilus but they're internal drives I want to have mounted automatically, and this was the only way I could make it happen. The two relevant lines in /etc/fstab are:

LABEL=Spinner /media/Spinner ext4 rw,nosuid,nodev,uhelper=udisks 0 0
/dev/md0 /media/Vault ext4 rw,nosuid,nodev,uhelper=udisks 0 0

This has been working fine for the last two or three versions of Ubuntu. :-) And works in Unity2D. And Nautilus sidebars, where each volume only shows up once. So it's a Unity (3D) bug and it's new. :-D

I also note that while the bluray disc (obviously not in fstab) showed up with two icons yesterday, it isn't doing so today, so it's less repeatable in that case. It's possible when it did do so yesterday, the disc was in the drive at boot time; whereas this time round it wasn't.

Also when I plug in a "new" external drive (ie: not already known about in fstab) it seems to only produce one icon, as you'd expect.

So the route to reproducing the bug may be to do as above: Have an internal drive you want mounted with udisks at boot time by putting lines in /etc/fstab with uhelper=udisks.

I would also be happy with an alternative way to have internal volumes mounted at boot automatically *and* working as icons in launcher etc. I can confirm, by the way, that they're not mounted twice.

Also, I just did a 'mount' and see that new volumes (the bluray, the external drive) show uhelper=udisks2 rather than uhelper=udisks. I shall try changing the lines in /etc/fstab to that, but that experiment has to wait while something else (that's working on those drives) finishes.

NB: gnome-disk-utility, aka "Disks" in dash, seems to offer a new proper way to do what I actually want it to do: have internal volumes mount automatically and show in launcher etc. It's not working the obvious way yet (bug #1011257 - x-gvfs-show doesn't seem to work) but using that tool to author lines in /etc/fstab similar to what I had before (but with uhelper=disks2) does work, but only as well as it worked before: I still get two of each icon.

I expect the "correct" fix for this, however, is to fix bug #1011257 and have x-gvfs-show mount option work properly. :-)

NB: I can confirm that having an optical disk in the drive at boot time does also repeatably produce two optical disk icons in the launcher.

Further finding: As reported in bug #1011257, the x-gvfs-show mount option that looks like being the correct way to implement this is failing because util-linux needs to be upgraded to 2.21+. However for older versions of util-linux the mount option "comment=gvfs-show" should work.

It works (I can mount) but from boot I still end up with two icons per volume in the unity (3d) launcher. So either way the automatic launching is done, it's still a unity bug that it shows each one twice. :-)

Omer Akram (om26er) on 2012-06-13
Changed in unity:
importance: Undecided → Medium
status: New → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1010858

tags: added: iso-testing
Omer Akram (om26er) wrote :

this bug and bug 1010714 seems to have the same root cause. the gvfs update did change something that unity is not sure about ;-)

madbiologist (me-again) wrote :

I am also seeing duplicate launcher icons for a USB flash drive if the computer is booted with the drive plugged in to the USB port, as well as duplicate icons for the Windows-only U3 system on the drive and it's associated setup assistant (6 icons instead of the expected 3).

Andrea Azzarone (azzar1) on 2012-07-17
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
milestone: none → 6.2
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package unity - 6.2.0-0ubuntu1

---------------
unity (6.2.0-0ubuntu1) quantal-proposed; urgency=low

  [ Adam Conrad ]
  * Removed debian/patches/libgeis-rename.patch

  [ Łukasz 'sil2100' Zemczak ]
  * debian/rules:
    - added override for dh_shlibdeps to point it to the private directory of
      libunity-protocol-private.so
  * debian/unity.lintian-overrides,
    debian/libunity-core-6.0-5.lintian-overrides:
    - added override to silence the binary-or-shlib-defines-rpath error, since
      we are forced to use RPATH in our case

  [ Didier Roche ]
  * New upstream release.
    - [nvidia] compiz crashed with SIGSEGV in
      nux::GraphicsEngine::QRP_GLSL_Color() from
      nux::GraphicsEngine::QRP_Color() from nux::BasePainter::PaintBackground
      (LP: #982626)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold. (LP: #839717)
    - running applications without an icon use a blank icon (LP: #886778)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - still some accent issues with unity/nux (LP: #950740)
    - Launcher doesn't autoscroll when holding an icon (can't reach trash)
      (LP: #987223)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - [GLES] framebuffer output scaled incorrect in both blur and items above
      shell with multimonitor (LP: #1016789)
    - [regression] [unity 6.0] Fullscreen windows flicker and/or never redraw
      properly if panel_opacity<1.0 or dash is opened. (LP: #1024911)
    - panel and launcher blinks when using libreoffice presenter/spreadsheet
      (LP: #1024459)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Update to 1.6.4 (LP: #1014850)
    - [nvidia] unity crashed in nux::GraphicsEngine::QRP_GLSL_1Tex
      (glDrawArrays) (LP: #1031554)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - Launcher, Dash - Showing dash, via super key, with a quicklist shown
      doesn't work (LP: #913994)
    - REGRESSION: can't type characters with accent (dead keys) (LP: #961741)
    - Launcher wrongly shows top tooltip when peforming the accordion effect
      (LP: #980942)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - logging out/in with mounted drives causes unity launcher icons to be
      duplicated (LP: #1010714)
    - Mounted volume icons doubled up in launcher (LP: #1010858)
    - Launcher - when a user starts dragging a item, the launcher icons that
      are *not* valid drop receptacles should be tinted (LP: #1020891)
    - Alt+F4 does not close the hud when Numlock or Capslock are on.
      (LP: #1022801)
    - Unity shortcut overlay needs to include shortcut for video lens
      (LP: #937334)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - give a way to remove 'Show Desktop' from the Alt-Tab items
      (LP: #1014346)
    - Multi...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released

Something interesting to notice if the partition has a label: both icons have different labels/appearance.

In launcher it appears:
* as "hard disk" icon and also
* as "generic filesystem" icon.

In nautilus windows it appears:
* as "hard disk" icon with its label and also
* as "generic filesystem" icon with its short UID 26A9-6E01.

How to reproduce : simple instructions in https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/1012081/comments/5

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers