x-gvfs-show option doesn't work

Bug #1011257 reported by Rachel Greenham on 2012-06-10
This bug report is a duplicate of:  Bug #1012081: util-linux needs updating to 2.24.2. Edit Remove
This bug affects 90 people
Affects Status Importance Assigned to Milestone
gnome-disk-utility (Ubuntu)

Bug Description

was reporting a separate bug #1010858 about double icons appearing for mounted filesystems, and it occurred to me that it was happening for volumes I had listed in /etc/fstab with uhelper=udisks, the mechanism i used in previous versions to mount internal drives and see them in launcher etc.

In investigating, I found the apparently-new gnome-disk-utility "Disks" and that seems to have new options for doing this properly, but when I tried to use them in closest-to-default way, it failed.

The attached screenshot shows the options I had set on a volume. Below is the line that generated in /etc/fstab:

LABEL=Spinner /mnt/Spinner auto nosuid,nodev,nofail,x-gvfs-show 0 0

It fails to mount when you try to mount it in the disk utility. An error dialogue opens with:

Error mounting system-managed device /dev/sdg1: Command-line `mount "/mnt/Spinner"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sdg1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

 (udisks-error-quark, 0)

dmesg | tail gives:

[ 619.470006] EXT4-fs (sdg1): Unrecognized mount option "x-gvfs-show" or missing value

I expect the bug isn't so much in the disk utility app itself as in the underlying mount tools that have probably been compiled without a required option, but the user experience is that it fails when using the disk utility, hence reporting it here for now.

I suspect I can make this work a different way using prior knowledge, to make it mount in /media and using uhelper=udisks2 - will be trying that in a moment - but this seemed the logical, minimal way to proceed for the new utility and it failed.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-disk-utility 3.5.1-0ubuntu3
ProcVersionSignature: Ubuntu 3.4.0-5.11-generic 3.4.0
Uname: Linux 3.4.0-5-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.1.1-0ubuntu2
Architecture: amd64
Date: Sun Jun 10 18:54:35 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
 PATH=(custom, user)
SourcePackage: gnome-disk-utility
UpgradeStatus: Upgraded to quantal on 2012-06-09 (1 days ago)

Additional note: "making it work a different way" half-worked. Using gnome-disk-utility to set mount options to generate the /etc/fstab line:

LABEL=Spinner /media/Spinner auto nosuid,nodev,nofail,uhelper=udisks2 0 0

did allow the drive to mount from the disk utility; but after reboot, I still got two icons for each volume mounted this way in the launcher, as per bug #1010858.

I suspect the "correct" way to fix this is to fix x-gvfs-show mount option though, as that seems a more natural and user-discoverable way to get the desired effect (internal volume mounted at boot showing up in launcher etc)

Further findings.

I think the reason why x-gvfs-show doesn't work is that package util-linux needs to be upgraded to 2.21+ to support the x-gvfs options.

In the meantime I tried changing the option in my /etc/fstab to "comment=gvfs-show", which seems to be the way to do it for older versions of util-linux. mount -a then worked immediately (I got one icon per volume) but after a reboot I still get two icons as per bug #1010858.

But as regards *this* bug, the real fault is that it's depending on a feature in util-linux-2.21+ and that package hasn't (yet, presumably) been updated yet.

dino99 (9d9) wrote :

i'm affecting too on Quantal i386

gnome-session[2673]: WARNING: Failed to start app: Unable to start application: L'exécution du processus fils « /usr/lib/gnome-disk-utility/gdu-notification-daemon » has failed

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-disk-utility (Ubuntu):
status: New → Confirmed
Tom Wright (twright-tdw) wrote :

This patch is most probably relevant to the issue:

A side issue here is that the current version of Disks seems to apply this option by default. I used the utility to persistently mount some favourite partitions, without touching the mount options, and consequently they would fail to mount in either Disks or via "sudo mount /mountpoint". If I edited the mount options in Disks to remove x-gvfs-show then they could be mounted.

If the underlying support is enabled then it may be reasonable to include this option (and I am running a beta after all), but otherwise, Disks is broken in that it's including an unsupported option in its default mount option string.

I'm running:
gnome-disk-uti 3.5.3-0ubunt
util-linux 2.20.1-5.1ub

J Phani Mahesh (phanimahesh) wrote :

I can confirm that the bug is unresolved in Quantal Release.

German Galkin (galkinga) wrote :

There is a bug #1012081 to update util-linux to the version supporting x-gvfs-* mount options, which seem to be the root of the problem.

Quantal shipped with "old" util-linux 2.20.1-5.1ubuntu2.

This bug is serious as it can render the system unbootable, see

Human user does not expect to make its system unbootable just by following graphical tools and "disabling automatic mount option" for a data partitions (without changing any other settings).

Furthermore, this scenario is likely to happen to other users that are tech-savvy enough (e.g. about partitions) but new to Linux. Their Ubuntu no longer boots, maybe days after they changed that option. Such bad scenario will make some users extremely disappointed by Ubuntu.

Waiting for util-linux to be upgraded may not be an option. Disabling "x-gvfs-show" in gnome-disks seems IMHO safer.

Xavier Guillot (valeryan-24) wrote :

I have the same problem in current alpha release of Ubuntu Raring 13.04, where util-linux is still at version 2.20.1-5.1ubuntu2.

when I try to connect an external hard disk eSATA with ext4 partition, it is recognized but can not be mounted and content is not accessible, I get the following error message :

Error mounting /dev/sdd1 at /media/valeryan24/Verbatim: Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdd1" "/media/valeryan24/Verbatim"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sdd1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

With USB key or external disk it works, not with this eSTATA one.

ouss (oussjarrouse) wrote :

I just spent 2 hours trying to figure out what i am doing wrong...
Ubuntu people... please update util-linux soon :-)

ouss (oussjarrouse) wrote :

Any news on the topic?

Bryce Harrington (bryce) on 2013-03-06
Changed in gnome-disk-utility (Ubuntu Raring):
milestone: none → ubuntu-13.04
Zach (zthornbury) wrote :

Issue still exists. Using Mint 15.

caleb (thinknot) wrote :

I'm experiencing the same problem on Ubunutu 13.04, util-linux 2.20.1-5.1ubuntu8, gnome-diskutility 3.6.1-1ubuntu1

Here's the relevant fstab lines. (all three were generated by the Disks utility):
# Windows is installed on sda1 (and sda3)
/dev/disk/by-partlabel/Win7 /mnt/Win7 auto nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=windows7 0 0
# these are the 2TB hard drives (usually sdb and sdc)
/dev/disk/by-partlabel/TB_ntfs /mnt/TB_ntfs auto nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=1TB%20-%20ntfs 0 0
/dev/disk/by-partlabel/TB_ext4 /mnt/TB_ext4 auto nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=1TB%20-%20ext4 0 0
What's interesting is that the ntfs partitions in the above lines mount just fine; the show up in Files browser, etc.
The ext4 partition does not mount, generating the dmesg:
EXT4-fs (sdc1): Unrecognized mount option "x-gvfs-show" or missing value

Brian Ealdwine (eode) wrote :

Issue still exists in raring.

Issue still exists in Saucy.

Issue still exists in Saucy.

Vyagudin (vyagudin) wrote :

Issue still exists in Saucy.

Butterfly (kelebek333) wrote :

Issue still exists in Saucy.

Lacyc3 (lacyc3) wrote :

Issue still exists in Trusty.

laulau (olaulau) wrote :

try comment=x-gvfs-show instead of comment=gvfs-show (instead of x-gvfs-show)

LordPhoenix (lorphoenix) wrote :

Get same problem on Saucy, trick on #22 comment is good but a such bug because of an too old version of a library is very regrettable.

dino99 (9d9) on 2014-03-11
tags: added: trusty

It renders essential features or functionality of the package (or a dependent one) broken.

Changed in gnome-disk-utility (Ubuntu):
importance: Undecided → High
Changed in gnome-disk-utility (Ubuntu Raring):
importance: Undecided → High
Butterfly (kelebek333) wrote :

Problem solved for me.
I use comment=x-gvfs-show instead of x-gvfs-show.
Thanks to laulau (olaulau) at #22 comment.

Andreas Kern (kerna) wrote :

unchecking the "Show in user interface" box removes the x-gvfs-show option.
can the box be unchecked per default?

Juankof (juankof) wrote :

Issue still exists in Trusty.

Martin Vogel (marvodor) wrote :

Andreas Kern’s post #26 solved the issue for me. After unchecking the option"Show in user interface" (in German: "In der Benutzerschnittstelle anzeigen") the volume was mounted without error.

AdlerHorst (adlerhorst) on 2014-08-02
tags: removed: quantal
tags: added: utopic
Ryan (1yan) wrote :

still having the problem with 14.04
post 22 solved it. Thanks

benoit (ben-auvray) wrote :

still having the problem with 14.04.2

Hartwig Kolbe (kolbeb) wrote :

still having the problem with 14.04.2 - and the circumvent of post 22 does not work in 14.04.2 64bit.

Hartwig Kolbe (kolbeb) wrote :

Mentioned in #1012081, there is a new version for util-linux available via a ppa.
I installed that new version: The entry in fstab created by gnome-disk-utility (v 3.10.0) when "Show in user interface" is checked, "x-gvfs-show" still causes problems at boot, but, now, adding "comment=" according to post 22 works.
The developers did not agree on the interface here.
So, it is only partially a duplicate of bug #1012081.

Cedric Bhihe (cedric-bhihe) wrote :

Issue still exists in Trusty 14.04.3
util-linux version: 2.20.1-5 1ubuntu20.7
gnome-disk-utility 3.10.0
3.16.0-49-generic #65~14.04.1-Ubuntu x86_64

UDisks is pretty useless because of that.

Three long years have passed since bug submission....

Alexander Sashnov (sashnov) wrote :

Workaround is to use comment=x-gvfs-show option instead (works well on Ubuntu 14.04)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers