Error formatting disk "Error synchronizing after initial wipe: Timed out waiting for object (udisks-error-quark, 0)"

Bug #1318954 reported by Amr Ibrahim on 2014-05-13
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
GNOME Disks
Confirmed
Medium
gnome-disk-utility (Debian)
New
Unknown
gnome-disk-utility (Ubuntu)
Low
Unassigned
udisks2 (Ubuntu)
Undecided
Unassigned
util-linux (Ubuntu)
Undecided
Unassigned

Bug Description

I get this error "Error synchronizing after initial wipe: Timed out waiting for object (udisks-error-quark, 0)" when I try to format a USB pendrive. See screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: gnome-disk-utility 3.10.0-1ubuntu3
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Tue May 13 10:34:46 2014
ExecutablePath: /usr/bin/gnome-disks
InstallationDate: Installed on 2014-04-20 (22 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: gnome-disk-utility
UpgradeStatus: No upgrade log present (probably fresh install)

Amr Ibrahim (amribrahim1987) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-disk-utility (Ubuntu):
importance: Undecided → Low
Changed in gnome-disk-utility:
importance: Unknown → Medium
status: Unknown → New
Changed in util-linux (Debian):
status: Unknown → Confirmed
Changed in gnome-disk-utility (Debian):
status: Unknown → New
Changed in util-linux (Debian):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-disk-utility (Ubuntu):
status: New → Confirmed
Changed in udisks2 (Ubuntu):
status: New → Confirmed
Changed in util-linux (Ubuntu):
status: New → Confirmed
Changed in gnome-disk-utility:
status: New → Confirmed
Yu Ning (yuningdodo) wrote :

The bug is marked as closed in debian with util-linux (2.20.1-5.8), I have made some tests with it on my trusty environment, the timed out issue is still reproduced with gnome-disks or usb-creator.

Yu Ning (yuningdodo) wrote :

If we ignore the timed out error in util-linux/src/udiskslinuxblock.c: handle_format():

  if (udisks_daemon_wait_for_object_sync (daemon,
                                          wait_for_filesystem,
                                          wait_data,
                                          NULL,
                                          15,
                                          &error) == NULL)
    {
#if 0
      g_prefix_error (&error, "Error synchronizing after initial wipe: ");
      if (invocation != NULL)
        g_dbus_method_invocation_take_error (invocation, error);
      else
        g_clear_error (&error);
      goto out;
#endif
    }

Then gnome-disks can format usb sticks correctly, and usb-creator also works with another patch:
https://code.launchpad.net/~yuningdodo/usb-creator/usb-creator.lp1300361-format-parent-device-to-erase-correctly/+merge/225799

affects: util-linux (Debian) → ubuntu
Changed in ubuntu:
importance: Unknown → Undecided
status: Fix Released → New
no longer affects: ubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.