(14.04) Unable to install external deb packages "Package operation Failed"

Bug #1290228 reported by psy444ops on 2014-03-10
242
This bug affects 51 people
Affects Status Importance Assigned to Milestone
Ubuntu Software Center
Fix Released
Undecided
Unassigned
software-center (Ubuntu)
Critical
Unassigned
Trusty
Critical
Unassigned

Bug Description

Attempting to install external .deb packages results in the error "Package operation Failed"

Screenshot attached.

A work around is manually installing the packages using "sudo dpkg -i package.deb"

---
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-03-01 (8 days ago)
InstallationMedia: Ubuntu-Server 13.10 "Saucy Salamander" - Release amd64 (20131016)
Package: gdm 3.10.0.1-0ubuntu3
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.13.0-16.36-generic 3.13.5
Tags: trusty third-party-packages
Uname: Linux 3.13.0-16-generic x86_64
UpgradeStatus: Upgraded to trusty on 2014-03-03 (6 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

psy444ops (psy444loops) wrote :

the screenshot of the window that display`s after every installation via "Ubuntu Software Center" is in attachement.

                                                                                                                                                                  Thank you

psy444ops (psy444loops) wrote :

when i click on Software Updater button, he check for an update then display the window saying "Failed to download repository" "Please check your internet connection", connection work`s fine, and when i click ok, he gives me possibility to download updates.

                                                                                                                         Ubuntu 14.04 LTS Trusty Tahr

p.s. - screenshot of the window is in attachement

                                                                                                                                                                     Thank you.

Tim Lunn (darkxst) wrote :

You are trying to install gdm? Assuming you have a good internet connection and that is not the issue, can you try 'sudo apt-get install gdm' and paste output

Changed in gdm (Ubuntu):
status: New → Incomplete
Tim Lunn (darkxst) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:

  apport-collect 1290228

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

psy444ops (psy444loops) wrote :

psy444ops@KatKitBot:~$ sudo apt-get install gdm
[sudo] password for psy444ops:
Reading package lists... Done
Building dependency tree
Reading state information... Done
gdm is already the newest version.
The following packages were automatically installed and are no longer required:
  lcdproc lcdproc-extra-drivers libftdi1 libg15daemon-client1 libg15render1
  libgtkhotkey1 libmikmod2 libmono-accessibility4.0-cil
  libmono-system-runtime-serialization-formatters-soap4.0-cil
  libmono-system-runtime4.0-cil libmono-system-web-applicationservices4.0-cil
  libmono-system-web-services4.0-cil libmono-system-web4.0-cil
  libmono-system-windows-forms4.0-cil libmono-web4.0-cil
  libmono-webbrowser4.0-cil libnunit2.6-cil libsdl-gfx1.2-4 libsdl-mixer1.2
  libsdl-net1.2 libsdl-ttf2.0-0 libsmpeg0 libtaoframework-opengl3.0-cil
  libtaoframework-sdl1.2-cil libxosd2 libzeitgeist0.8-cil
  linux-headers-3.13.0-14 linux-headers-3.13.0-14-generic
  linux-image-3.13.0-14-generic linux-image-extra-3.13.0-14-generic
  musescore-soundfont-gm pastebinit
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
psy444ops@KatKitBot:~$

Thank you

tags: added: apport-collected third-party-packages trusty
description: updated

apport information

gdm is not the problem, are you using any PPA's?

yes i use some

chrome
wine
webupd8team/java

ᘤ ᔣ ᖻ ᔰ ᔰ ᔰ Ꭴ ᘤ ᔣ *№⁴**⁴**⁴*

On Mon, Mar 10, 2014 at 9:58 AM, Tim <email address hidden> wrote:

> gdm is not the problem, are you using any PPA's?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1290228
>
> Title:
> "Ubuntu Software Center" reports "Package operation Failed"
>
> Status in “gdm” package in Ubuntu:
> Incomplete
>
> Bug description:
> after installation of program,"Ubuntu Software Center" reports
> "Package operation Failed" "The installation or removal of package
> failed', even when software is installed properly and he install`s
> always ok, but just keep displaying this window.
>
>
> Thank
> you...
> ---
> ApportVersion: 2.13.3-0ubuntu1
> Architecture: amd64
> CurrentDesktop: Unity
> DistroRelease: Ubuntu 14.04
> EcryptfsInUse: Yes
> InstallationDate: Installed on 2014-03-01 (8 days ago)
> InstallationMedia: Ubuntu-Server 13.10 "Saucy Salamander" - Release
> amd64 (20131016)
> Package: gdm 3.10.0.1-0ubuntu3
> PackageArchitecture: amd64
> ProcEnviron:
> TERM=xterm-256color
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 3.13.0-16.36-generic 3.13.5
> Tags: trusty third-party-packages
> Uname: Linux 3.13.0-16-generic x86_64
> UpgradeStatus: Upgraded to trusty on 2014-03-03 (6 days ago)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
> _MarkForUpload: True
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/1290228/+subscriptions
>

psy444ops (psy444loops) wrote :

Thank you

ᘤ ᔣ ᖻ ᔰ ᔰ ᔰ Ꭴ ᘤ ᔣ *№⁴**⁴**⁴*

On Mon, Mar 10, 2014 at 10:23 AM, psy444ops <email address hidden> wrote:

> yes i use some
>
> chrome
> wine
> webupd8team/java
>
> ᘤ ᔣ ᖻ ᔰ ᔰ ᔰ Ꭴ ᘤ ᔣ *№⁴**⁴**⁴*
>
>
> On Mon, Mar 10, 2014 at 9:58 AM, Tim <email address hidden> wrote:
>
>> gdm is not the problem, are you using any PPA's?
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1290228
>>
>> Title:
>> "Ubuntu Software Center" reports "Package operation Failed"
>>
>> Status in “gdm” package in Ubuntu:
>> Incomplete
>>
>> Bug description:
>> after installation of program,"Ubuntu Software Center" reports
>> "Package operation Failed" "The installation or removal of package
>> failed', even when software is installed properly and he install`s
>> always ok, but just keep displaying this window.
>>
>>
>> Thank
>> you...
>> ---
>> ApportVersion: 2.13.3-0ubuntu1
>> Architecture: amd64
>> CurrentDesktop: Unity
>> DistroRelease: Ubuntu 14.04
>> EcryptfsInUse: Yes
>> InstallationDate: Installed on 2014-03-01 (8 days ago)
>> InstallationMedia: Ubuntu-Server 13.10 "Saucy Salamander" - Release
>> amd64 (20131016)
>> Package: gdm 3.10.0.1-0ubuntu3
>> PackageArchitecture: amd64
>> ProcEnviron:
>> TERM=xterm-256color
>> PATH=(custom, no user)
>> XDG_RUNTIME_DIR=<set>
>> LANG=en_US.UTF-8
>> SHELL=/bin/bash
>> ProcVersionSignature: Ubuntu 3.13.0-16.36-generic 3.13.5
>> Tags: trusty third-party-packages
>> Uname: Linux 3.13.0-16-generic x86_64
>> UpgradeStatus: Upgraded to trusty on 2014-03-03 (6 days ago)
>> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>> _MarkForUpload: True
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/1290228/+subscriptions
>>
>
>

OK, marking as invalid, since there is no official support for PPA's, if you can reproduce the issue with all ppa's purged or a fresh install, please re-open this bug.

Changed in gdm (Ubuntu):
status: Incomplete → Invalid
psy444ops (psy444loops) wrote :

ok Thank you

 ᘤ ᔣ ᖻ ᔰ ᔰ ᔰ Ꭴ ᘤ ᔣ *№⁴**⁴**⁴*

IKT (ikt) wrote :

I'm also on 14.05 and this is definitely looking like a bug, I've had this happen multiple times now on packages I know are good.

I can easily skirt around the issue by using "sudo dpkg -i package.deb" but the USC should not be failing like this.

Removing GDM and moving to USC.

affects: gdm (Ubuntu) → software-center (Ubuntu)
Changed in software-center (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
IKT (ikt) wrote :

https://ikt.id.au/uploads/fail.png

Is a screenshot of the USC failing to reinstall a package which I was able to install using dpkg.

summary: - "Ubuntu Software Center" reports "Package operation Failed"
+ Unable to install external deb packages "Package operation Failed"
description: updated
summary: - Unable to install external deb packages "Package operation Failed"
+ (14.04) Unable to install external deb packages "Package operation
+ Failed"
FiremanEd (firemaned) wrote :

Recorded interesting results in the duplicate, Bug #1292099

Sundaravenkataraman (ssvr-nyl) wrote :

Me too affected by this same problem while upgrading Intel Graphics Drivers Utility [See attachment].

But this sorted out my issue [it seems] - sudo dpkg -i <packagename>.deb

sundaravenkataraman@sundaravenkataraman-laptop:~$ cd Downloads
sundaravenkataraman@sundaravenkataraman-laptop:~/Downloads$ ls *.deb
gnome-terminal_3.6.1-0ubuntu4.1_i386.deb intel-linux-graphics-installer_1.0.2-0intel1_i386.deb mmc_1.8.2_i386.deb teamviewer_linux.deb
gnome-terminal-data_3.6.1-0ubuntu4.1_all.deb intel-linux-graphics-installer_1.0.3_i386.deb mmc_1.8.4_i386.deb
google-talkplugin_current_i386.deb intel-linux-graphics-installer_1.0.4-0intel1_i386.deb seafile_2.0.4_i386.deb
insync_1.0.24_i386.deb jre_1.7.021-1_i386.deb seafile_2.1.1_i386.deb
sundaravenkataraman@sundaravenkataraman-laptop:~/Downloads$ sudo dpkg -i intel-linux-graphics-installer_1.0.4-0intel1_i386.deb
[sudo] password for sundaravenkataraman:
(Reading database ... 968455 files and directories currently installed.)
Preparing to unpack intel-linux-graphics-installer_1.0.4-0intel1_i386.deb ...
Unpacking intel-linux-graphics-installer (1.0.4-0intel1) over (1.0.3) ...
Setting up intel-linux-graphics-installer (1.0.4-0intel1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140310-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for mime-support (3.54ubuntu1) ...
sundaravenkataraman@sundaravenkataraman-laptop:~/Downloads$

Hoping this will be useful to you...

It severely affects packages beyond the one that causes the flaw.

description: updated
Changed in software-center (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
Changed in software-center:
status: New → Confirmed

This is definitely an issue and both of our installations of 14.04 are affected.
It does not matter where the deb comes from, downloaded from any ppa..the install error is given with the software center.
The only error in the logs is this: AptDaemon.Worker: WARNING: An additional step to open the cache is required

Ernie 07 (ernestboyd) wrote :

Software Center correctly installed the following programs when executed following the 64-bit 2014-03_11.iso Desktop Installation (3.13.0-16-generic #36-Ubuntu SMP Tue Mar 4 23:02:40 UTC 2014):

1. Ubuntu Restricted Extras
2. Google Chrome Debian install
3. GParted
4. VLC
5. Unetbootin

Software Center will hang if the first program installed is Ubuntu Restricted Extras. This bug manifests in every install after 2014-03_11 that I tested including the 2014-03_25 iso.

Software Center will fail with a Package operation failed error when a Google Chrome Debian install is attempted. After that an attempt to install Ubuntu Restricted Extras or GParted would fail with the same error. Note, if the first program installed was GParted rather than Google Chrome or Unbuntu Restricted Extras, the GParted installation would be successful.

Knowing the approximate date that the failure was introduced should help. Also, I am somewhat concerned that usability regression testing may not catch this because the problem manifests differently depending upon which program is installed first.

Finally, if I install from 2014-03-11 and then update to (3.13.0-19-generic #40-Ubuntu SMP Mon Mar 24 02:36:06 UTC 2014) the failures described above will occur.

Akshar Patel (akshar-patel-47) wrote :

I have tried to install spideroak, google chrome, dropbox and xmind from deb files downloaded from their respective sites. The USC could not install them giving "package operation failed" error message. I had to install them using terminal dpkg command.

SignedAdam (signedadam) wrote :

I am also having by this problem, this is effecting all users of the beta.

all users should right click on the ".deb" files, and then hover over "open with" then pick "GDebi Package Installer"

it takes less time to instal something than using the software center, my cpu is under hevery load using software center but "GDebi Package Installer" installer the package faster with less load, Ill be using this installer more offen,

Ernie 07 (ernestboyd) wrote :

This "Critical" but "Unassigned" bug continues to manifest as described in comment #19. I will add the first screenshot here.

Ernie 07 (ernestboyd) wrote :

Could not figure out how to add multiple screenshots, so here is another one.

Ernie 07 (ernestboyd) wrote :

Just a little addition for Comment #21

If you intend to use the Software Center to install "GDebi Package Installer", do it BEFORE attempting to install "Ubuntu Restricted Extras" via the Software Center. Once you enter the failed state associated with "Ubuntu Restricted Extras" installation, you are toast.

If you have spent any time in the windoze world, you would have created an image before trying to install something; restored the working image if/when the installation failed; and then experimented to find a work around. Being more robust, Linux does not warrant those extra steps when dealing with open source. However when dealing with proprietary software one must expect the occasional "vista" experience.

cariboo (cariboo) wrote :

The problem with installing the restricted extras, is that you may not see the windows where you have to agree to the license when installing the ttf-mscorefonts-installer.

Dmitry Polovka (messaged-t) wrote :

Same problem. Tried to install dropbox and chrome from packages - fails. Installed dropbox via terminal.

Dan Kegel (dank) wrote :

Bug 1304323 is a dup of this.

Vincent Gerris (vgerris) wrote :

I have the same issue with packages like dropbox, teamviewer and sublime.
It is not a license show problem, it that is what cariboo907 refers to, although it might have that issue too.
I did not encounter it.

Just want to emphasize that this is a very confusing bug for non-technical users, who will experience failure of software center.
It would be great if this can be fixed before release.

Kevin (wittyman37) wrote :

Vincent, I completely agree. The clock is ticking and the official release date is fast approaching. If Ubuntu is to be widely adopted, then basic things like installing from a .deb package with the software center need to work flawlessly 100% of the time.

At the very least, can we include in the error message the exact command needed to install through the commandline? For instance, I just had this problem when installing google-talkplugin. I should get a message that says something like "The Software Center could not install this for you. Try running `sudo dpkg -i ~/Downloads/google-talkplugin-current_amd64.deb` in a terminal." This would at least empower the users who are not deathly afraid of commandline interfaces.

Vincent Thiele (vincentthiele) wrote :

C'mon guys such a bug in a lts release?

Jaime Marques (jimmy93) wrote :

Kevin, asking the user to open the command line is not a solution.
this needs to be fixed right and fast before release, otherwise ppl will start complaning or even have a bad experience and just leave ubuntu.
i have no problem in using the command line and its annoying the hell of me imagine what would do to a not geek guy.

Vincent Gerris (vgerris) wrote :

I agree with Jaime. This should really be fixed before release, it will be giving bad press if it does not.
Users will hate Ubuntu for it and that is exactly what is not needed.
I just persuaded a lot of people to use it and they are quite happy, I would not like to tell them not to upgrade for a while.
The automatic updates for distribution upgrades are set to LTS release at least by default, so this might affect a lot of current users!
Canonical, please fix this!

On Apr 11, 2014, at 11:13 AM, Launchpad Bug Tracker wrote:

>dpkg: error: unable to read filedescriptor flags for <package status and
>progress file descriptor>: Bad file descriptor

In Python 3.4, file descriptors are not inherited by child processes by
default. You need to use os.set_inheritable().

https://docs.python.org/3/library/os.html#fd-inheritance

Looks like the newest aptdaemon (1.1.1-1ubuntu5) resolved this bug.

I didn't have any problem with installing two external packages using Software Center.

Deb-files now are installed. Seems like problem is fixed.

Michael Vogt (mvo) wrote :

The latest aptdaemon fixes the problem:

https://launchpad.net/ubuntu/+source/aptdaemon/1.1.1-1ubuntu5

Specifically the change:
  * debian/patches/py3_inheritable.patch:
    - set status-fds inheritable to fix InstallFiles()

Changed in software-center:
status: Confirmed → Fix Released
Changed in software-center (Ubuntu Trusty):
status: Triaged → Fix Released
volker kempter (v-kempter) wrote :

#36
 newest aptdaemon (1.1.1-1ubuntu5) does not fix the problem for me: could not install the newest kernel 3.15.0-1 automatically. Had to do sudo dpkg --install /path/package.debi.
Using lubuntu-14.04.

volker

To post a comment you must log in.