Ubuntu

[Upstream] Unable to shutdown / reboot / logout when quickstarter is active

Reported by freak007 on 2010-04-13
976
This bug affects 164 people
Affects Status Importance Assigned to Milestone
LibreOffice Productivity Suite
Fix Released
Medium
Baltix
Undecided
Unassigned
libreoffice (Debian)
Fix Released
Unknown
libreoffice (Ubuntu)
Medium
Björn Michaelsen
Lucid
Undecided
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

Ubuntu Lucid Lynx 10.04 AMD64 - Packages up-to-date (ooo 3.2.0-4-ubuntu3)

When quickstarter is active and when I open a ooo file, I'm unable to logout / shutdown.
If I manually close quickstarter, I can shutdown fine my computer.

This problem occurred on my all personal and professional computer, under 10.04 too.

If I don't open any ooo file during my session even with quickstart activated, I can also shutdown my computer.

Matjaž Kaše (matjazkase) wrote :

Same here. Exactly the same on three different machines.

Changed in openoffice.org (Ubuntu):
status: New → Confirmed
freak007 (freak-linux4freak) wrote :

There is no change with 3.2.0-7-ubuntu1

Del (delonly) wrote :

I can confirm this bug too. I have now tested it on two laptops. One eeepc 901 with 10.04 i386, and one Dell Inspiron 9400 with 10.04 AMD64. With the openoffice systray quickstarter enabled I cannot shutdown either of the machines from the gui (sudo halt works fine though). Both machines are up-to-date with the latest packages as of today. I suggest this bug is given top priority as it severely reduces the impression users get of Ubuntu.

pinzia (pinzia) wrote :

I have same problem with acer aspire 1680.

Fabio Marzocca (thesaltydog) wrote :

More on this: a non-experienced user is compelled to hard switch off the laptop, without a regular shutdown, as he is not used to open a terminal and type "sudo poweroff"...

VladimirCZ (vlabla) wrote :

Some people propose disabling the quick-starter feature, because it is not supported upstream on linux ...
BUT
this would bring longer start-up times and this would not be good news for users who open frequently lots of oo documents.
AN IDEA
Would not be a chance to implement some particular killing command for Restart / Shut down procedures?

Mahendra Tallur (mahen) wrote :

Well, this used to work properly, and OO.org is one of the most essential pieces of software in the Linux microcosm. It should definitely be fixed properly (but I understand we lack resources and cannot blame anyone).

(still happens in RC BTW)

Arnaud (arnaud-champollion) wrote :

I confirm it still happens on stable release.

tags: added: shutdown
tags: added: button openoffice.org quickstarter ui

I confirm it still happens on stable release.

I can also confirm this bug.

Me too. If you try to shutdown with the power button, or the poweroff applet, a window flashes during a couple of seconds saying that some openoffice program cannot be closed. Than it disappears and nothing happens.

Notice that the aforementioned windows used to appear in Karmic, too, but in that case after its disappearance the system was shut correctly down.

HTH

skruibis (slamstas-fastmail) wrote :

I have this problem on two laptops: Lenovo R50e and HP Compaq 6735b. The same story: system shutdowns or reboots only through terminal or if Open Office quick starter is disabled.

I definitely agree that this is a serious bug, as it affects a lot of users. Most people use Open Office and quick starter is an essential function when you want to access Open Office applications quickly. For unexperienced users the only one option is left, that is Powering Off a computer, which can damage the system. As it was noted earlier it can leave a very negative impression about Ubuntu.

Nathalie Oldenburg (oldnat) wrote :

I am not really sure if it is the same bug for it seems to be irrelevant of openoffice and happens to me even after uninstalling openoffice: the indicator applet shutdown option (or restart) does only restart x (without flashing up an office window mentioned above). And this happens not always, only 2/3 of the cases. In these cases only a terminal shutdown is an option, then the X-Login screen's "shutdown" buttons right lower corner also do not do nothing. As I asked elsewhere, can this be raletd to the HAL drop issue?

I found several different threads with this shutdown problem and am still searching, so I found this page which seems to handle the same (?) or similar (?) or brother (?) bug of my problem.

Thanks, Nathalie

For me it is completely reproducible. Maybe it's and HAL issue, but the fact is, if I exit from OO quicklauncher, then shutdown/logout works as expected.

Is there some dev here that can suggest a debug strategy? I mean, if the applet can't do what asked for, I suppose there will be an error message somewhere, or a way to run it in debug mode, or strace-ing it...

Chris Cheney (ccheney) wrote :

This appears to not be an openoffice.org specific problem so reassigning to linux, though it seems it might be plymouth or something else as I have seen bugs filed against various bits of the system for the same issue.

affects: openoffice.org (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → New
ricardisimo (ricardisimo) wrote :

Affected my system as well. Disabled systray quickstarter and now all is good.

I do like the quickstarter option... Any chance it will be copacetic in the weeks to come?

Jeremy Foshee (jeremyfoshee) wrote :

Hi freak007,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, please run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 562027

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Pete Nelson (mr-pete-nelson) wrote :

I can confirm - if oo.o quickstarter is running, none of the GUI logout (reboot, shutdown, etc) buttons will work. If I exit the quickstarter, the GUI logout buttons work again.

Regardless of the state of the oo.o quickstarter, if I run:

  gnome-session-save --logout

I log right out, no problem!

(What is the disadvantage of using "gnome-session-save"? Maybe I'll just make a "logout" launcher for that command as a work-around)

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Jeremy Foshee (jeremyfoshee) wrote :

changed package as this is not a kernel issue

affects: linux (Ubuntu) → openoffice.org (Ubuntu)
ajgreeny (ajg-charlbury) wrote :

I can also confirm this problem.
AMD Sempron 2400+, ATI 9200se graphic card, which does not like plymouth and will not display the plymouth image properly, 2GB ram.
If I have not used the OOo quickstart during the session, I can shutdown, reboot, or logout with no problem. Once I have used the quickstart, any attempt to do either of those three activities does absolutely nothing; the desktop stays and will not go anywhere. If I disable or shutdown the OOo quickstart the computer shutdown, reboot or logout is OK.

In ubuntu versions up tp 9.04 it was possible to edit the shutdown commands in System -Administration-Login Window, but that option has gone for 9.10 and 10.04, since the new version of GDM. Can the commands be edited in some other way to allow a shutdown of OOo quickstart at shutdown?

Chris Cheney (ccheney) on 2010-06-06
affects: openoffice.org (Ubuntu) → gnome-session (Ubuntu)
Sebastien Bacher (seb128) wrote :

Chris you know about the inhibit in gnome-session, do you think you could have a go to this one when you have a free slot?

Changed in gnome-session (Ubuntu):
importance: Undecided → Low
assignee: nobody → Chris Coulson (chrisccoulson)
assignee: Chris Coulson (chrisccoulson) → nobody
Changed in gnome-session (Ubuntu Lucid):
importance: Undecided → Low
assignee: nobody → Chris Coulson (chrisccoulson)
Chris Coulson (chrisccoulson) wrote :

This is actually an openoffice bug, as the quickstarter cancels the logout:

gnome-session[30945]: DEBUG(+): GsmXSMPClient: Client '0x16e1be0 [/usr/lib/openoffice/program/soffice 10e1827b246fac322127590469171257800000309450041]' received InteractRequest(Dialog)
gnome-session[30945]: DEBUG(+): GsmManager: Response from end session request: is-ok=0 do-last=0 cancel=0 reason=This program is blocking logout.
gnome-session[30945]: DEBUG(+): GsmInhibitor: setting client-id = /org/gnome/SessionManager/Client9
gnome-session[30945]: DEBUG(+): GsmStore: Adding object id /org/gnome/SessionManager/Inhibitor1 to store
gnome-session[30945]: DEBUG(+): GsmManager: Inhibitor added: /org/gnome/SessionManager/Inhibitor1
gnome-session[30945]: DEBUG(+): GsmXSMPClient: xsmp_interact ('0x16e1be0 [/usr/lib/openoffice/program/soffice 10e1827b246fac322127590469171257800000309450041]')
gnome-session[30945]: DEBUG(+): GsmDBusClient: obj_path=/org/gnome/SessionManager/Client1 interface=org.gnome.SessionManager.ClientPrivate method=EndSessionResponse
gnome-session[30945]: DEBUG(+): GsmDBusClient: got EndSessionResponse is-ok:1 reason=
gnome-session[30945]: DEBUG(+): GsmManager: Response from end session request: is-ok=1 do-last=0 cancel=0 reason=
gnome-session[30945]: DEBUG(+): GsmXsmpServer: sms_error_handler (0x16943f0, FALSE, 3, 9, 32771, 0)
gnome-session[30945]: DEBUG(+): GsmXsmpServer: sms_error_handler (0x1691700, FALSE, 3, c, 32771, 0)
gnome-session[30945]: DEBUG(+): GsmDBusClient: obj_path=/org/gnome/SessionManager/Client3 interface=org.gnome.SessionManager.ClientPrivate method=EndSessionResponse
gnome-session[30945]: DEBUG(+): GsmDBusClient: obj_path=/org/gnome/SessionManager/Client3 interface=org.gnome.SessionManager.ClientPrivate method=EndSessionResponse
gnome-session[30945]: DEBUG(+): GsmDBusClient: got EndSessionResponse is-ok:1 reason=
gnome-session[30945]: DEBUG(+): GsmManager: Response from end session request: is-ok=1 do-last=0 cancel=0 reason=
gnome-session[30945]: DEBUG(+): GsmXSMPClient: Client '0x16e1be0 [/usr/lib/openoffice/program/soffice 10e1827b246fac322127590469171257800000309450041]' received InteractDone(cancel_shutdown = True)
gnome-session[30945]: DEBUG(+): GsmManager: Response from end session request: is-ok=1 do-last=0 cancel=1 reason=
gnome-session[30945]: DEBUG(+): GsmManager: Cancelling the end of session
gnome-session[30945]: DEBUG(+): GsmStore: Unreffing object: 0x169b640
gnome-session[30945]: DEBUG(+): GsmStore: emitting removed for /org/gnome/SessionManager/Inhibitor1
gnome-session[30945]: DEBUG(+): GsmManager: Inhibitor removed: /org/gnome/SessionManager/Inhibitor1

affects: gnome-session (Ubuntu) → openoffice.org (Ubuntu)
Sebastien Bacher (seb128) wrote :

Ok, thanks Chris, assigning to the other Chris since that's an openoffice issue

Changed in openoffice.org (Ubuntu Lucid):
assignee: Chris Coulson (chrisccoulson) → Chris Cheney (ccheney)
Changed in openoffice.org (Ubuntu Lucid):
assignee: Chris Cheney (ccheney) → nobody
assignee: nobody → Chris Cheney (ccheney)

QuickStarter is disabled in the official upstream version of OOo probably due to bugs, but ooo-build appears to have thought they fixed it and turned it back on. Perhaps they were wrong. I have emailed the list to see if anyone else is seeing this same problem and what needs to be done about it.

Thanks,

Chris

summary: - openoffice: unable to shutdown / reboot / logout when quickstarter is
- active
+ [ooo-build] OOo QuickStarter: unable to shutdown / reboot / logout when
+ quickstarter is active
CarlosRuiz_globalqss (carg67) wrote :

Although this can be considered an openoffice bug - I think there is a problem also in the gnome-session manager as it's not informing the user about the program causing the problem - in my case the program silently fail, proper behavior must be to warn user about the program causing the problem.

Also I wonder if the shutdown in gnome-session is too weak (compared with shutdown for example).
Which signal is trying to send to the programs to shutdown? How much timeout is allowed before killing it?
I think shutdown from gnome-session must behave similar to shutdown from system. Am I wrong? [Sorry if I've missed some previous discussion about this]

I have the feeling that ubuntu is the linux distro more focused on usability and best user experience - so these kind of things must be sensitive, IMHO an underdeveloped program (any) must not stop a shutdown raised by user.

Regards,

Carlos Ruiz

On Mon, 2010-06-07 at 15:35 +0000, CarlosRuiz_globalqss wrote:
> Although this can be considered an openoffice bug - I think there is a
> problem also in the gnome-session manager as it's not informing the user
> about the program causing the problem - in my case the program silently
> fail, proper behavior must be to warn user about the program causing the
> problem.
>
> Also I wonder if the shutdown in gnome-session is too weak (compared with shutdown for example).
> Which signal is trying to send to the programs to shutdown? How much timeout is allowed before killing it?
> I think shutdown from gnome-session must behave similar to shutdown from system. Am I wrong? [Sorry if I've missed some previous discussion about this]
>
> I have the feeling that ubuntu is the linux distro more focused on
> usability and best user experience - so these kind of things must be
> sensitive, IMHO an underdeveloped program (any) must not stop a shutdown
> raised by user.
>
> Regards,
>
> Carlos Ruiz
>
It isn't a bug in gnome-session, and it is doing the right thing here.
gnome-session already has a mechanism for informing users about
applications that are blocking logout etc, but openoffice is
specifically telling gnome-session that it is going to interact with the
user (InteractRequest), and then immediately tells gnome-session that
the user cancelled the logout. As far as gnome-session is concerned,
openoffice put a dialog in front of the user and the user chose to not
log out.

...and effectively, sometime the oo windows asking me if I want to close the files *do* flash by. Strangely enough, given that it happens especially if I do not have open files to close. Then it disappears swiftly.

Jérôme (jerome-bouat) wrote :

I confirm this bug with:
- lucid i386 (32bits) from Ubuntu 10.4 LTS
- openoffice.org-core 1:3.2.0-7ubuntu4.1

Bal Tazar (bal3001) wrote :

Confirmed bug
Linux IBM THINKPAD T23 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 22:02:19 UTC 2010 i686 GNU/Linux
ooo-build 3.2.0-7ubuntu4.1, Thu jun 3 02:15:29 UTC 20

I thank the community for their time and skills.

I know this is not "a Lucid's bug", but ooo's,
fine, but I would like to stress that this bug importance should be one of highiest, not lowest,
because most of users will face it,
and may be incapable of finding a good solution,
and may damage their system by shutting it down forcefully,
as someone pointed out before.

Keep up the good work.

I confirm that I have experienced this issue even with Debian Squeeze

El 19/06/10 11:50, Bal Tazar escribió:
> Confirmed bug
> Linux IBM THINKPAD T23 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 22:02:19 UTC 2010 i686 GNU/Linux
> ooo-build 3.2.0-7ubuntu4.1, Thu jun 3 02:15:29 UTC 20
>
>
> I thank the community for their time and skills.
>
> I know this is not "a Lucid's bug", but ooo's,
> fine, but I would like to stress that this bug importance should be one of highiest, not lowest,
> because most of users will face it,
> and may be incapable of finding a good solution,
> and may damage their system by shutting it down forcefully,
> as someone pointed out before.
>
> Keep up the good work.
>
>

I confirm the same bug on 4 different computers.
Ubuntu 10.04, 64 bits, up to date.
Deactivating quickstart makes the first file much too long to open.
So I downgraded ubuntu 10.04 to 9.10 on 3 computers.
No problem with Ubuntu 9.10.
I check from time to time if bug is gone on the 4th computer, still using 10.04.
On june 20th, bug is still here.

I also tried installing the latest version of OOO -> same problem.

veribaka (veribaka) wrote :

I agree that this bug should be given a higher importance, and confirm it, on 5 different computers (Dell D630, E8500, IBM R40, R60, Asus Eeepc 1000).

ddumanis (dave-davedumanis) wrote :

Confirmed on Dell Studio 15. Highly related to production/productivity, and really annoying. Please fix.

Valthare (valt) wrote :

I do not agree that this is just an openoffice bug. I know OO is causing it - and I am sure the OO-debuggers are working on it - but this is totally besides the issue.

I am not talking for myself here - I have no issue with shutting down via command line or disabling ooqs first. But other people will do.

"Shutting down" a pc is a pretty fundamental thing. Everybody will expect this to work - even if nothing else does!

I know that the only sensible importance for this bug is "low". Unfortunately there are importance levels for reputational damage to the Ubuntu System overall. This is a serious design flaw - making the system look stupid.

The quick-starter is a widely used thing. It may be the first thing many people activate after an install. Then they can not shut down.

I noticed on several occasions that a message flashes up for a fraction of a second (in am on an always fully updated 10.04) - telling you what is causing the failure of shutdown - but it disappears instantly. You should always get feedback why the system is not shutting down - and ideally suggestions on how to should down anyway. It should happen in any case for any application that is causing the cancellation of a shutdown.

...unless you are happy with MS handling this way better.

chief_stealth (jon-l-cosby) wrote :

Valthare is right, this should be escalated. Basic functionality such as logging off/shutting down is just too important to be put aside.

Chris Coulson (chrisccoulson) wrote :

This only affects the quickstarter (which isn't enabled by default and is buried away in the preferences) - this is why the importance is low, and people have more important issues to work on right now.

And *IT IS* just an openoffice bug, despite what Valthare says. See my previous comment which explains that we already have the infrastructure for notifying users of an application blocking logout, but openoffice isn't doing that. It's asking the session manager if it can interact with the user, and then immediately telling the session manager that it interacted in some way and the response was that the user manually cancelled the logout.

The session manager is behaving correctly here in not displaying any dialog. It would be pretty annoying to have it pop up a dialog telling me there is a problem with some application, every time i cancel a log out when i've realised i have work to save

chief_stealth (jon-l-cosby) wrote :

It's also marked "low" on the OOo project. I'm running an old machine, and disabling the quick starter isn't really an option. It takes up to 10 seconds to open a document without it. Exiting qs each time might work, if I remember to do it. But this is more than an annoyance.

Tony Pursell (ajpursell) wrote :

This may be a bug in OOo but it has system wide effects. An everyday Ubuntu user with little Linux/Unix experience will not know how to close the system down cleanly through the command line. I only found out the truth of it by searching for this bug. Again not the thing we would expect the everyday Ubuntu user to do.

If we virtually ignore this, we risk the reputation of Ubuntu as a whole. It MUST be given a HIGH priority. Its importance cannot be written off as just and OOo bug. As John Donne wrote "No man is an island". Likewise, we cannot consider OOo isolated from the rest of Ubuntu. His verse ends "And therefore never send to know for whom the bell tolls; It tolls for thee." We cannot let a single program, OOo in this case, bring down the whole of Ubuntu.

skruibis (slamstas-fastmail) wrote :

I find it very odd that this bug is given a low priority. I'm a big fan of
Linux and I can live with it. However, I find it very uncomfortable to
answer someone's question "Would I feel any inconvenience if I switched
from Windows to Ubuntu?" No, you'll just need to exit manually
quickstarter each time when you want to shut-down... Or: No, it's ok, it's just
that every document will be loading 5 seconds or more.

Common, Open-Office is not just an application -- it's an essential tool
for most people. If its' working very slow, or if it's causing problems
for people to shutdown their computer, impression about Ubuntu remains
as "some interesting experiment" or "maybe after ten years it's worth
trying".

Mahendra Tallur (mahen) wrote :

Please excuse me for stating the obvious but the low priority is probably due to the lack of manpower / the need not to scatter the available resources too much.

On the other hand, when I install some Ubuntu machines for friends, associations etc. the first thing I usually do, after applying updates and adding some restricted packages, is to enable the OO.org quickstart (and disable java), as this is definitely one of the top 3 most used apps, which several seconds launch can be kind of irritating.

I guess, instead of complaining, we should just get more people vote for this bug...

Stephen Judge (stephenjudge) wrote :

What is the URL for this bug on the OOo bug tracker so I can vote for this bug there too?

Fabián Rodríguez (magicfab) wrote :

I've reproduced this on 4 different systems (32bit and 64bit), so confirming it and I am raising it to importance high because it fits these criteria, IMO:
# Has a severe impact on a small portion of Ubuntu users (estimated)
# Makes a default Ubuntu installation generally unusable for some users

I can see several possible problems caused by this bug that match the above criteria:
1- Data loss (when a user forcibly powers off the system as there is not alternative)
2- Privacy problems (when a user can't logout)

Workarounds:
1- Do not use QuickStart at all. The rationale for this is applications and documents open faster anyways the second time they are invoked, which is QuickStart's goal, which makes it redundant and possibly irrelevant.
2- Exit QuickStart each time before logout/restart/shutdown. Although inconvenient, this works.
3- Using CTRL-ALT-L to lock your screen instead of logging out. Other users can then enter a new session without your session being exposed or lost

As with every other bug report, unless you have constructive comments leading to resolve this or contribute significantly to it, please don't comment. Use the " Does this bug affect you ?" link at the top of this page instead of adding "me too", and subscribe to the bug as it's now confirmed, invite other people to do the same on your blog, microblog, etc. which may also help when the time comes to test any possible fix.

Changed in openoffice.org (Ubuntu Lucid):
status: New → Confirmed
importance: Low → High
Valthare (valt) wrote :

@Chris Coulson
This is not just a quickstarter problem. This is a fundamental design issue of the behaviour in Gnome.
1. The user requests a shutdown
2. The user is asked by Gnome - Are you sure about that?
3. User explicitly confirms that he is indeed
4. Nothing happens.

The importance is low - I already accepted that. (it is set to high in OO by now though)
"People have more important issues to work on right now" - this is totally besides the issue.
This is not a technical problem that would involve lots of coding or testing. It is a gnome design issue. To fix problems like this - at some point, gnome developers would have simply to agree on that - in a design meeting. However - by denying in the first place that this is a design problem at all - this will NEVER happen. Again - If the user initiates and confirms a shutdown - should ANY third party application be allowed to silently override that? - Anybody voting yes here? A simple fix could be to have this dialogue insisting on a password entry - if that is what we want it to do.

The quick start function is not buried away in the prefs of OO. Anybody using OO will be familiar with it. Keep in mind that this includes MS users!! If they try Ubuntu for the first time - have used OO in Windows - It will be the first thing they enable - even if they never used linux before in their life. And what a nice welcome they will get upon meeting a Gnome that simply wont shut down. I fact - one of the main reasons why I switched to Gnome was a fully working quick-starter. I am sure gnome developers would have an interest in winning over users from KDE - not loosing them.

"The session manager is behaving correctly here in not displaying any dialog" - What? This can only be meant politically - and I disagree 100% :)

" It would be pretty annoying to have it pop up a dialog telling me there is a problem with some application, every time i cancel a log out when i've realised i have work to save" - I am using computers since 1993 - I never ever had to cancel a shutdown because I realised in that moment there is still some work I need to save. In Windows or Linux. Besides - you do NOT have the option to cancel the shutdown - which is exactly what I am talking about here...

I will not touch the severity of the bug, but I agree with Chris that the problem is in OO. In the track he reported above in comment #23, it is quite clear that OO told the session manager the user cancelled the shutdown, so I think that the session manager should not re-ask the question. breaking all application that works well. The severity should be high on the OO bug, not on the session manager one.

On the other hand, there is another workaround not commented above: open a terminal an do a "shutdown -h now". Worked on my old Digital Ultrix in 1989, still works ok :-)

Fabián Rodríguez (magicfab) wrote :

Romano, I would advise against using that workaround as you're essentially bypassing the gnome-session and forcing a shutdown. The safer way to shutdown is to first disable QS, then do as usual.

The more I read about this the more I think QS should be completely removed, but that is an entirely different issue (and not one I am pursuing actively).

This bug seems to be one step towards that:
"OpenOffice quickstarted shouldn't have a notification icon"
https://bugs.edge.launchpad.net/ubuntu/+source/openoffice.org/+bug/230196

Actually, this bug is precisely what prevents me from upgrading to Lucid
Lynx.
I don't want to loose time when opening OpenOffice. And I want to be
able to shutdhown my computer.

It might be the same for other people.

--
Arnaud Champollion
110 route de Trévans
04270 ESTOUBLON

04.92.35.57.03
06.66.45.80.95

<email address hidden>

Documents pédagogiques libres pour la classe
http://libresdocs.ecole.free.fr

For whatever it's worth, the new OOo is FAST all by its lonesome. That's not to say that I don't want this bug given a bit more priority, but I personally am not finding QS to grant the user the speed advantages it used to provide. Just my 2¢. Anyone else concur?

JMFTheVCI (jmfthevci) wrote :

How big an impact this problem has related to how the Ubuntu user base is and how Linux/Unix experienced they are.
If Ubuntu is for the Linux/Unix savvy who know that they can open a terminal and "sudo shutdown" then fine we have a low impact.
If Ubuntu is pitched at all levels of user then, as has been discussed, the impact is much higher. Imagine the call for help "...I couldn't shutdown so I powered off and now I have lost files/filesystems...etc"

My issue with this is the *lack* of any messages. It may well be that Gnome is accepting the shutdown request and that OpenOffice is then cancelling the shutdown. The problem is that I never see any message from OO to tell me that it has cancelled the shutdown and why it cancelled it. Nothing happens and there is no explanation for why nothing happens.

Inexperienced or newbie Ubuntu users will just flounder and crash kill the system to power off. Not good and far too reminiscent of Microsoft. Ubuntu may be resillient against such harsh user actions but then what choice did they have?

I suspect that a large proportion of Ubuntu users, perhaps not a majority, are going to be annoyed by the lack of a simple and consistent shutdown request. As a seasoned, but by no means guru, ubuntu user I know how to fix it but my statement is that I should not *have* to fix it.

When I say shutdown I want it to do so or correctly tell me why it has not happened. Then tell me how to fix it.

chief_stealth (jon-l-cosby) wrote :

Interestingly, having disabled OOo quick starter, I was able to log out, as expected. Having enabled it again, there's no longer a problem. Has anyone else found this?

chief_stealth: have you opened any OO document before testing shutdown? If you have the quick starter enabled, but you do not use it, there's no problem.

I can see a OO dialog flashing by, when shutdown fails. It's something about some file not correctly closed. Is there any utility that I can use to catch it?

chief_stealth (jon-l-cosby) wrote :

Maybe I hadn't opened an OOo document, it's now back to the old behavior.

PseHouri (psehouri) wrote :

This bug really impacts us : 80 PC waiting to upgrade to Lucid because of this problem... Really, I can not connect to ssh to every user to do an init 0 !!!

Same problem for me. I confirm that if no file have been opened with oOo there is no problem.
I am sure I have seen somewhere a message telling that shutdown has been cancelled because some files are still opened but I don't remember where. Is there any log file for the graphical console, where can we found messages about files that are started using the graphical environement ?
Thanks for your help!

Graham Ranger (graham-ranger) wrote :

In response to Stephane T, when you run "killall soffice.bin", that knocks out the quickstarter. This could be tied up to the system shutdown button with something like "killall soffice.bin && shutdown -P", but it's an openoffice specific hack, and, from what I've read, the user cannot, in any case, access the command invoked by the shutdown button, which is hardcoded in gnome somewhere!

Graham, thanks for your detailled answer. However I am sure I have "found" myself that the problem was coming from oOo before I read this bug report, when I read some messages from the system. I was very happy with this but don't remember where I could have read this message!!!
My last question would be : when I shutdown (using a sudo shutdown...) I am back on a black screen with some messages on it. This stays only a couple of seconds and it's difficult to read all of it. Is there any way to access these messages before the shutdown happen ? (I have read on ubuntu-fr that there is a special console usgin Ctrl+Alt+F8 but this doesn't work for me...)
Thanks, Stephane.

Graham Ranger (graham-ranger) wrote :

I suspect this is probably more a question for a forum than a bug report! In any case, I'm no expert, but I think you ought to be able to find this sort of message archived in syslog, i.e. /var/log/syslog which you can access with gedit or cat /var/log/syslog or, if you want to log just for errors, with sudo cat /var/log/syslog* | grep EE for example.
Hope that helps! (As for the special consoles, you might be thinking of changing run levels, normally with ctrl+alt+F2 or F3-F6. Can't see much on ctrl+alt+f8!)

I confirm that this bug takes effect even when no OO documents have been opened other than a blank one to tweak the memory settings.
Two fresh installs of Lucid - one Desktop and one Netbook Remix.
Enable Quickstarter - Shutdown/Restart menu options give the splash screen - "Are you sure you want to etc etc..." and then nothing happens.
Disable quickstart, everything's back to normal.

It happens exactly the same on Debian Squeeze.

--
Arnaud Champollion
110 route de Trévans
04270 ESTOUBLON

04.92.25.57.03
06.66.45.80.95

<email address hidden>

_____________________________________________

Documents pédagogiques libres pour la classe
http://libresdocs.ecole.free.fr
_____________________________________________

I experience this problem as well.

OpenOffice 3.2
Ubuntu 10.04

Mads E (g00n1975) wrote :

I confirm this bug on a fresh 10.04 install. Really had me confused. Shut down -> login screen. Tried again, and again...Finally did a search, and to my amusement, a lot of other ppl have this problem.

John Rose (johnaaronrose) wrote :

I suggest that OO3.2.1 be put on Ubuntu Lucid repositories.

Chris Cheney (ccheney) on 2010-08-23
Changed in openoffice.org (Ubuntu Lucid):
assignee: Chris Cheney (ccheney) → nobody
dho (ipulpeaceridho) wrote :

sorry i'm a newbie, i wanna ask how to disable quickstarter????
i'm really frustrated cause of this, i'm using Dell Vostro 1088

@dho -
Open any module of Open Office, do Tools-Options and in the Openoffice.org section, under Memory, uncheck the quickstarter option.

panticz.de (panticz.de) wrote :

Hi, here a quick fix for this problem:
sed -i '5s|true|false|g' /usr/lib/openoffice/basis3.*/share/registry/data/org/openoffice/Office/Recovery.xcu

You can see more details here:
http://www.panticz.de/Fix-OpenOffice-Quickstarter-logout-bug

i disabled the quickstarter and don't regret it
when OOo has been started one time, linux caches it anyway and it will open fast again - without the quickstarter

Chewable (chewable) wrote :

Ubuntu may not shutdown when OpenOffice Quickstarter is active, but there is more to this than just quickstarter because, on my system, the openoffice quickstarter was never checked and my system continues to not shutdown properly.

oblong (bob-oblong) wrote :

I can confirm that the fix from panticz.de (#67) seems to work for me (although I did the edit manually). (Maverick 10.10, 2.6.35-22-generic, upgraded from 10.4, OOo: OOO320m19 (Build:9505) ooo-build 3.2.1.4, Ubuntu package 1:3.2.1-7ubuntu1)

However, as the fix changes the value to false in:

<node oor:name="SessionShutdown">
  <prop oor:name="DocumentStoreUIEnabled" oor:type="xs:boolean">
   <value>false</value>
  </prop>
 </node>

what are any other effects of disabling "DocumentStoreUIEnabled"?

The fix of panticz.de works for me

-Maverick Linux 2.6.35-22-generic (i686)- OOO320m19 (Build:9505)
ooo-build 3.2.1.4, Ubuntu package 1:3.2.1-7ubuntu1

but please panticz explain which are the side effect of this command. What does it happen to change that value to false?

Thanks

mohican (mohican) wrote :

I confirm also the bug in both Lucid and Maverick

description: updated
greymate (helmut-gildein) wrote :

Can confirm this also in Lucid. As soon as the quickstarter is running, neither logout nor shutdown is working. Even without opening any document. This should be set to higher importance.

NoOp (glgxg) wrote :

Perhaps one of the OOo dev/maintainers can look at the code in LibreOffice. This problem is fixed in:
LibreOffice 3.3.0
OOO330m12 (Build:2)
libreoffice-build 3.2.99.3

Valthare (valt) wrote :

Thanks Panticz for the solution. I do not care about any side effects in the recovery functionality ( if there are any )
Of course you have to sudo this command though.
sudo sed -i '5s|true|false|g' /usr/lib/openoffice/basis3.*/share/registry/data/org/openoffice/Office/Recovery.xcu

That is good enough for me - as far as I am concerned this bug can be closed now. Any votes?

@Florian Schröck - your comment:
"i disabled the quickstarter and don't regret it
when OOo has been started one time, linux caches it anyway and it will open fast again - without the quickstarter"

...If that is not a problem to you - than why are you here? To me - disabling something I liked using for many years is not an option. It only starts starting faster the second time IF the memory is not used in the meantime by something else. Go play quake wars - quit - and start office again - and you are back to square one.
I like the one-click-insta-popup of all office apps. You do realize you only have to click once to pick and start any office app in the quickstarter? Well - I like that very much.... - Thanks again to Panticz....

Valthare (valt) wrote :

ps - Panticz's fix works in Lucid AND Maverick

Jeff (jdorenbush) wrote :

Panticz's fix worked for me. I had to reboot before the changes worked.

Valthare (valt) wrote :

@Jeff - this is just an openoffice config file for office. A reboot should not be required. But you should quit all office apps including the quickstarter. (re-enable it in office after the fix)

Nina Marwede (lynax) wrote :

For me, Panticz's fix does not work.
Using OOo 3.2.1 from Lucid-proposed.
I edited /usr/lib/.../Recovery.xcu to "false", and deleted ~/.../Recovery.xcu, then rebooted.
Still can't logout when quickstart is active and some document has been opened.

I'd be very happy to see an official solution since I installed Lucid a dozen times on my friend's and family's computers...

The problem doesn't seem to occur on Xubuntu though.

Dragonfly (mailboxcb-ubuntu) wrote :

So like this, I have the same trouble on:

Ubuntu 10.10
Linux 2.6.35-23-generic-pae
Gnome 2.32.0

With:

OpenOffice.org 3.2.1
OOO320m19 (Build:9505)
ooo-build 3.2.1.4, Ubuntu package 1:3.2.1-7ubuntu1

Robert Roth (evfool) wrote :

Please use the "Does this affect you?" link for confirming that this issue affects you. The link for this can be found at the top of the page, between the bug title and the packages affected. Thank you!

Valthare (valt) wrote :

@Nina Marwede and @Dragonfly - It is unlikely that the fix only works for some. It is more likely that the right file was not changed.
Open a terminal and do
locate Recovery
(note above command is case sensitive - so it is Recovery not recovery)
It should spit out something like this
---------------------
/home/smartass/.openoffice.org/3/user/registry/cache/org.openoffice.Office.Recovery.dat
/home/smartass/.openoffice.org/3/user/registry/data/org/openoffice/Office/Recovery.xcu
/usr/lib/openoffice/basis3.2/share/registry/data/org/openoffice/Office/Recovery.xcu
/usr/lib/openoffice/basis3.2/share/registry/schema/org/openoffice/Office/Recovery.xcs
---------------------
If you do not like the "sed-stuff" you can do following
the file in the 3rd line above needs to be modified (in share/registry) - select it with the mouse and rightclick and copy the selection
press alt-F2 to open the run dialog
type
gksu gedit (not the space after gedit and paste the full path here)
The whole line will then look like this:
gksu gedit /usr/lib/openoffice/basis3.2/share/registry/data/org/openoffice/Office/Recovery.xcu
It is a small file - only 17 lines - make sure it says false in both lines which so it looks like this
<value>false</value>
then safe and exit.
Please make sure to exit all office apps before you do it. Also quit the quickstarter itself before you do it.
Start an office application - re-enable the quickstarter. (you will have to go into options twice for that since there is no apply button)
Let us know if that still does not work for you. If it does not please send us the output of following command (run inside a terminal)
cat /usr/lib/openoffice/basis3.2/share/registry/data/org/openoffice/Office/Recovery.xcu

Nina Marwede (lynax) wrote :

@Valthare: Thanks for the explanation.
I confirm that I edited the file as you said. After that didn't work with OOo 3.2.0 I installed 3.2.1 from lucid-proposed. Then the Recovery file was reset to value "true", so I edited it again to "false". I also rebooted several times since. See attachment for my file.
I also removed the Recovery file in /home/nina/.openoffice.org/... but it is re-created soon.

Valthare (valt) wrote :

@Nina Marwede - Are you using gnome or kde? - I was assuming gnome... - which is what I am using.
If it's KDE I am bailing out of the trouble-shooting here. If it is gnome -
I have no longer lucid on any of my machines - but if it is gnome I create one in virtual box and try to re-create the problem. Over the WE.

To exclude the possibility of a config file in your home directory causing the problem - create a test user on your system
system/administration/users and groups
A test account is always handy to have to test things like that...
I suggest you log out as you and log on as the test user - rather then doing a parallel session.
Enable the quick starter for the test user. Create and save a test office doc. Close office app. Can you shut down then?
If the test user does not have the problem - we know it's a setting or file in your home dir.

Valthare (valt) wrote :

ps - first thing as test user run in a terminal following command
cat /usr/lib/openoffice/basis3.2/share/registry/data/org/openoffice/Office/Recovery.xcu

...to check the 2 "false" entries

Nina Marwede (lynax) wrote :

@Valthare: Good idea, thanks. I'm using Gnome, default Ubuntu installation, but continued to use my old home folder from Jaunty when installing Lucid. (Tried Maverick first, but it doesn't like my TV card - /dev/dsp missing.)

With a new user account, I cannot reproduce the problem! So you are right, it has to be something within my home dir, and I began to dig deeper... When comparing the structures, I see many differences, of course. Looking at the Recovery file, it's interesting that the "RecoveryInfo" block contains a "true" while in the global config we explicitly set it to "false". So I tried to replace only this file with the one from the new profile -- no success. Now I moved my old profile to a backup folder, copied it partly back to a fresh one... and while browsing with KDiff3, the scales fell from my eyes:

In addition to Panticz' fix, I had to clear the "/home/nina/.openoffice.org/3/user/registry/cache" folder -- now it works for me! :-)

(I already submitted a comment to his article.)

Valthare (valt) wrote :

@Nina Marwede - great stuff... :)

Dragonfly (mailboxcb-ubuntu) wrote :

@Valthare,

Hi Valthare and thanks for your explanations and your time. I want to give you my point of view. On Launchpad, I want just to confirm or signal some discover bug and I wait for the up date. This is a minor bug not essential and I don't want to loose my time for this "widget" I have a lot interest point and I'm not a student and I have no time for do that... I do just the minimum for to bring my contribution to the Ubuntu community.
So, thanks again and I hope you understand me (I don't speak English very well '-)).

Commoner (commoner51) wrote :

Panticz' fix worked also for me. In addition I had to clear the folder .openoffice.org/3/user/registry/cache and reboot.

rod singleton (rod40cool) wrote :

Thanks Valthare at #82. It took me a while to figure out why my 10.10 x64 suddenly stopped shutting down till I figured out that I'd recently enabled the quickstarter and promptly went googling and found this which has fixed it for me too.

Changed in openoffice.org (Ubuntu Lucid):
status: Confirmed → In Progress

I use LibreOffice 3.3.0 release and Ubuntu 10.10 (kernel 2.6.35-25).
When I enable the option of quickstart (in Memory preferences) the reboot and shutdown options in my OS not work.

Assigning to Bjoern, assuming this is Ubuntu-specific.

epictete (p-latreyte) wrote :

The fix/workaround suggested in https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/562027/comments/67 doesn't work if you've replaced OpenOffice with LibreOffice 3.3.1.

The path :
/usr/lib/openoffice/basis3.*/share/registry/data/org/openoffice/Office/Recovery.xcu
is no longer valid:
/usr/lib/libreoffice/basis3.3/share/registry/ >>> no data folder here.

And a search for Recovery.xcu in the filesystem brings nothing.

ToniTC (lunatc) wrote :

@epictete

The key location has changed:

It is now in the file

 /usr/lib/libreoffice/basis3.3/share/registry/main.xcd

search in the very long first line the key "DocumentStoreUIEnabled"
and change it to false

epictete (p-latreyte) wrote :

Thank you very much ToniTC!

It works perfectly!
For some reason, it was impossible to edit or even to move the cursor in the first line of the file using Gedit.
So I had to edit it with Nano.

You ask a question; a few hours later, you've got the answer; that's incredible…

tags: added: lo33

I have the same problem. OS : Ubuntu 10.10 and LibreOffice 3.3.2 (official version non-ubuntu).

Confirmed running LO 3.3.2 and Ubuntu 11.04 Beta 1. I believe this same bug exists with OOo as well.

Changing things as suggested in post # 93 had a nasty side effect in my computer: when I select "shutdown" or "reboot" it starts the shutdown/restart process and freezes in an ugly red screen... I don't know how LibreOffice can be interfering in this way, but if I set "DocumentStoreUIEnabled" back to "true", the problem disappears.

Sorry, it seems the nasty red screen is related to something else, so please disregard my previous comment.

I'm experiencing this on ubuntu 11.04 natty 32bit 2.6.38-8-generic on Libreoffice-3.3.2.2 (Ubuntu package 1:3.3.2-1ubuntu4) and will disable quickstarter in the meantime.

*** Bug 36654 has been marked as a duplicate of this bug. ***

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
Changed in openoffice.org (Ubuntu Lucid):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Changed in openoffice.org (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Changed in libreoffice (Ubuntu Lucid):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)

It's not just pure Ubuntu, the problem happens in Debian too.
(I'm currently on Debian unstable, LibreOffice 1:3.3.3-4+b1, but the problem has been there for months now, and happened under OpenOffice.org)

An additional point of reference: the problem happens when trying to shutdown using the Gnome GUI dialog. From the command line ("shutdown -h now"), shutdown works fine. The problem is only with the Gnome graphical mechanism, not shutdown in general (I haven't tried KDE or other desktop environments).

crtm (carlosrtm) wrote :

I confirm the bug on ubuntu 11.04 natty 64bit 2.6.38-10-generic on Libreoffice-3.3.3. and disable quickstarter in the meantime.

Changed in libreoffice (Debian):
status: Unknown → Confirmed
Changed in df-libreoffice:
importance: Unknown → Critical
status: Unknown → Confirmed
Changed in libreoffice (Ubuntu Lucid):
status: New → Confirmed
Changed in libreoffice (Ubuntu):
status: New → Confirmed

WORKAROUND: Close quickstarter before shutdown.

summary: - [ooo-build] OOo QuickStarter: unable to shutdown / reboot / logout when
- quickstarter is active
+ [Upstream] [ooo-build] QuickStarter: unable to shutdown / reboot /
+ logout when quickstarter is active
Changed in df-libreoffice:
importance: Critical → Low
Changed in openoffice.org (Ubuntu):
status: Confirmed → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

Also affects Libreoffice

I am using "LibreOffice 3.3.3, OOO330m19 (Build:301), tag libreoffice-3.3.3.1, Ubuntu package 1:3.3.3-1ubuntu2, and when the systarter is enabled it's the same result as existed in OpenOffice.

i.e. "When quickstarter is active and a libre office file is opened I'm unable to logout / shutdown, and if one manually closes quickstarter, shutdown works fine.

Ref 'upstream OpenOffice.org bugs in place to allow cross pollination'

Changed in libreoffice (Debian):
status: Confirmed → New
Changed in openoffice.org (Ubuntu Lucid):
status: In Progress → Won't Fix

*** Bug 40836 has been marked as a duplicate of this bug. ***

Vorona (erikmartre) wrote :

This bug is still present on my acer aspire 7740G in spite of the last upgrade to 11.10 (Oneiric 64 bits) ; as soon as libreoffice has been launched once, 3 processes related to this application are present (waiting) ; I can shutdown the system through the GUI only if I kill the most recent of those processes which runs soffice.bin.

I applied the patch proposed by panticz.de (modified by ToniTC for libreoffice), but I had to change manually the value of DocumentStoreUIEnabled, probably because the long line in which it appears is not the 5th one any longer. The sleeping processes are still present, but now I can shutdown my machine normally.

In brief, the bug is still here but the workaround works ! Thanks.

I have the exact same problem on Ubuntu 11.10 64bit. In Gnome shell, classic, unity, and unity 2d I cannot log out, shutdown, etc. while the quicktray starter is on.
Only when I shut it off can I log out, etc.
Also, in Unity-2d (and I think gnome classic, i can't remember) an error message would come up when trying to open libreoffice from a shortcut while the quickstarter is on, that multiple processes of libreoffice are active.

I use Kernel 3.0.0-13 on Ubuntu and Libreoffice 3.4.4
The problem was there on version 3.4.3 as well.

JC (nothingness) wrote :

Ubuntu 11.10 64bit Libreoffice 3.4.4
I also have the bug.

John C, please do not toggle the Version field. For more on this please see: http://wiki.documentfoundation.org/BugReport_Details#Version

I see. Sorry about that.

Making this an EasyHack with interesting difficulty:
Code pointers:
http://opengrok.libreoffice.org/xref/core/vcl/unx/generic/app/sm.cxx handles the Unix Session management
http://opengrok.libreoffice.org/xref/core/sfx2/source/appl/shutdowniconunx.cxx is the quickstarter

The quickstarter vetos each and every request to kill the instance, but we want it to do that only when it is not the session manager that wants to kill the instance.

I will mentor this one, so ping me, if you have questions.

Changed in df-libreoffice:
importance: Low → Medium

I could work around the problem as I mentioned before, but a recent update swept my work away. I'm gonna try to make it again...

Vorona (erikmartre) wrote :

OK, if you have the same problem, then look for message #93 by ToniC (and the previous one which it completes from panticz.de, or go to http://www.panticz.de/Fix-OpenOffice-Quickstarter-logout-bug ) and replace basis3.3 by the real directory on your machine. On mine it is basis3.4. It should work. If not for me, I'll be back soon to claim for another solution !

Vorona (erikmartre) wrote :

Well, changing the value of DocumentStoretUIEnabled to "false" is very difficult with a classic text editor - how could I make it last time, I don't know ; I think I will wait for a patch...

Fabián Rodríguez (magicfab) wrote :

Workaround:
- Do not enable Quickstarter
- Install the "preload" package:
 "preload monitors applications that users run, and by analyzing this data, predicts what applications users might run, and fetches those binaries and their dependencies into memory for faster startup times."

panticz.de (panticz.de) wrote :

LibreOffice should work afther this command:
sudo sed -i 's|<prop oor:name="DocumentStoreUIEnabled" oor:type="xs:boolean"><value>true|<prop oor:name="DocumentStoreUIEnabled" oor:type="xs:boolean"><value>false|g' /usr/lib/libreoffice/basis*/share/registry/main.xcd

else here a script with fix OpenOffice and LibreOffice:
wget http://www.panticz.de/sites/default/files/scripts/set.DocumentStoreUIEnabled.false.sh -O - | bash -

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

An EasyHack should have been checked by developers and thus is confirmed regardless of age. Moving back to NEW from NEEDINFO again. Sorry for the hassle.

roberto (roberss) wrote :

the error persists in the latest version 3.4.5 rc1 LibreOffice in Ubuntu 11.10, installed via the official ppa LibreOffice

roberto (roberss) wrote :

the problem seems solved by the script mentioned by panticz.de (panticz.de)

JC (nothingness) wrote :

Yep, the script above does indeed work.
Ubuntu 11.10 64bit Libreoffice 3.4.5

roberto (roberss) wrote :

but I still think that the error should be corrected by implementing the script, LibreOffice code because it is a mistake that affects a lot of people

JC (nothingness) wrote :

I have this problem on OpenSUSE 12.1 as well. However, the above script does not work.

no longer affects: openoffice.org (Ubuntu Lucid)
tags: removed: button openoffice.org quickstarter shutdown ui
summary: - [Upstream] [ooo-build] QuickStarter: unable to shutdown / reboot /
- logout when quickstarter is active
+ [Upstream] Unable to shutdown / reboot / logout when quickstarter is
+ active
Changed in openoffice.org (Ubuntu):
assignee: Björn Michaelsen (bjoern-michaelsen) → nobody
Vorona (erikmartre) wrote :

Thanks ++ for panticz.de !! I couldn't apply the script before, I just did it and it worked fine
(Ubuntu 11.10, LibreOffice 3.4.4).

Nina Marwede (lynax) wrote :

Although panticz' workaround does work for most people, I like to remember that (as far as I understand) this is not a real fix to the problem, because what it does is to prevent showing the dialog to save a document, so a user might lose data that hasn't been saved yet.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Committed
Changed in df-libreoffice:
status: Confirmed → Fix Released
Changed in libreoffice (openSUSE):
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in libreoffice (Ubuntu Lucid):
assignee: Björn Michaelsen (bjoern-michaelsen) → nobody
Changed in libreoffice (Ubuntu):
milestone: none → ubuntu-12.04
David Ames (thedac) on 2012-02-28
no longer affects: libreoffice (openSUSE)
Changed in libreoffice (Debian):
status: New → Confirmed
Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
Changed in libreoffice (Debian):
status: Confirmed → Fix Released
Mantas Kriaučiūnas (mantas) wrote :

Is this bug fixed in Ubuntu Lucid and Natty versions (3.5.2 and 3.5.1) of LibreOffice backports from this PPA: https://launchpad.net/~libreoffice/+archive ?

jpxsat (jpxsat) wrote :

My Ubuntu Lucid is working fine with 3.5.4
Still getting a dialog from libreoffice when shutting-down, but it does shutt-down now

JC (nothingness) wrote :

Ubuntu 12.04 shows a dialog when logging out/shutting down with the quickstarter enabled. This did not happen in 11.10

Changed in libreoffice (Ubuntu Lucid):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.