Ubuntu

Networking is disabled on boot (usually after suspend/hibernate)

Reported by David Siegel on 2010-02-19
810
This bug affects 212 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
High
network-manager (Debian)
Fix Released
Unknown
network-manager (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned
Maverick
Low
Unassigned

Bug Description

Binary package hint: network-manager

My networking is disabled every time I boot. To correct, I must right-click on Network Manager applet and choose "Enable Networking," after which my wireless networks become available and I can get online.

I'm using Lucid on a MacBookPro2,1

------SRU details----
Impact: This bug keeps the the networking disabled after a resume from suspend/hibernate. Right-clicking on the Network Manager applet and choosing "Enable Networking" solves the problem.

How the bug has been addressed: NM 0.8 has some bugs witch are partially listed at http://live.gnome.org/NetworkManager/ReleaseProcess The upstream has provided two patches (both are attached to this bug). There are two patches because the person who did the fix forgot something from the first commit and therefore made a second commit. The links to commits and patches can be found at comments 59 and 61. Some of these bugs including this bug are fixed in NM 0.8.1

TEST CASE:
Suspend or hibernate. The upstream report isn't very detailed about this, but in my case that process is unsuccessful. On resume you should not have a working network.

To solve:
 1) run
service network-manager stop
rm /var/lib/NetworkManager/NetworkManager.state
service network-manager start

or 2) right-click on Network Manager applet and choose "Enable Networking,"

or 3) Reboot.

Regression potential: Really none. This bug is a regression in the new NM 0.8. The upstream has fixed this bug and some other bugs in NM 0.8.1.

------------------------
ProblemType: Bug
Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
Date: Fri Feb 19 14:25:27 2010
DistroRelease: Ubuntu 10.04
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
IpRoute:
 10.45.43.0/24 dev wlan0 proto kernel scope link src 10.45.43.23 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
 default via 10.45.43.1 dev wlan0 proto static
Keyfiles: Error: [Errno 2] No such file or directory
Package: network-manager 0.8~rc2-0ubuntu1
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-13.18-generic
SourcePackage: network-manager
Uname: Linux 2.6.32-13-generic i686

Michael Tinsay (tinsami1) wrote :

+1

Using Kubuntu. After applying updates a few days ago, Network Manager has been disabled ever since with no way to enable it. /etc/network/interfaces only contains definition for lo -- no eth0, no wlan0.

Michael Tinsay (tinsami1) wrote :

Using Kubuntu Lucid Lynx with the latest updates. Clicking or right-clicking the network manager taskbar icon show a greyed out "Network Management disabled" messages with no option to enable it.

I can get wired connection going by putting the proper lines in /etc/network/interfaces.

Michael, David,

Just to be sure, is this with network-manager 0.8-0ubuntu1?

On Feb 21, 2010 11:21 AM, "Michael Tinsay" <email address hidden> wrote:

Using Kubuntu Lucid Lynx with the latest updates. Clicking or right-
clicking the network manager taskbar icon show a greyed out "Network
Management disabled" messages with no option to enable it.

I can get wired connection going by putting the proper lines in
/etc/network/interfaces.

-- Networking is disabled on boot https://bugs.launchpad.net/bugs/524454 You
received this bug not...

I found what was causing my problem. /var/lib/NetworkManager/NetworkManager.state had NetworkingEnabled=false and WirelessEnabled=false. I don't know what caused this.

I deleted the file, rebooted, and now I can connect to my network again -- at least the wired network which I use at the office. I'll connecting to a wireless network when I get home.

Søren Holm (sgh) wrote :

Nice catch Micahel....

Editing /var/lib/NetworkManager/NetworkManager.state setting NetworkingEnabled=true and then issuing "sudo restart network-manager" enabled networking again.

[~]% apt-cache policy network-manager
network-manager:
  Installed: 0.8-0ubuntu2
  Candidate: 0.8-0ubuntu2
  Version table:
 *** 0.8-0ubuntu2 0
        500 http://us.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

I confirm this problem, and the workaround described by Michael Tinsay.

This also started happening for me only *after* I updated for the first time. If it's not fixed quickly there may be a lot of people on the beta who are stuck with no way to get fixes b/c of no network.

Jeff Trull (jetrull) on 2010-03-23
Changed in network-manager (Ubuntu):
status: New → Confirmed
Ellie Frost (stillinbeta) wrote :

My Network Manager is disabled on boot, and I can gonfirm that in NetworkManager.state NetworkingEnabled is set to true. I still have to right click-> enable networking on boot.

Mehul J. Rajput (mehulrajput) wrote :

I too confirm this. I had the same problem and it is working perfectly now.

Mehul J. Rajput (mehulrajput) wrote :

Sorry I mean it worked after the workaround it worked fine with me.

Kılıç Köken (kilickoken) wrote :

I edit /var/lib/NetworkManager/NetworkManager.state, and change all falses with trues.

But when I reboot, wirelessenabled returnes false again. And my wireless doesn't work.

Kılıç Köken (kilickoken) wrote :

Sorry, after second reboot, it worked :)

Chris Pearson (ufgeek) wrote :

Same for me. Lucid Beta 1 on Dell D630C, upgraded from Karmic.

Indra (indra6oc) wrote :

Kubuntu Lucid x86_64, same problem, fix worked

amil (amilmohanan) wrote :

Doing what Michael Tinsay/Søren Holm seems to have fixed the problem for me.

norbert (globtroter) wrote :

Fix reported by Michael seems to solve this problem

Ramesh (vrgupt) wrote :

my /var/lib/NetworkManager/ is empty.
can't find NetworkManager.state!

323232 (323232) wrote :

had the same thing.

After I had drained my laptop battery to the max the laptod hibernated for the first time in Lucid
after putting it to the adapter i rebooted
then network manager was disbled. This hs not been the case before i hibernated
the /var/lib/NetworkManager/ file had the mentioned falses, i deleted it, i rebooted.
The wireless network was not disabled but did not see any networks
The wired network was working perfectly
tried a few things and rebooted a few time
finaly i put a noresume in grub, rebooted and the wireless got working again.

nbubis (nbubis) wrote :

Having a similar problem as Michael.

The file "/var/lib/NetworkManager/NetworkManager.state" contains:

[main]
NetworkingEnabled=true
WirelessEnabled=false
WWANEnabled=true

after changing to true and running "sudo restart network-manager"

it returns to false. havn't found a fix for this yet, running latest lucid on a dell 1420n.

Having the same problem here - just updated Dell Latitude and found no networking.
Editing NetworkManager.state as above and rebooting gives wired networking but wireless is always reset to false

nbubis (nbubis) wrote :

Wanted to report that after a clean install (formatting the drive etc..) it runs just fine.
It therefore seems like it's a problem with the upgrade from karmic to lucid that skips / keeps some files.

Good luck :)

Joseph Lansdowne (j49137) wrote :

Mm, no, I'm affected and I did a clean install. It's only happened about every third startup so far, though.

Jan Tarpila (jan-tarpila) wrote :

I had the very same problem described here after updating to 10.04.
lshw -C network was reporting disabled and all enabling option grayed out on the networking applet.
NetworkManager.state was also set to false. Changing these did nothing.

However after setting:
ifupdown managed=false to true in
/etc/NetworkManager/nm-system-settings.conf
(which I noticed after doing a "/etc/init.d/networking restart")

..and rebooting, network was back up. Mr. Tinsays method did not work for me,
being somewhat of a newbie, hope this is related and helps. :)

System being a HP DV5 with AR5001 Wireless Network Adapter.

Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 10.04
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
IpRoute:
 192.168.5.0/24 dev wlan0 proto kernel scope link src 192.168.5.102 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
 default via 192.168.5.1 dev wlan0 proto static
Keyfiles: Error: [Errno 2] No such file or directory
Package: network-manager 0.8-0ubuntu3
PackageArchitecture: i386
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-22-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
WifiSyslog:

tags: added: apport-collected

apport information

apport information

apport information

I sometimes experience this bug whenever my system is suspended and crashes when it tries to unsuspend.

Running Lucid Kubuntu here. Fully up to date and I can report that it is still occurring for me as well. All I've come up with is that if I attempt to hibernate or suspend to ram (both fail in Lucid both worked in Karmic, this install is a clean install as I wanted to re-partition. )

If I either write a script in rc.local that sed's the NetworkManager.state file on startup to change false to true, or if I use the chattr command and set the immutable bit (chattr +i so that not even root can modify the file.) it doesn't have this problem after a suspend crash/failure occurs. However if I don't do this every time suspend of any kind crashes or fails I have this problem occur.

What appears to happen is that normal suspend should write this state info out to this file so that the system doesn't react to commands while suspended. (Like wake-on-lan?) then it should write back to the file upon return from suspend to re-enable connectivity. This also seems to have the added advantage of dealing with cases where you suspend with wireless at location A and resume with wireless or wired at location B. You don't end up with the iPad problem (this is good.)

The solution seems to be giving knetworkmanager or the gnome equivalent a button to "Enable Network Management" Conversely a button to disable it would also be a nice feature. In other words I don't think the bug is with the code as it exists, I think the bug is a missing feature (ie the Enable button)

I added my report on 5 May over at duplicate bug 555571. Today I had the problem again, however with these differences: 1) This time it occurred after a successful sleep/reawaken (computer was running on battery and auto-suspended to RAM). 2) NetworkingEnabled In NetworkManager.state was still TRUE.

Restarting NWM did not fix the problem, but after rebooting the computer, NWM was working again.

This is an ASUS PV80C laptop with Ubuntu 10.04 with all the latest updates.

I just got the same issue, but it wasn't related to suspend or sleep, I just "hard-shutdowned" it.
Only thing I made different related to network was to plug the laptop on cable ethernet instead of using wireless... But it worked fine.
I hard shutdowned it by pure laziness as everything was working fine...

This ticket is starting to contain different bugs, let's focus on the first bug reported by David Siegel:
Network manager is disabled on boot:
* when left clicking on it shows:"Networking disabled"
* when right clicking on it, "Enable Networking" is not ticked
* the file /var/lib/NetworkManager/NetworkManager.state is present and contain NetworkingEnabled=false

Hermanus (hermanborsje) wrote :

My AMD64 Ubuntu 10.04 Lucid desktop system had exactely that problem. The first time change of the NetworkingEnabled setting in the .state file survived a couple of shutdowns and suspends, but then the problem reappeared. I changed it a second time some days ago and it has been working fine since then. I'm wondering if it will break again...

markofealing (mark-ferns16) wrote :

Same problem here on a Dell C640 running Kubuntu 10.04, had to do following to fix:

service network-manager stop
rm /var/lib/NetworkManager/NetworkManager.state
service network-manager start

Looks like QC on 10.04LTS has been very poor!

Same problem for me: This fixed it for me. Thanks Jan Tarpila

ifupdown managed=false to true in
/etc/NetworkManager/nm-system-settings.conf

service network-manager start

Dell E4300.

Same thing happened to me: suspend crashed for no apparent reason and then had no network, just the grayed out message "Network management disabled". Following https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/524454/comments/35 solved the problem, but as https://bugs.launchpad.net/ubuntu/+bug/555571/comments/16 mentions, this seems to be a well known and somewhat old bug.

Maybe contacting the kde gui authors for the possibility of adding a small button to send the dbus command? Or erase the status file on reboot would be sensible?

skierpage (skierpage) wrote :

Happens to me too after I upgraded to Kubuntu Lucid. Whenever I have a problem with standby, shutdown, or resume (about 1 in 4 times, alas), after I power-off and reboot I have no network and KDE's knetworkmanager shows "Network Manager disabled". Every time I looked /var/lib/NetworkManager/NetworkManager.state contained NetworkingEnabled=false. Regarding comment #24, my /etc/network/interfaces is unchanged since 2009-10-14 (Karmic?) and contains
  [main]
  plugins=ifupdown,keyfile

  [ifupdown]
  managed=false
and regarding comment #2 my /etc/network/interfaces dates from 2009-04-25 (Jaunty?) and contains
  auto lo
  iface lo inet loopback

Andrej Mernik (r33d3m33r) wrote :

Same problem here with Kubuntu 10.04. The computer was in standby. It didn't resume from it, instead black screen was shown. Then I forced reboot and since then KNetworkManager showed Unmanaged/Network Management disabled. After changing /var/lib/NetworkManager/NetworkManager.state contents this works again. As already written, KNetworkManager applet should have a checkbox -> enable networking.

Peter Antoniac (pan1nx) on 2010-06-07
Changed in network-manager (Ubuntu):
importance: Undecided → Low
papukaija (papukaija) wrote :

Added the regression tag since this hasn't happened in karmic or older.

tags: added: regression-release
summary: - Networking is disabled on boot
+ Networking is disabled on boot (usually after suspend/hibernate)
Changed in network-manager:
status: Unknown → New
Adam Porter (alphapapa) on 2010-06-09
tags: added: fixed-upstream
tags: added: backport-needed
papukaija (papukaija) on 2010-06-10
Changed in network-manager:
status: New → Unknown
Changed in network-manager:
status: Unknown → Fix Released
Changed in network-manager (Debian):
status: Unknown → New
papukaija (papukaija) on 2010-07-05
tags: added: patch
Changed in network-manager (Debian):
status: New → Fix Released
papukaija (papukaija) on 2010-07-26
description: updated
description: updated
tags: removed: backport-needed
Liam Farrell (liamfez) on 2010-07-27
Changed in network-manager (Ubuntu Lucid):
assignee: nobody → Liam Farrell (liamfez)
papukaija (papukaija) on 2010-07-27
description: updated
Changed in network-manager (Ubuntu Lucid):
status: New → Confirmed
tags: added: maverick
28 comments hidden view all 108 comments
Miguel Tadeu (mtadeunet) wrote :

This bug got to me since karmic...I'm on lucid and got bitten again...

i think you can try that without reboot

service network-manager stop
rm /var/lib/NetworkManager/NetworkManager.state
service network-manager start

Jakob Lund (jakob-bebop) wrote :

POSSIBLE WORKAROUND
I have this on an Asus EEE running Kubuntu.
It's annoying because I can't fix it from the GUI.
I put the attached text in a file called /etc/pm/sleep.d/90_netkick.sh and did chmod +x on it so it will run automatically on wakeup.

This seems to have fixed it here.

The fact that this happens on a failed suspend/resume indicated it's not NetworkManager's fault, but that the issue resides in the scripts run to "suspend" networking on S3/S4 states.

I'm assigning myself for the tasks for both Lucid and Maverick, there needs to be some work done to see if the commits fa70542c618665cf203a2b71fa0e504f759f7902 in NM and adf56461a7859280f8ea1520c9689e9383fab3f6 in nm-applet can be directly applied or backported; I'll make a test package available in a PPA (or -proposed).

Changed in network-manager (Ubuntu Lucid):
assignee: Liam Farrell (liamfez) → Mathieu Trudel (mathieu-tl)
Changed in network-manager (Ubuntu Maverick):
assignee: nobody → Mathieu Trudel (mathieu-tl)

papukaija, do the patches you mentioned (which are the same as I found but against the 0.8.1 tree), apply cleanly on top of 0.8-0ubuntu3?

papukaija (papukaija) on 2010-08-09
description: updated
papukaija (papukaija) wrote :

Mathieu: I'm not sure but the patches are directly downloaded from the upstream's git (see this bug's comments 59-61) and then uploaded to LP. Therefore the file/directory names might need some adjustments in the patches.

ahmet ertas (ahmetertas) on 2010-08-13
Changed in network-manager (Ubuntu Lucid):
status: Confirmed → Fix Committed

Right, thanks for that work, we'll just need to build an updated package and propose an SRU, I'll see what can be done to that (so keeping myself assigned for the issue in Lucid).

Changed in network-manager (Ubuntu Lucid):
status: Fix Committed → Confirmed
importance: Undecided → Low
Changed in network-manager (Ubuntu Maverick):
status: Confirmed → Fix Released
assignee: Mathieu Trudel (mathieu-tl) → nobody

I can confirm this bug on 64bit lucid with all updates up until now. Luckily, erasing the NetworkManager.state file did fix the problem and it hasn't occurred since.

bitlisz (bitlisz) wrote :

Same problem: Networking disabled (after hibernation) and the enable greyed out.
I'll try the solution today.

Anyway there is a lot bug around the new "power management"...
I dont have suspend to ram, and hibernation does not work correctly.
I dont get why Karmic just worked out of the box.

Michael Cook (mcook2) wrote :

Possibly related issue with Ubuntu 10.4 ...

Using Network Manager or WICD - even with Wake-on-LAN disabled - wired NIC is not powered off after shutdown request - unlike in Ubuntu 8.04 (and even Windows Vista).

Workaround is to "sudo ifconfig eth[n] down" prior to "sudo shutdown -h now". On reboot the NIC is reactivated and reconnects successfully whether using NM or WICD.

See https://bugs.launchpad.net/bugs/621343 - rejected against Network Manager - not sure where to resubmit it.

P.S. In this case the NIC is Marvell Yukon 88E8056 on a desktop/wired/server. Same results with sky2 driver v1.25 and sk98lin v10.85.8.3, except that with sky2 the device remains active and poisons the switch. sk98lin is supposed to eventually replace sky2, so no bug report for that yet.

bitlisz (bitlisz) wrote :

Thanks markofealing the solution is worked for me!

service network-manager stop
rm /var/lib/NetworkManager/NetworkManager.state
service network-manager start

And sorry for my last comment, suspend not worked with 9.10 too...
Here is the official answer from Point Of View, regarding my PC
(Mobii ION miniPC Sydney: ION-CS330-1 with motherboard POV/ION330-1)
"The 330-1 is not equipped with S3 by hardware, what means it is not possible to enable it by a bios update"
:(

boky (verynotbad) wrote :

FYI people, might be helpful for some:
I've seem to have traced my problem to a (faulty?) wireless on-off switch on my Dell D830. It seems to be very sensitive to the position. When I would switch my wireless on/off with a hardware switch I would get 10 hw on-off signals in /var/log.

What I did try was to disable the HW switch completely in BIOS. Seems that Ubuntu / Linux is still catching it nevertheless, although now there are only 3-4 on-off signals in the logs.

With HW switch off in BIOS and moving it very gently from on to off (or vice versa) I can find a state when the WIFI light turns on. If I don't touch it afterwards it works perfectly.

Now I don't know if this is a SW or HW issue (haven't had this problem when I was running Windows on the same machine); heck I don't even know if this is the same problem as this bug describes. Let's just say it did look like this bug when I was looking around the web for a solution and hopefully this comment will help someone.

papukaija (papukaija) on 2010-09-09
tags: added: metabug
Changed in network-manager:
importance: Unknown → High
Sheryl Barrow (plotchick) wrote :

I don't know if this is new info or not, but on mine I've noticed that it only does this when coming back on after Suspend, but *only when there's a USB connection plugged in*. USB Key, external harddrive, camera - all of them will cause it. I want to say it's only when the item is unplugged while in Suspend mode, but I can't be 100% positive. I do know it's gone into Suspend and returned ok with *no* USB plugs.

I can't right-click on Network Manager (but I might be in the wrong place), and the network-manager service isn't running, so I don't have to stop it. I just do the "rm /var/lib/NetworkManager/NetworkManager.state" command and then reboot (without trying to start the service either) and poof! it works again.

This is a brand new install of Ubuntu 10.04 LTS (Lucid Lynx). I downloaded and installed maybe a week ago.

Sheryl, this might be what causes your system to fail to suspend properly (assuming it does and you then reboot the system completely, which is how this bug is usually triggered). I don't think it has any link in why NM starts disabled though.

I don't really think Low is an appropriate priority level. I would rate it as High since there's no obvious workaround (disabling/re-enabling networking via the applet is simple enough, but does not work consistently).
So basically, for a "standard" user, the only remedy is closing any application and rebooting... this is not really appropriate IMHO since
1. Lucid is a LTS release
2. People tend to use standby a lot nowadays, so are likely to encounter this behavior one time or another

Using Lucid x86_64

sirald66 (sirald66) wrote :

Nexos, I stuck with Ubuntu 9.10 for reasons such as this.

Like Microsoft, Ubuntu is introducing new features/bugs before they nail down all the previous bugs. Ubuntu can say 'Fix Released' all they want, but if it doesn't appear/install from Update Manger -- it isn't fixed. Now that I can't suspend/hibernate the system, I have to stay tethered to an AC outlet or run out of battery.

I haven't been using Suspend or Wake-on-LAN, and I am using a wired
connection.

Nevertheless, I found it helpful to remove Network Manager 8.0 and use WICD
instead.

I find it very frustrating bumping into such basic problems with new
releases (I'm thinking of various gnome-applet issues with Hardy, this issue
with Network Manager, and ongoing video driver issues). "Whatever happened
to if it ain't broke don't fix it?", says my Mum. However, I am certain I
would not be any better off using another Linux distro or even good ol'
OpenBSD to satisfy my "UNIX Jones". After all this is free,
community-supported software, and - whatever else it may be - it's certainly
not boring.

Re. https://bugs.launchpad.net/bugs/621343 that I mentioned above on Aug 25
(wired Yukon NIC not being powered off at shutdown even w/o WLAN). At first
I thought this might be a related Network Manager issue (trying to keep the
NIC alive no matter what), and that's why I mentioned it here. Since then,
Mathieu kindly reassigned that bug report to the sky2 driver, where I am
pleased to say upstream testing (linux-image-2.6.36-020636rc3-generic)
indicates the issue is now fixed.

Does anybody know when we will get Network Manager 8.01 please? Can we get
it early for testing?

Sheryl Barrow (plotchick) wrote :

Mathieu,

I don't reboot it before/during/after Suspend. When it goes to sleep (Suspend) it's working, and when it wakes from Suspend it's disabled. Just like that. :) There are no problems waking back up - everything works fine, except networking. That's why I wanted to mention it here; no one else seemed to be having these exact symptoms (or at least not reporting them) and I was hoping the bit about the USB might help to narrow down the cause. We'll see....

I originally tried rebooting to see if that would fix it (before I found the correct steps) and it didn't work obviously. I just use sudo rm and then reboot and all is better.

J Bruni (jbruni) wrote :

This bug was reported in February... and almost reaching October I just summed to the 92 affected people being the 93rd.

I am using Kubuntu Lucid Lynx fully updated.

I changed both /var/lib/NetworkManager/NetworkManager.state and /etc/NetworkManager/nm-system-settings.conf as described.

After reboot, I see the changes in the files are still there (NetworkEnabled=true and [ifupdown] managed=true), and the internet connection was restablished. Cool!

BUT, a side-effect persists. It does not happen if I log as the primary user (the one with all sudo powers). It only happens if I log in as another user: the Network Manager icon says "Not available" on mouse hover, and it says "Network management disabled" on right click. No options, no nothing.

i want my Network Manager icon working again (as it already is working as I log in as the primary user)! I searched for personal settings, but ~/.kde/share/apps/networkmanagement has no files and an empty "connections" folder inside it...

Suggestions?

Thanks...

FWIW, I found a PPA to get newer versions of network-manager on Lucid: cf. https://launchpad.net/~network-manager/+archive/trunk?field.series_filter=lucid (NetworkManager daily trunk builds for ubuntu):

It seems to work for me, but YMMV (you shouldn't probably do this if you are not able to "fix" network connectivity without the help of network-manager, e.g. using command-line tools).

Don't complain... I give no refund in case your machine breaks :p

w1zard (pacehead) wrote :

Thumbs up to the solution given by Nexos in comment #88 - I added the the two PPA lines given in the link, ran update manager and installed all updates, and since then the networking has stayed enabled between restarts for the first time in a long time.

Running Xubuntu 10.04 and been experiencing the 'Networking Disabled' issue for months until now.

Thanks for the advice :)

Oops. I commented on a duplicate instead of this one. Sorry.

It's a bit drastic perhaps but you can fix this this problem permanently by making your /var/lib/NetworkManager/NetworkManager.state file look like so:

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

And then running this magical command as root:

chattr +i /var/lib/NetworkManager/NetworkManager.state

In case that doesn't makes sense, you're essentially fixing the configuration options and then making the file immutable (i.e not even the root user can change it)

Changed in network-manager (Ubuntu Lucid):
status: Confirmed → In Progress

Chris, you probably shouldn't do this because it will likely cause you further issues when disabling wireless or networking later.

I'm building packages now for testing, they will be available in https://edge.launchpad.net/~mathieu-tl/+archive/nm as soon as they are done building with the package in the same state as they are on Lucid with just this patch added. I haven't tested them myself yet, so no guarantees it works since I have to edit the patches a fair amount.

OTOH, you could always use the packages from the ~network-manager team PPA as it was proposed previously. Again, those packages may not work and cause other issues. Please only attempt either PPA if you're comfortable with fixing NM and downloading packages manually by downgrade or whatever if things don't work.

Changed in network-manager (Ubuntu Lucid):
status: In Progress → Fix Committed

I've marked this Fix Committed since there are now two ways to get a fix for this issue, as outlined above. It still means you need to go through using PPAs for now. After some testing of the packages we could look into whether this is too involved a fix to make it into a SRU or not, or wether NetworkManager 0.8.1 (from maverick) could be suitable for a backport.

Updating to NetworkManager 0.8.1 (i.e. updating from Lucid to Maverick) has not fix the bug on my computer. I had to manually change the config files as described here. So even as a backport, it may not be enough.

papukaija (papukaija) wrote :

@Adrien: Did you try rebooting before suspending/hibernating as network-manager doesn't (I think) restart automatically on upgrade?

@Mathieu: Thank you for working on this bug.

Adrien, after upgrading if the file is set to false, you would still need to click Enable in nm-applet or edit the file, but normally you should only have to do it once. Note that if you used Chris' workaround with chattr then you may want to revert that as well.

Tharakan (tharakan) wrote :

[TEMPORARY SOLUTION for some cases]

Although in the associated Gnome bug report, this is reported to have been committed to the 0.8.1 update for network-manager, people using the stock variety of Ubuntu have the daunting task of putting up with an Ubuntu system which shows Network Manager as 'disabled' on every reboot, until that is Ubuntu updates this application for all users. (I've tried changing ='false' to ='true' however this didn't do the job for me.)

A reliable solution for those trying only a clean boot for laptops ... can simply try the following. For me this solution has been working for the past week. (I've been bothered by this bug since at least the past 2 months).

1. Boot into Ubuntu
2. Check whether wireless is disabled by right-clicking on the network icon (top-right)
3. Press the key-combination for Wireless networking on the Laptop (Only Once)
4. Reboot Ubuntu
5. Go to step 2

Within 2 iterations this should start working now.

Isn't this bug fixed yet in 10.04? It's a very serious bug when you have many computers that need to be connected to a wifi automatically, with no user intervention. I might try the hard workaround of removing all write permissions on that file, but I don't like that sort of dirty hacks to make it work when it could be fixed in the ubuntu repos.

papukaija (papukaija) wrote :

@Lars: Lucid users need to use a PPA, more information in comment 91.

papukaija, no. What I wrote there is so that we could get the necessary testing to figure out what is wrong. If a later version of the package (such as the one in Maverick) works, then I know which patches to apply.

My PPA (linked above) contains a premade package for Lucid that contains the patches from upstream most likely to address the problem.

Zaki Akhmad (zakiakhmad) wrote :

I just had this problem on my Kubuntu 10.10

I tried to run with live cds: Ubuntu 10.10 and Helix 3.1. These live cds also didn't detect my LAN card. Problem solved after I unplugged the power bar, then I plugged it again, turned on the computer. The LAN card finally detected.

Stefano Rivera (stefanor) wrote :

Confirmed that the package in Mathieu's PPA fixes the issue for me on Lucid. I'm happy to verify a SRU.

(I have an office of machines affected by this, although they don't correctly suspend/hibernate anyway, due to NFS-mounted /home)

Rolf Leggewie (r0lf) wrote :

getting the ball rolling for lucid SRU (that's a pretty hefty patch at 26KB!)

1 comments hidden view all 108 comments

Hey!

Bedankt voor je mail! Ik ben er even tussenuit geknepen naar een lekker warm land! Ik beantwoord je mail na mijn vakantie (11 oktober).

Groetjes!

Ruben

Rolf Leggewie (r0lf) wrote :

resetting status and assignment for SRU process

Changed in network-manager (Ubuntu Lucid):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
status: Fix Committed → Confirmed
1 comments hidden view all 108 comments
Jeff Lane (bladernr) wrote :

Did this ever make it into an SRU for lucid?

The Gavitron (me-gavitron) wrote :

This bug still exitsts in lucid-current:
> uname -a
Linux unicron 2.6.32-42-generic #95-Ubuntu SMP Wed Jul 25 15:56:09 UTC 2012 x86_64 GNU/Linux
> lsb_release -r
Release: 10.04
> aptitude show network-manager |grep Version
Version: 0.8-0ubuntu3.3

This bug hit me when hibernating the machine failed. On all subsequent restarts, the machine would not automatically reconnect to the wired network, but dhclient could grab an IP if run manually. All "network state aware" applications, ie: Chrome & pidgin exhibited broken behaviours after obtaining a network address - Pidgin refused to connect to any services at all. Chrome could browse, but all application icons on the 'New Tab' page were grayed out, and no plugins would start.

to fix DHCP, I had to edit /etc/network/interfaces, and uncomment the following line:
# iface eth0 inet dhcp

while this allowed the machine to connect to the network at boot, the problems with the applications persisted. Thanks to this bug report, I was able to find that /var/lib/NetworkManager/NetworkManager.state contained the line:
  NetworkingEnabled=false

by changing this line to true, then running:
 sudo service network-manager restart

I was able to reconnect.

since 10.04 is still under LTS support, I certainly hope there is an effort to fix this 2+ year old bug, rather than hope it goes away when support is dropped in 2013...

Hans Ginzel (hans-matfyz) wrote :

I realised this bug after upgrading to saucy. In raring networking and suspend worked well.

Displaying first 40 and last 40 comments. View all 108 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.