Networking disabled after suspend/hibernate

Bug #533471 reported by RussianNeuroMancer on 2010-03-06
40
This bug affects 9 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

After I resume or reboot laptop (Lenovo Y550-4CWI) after suspend/hibernate networking is always disabled.

When enabled manually from nm-applet, the networking is enabled correctly:
** (nm-applet:1523): DEBUG: old state indicates that this was not a disconnect 0
** (nm-applet:1523): DEBUG: old state indicates that this was not a disconnect 1
** (nm-applet:1523): DEBUG: foo_client_state_changed_cb
** (nm-applet:1523): DEBUG: going for offline with icon: notification-network-disconnected
** (nm-applet:1523): DEBUG: old state indicates that this was not a disconnect 2
** (nm-applet:1523): DEBUG: going for offline with icon: notification-network-disconnected
** (nm-applet:1523): DEBUG: foo_client_state_changed_cb
** (nm-applet:1523): DEBUG: foo_client_state_changed_cb

It's look like Ubuntu always disable networking when suspend/hibernate, but not trying to enable it after resume or reboot.

description: updated
tags: added: regression-update
tags: removed: regression-update
papukaija (papukaija) on 2010-05-10
Changed in network-manager (Ubuntu):
status: New → Confirmed
papukaija (papukaija) wrote :

This bug is a regression from karmic.

tags: added: regression-release

Architecture: i386
CRDA: Error: [Errno 2] Tiedostoa tai hakemistoa ei ole
DistroRelease: Ubuntu 10.04
Gconf:

IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
IpRoute:
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.7 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
 default via 192.168.1.1 dev wlan0 proto static
Keyfiles: Error: [Errno 2] Tiedostoa tai hakemistoa ei ole
Package: network-manager 0.8-0ubuntu3
PackageArchitecture: i386
PciNetwork:

ProcEnviron:
 LANG=fi_FI.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: lucid
Uname: Linux 2.6.32-22-generic i686
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape video

description: updated
tags: added: apport-collected

apport information

apport information

apport information

apport information

apport information

apport information

apport information

papukaija (papukaija) wrote :

Is any additional information needed to fix this bug?

Peter Antoniac (pan1nx) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 524454, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers