[SRU] Update to maintenance release 2.2.4 in Bionic

Bug #1811571 reported by Amr Ibrahim on 2019-01-13
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lyx (Ubuntu)
Low
Unassigned
Bionic
Low
Unassigned

Bug Description

IMPACT
-------
http://www.lyx.org/announce/2_2_4.txt

LyX 2.2.4 is the fourth and final maintenance release in the 2.2.x series.
You can download LyX 2.2.4 from http://www.lyx.org/Download/.

LyX 2.2.4 is the result of ongoing efforts to make our stable version more reliable and more stable. We have fixed a number of bugs and made several improvements.

What's new
==========

** Updates:
***********

* USER INTERFACE

- On Windows, allow to automatically bring the LyX window to top (bug 10469).

- Cache information on exportable formats (bug 9980).

- Shorten the time required to save the session state on exit.

* DOCUMENTATION AND LOCALIZATION

- Updated Arabic, Czech and Japanese user interface localization.

* BUILD/INSTALLATION

- Mark some intentional fall-throughs in order to silence false -Wimplicit-fallthrough warnings with gcc7.

** Bug fixes:
*************

* DOCUMENT INPUT/OUTPUT

- Fix wrong spacing in output when the font size is changed inside a center environment or a greyed out note (bugs 9598 and 10650).

- Assure properly nested \begin{lang} and \end{lang} tags even when no language package is selected (bug 10685).

- Catch "! Incomplete \if[x]" LaTeX error (bug 10666).

- Ignore LaTeX error on missing ZWNJ (ligature break) characters (bug 10727).

- Fix PDF output of clipped graphics with recent graphics package (bug 7910).

- Catch xdvipdfmx driver error that breaks XeTeX compilation (bug 10076).

- Fix caption handling in listings insets when it is split into multiple lines in the LaTeX output (bug 10705).

- Do not let the natbibapa module overwrite what the class or other packages add to the preamble.

- Assure the color package is loaded before polyglossia in preview snippets. This fixes preview image generation with polyglossia and bidi (bug 10716).

- Fix babel name of Vietnamese language. This requires now babel-vietnamese (2013ff.) instead of vietnam.ldf that was shipped with vntex previously (bug 10743).

- Fix issue with language nesting when using Asian languages (bug 10778).

- Fix bug that TeX files were not detected when reconfiguring LyX (bug 11053).

* USER INTERFACE

- Fix crash occurring in certain circumstances when previewing the source of a single paragraph containing a language switch (bug 10636).

- Fix crash when closing master file with full view source open (bug 10560).

- Fix crash when closing master document with dirty child while Document Settings dialog is open (bug 9979).

- Fix crash when closing master with children and grandchildren (bug 10766).

- Fix crash when pasting multiple cells into a multi-paragraph cell of a table (bug 9983).

- Fix random crash when dissolving inset (bug 10667).

- Fix potential crash when cursor enters an inset (bug 10691).

- Avoid crash when selecting long text (bug 10324).

- Fix crash with undo and child documents (bug 10643).

- Fix completely broken undo in Advanced Find & Replace edit areas (bug 10847).

- Fix crash when changing preview preferences while previewable external inset is open (bug 10785).

- Fix problem with decimal special height/width values in the Box dialog in some localizations (bug 11000).

- Remove duplicate entries from the Symbols dialog (bug 10644).

- Always show the float type in the float inset label (bug 10618).

- Show correct color name for green in the status bar (bug 10656).

- fixes to cursor positioning on mouse click for right-to-left text (bug 10569).

- Fix metrics of full-width insets when paragraph endings are shown (bug #10537).

- Fix glacial performance with ancient Hebrew text on macOS.

- Fix hole in selection for some zoom and justification values (bug 8883).

- Fix some rare cases of bad on-screen line breaking (bug #10700).

- Fix bad justification before a displayed inset (bug 10699).

- Fix selection display glitch with paragraph label (bug 10972).

- Fix cursor state after double/triple click in mathed (bug #10686).

- Avoid a case of stuck cursor after entering an inset (bug 10630).

- Fix problems with hidden "BibTeX Add" dialogs on MacOSX by using drawers instead of modal subdialogs (bug 10662).

- Don't swallow labels not entered through the toolbar in mathed (bug 10546).

- Fix bad context menu on insets that do not have one (bug 10616).

- Enable OK/Apply buttons when resetting to class defaults.

- Fix untranslated GUI string in Box dialog (bug 10999).

- Fix untranslated GUI strings on View/Update toolbar button menu (bug 11040).

- When entering a math macro name, Escape properly cancels the operation (bug 9251).

* INTERNALS

- Fix execution of set-graphics-group function.

* DOCUMENTATION AND LOCALIZATION

- Fix loading of math packages in many manuals (bug 10661).

- Add note that the fixltx2e package (and so module) is obsolete as of TeXLive 2015 (bug 9361).

- Updated French user interface localization.

* TEX2LYX

- Fix import of \newtheorem* declarations (bug 10622).

- Fix import of (specific) BibTeX paths (bug 7637).

- Fix import of flalign* environment (bug 10501).

* BUILD/INSTALLATION

- Update tex2lyx tests (bug 10800).

[Test case]
1. Launch lyx 2.2.3 from bionic. Edit a file, then save it.
2. Upgrade to lyx 2.2.4 from bionic-proposed.
3. Open the previously-saved file with the new version of lyx.
4. Modify the file.
5. Confirm that viewing the file as a PDF works.
6. Confirm that the file can be exported to other formats.

[Regression potential]
---------------------
The only new feature of 2.2.4 is that it is able to read and write files in the 2.3.x format. Please note, however, that the conversion process back and forth usually will not leave one with an identical file, so we do not recommend that users of 2.2.4 try to collaborate with users of 2.3.x.

Version 2.2.3 in Bionic now cannot even read or write in 2.3.x format so users of Bionic already know that they cannot collaborate with 2.3.x users. So the regression potential is low.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lyx (Ubuntu):
status: New → Confirmed
Changed in lyx (Ubuntu):
importance: Undecided → Low
tags: added: upgrade-software-version
Mathew Hodson (mathew-hodson) wrote :

debdiff

Mathew Hodson (mathew-hodson) wrote :

I attached the diff that was posted in duplicate bug #1602145 by Juhani Numminen

The attachment "lyx_2.2.4-0ubuntu1.patch" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in lyx (Ubuntu):
status: Confirmed → Fix Released
Changed in lyx (Ubuntu Bionic):
importance: Undecided → Low
Simon Quigley (tsimonq2) wrote :

Thanks for your work on this!

Could you please update the bug description to follow the SRU template? That can be found here: https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

Once that is done, please resubscribe the Ubuntu Sponsors Team.

description: updated
description: updated
Simon Quigley (tsimonq2) wrote :

Uploaded with some minor changelog edits.

Thanks!

Robie Basak (racb) wrote :

Same question as https://bugs.launchpad.net/ubuntu/+source/lyx/+bug/1595358/comments/18:

This part of SRU policy is relevant here: https://wiki.ubuntu.com/StableReleaseUpdates#New_upstream_microreleases

Please could you confirm if the following are all true?

a reliable and credible test suite for assuring the quality of every commit or release,
the tests are covering both functionality and API/ABI stability,
the tests run during package build to cover all architectures,
the package has an autopkgtest to run the tests in an Ubuntu environment against the actual binary packages,

If not, this will need approval from the Ubuntu Technical Board, unless they have already granted such permission (if so, please link to that).

Amr Ibrahim (amribrahim1987) wrote :

To one of the Lyx upstream developers, could you please answer comment #7?

Amr Ibrahim (amribrahim1987) wrote :

@Jean-Mark, would you shed some light on comment #7?

@Robie, a micro-release update already happened in Trusty bug #1303688, it went from 2.0.6 to 2.0.8. Upstream makes sure that micro-releases are stable and only bug-fixes get cherry-picked to the stable branch from master.

Jean-Marc Lasgouttes (jmarc) wrote :

I am one of the upstream developers. What I can say about this 2.2.4 version is

* we have unit tests for the code, but I would not qualify them as extensive

* as of versions 2.2.x, we have a rather extensive test repository that checks whether our file export routines (which is the main purpose of LyX after all) work well.

* as the last release of the 2.2.x series, LyX 2.2.4 has been build very conservatively, so that it would not introduce new problems. It does fix 56 bugs, among which crashes like bug #1737429.

* I do not remember of any new problem introduced in 2.2.4. Unfortunately, we did not create a "2.2.4" version in our bug tracker, so I cannot substantiate that.

* the only new feature is the possibility to read/write LyX 2.3.x files, which is very valuable in itself.

I am not sure this fulfill the SRU rules, but I want to emphasize that long term releases is the main target of a release such as this one. We have a stable release manager whose job is to sure that people can upgrade stable releases with low risk, and is twice as cautious for the last one in a series.

Steve Langasek (vorlon) on 2019-05-24
description: updated
Changed in lyx (Ubuntu Bionic):
status: New → Fix Committed

Hello Amr, or anyone else affected,

Accepted lyx into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lyx/2.2.4-0ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
Amr Ibrahim (amribrahim1987) wrote :

I have been using 2.2.4-0ubuntu0.18.04.1 from bionic-proposed without any issues. I successfully read and write .lyx files and export them into PDF using several backbends without any problems.

tags: added: verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for lyx has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lyx - 2.2.4-0ubuntu0.18.04.1

---------------
lyx (2.2.4-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream release (LP: #1811571).
  * Drop 0002-Fix-spelling-errors.patch which does not apply cleanly.

 -- Juhani Numminen <email address hidden> Fri, 14 Sep 2018 15:36:22 +0300

Changed in lyx (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers