Ubuntu

gnome programs don't respect ~/.cups/lpoptions

Reported by Superkatze on 2006-03-08
314
Affects Status Importance Assigned to Milestone
gnome-cups-manager (Ubuntu)
Medium
Unassigned
libgnomecups (Ubuntu)
Medium
Unassigned
libgnomeprint (Fedora)
Fix Released
Unknown
libgnomeprint (Ubuntu)
High
Martin Pitt
libgnomeprintui (Ubuntu)
Medium
Unassigned

Bug Description

I managed this problem and many duplicates bugs :

    * Bug #31864
    * Bug #38149
    * Bug #41303
    * Bug #41304
    * Bug #41402

So i resume here the problem.

When you use Gnome-Cups-Manager to mark a printer as default user, or when you change some parameters (like PageSize), modifications are saved in ~/.cups/lpoptions . This comportement is ok.

But this user configuration file is not used by gnome-cups-manager so user's parameters like default printer or user default parameters are not used.

STEP TO REPRODUCE THE BUG:
open gnome-cups-manager
add a new local printer (even if you don't have one)
change settings (like paper format A4/A5/A3 ...)
close gnome-cups-manager
view ~/.cups/lpoptions ... your changes are well saved.
open gnome-cups-manager
go to printer settings and you can see that your changes are lost

> ORIGINAL DESCRIPTION
>If I set my printer (HP Deskjet 6540 with hplip) to fast >draft mode it will not work. It still prints in normal mode.
>
>If I look at the web frontend for cups the settings didn't >change.
>
>If I change the settings directly in the web frontend it >works as desired.

What is the application you printed from?
I did a test with my HP DeskJet 3820 printer using OpenOffice.org and draft and normal mode printout both work.

The CUPS web interface changes default printer options directly in the PPD files located in /etc/cups/ppd.

gnome-cups-manager printer options are saved in ~/.lpoptions

You can type this in a terminal to see if options are set by gnome-cups-manager:
$ lpoptions

Changed in gnome-cups-manager:
status: Unconfirmed → Needs Info
Matthias Klose (doko) wrote :

please recheck after a dist-upgrade to dapper 20060414, removal and reinstallation of the printer

ARR (alanrr-sr) wrote :

I am using a epson CX 4100, and changes are not applied for the printer (even the "set default" change"
I could not that if I try to change in WEB interface, I get printer not found... maybe because of the freak name of the driver?? (CX4100---CUPS+Gutenprint-v5.0.0-rc2)

Holger Arnold (holgerarnold) wrote :

If I start the printer setup dialog by "sudo gnome-cups-manager", then changes to the printer options are preserved (and shown in the "Properties" dialog of the printer).

Strangely, these settings are not used when printing, and, more strangely, the web interface of CUPS shows different settings than gnome-cups-manager.

Holger Arnold (holgerarnold) wrote :

If I change a setting in gnome-cups-manager (started from the menu), the file ~/.lpoptions is deleted. I don't think that this is the intended behavior.

This bug seems to be related to #26122.

Gerry Tool (gerry-thetoolshed) wrote :

The gnome-cups-manager app appears to change the paper size from A4 to US Letter, but if I print a test page it is still A4. The change is not persistent. When I look at the properties of the printer again, it is still set to A4. I tried in the localhost:631 interface, but according to the page it is disabled, and of course if I enter my name and password, it just keeps asking over again. Since there is no root account, I can't try as root in the web interface.

If I run sudo gnome-cups-manager, the paper size change sticks. However, since the web interface still shows the paper size to be A4 (yes, I did a fresh view), thee is a very large upper margin on the top of the page. I have had this problem in many gnome systems, and it is always indicative that localhost:631 and gnome-cups-manager have different settings.

Since I can't make the change in localhost:631, I cannot get rid of this large top margin. This causes progarms like glabels to not be able to line up the label with the medium.

Gerry Tool (gerry-thetoolshed) wrote :

OK, I found the file with instructions on enabling the web interface. I did that, rebooted, and was able to set the paper size in the web interface to the same value as in gnome-cups-manager. The top margin is now correct.

However, this is not going to fly if normal users cannot set the paper size and have it viewed as the same value in both interfaces. That needs fixing.

Gerry Tool (gerry-thetoolshed) wrote :

Sorry, I spoke too soon about the margin.

Even with both interfaces reporting the same settings, glabels printing, and gedit printing, and probably any gxxx printing has too large a top margin. This testing was done using a Samsung ML-1750 laser printer set for US Letter and 1200x600dpi printing.

Gerry Tool (gerry-thetoolshed) wrote :

Update - sorry about the flip-flopping here, but I just succeeded in getting my Canon PIXMA ip-4000 working in Dapper using Turboprint 1.94-2. I set the printer up in the Turboprint config utility and then used the CUPS web interface to adjust the settings to be the same both places.

It prints from Glabels now with the CORRECT top margin.

I was still curious why the Samsung top margin is too large, so I tried the lj4dith driver instead of the recommended pxlmono driver. That fixed the top margin problem for that printer.

description: updated

This seems to bite many people, upgrading severity.

What more info is needed on this bug?

Carthik Sharma (carthik) wrote :

Confirmed bug. Needs Info seems inappropriate to at least one subscriber.
As a note, this remained "needs info" since others like me might have hesitated to spam all the subscribers to this bug. Thank you for reporting this bug.

Changed in gnome-cups-manager:
status: Needs Info → Confirmed
Paul Sladen (sladen) wrote :

This needs some looking at.

Changed in gnome-cups-manager:
assignee: nobody → desktop-bugs
description: updated
Martin Pitt (pitti) on 2006-05-17
Changed in gnome-cups-manager:
assignee: desktop-bugs → pitti
Martin Pitt (pitti) wrote :

Got it! Testing patch with Patrice now.

Changed in gnome-cups-manager:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

 libgnomecups (0.2.2-1ubuntu3) dapper; urgency=low
 .
   * libgnomecups/gnome-cups-printer.c, parse_lpoptions(): Do not only look in
     the obsolete ~/.lpoptions file, but also into ~/.cups/lptoptions. This
     fixes the handling of user defined printer settings, default printer, etc.
     Closes: LP#34112 and half a thousand duplicates.

Finally! Feedback appreciated, but it works just fine here now (for Patrice as well).

Changed in libgnomecups:
status: Fix Committed → Fix Released
hove99 (hove99) wrote :

When I modify properties for a printer (System -> Administration -> Printing), I can see the changes in ~/.cups/.lpoptions, but the changes cannot be seen in (System -> Administration -> Printing). However, the options seem to have gone in to effect, since I can enable and disable duplexing.

Hove99 : please see Martin 's comment before your's and wait for libgnomecups (0.2.2-1ubuntu3) :)

Andrea Garbarini (garba) wrote :

okie now the lpoptions file in .cups is updated accordingly and gnome-cups-manager properly seems to parse it, problem is, I've just printed a doc from evince but my personal settings are still ignored, it's the system wide settings that are being used (i.e. stuff in /etc/cups/pppd)

This Bug is closed. And your problem is with evine not gnome-cups-manager.
If you have a bug with evince please create a new one after a search if the bug is already reported.
Thank you

Changed in gnome-cups-manager:
status: Unconfirmed → Fix Released
Jens Berke (jensberke) wrote :

I've got the same problem Andrea reported two posts above. I checked with Evince, GPdf and GEdit, and all three applications don't care about the settings I made wth gnome-cups-manager. I've got Dapper Release Candidate 1 with libgnomecups 0.2.2-1ubuntu5 installed. Maybe this bug needs to be reopened?

Jens

drafil (dragosfilipescu) wrote :

Hi Berke!
Have you tried to reinstall your printer?

Jens Berke (jensberke) wrote :

You mean removing it in gnome-cups-manager and then installing it again? If so, yes, several times, but to no avail.
Jens

drafil (dragosfilipescu) wrote :

Yes, Jens, but forget it! I have the same problem! :((
I can print from Windows to Ubuntu printer well (there are the setting made on Windows machine that are applied), but when printing from Ubuntu, my settings are ignored...
I think this bug should be reopened.

Martin Pitt (pitti) wrote :

Reopening, it seems that there is still an issue with that.

Changed in libgnomecups:
status: Fix Released → Confirmed
Jens Berke (jensberke) wrote :

If you need more info (debug info, logs, config files...) let me know and I see what I can do.
Jens

Sean Middleditch (elanthis) wrote :

My issues detailed in bu #44469 are still present, with libgnomecups1.0-1 0.2.2-1ubuntu5.

My .cups/lpoptions is configured correctly. The problem is that all libgnomeprint-using applications ignore the settings set in the individual print-dialog UIs (that is, the dialog reflects the settings in .cups/lpoptions, but doesn't use them), while non-libgnomeprint-using applications honor the defaults *and* actually work correctly.

Dirk (ubuntu-tobit) wrote :

Sorry about the "me too" post, but I cannot stress enough that this is NOT a duplicate of any bug to do with *lpoptions.

The bug we are complaining about is that any attempt to alter the default options presented in the libgnomeprint dialogs for a print are either ignored (eg duplex printing or tray selection) or wrongly implimented (as in landscape: where the print is done landscape, but on portrait oriented paper).

Just to be clear here, we are specifically NOT talking about storing or using stored options, we are complaining about print specific, default overriding, selections.

drafil (dragosfilipescu) wrote :

I have exactely the same problem reported by Sean Middleditch two posts above.

We have 2 bugs here:
- libgnomecups looking in the obsolete ~/.lpoptions instead of ~/.cups/lpoptions, this was fixed in libgnomecups 0.2.2-1ubuntu3.
- libgnomeprintui ignoring ~/.cups/lpoptions as described below, this is still not fixed.

I did some debugging of foomatic-rip and come to the following conclusion.

Printing options can be set in 2 ways:
- By changing Default values in the configured PPD for your printer in /etc/cups/ppd, this is done for printing options set by CUPS web interface.
- By setting options in ~/.cups/lpoptions, this is done by gnome-cups-manager.

Now the problem is that printing options set with gnome-cups-manager in ~/.cups/lpoptions are not applied when printing from a gnome application (libgnomeprintui), only options from the configured PPD in /etc/cups/ppd are used.

When printing from a non-libgnomeprintui application (e.g. firefox or the command line) both the options from the configured PPD /etc/cups/ppd and ~/.cups/lpoptions are applied, in that order (meaning options in ~/.cups/lpoptions override options in the configured PPD).

The way I see it there are 2 possible solutions:
* gnome-cups-manager should directly change printer options in the configured PPD like CUPS web interface does. This is the recommend way since it will work with every application understanding PPDs.
* Or gnome applications (libgnomeprintui) should make use of printer options in ~/.cups/lpoptions. Perhaps this one is easier to fix.

I already suggested these solutions 3 months ago in bug #26122.

I have no C programming experience, please can somebody fix this before dapper release.

Changed in libgnomeprintui:
status: Unconfirmed → Confirmed

@Pascal De Vuyst

It's normal that libgnomeprintui ignore lpoptions, that lib has nothing to do with it.
libgnomeprint should not have to interact with lpoptions, but it's too late to do anything.

For informations :
~/.cups/lpoptions is changed by gnome-cups-manager when used normally by the user
/etc/cups/ppd/ drivers are changed by gnome-cups-manager run as ROOT or by cups web interface.

It's clear that a quick work around for this bug is to always run gnome-cups-manager as root (using gksudo). Pitti ?!

The best is to find where user options are lost. May be libgnomeprintui forgot to return all options passed for dialogs or ...

Andrea Garbarini (garba) wrote :

Actually, running gnome-cups-manager as root won't cause the ppd driver in /etc/cups/ppd to get modified, at least on my box here.

Jens Berke (jensberke) wrote :

Same here: gnome-cups-manager as root is no workaround.

Sorry :/
running gnome-cups-manager save changes in /etc/cups/lpoptions

Jens Berke (jensberke) wrote :

Ok, /etc/cups/lpoptions is modified actually when running "gksudo gnome-cups-manager". File looks like it should according to my settings:

Dest DeskJet-5940 PrintoutMode=Draft.Gray Quality=FromPrintoutMode PageRegion=A4

but these settings are ignored.

Don't know if this has something to do with the bug, but I get the following output only when starting gnome-cups-manager with gksudo:

(gnome-printer-view:5539): GnomeUI-WARNING **: While connecting to session manag er:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

This bug also exists in Fedora, see https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=157878.
Can somebody change this bug number in the Fedora bug watch, initially I gave the wrong bug number and now I am unable to change it.

ozonehole (taibei) wrote :

I don't know if I should be posting this here, but anyway, I was one of the people who originally reported this bug (when I was running Dapper beta). Now I've installed Dapper final release, and the situation has changed. Instead of getting draft printing when I should be printing high quality, I'm simply not getting any printing at all. I can setup the printer and jobs will queue, but nothing gets printed.

Whatever has been changed between the beta and final release killed my printing altogether.

My printer is an Epson 24-pin dot-matrix on /dev/lp0.

cheers,
Robert

The problems described here are because gnome-print libraries are not maintained and buggy. Thanks to Project Ridley these libraries are abandoned and a new printing dialog and libraries will be part of GTK+ (available in GTK+ 2.10). These new libraries will bring a better printing experience and are the right way forward. More info on http://live.gnome.org/ProjectRidley.

Until then we are stuck with gnome-print in dapper (GTK+ 2.8). I have created a patch for libgnomeprint that improves the current printing experience from gnome applications by:
  * Reading options set in PPD, /etc/cups/lpoptions and ~/.cups/lpoptions by making use of gnome_cups_printer_get_options from libgnomecups. This makes sure that options set by gnome-cups-manager will be applied, even options that can't be changed in the gnome print dialog like Printing Quality.
  * allowing more options to be usable in the gnome print dialog: changing of Paper Size, Page Orientation (e.g. Landscape), Duplex and Tumble, 2 pages to 1 and 4 pages to 1. These options only apply to the current print job and are not saved when closing the gnome application.
This was part was inspired by gnome-bug 166564.
Hard to believe that e.g. landscape printing didn't work in gnome apps, this fix solves that.

You find the patch in attachment. This patch solves bug #34112 and its duplicates according to me in the best way possible for the current gnome-print implementation. I advice everyone to test it and to report possible problems with it.

This patch lets gnome applications use the printing options set in gnome-cups-manager.

Andrea Garbarini (garba) wrote :

thanks a LOT for the patch Pascal, i've just rebuilt the libgnomeprint package applying ur patch and now i can print multiple pages on a single page :)

Andrea Garbarini (garba) wrote :

I also happily report that now even the settings applied in gnome-cups-manager are honored when printing through the gnome frontend, thanks again!

Prinz Igor (pigor) wrote :

how can i build and patch libgnomeprint by myself?

will the patch be part of dapper soon? i mean so that "normal" users can print again?

Andrea Garbarini (garba) wrote :

there's a post of mine at the ubuntu forums with the patched debs attached:

http://www.ubuntuforums.org/showthread.php?t=190714

hope this helps, regards, andre

Jens Berke (jensberke) wrote :

Many many thanks for that patch. I can confirm that now the settings for printer quality and grayscale are used. Tested with Evince and GEdit (using the debs provided in ubuntuforums).

Prinz Igor (pigor) wrote :

one question to all which have applied the patch successfully: do you use turboprint?

my problem is that (with turboprint) every job is queued but nothing happens. perhaps i have to open a new bug ...

Ante Karamatić (ivoks) wrote :

Open new bug only if there are problems with official package. If there are problems with patched package, them you should discuss it with author of that patch/package.

Jens Berke (jensberke) wrote :

Found a bug with the patch applied (reason for that bug might be in a different package, though): printing a pdf that has text and images in it, with the option for "layout" set to "2 pages on 1", produces the 2 on 1 now but with big black boxes beneath some of the images. These boxed overlay the text, which is printed fine. If needed, I can post an attachment which shows how it looks like.

Prinz Igor (pigor) wrote :

> Open new bug only if there are problems with official package.

that's because i have make my question. i don't know if it is a special turboprint problem or a general problem with ubuntu-print.

so again: are there any people using turboprint who have applied the patch above? is it working or not?

Martin Pitt (pitti) wrote :

Closing libgnomeprintui task

Changed in libgnomeprintui:
status: Confirmed → Rejected
Martin Pitt (pitti) wrote :

Fixing affected source package

Martin Pitt (pitti) wrote :

Pascal, thanks a lot for your patch! I tested it and it works just fine. I built a test package (amd64 and i386, and source) on

  deb http://people.ubuntu.com/~pitti/packages/libgnomeprint/ ./
  deb-src http://people.ubuntu.com/~pitti/packages/libgnomeprint/ ./

just add this to /etc/apt/sources.list, sudo apt-get update, and upgrade. More test reports greatly appreciated!

Changed in libgnomeprint:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Once we have enough test reports and Matt approves, I'll upload this to dapper-updates.

Florian L (flad) wrote :

Duplex printing and 2-to-1 printing of pdf using evince (that's what I tried so far) works for me now using the new packages. The pdf has images in it and it prints fine for me (no black boxes like the ones reported above). Thanks!

Pitti :
trying to print here at home, with Canon iP3000 with turboprint drivers works as i want ! Patch is OK for me :)
Excellent patch Pascal De Vuyst !

I have to test it at work now ...

Prinz Igor (pigor) wrote :

@VETSEL Patrice:

i am using the same printer with turboprint too. but i cannot print. every time when i start a print job the panel icon appears but nothing else happens. all jobs are ignored. do you have changed anything else? (in xtpsetup is a message: "USB printer is busy; will retry in 5 seconds")

Prinz Igor (pigor) wrote :

i have tested a little bit more. printing with evince works fine!

but when i try to print with acroread nothing happens and i have to turn off and on my printer to print with evince again.

@Prinz :

installed turboprint.
run gnome-cups-manager to add printer and choosen canon turboprint ip3000 driver
nothing else.

@Pitti: patch seems ok at work too :)

Prinz Igor (pigor) wrote :

@VETSEL:

1) could you test another format please? e.g. 4x6 inch (10x15cm) borderless with gimp prints just a small bar on one side of the paper.

2) do you have tested acroread too?

Sean Middleditch (elanthis) wrote :

Prinz Igor: Neither GIMP nor Acroread use gnome-print. They're GTK applications, yes, but they're not GNOME applications. GIMP uses gimp-print and Acroread uses something else. Neither of these programs' problems should be related to this bug (theoretically). Are the problems only occurring after installing the patched libgnomeprint packages?

Martin Pitt (pitti) wrote :

Please be aware that acroread is not a gnome program and thus doesn't use libgnomeprint. Printing problems in acroread are entirely unrelated to this bug report.

Prinz Igor (pigor) wrote :

thanks sean. i did not knew that acroread and gimp use another printing-environment.

> Are the problems only occurring after installing the
> patched libgnomeprint packages?

the problem is not new.

@VETSEL: because you have the same printer as i - could you mail me please, if you have the same problems (printing with gimp or acroread and/or with excotic formats like 4x6inch borderless)? my mail-address is dev[at]ceglarek[dot]org

Dirk (ubuntu-tobit) wrote :

So does this mean that I need to open new bugs on gimp and acroread to reflect the fact that they use different printing mechanisms and they don't work?

Could I politely say that: not having printing working, to the extent of offering non-default options on dialogs and then ignoring them, not printing landscape correctly, if some are selected - on officially released product - strikes me as pretty show stopping bug for any serious or commercial user!

Please could you make sure that all the various paper location selections (eg top tray, bottom tray) work. Again, this is because commercial users will have different papers in these trays and will want to print on the correct one. If you want a concrete example for (a less serious) user, I have A4 normal paper in the top tray and thick 6x4 borderless glossy photo paper in the bottom tray of a Canon IP4000. Currently I cannot print with *any* gnome based program (including gimp) on the bottom tray - whether I select it or not.

KDE programs - meanwhile - work flawlessly. But I don't want to use KDE.

Martin Pitt (pitti) wrote :

 libgnomeprint (2.12.1-3ubuntu2) dapper-updates; urgency=low
 .
   * Add debian/patches/cups-transport.patch:
     - Teach libgnomeprint to respect the settings made in the printing options
       dialog.
     - Many thanks to Pascal De Vuyst for this patch!
     - Closes: LP#34112 and the longest list of duplicates ever.

Changed in libgnomeprint:
status: Fix Committed → Fix Released

Many Thanks Pascal De Vuyst !

Thanks for including this patch in dapper-updates.

@Dirk
Tray selection in libgnomeprint based apps should have worked before the patch and still should work with the patch.
I can't test this since I have a printer that has only one tray. Looking at foomatic-rip.log this should work since the option InputSlot is applied, can somebody verify that tray selection works?
If you still have the problem you should file a seperate bug report indicating that tray selection does not work for you specific printer model.

Dirk (ubuntu-tobit) wrote :

@Pascal

I have not yet tried the patch, but the only printing that ever happens in the current issue ubuntu is the whatever the default is for that printer. You cannot change it with the gnome printer dialog. Any changes/options one makes in the dialog is ignored. If the default is A4 600 dpi plain paper from the top tray, then that is what you get - regardless that you select 6x4, 2400 dpi, glossy photopaper from the bottom tray.

@Dirk

Please file a seperate bug report for this.

@Martin
The updated package is still not available from the archives. Any idea why?
Should we not mark this bug as "fix committed" until the fix has actually been released. This would allow people to still find the bug and avoid duplicates.

Martin Pitt (pitti) wrote :

Pascal: the package is available for quite some time now. "Fix committed" means I have a fix and prepared a package to upload. "Fix released" means it's in the archive.

Martin Pitt (pitti) wrote :

Sorry, the archive still does not have fixed binaries. Only the source is on the mirror, apparently the buildds need a manual kick to actually built the new package. Reopening bug until that's fixed.

Changed in libgnomeprint:
status: Fix Released → Fix Committed
mannheim (kronheim) wrote :

Maybe I have messed up apt, or misunderstood. But I don't think that binary debs are in the archive.

If I do "apt-get source" then I do get a source tree which contains the patch. But I don't see the binary debs in

http://archive.ubuntu.com/ubuntu/pool/main/libg/libgnomeprint/

Changed in libgnomeprint:
status: Unknown → Confirmed
Whoopie (whoopie79) wrote :

Fix released. Thanks, Martin!

Changed in libgnomeprint:
status: Fix Committed → Fix Released
Junglebz (junglebz) wrote :

Guys ... I'm still having this issue in Ubuntu Dapper 6.06 and package libgnomeprint (2.12.1-3ubuntu2) installed.

Could anyone help me with this?

Thanks.
Fernando.

@Junglebz

I believe the patch fixes printing for libgnomeprint based applications as far as it can be fixed, many people have confirmed it.
Perhaps you have a different issue that is only related to your printer model. You are not being very specific, please help us first by providing more information.
What printer model do you have? What application(s) did you try to print from?
The patch normally solves several issues, can you give examples of issues you still have (e.g. printer quality set in gnome-cups-manager not respected).

Vincenzo Ciancia (vincenzo-ml) wrote :

I have libgnomeprint2.2-0 version 2.12.1-3ubuntu, my lpoptions file has been set up by the gnome printer configuration interface, it contains Dest lj5 Duplex=DuplexNoTumble, I just removed and added the printer again, but it prints single-sided. Kde applications and firefox print double-sided.

Ante Karamatić (ivoks) wrote :

2.12.1-3ubuntu1 or 2.12.1-3ubuntu2?

Tormod Volden (tormodvolden) wrote :

Vincenzo, you are probably victim of the most irritating "feature" of dpkg -l, it silently truncates the output strings. Use "dpkg -l libgnomeprint2.2-0 | cat" or make a wide terminal window to see the complete version string.

Vincenzo Ciancia (vincenzo-ml) wrote :

Sorry for the late reply, I forgot to check the "e-mail me about changes" checkbox. I just tested that I still have the bug (removed and added the printer again) and that I have 2.12.1-3ubuntu2 - sorry for the inconvenience. This bug is really irritating, please tell me anything I can do to provide more information.

Marcin Białoń (mbialon) wrote :

Yesterday I checked this in a new, clean install of Dapper (libgnomeprint 2.12.1-3ubuntu2) and everything works fine.

Dirk (ubuntu-tobit) wrote :

Well I am using 2.12.1-3ubuntu2 and it (specifically selecting duplex for a print from the dialog box) does *not* work (and never has). However, as far as I can tell, paper selection and all the other options now *do* work.

Since the duplex check box is on a different screen to all the others, could it simply be that it has got overlooked?

Just a reminder: duplex printing is working in kde programs and manually with lpr with the "-o sides=two-sided-long-edge" option.

@Vincenzo and Dirk
Please provide the following information:
1) Your printer model and the driver you use.
2) Tell us in which application(s) duplex printing does not work.
3) Please debug foomatic-rip to find out more: edit /etc/foomatic/filter.conf and set debug: 1. Print a document with duplex activated from gedit or evince. After printing attach the file /tmp/foomatic-rip.log here.

@Dirk
Does tray selection work for your printer after the update to libgnomeprint 2.12.1-3ubuntu2?

Simon Law (sfllaw) on 2006-07-10
Changed in libgnomecups:
importance: Untriaged → Medium
status: Unconfirmed → Fix Released
Changed in libgnomeprint:
status: Confirmed → Needs Info
Changed in libgnomeprint:
status: Needs Info → Rejected
Changed in libgnomeprint:
status: Rejected → Fix Released
Huygens (huygens-25) wrote :

Very weird, I have the problem yet again with evince 0.8 (Ubuntu Feisty Fawn).
My printer is an HP Laserjet 4345 and is configured in CUPS with the duplex mode. I can print with OpenOffice.org or other applications with the two side printed. However, if I open a PDF with Evince (the default), when I want to print I have only the "one-sided" possibility for the "two-sided" option (in Page set-up of the HP printer).
In all application I can print two-sided but Evince :-(

Alexander Papaspyrou (lxndrp) wrote :

I can confirm this, using Feisty with evince-0.8.1 with a HP LaserJet 4050. All other apps do duplex perfectly, just evince doesn't.

However, this seems to be a gnome-cups-admin issue. Although I setup my printer settings with the GNOME printer setup tool, none of the settings have been propagated to CUPS correctly. After setting things up via the CUPS web frontend, evince recognizes everything in the correct way and seems to work.

maybee (chuan137) wrote :

I have the same problem with evince-0.8-1.

"After setting things up via the CUPS web frontend, evince recognizes everything in the correct way and seems to work."

How is that done?

@Alexander Papaspyrou and maybee
This is a different issue that has been reported as bug #111964, please add further comments there.

Changed in libgnomeprint:
status: Fix Released → In Progress
Changed in libgnomeprint:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.