gnome-session-flashback/Unity fails to start without hardware acceleration in cloud/remote environments (Forwarded-X/XRDP/VNC/NX/X2GO/Chromoting)

Bug #1251281 reported by Roman Bazalevsky on 2013-11-14
786
This bug affects 161 people
Affects Status Importance Assigned to Milestone
gnome-session
Fix Released
Medium
gnome-flashback (Ubuntu)
Vivid
Medium
Unassigned
gnome-session (Debian)
New
Unknown
gnome-session (Ubuntu)
Critical
Unassigned
Trusty
Critical
Unassigned
Utopic
Critical
Unassigned
Vivid
Critical
Unassigned

Bug Description

== Impact ==
It was impossible to launch a gnome-session-based desktop on a system where hardware accelerations is not available (such as old hardware, or when using a remote desktop).

That looks like a quite popular use case — more than a hundred of people marked this bug as affecting them.

== Test Case ==
The original bug description below contains a test case.

== Proposed Fix ==
The fix backports an upstream commit which adds --disable-acceleration-check commandline option, and makes Upstart user session pass that flag to gnome-session when the session is gnome-fallback (aka gnome-flashback-metacity). Of course, that option can be used with other sessions as well.

This was fixed in vivid in version 3.14.0-2ubuntu4.

== Regression Potential ==
The option was accepted upstream, and nobody complained so far. So the regression potential should be low.

This bug will cause static grey or black screen instead of opening remote session using Forwarded-X/XRDP/VNC/NX/X2GO/Chromoting from x2goclient, rdpclient(reminna/vinagre/mstsc), SSH, VNC, NOMACHINE and etc.

== Original Description ==
1) lsb_release -rd
Description: Ubuntu 14.04 LTS
Release: 14.04

2) apt-cache policy gnome-session
gnome-session:
  Installed: 3.9.90-0ubuntu12
  Candidate: 3.9.90-0ubuntu12
  Version table:
 *** 3.9.90-0ubuntu12 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen is when one installs xrdp on the host and attempts to use remmina or vinagre on a Ubuntu 14.04 client to RDP in, it works.

4) What happens instead is it shows a gray static screen as per attached screenshot. This would appear an issue with gnome-session as per client log:
cat .xsession-errors.old
Script for ibus started at run_im.
Script for auto started at run_im.
Script for default started at run_im.
init: indicator-application main process ended, respawning
init: indicator-application main process ended, respawning
init: indicator-application respawning too fast, stopped
Xsession: X session started for at Sun Jul 20 15:25:59 CDT 2014
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 109 (X_ChangeHosts)
  Value in failed request: 0x5
  Serial number of failed request: 6
  Current serial number in output stream: 8
localuser:moniker being added to access control list
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 109 (X_ChangeHosts)
  Value in failed request: 0x5
  Serial number of failed request: 6
  Current serial number in output stream: 8
Script for ibus started at run_im.
Script for auto started at run_im.
Script for default started at run_im.
Script for ibus started at run_im.
Script for auto started at run_im.
Script for default started at run_im.
gnome-session-is-accelerated: No composite extension.
gnome-session-check-accelerated: Helper exited with code 256
gnome-session-is-accelerated: No composite extension.
gnome-session-check-accelerated: Helper exited with code 256

** (process:2565): WARNING **: software acceleration check failed: Child process exited with code 1

** (x-session-manager:2565): CRITICAL **: We failed, but the fail whale is dead. Sorry....

The following is not a WORKAROUND, create /etc/xorg.conf :
Section "Device"
   Identifier "Intel Graphics"
   Driver "Intel"
   Option "DRI" "False"
EndSection

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: gnome-session 3.9.90-0ubuntu12
ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Jul 20 15:35:23 2014
InstallationDate: Installed on 2014-06-22 (28 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
PackageArchitecture: all
SourcePackage: gnome-session
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
Pasi Tarhonen (pasi-tarhonen) wrote :

.xsession-errors:

Xsession: X session started for at su 17.11.2013 22.30.16 +0200
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 109 (X_ChangeHosts)
  Value in failed request: 0x5
  Serial number of failed request: 6
  Current serial number in output stream: 8
localuser:pasi being added to access control list
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 109 (X_ChangeHosts)
  Value in failed request: 0x5
  Serial number of failed request: 6
  Current serial number in output stream: 8
Script for cjkv started at run_im.
Script for default started at run_im.
Script for cjkv started at run_im.
Script for default started at run_im.
gnome-session-is-accelerated: No composite extension.
gnome-session-check-accelerated: Helper exited with code 256
gnome-session-is-accelerated: No composite extension.
gnome-session-check-accelerated: Helper exited with code 256

** (process:18797): WARNING **: software acceleration check failed: Child process exited with code 1

** (gnome-session:18797): CRITICAL **: We failed, but the fail whale is dead. Sorry....

Same issue here. Is there a workaround for this?

One workaround is to install a different desktop environment - here's more info: http://c-nergy.be/blog/?p=4448

fmo (fmo) wrote :

I used to use FreeNX to connect to my desktop over SSH and it doesn't work anymore because of this bug.

Eugene San (eugenesan) on 2014-04-20
summary: - gnome-flashback (without effects) fails to start without hardware
- acceleration
+ gnome-flashback (metacity) fails to start without hardware acceleration,
+ cloud/remote environments (Forwarded-X, VNC and NX/X2GO)
description: updated
summary: gnome-flashback (metacity) fails to start without hardware acceleration,
- cloud/remote environments (Forwarded-X, VNC and NX/X2GO)
+ cloud/remote environments (Forwarded-X/XRDP/VNC/NX/X2GO/Chromoting)
Eugene San (eugenesan) on 2014-04-20
tags: added: regression-release trusty

Testing showed that disabling GL enforcement is not enough.
Seems like gnome-session-3.9.99 suffers from severe stability issues, it crashes frequently with GL enforcement disabled.
I've prepared back-ported from gnome 3.12 package:
https://launchpad.net/~eugenesan/+archive/ppa/+sourcepub/4095467/+listing-archive-extra
It contains a fix for GL enforcement (100_kill_gl_enforcement.patch) and upstream fixes, combined they solve the problem.

I hope package maintainers will find a way to "extract" the fix from the package above or import it to official repos.

Changed in gnome-session (Ubuntu):
status: Confirmed → Fix Committed
Maxim Kuvyrkov (maxim-kuvyrkov) wrote :

Hi Eugene,

Any user-friendly instructions on how to install packages from your PPA? Or which packages need to be replaced?

Thank you.

Eugene San (eugenesan) wrote :

@Maxim:
You can just use ppa with fixed packages:
$ apt-add-repository ppa:eugenesan/ppa
$ apt-get update
$ apt-get upgrade
Note: ppa also contains unrelated to this bug packages, so be warned.

In addition you might take a look at the following article : http://www.webupd8.org/2014/04/how-to-install-and-tweak-gnome.html

This bug does also prevent starting the gnome fallback session on LTSP thin clients. The only way I got it to start is by forcing "DRI False" in xorg.conf. X will then not even try to use acceleration.
I will now try Eugenes PPA.

Eugene, your backports work. I (finally!) have accelerated graphics with LTSP!
That's great, I have been seaching for a solution of this bug literally for years!

Can you get this fix into the normal trusty sources?

Eugene San (eugenesan) wrote :

@ruediger.kupper, unfortunately that decision is not in my hands.

Ryan Tandy (rtandy) wrote :

Hi Eugene,

Can you please attach a debdiff of your proposed changes here, suitable for upload to utopic? If you mark it as a patch, a bot will subscribe the sponsors team and it will show up on their board for review. http://reqorts.qa.ubuntu.com/reports/sponsoring/ The queue is fairly long right now, but someone will review it eventually.

Status "Fix Committed" is appropriate once a fixed package is uploaded to utopic-proposed.

After the fix goes into Utopic (promoted from -proposed), we can follow the SRU process and get it backported to Trusty.

Thanks for working on this! I'm also interested in having gnome-flashback working over NX.

Changed in gnome-session (Ubuntu):
status: Fix Committed → Invalid
status: Invalid → Confirmed
status: Confirmed → In Progress
Eugene San (eugenesan) wrote :

Hi @Ryan,

Thanks for advice.
Unfortunately, fixing only gnome-session won't fix gnome-flashback.

Actually I've already fixed it in my PPA (ppa:eugenesan/ppa).
Among the changes are:
1. Migration from metacity to xfwm4.
2. Backporting and tweaking of: gnome-desktop3, gnome-panel, gnome-session, indicator-appmenu, ubuntu-themes.
3. Introduction of optional but highly recommended: gnome-wndow-applets, cardapio and gnome-flashback-desktop.

debdiffs and new packages are available in my PPA.
However, due to the nature and the amount of changes, we need maintainers of Ubuntu-UX and/or gnome-flashback(panel) to step in.

In mean time, anyone interested in "unity-2d" like environment for light/virtualized/NX/X/VNC desktop environments, can add my PPA and install gnome-flashback-desktop.

Dmitry Shachnev (mitya57) wrote :

Eugene's patch to gnome-session disables acceleration check for *all* sessions. I think it is still needed for gnome-shell, so we can't accept it to Ubuntu as-is.

Has anyone tried speak about this with upstream?

Did not check Eugene's patch, but my idea is simple. Just add extra command line option to allow disable acceleration check. If it is set, than check should not be made. For example --disable-acceleration-check. Than sessions who need it could add that in .desktop file: gnome-session --session=gnome-flashback --disable-acceleration-check

Thanks, folks, for getting this into action. Meanwhile, here's a problem related to Eugene's backport:

Eugene provides a backport of gnome-session 3.12, but this package has a bug: the "gnome-session-quit" command is broken. This prevents that users from logging out of the session. The problem is described here:
https://bbs.archlinux.org/viewtopic.php?pid=1344528#p1344528 (see comment 4: the logout dialog was removed with gnome-session 3.12).
So Eugenes fix currently introduces another bug. Looks we need to choose: Have acceleration but no logout, or the other way round :-(

Michael Pabst (celestius) wrote :

Hey @eugenesan - I followed your instructions on installing your patched packages, but it was still not working for me, at least using tightvncserver on a newly-created EC2 instance running Trusty. Is there anything I need to do other than pass --session=gnome-flashback as the argument to gnome-session ? Thanks for supplying this, btw.

Eugene San (eugenesan) wrote :

Hi all,

I've reworked my solution and now, I guess, at least parts of it are ready to be merged as SRU.

Summary:
* gnome-{session,desktop} - No backports this time, only bug fixing patches.
* metacity - Backport fresh gtk3 port with composting support and no artifacts.
* gnome-panel - Backport new upstream snapshot and follow upstream guidelines in Ubuntu packaging. For example provide only gnome-flashback.
* indicator-appmenu - Fix missing appmenu support for non-LightDM started sessions.
* ubuntu-themes - Add support of XFWM4 (in case some one still would prefer it over new fixed Metacity).
* gnome-window-applets - New package to mimic Unity style window controls on panel.
* cardapio - New package for main menu replacement with search capabilities (similar to Whisker from Xubuntu).
* gnome-flashback-desktop - New meta package for unity like environment (installs all of the above).

Packages:
https://launchpad.net/~eugenesan/+archive/ppa/+packages?field.name_filter=gnome&field.status_filter=published&field.series_filter=trusty
https://launchpad.net/~eugenesan/+archive/ppa/+packages?field.name_filter=meta&field.status_filter=published&field.series_filter=trusty

Notes:
* If you still want to use official gnome-panel packages you might want to comment out gnome-fallback in /etc/upstart-xsessions.
* Solution works mainly due addition of 0105_gsm-presence-check-also-monitor.patch (will be reported upstream) and 0104_cmdline_option_disable-acceleration-check.patch (thanks to albertsmuktupavels).
* I am still looking for a solution for missing NetworkManager applet and inability to mount media. Seems like polkit settings are to blame for that. Many permissions are defined only for active users, while "virtual" sessions' users registered as non-active. It would be nice if someone could provide a solution.
* I've tested above changes only with x2go and natively.
* If you installed previously backported packages from my PPA, you will need to downgrade them manually or "re-install" my PPA using ppa-purge and add-apt-repository.

Sorry for the bother, but are there any plans to get this fix into upstream on Ubuntu 14.x? This is the one thing holding many of us up from upgrading and we are getting nervous because of End-of-Updates coming so soon on Ubuntu 12.x.

description: updated
Changed in gnome-session (Ubuntu):
importance: Undecided → High
status: In Progress → Triaged
summary: - gnome-flashback (metacity) fails to start without hardware acceleration,
- cloud/remote environments (Forwarded-X/XRDP/VNC/NX/X2GO/Chromoting)
+ xrdp from gnome-session-fallback shows static gray screen via remmina or
+ vinagre
Changed in gnome-session:
importance: Unknown → Medium
status: Unknown → New
Eugene San (eugenesan) on 2014-08-17
summary: - xrdp from gnome-session-fallback shows static gray screen via remmina or
- vinagre
+ gnome-flashback fails to start without hardware acceleration,
+ cloud/remote environments (Forwarded-X/XRDP/VNC/NX/X2GO/Chromoting)
description: updated
Eugene San (eugenesan) on 2014-08-17
description: updated
summary: - gnome-flashback fails to start without hardware acceleration,
+ gnome-session-flashback fails to start without hardware acceleration in
cloud/remote environments (Forwarded-X/XRDP/VNC/NX/X2GO/Chromoting)

Eugene,
I have purged and re-installed your PPA as you suggest in comment #20, but the problem is back:
The session does never start, and in ~/.xsession-errors I see:

  gnome-session-flashback (3.8.0): attempting to launch gnome-session at 2014-09-22T13:14:34+0200
  gnome-session-is-accelerated: No hardware 3D support.
  gnome-session-check-accelerated: Helper exited with code 256
  gnome-session-is-accelerated: No hardware 3D support.
  gnome-session-check-accelerated: Helper exited with code 256

  ** (process:12360): WARNING **: software acceleration check failed: Child process exited with code 1

  ** (gnome-session:12360): CRITICAL **: We failed, but the fail whale is dead. Sorry....

Has something changed with your PPA?

Eugene San (eugenesan) wrote :

Rüdiger Kupper:
Recently I've updated gnome-flashback related packages to align with recent changes in Utopic/Sid.
Now acceleration check is skipped automatically for flashback/fallback sessions and still can be disabled explicitly.

Packages should be fine now, but there is a chance reinstall of the ppa might be needed.

P.S.
* x2go users should use flashback session instead of default fallback, since fallback session "hijacked" by upstart and therefor is broken.
* decorations in flashback-compiz session are missing ubuntu styling (probably missing schemes due to gconf->gsettings migration).

Dmitry Shachnev (mitya57) wrote :

> decorations in flashback-compiz session are missing ubuntu styling (probably missing schemes due to gconf->gsettings migration).

It is not missing schemes, we need lp:~albertsmuktupavels/compiz/gtk-window-decorator-4 merged into compiz to restore theme support (it was lost during metacity gtk2→gtk3 switch).

Fix for compiz is already in proposed.

Eugene:
> Now acceleration check is skipped automatically for flashback/fallback sessions and still can be disabled explicitly.

How would I disable it explicitly?

Chris Good (chris-good) wrote :

Would someone please explain what the problem is in simple terms?
I thought it was that Unity in Ubuntu 14.04 requires 3D acceleration but if so, why does Unity work when run in VirtualBox without 3D acceleration, and also when run in a VMware VM in a vSphere console?

1 comments hidden view all 107 comments
Eugene San (eugenesan) wrote :

ruediger.kupper:
Acceleration check can be skipped by passing --disable-acceleration-check to gnome-session

chris-good:
I might be wrong but by 3D acceleration, VM hypervizors usually mean H/W 3D offloading to host GPU.
Also usually VM para-virtualized drivers support direct rendering and all most X11 extensions which can be used by Mesa (pure software or LLVM-pipe) to simulate 3D.
Regarding Unity, it uses Compiz which also supports Mesa simulated 3D (at least in recent versions).
Environments like NX/VNC/RDP and etc, usually lack direct rendering and most X11 extensions therefor 3D simulation is broken.
It's sad that this fact is ignored by distributions and desktop environments developers and we are enforced to deal with it here :-(

On Sat, Sep 27, 2014 at 6:54 PM, Chris Good <email address hidden> wrote:
> Would someone please explain what the problem is in simple terms?
> I thought it was that Unity in Ubuntu 14.04 requires 3D acceleration but if so, why does Unity work when run in VirtualBox without 3D acceleration, and also when run in a VMware VM in a vSphere console?

On Fri, Oct 3, 2014 at 1:33 AM, Eugene San <email address hidden> wrote:
> chris-good:
> I might be wrong but by 3D acceleration, VM hypervizors usually mean H/W 3D offloading to host GPU.
> Also usually VM para-virtualized drivers support direct rendering and all most X11 extensions which can be used by Mesa (pure software or LLVM-pipe) to simulate 3D.
> Regarding Unity, it uses Compiz which also supports Mesa simulated 3D (at least in recent versions).
> Environments like NX/VNC/RDP and etc, usually lack direct rendering and most X11 extensions therefor 3D simulation is broken.
> It's sad that this fact is ignored by distributions and desktop environments developers and we are enforced to deal with it here :-(

Greetings from an X2Go developer,

This isn't a simple explanation, but it is as simple as I could make
it without losing important details.

On recent Linux distros, llvmpipe can provide software 3D rendering.
However, in order for 3D rendering to work with GNOME3 (and with many
other 3d programs), you *also* need an X server with good enough
support for the GLX extension. The X server needs to support the GLX
extension in the 1st place, and it needs to support a new enough
version of the GLX extension.

The current version of GLX is 1.4. I just checked: Both Ubuntu 12.04
and 14.04 have GLX 1.4 support in their X.org server.

X2Go (whose X server is nxagent 3.5.0.x) only supports GLX 1.2, You
can verify this by running the "glxinfo" command under X2Go. GLX 1.2
is not new enough for GNOME3, and thus X2Go is affected by this bug.

TightVNC 1.3.9-6.4ubuntu1 (in Ubuntu 14.04) is also affected because
it does not support GLX at all. You can verify this by running the
"glxinfo" command under a TightVNC server.

TigerVNC 1.3.0 (in Fedora 20) does support GLX 1.4. Therefore, it is
not affected; you can run GNOME3 under TigerVNC 1.3.0 (and possibly
prior versions.) I just tested this on both a physical Fedora 20
machine with 3D graphics hardware, and on a Fedora 20 VM whose
hypervisor does not provide 3D support.

When you running Ubuntu 12.04 or 14.4 under the VMware vSphere
console, the regular X.org X server is running, and that X server
supports GLX 1.4. VMware vSphere (ESXi) can provide 3D hardware
acceleration under certain setups, but in the absence of 3D, the guest
OS simply uses llvmpipe. In either case, the guest OS thinks the
vSphere console is its "local display".

The composite extension is also a limitation of many X servers. I am
not sure if the version needs to be new enough, or if the extension
simply needs to be present.

-Mike

Hello,

I'm sorry to bother, I know that practically the same question was asked a few months ago by Nicholas DiPiazza, but it wasn't directly answered. - Is there any time frame to fix this problem in the "official" distribution of "Trusty"? Similarly to what was said previously - this is the main reason we cannot upgrade to 14.04 from 12.04. It's absolutely critical for us to use remote sessions using NX (or any other method to have remote gnome session that would provide speed as good as NX does).

Thank you,
Michael.

Chris Good (chris-good) wrote :

Hi eugenesan & mikedep333,

Thanks very much for your explanations. Based on them I've done more research and now understand much better. Very interesting! Sorry for the late reply - I've been on holidays.

Changed in gnome-session:
status: New → Fix Released

Patch for gnome-session was accepted. :)

Should I add --disable-acceleration-check to metacity session only or this is needed for compiz session too? Will be in 3.16.

Dmitry Shachnev (mitya57) wrote :

No, I think Compiz won't work without hardware acceleration. So only for Metacity.

On Tue, Nov 25, 2014 at 12:32 AM, Dmitry Shachnev <email address hidden> wrote:
> No, I think Compiz won't work without hardware acceleration. So only for
> Metacity.

I just tested compiz 0.8.8.28.fc21 on Fedora 21 and I can confirm that
it does require the GLX extension.

So I agree that we should only add that option for metacity sessions.

Hi,

Would, please, someone clarify for users whether the fix will be backported to trusty's gnome-session or to any other released ubuntu version?

Thank you.

Dmitry Shachnev (mitya57) wrote :

Maxim, that will be unlikely, as the fix is actually a “feature” (it adds new commandline option). But I hope we will have new gnome-session in Vivid, where this will be fixed.

tags: added: cherry-pick

Importance Critical as it fits the following criteria:
+ "A bug which has a severe impact on a large portion of Ubuntu users" -> Anyone using Unity, gnome-shell, gnome3, etc.
+ "Renders the system temporarily or permanently unusable." Not being able to remote in via all the applicable remote access protocols renders Ubuntu largely useless at the workstation level for enterprises (as well as those setting up home LANs), as they cannot provide the expected remote support.
+ "Severely affects applications beyond the package responsible for the root cause." Not being able to remotely connect to Ubuntu would fit this criteria. While one may use Kubuntu, or Xubuntu as a WORKAROUND, this would not help those folks who have to disrupt their environments (re-install/change desktop environments) to obtain this outcome, or who want to retain their 5 year support on an LTS in the case of Xubuntu.

As this has been fixed upstream as per attachment https://bugzilla.gnome.org/attachment.cgi?id=290278 , this should at least be given an opportunity to test in the Proposed repository to see if it resolves our issue here in Ubuntu.

Changed in gnome-session (Ubuntu):
importance: High → Critical
summary: - gnome-session-flashback fails to start without hardware acceleration in
- cloud/remote environments (Forwarded-X/XRDP/VNC/NX/X2GO/Chromoting)
+ gnome-session-flashback/Unity fails to start without hardware
+ acceleration in cloud/remote environments
+ (Forwarded-X/XRDP/VNC/NX/X2GO/Chromoting)
tags: added: utopic vivid
tdeering (tomdeering7) wrote :

Eugene's PPA doesn't seem to fix this for me on 14.10. If I log in with NX and "gnome-session --session=gnome-flashback", I still get a black screen. Am I missing something? Or were the fixes only intended to work with 14.04?

tags: added: patch
Changed in gnome-session (Debian):
status: Unknown → New
Rolf Leggewie (r0lf) on 2015-03-18
Changed in gnome-session (Ubuntu Vivid):
milestone: none → ubuntu-15.03
Changed in gnome-session (Ubuntu Trusty):
milestone: none → ubuntu-14.04.3
Changed in gnome-session (Ubuntu Vivid):
status: Triaged → Fix Released
Changed in gnome-session (Ubuntu Utopic):
importance: Undecided → Critical
status: New → Triaged
Changed in gnome-session (Ubuntu Trusty):
importance: Undecided → Critical
status: New → Triaged
description: updated
Changed in gnome-session (Ubuntu Utopic):
status: Triaged → In Progress
Changed in gnome-session (Ubuntu Trusty):
status: Triaged → In Progress
Changed in gnome-panel (Ubuntu Vivid):
importance: Undecided → Critical
status: New → Triaged
Changed in gnome-panel (Ubuntu Utopic):
importance: Undecided → Critical
status: New → Triaged
Changed in gnome-panel (Ubuntu Trusty):
importance: Undecided → Critical
status: New → Triaged
Changed in gnome-panel (Ubuntu Trusty):
importance: Critical → Medium
status: Triaged → Incomplete
Changed in gnome-panel (Ubuntu Utopic):
importance: Critical → Medium
status: Triaged → Incomplete
Changed in gnome-panel (Ubuntu Vivid):
importance: Critical → Medium
status: Triaged → Incomplete
Changed in gnome-panel (Ubuntu Trusty):
status: Incomplete → Triaged
Changed in gnome-panel (Ubuntu Utopic):
status: Incomplete → Triaged
Changed in gnome-panel (Ubuntu Vivid):
status: Incomplete → Triaged
Changed in gnome-panel (Ubuntu Vivid):
status: Triaged → Invalid
Changed in gnome-session (Ubuntu Utopic):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in gnome-session (Ubuntu Trusty):
status: In Progress → Fix Committed
no longer affects: gnome-panel (Ubuntu Utopic)
no longer affects: gnome-panel (Ubuntu Trusty)
no longer affects: gnome-panel (Ubuntu)
affects: gnome-panel (Ubuntu Vivid) → gnome-flashback (Ubuntu Vivid)
Changed in gnome-flashback (Ubuntu Vivid):
status: Invalid → Triaged
Changed in gnome-flashback (Ubuntu Vivid):
milestone: none → ubuntu-15.03
Changed in gnome-flashback (Ubuntu Vivid):
status: Triaged → Fix Released
27 comments hidden view all 107 comments
Xavier (xavier-depedro) wrote :

Hi there:

I was also affected by this type of back when attemtping to connecto to a Lubuntu 14.04 server with X2Go server there (and from a Ubuntu 14.04 with Unity and X2Go client, in case this matters). Things were working as expected yesterday (no patches needed), when I was setting up the whole server (X2Go, plus a few other server settings needed for ISPConfig, Backintime, etc)

Since today I could not login thorugh X2Go using the same connetion to LXDE that I was using yesterday (message shown today just after the connection attempt: "Unable to execute: startlxde"), I found this bug report, and after enabling the extra repo trusty-proposed, I installed the gnome-session-bin from there and gnome-session-flashback from standard ubuntu repos. But it was not enough, it seems: I could see the screen a little bit more evolved (blueish instead of fully black as before), but not enough. The errors shown server side at ~/.xsession-x2go-errors were the ones shown in the attached document, corresponding to the attempts to connect with a custom-desktop definition as:

gnome-session --session=gnome-flashback --disable-acceleration-check

After adding the repo ppa:rtandy/flashback, and upgrading packages gnome-desktop3-data & libgnome-desktop-3-7, I was able to connect again with X2Go and standard LXDE as a session, and no more errors shown in the ~/.xsession-x2go-errors.

My commands in case anyones is looking for easy copy&paste of workaround:

sudo add-apt-repository ppa:rtandy/flashback
sudo apt-get update
sudo apt-get upgrade gnome-desktop3-data libgnome-desktop-3-7

I wonder if the addition of trusty-proposed was really necessary.

Ryan Tandy (rtandy) wrote :

Marking verified, based on my own testing and on Xavier's confirmation that 'gnome-session --disable-acceleration-check' works for him in trusty.

Xavier: right now 'gnome-session --disable-acceleration-check' is only supported in trusty-proposed, as soon as it's released to -updates that won't be needed any more.

tags: added: verification-done
removed: verification-needed
Xavier (xavier-depedro) wrote :

thanks for the info (and your work, all) to fix this issue and provide workarounds in the meantime.

Ubuntu LTS and the ecosystem around it (launchpad, repos, community, etc) rock! :-)

  Did reasonably extensive testing last night of the proposed fix for
Trusty.
I believe that my results are very similar to Xavier: after I installed all
updates related to this bug from trusty-proposed repository (pre-released)
I couldn't start remote X2go session at all. In /var/log/messages I found
information about segfault in libgnome-desktop-3-7:

Apr 1 05:17:12 marina-net /usr/bin/x2goruncommand: launching session
with Xsession-x2go mechanism, using STARTUP="gnome-session
--session=gnome-flashback --disable-acceleration-c\
heck"
Apr 1 05:17:20 marina-net kernel: [ 1747.973711] gnome-session[7806]:
segfault at 18 ip 00007fc4c3952196 sp 00007fff7f38a820 error 4 in
libgnome-desktop-3.so.7.0.0[7fc4c3930000+3\
1000]

  It appears that libgnome-desktop-3-7 wasn't update since July of 2014
and its
version was 3.8.4-0ubuntu3. So I installed updates from
ppa:rtandy/flashback
repository according to Xavier instructions, which includes updating
libgnome-desktop-3-7. After update the version of libgnome-desktop-3-7
became 3.8.4-0ubuntu4. Actually it updated 16 other packages as well at
that time. After this update everything began working very well.
  So my conclusion is that the fix in the trusty-proposed repository as
it stands
there right now is not helpful at all, but the version in
ppa:rtandy/flashback
repository works fine.

Thank you,
Michael.

On 01.04.15 03:30, Xavier wrote:
> thanks for the info (and your work, all) to fix this issue and provide workarounds in the meantime.
>
> Ubuntu LTS and the ecosystem around it (launchpad, repos, community, etc) rock! :-)
>

"So my conclusion is that the fix in the trusty-proposed repository as it stands there right now is not helpful at all, but the version in ppa:rtandy/flashback repository works fine."

Not helpful? Without fix in trusty-proposed gnome-session will not start session... Segfault in libgnome-desktop is another bug/problem and is not directly related to this bug. And probably should be reported as separate/new bug.

Ryan Tandy (rtandy) wrote :

On Wed, Apr 01, 2015 at 08:12:23PM -0000, Michael Plotkin wrote:
>Apr 1 05:17:12 marina-net /usr/bin/x2goruncommand: launching session
>with Xsession-x2go mechanism, using STARTUP="gnome-session
>--session=gnome-flashback --disable-acceleration-c\
>heck"
>Apr 1 05:17:20 marina-net kernel: [ 1747.973711] gnome-session[7806]:
>segfault at 18 ip 00007fc4c3952196 sp 00007fff7f38a820 error 4 in
>libgnome-desktop-3.so.7.0.0[7fc4c3930000+3\
>1000]

This is bug 1416081.

> So my conclusion is that the fix in the trusty-proposed repository as
>it stands
>there right now is not helpful at all

Not true. Your STARTUP above includes '--disable-acceleration-check'
which was only added in the version currently in trusty-proposed.

> gnome-session-flashback/Unity fails to start without hardware
> acceleration in cloud/remote environments
> (Forwarded-X/XRDP/VNC/NX/X2GO/Chromoting)
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/gnome-session/+bug/1251281/+subscriptions

On Wed, Apr 01, 2015 at 08:36:48PM -0000, Alberts Muktupāvels wrote:
>Segfault in libgnome-desktop is another bug/problem and is
>not directly related to this bug. And probably should be reported as
>separate/new bug.

Already fixed in vivid, and proposed patches for SRU. Any help getting
those uploaded would be tremendously welcome. :)

Michael Plotkin (plotkin) wrote :

I'm sorry - I don't understand this at all: local gnome-session always
worked
all right without this fix in trusty-proposed, and the remote gnome-session
doesn't start at all with this fix in trusty-proposed but without other
changes
from ppa:rtandy/flashback repository. At least this was my result...

On 4/1/2015 4:36 PM, Alberts Muktupāvels wrote:
> "So my conclusion is that the fix in the trusty-proposed repository as
> it stands there right now is not helpful at all, but the version in
> ppa:rtandy/flashback repository works fine."
>
> Not helpful? Without fix in trusty-proposed gnome-session will not start
> session... Segfault in libgnome-desktop is another bug/problem and is
> not directly related to this bug. And probably should be reported as
> separate/new bug.
>

Ryan Tandy (rtandy) wrote :

Hi all,

The patches that were in my PPA (ppa:rtandy/flashback) are now in trusty-proposed and utopic-proposed; so if you were using those packages, please head over to bug 1416081, test the proposed packages, and leave your feedback there.

If you had the PPA packages installed, please ensure you _downgrade_ to the proposed packages as the version in -proposed is lower than what was in the PPA. ppa-purge may help with that. (My bad; will choose ppa versions more carefully next time.)

Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.9.90-0ubuntu12.1

---------------
gnome-session (3.9.90-0ubuntu12.1) trusty; urgency=medium

  [ Tim Lunn ]
  * debian/patches/103_kill_the_fail_whale.patch: fix logic gnome-session
    should die at this point. This will fix LP: #1236749,
    LP: #1385572 and possibly various other strange bugs

  [ Ryan Tandy ]
  * debian/patches/git_add_disable_acceleration_option.patch: Backport
    upstream patch to add a --disable-acceleration-check command-line option.
    (LP: #1251281)
  * debian/gnome-session-bin.user-session.upstart: Disable acceleration check
    when launching a GNOME Flashback (Metacity) session.
 -- Dmitry Shachnev <email address hidden> Sat, 21 Mar 2015 15:49:36 +0300

Changed in gnome-session (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-session has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.9.90-0ubuntu16.1

---------------
gnome-session (3.9.90-0ubuntu16.1) utopic; urgency=medium

  [ Tim Lunn ]
  * debian/patches/103_kill_the_fail_whale.patch: fix logic gnome-session
    should die at this point. This will fix LP: #1236749,
    LP: #1385572 and possibly various other strange bugs

  [ Ryan Tandy ]
  * debian/patches/git_add_disable_acceleration_option.patch: Backport
    upstream patch to add a --disable-acceleration-check command-line option.
    (LP: #1251281)
  * debian/gnome-session-bin.user-session.upstart: Disable acceleration check
    when launching a GNOME Flashback (Metacity) session.
 -- Dmitry Shachnev <email address hidden> Sat, 21 Mar 2015 15:49:36 +0300

Changed in gnome-session (Ubuntu Utopic):
status: Fix Committed → Fix Released
martin lantz (martin-lantz) wrote :

Hello,

I am a bit confused on what to expect with the bug fixes that just have been released.

I have NX version 3.5 installed on a Ubuntu 14.04 server. I have just install the relevant version of the packages discussed above.

I can login successfully running the following command "/etc/X11/Xsession mate-session"

But when I login using "/usr/bin/gnome-session --session=gnome-flashback --disable-acceleration-check" the desktop appears but there is no menu and no unity launcher.

Is this what I should expect or is there something else that I am is missing?

Kind regards,
Martin

On Wed, Apr 22, 2015 at 06:04:55PM -0000, martin lantz wrote:
>I have NX version 3.5 installed on a Ubuntu 14.04 server. I have just
>install the relevant version of the packages discussed above.
>
>I can login successfully running the following command
>"/etc/X11/Xsession mate-session"
>
>But when I login using "/usr/bin/gnome-session --session=gnome-flashback
>--disable-acceleration-check" the desktop appears but there is no menu
>and no unity launcher.

Unity does not work under NX 3.5. These changes do not address that.

You should be seeing the classic GNOME desktop with panels on top and
bottom. I've just tested the same gnome-session command you mentioned
under x2goserver (based on NX 3.5) and it works.

Please double-check the versions of the relevant packages:
- gnome-session-bin 3.9.90-0ubuntu12.1
- libgnome-desktop-3-7 3.8.4-0ubuntu3.1

If you still have problems, please log into your NX with just "xterm" as
the command (or "gnome-terminal"), run your gnome-session command in
that terminal, and pastebin the output somewhere.

gnome-session was aborting if acceleration check failed. This bug was about fixing it so it is possible to bypass this check. Bypassing this check allows gnome-session to start.

You need to use session that does not require hardware acceleration, but from you comment - you are using. As Ryan already told - you need to get and paste log file to find why session does not fully start.

lightdm and other display manager are setting environment variables - this might be your problem.

One thing you could try is to add this line before /usr/bin/gnome-session line:
export XDG_CURRENT_DESKTOP="Unity"

Then you will need also this line:
export XDG_MENU_PREFIX="gnome-flashback-"

Also you could add --debug to gnome-session line as it might show some info why needed components are not started.

martin lantz (martin-lantz) wrote :

Hello Ryan and Alberts,

I double-checked and I do have the mentioned versions of the relevant packages installed:
- gnome-session-bin 3.9.90-0ubuntu12.1
- libgnome-desktop-3-7 3.8.4-0ubuntu3.1

I logged into NX using gnome-terminal. From there I run:
/usr/bin/gnome-session --session=gnome-flashback --disable-acceleration-check &> gnome-session.log.0

The desktop background image appears, but nothing else seems to work.

I uploaded gnome-session.log.0 here:
http://pastebin.com/tvVU2fMa

I also tried to log into NX using gnome-terminal and from there run:
export XDG_CURRENT_DESKTOP="Unity"
export XDG_MENU_PREFIX="gnome-flashback-"
/usr/bin/gnome-session --session=gnome-flashback --disable-acceleration-check &> gnome-session.log.1

Still, only the desktop background image appears, but nothing else seems to work.

I uploaded gnome-session.log.1 here:
http://pastebin.com/if7Cn0pF

What do you think I am doing wrong?

Kind regards,
Martin

What software should I install to use NX? I will try to reproduce problem...

Michael Plotkin (plotkin) wrote :

Just to reproduce the problem you are welcome to get it from
my ftp server: ftp://mplotkin.com
(login as anonymous).
Sorry, it can be slow - I am using a very old computer for ftp...
You need to install all three (appropriate of course) packages
on the server and just nxclient on the client.

Michael.

On 04/23/2015 08:21 AM, Alberts Muktupāvels wrote:
> What software should I install to use NX? I will try to reproduce
> problem...
>

Ryan Tandy (rtandy) wrote :

On Thu, Apr 23, 2015 at 09:02:19AM -0000, martin lantz wrote:
>I logged into NX using gnome-terminal. From there I run:
>/usr/bin/gnome-session --session=gnome-flashback --disable-acceleration-check &> gnome-session.log.0
>
>The desktop background image appears, but nothing else seems to work.
>
>I uploaded gnome-session.log.0 here:
>http://pastebin.com/tvVU2fMa

Looks like the /etc/X11/Xsession wrapper is being used; it's trying to
launch an Upstart session. In this case you need to export:

DESKTOP_SESSION="gnome-fallback"
XDG_CURRENT_DESKTOP="Unity"

in order for the upstart Xsession.d scripts to work properly.

martin lantz (martin-lantz) wrote :

Hello Ryan and Alberts,

I figured out what was wrong.

Actually, gnome does start just fine by just running:
usr/bin/gnome-session --session=gnome-flashback --disable-acceleration-check

The screen resolution did not adjust to the monitor i am using and the menu just happened to be off screen. The mate session seams to adjust automatically.

(I did try to start using DESKTOP_SESSION="gnome-fallback" and the log was similar to what i have seen earlier)

Many thanks for all your help! It's really appreciated!

Kind regards,
Martin

Ryan Tandy (rtandy) wrote :

On Sat, Apr 25, 2015 at 08:51:37AM -0000, martin lantz wrote:
>The screen resolution did not adjust to the monitor i am using and the
>menu just happened to be off screen. The mate session seams to adjust
>automatically.

Ah, right. Yes, this is a known problem with GNOME3 under NX3 and its
derivatives:

https://www.nomachine.com/AR06J00636
http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=96

Glad you figured it out.

Chris Good (chris-good) wrote :

Hi people,

Thanks very much for all the help.

I can run gnome-flashback in Ubuntu 14.04.2 LTS (up to date) using xrdp/vnc now, but it is not workable yet.
I'm using Remote Desktop from Windows 7 to connect to Ubuntu.

The major problem is that logging out doesn't work. The window changes to a blank purple screen and never closes.
All the processes still seem to be running.

Installed are:

gnome-session-flashback 1:3.8.0-1ubuntu12.2
gnome-session 3.9.90-0ubuntu12.1

~/.xsession :
gnome-session --session=gnome-flashback --disable-acceleration-check

I have attached the

Chris Good (chris-good) wrote :

Oops, I should have posted the comment first before adding an attachment.
Here is the rest of comment #89:

I have attached the ~/.xsession-errors file.

The other problems are:

Many indicators do not work. eg nm-applet
I cannot type 's' in gnome-terminal - it keeps on opening the Applications menu.

Should I raise new bug(s) for these? This problem is sort of finished. Should a new bug be for gnome-session or xrdp?

Thanks again.

Dmitry Shachnev (mitya57) wrote :

> I cannot type 's' in gnome-terminal - it keeps on opening the Applications menu.

This is probably bug 1440570 (the Trusty fix is waiting in the queue).

For the rest please open new bugs.

Chris, you might need to add:
export DESKTOP_SESSION="gnome-fallback"
export XDG_CURRENT_DESKTOP="Unity"
before gnome-session line:
gnome-session --session=gnome-flashback --disable-acceleration-check

Chris Good (chris-good) wrote :

Hi Alberts Muktupāvels,

Thanks for the suggestion. I tried it but it hasn't made any difference. (I know the new environment values were used because I can see them in the environment when running terminal in the gnome desktop). The messages in .xsession-errors are in a different order but seem to be the same.

I have attached the latest ~/.xsession-errors file.

Chris Good (chris-good) wrote :

Created bug https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1450279 for the logout problem in comment #89.

Pradeep Kumar (pradeep8985) wrote :

Sorry if i am re-asking again. Please let me know if the fix is released for the below versions. I could still see gray screen after logging in. If it is released , Kindly let me know how to fix the same.

# lsb_release -rd
Description: Ubuntu 14.04.3 LTS
Release: 14.04

# apt-cache policy gnome-session
gnome-session:
  Installed: 3.9.90-0ubuntu12.1
  Candidate: 3.9.90-0ubuntu12.1
  Version table:
 *** 3.9.90-0ubuntu12.1 0
        500 http://in.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.9.90-0ubuntu12 0
        500 http://in.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

# apt-cache policy xrdp
xrdp:
  Installed: 0.6.0-1
  Candidate: 0.6.0-1
  Version table:
 *** 0.6.0-1 0
        500 http://in.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

Ryan Tandy (rtandy) wrote :

Hi Pradeep,

On Wed, Sep 16, 2015 at 06:14:21AM -0000, Pradeep Kumar wrote:
>Sorry if i am re-asking again. Please let me know if the fix is released
>for the below versions.

Yes, it looks like you have the fixed version.

>I could still see gray screen after logging in.
>If it is released , Kindly let me know how to fix the same.

Please ask for support in an appropriate venue:

http://www.ubuntu.com/support
http://ubuntuforums.org/
http://askubuntu.com/

I haven't looked at xrdp ever since working on this bug, but IIRC it did
still require a bit of configuration (see e.g. comment 58) and reading
of scripts to see how things are put together.

adrhc (adrhc) wrote :

Guys I have:

me@me-desktop:~$ uname -a
Linux me-desktop 3.19.0-30-generic #34-Ubuntu SMP Fri Oct 2 22:08:41 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
me@me-desktop:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 15.04
Release: 15.04
Codename: vivid

just updated and still can't connect with RDC from win7 to Ubuntu.
The RDC shows some logs then a gray screen then simply exits.
I noticed the "Fix Released" for Vivid but I don't know how to use it other than updating Ubuntu's packages.
Any hint ?

adrhc (adrhc) wrote :

There's also the "vivid gnome-session patch" but really I don't know what to do with it.

adrhc, as this report is closed, it has nothing to do with your problem.

If you have an issue with RDP'ing to Ubuntu while using gnome-session-flashback, you either haven't configured it properly (more likely as I can use Windows RDC to connect to Vivid using gnome-session-flashback just fine), or you have a corner case bug (not very likely).

Hence, please file a support request (not a bug report) via https://answers.launchpad.net/ubuntu/+source/gnome-panel/+addquestion . Please feel free to subscribe me to it.

adrhc (adrhc) wrote :

Thanks, but I said nothing about gnome-session-flashback.
I have no gnome-session-flashback and gnome-flashback package installed (also I know nothing about them).
Instead I have the same result:
"4) What happens instead is it shows a gray static screen as per attached screenshot."
regardless of technical stuff behind ...

drhc, again, this report is closed, so commenting here is a waste of time. File a support request against whatever Ubuntu GUI you are using as already previously requested (not continue to comment here in a closed report).

adrhc (adrhc) wrote :

I understand and I'll move.

Hi, I'm still having this bug on Ubuntu 14.04.
The status of the bug says "fix released".
How do I obtain this fix?

Jonathan Laserson, as the scope of this report is already released, and this report is closed, you don't have the same problem, but a different one outside the scope of this report.

If you want your problem addressed, please file a new report (not comment here).

Reinier Post (reinpost) wrote :

Christopher M. Penalver, the reported problem was that using remote desktop to connect to an Ubuntu 14.04 with a gnome-session doesn't work.

It is now May 31, 2016, it *still* doesn't work. That's why I'm here.

The problem description was since changed and a fix was developed for a later Ubuntu release.
While that is great, it does not fix the original problem. The original problem won't have been fixed until a backport for 14.04 is available. Now you say people reporting the original problem should do so in a separate bug report. I'm happy do do that but I think it will be closed as a duplicate.

Will it?

On Tue, May 31, 2016 at 5:26 PM, Reinier Post <email address hidden>
wrote:

> Christopher M. Penalver, the reported problem was that using remote
> desktop to connect to an Ubuntu 14.04 with a gnome-session doesn't work.
>

Which session do you try to use?

It is now May 31, 2016, it *still* doesn't work. That's why I'm here.
>
> The problem description was since changed and a fix was developed for a
> later Ubuntu release.
> While that is great, it does not fix the original problem. The original
> problem won't have been fixed until a backport for 14.04 is available. Now
> you say people reporting the original problem should do so in a separate
> bug report. I'm happy do do that but I think it will be closed as a
> duplicate.
>

There is new LTS release - 16.04, have you tried to use it?

I encountered the same problem for Ubuntu 16.04.

Displaying first 40 and last 40 comments. View all 107 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.