After dist-upgrade to 13.10, gnome-session starts with just a black screen w/ mouse cursor

Bug #1255875 reported by Martin Valgur on 2013-11-28
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-session (Ubuntu)
Undecided
Unassigned

Bug Description

Normally, I would expect to be launched into the (classic) gnome desktop. I can temporarily work around the issue by using xfce4-session instead.

Starting "gnome-session --session=gnome-classic" from terminal (under xfce4) I get the following message:
 $ gnome-session --session=gnome-classic
 gnome-session-is-accelerated: No composite extension.
 gnome-session-check-accelerated: Helper exited with code 256
 gnome-session-is-accelerated: No composite extension.
 gnome-session-check-accelerated: Helper exited with code 256
 ** (process:6197): WARNING **: software acceleration check failed: Child process exited with code 1
 ** (gnome-session:6197): CRITICAL **: We failed, but the fail whale is dead. Sorry....

Perhaps relatedly, since upgrade to 13.10 some gnome apps have started having errors, too.
 $ evince
 (evince:7046): EggSMClient-WARNING **: Failed to connect to the session manager: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
 No protocol specified
 ** (evince:7046): WARNING **: Could not open X display
 No protocol specified
 Cannot parse arguments: Cannot open display:

After running "sudo xhost +" the error changes to:
 (evince:7507): EggSMClient-WARNING **: Failed to connect to the session manager: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
 (evince:7507): Gtk-WARNING **: Attempting to read the recently used resources file at `/home/martin/.local/share/recently-used.xbel', but the parser failed: Failed to open file '/home/martin/.local/share/recently-used.xbel': Permission denied.
 (evince:7507): EvinceDocument-CRITICAL **: ev_document_get_n_pages: assertion 'EV_IS_DOCUMENT (document)' failed
 Segmentation fault (core dumped)

Eye of Gnome (eog) simply segfaults, too.

Some system information:
Description: Ubuntu 13.10
Release: 13.10
uname: Linux to127 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 07:38:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
The system is running under VMWare and is connected to via NX/SSH (which should not have any effect, I think).
All software packages should be at their latest versions. gnome session version is 3.9.90-0ubuntu3.

The information I have provided is probably very vague. Is there anything else I could do to clarify things?

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: gnome-session 3.9.90-0ubuntu3
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Thu Nov 28 10:18:40 2013
InstallationDate: Installed on 2012-06-27 (518 days ago)
InstallationMedia: Ubuntu-Server 12.04 LTS "Precise Pangolin" - Release amd64 (20120424.1)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: gnome-session
UpgradeStatus: Upgraded to saucy on 2013-11-21 (6 days ago)

Martin Valgur (mart4n) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers