Blacklist fglrx/Catalyst in Jockey

Reported by Sergey "Shnatsel" Davidoff on 2012-06-24
388
This bug affects 61 people
Affects Status Importance Assigned to Milestone
elementary OS
Medium
Sergey "Shnatsel" Davidoff

Bug Description

Installing fglrx/Catalyst severely breaks Mutter-based WMs, including Gala, and installing it is hard to revert. Nevertheless, Jockey suggests installing it. We should blacklist fglrx in Jockey so users don't end up with a broken system.

Currently all bugs in elementary OS caused by fglrx/Catalyst are marked as duplicates of this one because there's nothing we can do about them - only AMD can fix bugs in their proprietary driver.

AMD does not have a public bugtracker for their driver. However, you can report your issues to:
 * the Unofficial AMD Linux bugzilla: http://ati.cchtml.com/
 * fglrx and fglrx-updates packages in Ubuntu, but only in case you're using these Ubuntu-provided driver packages (downloads from AMD website don't count):
   - https://bugs.launchpad.net/ubuntu/+source/fglrx-installer
   - https://bugs.launchpad.net/ubuntu/+source/fglrx-installer-updates
 * AMD themselves, but since they don't have a public bugtracker, we don't know how exactly to contact them.

Changed in elementaryos:
milestone: none → luna-beta1
description: updated
Changed in elementaryos:
importance: Undecided → Medium

Open-source drives are officially supported by AMD (unlike the Nvidia situation) and video acceleration doesn't really work in Catalyst (see http://www.phoronix.com/scan.php?page=article&item=amd_xvba_xbmc&num=1 and http://www.phoronix.com/scan.php?page=news_item&px=MTEyNDk) so we can kill it with fire and without regrets.

tags: added: os-patch
Changed in elementaryos:
status: New → Fix Committed

Not fixed as of 26 september daily ISO.

Changed in elementaryos:
status: Fix Committed → Triaged

Blacklisting doesn't quite work and a workaround for fglrx issues seems to exist, so we'll decide what to do about this for beta2

Changed in elementaryos:
status: Triaged → Confirmed
milestone: luna-beta1 → luna-beta2
Changed in elementaryos:
status: Confirmed → Triaged

I've just tried the suggested workaround of adding "CLUTTER_PAINT=disable-clipped-redraws:disable-culling" to /etc/environment; it didn't fix even the sluggishness of moving windows around on Precise's fglrx, left alone multimonitor not working, black screenshots and screencasts, etc.
Quantal's fglrx 9.x is no better - it's completely broken on my HD 6770.
I guess we'd better give fglrx a GTFO after all. r600g is official and, as opposed to fglrx, it *works*.

Rubén Reina (ruben-reina-dev) wrote :

It's a pity because without fglrx you cannot play well decent Windows Games in Linux (Using Wine! and soon with Steam for Linux). The difference in 3D is abysmal.

Varun Priolkar (varunpr97) wrote :

If support for fglrx is removed, the os is going to lose a large market share. There will be a lot of WIndows users transitioning to Linux because of Steam and we need to find a way to get the fglrx drivers working instead of just blacklisting the drivers.

If I try to install fglrx from the Debian experimental repo or the jockey, it doesn't boot for me. I don't know coding but someone needs to make a wonder patch for gala to fix the issue. The drivers are the only reason why I can't switch completely over to elementary.

I think we need to find a way to fix the problem itself, instead of trying to hide it.

True, but since the driver is *proprietary*, there's nothing we can do about it.

UncleLaz (andrei-lisnic) wrote :

I totally agree with Varun, combination of Steam + Elementary sounds very appealing, if Elementary team can get this done right, there should be a HUGE audience boost.

UncleLaz (andrei-lisnic) wrote :

Also, in Unity, disabling "Sync to VBlank" option seemed to fix the performance issues at least, maybe that helps.

Varun Priolkar (varunpr97) wrote :

I don't know much about this but can't we make gala to fallback to gnome's compositing manager or something for the proprietary drivers?
The drivers aren't a problem for me on gnome shell..

GNOME Shell has the same underlying architecture. I believe fglrx applies application-specific workarounds to GNOME Shell, as they were known to do that for Compiz (see http://www.phoronix.com/scan.php?page=news_item&px=MTE3Nzc).

You can try bugging AMD to apply the same workarounds to Gala. That still won't fix the nasty vsync issues and lack of multimonitor support though.

Varun Priolkar (varunpr97) wrote :

Thank you for the response. I'll try writing a mail to AMD about the issue. That still wont solve the issue for folks who are on 4xxx or below cards(legacy support) as I don't see AMD bothering to update the drivers. Last time I tried to ask them for a updated drivers for the legacy card, they told me to write to several departments, from which I never heard back.

Do you mean that vsync doesn't work or isn't on? Is it only for Ati cards or for everyone in general and is it for Opensource or proprietary drivers? I tried to google it but nothing showed up :( I know about multimonitor support being poor. I really think Luna should be held back till its perfectly ready. Also there are a lot of things that can be improved upon as far as graphics go. These may not be a problem for folks who use Intel but the Ati support for Linux is atrocious. Updating the graphics stack has really helped me :)

Besides gala is suffereing from a lot of bugs that ill file bug reports when I get time.

VSync is notorious under AMD's binary blob. On open-source r600g it works fine for me though (I have Radeon HD6770).

Varun Priolkar (varunpr97) wrote :

Agreed.. I remember having to disable Vsync to get things working smoothly in Compiz.

Daniel Fore (danrabbit) on 2012-12-23
Changed in elementaryos:
milestone: luna-beta2 → luna-beta3
Nicki Aya (nicki-aya) wrote :

so ... this morning (my morning--greetings from Germany) I mistakenly installed the fglrx drivers to see what would happen on a new install. Crash as usual. But, in the additional drivers window, the two choices were different. Something about updates on one of them.

Anywho, as I´m struggling to get radeon support, I thought I´d pop in again out of curiousity. And now, I don´t remember if it had this before, but each of the fglrx drivers have a badge for "Tested by elementary-OS developers". Is that just a generic "tested by [OS NAME] developers", or is this legit?

I know windows catalyst was recently updated, but they send out a new version for us today?

It's a generic badge. It will be legit only by the time of final release.

description: updated
George Nicolson (aggronfg) wrote :

I use fglrx and can confirm manu bugs .. But with the opensource driver it seems like my laptop(with RADEON HD 6470M) will catch fire or explode at any minute(in addition, with the version from precise Gala is surprisingly slower than it is on fglrx). Not to mention it makes cool sounds like a jet plane. :)
I hope radeon receives good power management support soon, and maybe the newer version can be used on elementary then, if it happens any time soon. I'd love to be able to switch to radeon, but I pretty much can't, simple web browsing can bring the temperature to the limits. Not to mention more intensive tasks, including updating the system etc that use some CPU power.
(I've already tried the current dynamic power management implementation, settings power profile to low, etc, even in much newer version and Arch Linux, but none help, and while I can get a few degrees cooler than before, it's still hot with the addition of slugginess and flickering.
Desktop users shouldn't have much of a problem though. But for laptops ... It was similar on other's people's machines that I tried.)

description: updated
Nicki Aya (nicki-aya) wrote :

so, for the heck of it, I did a new elementary os install (From beta1, updating during installation), and decided to try the binary drivers since you know, they were updated recently. Interestingly enough, there was a beta driver available. So I had to install it.

Of course there´s this stupid "AMD Testing use only" glyph on my screen, which is really annoying, but ... it seems like I´m using the catalyst driver.

Driver packet version: 9.01-121018a-148746E-ATI
2D- Driver verion 9.1.11
Catalyst Control Center-Version 2.18

Any more details I can provide?

Rubén Reina (ruben-reina-dev) wrote :

Yes please. Tell us if you can see fullscreen videos in Youtube with Google Chrome or play a game in Fullscreen mode.

Nicki Aya (nicki-aya) wrote :

My Little Pony: Friendship if Magic - Season 3 Episode 10, 1080p runs wonderfuly in Chromium and no noticable loss of framerate when switching to full screen and back.

World of Goo (via Steam) worked flawlessly. As did the steam overly.

Morrowind, via Steam on Wine worked wonderfully. No issues. Didn´t try steam overly. (Didn´t work in Unity and didn´t bother)

Machinarium, via Steam on Wine worked good. The animated cursors seemed a bit slow to move (animation speed was still norma).

Torchlight (native) is just. Breathtaking. Max settings (minus blood, because it´s not my thing). No issues. Except I died trying to find baddies. I gotta rethink my approach there (But it´s also utterly painless, compared to Unity. But I think we already know that)

Nicki Aya (nicki-aya) wrote :

Minecraft also worked pretty well. The server I´m usually on is down, so there wasn´t too much strain on it. Fullscreen worked fine. Getting out of fullscreen was a little difficult. It stopped refreshing until I resized the window.

But other than that, I haven´t noticed any problems with anything.

Rubén Reina (ruben-reina-dev) wrote :

I have already installed latest AMD beta drivers and I am experiencing black screen (in full screen mode) in videos. So the bug still persists with mutter based desktop environments.

I can also confirm that there is a huge performance improvement with the latest beta of the drivers for me. There are still CPU spikes, but they rarely go to the 90-100% range as they used to with the previous versions. Also, all the steam games I tried played perfectly well. I'm on a AMD Phenom II CPU with a Radeon HD 5750 GPU.
Still, I don't think I will be using it for much longer, especially since the CPU spikes are still present, but it is definitely an improvement.

Nicki Aya (nicki-aya) wrote :

So, some updates: Last night (UTC+1 time) the beta driver stopped worked for me. I thought it was related to virtualbox or some updates/installations I did. So I did a clean install this morning, avoiding updates and installed the beta driver: same thing. Torchlight gave me a teal screen with no video (buttons and controls and everything were still there). Morrowind (Steam + wine) wouldn´t give me any video and gave me a white screen.

So, ready to do another clean install and think of alternatives (since the radeon drivers don´t work for me for some reason), I thought I´d try the actual fglrx driver. I reboot. See the elementary logo. And it sits on the black screen for a while. Next thing I know, Pantheon-login pops up. I log in. Check jockey, I´m using the fglrx driver, not the beta.

I don´t yet have torchlight reinstalled, but I got Steam up and running on wine, and launched Morrowind. Super super super shakey video, but I was able to exit out.

Random thought: why not try awesome wm. Installed it. Poped in my configs. Bam. Morrowind runs without a hitch. So, obviously we still have some issues with mutter based wm and fglrx, but it´s nice to know that we´re getting somewhere.

My setup:
AMD Phenom II 945 (not overclocked)
Saphire Radeon HD 6570 4GB DDR2

Stuff is happening. And this is exciting.

Guys, this problem is making the elementary OS hard to use. Because of various sorts of conflicts between Gala and ATI/AMD graphics driver following issues could be observed:
1) Inability to view the full-screen video from browser
2) Inability to play the steam native linux games
3) Noticeable freezes of the desktop environment when new notification in dock arrives
4) Small slowness during working with workspaces in pantheon (moving windows from one ws to another, switching between them)

Fglrxinfo tells me the following information:
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Mobility Radeon HD 5000
OpenGL version string: 4.2.11903 Compatibility Profile Context

I'm currently using the fglrx-updates, version 2:9.000-0ubuntu0.3 as the most stable one (allows to access the 1st point from my list, fglrx-experimental, version 2:9.010-0ubuntu0.3 doesn't allow)

Let me know if there's anything I can do to help. But that issue makes really lots of pain (which I can stand though, because I love all other features of elementary OS and pantheon/gala things).

Thanks a lot for your work, guys!

We're working on backporting newer Clutter to make the greeter not crash. This is going to change the situation once again, for good or ill.

But as it stands rigth now, fglrx is still too buggy and doens't provice a good experience for general audience, even with Compiz or Metacity.

Clutter update has landed to Daily PPA (thanks Rico!). The situation has probably changed again.

Unfortunately, all previous problems remain in my situation.

Jochen Fahrner (jofa) wrote :

I depend on fglrx driver because the free radeon driver often freezes my Acer Aspire One 521 netbook after wakeup from suspend.
So in my situation radeon is worse than fglrx. :-(

Laszlo Demeter (demlasjr) wrote :

Hey everyone !

I just installed ElementaryOS and I found that taking screenshots it's not working. All I get is the blue stripes background images, with no icons or windows. I'm using the prioritary beta ATI driver from ATI website with a Radeon HD 3200.

Everything is working flawless, no lag in fullscreen 1080p videos on youtube (which are freezing on Windows 8, even 720p videos are impossible to be watch on Windows).

Also +Nicky Aya, that For testing only image can be easily removed.

Finding a solution for printscreens will be great !

Laszlo Demeter (demlasjr) wrote :

Sorry, I forgot to add that the used driver is this one and not the one found in additional drivers:
http://support.amd.com/us/kbarticles/Pages/catalyst126legacyproducts.aspx

Nicki Aya (nicki-aya) wrote :

I too have the screenshot issue. For me though, everything just comes out in black. I don´t remember trying it without the fglrx driver, but as far as I remember it´s been solid black with only my mouse icon. Most likely fglrx related.

But I´m still using the "*expermentel*" driver (not the new driver + kernel module - a little afraid to break everything). Full screen *games* don´t work to well anymore. Sometimes I can get them working, othertimes not, but if I load awesome then everything works wonderfully. Same as before. And I´m super happy. I also haven´t updated to the lastest kernel.

At this moment we have two options:

1) Never suggest fglrx to the user by patching the "available(self)" function in the fglrx handler to always return False.

2) Patch the descriptions in fgrlx to include warnings that the driver will improve power management and 3D performance, but may compromise system stability and/or break other things. This will require localizing them somehow, gotta talk to Gotwig about localization if we go for it.

Designer input needed!

After a discussion in IRC we decided to go with (2): We will patch the descriptions in fgrlx to include warnings that the driver will improve power management and 3D performance, but may compromise system stability and break other features.

Now we need somebody to provide the actual strings we'll put in there. The original strings can be found at http://bazaar.launchpad.net/~elementary-os/ubuntu-package-imports/jockey-precise/view/head:/data/handlers/fglrx.py
A screenshot of how it looks for understanding the context: http://i41.tinypic.com/mlms5d.png

Press team, to the rescue!

Changed in elementaryos:
assignee: nobody → elementary UX Team (elementary-design)
Cassidy James (cassidyjames) wrote :

Are you talking about lines 25-27?

So we've brainstormed the copy in IRC, I'm integrating it now.

Changed in elementaryos:
status: Triaged → In Progress
assignee: elementary UX Team (elementary-design) → Sergey "Shnatsel" Davidoff (shnatsel)

The patched version should land to PPA soon. I still have to set up translations for it.

I've set up translations: https://translations.launchpad.net/elementaryos/0.2-luna

Translators: please complete the translations of this package. It's a mostly point-and-click process since most strings are suggested to you from Ubuntu package. Only two new strings require actual translation.

This is important info which we really need to get translated. Thanks!

Changed in elementaryos:
status: In Progress → Fix Released
Cody Garver (codygarver) on 2013-05-13
Changed in elementaryos:
milestone: luna-beta3 → luna-rc1
Johan Bjäreholt (johanthepro) wrote :

Still any activity on this?

I have the same problem as Jochen Fahrner (https://bugs.launchpad.net/elementaryos/+bug/1017091/comments/31), and my computer cannot resume after suspend with the radeon drivers, so i'm pretty much stuck with fglrx.

It is not that unstable, the highest annoyances are the Gala support.
Changing workspace doesn't lag, but frameskips alot and looks very bad. Would even be an improvement if the animation was removed. Moving windows is also slow, and gets annoying.

A wierd thing that i'm not sure of though, it feels like the refreshrate of my screen has lowered when i changed driver.
But as i said, i have not confirmed this yet.

Video playback (both from harddrive and streaming) works great though and minecraft runs at over 100fps.
I am using a radeon 4750

Johan Bjäreholt (johanthepro) wrote :

Ok, tested some more yesterday with the fglrx drivers.

First off, the thing i said about the refresh rate was invalid.

So, i tried multi monitors and mirroring works fine, but multi desktops or eyefinity does not!
The display settings in settings manager will not allow you to enable another monitor and gives a error unless you have selected mirroring.
The only way to turn on multiple desktops is to go into Catalyst Control Center, and do the configurations there.
However, that doesn't work well at all neither (but partly works atleast). It is possible to drag your mouse between the screens, but your windows will not be able to be dragged to the 2nd configured monitor.
Now with the monitors setup in CCC, when you go into settings manager and monitor it will only show you the no.1 monitor.

I am unsure how the window manager handles fullscreen applications, so i will try that out later today when i get home.

If you guys could just fix multi monitor, i would be very happy. I can live with the slow animations, but i can't without my other monitors!
I am a programmer but have absolutely no skills with either X or Gala. I'm very sorry that i cannot help more than testing it out and reporting!

Jarosław Guza (jarekj83-4) wrote :

i have it in fresh install (yesterday) ...when can we expect a fix?

I installed elementary OS today and it was with the same issue of you guys. Conky showed that gala was eating at least 50% of the CPU continuously. After I installed the AMD Experimental FGLRX proprietary driver with the "additional drivers" tool provided by elementary itself, my problems were gone.

I suggest one to install mutter and then issue the command "mutter --replace" if elementary still remain lagging.

murr4y (murr4y) wrote :

Installed it today as well.
I installed the recommended fglrx drivers and now it's pretty laggy. I have an ATI 4670 and normally on Ubuntu I used the legacy drivers. It boots and everything works but the performance of the window manager is quite bad.
I tried installing mutter like mentioned above but that didn't help.

murr4y (murr4y) wrote :

Okay, I got it working smoothly now. Probably because I activated the tear free display in the amdcccle, issues with vsycn were mentioned here before.

Erasmo Marín (erasmo-marin) wrote :

So, are the drivers working now? at least the experimental drivers?

Also, is the performance good? better or worst than free drivers?

Johan Bjäreholt (johanthepro) wrote :

@Erasmo Marín

Pros:
 - 3d acceleration works like a charm!

Cons:
 - 2d performance is worse but decent when you activate tear free in ccc
 - stability is decent, you might encounter some visual artifacts but most things works as they should
 - multimonitors does not work.

I am really in need for these drivers because of multiple reasons:
1. I don't want to reboot to windows everytime im gaming (it's the only reason why i still have a windows partition)
2. And i want to be able to use all of my 3 screens while gaming
3. To be able to use my two 4870's in crossfire
4. I have a problem with the radeon drivers, which is that after waking up from a suspend the display does not start and is just black and flickers a little. I do not have this error with Catalyst

Adri Sans (asansc) wrote :

Hello.
This is my first post in Launchpad and I want to contribute to improve eOS Luna.

Actually I have a AMD HD6850 and I have the same problems mentioned above. I think that we can improve the installation of proprietary drivers changing the name of them and their description. When I go to Jockey, there are a lot of drivers to choose without any real util information or outdated information. (view attachment)

I think is necessary to change the name of the drivers, because now is very confusing. For Ex:

- AMD Proprietary driver Catalyst version 13.4 (Stable) - Description: More specific information of this version of the driver (which provides AMD; OpenGL version, driver version, etc) and known issues in eOS.

- AMD Proprietary driver Catalyst version 13.8 (beta or experimental)- Description: AMD official information (OpenGL version, driver version, etc) and Known issues in eOS.

I just post this examples because now it's impossible to know the version of the driver that I'm installing from Jockey (view attachment), and now it's very important for Steam games. That think you?

Only I suggest that the installation of the AMD drivers can be more clear. ¿More ideas?

Thanks a lot to all persons that are working to improve ElementaryOS. :)

Marcelo (marceloramone-gmail) wrote :

Hello,

I'M writing this post from my elementary os luna amd 64 full updated.
I installed amd privative driver to play steam games...
I can't take screenshots, record my desktop (i get black screen as a result with kazam tool)
Also, i can't use teamviewer!!! I loads a black screen!
I upgrade to latest amd video driver from jockey tool, but the problems continues.

Los drivers de AMD para linux siguen siendo una porquería!

Richard (rkuesters) wrote :

Hello everyone.

I just got it working in my machine. I installed the beta Linux driver from AMD, producing .debs like explained in https://help.ubuntu.com/community/BinaryDriverHowto/ATI .

At first, just the background (very dark) is viewable in the screenshots, but, after opening "amdcccle", the screenshots started working.

I just open amdcccle and close. Everything works great. The problem is maybe composed by the driver AND elementary OS.

[ richard @ mordor ] ~ $ uname -a
Linux mordor 3.8.0-31-generic #46~precise1-Ubuntu SMP Wed Sep 11 18:21:16 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

[ richard @ mordor ] ~ $ fglrxinfo
display: :0 screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 5400 Series
OpenGL version string: 4.3.12458 Compatibility Profile Context 9.00.11

My best regards,
Richard.

Richard (rkuesters) wrote :

Hello again :)

I may have been mistaken about "screenshots started working". Well, I got them working but, as long as the screenshot I want to take is after I hit OK or APPLY on amdcccle.

Ok, at least I might have narrowed down some options. I tried this method in eOS using kernel versions 3.2.x and 3.8.x, and with AMD drivers version 13.04 and 13.11. I mixed up those configurations in two differente PCs, and the result is always the one I described.

When I started messing around with the framebuffer (either using fbset or in the xorg.conf for Radeon HD), some very interesting results came to light (like the very dark backgrounds; black screens; no alpha channels in anything related to eOS (shadows, plank, notifications) and so on. Yes, I know framebuffer is for the console, but nevertheless the results are weird.

The interesting question to do is: what is the [command|signal|whatever] amdcccle sends to [Xorg|framebuffer|whatever] that makes the "screen" available? Is the screenshot a buffer? If so, why is it not in realtime like others? Is eOS not sending a specific [command|signal|whatever] every time something changes in the screen that just affects proprietary AMD drivers?

I would go behind the buffer question first, but that would be just a guess -- I never went deeper on Linux GFX as much as getting WebGL working on my webkit application.

PS: In my notebook running with Nvidia graphics, everything works "as expected". Other Intel machine with IGU too.

My best regards,
Richard.

To post a comment you must log in.