Window management - Compiz grid overlay appears after workspace switcher use

Reported by Greg A on 2011-10-16
686
This bug affects 134 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Compiz Expo Plugin
High
Marco Trevisan (Treviño)
Compiz Main Plugins
High
Marco Trevisan (Treviño)
Trunk
High
Unassigned
Unity
Undecided
Unassigned
6.0
High
Unassigned
Unity Distro Priority
Undecided
Unassigned
compiz-plugins-main (Ubuntu)
Critical
Didier Roche
Oneiric
Undecided
Marco Trevisan (Treviño)
Quantal
Critical
Didier Roche

Bug Description

Steps to reproduce (currently I can consistently reproduce this):
 - Focus a window (I'm choosing a window in the top left workspace, out of four)
 - Click on the Unity Workspace Switcher
 - Select a workspace with a window open (e.g. the one you came from) by double clicking on it
 - Move the mouse directly to the left edge of the screen

Expected result: if it is not already visible, the Launcher appears (as normally happens when moving to the left edge of screen). Nothing else should happen.

Actual result: the launcher appear, but also an orange highlighting appears on the right hand side of the screen (as if I trying to snap the window to the left). However the windows is still maximised / in it's original position. See the screenshot for a clearer idea of what is happening.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.22.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,compiztoolbox,imgpng,resize,place,snap,gnomecompat,vpswitch,move,grid,regex,animation,session,unitymtgrabhandles,mousepoll,workarounds,expo,wall,ezoom,fade,scale,unityshell]
CompositorRunning: compiz
Date: Sun Oct 16 09:07:16 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
GraphicsCard:
 ATI Technologies Inc RV710 [Radeon HD 4350] [1002:954f] (prog-if 00 [VGA controller])
   Subsystem: Hightech Information System Ltd. Device [1787:2271]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
MachineType: Dell Inc. Dell DXP061
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=d30f0894-f34b-416e-828c-7e5549c1f048 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/22/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 2.5.3
dmi.board.name: 0WG855
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 7
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr2.5.3:bd11/22/2007:svnDellInc.:pnDellDXP061:pvr:rvnDellInc.:rn0WG855:rvr:cvnDellInc.:ct7:cvr:
dmi.product.name: Dell DXP061
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu5
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Greg A (etulfetulf) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2011-10-18
Changed in unity:
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
status: New → Won't Fix
status: Won't Fix → Confirmed
Changed in compiz-core:
status: New → Confirmed
Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Alex Launi (alexlauni) on 2011-10-19
Changed in compiz-core:
importance: Undecided → Medium
dFlyer (ggaribaldi) wrote :

Same problem here.

Omer Akram (om26er) on 2011-10-24
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in compiz (Ubuntu):
importance: Medium → High
Omer Akram (om26er) wrote :

this is a regression that came with the update of compiz-plugins-main so I am marking this as critical as the change is causing some serious problems.

Changed in unity:
importance: High → Critical
importance: Critical → High
Changed in compiz (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
importance: High → Critical
affects: compiz (Ubuntu) → compiz-plugins-main (Ubuntu)
Changed in compiz-plugins-main (Ubuntu):
assignee: Sam Spilsbury (smspillaz) → nobody
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → oneiric-updates
tags: added: regression-proposed
tags: added: regression-update
removed: regression-proposed
Omer Akram (om26er) on 2011-10-24
affects: compiz-core → compiz-plugins-main
summary: - Compiz grid plugin golden box appears after workspace switcher use
+ Compiz grid overlay appears after workspace switcher use
Omer Akram (om26er) on 2011-10-25
Changed in unity:
milestone: none → 4.26.0
Doug Morse (dm-dougmorse) wrote :

Since my report, Bug #877951, has been marked a duplicate of this bug, I just thought I should mention the following:

1. The procedure for creating the problem as reported by the OP in this report (Bug #875557) does NOT cause the problem for me. In other words, clicking on the viewport switcher in the launcher and then moving the mouse to the left does not cause the unwanted orange box to appear. Indeed, on repeated trials, even trying other edges when in expo view of the viewports does not induce the orange box. However, I have set the middle mouse button in Compiz settings to bring up expo view, and when I access the expo view in this fashion, moving the mouse to the left or right edge in expo view OCCASIONALLY induces the orange box.

2. Relatedly, the unwanted orange box most often appears for me when NOT in expo view; simply moving the mouse to the right or left edge of the screen can induce the problem. I have not yet been able to determine under what conditions this happens and why it does not occur at other times. The problem does seem to be a "state" issue, in that, once it occurs, it keeps occurring until some sequence of events brings it out of the unwanted state of behavior. I most often go into expo view and click a different viewport and then back again to the viewport within which I was working in order to get rid of the orange box. Sometimes this fix takes right away, other times I might have to go into expo view to fix it repeatedly to get the unwanted behavior to stop (for a time; the unwanted behavior invariably returns, typically within 10-20 minutes).

Didier Roche (didrocks) on 2011-10-28
Changed in unity-distro-priority:
status: New → Fix Committed
DJ (ke7mbz) wrote :

I reported basically the same behavior as Doug. Sometimes it happens, and sometimes it doesn't. It occurs on both edges of the screen, but I haven't been able to consistently reproduce it. I've marked my bug (Bug #883685) as a duplicate of this one, though it's worth looking at the notes for my bug. It also seems that I've resolved it on my system by reducing the the thresholds for the Grid plugin. I reduced them all to 1, but had to raise the right edge to 4 to get snap to work again.

DJ (ke7mbz) wrote :

Here's a shot of my settings.

Che Dean (dean-che) wrote :

It's affecting me also on three different machines. Happens when I mouse to either side of the screen without dragging a window. I have to click the workspace switcher to get rid of it.

Chris._k (crash-chris) wrote :

Same probolem as Doug... It's a real workflow-breaker...

DJ (ke7mbz) wrote :

Update: Changing the thresholds did not make it go away, though it happens less frequently. I set them all to zero, so we'll if it comes back. It often happens right after rebooting the system. Definitely more than an annoyance, as it's impossible to get anything done while it's happening. Thus far, I'm pretty frustrated with Oneiric. It seems to have added at least as many bugs as it solved.

Julien (julienmbpe) wrote :

I know this is certainly not the place to discuss this, but I see that the bug affects 5 projects and one of them is marked as "Fix commited". Shouldn't it be marcked as "fix commited" in all projects ?

An other question : it as been marked as "Fix commited" 5days ago. What is the procedure to see the fix released ?

If someone could take a moment to anser those 2 questions, i could better understand Launchpad process and will be very greatfull :)

Andy Key (akpraha) wrote :

This is annoying. I was beginning to think that Ubuntu with Unity was better than Fedora/Gnome3, but this is almost a show-stopper. Any chance on getting a fix released soon?

@Andy, unless I'm mistaken, a fix for this was committed on 2011-10-28 and is being currently in the release cycle. So it _has_ been fixed.

Che Dean (dean-che) wrote :

@Louis Bouchard, Still happening to me and I've been checking for updates every few hours. It's really causing problems with productivity. Apart from this problem, 11.10 has been a really sweet release, running well but having an orange box appear every time I touch either side of the screen is really hampering me.

@Che, you are right, fix-commited does not mean that the fix has been released yet. I'm also waiting for the fix to be released

DJ (ke7mbz) wrote :

I know it's only a work around but has anyone else tried setting the thresholds to zero. It at least lets you get back to work.

sportscrazed2 (shawn-r) wrote :

Same bug here on my Samsung N130 netbook. Settng Grid thresholds to zero does effectively eliminate problem for me but, it also gets rid of the "aero snap" feature that I love so much when dragging windows to the edge of screen. A decent workaround is switch to windows on other workspaces by clicking the icon in Unity dock of a window opening in other workspace. This is very annoying if you switch workspaces a lot and look forward to it being fixed. Otherwise Unity is pretty awesome on my netbook.

Download full text (4.8 KiB)

I've worked around it by removing the expo edge effect and not using the
switch workspace dock button. I just used control + alt + keys to switch
between them and the problem doesn't happen.

On Thu, Nov 3, 2011 at 6:35 PM, sportscrazed2 <email address hidden>wrote:

> Same bug here on my Samsung N130 netbook. Settng Grid thresholds to
> zero does effectively eliminate problem for me but, it also gets rid of
> the "aero snap" feature that I love so much when dragging windows to the
> edge of screen. A decent workaround is switch to windows on other
> workspaces by clicking the icon in Unity dock of a window opening in
> other workspace. This is very annoying if you switch workspaces a lot
> and look forward to it being fixed. Otherwise Unity is pretty awesome
> on my netbook.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/875557
>
> Title:
> Compiz grid overlay appears after workspace switcher use
>
> Status in Compiz Main Plugins:
> Confirmed
> Status in Unity:
> Confirmed
> Status in Unity Distro Priority:
> Fix Committed
> Status in “compiz-plugins-main” package in Ubuntu:
> Confirmed
> Status in “unity” package in Ubuntu:
> Confirmed
>
> Bug description:
> Steps to reproduce (currently I can consistently reproduce this):
> - Focus a window (I'm choosing a window in the top left workspace, out
> of four)
> - Click on the Unity Workspace Switcher
> - Select a workspace with a window open (e.g. the one you came from) by
> double clicking on it
> - Move the mouse directly to the left edge of the screen
>
> Expected result: if it is not already visible, the Launcher appears
> (as normally happens when moving to the left edge of screen). Nothing
> else should happen.
>
> Actual result: the launcher appear, but also an orange highlighting
> appears on the right hand side of the screen (as if I trying to snap
> the window to the left). However the windows is still maximised / in
> it's original position. See the screenshot for a clearer idea of what
> is happening.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: unity 4.22.0-0ubuntu3
> ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
> Uname: Linux 3.0.0-12-generic x86_64
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.23-0ubuntu3
> Architecture: amd64
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,compiztoolbox,imgpng,resize,place,snap,gnomecompat,vpswitch,move,grid,regex,animation,session,unitymtgrabhandles,mousepoll,workarounds,expo,wall,ezoom,fade,scale,unityshell]
> CompositorRunning: compiz
> Date: Sun Oct 16 09:07:16 2011
> DistUpgraded: Fresh install
> DistroCodename: oneiric
> DistroVariant: ubuntu
> GraphicsCard:
> ATI Technologies Inc RV710 [Radeon HD 4350] [1002:954f] (prog-if 00 [VGA
> controller])
> Subsystem: Hightech Information System Ltd. Device [1787:2271]
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
> MachineType: Dell Inc. Dell DXP061
> ProcEnviron:
> LANGUAGE=en_GB:en
> PATH=(custom, no user)
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/...

Read more...

The bug ist caused by the Drag&Drop binding of the expo-view (for moving the windows in the expo-view). If you exit Expo by double-clicking on a workspace with a window, you zoom in to the workspace and because the Drag&Drop-binding is set to "Button1" (=left click) expo also tries to start to move the window. If you now move the window to the border of the viewport, compiz believe you want to use the compiz grid feature.

A simple workaround: change either the Drag&Drop-binding to something else ( CompizConfig->Expo->Bindings->Drag&Drop, set to <Control>Button1 or something else) OR find a other way to exit the expo view ( expo edge, expo button etc.)

Julien (julienmbpe) wrote :

I comfirm the discover made by Raphael : as long as you don't double-click to quit the expo mode, everything is ok.
Nice to now that : it will help waiting the patch release more easily.

Thank you

Che Dean (dean-che) wrote :

Confirmed, as long as you don't double click to leave expo it's fine.

Download full text (4.1 KiB)

Confirmed as well. :)

On Sat, Nov 5, 2011 at 12:27 PM, Che Dean <email address hidden> wrote:

> Confirmed, as long as you don't double click to leave expo it's fine.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/875557
>
> Title:
> Compiz grid overlay appears after workspace switcher use
>
> Status in Compiz Main Plugins:
> Confirmed
> Status in Unity:
> Confirmed
> Status in Unity Distro Priority:
> Fix Committed
> Status in “compiz-plugins-main” package in Ubuntu:
> Confirmed
> Status in “unity” package in Ubuntu:
> Confirmed
>
> Bug description:
> Steps to reproduce (currently I can consistently reproduce this):
> - Focus a window (I'm choosing a window in the top left workspace, out
> of four)
> - Click on the Unity Workspace Switcher
> - Select a workspace with a window open (e.g. the one you came from) by
> double clicking on it
> - Move the mouse directly to the left edge of the screen
>
> Expected result: if it is not already visible, the Launcher appears
> (as normally happens when moving to the left edge of screen). Nothing
> else should happen.
>
> Actual result: the launcher appear, but also an orange highlighting
> appears on the right hand side of the screen (as if I trying to snap
> the window to the left). However the windows is still maximised / in
> it's original position. See the screenshot for a clearer idea of what
> is happening.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: unity 4.22.0-0ubuntu3
> ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
> Uname: Linux 3.0.0-12-generic x86_64
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.23-0ubuntu3
> Architecture: amd64
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,compiztoolbox,imgpng,resize,place,snap,gnomecompat,vpswitch,move,grid,regex,animation,session,unitymtgrabhandles,mousepoll,workarounds,expo,wall,ezoom,fade,scale,unityshell]
> CompositorRunning: compiz
> Date: Sun Oct 16 09:07:16 2011
> DistUpgraded: Fresh install
> DistroCodename: oneiric
> DistroVariant: ubuntu
> GraphicsCard:
> ATI Technologies Inc RV710 [Radeon HD 4350] [1002:954f] (prog-if 00 [VGA
> controller])
> Subsystem: Hightech Information System Ltd. Device [1787:2271]
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
> MachineType: Dell Inc. Dell DXP061
> ProcEnviron:
> LANGUAGE=en_GB:en
> PATH=(custom, no user)
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic
> root=UUID=d30f0894-f34b-416e-828c-7e5549c1f048 ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 11/22/2007
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: 2.5.3
> dmi.board.name: 0WG855
> dmi.board.vendor: Dell Inc.
> dmi.chassis.type: 7
> dmi.chassis.vendor: Dell Inc.
> dmi.modalias:
> dmi:bvnDellInc.:bvr2.5.3:bd11/22/2007:svnDellInc.:pnDellDXP061:pvr:rvnDellInc.:rn0WG855:rvr:cvnDellInc.:ct7:cvr:
> dmi.product.name: Dell DXP061
> dmi.sys.vendor: Dell Inc.
> version.compiz: compiz 1:0.9.6+b...

Read more...

I suggest to use "Button 2", the Mouswheel-Button, to Drag&Drop Windows in Expo. So you can work without the keybord and avoid overlapping buttons.

Thank you for the workaround, Raphael.

Jamy Golden (jamyg88) wrote :

This is quite an annoying bug. Thanks for the simple workaround Raphael!

Dennis Sheil (dennis-sheil) wrote :

I tried Raphael's suggestion. From a shell I ran "gconf-editor". Went to both
apps/compiz-1/plugins/expo/screen0/options/dnd_button

and

apps/compizconfig-1/profiles/plugins/expo/screen0/options/dnd_button

and changed from "Button1" to "Disabled".

Have not had a problem since.

This should be fixed for Unity. It is new behavior, and from the 41 people saying this bug affects them, plus the duplicate bug reports etc., it is a hassle for a lot of people. I even get the orange overhang on the screen when I go idle and my screen locks - the orange overhang is even on my lock screen.

iuuuuan (ivan-janes) wrote :

I agree about annoying bug. Thanks for simple workaround.

Tim Penhey (thumper) on 2011-11-14
tags: added: udp
Rizadh (rizadh97) wrote :

I've been having the same problem but I've discovered a simple (but annoying) workaround:

After using workplace switcher just double click the windows menu bar (which would maximise or restore it). Double click it again to change it back to it's original state. After that, moving your mouse to any edge of the screen won't result in the orange overlay!!

Hope it works for everyone else but I hope they release a fix soon :(

Changed in unity-distro-priority:
status: Fix Committed → Fix Released

Rizadh workaround *do* work. Thanks.

Julien (julienmbpe) wrote :

Rizadh : a workaround is NOT a fix ! So this bug don't have to be marked as "Fix Released"...

Unfortunally, it seemes we can not return to the prevous state...

Download full text (4.1 KiB)

Yes I know. Unfortunately I had accidentally clicked the button due to my laggy touchpad which I am also looking for a fix for.

Sent from my iPod

On 2011-11-14, at 9:30 PM, Julien <email address hidden> wrote:

> Rizadh : a workaround is NOT a fix ! So this bug don't have to be marked
> as "Fix Released"...
>
> Unfortunally, it seemes we can not return to the prevous state...
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/875557
>
> Title:
> Compiz grid overlay appears after workspace switcher use
>
> Status in Compiz Main Plugins:
> Confirmed
> Status in Unity:
> Confirmed
> Status in Unity Distro Priority:
> Fix Released
> Status in “compiz-plugins-main” package in Ubuntu:
> Confirmed
> Status in “unity” package in Ubuntu:
> Confirmed
>
> Bug description:
> Steps to reproduce (currently I can consistently reproduce this):
> - Focus a window (I'm choosing a window in the top left workspace, out of four)
> - Click on the Unity Workspace Switcher
> - Select a workspace with a window open (e.g. the one you came from) by double clicking on it
> - Move the mouse directly to the left edge of the screen
>
> Expected result: if it is not already visible, the Launcher appears
> (as normally happens when moving to the left edge of screen). Nothing
> else should happen.
>
> Actual result: the launcher appear, but also an orange highlighting
> appears on the right hand side of the screen (as if I trying to snap
> the window to the left). However the windows is still maximised / in
> it's original position. See the screenshot for a clearer idea of what
> is happening.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: unity 4.22.0-0ubuntu3
> ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
> Uname: Linux 3.0.0-12-generic x86_64
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.23-0ubuntu3
> Architecture: amd64
> CompizPlugins: [core,bailer,detection,composite,opengl,decor,compiztoolbox,imgpng,resize,place,snap,gnomecompat,vpswitch,move,grid,regex,animation,session,unitymtgrabhandles,mousepoll,workarounds,expo,wall,ezoom,fade,scale,unityshell]
> CompositorRunning: compiz
> Date: Sun Oct 16 09:07:16 2011
> DistUpgraded: Fresh install
> DistroCodename: oneiric
> DistroVariant: ubuntu
> GraphicsCard:
> ATI Technologies Inc RV710 [Radeon HD 4350] [1002:954f] (prog-if 00 [VGA controller])
> Subsystem: Hightech Information System Ltd. Device [1787:2271]
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
> MachineType: Dell Inc. Dell DXP061
> ProcEnviron:
> LANGUAGE=en_GB:en
> PATH=(custom, no user)
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=d30f0894-f34b-416e-828c-7e5549c1f048 ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 11/22/2007
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: 2.5.3
> dmi.board.name: 0WG855
> dmi.board.vendor: Dell Inc.
> dmi.chassis.type: 7
> dmi.chassis.vendor: Dell Inc.
> dmi.modalias:...

Read more...

Rizadh (rizadh97) wrote :
Download full text (3.9 KiB)

Happy to help :)

Sent from my iPod

On 2011-11-14, at 9:03 PM, Romano Giannetti <email address hidden> wrote:

> Rizadh workaround *do* work. Thanks.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/875557
>
> Title:
> Compiz grid overlay appears after workspace switcher use
>
> Status in Compiz Main Plugins:
> Confirmed
> Status in Unity:
> Confirmed
> Status in Unity Distro Priority:
> Fix Released
> Status in “compiz-plugins-main” package in Ubuntu:
> Confirmed
> Status in “unity” package in Ubuntu:
> Confirmed
>
> Bug description:
> Steps to reproduce (currently I can consistently reproduce this):
> - Focus a window (I'm choosing a window in the top left workspace, out of four)
> - Click on the Unity Workspace Switcher
> - Select a workspace with a window open (e.g. the one you came from) by double clicking on it
> - Move the mouse directly to the left edge of the screen
>
> Expected result: if it is not already visible, the Launcher appears
> (as normally happens when moving to the left edge of screen). Nothing
> else should happen.
>
> Actual result: the launcher appear, but also an orange highlighting
> appears on the right hand side of the screen (as if I trying to snap
> the window to the left). However the windows is still maximised / in
> it's original position. See the screenshot for a clearer idea of what
> is happening.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: unity 4.22.0-0ubuntu3
> ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
> Uname: Linux 3.0.0-12-generic x86_64
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.23-0ubuntu3
> Architecture: amd64
> CompizPlugins: [core,bailer,detection,composite,opengl,decor,compiztoolbox,imgpng,resize,place,snap,gnomecompat,vpswitch,move,grid,regex,animation,session,unitymtgrabhandles,mousepoll,workarounds,expo,wall,ezoom,fade,scale,unityshell]
> CompositorRunning: compiz
> Date: Sun Oct 16 09:07:16 2011
> DistUpgraded: Fresh install
> DistroCodename: oneiric
> DistroVariant: ubuntu
> GraphicsCard:
> ATI Technologies Inc RV710 [Radeon HD 4350] [1002:954f] (prog-if 00 [VGA controller])
> Subsystem: Hightech Information System Ltd. Device [1787:2271]
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
> MachineType: Dell Inc. Dell DXP061
> ProcEnviron:
> LANGUAGE=en_GB:en
> PATH=(custom, no user)
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=d30f0894-f34b-416e-828c-7e5549c1f048 ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 11/22/2007
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: 2.5.3
> dmi.board.name: 0WG855
> dmi.board.vendor: Dell Inc.
> dmi.chassis.type: 7
> dmi.chassis.vendor: Dell Inc.
> dmi.modalias: dmi:bvnDellInc.:bvr2.5.3:bd11/22/2007:svnDellInc.:pnDellDXP061:pvr:rvnDellInc.:rn0WG855:rvr:cvnDellInc.:ct7:cvr:
> dmi.product.name: Dell DXP061
> dmi.sys.vendor: Dell Inc.
> version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu5
...

Read more...

Didier Roche (didrocks) on 2011-11-15
Changed in unity-distro-priority:
status: Fix Released → Fix Committed
Changed in compiz-plugins-main:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Confirmed → Invalid
Changed in compiz-plugins-main (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
assignee: Sam Spilsbury (smspillaz) → Marco Trevisan (Treviño) (3v1n0)
Changed in compiz-plugins-main (Ubuntu):
assignee: Sam Spilsbury (smspillaz) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Hairo R. Carela (hairocr8) wrote :

Same here...

Omer Akram (om26er) on 2011-11-28
no longer affects: unity (Ubuntu)
Omer Akram (om26er) on 2011-11-28
no longer affects: unity
Kamil Nadeem (nadeemsdreamz) wrote :

I found a solution and its working for me Ubuntu 11.10. Use your workspace switcher like you , do you dragging of windows and stuff but instead of double left clicking on the workspace use right click.
Hope It helps.

Rizadh (rizadh97) wrote :

Thanks! :)

But I've found that if you double left click than enter workplace switcher then left click the overlay still appears.

yeah, the left click is cool! :) Thx!

2011-11-29 17:05 keltezéssel, Rizadh írta:
> Thanks! :)
>
> But I've found that if you double left click than enter workplace
> switcher then left click the overlay still appears.
>

Left click works, but this is just a temporary solution... it was meant for using double click without problems...

So is this fixed or not? It is incredibly annoying.

I have set (with ccsm) the drop action to button 2 (middle button), and never had it again. See comment #20. It's a workaround, but a good one for the time being.

@Christie:
The bug has been fixed in code, but it has not landed to Oneiric yet.

You can compile the fixed branch by hand...

Martin Pitt (pitti) wrote :

Applying this to precise is currently blocked as this change does not have a corresponding test, so assigning to Didier who will assign it to the correct person in DX.

Changed in compiz-plugins-main (Ubuntu Oneiric):
milestone: none → oneiric-updates
Changed in compiz-plugins-main (Ubuntu):
milestone: oneiric-updates → ubuntu-12.04-beta-1
Changed in compiz-plugins-main (Ubuntu Oneiric):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in compiz-plugins-main (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Didier Roche (didrocks)

Hello Greg, or anyone else affected,

Accepted compiz-plugins-main into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in compiz-plugins-main (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed

Forgot last comment, I've posted it on the wrong bug. Sorry.

Forget last comment, I've posted it on the wrong bug. Sorry.

Miklos Juhasz (mjuhasz) wrote :

The proposed version resolves this bug for me.

I can also confirm that the proposed version does fix this bug. Thanks

Martin Pitt (pitti) on 2011-12-05
tags: added: verification-done
removed: verification-needed
John Lea (johnlea) on 2011-12-13
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
status: New → Triaged
importance: Undecided → High
summary: - Compiz grid overlay appears after workspace switcher use
+ Window management - Compiz grid overlay appears after workspace switcher
+ use
Changed in compiz-plugins-main:
status: Confirmed → In Progress
Clint Byrum (clint-fewbar) wrote :

Please make sure this is fixed in Precise, as that is the only thing blocking this fix from progressing into oneiric-updates.

mattdu61 (mattdu61) wrote :

I confirm that the patch does fix the bug.

meist3r (meist3r) wrote :

After installing the latest update this issue is fixed for me. Good job.

Changed in compiz-grid-plugin:
status: New → Triaged
importance: Undecided → High
Nidal R (nidalrashid) wrote :

Why is it taking so long for the patch to be released? Is there no one using Precise to confirm whether this works or not?

Adolfo Jayme (fitoschido) wrote :

I think everyone went on holidays ;)

Daniel van Vugt (vanvugt) wrote :

The fix for this bug is now in oneiric-proposed. So it will in theory go into oneiric-updates soon enough.

Unfortunately precise does not seem to have the fix at all, and is way behind oneiric-proposed right now. This sync problem between the oneiric and precise code is described in bug 910698.

compiz-plugins-main (1:0.9.6-0ubuntu4.1) oneiric-proposed; urgency=low

  * debian/patches/fix-875557.patch:
    - Compiz grid overlay appears after workspace switcher use.
      (LP: #875557)
  * debian/patches/fix-891886.patch:
    - Compiz grid plugin is fired when resizing a window. (LP: #891886)

 -- Omer Akram <email address hidden> Mon, 05 Dec 2011 15:36:29 +0100

See:
https://launchpad.net/ubuntu/oneiric/+source/compiz-plugins-main
https://launchpad.net/ubuntu/precise/+source/compiz-plugins-main

Mark East (feasty) wrote :

This bug is a complete pain and I've been waiting months for the fix. Can someone see that this is released as a matter of urgency as it's a constant problem on my (and clearly many others) desktop and hinders my work! It is also stopping loads of people from upgrading their secondary Linux machines as they think it's a load of crap when they see glaring bugs like this go on for months.

Yep, I understand this is a nasty bug, but you can workaround it in very easy way by assigning the middle mouse button to windows movement in expo-mode, which is a minor pain... I have done it and I suppose I will leave it as is...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-plugins-main - 1:0.9.6-0ubuntu4.2

---------------
compiz-plugins-main (1:0.9.6-0ubuntu4.2) oneiric-proposed; urgency=low

  * debian/patches/fix-876591.patch:
    - Ctrl-Alt-KP_9 adjusts window to upper half instead of top right corner
      (behaves like Ctrl-Alt-KP_8)
      (lp: #876591)

compiz-plugins-main (1:0.9.6-0ubuntu4.1) oneiric-proposed; urgency=low

  * debian/patches/fix-875557.patch:
    - Compiz grid overlay appears after workspace switcher use.
      (LP: #875557)
  * debian/patches/fix-891886.patch:
    - Compiz grid plugin is fired when resizing a window. (LP: #891886)
 -- Omer Akram <email address hidden> Mon, 05 Dec 2011 20:38:27 +0500

Changed in compiz-plugins-main (Ubuntu):
status: In Progress → Fix Released
Changed in compiz-plugins-main (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Andrew Hayzen (andrew-hayzen) wrote :

Hi

Just updated compiz-plugins-main

Description: Ubuntu 11.10
Release: 11.10

compiz-plugins-main:
  Installed: 1:0.9.6-0ubuntu4.2
  Candidate: 1:0.9.6-0ubuntu4.2
  Version table:
 *** 1:0.9.6-0ubuntu4.2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:0.9.6-0ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages

I can confirm that on Oneiric this bug has been successfully resolved :)

Thank you to everyone who has worked on this bug, keep up the good work.

Many thanks

Andy

Daniel van Vugt (vanvugt) wrote :

It appears this fix (which affects both grid and expo) is missing from both upstream projects' branches.

Changed in compiz-expo-plugin:
status: New → Triaged
importance: Undecided → High
Changed in compiz-grid-plugin:
status: Triaged → In Progress
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz-grid-plugin:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Oops. The fix for this one seems to be expo only. Not grid.

no longer affects: compiz-grid-plugin
Changed in compiz-expo-plugin:
status: Triaged → In Progress
assignee: nobody → Daniel van Vugt (vanvugt)
Didier Roche (didrocks) on 2012-01-19
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
no longer affects: compiz-expo-plugin
Daniel van Vugt (vanvugt) wrote :

Hi 3v1n0, could you please port this bug fix upstream to:
lp:compiz-expo-plugin

Otherwise it looks like the fix will be missing in Ubuntu 12.04 when that uses compiz-plugins-main 0.9.7.x...
(see bug 918057)

Changed in compiz-plugins-main:
importance: Medium → High
milestone: none → 0.9.7.0
Changed in compiz-expo-plugin:
status: New → Triaged
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High
Tim Penhey (thumper) on 2012-02-07
Changed in ayatana-design:
status: Triaged → Fix Committed
Marcos Nino-Ruiz (mninoruiz) wrote :

Well, I am not an expert, but I came to this place because the orange transparent window appears suddenly out of nowhere, after trying to resize a window. I installed Unity yesterday a performed a full update and upgrade.. this means this is still affecting this version

Changed in compiz-plugins-main:
milestone: 0.9.7.0 → none
Nick Tait (jnick-tait) on 2012-03-08
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
Changed in compiz-plugins-main:
status: In Progress → Fix Released
Changed in compiz-expo-plugin:
status: Triaged → Fix Released
Bilal Akhtar (bilalakhtar) wrote :

This bug has resurfaced in Quantal, as of Unity 6.0.

Changed in compiz-plugins-main (Ubuntu Quantal):
status: Fix Released → Triaged
milestone: ubuntu-12.04-beta-1 → ubuntu-12.10-beta-1
Omer Akram (om26er) wrote :

>> This bug has resurfaced in Quantal, as of Unity 6.0.

@Bilal can you check and make sure you are not using the staging ppa? if the issue is there for you please open a new bug

Changed in compiz-plugins-main (Ubuntu Quantal):
status: Triaged → Fix Released
Changed in unity:
status: New → Invalid
Omer Akram (om26er) wrote :

This issue started after this commit to compiz trunk (I believe) http://bazaar.launchpad.net/~compiz-team/compiz/0.9.8/revision/3307

Changed in compiz-plugins-main (Ubuntu Quantal):
milestone: ubuntu-12.10-beta-1 → none
Daniel van Vugt (vanvugt) wrote :

The regression of this bug has been reported as bug 1037142, I think.

Bilal Akhtar (bilalakhtar) wrote :

@Omer: No, I'm NOT using any PPA for compiz. And it's still not fixed in quantal, but the bug report that tracks it is now bug #1037142

Tory (tory-andrew-law) wrote :

Still exists in 13.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers