drag from dash to launcher

Bug #662616 reported by Christian Giordano on 2010-10-18
100
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
High
Jason Smith
unity-2d
High
Olivier Tilloy
unity (Ubuntu)
High
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Cannot drag and drop from the Dash to the Launcher. The prevents opening files in applications or adding applications to launcher.

See spec: http://use-case-mapper.canonical.com/specifications/0ASy0fFup3CvEZGRibTl0YmJfNjgyMmN4emM0

Related branches

Changed in ayatana-design:
importance: Undecided → High
Changed in unity:
status: New → Confirmed
tags: removed: natty
Alex Launi (alexlauni) on 2010-11-16
Changed in unity (Ubuntu):
status: New → Confirmed
Neil J. Patel (njpatel) on 2010-12-01
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → High
milestone: none → 3.4
status: Confirmed → Triaged
John Lea (johnlea) on 2010-12-16
Changed in ayatana-design:
status: New → Fix Committed
assignee: nobody → John Lea (johnlea)
tags: added: udn-launcher udt
tags: added: udn-dash
description: updated
John Lea (johnlea) on 2011-01-13
Changed in ayatana-design:
status: Fix Committed → Fix Released
David Barth (dbarth) on 2011-01-13
Changed in unity:
assignee: Neil J. Patel (njpatel) → Jason Smith (jassmith)
Neil J. Patel (njpatel) on 2011-01-18
Changed in unity:
milestone: 3.4 → 3.6
Changed in unity-2d:
status: New → Triaged
milestone: none → 3.6
importance: Undecided → High
Mark Shuttleworth (sabdfl) wrote :

This is indeed high importance and required for Natty.

Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity-2d:
assignee: nobody → Olivier Tilloy (osomon)
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity-2d:
milestone: 3.6 → none

This is an important behaviour, why drop it from the milestone?

Mark

Florian Boucault (fboucault) wrote :

@Mark: it will not make it before feature freeze I am afraid. I will do a round of scheduling for the next milestone (3.8) and will assign that task to it then.

Didier Roche (didrocks) on 2011-03-01
Changed in unity:
milestone: 3.6 → 3.6.2
Changed in unity-2d:
assignee: Olivier Tilloy (osomon) → nobody
milestone: none → 3.8
Neil J. Patel (njpatel) wrote :

Though this works in natty now, it's wonky as hell so I'm leaving it open pending some cleanups.

Changed in unity:
milestone: 3.6.2 → 3.6.4
milestone: 3.6.4 → 3.6.6
tags: added: delta-with-3d
Changed in unity-2d:
milestone: 3.8 → 3.10
Changed in unity-2d:
milestone: 3.10 → none
Neil J. Patel (njpatel) wrote :

This is fixed in Unity, the issue is that there is a nice big black square instead of a proper icon, but that is being tracked by another bug (https://bugs.launchpad.net/unity/+bug/727675).

For remaining issues, please open individual bug reports that are easier to track, thanks!

Changed in unity:
status: Triaged → Fix Released
Joaquin (jknvv13) wrote :

But on Unity 2D there's no way to do drag and drop.

2011/3/15 Neil J. Patel <email address hidden>

> This is fixed in Unity, the issue is that there is a nice big black
> square instead of a proper icon, but that is being tracked by another
> bug (https://bugs.launchpad.net/unity/+bug/727675).
>
> For remaining issues, please open individual bug reports that are easier
> to track, thanks!
>
> ** Changed in: unity
> Status: Triaged => Fix Released
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (729133).
> https://bugs.launchpad.net/bugs/662616
>
> Title:
> drag from dash to launcher
>
> Status in Ayatana Design:
> Fix Released
> Status in Unity:
> Fix Released
> Status in Unity 2D:
> Triaged
> Status in “unity” package in Ubuntu:
> Triaged
>
> Bug description:
> Cannot drag and drop from the Dash to the Launcher. The prevents
> opening files in applications or adding applications to launcher.
>
> See spec: http://use-case-
> mapper.canonical.com/specifications/0ASy0fFup3CvEZGRibTl0YmJfNjgyMmN4emM0
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ayatana-design/+bug/662616/+subscribe
>

Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package unity - 3.6.6-0ubuntu1

---------------
unity (3.6.6-0ubuntu1) natty; urgency=low

  * New upstream release:
    - drag and drop from dash to launcher issues (LP: #727675)
    - unity-panel-service crashed in g_type_class_meta_marshal (LP: #727788)
    - Dash: first-use text entry does not work until Alt-F2 version is used
      (LP: #735342)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #734721)
    - drag from dash to launcher (LP: #662616)
    - Dash - Create single widget for Dashboard (LP: #683729)
    - [FFe] Recently installed applications should be easy to run
      (LP: #670403)
    - Pressing Alt key does not underline mnemonics (LP: #689179)
    - indicator-appmenu breaks Alt accelerator keys (LP: #663030)
    - can't pin KTouch to the launcher (LP: #693755)
    - Unity paints multiple times with multi-screen (LP: #727116)
    - unitymtgrabhandles crashes when no key is set (LP: #727144)
    - SIGSEGV in PlaceEntryHome::SetSearch (LP: #731927)
    - [launcher] New Default favorites (LP: #714707)
    - Dash: Alt-F2 Pressing enter on the dash can start the first entry of the
      second group from the history (LP: #734738)
    - Dash: keyboard arrow navigation disappears off bottom (LP: #735347)
    - Increase the size of the top left Launcher reveal area from 1px to a 3px
      by 3px square (LP: #736034)
    - [dash] scrollbar's clickable zone should extend to the right border of
      the dash border (LP: #651398)
    - Launcher - Replace Dash lens Launcher icons with updated versions
      (LP: #676613)
    - NuxUtilAccessible requires to implement support to key event listeners
      (LP: #702672)
    - launcher icons dnd doesn't behave correctly when the dash is in use
      (LP: #708885)
    - Keyboard-navigation: highlight stays after losing focus (LP: #713632)
    - Implement AtkComponent for ATK objects in the panel service
      (LP: #715297)
    - Super shortcuts for application place and worskspace swither conflicts
      with compiz keys (LP: #723273)
    - Use DeeIndex instead of strcmp in PlaceEntryHome (LP: #724886)
    - [dash] text cursor not vertically centred in the entry (LP: #724927)
    - Moving cursor in dash text entry field causes cursor artifacts
      (LP: #725493)
    - Missing "children_changed" event emission from the atk support
      (LP: #727137)
    - Typing should immediately search; focusing the search field is fiddly
      (LP: #727295)
    - "Find Internet Apps", "Browse the Web", and "Check Mail" are scattered
      in default Dash (LP: #729009)
    - Press-holding on a icon in the Launcher should de-couple the icon and
      enable the user to reorder the icon vertically without leaving the
      Launcher. (LP: #727922)
    - "Shortcuts" heading in Dash seems pointless (LP: #729000)
    - intellihide is incompatible with totem fullscreen / Still some false
      positive on ws switch (LP: #730679)
    - Launcher - provide visual design for launcher keyboard navigation
      (LP: #702490)
    - Dash - Update the 'Shortcuts' dash home icon (LP: #689763)
    - The Unity panel service Does not connect to the
      INDICATOR_OBJECT...

Read more...

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Joaquin (jknvv13) wrote :
Download full text (5.9 KiB)

Not working on 2D version...

2011/3/17 Launchpad Bug Tracker <email address hidden>

> This bug was fixed in the package unity - 3.6.6-0ubuntu1
>
> ---------------
> unity (3.6.6-0ubuntu1) natty; urgency=low
>
> * New upstream release:
> - drag and drop from dash to launcher issues (LP: #727675)
> - unity-panel-service crashed in g_type_class_meta_marshal (LP: #727788)
> - Dash: first-use text entry does not work until Alt-F2 version is used
> (LP: #735342)
> - compiz crashed with SIGSEGV in g_type_check_instance_is_a()
> (LP: #734721)
> - drag from dash to launcher (LP: #662616)
> - Dash - Create single widget for Dashboard (LP: #683729)
> - [FFe] Recently installed applications should be easy to run
> (LP: #670403)
> - Pressing Alt key does not underline mnemonics (LP: #689179)
> - indicator-appmenu breaks Alt accelerator keys (LP: #663030)
> - can't pin KTouch to the launcher (LP: #693755)
> - Unity paints multiple times with multi-screen (LP: #727116)
> - unitymtgrabhandles crashes when no key is set (LP: #727144)
> - SIGSEGV in PlaceEntryHome::SetSearch (LP: #731927)
> - [launcher] New Default favorites (LP: #714707)
> - Dash: Alt-F2 Pressing enter on the dash can start the first entry of
> the
> second group from the history (LP: #734738)
> - Dash: keyboard arrow navigation disappears off bottom (LP: #735347)
> - Increase the size of the top left Launcher reveal area from 1px to a
> 3px
> by 3px square (LP: #736034)
> - [dash] scrollbar's clickable zone should extend to the right border of
> the dash border (LP: #651398)
> - Launcher - Replace Dash lens Launcher icons with updated versions
> (LP: #676613)
> - NuxUtilAccessible requires to implement support to key event listeners
> (LP: #702672)
> - launcher icons dnd doesn't behave correctly when the dash is in use
> (LP: #708885)
> - Keyboard-navigation: highlight stays after losing focus (LP: #713632)
> - Implement AtkComponent for ATK objects in the panel service
> (LP: #715297)
> - Super shortcuts for application place and worskspace swither conflicts
> with compiz keys (LP: #723273)
> - Use DeeIndex instead of strcmp in PlaceEntryHome (LP: #724886)
> - [dash] text cursor not vertically centred in the entry (LP: #724927)
> - Moving cursor in dash text entry field causes cursor artifacts
> (LP: #725493)
> - Missing "children_changed" event emission from the atk support
> (LP: #727137)
> - Typing should immediately search; focusing the search field is fiddly
> (LP: #727295)
> - "Find Internet Apps", "Browse the Web", and "Check Mail" are scattered
> in default Dash (LP: #729009)
> - Press-holding on a icon in the Launcher should de-couple the icon and
> enable the user to reorder the icon vertically without leaving the
> Launcher. (LP: #727922)
> - "Shortcuts" heading in Dash seems pointless (LP: #729000)
> - intellihide is incompatible with totem fullscreen / Still some false
> positive on ws switch (LP: #730679)
> - Launcher - provide visual design for launcher keyboard navigation
> ...

Read more...

Florian Boucault (fboucault) wrote :

Olivier estimates it to around 12 hours of work left.

John Lea (johnlea) wrote :

Bug reverted to Triaged because:

1) Dragging and dropping a file icon from the File Lens on the Launcher is broken. When the spread appears, the user is no longer able to drop the file on the Launcher icon to open the file in a new window.

2) Dragging and dropping a application that is 'Available for download' to the Launcher doesn't work, dropping the file in the Launcher does not install the application. Also when a user starts dragging a 'Available to Download' application the icon for the application disappears.

Changed in unity:
status: Fix Released → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Triaged

Initially the dragging of an icon from dash to the launcher works. However, once I have removed an icon from the launcher, dragging to the launcher stops working. Mysteriously, it later starts working again, and I can once again drag to the launcher!

I can get this to work only about one out of 30 attempts or so. See attached video.

Joaquin (jknvv13) wrote :

I can't drag&drop with Unity2D
El 02/04/2011 21:57, "Andrew Starr-Bochicchio" <email address hidden>
escribió:
> I can get this to work only about one out of 30 attempts or so. See
> attached video.
>
> ** Attachment added: "out-1.ogv"
>
https://bugs.launchpad.net/unity/+bug/662616/+attachment/1970022/+files/out-1.ogv
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (729133).
> https://bugs.launchpad.net/bugs/662616
>
> Title:
> drag from dash to launcher
>
> Status in Ayatana Design:
> Fix Released
> Status in Unity:
> Triaged
> Status in Unity 2D:
> Triaged
> Status in “unity” package in Ubuntu:
> Triaged
>
> Bug description:
> Cannot drag and drop from the Dash to the Launcher. The prevents
> opening files in applications or adding applications to launcher.
>
> See spec: http://use-case-
> mapper.canonical.com/specifications/0ASy0fFup3CvEZGRibTl0YmJfNjgyMmN4emM0
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ayatana-design/+bug/662616/+subscribe

Jason Smith (jassmith) on 2011-04-08
Changed in unity:
milestone: 3.6.6 → 3.8.6
status: Triaged → Fix Committed
Joaquin (jknvv13) wrote :

It's not fixed on Unity2D
El 09/04/2011 01:25, "Jason Smith" <email address hidden> escribió:
> ** Changed in: unity
> Milestone: 3.6.6 => 3.8.6
>
> ** Changed in: unity
> Status: Triaged => Fix Committed
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (729133).
> https://bugs.launchpad.net/bugs/662616
>
> Title:
> drag from dash to launcher
>
> Status in Ayatana Design:
> Fix Released
> Status in Unity:
> Fix Committed
> Status in Unity 2D:
> Triaged
> Status in “unity” package in Ubuntu:
> Triaged
>
> Bug description:
> Cannot drag and drop from the Dash to the Launcher. The prevents
> opening files in applications or adding applications to launcher.
>
> See spec: http://use-case-
> mapper.canonical.com/specifications/0ASy0fFup3CvEZGRibTl0YmJfNjgyMmN4emM0
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ayatana-design/+bug/662616/+subscribe

Olivier Tilloy (osomon) wrote :

> It's not fixed on Unity2D

Which is why the status of the bug for unity-2d is "Triaged".

Didier Roche (didrocks) on 2011-04-11
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.6-0ubuntu1

---------------
unity (3.8.6-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGABRT in raise() (LP: #748163)
    - System freezes when maximize button is clicked (LP: #754063)
    - compiz crashed with SIGSEGV in QuicklistView::IsMenuItemSeperator()
      (LP: #754302)
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #754235)
    - compiz crashed with SIGSEGV in ubus_server_pump_message_queue()
      (LP: #754657)
    - drag from dash to launcher (LP: #662616)
    - Add a test case for unity-decorator regressions (LP: #736878)
    - the files place category combo has empty space (LP: #741641)
    - panel superposition (LP: #742859)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - [FFE] Need API to set urgency from background process (LP: #747677)
    - Launcher - Escape from 'drag behind the Launcher' interaction
      (LP: #750298)
    - Launcher needs to be desaturated when Dash is open, not transparent.
      (LP: #750358)
    - compiz crashed with SIGSEGV in free() (LP: #752293)
    - migrate_favorites.py crashed with ImportError in __main__: No module
      named gconf (LP: #752176)
    - compiz crashed with SIGSEGV in PluginClassHandler<DecorWindow,
      CompWindow, 0>::get() (LP: #743807)
    - cannot close the dash by clicking on the bfb (LP: #753914)
    - Animation for Grid Previews is broken (LP: #754088)
    - compiz crashed with SIGSEGV in PanelMenuView::OnPlaceViewShown()
      (LP: #754585)
    - Pressing F10 then "left arrow" wit Unity on Natty makes the system
      unusable (LP: #756867)
    - compiz crashed with SIGSEGV in __pthread_mutex_lock() (LP: #711231)
    - Tooltips and Dash Font Problems (LP: #741605)
    - Title elipisising incorrect. Type “Shotwell” for a good example
      (LP: #750350)
    - compiz crashed with SIGSEGV in Launcher::Launcher() (LP: #748096)
    - BFB - Turn top left corner blue rather than Ubuntu logo (LP: #755286)
    - launcher appears and gets stuck when resizing windows with mouse
      (LP: #754690)
    - Wrong item gets dragged out (LP: #729796)
    - Launcher - when the launcher is folded, the bottom icon partially falls
      off the end of the screen (LP: #731869)
    - unity-window-decorator: Resize padding: Tiny focused windows lose resize
      padding and shadow when <69 pixels wide (LP: #737707)
    - Deinstalling an application with launcher entry leaves orphaned shortcut
      (LP: #748107)
    - Two Nautilus windows open when clicked on a device icon on Launcher
      (started after 3.8.2) (LP: #748299)
    - compiz crashed with SIGSEGV in Launcher::AnimationTimeout()
      (LP: #749890)
  * debian/control:
    - build-dep on latest nux (ABI break)
  * debian/unity-common.install:
    - install the desktop file for the new capplet
 -- Didier Roche <email address hidden> Mon, 11 Apr 2011 12:42:33 +0200

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Joaquin (jknvv13) wrote :
Download full text (3.7 KiB)

I reported this bug for Unity2D...
El 11/04/2011 13:03, "Launchpad Bug Tracker" <email address hidden>
escribió:
> This bug was fixed in the package unity - 3.8.6-0ubuntu1
>
> ---------------
> unity (3.8.6-0ubuntu1) natty; urgency=low
>
> * New upstream release.
> - compiz crashed with SIGABRT in raise() (LP: #748163)
> - System freezes when maximize button is clicked (LP: #754063)
> - compiz crashed with SIGSEGV in QuicklistView::IsMenuItemSeperator()
> (LP: #754302)
> - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
> (LP: #754235)
> - compiz crashed with SIGSEGV in ubus_server_pump_message_queue()
> (LP: #754657)
> - drag from dash to launcher (LP: #662616)
> - Add a test case for unity-decorator regressions (LP: #736878)
> - the files place category combo has empty space (LP: #741641)
> - panel superposition (LP: #742859)
> - Unity Launcher stops autohiding and is not responsive (LP: #744325)
> - Unity Launcher stops autohiding and is not responsive (LP: #744325)
> - [FFE] Need API to set urgency from background process (LP: #747677)
> - Launcher - Escape from 'drag behind the Launcher' interaction
> (LP: #750298)
> - Launcher needs to be desaturated when Dash is open, not transparent.
> (LP: #750358)
> - compiz crashed with SIGSEGV in free() (LP: #752293)
> - migrate_favorites.py crashed with ImportError in __main__: No module
> named gconf (LP: #752176)
> - compiz crashed with SIGSEGV in PluginClassHandler<DecorWindow,
> CompWindow, 0>::get() (LP: #743807)
> - cannot close the dash by clicking on the bfb (LP: #753914)
> - Animation for Grid Previews is broken (LP: #754088)
> - compiz crashed with SIGSEGV in PanelMenuView::OnPlaceViewShown()
> (LP: #754585)
> - Pressing F10 then "left arrow" wit Unity on Natty makes the system
> unusable (LP: #756867)
> - compiz crashed with SIGSEGV in __pthread_mutex_lock() (LP: #711231)
> - Tooltips and Dash Font Problems (LP: #741605)
> - Title elipisising incorrect. Type “Shotwell” for a good example
> (LP: #750350)
> - compiz crashed with SIGSEGV in Launcher::Launcher() (LP: #748096)
> - BFB - Turn top left corner blue rather than Ubuntu logo (LP: #755286)
> - launcher appears and gets stuck when resizing windows with mouse
> (LP: #754690)
> - Wrong item gets dragged out (LP: #729796)
> - Launcher - when the launcher is folded, the bottom icon partially falls
> off the end of the screen (LP: #731869)
> - unity-window-decorator: Resize padding: Tiny focused windows lose resize
> padding and shadow when <69 pixels wide (LP: #737707)
> - Deinstalling an application with launcher entry leaves orphaned shortcut
> (LP: #748107)
> - Two Nautilus windows open when clicked on a device icon on Launcher
> (started after 3.8.2) (LP: #748299)
> - compiz crashed with SIGSEGV in Launcher::AnimationTimeout()
> (LP: #749890)
> * debian/control:
> - build-dep on latest nux (ABI break)
> * debian/unity-common.install:
> - install the desktop file for the new capplet
> -- Didier Roche <email address hidden> Mon, 11 Apr 2011 12:42:33 +0200
>
> ** Changed in: unity (Ubuntu)
> Status: Triaged => Fix Released
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplica...

Read more...

James Clemence (jvc26) wrote :

It looks like both Unity-2D and Unity-3D bugs have been merged into
this single bug report - might be worth separating them out otherwise
it can't really be marked as complete.

J

Olivier Tilloy (osomon) wrote :

@James: they are not "merged"; we use the same bug report to track the issue in both projects. If you open the bug in a web browser, you will notice that the status of the bug for unity-2d is still "Triaged", meaning we are aware it’s not fixed there.

@Joaquín: unfortunately Launchpad doesn’t allow to filter bug-mail on a project basis, so you are also receiving status updates even if the changes affect only unity, not unity-2d. That’s unfortunate. However you don’t need to systematically confirm that it is still valid in unity-2d, unless the status is incorrect. Look for the "** Changed in: …" line at the end of the e-mails to know which project a given status update concerns. Even though we try hard to keep synchronization with unity, if a bug report is marked "Confirmed" or "Triaged" for unity-2d, then we are aware it’s not fixed yet.

James Clemence (jvc26) wrote :

Ah that makes sense - my bad, had just assumed from the email
correspondance. Thanks for the clear-up.

J

John Lea (johnlea) on 2011-04-18
tags: added: buggybutclosed reviewedbydesign
removed: udt
Changed in unity-2d:
milestone: none → 3.10
Bill Filler (bfiller) on 2011-05-02
Changed in unity-2d:
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) on 2011-05-05
Changed in unity-2d:
status: Triaged → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Fix Committed
Changed in unity-2d:
milestone: 3.10 → 3.8.8
Didier Roche (didrocks) on 2011-06-14
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 3.8.8-0ubuntu1

---------------
unity-2d (3.8.8-0ubuntu1) oneiric; urgency=low

  [ Didier Roche ]
  * new upstream release:
    - [spread] Corruption when switching workspaces after windows have been
      moved to other workspaces (LP: #760787)
    - [launcher] launcher won't fully paint, corrupted view (LP: #764690)
    - [launcher] icons no longer active after an incomplete drag (LP: #768812)
    - drag from dash to launcher (LP: #662616)
    - Don't create windows over the launcher (LP: #688816)
    - [launcher] Does not reveal when hovering over the left edge of the
      screen (LP: #760537)
    - UIFe: Launcher - update launcher reveal interaction to make it more
      accessible to first time users (LP: #754583)
    - [launcher] Trash icon should indicate when it has deleted elements
      (LP: #715611)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - double clicks should be disabled on bfb/Place launcher icon/double key
      press (LP: #766776)
    - [dash][launcher] Should use real transparency when a compositing manager
      is running (LP: #794042)
    - [dash] Thunderbird icon is pixelated (LP: #767115)
    - [panel] Hovering the mouse cursor over the BFB reveals the current
      window’s menu (LP: #793403)
    - [panel] Hovering the mouse cursor away from the appmenu applet doesn’t
      hide the menu (LP: #793406)
    - unity-2d: does not parse QT_GRAPHICSSYSTEM env var (LP: #791852)
    - Cannot drag applications from dash to desktop (LP: #756614)
  * debian/control:
    - unity-2d-panel recommends the indicator, not unity-2d
    - appmenu-gtk and appmenu-qt are already provided by indicator-appmenu
    - remove other meaningless recommends
  * debian/libunity-2d-private0.install:
    - install everything in Unity2d private directory

  [ Florian Boucault ]
  * debian/unity-2d-launcher.install:
    - do not install usr/lib/qt4/imports/UnityApplications/ anylonger as all of
      UnityApplications features have been moved to the Unity2d QML plugin
      installed by libunity-2d-private0
  * debian/control:
    - unity-2d-places and unity-2d-spread do not depend on unity-2d-launcher.
      All they need is now in libunity-2d-private0.
 -- Didier Roche <email address hidden> Tue, 14 Jun 2011 16:14:18 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments