[regression] Icon count is not shown if the icon is not transformed

Bug #1171663 reported by Marco Trevisan (Treviño) on 2013-04-23
100
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Marco Trevisan (Treviño)
7.1
Fix Released
High
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Raring
High
Marco Trevisan (Treviño)

Bug Description

[Impact]

Icon count not shown.

[Test Case]

The icon emblem count for an icon is not shown in unity if the icon is not moved, rotated or folded after that the count has been updated.

[Regression Potential]

None.

Related branches

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision 3312, scheduled for release in unity, milestone 7.1.0

Changed in unity:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity/7.0 at revision 3313, scheduled for release in unity, milestone 7.0.1

Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Raring):
status: New → Confirmed
description: updated
Changed in unity (Ubuntu Raring):
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :
Download full text (12.1 KiB)

This bug was fixed in the package unity - 7.0.0daily13.06.07-0ubuntu1

---------------
unity (7.0.0daily13.06.07-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * gtk_icon_info_free() is deprecated for g_object_unref().
  * Upstart event for when the indicators are loaded by the panel
    service.
  * Add an upstart job to unity-common.
  * Manage Unity Panel Service's lifecycle with Upstart.

  [ Didier Roche ]
  * add dep on autopilot-desktop.
  * Revert the panel on upstart from ted, it doesn't respawn as expected
    when another service try to communicate with the panel service and
    the consequence is a lot of tests failing

  [ Nick Dedekind ]
  * Uses a gobject weak ref to test for object deletion in the
    GLibObject tests. Previously was checking with G_IS_OBJECT on an
    invalid pointer, which was causing a segfault

  [ Manuel de la Pena ]
  * Adds support for payment previews that will allow users to buy music
    from within the dash. .

  [ Mathieu Trudel-Lapierre ]
  * Increase timeouts for hud functional and search tests.

  [ Francis Ginther ]
  * Handle StateNotFoundError when querying the label of a hud button.

  [ Łukasz 'sil2100' Zemczak ]
  * Now that we're using the new HUD, there have been some changes that
    typically cause test_hud tests to fail. Fix the tests to fit the new
    model. The first one is that generally we do not have indicator
    entries visible in the HUD anymore. Only application menu entries
    are in it now. The second one - the way the results are displayed is
    different. Now, instead of "Menu > Entry" we have "Entry (Menu)"
    etc.
  * Fix two HUD failures related to HUD slow action activation.
  * Fix some autopilot test failures, some related to test_shortcut_hint
    and some to test_scroll in launcher.
  * Modify all the hud_query_check lambdas to be more smart and error-
    checking. Same for the selected_hud_button method in the HUD
    emulator. Also, get rid of the troublesome test_gedit_undo and
    change it into test_gedit_save, which is easier to test and anyway
    tests what we want. Besides that we also now try to handle the
    StateNotFoundError exception in the HUD emulator, another cause of
    some AP failures.
  * Add a flag for -Wno-error=unused-local-typedefs, since this causes a
    FTBFS on ARM

  [ Michal Hruby ]
  * Don't activate a result twice after pressing Enter. (LP: #1188191)

  [ Sebastien Bacher ]
  * Use '%s:' string for preview hints, rather than just appending ':'.
    (LP: #1074038)

  [ Marco Trevisan (Treviño) ]
  * IconRenderer: preprocess an icon if its emblem has been shown/hidden
    In that way we can update its transformation. (LP: #1171476,
    #1171663)
  * UnityWindow: don't draw the panel shadow above a fullscreen window.
    (LP: #1171934)
  * UnityCore: add GtkWrapper to handle GtkIconInfo correctly for
    different GTK versions Fix a memory leak in LauncherIcon. (LP:
    #1180790)
  * SwitcherController: use proper long long types for
    WindowActiveNumber Otherwise an overflow can cause bad window
    selection after long uptime.
  * Unity: "s/unsigned long long/uint64_t/g".

  [ Chris Townsend ]
  * Fixes issue where minimiz...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Hansen (moteprime) wrote :

Are the fix not going to be applied to Raring?

> Are the fix not going to be applied to Raring?

Please be patient: an update to a stable release takes time and careful scrutiny. I see the fix is already in the queue
fir Ubuntu 13.04 and will appear in the archives in due course.

Hansen (moteprime) wrote :

Thank you for your reply.
I'm sorry if i appear to be impatient, but was merely asking because i did not know.

Hello Marco, or anyone else affected,

Accepted unity into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.0.0daily13.06.19~13.04-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: added: verification-needed

The issue is NOT reproducible with unity 7.0.0daily13.06.19~13.04-0ubuntu1 amd64 from raring-proposed.
Thanks!

tags: added: verification-done
removed: verification-needed
Hansen (moteprime) wrote :

I have tried the last 24 hours, but cannot find the package in raring/proposed.

Hansen (moteprime) wrote :

@Dmitry Shachnev. thank you for your reply.
I don't know if i misunderstand something, but i was trying to install it by enabling proposed, updating and selecting it either in synaptic or update manager, but i can't find it.
Is the only way to download and install?

Stephen M. Webb (bregma) wrote :

@Hansen: no you do not misunderstand.

The binary deb is in the raring-proposed pocket, available for installation and testing using your favourite package manager.

stephenw@ariel:~$ apt-cache policy unity
unity:
  Installed: 7.0.0daily13.06.19~13.04-0ubuntu1
  Candidate: 7.0.0daily13.06.19~13.04-0ubuntu1
  Version table:
 *** 7.0.0daily13.06.19~13.04-0ubuntu1 0
        500 http://ubuntu.mirror.iweb.ca/ raring-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     7.0.0daily13.04.18~13.04-0ubuntu1 0
        500 http://ubuntu.mirror.iweb.ca/ raring/main amd64 Packages

If you do not see this, please recheck your APT settings.

Hansen (moteprime) wrote :

Can now also confirm unity 7.0.0daily13.06.19~13.04-0ubuntu1 amd64 fixes the bug.
Thanks

@Stephen M. Webb - Thanks.
I installed Smart Scopes couple of days ago, got a experimental Unity with that. Got it fixed now.

I'm still waiting to see the progress bar for unread mail reappear on my Thunderbird icon. I'm not competent to extract and install patches, I'm just waiting for the fix to appear in the standard updates. When can we expect that?

PS: I appreciate that you have added this to proposed updates for raring, but when I enable proposed updates, I see a great many items, including kernel updates, most of which I presumably do not want, and no way to identify the desired item or items.

Rowan, the update will be hopefully in main repository soon, but if you only want to update unity, just tick it on the update manager (unselecting the other ones with right-click menu).
Otherwise doing a "sudo apt-get update unity" in a terminal, would also work.

Ok, thanks.

It isn't quite that simple, Marco. "Sudo apt-get update unity" returns "update accepts no arguments." As for the update manager, there are at least seven items in the "Ubuntu base" proposed list which could be relevant, and here is my list of them, but of course I cannot guarantee that there aren't others that are relevant: "Application lens for unity", "Common files for the Unity interface", "Core library for the Unity interface", "Display Manager", "Panel indicator applet - shared library" (twice, one 25kB and the other 29 kB), and "Services for the Unity interface". There is no separate category for "Unity" such that one can select that, or deselect other categories by right-click. Every item just has a tick box which one can untick. So unless I want unexpected proposed modifications installed, some of which might not work, I am better off not trying it. I need a definite name for the specific fix we are talking about, and then I can just untick everything else, tedious though that is (there are over 80 items in the proposed list currently). I think I might be wiser to wait.

I think Marco meant "sudo apt-get update && sudo apt-get install unity".

ah, well, from that I get "Unity is already the latest version. 0 packages installed." But really, I'm too untutored to be any use here. I'll wait until it finds its way into the regular updates.

If today's update is supposed to include this fix, I have to tell you, it isn't working. I have installed the update package and restarted, and I am still not getting a progress bar on my thunderbird icon when I receive new mail. What I have is all-vanilla up-to-date raring.

Saikrishna Arcot (saiarcot895) wrote :

Rowan, what version of Unity do you have? Use "apt-cache policy unity" to see what version you have. If the installed and candidate versions say 7.0.0daily13.04.18~13.04-0ubuntu1, then you need to enable the -proposed pocket.

On 02/08/13 17:29, Saikrishna Arcot wrote:
> Rowan, what version of Unity do you have? Use "apt-cache policy unity"
> to see what version you have. If the installed and candidate versions
> say 7.0.0daily13.04.18~13.04-0ubuntu1, then you need to enable the
> -proposed pocket.
>
Yup, they say that. But as I said previously in this thread, 'proposed'
contained 80 items last time I looked, some of them doubtless
inadvisable, and none of them clearly labelled in any way which would
allow me to identify the desired one. If you could look at the
'proposed' list as seen in the ordinary user's GUI, not as seen by
developers, and tell me what I want, then I shall leave that (or those)
ticked, and untick the other ~79 items (the only way to do it. Thanks.

And why in fact am I not getting it, anyway? Why doesn't this fix work
for all versions of Unity? Why don't I have the desired version of
Unity? Why isn't that part of the general updates?

Yup, they say that. But as I said previously in this thread, 'proposed' contained 80 items last time I looked, some of them doubtless inadvisable, and none of them clearly labelled in any way which would allow me to identify the desired one. This is the first time I have tried to follow through a bug fix. Looking at the 'status' for this fix, I see:

Status in Unity: Fix Committed
Status in Unity 7.1 series: Fix Released
Status in “unity” package in Ubuntu: Fix Released
Status in “unity” source package in Raring: Fix Committed

Since the final line says "committed" but not "released", does that mean I could wait until the fix is "released" for "Raring", which would include Unity 7.0? I failed to spot that crucial qualification in the Status until just now, when you asked me which version of Unity I had, so I am only guessing.

Whoops, sorry for duplication. First I replied by email, then I decided that hadn't worked, so I came to the site and replied again.

Saikrishna Arcot (saiarcot895) wrote :

One method might be to run "sudo apt-get install unity=7.0.0daily13.06.19*" (without the quotes at the ends). This should update unity and necessary dependencies.

Stephen M. Webb (bregma) wrote :

> Since the final line says "committed" but not "released", does that mean I could wait until the fix is "released" for
> "Raring", which would include Unity 7.0?

Yes.

The -proposed pocket is there for testing release candidates to make sure (a) they fix the problem and (2) they do not introduce new problems. Once a few valiant testers verify those conditions hold, the package(s) is (are) moved into the general release archives and the bug marked 'Fix Released'.

So, assuming someone else is testing and verifying the package, you could just wait. The downside to that is nobody else may be interested in verifying the bug is fixed by the release candidate.

On 02/08/13 18:59, Saikrishna Arcot wrote:
> One method might be to run "sudo apt-get install
> unity=7.0.0daily13.06.19*" (without the quotes at the ends). This should
> update unity and necessary dependencies.
>
unity=7.0.0daily13.06.19* not found

On 02/08/13 19:09, Stephen M. Webb wrote:
>> Since the final line says "committed" but not "released", does that mean I could wait until the fix is "released" for
>> "Raring", which would include Unity 7.0?
> Yes.
>
> The -proposed pocket is there for testing release candidates to make
> sure (a) they fix the problem and (2) they do not introduce new
> problems. Once a few valiant testers verify those conditions hold, the
> package(s) is (are) moved into the general release archives and the bug
> marked 'Fix Released'.
>
> So, assuming someone else is testing and verifying the package, you
> could just wait. The downside to that is nobody else may be interested
> in verifying the bug is fixed by the release candidate.
>
Well, if I can get the right Unity update, which for whatever reason is
not as Saikrishna specified it, I can test.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.0.0daily13.06.19~13.04-0ubuntu1

---------------
unity (7.0.0daily13.06.19~13.04-0ubuntu1) raring; urgency=low

  [ William Hua ]
  * Revert 3196 to fix menu highlighting issues with LibreOffice.
    Revision 3196 prevents LibreOffice's menu items from highlighting.
    See Launchpad bug #1153350. (LP: #1153350)

  [ Chris Townsend ]
  * Fixes issue where minimizing a full screen window would not draw the
    Launcher and Panel after minimization. This is a backport of
    lp:unity revno. 3320. (LP: #1064155)

  [ Marco Trevisan (Treviño) ]
  * SwitcherController: use proper long long types for
    WindowActiveNumber Otherwise an overflow can cause bad window
    selection after long uptime. (LP: #1181367)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3319 (bootstrap)
  * Automatic snapshot from revision 3320

unity (7.0.0daily13.05.08~13.04-0ubuntu1) raring; urgency=low

  [ Sebastien Bacher ]
  * Some untranslatable and wrong strings in the previews (LP: #1074038)

  [ Andrea Azzarone ]
  * [alt-tab] Disable detail view for webapp icons. (LP: #1169340)

  [ Marco Trevisan (Treviño) ]
  * Launcher - count label pops out in auto-hide mode (LP: #1171476)
  * Panel shadow is drawn above full-screen windows when notifications
    are shown (LP: #1171934)
  * [regression] Icon count is not shown if the icon is not transformed
    (LP: #1171663)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3314
 -- Ubuntu daily release <email address hidden> Wed, 19 Jun 2013 04:02:40 +0000

Changed in unity (Ubuntu Raring):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Raring):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

S Kitterman #31 says " In the event that you encounter a regression using the package from -updates please report a new bug." Since the fix has not solved the problem I have done just that, and after 10 days no one has acknowledged or responded to my new bug report in any way.
https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1208719

Stephen M. Webb (bregma) on 2014-04-03
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers