Ubuntu

maximized window is displaced

Reported by Lucas Clemente Vella on 2011-04-28
506
This bug affects 95 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Sam Spilsbury
compiz (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: unity

Firefox maximized window is a displaced from that bar in the top if I follow these steps:

Install compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2.1 from natty-proposed:
Test case:
- Open Firefox (make sure it is the default browser)
- Maximize Firefox
- Minimize Firefox
- Open the Terminal
- Type "ubuntu-bug unity"
- Follow until it opens a new tab on Firefox
- The restored Firefox window will be buggy

In this condition, the maximize window is displaced from the top, but the input works as if it was being drawn in the correct position, so I must click above a button to activate it.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.10-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wBMo0YwAAAAAAASAQOAIhN4Cs6FnltMlCYXUFQAAAABAQEBAQEBAQEBAQEBAQEBQRxWoFAAFjAwICUAWMEQAAAZAAAADwAAAAAAAAAAAB60AnQAAAAA/gBTQU1TVU5HCiAgICAgAAAA/gAxNTZBVDAxLUEwMQogAPE=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Thu Apr 28 15:50:35 2011
DistUpgraded: Log time: 2011-04-27 14:28:07.917057
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:0212]
   Subsystem: Acer Incorporated [ALI] Device [1025:0212]
MachineType: eMachines eMachines E725
ProcEnviron:
 LANGUAGE=pt_BR:en
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: root=UUID=2cdcad63-4a14-4e12-9cd4-bf10a0d49acd ro locale=pt_BR quiet splash crashkernel=384M-2G:64M,2G-:128M
ProcVersionSignature_: Ubuntu 2.6.35-28.50-generic 2.6.35.11
ProcVersionSignature__: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-27 (0 days ago)
dmi.bios.date: 03/11/2009
dmi.bios.vendor: eMachines
dmi.bios.version: V1.03
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: eMachines E725
dmi.board.vendor: eMachines
dmi.board.version: V1.03
dmi.chassis.type: 1
dmi.chassis.vendor: eMachines
dmi.chassis.version: V1.03
dmi.modalias: dmi:bvneMachines:bvrV1.03:bd03/11/2009:svneMachines:pneMachinesE725:pvrV1.03:rvneMachines:rneMachinesE725:rvrV1.03:cvneMachines:ct1:cvrV1.03:
dmi.product.name: eMachines E725
dmi.product.version: V1.03
dmi.sys.vendor: eMachines
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Didier Roche (didrocks) wrote :

Thanks for your bug report and help to make unity better.

I'm quite sure it's a duplicate, but couldn't find the master bug… But anyway, you have a very easy reproducible testcase. Thanks :-)

Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → 3.8.14
description: updated

I am having the same problem but also with evolution. If I minimize the window and restore it by using the launcher everything is fine. It seems however that sometimes if the window is restored from minimized state using the panel (in case of evolution), the window is placed around 24px too low. (looks like theres an empty space for the window decoration bar...)

Sorry, it was Gwibber instead of evolution.

fts9 (edicoles) wrote :

On my system, the window is maximised and encounters the same problem but the window also does not have focus. That is to say, in order to use the interface I need to go and select the appropriate icon from the launcher in order to switch focus to the window

Mio (m10) wrote :

I have the same problem but i encounter it in other (random??) circumstances too. it is QUITE annoying and imo should not be low priority...

Given the fact that I got it in the first minutes of usage of my new installation, and it caused so bad first impression that I changed back to Ubuntu Classic, I think it should be of higher priority, too.

ngc2997 (ngc2997) wrote :

Confirmed also for Chromium browser.

Changed in unity:
status: Triaged → Fix Committed
Franck (alci) wrote :

Report https://bugs.launchpad.net/ubuntu/+source/unity/+bug/760436 gives a way to reproduce. So it is not ramdom...

Is there a way to get this bugfix rolled out to end users faster? It seems to be affecting a lot of people.

Omer Akram (om26er) wrote :

this is overall a very problematic issue raising the priority to high as it seems every one faces it one way or teh other.

Changed in unity (Ubuntu):
importance: Medium → High
milestone: none → natty-updates
Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
David Barth (dbarth) on 2011-05-31
Changed in unity:
milestone: 3.8.14 → 3.8.16
Didier Roche (didrocks) on 2011-06-01
description: updated
affects: unity (Ubuntu) → compiz (Ubuntu)
Didier Roche (didrocks) on 2011-06-01
Changed in unity:
status: Fix Committed → Fix Released
Bilal Akhtar (bilalakhtar) wrote :

Seems okay for an SRU to Natty, marking appropriately.

Changed in compiz (Ubuntu Natty):
milestone: none → natty-updates
Changed in compiz (Ubuntu):
milestone: natty-updates → none
Changed in compiz (Ubuntu Natty):
importance: Undecided → High
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.4+bzr20110606-0ubuntu1

---------------
compiz (1:0.9.4+bzr20110606-0ubuntu1) oneiric; urgency=low

  * New bug fix release:
    - Switcher window borders are not properly unmapped with
      (unity|gtk)-window-decorator (LP: #789580)
    - maximized window is displaced (LP: #772612)
    - Unity launcher gets visible while screensaver is active (LP: #771391)
    - 1 pixel icons in notification-area-applet when compiz is the windows
      manager (LP: #767095)
  * debian/patches/00_bzr_fix_apps_without_startupid.patch:
    - removed: upstream
 -- Didier Roche <email address hidden> Mon, 06 Jun 2011 16:18:08 +0200

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released

Accepted compiz into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in compiz (Ubuntu Natty):
status: Triaged → Fix Committed
tags: added: verification-needed
Andy Whitcroft (apw) wrote :

I seem to be unable to reproduce this issue with the packages in -proposed.

Bilal Akhtar (bilalakhtar) wrote :

I can also confirm that the fix in -proposed works.

tags: added: verification-done
removed: verification-needed
Martin Matysiak (k621) wrote :

I have installed the proposed update, restarted my PC but encountered the bug again. This time it was in Thunderbird.

Steps to reproduce:
* Maximize Thunderbird (I'm using 5.0b1)
* Minimize it
(* Wait for an e-mail to arrive)
* Open Thunderbird by using the menu in the notifier area

Then everything is displaced again. It seems to fix itself after a bit of clicking, though (the displacement disappears and everything works again)

Vicenç Juan Tomàs (vtomasr5) wrote :

I can be able to reproduce this bug with all "proposed" packages installed. It's an upgraded from Maverick.

Franck (alci) wrote :

Does not fix the issue here either.

unity package is 3.8.14-0ubuntu1~natty1
compiz package is 1:0.9.4+bzr20110606-0ubuntu1~natty1

Steps to reproduce :
- open evolution
- minimize it
- open firefox
- unmaximize it
- minimize it
- open evolution from message-indicator

Daniel Bruckner (dmeirb) wrote :

Not fixed for me. Can still reproduce original test case w/firefox. In fact, maximizing any window results in it being displaced. Alt-Tab away and back fixes until next maximize.

compiz 1:0.9.4+bzr20110606-0ubuntu1~natty1
unity 3.8.14-0ubuntu1~natty1

Omer Akram (om26er) wrote :

not fixed for me neither, Failed with the test case that Sam used to reproduce the bug.

tags: added: verification-failed
removed: verification-done
eden6000 (eden6000) wrote :

Still not fixed for me too...

Alphag33k (alphag33k) wrote :

Not fixed here either

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.4+bzr20110606-0ubuntu1~natty1

---------------
compiz (1:0.9.4+bzr20110606-0ubuntu1~natty1) natty-proposed; urgency=low

  * New bug fix release:
    - Switcher window borders are not properly unmapped with
      (unity|gtk)-window-decorator (LP: #789580)
    - maximized window is displaced (LP: #772612)
    - Unity launcher gets visible while screensaver is active (LP: #771391)
    - 1 pixel icons in notification-area-applet when compiz is the windows
      manager (LP: #767095)
  * debian/patches/00_bzr_fix_apps_without_startupid.patch:
    - removed: upstream
 -- Didier Roche <email address hidden> Wed, 01 Jun 2011 10:23:26 +0200

Changed in compiz (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

As this was verification-failed, but not a regression in the SRU, I published the SRU, but reopen this bug.

tags: removed: regression-update verification-failed
Changed in compiz (Ubuntu Natty):
status: Fix Released → Triaged
Changed in compiz (Ubuntu):
status: Fix Released → Triaged
Martin Pitt (pitti) wrote :

Can someone please reopen the upstream task, too? I can't.

Massimo (maxx5) wrote :

Not fixed either, and very annoying.
Clicking on title bar of the wrongly maximized window fix it until next maximize.
When the window is wrong, the mouse behave as it would be maximized right, so clicks on close button, for example, must be displaced to work.
On apps with many small toolbars icons I usually click the wrong icon because of this bug.

Daniel Bruckner (dmeirb) wrote :

This is still broken, despite the recent update.

Does it need need to be resubmitted? Does someone have to reset its status in unity? This bug is very irritating, and has been for a long time now.... How do we get it attention again?

Download full text (4.5 KiB)

the branch attached fixes the issue, i'll pack it in a ppa for testing soon

On Mon, Jun 20, 2011 at 7:32 PM, Daniel Bruckner
<email address hidden> wrote:
> This is still broken, despite the recent update.
>
> Does it need need to be resubmitted?  Does someone have to reset its
> status in unity?  This bug is very irritating, and has been for a long
> time now....  How do we get it attention again?
>
> --
> You received this bug notification because you are subscribed to unity.
> https://bugs.launchpad.net/bugs/772612
>
> Title:
>  maximized window is displaced
>
> Status in Unity:
>  Fix Released
> Status in “compiz” package in Ubuntu:
>  Triaged
> Status in “compiz” source package in Natty:
>  Triaged
>
> Bug description:
>  Binary package hint: unity
>
>  Firefox maximized window is a displaced from that bar in the top if I
>  follow these steps:
>
>  Install compiz 1:0.9.4+bzr20110531-0ubuntu1 from natty-proposed:
>  Test case:
>  - Open Firefox (make sure it is the default browser)
>  - Maximize Firefox
>  - Minimize Firefox
>  - Open the Terminal
>  - Type "ubuntu-bug unity"
>  - Follow until it opens a new tab on Firefox
>  - The restored Firefox window will be buggy
>
>  In this condition, the maximize window is displaced from the top, but
>  the input works as if it was being drawn in the correct position, so I
>  must click above a button to activate it.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: unity 3.8.10-0ubuntu2
>  ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
>  Uname: Linux 2.6.35-28-generic i686
>  Architecture: i386
>  CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
>  CompositorRunning: compiz
>  DRM.card0.DP.1:
>   status: disconnected
>   enabled: disabled
>   dpms: Off
>   modes:
>   edid-base64:
>  DRM.card0.LVDS.1:
>   status: connected
>   enabled: enabled
>   dpms: On
>   modes: 1366x768
>   edid-base64: AP///////wBMo0YwAAAAAAASAQOAIhN4Cs6FnltMlCYXUFQAAAABAQEBAQEBAQEBAQEBAQEBQRxWoFAAFjAwICUAWMEQAAAZAAAADwAAAAAAAAAAAB60AnQAAAAA/gBTQU1TVU5HCiAgICAgAAAA/gAxNTZBVDAxLUEwMQogAPE=
>  DRM.card0.VGA.1:
>   status: disconnected
>   enabled: disabled
>   dpms: Off
>   modes:
>   edid-base64:
>  Date: Thu Apr 28 15:50:35 2011
>  DistUpgraded: Log time: 2011-04-27 14:28:07.917057
>  DistroCodename: natty
>  DistroVariant: ubuntu
>  GraphicsCard:
>   Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 09) (prog-if 00 [VGA controller])
>     Subsystem: Acer Incorporated [ALI] Device [1025:0212]
>     Subsystem: Acer Incorporated [ALI] Device [1025:0212]
>  MachineType: eMachines eMachines E725
>  ProcEnviron:
>   LANGUAGE=pt_BR:en
>   LANG=pt_BR.UTF-8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: root=UUID=2cdcad63-4a14-4e12-9cd4-bf10a0d49acd ro locale=pt_BR quiet splash  crashkernel=384M-2G:64M,2G-:128M
>  ProcVersionSignature_: Ubuntu 2.6.35-28.50-generic 2.6.35.11
>  ProcVersionSignature__: Ubuntu 2.6.35-28.50-generic 2.6.35.11
>  Renderer: Unknown
>  So...

Read more...

Scott Talbert (swt-techie) wrote :

Omer, what branch?

eden6000 (eden6000) wrote :

BUMP!

Massimo (maxx5) wrote :

Still not fixed and still *very* irritating.
I keep closing the wrong window because of this bug, as the buttons are misplaced and the window underneath get closed.

I think that's incredible that such an evident and nasty bug is still there after many updates.
Shall we resubmit it ?

Max

Omer Akram (om26er) wrote :

I have build it with the attached branch from Sam, please check if it fixes the issue for you using this ppa https://launchpad.net/~om26er/+archive/test and report here. I'd be happy to work on the SRU. Also if you see any regressions mention here.

Franck (alci) wrote :

@omer: I just tried your ppa, but then the desktop won't show after a login / logout... So it seems to be broken for me.

Omer Akram (om26er) wrote :

I have deleted the package in the ppa as I can also confirm the issue as described by Franck. (previously I did not had access to Natty).

If you installed from the ppa and are facing the start-up problem then login to classic desktop, disable my ppa in software-sources and run the following command in terminal.

sudo apt-get install compiz/natty compiz-core/natty compiz-gnome/natty compiz-plugins/natty libdecoration0/natty

Massimo (maxx5) wrote :

I'm using classic, not unity, and the bug is present, so I guess it's not related to unity itself.
You can notice very well if you have the window close/minimize buttons on the right.... you miss them almost always then.

Alphag33k (alphag33k) wrote :

This bug cause the accidental loss of a lot of work last night so it has graduated from annoying to unacceptable.

I caught this in BETA and it's still not fixed along with a number of other small (but annoying) UI quarks that should not have made it out of BETA. I loves me some Ubuntu but seriously you guys should have stuck with Gnome instead of trying to do your own thing.

I can give it another month but then I and the people I've spent the last year turning to the Linux side of the force will have to go with another distro or gods forbid... back to Windows!

Massimo (maxx5) wrote :

Well, I gave it a bit more than one month and, tired of this one, switched to gnome shell.
And, I must say, it's light years from unity, and on positive side.
Still not perfect, but at least you can *work* with it, not just play.

Max

Mio (m10) wrote :

Is this dead?.. I would like some clarifications on why this is taking sooo long

Nikolaus Filus (nfilus) wrote :

 Can someone from the devs please clarify on the status of this report? unity upstream is still at "fix released", but the issue is not solved for many people. There are ~20 duplicates and I was short of opening a similar report...

Omer Akram (om26er) on 2011-08-10
affects: unity → compiz
Changed in compiz:
milestone: 3.8.16 → none
Omer Akram (om26er) on 2011-08-10
description: updated
Changed in compiz (Ubuntu):
status: Triaged → Fix Released
24 comments hidden view all 104 comments
Omer Akram (om26er) wrote :

Chris, This bug report would do it, I have proposed a branch for SRU
already, lets wait for it to get reviewed and accepted.

eden6000 (eden6000) wrote :

Strange thing...after applying the patch I have a problem with network information applet...it opens the first time, then, if you close and reopen it, it acts as in the attachment, or it opens, but refuses to show...anyone is experiencing this issue?

Omer Akram (om26er) wrote :

eden60000, I see this issue in Oneiric actually its a much known issue in Oneiric, Your obervation, it seems have narrowed down the issue to this patch. Do you face it 100% of the times?

I just tried eden's observation, and can reproduce. Once triggered, it has happened consistently for about 10 openings for me..

eden6000 (eden6000) wrote :

Omer, yes, I've tried it 5 times, the sequence is: 1. opens fine, 2. opens as in previously attached screenshot and you can close it from unity's launcher. 3. opens but refuses to show; at this point it's enough to logout and login and the sequence starts again.

Yes, I can confirm eden6000's observation in Natty with the patches applied.

I also note that cycling through the task switcher (Alt+Tab) fixes the display of Network Information, making it display properly and respond to window controls including close. The next opening displays the fault again...

eden6000 (eden6000) wrote :

I think I've found another one, Skype: it opens the first time, then you close it and if you reopen it's not present neither it the top bar or in natty's launcher, so you can only kill it with system monitor....

VoLk (ivn-wd77) wrote :

eden6000, in this case, you can use ALT+F10 :) But you right, it's bug too and not only for skype.

hm, I have found another application with visibility issues with the new patch. Rainlendar (a desktop calendar software, rainlendar.net) now has an invisible (or weird ghost like the network applet) main window, rendering it unusable.
I think this patch has some unintended consequences.

I'm getting poor behaviour with rolling windows up (to just the title bar); transparent ghost windows and some unresponsiveness to clicking to unroll. This applies to all apps I have tried so far. (Tomboy, Chrome, Evolution...)

I can confirm this, too. :-(

Omer Akram (om26er) wrote :

You can revery to the previous version by disabling the ppa in software sources and then run this command

$ sudo apt-get install compiz/natty compiz-gnome/natty compiz-plugins/natty compiz-core/natty libdecoration0/natty

eden6000 (eden6000) wrote :

Or by running

$ sudo ppa-purge ppa:swt-techie/ppa-772612

assumed you have installed "ppa-purge" package

Omer Akram (om26er) wrote :

that ;)

Gave Scott's PPA a try - unfortunately I still see the same behaviour - windows such as Firefox, VLC media player, Nautilus, gedit, etc. still have the same problem.

The one difference I did notice is that after applying the PPA, the "minimize and maximize" (or switch windows with ALT+TAB) trick used previously to work around this bug no longer worked.

I am running Natty with Ubuntu Classic (the regular one, not the "no effects" one), but compiz is running as well:

keith@ryo-ohki:~$ ps aux | grep compiz
keith 1276 1.4 1.4 60196 14348 ? Sl 12:09 0:14 /usr/bin/compiz
keith 1376 0.0 0.0 1912 508 ? Ss 12:09 0:00 /bin/sh -c /usr/bin/compiz-decorator
keith 2518 0.0 0.0 4160 864 pts/0 S+ 12:25 0:00 grep --color=auto compiz

Not sure what the next steps should be - if more info is required, or if this should be a new bug. Any guidance on this would be helpful; I want to help as much as I can with this!

Alistair Buxton (a-j-buxton) wrote :

With the PPA I no longer see the problem with firefox, but sometimes it still happens with eog and the pdf reader. Also sometimes firefox windows cover the launcher, which didn't happen before.

James Haigh (james.r.haigh) wrote :

This is not Unity specific. I've seen this bug in older releases of Ubuntu with Compiz enabled. It would often happen (and still does happen) in Firefox when many windows and tabs are open.

I notice that clicking on an empty part of the Unity Panel makes the window jump into place. Alt+Click -ing anywhere on the displaced window also works.

This work-around makes the bug less annoying and easier to work with until a real fix is released.

HTH.
James.

Franck (alci) wrote :

Still here in Oneiric Ocelot beta1. Same steps to reproduce : open thunderbird, minimize, open firefox, unmaximize, minimize, open thunderbird from message indicator :=> window is displaced.

Hope this can be fixed in Oneiric Ocelot...

Franck (alci) wrote :

Just in case that can help, here is how to reproduce in even less steps :

1) open thunderbird.
2) maximize it if it is not
3) minimize it
4) open any non maximzed app, or else unmaximize the app (say firefox)
5) open thunderbird from message indicator

==> no need to minimize firefox after step 4, having it non maximized is sufficient to make the misplacment happen.

Franck (alci) wrote :

Sorry for making noise, but what is the status of this bug for Oneiric Ocelot ? Is it fix released ???
I can confirm it is still broken in latest (as of 2011-09-05) OO. I really think this is an important bug as it will hit every one now and then, giving a very bad felling about the system, especially to new users...

Sian Aherne (sian-aherne) wrote :

This is for 11.04 - I haven't tested this on the new Beta for 11.10 yet.

On 05/09/11 10:35, Franck wrote:
> Sorry for making noise, but what is the status of this bug for Oneiric Ocelot ? Is it fix released ???
> I can confirm it is still broken in latest (as of 2011-09-05) OO. I really think this is an important bug as it will hit every one now and then, giving a very bad felling about the system, especially to new users...
>

--
Sian Aherne
PR & AR Manager

Canonical Comms Team
t: +44 (0) 207 630 2440 m: +44 (0) 7872 985957
e: <email address hidden>

This email was sent using Thunderbird
<http://www.mozillamessaging.com/thunderbird/> on Ubuntu
<http://www.ubuntu.com/>.

Franck (alci) wrote :

So should another bug report be opened for 11.10 (cause I can confirm it is still broken) ?

eden6000 (eden6000) wrote :

In Oneiric it seems somehow solved, since "reopening" apps from the indicator has been disabled...if you call the app (that is already open and minimized) from the indicator, it simply makes the icon blink.

Franck (alci) wrote :

@eden6000: ouch... not what is happening here. Choosing email from message indicator definitely brings thunderbird up, even if the application was currently minimized. And f I do that while working on a non maximized window, thunderbird will be "displaced".

This is on a system that was freshly (re)installed in 11.04 and upgraded to OO beta1 as few days ago.

eden6000 (eden6000) wrote :

@Franck: I'm on oneiric, with fresh beta install fully updated...I can confirm, if I minimize TB, and then call it back from menu indicator it simply blinks...anyone else is experiencing this?

eden6000 (eden6000) wrote :

Wait, I checked again, I was partially wrong...the behaviour I reported comes when a window is present on the desktop, fully or not maximized...and Franck you are right, if the desktop is empty, calling tb or banshee from their indicators calls them up full screen...and (shhh....talking in a low voice....) the bug is not appearing....

Franck (alci) wrote :

@eden6000: did you follow the "well known steps" :-) to reproduce the bug, ie:
1) open thunderbird maximized
2) minimize it
3) open firefox. Unmaximize it if it is not.
4) call back thunderbird via message indicator

This keeps triggering the bug here.

eden6000 (eden6000) wrote :

Yes Frank, I know the steps, I've been following this bug for months...in my machine it's not happening now, I've tried many times...but I can't say it's solved, it could be interesting to hear some other users...

Franck (alci) wrote :

Ok, a few more tests in OO...

If I give _focus_ to thunderbird before I minimize it, the misplaced bug does _not_ occur any more when called back from message indicator (but I get a stacking bug, Firefox window staying on top but not getting focus).

If I minimize Thunderbird directly after opening (thus not clicking in the window, only in the main title bar), the bug still occurs.

So new steps to reproduce:
1) open thunderbird from message indicator
2) don't give it focus, minimize directly
3) open firefox, unmaximize
4) call thunderbird back from message indicator

You get two bugs for the price of one : misplaced thunderbird window, and stacking problem (firefox window staying on top but not getting focus).

manny (estelar57) wrote :

i also experience this with oneiric alpha3 and firefox (2 windows open).

anyone has a link for this bug in oneiric? i think we need to open a new one...

Franck (alci) wrote :

Latest upgrade in OO (2011-09-06) seems to fix the issue ?? I cannot reproduce anymore here.

But the stacking problem remains. I'm going to look for a bug report on this one.

Franck (alci) wrote :

Stacking problem seems to be described in #802527.

I added my steps to reproduce in a comment.

Changed in compiz (Ubuntu Natty):
status: Triaged → Fix Committed
adrenochrome (adrenochrome) wrote :

same king of problem with chrome and synaptics, maximize by double click on title, go back to window mode by bouble-click again and then there's a kind of mouse offset of approximatively one line of text (menu height ?)
it goes back to normal after several click, the bug dont happend every time, seems to be random

Is this bug back?
Since about two weeks, from time to time, I get weird issues with displaced windows when restoring or switching to thunderbird or firefox via clicking the launcher. Symptoms are just like in this bug. I haven't found a reproducible triggering sequence yet, though.

OK, this bug is definitely back. Reproduction method as in OP, only it's not even necessary to start ubuntu-bug in the terminal, you just have to alt-tab back to firefox, and it breaks.
Marking regression-update, since I'm fairly certain it was OK in freshly released oneiric. Setting Confirmed (if I'm allowed to).

tags: added: regression-update
Changed in compiz (Ubuntu Natty):
status: Fix Committed → Confirmed
John Watson (jwatson) wrote :

This happens for me too in Oneiric. I've been on Oneiric since October but I don't recall having this problem until the past month and now it's a daily occurrence. All I have to do is maximize a window, minimize it, then restore it again. The problem occurs whether the window is fully maximize (Alt-F10) or if it's just maximized to fill the desktop area (Ctrl-Alt-Numpad5).

Confirm previous comment. The bug is occurring daily.

diego (marcodiegomesquita) wrote :

The bug happens to me in precise. Simply start gitg maximized and it will be displaced.

diego (marcodiegomesquita) wrote :

Attached images illustrates the problem. Note the displacement in the bottom of the image.

dino99 (9d9) wrote :
Changed in compiz (Ubuntu Natty):
status: Confirmed → Invalid
Displaying first 40 and last 40 comments. View all 104 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers