Available resolutions incompletely set to 1024x768, 800x600, 640x480

Bug #49827 reported by GreatBunzinni on 2006-06-15
232
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xresprobe (Ubuntu)
High
Unassigned

Bug Description

I've installed Kubuntu 6.06 LTS on my Acer Aspire 1524 which carries a NVidia GeForce FX Go 5700 and the screen resolution is 1280x800.

After the install process, the default screen resolution is set to 1024x768 and there isn't an option available in KDE's display system settings to change it to 1280x800, which in effect forces the computer to be stuck with an unnatural screen resolution.

[Many people are reporting this bug - Ubuntu is only providing the resolutions 1024x768, 800x600, and 640x480, when the user's system ought to support other resolutions beyond these.]

GreatBunzinni (greatbunzinni) wrote :

After some tweaking done on the xorg.conf file I've managed to configure the natural 1280x800 screen resolution. To achieve that I did the following changes:

Added the following to the "device" section:
Option "IgnoreEDID" "0"

Commented out the following from the "Monitor" section:
HorizSync <any value>
VertRefresh <anyvalue>

After reading NVidia's forum I've also commented out the following from the "modules" section:
Load "dri"

So now I have a nice and easy on the eyes 1280x800 resolution. Now the only problem is that I am stuck with the huge 101dpi fonts. Is it possible to change them to something a bit more sensible, i.e., smaller?

Matthew Lange (matthewlange) wrote :

Confirmed. Same behavior on Acer Aspire 3003WLMi. Not specific to NVidia cards. Problem affects widescreen laptops.

See https://wiki.ubuntu.com/LaptopTestingTeam/AcerAspire3003WLMi

Matthew Lange (matthewlange) wrote :

GreatBunzinni, could you try
"sudo dpkg-reconfigure -phigh xserver-xorg", select your video driver, select resolution 1280x800, and then restart?

This worked for me. I had to select the SiS driver instead of "VESA" which it was defaulted to.

Is this a mis-detection of the card?

Bryce Harrington (bryce) on 2007-04-14
description: updated
Changed in xorg:
importance: Undecided → High
Lin4U (kontakt-fischer) wrote :

Hallo,

the following steps are only up to date for UBUNTU 7.04 Feisty Fawn:
I had the following problems: after installing the nvidia-glx-driver via terminal or synaptic I got a wrong xorg.conf. So I edited it, but that didn't solved my problems. A handmade compilation of the newest nvidia-driver made no effort, too.
So last but not least I tried the "easy" way:
at the Gnome-Taskbar I choosed -> System/Administration/Restricted Driver Update (my english is al little bit rusty ... )
There I activated the nvidia-glx-driver with one (!) mouse-click. Than started a downwload and a configuring. I studied my new xorg.conf and all looked fine. So I restarted my computer and viola
my 3D-acceleration worked (with the right resolution)

Sander D (sanderd) wrote :

Is this a duplicate of "X.org doesn't detect widescreen resolution"?
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/49827

Daniel Hahler (blueyed) wrote :

Sander, there are probably quite a lot of dupes/similar bugs in this region. The source of error may be slightly different though.
You are refering to bug 63551 as duplicate probably. I'll mark it as such (and just commented there).

Thank you for pointing this out.

Daniel Hahler (blueyed) wrote :

I've marked bug 63551 as Duplicate of this instead.

I think the problem is the default hsync value in xorg.conf:
  HorizSync 28-51
Therefor the autodetection for the correct resolution fails with:
 (--) NV(0): Panel size is 1920 x 1200
 (II) NV(0): Using hsync ranges from config file
 ...
 (II) NV(0): Not using default mode "1920x1200" (hsync out of range)

And if you enter specific mode lines (or probably adjust HorizSync value) it somehow gets forced.

So, where do the default settings come from and can they get bumped/removed?

deladrien (daletheladrien) wrote :

Just to be clear, I'm running Kubuntu. I don't think it makes a difference.

I believe I've encountered the same issue here, on an Everex VA4103M laptop. I'm unable to access everex.com, nor have any paper documentation, and have found very little reference to the VA4103M, let alone Everex, so I'm unsure of the video card. The 4101 I think, uses an S3 of some sort... I'm pretty certain the native resolution is 1280x800

I've got it slightly better. After reinstalling Kubuntu Dapper Drake (or Edgy Eft, I can't keep these straight) several times, I finally got it running properly, at a reasonable resolution (actually, I don't even remember what it was, prolly around 1024). This lasted about 4 reboots, at which it spontaneously booted to 800x600. No warnings, errors, or anything. I checked the Monitors dialog, and the slider showed options for 640 or 800. Interestingly, choosing 640 and applying the change made no difference...

I reinstalled to 7.04 Feisty Fawn, but the problem persisted. I've spent several hours now, attempted Bunzinni's fixes, tried "sudo dpkg-reconfigure -phigh xserver-xorg", and finally got it to the point where the kdm login screen displays a crisp, clear beautiful 1280x800...

That is, until I enter my password, hit enter, and the screen goes all screwy again. It's displaying, I can kinda see the background and mouse pointer, but it's multiple overlapped and def. FUBARed.

xorg.conf reveals that there are no vertical or horizontal refresh rates to comment out. As mentioned, i've tried IgnoreEDID and "dri", not that they would make a difference (I'm not even nVidia).
Xorg.0.log isn't formatted very well, but does send warnings and errors about EDID and DRI. It also seems to be checking a variety of modes it shouldn't be, whatever that means. It does complain about hsync a couple of places.
IOW, no help at all to someone like me.

My biggest question, what drives me to the edge of sanity here, is *why oh god why* would X or KDE (or whatever the hell controls it) display the login screen clearly, but corrupt the main desktop?

Kent Fuller (kentfuller39) wrote :

Here's a partial workaround. I'm a newbie to Linux and am just getting used to Ubuntu Feisty Fawn. I'm using 1280x1024 LCD monitor that can't be set to this native resolution through Gnome's System/Preferences/Screen resolution and I am nowhere near ready to start fiddling with command lines. What has worked in part in my case, as I have a (fairly old but serviceable) NVidia GeForce 2 Ti4200 graphics card, is to run the downloadable NVidia driver package. I see that my monitor Brand and Model and graphics card are all correctly identified within this NVidia package. That allows me to go into the Server Settings menu, select the XServer menu then X Server Display Configuration (no idea why a screen should be called a server??) and change the resolution to the correct native setting. However the recommended refresh rate is too high and cannot be set to the recommended 70 or 75Hz.

With the screen now looking as it should, if I now go back to System/Preferences/Screen Resolution I see my native resolution that was not there before is now available in the menu, but again with too high a refresh rate (85Hz) as the only option. In addition, the option to make that the default setting is ineffective. Reboot the computer and the entire rigmarole must be gone through again next time because my settings have been lost. I have tried many times... a very annoying bug to face each new bootup, even before you start to do anything at all. I have been given to understand that driving LCD screens with too high a refresh rate shortens their life, so 85Hz doesn't seem to be a great option. I'm hoping someone can help with a proper fix.
Kent

James (chiisu81) wrote :

Confirmed in Ubuntu Feisty Amd64. It was set at 1024*768, and the only way to fix it was to edit xorg.conf to get 1280*1024. In past Ubuntu releases installing nvidia-glx would increase the resolution automatically. Ubuntu/Xorg should be able to detect the user's monitor and lookup the max supported resolution automatically, is this going to happen with Xorg 7.3?

GreatBunzinni (greatbunzinni) wrote :

I've just bought a desktop computer along with a samsung Syncmaster 940NW, which has a resolution of 1440x900. I've installed kubuntu 7.04 and lo and behold, the screen resolution was set to 1024x768 without any option to set a higher screen resolution, not even after installing the nvidia driver. Once again I had to hand-tweak xorg.conf.

Giles Weaver (gweaver) wrote :

Confirmed in Ubuntu Feisty AMD64 and i386 with nVidia 6600GT. I had to edit the xorg.conf to add 1280x1024 resolution.

Alexander van Loon (avanloon) wrote :

I'm still affected by this problem as well. With Ubuntu 7.10 Tribe 5, a daily build of 27 August to be exact, Ubuntu still doesn't choose the right resolution. Installing the NVIDIA driver (nvidia-glx-new) for my NVIDIA GeForce 7800 GT didn't change anything, and I had to manually edit xorg.conf to be able to use the 1680 x 1050 resolution on my Dell 2007 WFP 20 inch widescreen monitor, Ubuntu defaults to 1280 x 1024. I'll attach the full output of 'sudo lspci -vvnn', /etc/X11/xorg.conf and /var/log/Xorg.0.log (of course from before I installed the NVIDIA driver or edited xorg.conf). Don't know if it's any use, but I hope so.

Alexander van Loon (avanloon) wrote :
Alexander van Loon (avanloon) wrote :
rickmans (rickmans) wrote :

I used to had the same problem however I upgraded to 7.10 (tribe 5 via a dist-upgrade) and re-ran the configure of X. Also I switched to xubuntu, since then the proper resolution is available (1440*900@60) and usable. However I do not know if this is due to the upgrade to 7.10 or my switch to xubuntu I will try to figure that out. Videocard is an onboard videocard.

Bryce Harrington (bryce) on 2007-09-19
Changed in xorg:
assignee: nobody → bryceharrington
Dave Gilbert (ubuntu-treblig) wrote :

I've just had something similar on Gutsy (updated as of 23rd September, it's a feisty upgrade done a few weeks ago)
ona Toshiba Equium A100-306 (Intel chipset) that runs at 1280x800 on its internal LCD.
After a reboot it had dropped back to 1024x768 - this may have been me editing the driver to intel from i810.

So I reconfigured with dpkg-reconfigure on the xserver-xorg and got it working having selected the resolution, and used a customer monitor (but accepted the defaults).
However If I use the System->Administration->Screens and Graphics dialogue and select the Generic-> LCD Panel 1280x800 it lets me select some lower res (e.g. 1024x768) and higher res (1280x960) but not 1280x800.

I've attached the Xlog and xorg.conf of my current (apparently working OK) X config from my dpkg-reconfigure.

Dave Gilbert (ubuntu-treblig) wrote :

and my xorg.conf

Bryce Harrington (bryce) on 2007-09-25
Changed in xorg:
assignee: bryceharrington → nobody
Bryce Harrington (bryce) wrote :

Btw, for those who are using LCDs instead of laptops, you might possibly be actually seeing 27667.

For those of whom ddcprobe returns 'edid fail', you may be seeing 94994 instead.

Adrian D (grosem) wrote :

Hi,

I'm not really sure whether I have this problem. I can also just choose the resolution options you've named. After editing the xorg.conf I have the right resolution, http://i5.tinypic.com/5ys272o.png, but Gnome doesn't use all of it. I can still use the place at the right side. So are we talking about the same topic?

Bryce Harrington (bryce) wrote :

It turns out there's several distinct bugs being glommed together into this one.

bug 27667 affects LCD's and results in their top most (usually preferred) resolution being ignored. My fix for 27667 should solve this. If you know your VGA-attached LCD or CRT monitor supports exactly 4 resolutions, which include 1024x768, 800x700, 640x480, and one more that is bigger than 1024x768 but which is missing, then this is probably your bug.

Some other proportion are seeing 94994, which occurs when the monitor doesn't report its edid properly. I suspect this is because xresprobe only supports edid 1.0 style data, and some (newer) monitors report only in edid 2.0 format. However I've not confirmed this. If you suspect you fall into this category please review 94994 and help test.

I've also noticed that gnome seems to display the three resolutions 1024x768, 800x600, and 640x480 as defaults when it wasn't able to determine the correct resolutions. If you know your monitor supports far more than these three, but only these three are available, then you have this one. Unfortunately, this is just a symptom of what's really wrong with your system; the root cause could be a variety of things. Check your output on "sudo xresprobe <driver>", "sudo ddcprobe", "sudo get-edid | report-edid", verify the driver in xorg.conf is correct for your hardware, and report your findings here.

Dave Gilbert (ubuntu-treblig) wrote :

Hi Bryce,
  Please find attached the result of xresprobe and ddcprobe; it looks like xresprobe is only getting 1024x768 for me
and ddcprobe isn't seeing 1280x800.
One thought though is that I'm getting this behaviour even when I explicitly select generic 1280x800 LCD monitor;
I'm not sure but I think it should believe me.

I don't seem to have get-edid or report-edid and an apt-cache search fails to find them.

Dave

Alex Muntada (alex.muntada) wrote :

Dave, the package you're looking for is "read-edid", though I think that the command report-edid doesn't exist, it's parse-edid; this works for me:

$ get-edid | parse-edid

Dave Gilbert (ubuntu-treblig) wrote :

Nope, doesn't seem to exist on x86-64;

dg@davros:/var/log$ apt-cache search edid
dg@davros:/var/log$ sudo apt-get install read-edid
[sudo] password for dg:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package read-edid is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package read-edid has no installation candidate

Dave

Daniel Hahler (blueyed) wrote :

Yes, read-edid only gets build for i386 and powerpc (from its debian/changelog file).

FYI, the "get-edid | parse-edid" call fails on AMD64 running ubuntu x86, and maybe there's a similar problem in amd64 altogether, why it's deactivated?

$ sudo get-edid | parse-edid
[...]
VBE/DDC service about to be called
        Read EDID

        Performing real mode VBE call
        Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
        Function supported
        Call failed

The EDID data should not be trusted as the VBE call failed
Error: output block unchanged
parse-edid: IO error reading EDID

Attached is the full output for this command.

My Eizo S2410W monitor has 1920x1200, but the requested debug output does not include this at all (nvidia 6600GT graphic card, AMD64, but running as x86).
$ sudo xresprobe nvidia
id:
res:
freq:
disptype:
daniel@base { /tmp/read-edid-1.4.1 }
$ sudo ddcprobe
vbe: VESA 3.0 detected.
oem: NVIDIA
vendor: NVIDIA Corporation
product: nv43 Board - p216h1 Chip Rev
memory: 131072kb
mode: 640x400x256
mode: 640x480x256
mode: 800x600x16
mode: 800x600x256
mode: 1024x768x16
mode: 1024x768x256
mode: 1280x1024x16
mode: 1280x1024x256
mode: 320x200x64k
mode: 320x200x16m
mode: 640x480x64k
mode: 640x480x16m
mode: 800x600x64k
mode: 800x600x16m
mode: 1024x768x64k
mode: 1024x768x16m
mode: 1280x1024x64k
mode: 1280x1024x16m
edid:
edidfail

Giles Weaver (gweaver) wrote :

Since installing Ubuntu 7.10 I no longer have this problem.

Timo Aaltonen (tjaalton) wrote :

Hi, xresprobe is no longer used in Hardy Heron, the development version which will become Ubuntu 8.04. Because of that I'm closing this bug. Please test Hardy (alpha3 or later), and if your hardware still fails to get a correct resolution (or if it drops to failsafe mode), file a bug against the driver package (xserver-xorg-video-$driver). Thanks!

Changed in xresprobe:
status: Confirmed → Won't Fix
To post a comment you must log in.