X.org doesn't detect widescreen resolution

Bug #63551 reported by Alexander van Loon on 2006-10-02
32
Affects Status Importance Assigned to Milestone
X.Org X server
Invalid
Unknown
xresprobe (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

I have a Dell 2007WFP 20 inch widescreen monitor. It has a resolution of 1680 x 1050 pixels. I booted up the latest Ubuntu 6.10 beta Live CD, and I noticed that the resolution was set at 1280 x 1024, which looked absolutely terrible.

With no way to set the correct resolution in System -> Preferences -> Screen Resolution, I had to edit my xorg.conf and add "1680x1050" to it, as seen below:

Section "Screen"
 Identifier "Default Screen"
 Device "NVIDIA Corporation NVIDIA Default Card"
 Monitor "DELL 2007WFP"
 DefaultDepth 24
 SubSection "Display"
  Depth 1
  Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 4
  Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 8
  Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 15
  Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 16
  Modes "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
  Depth 24
  Modes "1680x1050" "1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
 EndSubSection
EndSection

What if I did not know how to edit my xorg.conf? In the worst case scenario I would give up on Ubuntu because it didn't detect the correct resolution and there was no easy way to set the correct resolution. 1280x1024 on a monitor which should be set to 1680x1050 is very annoying to work with, your display is a total blur and with the wrong aspect ration it's all out of proportion.

Why can't X.org detect the correct resolution? Windows can. Ubuntu has a serious problem if users of widescreen monitors (which are getting more common) have to edit a config file to get the correct resolution.

writser (writser-gmail) wrote :

I completely agree. I had to google up this article to get my 2005FPW working:

http://www.wiredfool.com/2005/06/15/widescreenLcdsAndUbuntuLinux

And had to manually add the following line to my xorg.conf:

Modeline "1680x1050@60" 154.20 1680 1712 2296 2328 1050 1071 1081 1103

as well as changing all display modes. Seriously, how is any linux newbie supposed to figure this out? Widescreen LCD's are getting more and more common and need support from Ubuntu. A quote from the author of the article:

"I'm not going to belabor the point that it's 2005 and this is one of the friendlier linux distros that I've dealt with."

Colan Schwartz (colan) wrote :

I can confirm this. I've been having the same problem. All I've had to do though was install the 915resolution package, and it worked. I didn't even have to configure anything. (I've got a Gateway MX1023 notebook/laptop.)

There is a lot more information about this issue on that tool's web site: http://www.geocities.com/stomljen/

I'm not sure if it's too late to get this update in before the release. If it's not too late, then this package should be installed automatically if appropriate.

Ravi (s-ravi-in) wrote :

I can confirm this. After adding the VerticalSync HorizontalRefresh and desired resolution, it worked fine.

It would be great if this worked out of box

knine (jalbretsen) wrote :

I can confirm this for Edgy.

I am using a Dell D620 with the GMA 950 and I can't even get the live part of the desktop CD to load the GUI so I install the system.

For the record with Dapper, I was able to run the live and install, then install 915resolution package to get the 1440 x 900 resolution.

Andrew Ash (ash211) wrote :

I had a similar problem on my Dell Inspiron B130. /etc/X11/xorg.conf had the correct settings, but I was forced to run 915resolution to mess with the video BIOS and actually get the correct resolution.

I'm going to mark this bug confirmed, too. There have been enough people, for sure!

Changed in xorg:
status: Unconfirmed → Confirmed
Alexander van Loon (avanloon) wrote :

Thanks for your comments everybody, I didn't expect this many reactions.

I also have a notebook with Intel GMA onboard video which required me to install 915resolution in order to get the correct resolution. Essentially it is the same problem, however I filed a different bugreport for that: bug #63560

Lee Olson (leeolson) wrote :

Confirmed. This issue still exists in Feisty Herd 1. I resolved this by editing the /etc/X11/xorg.conf as shown in the original report, as I am using an NVIDIA card.

Lee Olson (leeolson) wrote :

I forgot the mention that this issue still existed in Feisty Herd 1 (Kubuntu LiveCD), but doesn't seem to exist in Feisty after editing my /etc/apt/sources.list file and running an apt-get dist-upgrade. After upgrading, the x.org file now contains the proper information to support my Dell 2700WFP display:

Section "Monitor"
  identifier "DELL 2007WFP"
  modelname "Custom 1"
  modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
  modeline "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
  modeline "1280x800@75" 107.21 1280 1360 1496 1712 800 801 804 835 -hsync +vsync
  modeline "1280x768@75" 102.98 1280 1360 1496 1712 768 769 772 802 -hsync +vsync
  modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
  modeline "1440x900@75" 136.49 1440 1536 1688 1936 900 901 904 940 -hsync +vsync
  modeline "1440x900@60" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
  modeline "1600x1024@60" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -hsync +vsync
  modeline "1680x1050@60" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
  modeline "1920x1200@60" 193.16 1920 2048 2256 2592 1200 1201 1204 1242 -hsync +vsync
  gamma 1.0
EndSection

Section "Screen"
  Identifier "Default Screen"
  Device "NVIDIA Corporation NV18 [GeForce4 MX 440 AGP 8x]"
  Monitor "DELL 2007WFP"
  DefaultDepth 24

  SubSection "Display"
    depth 24
    modes "1680x1050@60" "1920x1200@60" "1600x1024@60" "1440x900@60" "1440x900@75" "1280x800@60" "1280x768@75" "1280x800@75" "1280x720@60" "1280x768@60" "800x600@60" "800x600@75" "800x600@72" "800x600@56"
  EndSubSection
EndSection

Can anyone else confirm this?

Emilio Pozuelo Monfort (pochu) wrote :

Not for me, but I have an Acer 1642wlmi with an Intel GMA.

Do you know why this bug isn't assigned to anybody if it is confirmed?

Andrew Ash (ash211) wrote :

There aren't enough developers to go around!

If an apt-get upgrade fixes to for Lee, it's likely that whatever updated package fixed it for him will be released in Feisty Final.

For the 915resolution problem, I've heard that newer version of X.org plan to not need to run 915resolution, by getting modesetting support in the driver. See comments in https://wiki.ubuntu.com/BetterWidescreenDetection

Andrew Ash (ash211) wrote :

Sander, I'm working on the wiki page some more, and am starting to organize bugs that the spec would cover. Were you able to get your 1680x1050 resolution monitor working with a simple install of 915resolution, or did you need to edit /etc/default/915resolution?

Alexander van Loon (avanloon) wrote :

My Dell 2007WFP 20" widescreen is connected to a NVIDIA video card, so I did not use 915resolution because 915resolution only applies to Intel chips. So I had to edit my xorg.conf.

rickmans (rickmans) wrote :

Exact the same issue here with an iiyama E1900ws. 915resolution and editting xorg.conf solves the problem, allthough it is rather anoying.

Alexander van Loon (avanloon) wrote :

I just downloaded Ubuntu 7.04 Herd 5, and when I started the LiveCD it still automatically detected a resolution of 1280x1024. I'm still using the same hardware, a Dell 2007WFP with a resolution of 1680x1050 which is connected to a NVIDIA GeForce 7800GT.

I thought that Herd 5 has X.org 7.2 included, which is supposed to have improved autoconfiguration. But why can't it still detect widescreen resolutions properly?

Alexander van Loon (avanloon) wrote :

Ok, so because there wasn't any Ubuntu dev giving any attention to this bug, I decided to report it upstream myself. I just added a remote bug watch. Within a few hours I already got a reply on my bugreport, the bug is apparantly not X.org's fault, but Ubuntu's fault. I can imagine that the Ubuntu dev's are busy, but I'm a bit disappointed that nothing has been done on this serious bug for quite a few months.

Changed in xorg-server:
status: Unknown → Rejected
Miklos Erdos (merdos) wrote :

This problem exists on my Fujitsu-Siemens Si1848 laptop. (Core2Duo, ICH7, X1300, SATA HDD)
I've tried the Herd5 installer, but it fails to start the X environment.

The screen resolution is correctly detected:

(II) VESA(0): Modeline "1280x800" 71.25 1280 1328 1360 1440 800 802 808 823 -hsync -vsync

then after listing quite a few resolution combos the X server fails:
...
*(II) VESA(0): Not using built-in mode "640x480" (hsync out of range)
...
Fatal server error:
no screens found

adding the needed lines to xorg.conf fixes the problem and allows me to install.

My laptop's DDC data is dumb as it doesn't list lower (and 'standard') resolutions and the X server fails as it depends too much on detected data.

The installed system successfully starts, but needs a tiny change in my xorg.conf. The horizontal resolution is only 1080 by default, not the correct 1280, but this is a minor problem.

Timo Aaltonen (tjaalton) wrote :

could you attach your /var/log/casper.log from the live-session, and also Xorg.log and xorg.conf.

what does 'sudo xresprobe nv' give?

xjnumb (wim-salomons) wrote :

The bug also exists for Herd 5 in combination with an Dell Optiples GX520 (with the intel video chip) attached to an external 22 inch Belinea LCD monitor. Defaults to 1280X1024. No way to change it.

Timo Aaltonen (tjaalton) wrote :

xjnumb: that's a different bug and specific to the i810 driver.

bzipitidoo (bzipitidoo) wrote :

I have an NVidia GEForce 7100 based video card which I am using instead of the integrated graphics on an Intel 965 based motherboard. With a widescreen LCD (native is 1440x900@60) Xubuntu 7 Herd 5 defaults to 1280x1024. If I change xorg.conf for 1440x900, the system apparently does change to 1440x900 and even lists 1440x900 in the display utility, but the monitor doesn't cooperate and goes to 1152x864, leaving the bottom and right edges of the display off the screen.

Peter Breuls (breuls) wrote :

bzipitidoo: did you enter the ModeLine at the right place? If you don't have one, you can generate one by typing 'gtf 1440 900 60' in your console. The 60 means 60Hz. You will then get an output you can paste into a Monitor section in xorg.conf.

obocho (obocho) wrote :

dell inspiron 8600i + Xubuntu Feisty Herd 5 and the same problem...

I cannot get 1680x1050 without manual configuration (which means a lot of work)... Actually, I don't understand; ubuntu, (k)ubuntu and many other distro work very well... just Xubuntu doesn't want to work easy!

rngadam (rngadam) wrote :

Same problem here, but with a Dell 2405FPW attached to an BFG 6600 (Nvidia chipset); the resolution when booting from CD is not set to the native widescreen resolution of 1920x1200 but to 1024x768. This is with Ubuntu 7.04 beta... I'll attach the appropriate log.

ubuntu@ubuntu:~$ sudo xresprobe nv
id:
res:
freq:
disptype:

rngadam (rngadam) wrote :
rngadam (rngadam) wrote :
rngadam (rngadam) wrote :

My problem seems to be more related to bug #43276...

michele (garetto) wrote :

I have Ubuntu Feisty 7.04, nvidia chipset and a Dell 2007WFP 20 inch widescreen monitor.
I was able to get the 1680 x 1050 pixels resolution without manual editing as follows:
1. install package nvidia-glx-new
2. enable the driver: sudo nvidia-glx-config enable
3. generate new xorg.conf: sudo dpkg-reconfigure -phigh xserver-xorg
Apparently, the problem is that the new driver is not officially supported by ubuntu.

Sander D (sanderd) wrote :

I seem to have the same problem with the following configuration:
- ATI Radeon 9600
- LG Electronics L204WT monitor, max. resolution 1680x1050
- Ubuntu 7.04

Some xresprobe and ddcprobe information can be found in the attachment. Currently, my workaround is enabling the extra resolutions by reconfiguring xserver-xorg too.

Daniel Hahler (blueyed) wrote :

I think the problem are the default sync values in xorg.conf:
 HorizSync 28-51
 VertRefresh 43-60

Therefor the autodetection for the correct resolution fails with:
(--) NV(0): Panel size is 1920 x 1200
(II) NV(0): Using hsync ranges from config file
(II) NV(0): Using vrefresh ranges from config file
...
(II) NV(0): Not using default mode "1920x1200" (hsync out of range)

And if you enter specific mode lines (or probably adjust HorizSync value) it somehow gets forced.

So, who is adding those default values and can they get bumped/removed.

joejoy (joe2joy) wrote :

I have same issues with Ubuntu 7.04 with my Dell E520 with Intel G965 Chipset on a 20 Inc Wide-screen monitor.

WinXP supports 1680x1050 resolution. But Ubuntu supports 1024x768.

Tried lot of things like reconfiguring X, 915resolution but nothing seems yo work... I guess I will abandon plans with Ubuntu..

Daniel Hahler (blueyed) wrote :

joejoy, you can probably always fix this by manually editing /etc/X11/xorg.conf and adding your screen resolution there manually, as an entry in a "Modes" line.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.