(i810/S3/Cirrus Logic GD 5446) + xorg = xfce crashes when opening terminal

Bug #91849 reported by Allan MacKinnon on 2007-03-13
160
Affects Status Importance Assigned to Milestone
xfce4-terminal (Ubuntu)
Medium
Unassigned
xorg-server (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: xfce4-terminal

Xfce crashes on my Feisty install whenever I run Terminal. I believe this bug is xorg-related.

Lately, I wanted to reconfigure my xserver due to recent updates so I logged out and typed:

$sudo dpkg-reconfigure -phigh xserver-xorg

I tried the vesa driver and only got 800x600 resolution (or 600x480, whatever the default is) but Terminal ran WITHOUT crashing Xfce!

I tried i810 next (my actual chipset) and Xfce ran at my usual 1024x768 but running Terminal still crashes Xfce.

Something, probably related to i810 settings in Xorg, is causing terminal to crash. It COULD be a rogue config file but I don't know how to fix that. Suggestions? If you need the output of a log file let me know which one.

EDIT

If I remember correctly, this glitch began after installing and playing prboom/freedoom. The screen froze and I had to hit my reset button. The terminal actually worked beforehand but doesn't any longer. Those packages have long since been removed.

EDIT EDIT

After switching my xorg.conf DefaultDepth setting from 24 to 16 the problem vanished with no affect on performance.

No idea why this happens.

[backtrace]
#0 0xb7b3a2d4 in XAARemoveAreaCallback (area=0xb7e7f170)
    at ../../../../hw/xfree86/xaa/xaaOffscreen.c:109
 infoRec = (XAAInfoRecPtr) 0x8272568
 pPix = <value optimized out>
 pPriv = <value optimized out>
#1 0xb7b1e01d in XAAValidateGC (pGC=0x8272568, changes=<value optimized out>,
    pDraw=0xb3129008) at ../../../../hw/xfree86/xaa/xaaGC.c:130
 area = (FBAreaPtr) 0xb7e7f170
 infoRec = (XAAInfoRecPtr) 0x8242620
 pGCPriv = (XAAGCPtr) 0x82725f8
#2 0x0811e0a9 in miBSCheapValidateGC (pGC=0x8272568, stateChanges=8388607,
    pDrawable=0xb3129008) at ../../mi/mibstore.c:808
No locals.
#3 0x0817be77 in cwValidateGC (pGC=0x8272568, stateChanges=8388607,
    pDrawable=0xb3129008) at ../../../miext/cw/cw.c:166
 pBackingGC = <value optimized out>
 pPriv = (cwGCPtr) 0x827261c
 pBackingDrawable = <value optimized out>
 x_off = <value optimized out>
 y_off = <value optimized out>
#4 0x08176ee0 in damageValidateGC (pGC=0x8272568, changes=8388607,
    pDrawable=0xb3129008) at ../../../miext/damage/damage.c:445
 pGCPriv = (DamageGCPrivPtr) 0x8272614
#5 0x0809d1c5 in ValidateGC (pDraw=0xb3129008, pGC=0x8272568)
    at ../../dix/gc.c:77
No locals.

description: updated
description: updated
JLK (jlk) wrote :

Same problem here with Xubuntu Feisty Beta.
I have a Sony laptop with i810 chipset and a fresh install of Xubuntu Feisty Beta.
xfce crashes when I launch xfce4-terminal from the Applications menu.

JLK (jlk) wrote :

I attach my Xorg.0.log if it may help...

Jani Monoses (jani) wrote :

could you please try gnome-terminal and see if that works? This is to rule out Xorg, or libvte. Thanks.

JLK (jlk) wrote :

I just installed gnome-terminal and it works ok.

Lukas Sabota (punkrockguy318) wrote :

I just installed a fresh installation of Xubuntu Beta, and upgraded to the latest packages. Every time I open terminal, my x session crashes like the above poster's.

Jani Monoses (jani) wrote :

can one of you please file the bug to upstream xfce bugzilla, just in case it is not an Xorg bug, as gnome-terminal seems to be happy. thank you

JLK (jlk) wrote :

Bug now filed in upstream xfce bugzilla:
http://bugzilla.xfce.org/show_bug.cgi?id=3130

Changed in xfce:
status: Unknown → Confirmed

It's not just with an i810 that the X server ends up crashing. And I do believe there may well be a bug in Xorg, in the X server (as well as any bug there might be in xfce4-terminal or elsewhere in Xfce).

I have a SiS 6326, rather than an i810, and xfce4-terminal in Xubuntu 7.04 crashes the X server. As my saved Xfce session included an xfce4-terminal window, it was a bit of a problem! So, via one of the virtual terminals, I installed Gnome as a temporary alternative. In one Gnome session, I opened an xfce4-terminal and the X server didn't crash. But when opened in Xfce, the X server does crash. The Gnome terminal doesn't crash the X server in either Gnome or Xfce.

I do believe there may well be a bug in Xorg, in the X server, as its log reported a "Fatal server error". (Just because the X server's crashed by xfce4-terminal and not Gnome's terminal doesn't mean there isn't a bug in Xorg. Bugs just don't have to be that well-behaved.) The tail end of the log is pasted at http://paste.ubuntu-nl.org/16529/ . Surely X clients such as xfce4-terminals should not be causing "Fatal server error"s and crashing the X server. It just looks like a bug in the X server to me, that xfce4-terminal under Xfce is managing to trigger.

Oh, and it's Xubuntu 7.04, the actual release, installed as a distribution upgrade to 6.10. (I did the upgrade two days ago, on the very day 7.04 was released.)

Hi!
I also have an i810 chipset causing the terminal to terminate the xfce session.
For me also, changing the color depth in xorg.conf from 24 to 16 fixed the problem.
Hope that helps narrowing the bug's location.

Sebastian

P.S.: I made a fresh installation with the alternate-iso

Hi,

I also have an i810 chipset with the same problem (if a run xfce4-terminal my X session crash)!

I'm using:

amartins@gamma:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 7.04
Release: 7.04
Codename: feisty

I would like to thank chAoS, because his workaround (change the color depth from 24 to 16) solve the problem!

Regards,

Alessandro Martins

calimarno (calimarno) wrote :

Same problem here, but I'm actually using the neomagic video driver.
I'll try the workaround.

I am using an older S3 chipset, and am experiencing the same problem. I have tried to change the colour depth, and that allowed me to log in. But trying to open a terminal causes a crash. This is an upgrade to 7.04 from 6.10. Everything worked fine before, so I don't know what changed.

Same problem, xfce crashes when opening terminal from "Applications -> Accesories -> Terminal" in Xubuntu 7.04 Feisty Fawn.
I have tried changing the color depth from 24 to 16, as suggested, and this workaround worked like a charm.

djfake (djfake) wrote :

Same problem with Xubuntu 7.04 on a Dell Dimension L433c (128MB Ram). Editing /etc/X11/xorg.conf to 16 bit fixed the problem.

Craig Younkins (cyounkins) wrote :

I have the same exact configuration as the djfake:
Xubuntu 7.04
Dell Dimension L433c
128MB Ram

Editing /etc/X11/xorg.conf to 16 bit DID fix the problem.

Morgan G (morgan-greenleaf) wrote :

Im having the same problem with the terminal crashing but cant figure out the workarounds. How do you install gnome terminal without a terminal? or how do you edit xorg.conf without using sudo in a terminal window?

There is an answer to this question in the following link

https://answers.launchpad.net/ubuntu/+source/xfce4-terminal/+question/7143

but please note that I decide to go back to Dapper and does not face the same problem.

Hi Morgan,

I think that this fix has worked for a few people:

As for X crashing when you open the terminal, I recommend the following:

To do this, you'll need to boot into an xterm session, so when the login
screen comes up, click on the Sessions icon, and select Terminal session or
something similar.
This will bring you into an xterm session - not an xfce4-terminal. It
should work. :)

* use the "cd" command to navigate to your /etc/X11 folder and make a backup
copy of your xorg.conf file. You can do this by entering:
cd /etc/X11
sudo cp xorg.conf xorg.conf_backup

* edit your xorg.conf file, changing the default depth from 24 to 16. You
can
do this by entering:
sudo nano xorg.conf
. . . then scroll down to the Screen section, and find the DefaultDepth
option. Change that number to 16.

*press control-o (letter "O") to save the file, then press control-x to exit
the nano text editor.

Then exit from the xterm session, and it should bring you back to the login
window. Select an Xfce session from the session button, and proceed to login
as usual.

I hope this helps! Sorry it is kind of a non-pretty way to do things, but
it's hard to tell you to enter these changes into a regular terminal when
the
regular terminal crashes your X session! I think that this should work,
though . . .
Let us know if it doesn't work. Thanks!

Jim

--
> i810 + xorg = xfce crashes when opening terminal
> https://bugs.launchpad.net/bugs/91849
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
<email address hidden>

Excellent! Terminal is up and running, thanks again.

This is also a problem on the Xubuntu i386 LiveCD. That may not be a problem for most people who only pop the CD in and install, but for those who actually run the system for a day or two at a time off of a LiveCD, this makes for a problem.

Martin (viiieighte) wrote :

Exact same problem here: S3 gives a crash.

Logan56 (bluemoon-cgp) wrote :

I had this same problem using Xfce as my desktop environment in another distro: BLAG, which is based on Fedora (versions 6 and 7).
My graphical card is also an S3 and I solved the issue in the way Jim Campbell indicated above.
Thanks Jim ;-)

Derek (bugs-m8y) wrote :

Hey, um, if the only app that has this issue (and I ran into it too) is xfce4-terminal - then why the not just symlink /usr/bin/xterm to /usr/bin/xfce4-terminal ?
I'd would rather give up xfce4-terminal than 24bit colour.

Changed in xfce4-terminal:
importance: Undecided → Medium
status: New → Triaged

This seems similar to bug #81512. I am not sure if it is a duplicate. But #81512 does not specify a chipset, but it has the same problem.
https://bugs.launchpad.net/ubuntu/+source/xfce4-terminal/+bug/81512

libertyernie (libertyernie) wrote :

gnome-terminal works fine in Xfce. Just have xubuntu-desktop depend on:
gnome-terminal | xfce4-terminal
And when the bug is fixed, flip them around to make xfce4-terminal default.

libertyernie (libertyernie) wrote :

Xubuntu is used on many old computers. Many old computers use i810.
The release candidate isn't going to go over all that well...

Bryce Harrington (bryce) wrote :

Bug 81512 sounds to be a dupe of this bug. On that bug, the following backtrace was reported:

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x81) [0x80c9581]
1: [0xffffe420]
2: /usr/lib/xorg/modules//libxaa.so [0xb7b6101d]
3: /usr/bin/X [0x811e0a9]
4: /usr/bin/X [0x817be77]
5: /usr/bin/X [0x8176ee0]
6: /usr/bin/X(ValidateGC+0x25) [0x809d1c5]
7: /usr/bin/X [0x817c64c]
8: /usr/bin/X [0x817ca7f]
9: /usr/bin/X [0x81780f1]
10: /usr/bin/X(compPaintWindowBackground+0x6d) [0x810a77d]
11: /usr/bin/X(miWindowExposures+0xfa) [0x81265ea]
12: /usr/bin/X [0x80debbc]
13: /usr/bin/X(miHandleValidateExposures+0x78) [0x813e168]
14: /usr/bin/X(MapWindow+0x3e7) [0x807b857]
15: /usr/bin/X(ProcMapWindow+0x59) [0x808edb9]
16: /usr/bin/X [0x81575b1]
17: /usr/bin/X(Dispatch+0x1aa) [0x808f47a]
18: /usr/bin/X(main+0x495) [0x8076f05]
19: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7d91050]
20: /usr/bin/X(FontFileCompleteXLFD+0x1e1) [0x8076241]

Fatal server error:
Caught signal 11. Server aborting

This matches one of the backtraces in the upstream bug, 3130.

Changed in xserver-xorg-video-intel:
importance: Undecided → Medium
status: New → Triaged
Bryce Harrington (bryce) wrote :

Can those experiencing this issue try the following things? (In increasing order of challenge.)

1. Look in your /var/log/Xorg.0.log[.old] for backtraces like the one in the previous message. If you get a crash message but it looks different than the above, please post it here for comparison.

2. Try disabling composite (reportedly in 3130 some people said the issue went away when they disabled composite).

3. Try disabling DRI. Add this to your /etc/X11/xorg.conf:

 Section "Module"
        ...
        Load "dri"
        ...
 EndSection

4. If you are on Gutsy and using the "intel" driver, test for this bug using this git snapshot of the driver:

  http://people.ubuntu.com/~bryce/Testing/intel/xserver-xorg-video-intel_2.1.1~git20071004-0ubuntu1_i386.deb

5. Get an strace output for xfce-terminal and upload here. This is done via something like,

  strace -o xfce4-terminal.trace xfce4-terminal

6. Get a backtrace through gdb manually. See https://wiki.ubuntu.com/DebuggingXorg for details on how to debug X crashes. (This is the most likely way we'll get to the bottom of this issue, so is probably going to be well worth the difficulty to set this up and try it.)

Sergio Zanchetta (primes2h) wrote :

@Bryce

I tested your driver but no luck.

Here you have new backtrace

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x81) [0x80c9581]
1: [0xffffe420]
2: /usr/lib/xorg/modules//libxaa.so [0xb7b4201d]
3: /usr/bin/X [0x811e0a9]
4: /usr/bin/X [0x817be77]
5: /usr/bin/X [0x8176ee0]
6: /usr/bin/X(ValidateGC+0x25) [0x809d1c5]
7: /usr/bin/X [0x817c64c]
8: /usr/bin/X [0x817ca7f]
9: /usr/bin/X [0x81780f1]
10: /usr/bin/X(compPaintWindowBackground+0x6d) [0x810a77d]
11: /usr/bin/X(miWindowExposures+0xfa) [0x81265ea]
12: /usr/bin/X [0x80debbc]
13: /usr/bin/X(miHandleValidateExposures+0x78) [0x813e168]
14: /usr/bin/X(MapWindow+0x3e7) [0x807b857]
15: /usr/bin/X(ProcMapWindow+0x59) [0x808edb9]
16: /usr/bin/X [0x81575b1]
17: /usr/bin/X(Dispatch+0x1aa) [0x808f47a]
18: /usr/bin/X(main+0x495) [0x8076f05]
19: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7d73050]
20: /usr/bin/X(FontFileCompleteXLFD+0x1e1) [0x8076241]

Fatal server error:
Caught signal 11. Server aborting

P.S.: You put Bug 81512 as a duplicate of this bug not adding intel xserver as package affected. (it was even high rated)

Sergio Zanchetta (primes2h) wrote :

strace

Bryce Harrington (bryce) wrote :

Hi Sergio, thanks for the backtrace; looks like it also involves compPaintWindowBackground. It would be helpful if you installed -dbg versions of xserver and your video driver, to try and get additional details on the crash.

Yes, I dropped -intel as an involved package because reports have indicated that the same problem affects other drivers beyond -intel (S3 for instance). Also, from the backtraces we aren't yet seeing a failure in driver code. It may very well end up being a driver issue, but we don't yet have solid enough evidence of that yet.

The following is at the end of the xfce-terminal strace:

connect(4, {sa_family=AF_FILE, path="/tmp/.X11-unix/X0"}, 19) = 0
...
write(4, "\24\0\6\0\1\0@\2\354\0\0\0\4\0\0\0\0\0\0\0@B\17\0", 24) = 24
read(4, "\34P\236\1 \0@\2\364\0\0\0]\274K\326\0\0\0\0\2\0\0\0\0"..., 32) = 32
read(4, "\34P\236\1 \0@\2_\1\0\0]\274K\326\0\1\0\0\2\0\0\0\0\0\0"..., 32) = 32
read(4, "\34P\236\1 \0@\2a\1\0\0]\274K\326\0\1\0\0\2\0\0\0\0\0\0"..., 32) = 32
read(4, "\34P\236\1 \0@\2\356\0\0\0]\274K\326\0\0\0\0\2\0\0\0\0"..., 32) = 32
read(4, "\25\0\236\1 \0@\2 \0@\2\24\r\340\0\6\0\33\0\0?\t\10\200"..., 32) = 32
read(4, "\34P\236\1E\0\0\0\37\1\0\0_\274K\326\0\1\0\0\2\0\0\0\0"..., 32) = 32
read(4, "\34P\236\1E\0\0\0Z\1\0\0_\274K\326\0\1\0\0\2\0\0\0\0\0"..., 32) = 32
read(4, "\34P\236\1 \0@\2F\1\0\0_\274K\326\0\1\0\0\2\0\0\0\0\0\0"..., 32) = 32
read(4, "\26\0\236\1 \0@\2 \0@\2\"\r\340\0\6\0\33\0\341\2\312\1"..., 32) = 32
read(4, "\226\216\236\1 \0@\2 \0@\2\24\r\340\0\26\1+\1\341\2\312"..., 32) = 32
read(4, 0xbfcadbfc, 32) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=4, events=POLLIN, revents=POLLIN|POLLERR|POLLHUP}], 1, -1) = 1
read(4, 0xbfcadbfc, 32) = -1 ECONNRESET (Connection reset by peer)
write(2, "xfce4-terminal: Fatal IO error 1"..., 96) = 96
close(7) = 0
--- SIGCHLD (Child exited) @ 0 (0) ---
sigreturn() = ? (mask now [])
kill(4959, SIGTERM) = 0
exit_group(1) = ?

I notice that first write() statement is writing 24 bits... I wonder if that relates at all to the 16/24 DefaultDepth distinction being noticed with this bug.

But anyway, the connection to X is dying after doing some IO with it. Unfortunately the backtraces so far have not pinpointed where in the server this IO is being received, so it's hard to identify why it is causing a crash. So we'll definitely need to have someone install -dbg versions and run gdb against this to get a backtrace (and maybe step through code to identify what lines are involved.)

aletheianalex (aletheianalex) wrote :

I can confirm this also. I reformatted and did a clean install from the most recent .iso. Even with the raw, unaltered install, Terminal crashes gdm and sends me back to the login. Also, I cannot bring up a text console on any other tty via ctrl+alt+(function key). I get a blank black screen with a blinking underscore cursor.

Hitting alt+f2 to bring up "run" and them launching xterm works, but typing "xfce4-terminal" has the same effect.

I am running an S3 card as well. It appears to be an Xfce problem, and switching to 16 bit is not acceptable, so I am going to switch to another distro until this driver gets sorted out.

Peter Clifton (pcjc2) wrote :

If you find one which works, please let us know the version numbers of the libX11 and the X server being used. We might then see what is different.

Sergio Zanchetta (primes2h) wrote :

@Bryce

Ok, I didn't see that in this Bug report there are also people with S3 card (in Bug I was subscribed as duplicate were just intel one)
But isn't it worth a High rated Importance?

Soon I'll post some debug...

Sergio Zanchetta (primes2h) wrote :

Xorg debug attached.

Sergio Zanchetta (primes2h) wrote :

@Bryce
I tried adding dri module in xorg.conf but no luck.

I don't have composite enabled.
If I try to enable it I just get wallpaper on my screen (icons, panels etc. disappears)
To get back I need to change depth to 16 by booting in no graphic mode, then reeboting normally and disable composite.

sargas (sargas) wrote :

@Bryce
Had the same problem on a new (although updated) install of xubuntu gusty, added the following to my xorg.conf:

Section "Extensions"
        Option "Composite" "Disable"
EndSection

Section "ServerFlags"
        Option "AIGLX" "off"
EndSection

And that fixed the problem (didn't even notice composite was on, it probably doesn't help things in a computer this old)

I have version "2:1.1.1-1ubuntu4" of libx11-6 and libx11-data, version 2:1.7.4-0ubuntu5 of xserver-xorg-video-i810, and version 1:7.2-5ubuntu13 of xorg package

I tried copying what Bryce did, and it works for me, too. I have no idea what those two things mean (Composite and AIGLX), but all seems fine with them disabled.

From wiki.archlinux.org:

AIGLX -- Enables GL-accelerated effects on a standard desktop.

Composite -- A Xorg extension required by composite managers
The Composite extension for X causes an entire sub-tree of the window hierarchy to be rendered to an off-screen buffer. Applications can then take the contents of that buffer and do whatever they like. The off-screen buffer can be automatically merged into the parent window or merged by external programs, called compositing managers.

"write(4, "\24\0\6\0\1\0@\2\354\0\0\0\4\0\0\0\0\0\0\0@B\17\0", 24) = 24
read(4, "\34P\236\1 \0@\2\364\0\0\0]\274K\326\0\0\0\0\2\0\0\0\0"..., 32) = 32
.
.
.
I notice that first write() statement is writing 24 bits... I wonder if that relates at all to the 16/24 DefaultDepth distinction being noticed with this bug."

If (big if) that's the case then those following statements are trying to read 32 bits from video that doesn't support 32 bit depth (the i810 only does 8/16/24). I wonder if that cold be a problem.

I found that I needed only to disable the composite extension by adding the following to xorg.conf:

Section "Extensions"
        Option "Composite" "Disable"
EndSection

I did not need to disable AIGLX or switch to 16 bit mode.

Changed in xfce:
status: Confirmed → Invalid
robert567 (rob2342) wrote :

Had the same problem using xubuntu 7.10 on IBM NetVista p3 (using standard video card on motherboard)

Changing the colour depth from 24 to 16 in xorg.conf fixed it.

Thanks.

also noted

with an upgrade from 6.6. to 7.04 going onto 7.10 still experiencing issue

here is a complete backlog as requested earlier

Sergio Zanchetta (primes2h) wrote :

Just added a duplicate in which crash happens with a Cirrus Logic GD 5446.

I think the patch I posted in

https://bugs.launchpad.net/ubuntu/+source/xfce4-terminal/+bug/194769

might solve this problem. Anyone want to try it?

Bryce Harrington (bryce) on 2009-01-28
Changed in xorg-server:
assignee: nobody → bryceharrington
Bryce Harrington (bryce) wrote :

Thanks for getting that backtrace, that illuminates the situation better. However it doesn't appear to be something trivial like a null pointer dereference.

Next step for this bug is to go upstream for further analysis.

description: updated
Changed in xorg-server (Ubuntu):
assignee: bryceharrington → nobody
Bryce Harrington (bryce) on 2009-03-19
Changed in xorg-server (Ubuntu):
importance: Medium → High
Cruncher (ubuntu-wkresse) wrote :

Just confirming this bug on Ubuntu 8.04 Hardy (upgraded). System is up-to-date, with:
xfce4-terminal 0.2.8-4ubuntu1
xserver-xorg 1:7.3+10ubuntu10.2

xorg.conf uses i810.
Workaround to disable Composite helps.

GaryW (gnubyexample) wrote :

Have upgraded to Jaunty from Intrepid in the last few days and now I experience a problem running xfce4-terminal. Have no problems running gnome-terminal or konsole or xterm but for whatever reason xfce4-terminal is now broken in my Jaunty (9.04) setup.

An strace is attached as file xfce4-terminal-strace.8289 and the final few lines look like this:

d183z2g:~$ tail xfce4-terminal-strace.8289
select(5, [4], [4], NULL, NULL) = 1 (out [4])
writev(4, [{"&\0\2\0[\0\240\3"..., 8}, {NULL, 0}, {""..., 0}], 3) = 8
select(5, [4], [], NULL, NULL) = 1 (in [4])
read(4, "\1\1\205\0\0\0\0\0\240\0\0\0\0\0\0\0\250\1\364\0;\1\247\0\0\0\0\0\320\211\350\17"..., 4096) = 32
read(4, 0x9b60398, 4096) = -1 EAGAIN (Resource temporarily unavailable)
select(5, [4], [4], NULL, NULL) = 1 (out [4])
writev(4, [{"%\0\1\0"..., 4}, {NULL, 0}, {""..., 0}], 3) = 4
read(4, 0x9b60398, 4096) = -1 EAGAIN (Resource temporarily unavailable)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

There is some other supporting information in the attachments also regarding running kernel 2.6.27-11-generic and some dpkg output showing installed package versions.

GaryW (gnubyexample) wrote :

Supporting information to the comment above is in the attachment here.

Lionel Le Folgoc (mrpouit) wrote :

Any evolution/change/improvement with xfce4-terminal 0.4.0 in karmic?

I've completely changed systems since I experienced this bug and the hardware no longer applies. Sorry.

Bryce Harrington (bryce) wrote :

Since the hardware is no longer available for doing troubleshooting with, we'll have to close the bug for now. However please feel free to reopen if you or anyone else has the same HW and can reproduce this issue using the latest development version of Ubuntu and is willing to do some troubleshooting with it.

Changed in xorg-server (Ubuntu):
status: Triaged → Invalid
Lionel Le Folgoc (mrpouit) wrote :

Same here, if someone can reproduce this bug with a recent xfce4-terminal version (>= 0.4.0), feel free to reopen this bug report.

Changed in xfce4-terminal (Ubuntu):
status: Triaged → Fix Released
to be removed (liw) wrote :

Bryce,

kvm (or qemu) emulates a Cirrus Logic GD 5446 graphics card. That's how I ran into this: I was testing a Xubuntu ISO under kvm. I'll undo the status change to invalid for now, and will test the current xubuntu ISO for karmic to see if this still happens.

to be removed (liw) wrote :

I've verified that starting the terminal under XFCE (live cd, latest karmic ISO) no longer crashes X, so this bug can stay closed for all I care.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.