Xubuntu 7.04 xserver crashes when launching terminal

Bug #114124 reported by vschmidt on 2007-05-11
10
Affects Status Importance Assigned to Milestone
xfce4-terminal (Ubuntu)
Undecided
Unassigned

Bug Description

After fresh install Xubuntu 7.04 from Alt-Install 386 CD on older hardware, launching terminal from application menu will cause xserver to crash and reload. Not entire system reboot, just xserver restart back to logon screen. I confirmed this on 5 different PC's our LUG is reworking for charity - All older machines.

Specs: (typical)
Dell P3 - 666 Mhz / 192 MB Ram / 8 MB video cards (old)

xterm does not crash when launched.

All current updates applied to 7.04. I notice this is reported in forums, and seems to be related to older-vintage hardware.

JF (jackojf-xu) wrote :

I am having the same problem on a Sony Vaio PCG-F540 with 192 MB RAM.
I just installed the latest release around May 5.

Cheers!

JF

Sam Liu (samcliu) wrote :

Same problem on a 6.10 Edgy that I updated to 7.04 Feisty running XFCE on Xubuntu Desktop. 128mb ram, 700mhz Celeron Coppermine Processor.

When I hit terminal, the Xserver crashes and restarts.

Sam Liu (samcliu) wrote :

(oh and this was today. I upgraded today. It was working fine before the upgraded so this problem is strictly feisty.)

Sam Liu (samcliu) wrote :

temporary solution - open synaptic and install gnome2 terminal since its only the xfce4 terminal thats having an issue.

This also effected me using QEMU and installing from the alternate cd image for feisty (i386) onto a hard drive image. So could be tested on a vitual machine by the person who tries to fix this bug.

To reproduce:
(Opt install qemu)
Install from alternate CD (not sure if this is the same with the desktop cd) xubuntu.
Open a terminal from the menu.
X will crash and restart bringing you back to the x login prompt.

Can reproduce and doesn't look isolated to one person from the comments so setting to confirmed. More info may be needed though to fix this bug.

Changed in xfce4-terminal:
status: Unconfirmed → Confirmed
Julián Landerreche (maniqui) wrote :

Simple solution (that worked for me): change your color depth from 24 to 16 (in xorg.conf).

First seen here:
https://bugs.launchpad.net/ubuntu/+source/xfce4-terminal/+bug/91849/comments/9

credford (credford) wrote :

Here's a problem I'm running into with the color depth solution: in order to change xorg.conf, you have to be root. However, my Xubuntu GUI isn't prompting me for a root password when I open xorg.conf and I obviously can't do a manual sudo because I can't open the terminal. How are you editing xorg.conf without the terminal?

Also, I've seen a number of people recommending some kind of gnome terminal as an alternative but I don't see a gnome terminal of any type in Synaptics. Am I missing something? Is there a listing somewhere with specific instructions for getting the gnome terminal working?

JF (jackojf-xu) wrote :

Hi Credford!

If you right-click on the "Applications" menu on the top left of your screen, you'll be able to choose either Edit Menu or Add New Item. From there you can add an item to the menu with the name and command you want. In my menu, I added an item with the name Shell and the command /usr/bin/xterm. You may need to install xterm with Synaptics first. I'm not sure if xterm is installed by default.

Cheers!

JF

credford (credford) wrote :

Okay, thanks JF. Xterm gives me terminal access. Whew..

wandy (info-gandalf) wrote :

Thanks JF for your information.

On my screen xterm was a bit difficult to read. Instead of the command /usr/bin/xterm i have added /usr/bin/gnome-terminal.
You may need to install gnome-terminal with Synaptics first. ( just search form gnome-terminal in the Synaptic Package Manager)

Jim Campbell (jwcampbell) wrote :

This is a duplicate of bug #91849, and it also affects the upstream xfce4-terminal - xfce-bugs #3130.

As a workaround, please see the answer left at the bottom of this page: https://answers.launchpad.net/ubuntu/+source/xfce4-terminal/+question/7143

Just want to mention that I encountered this issue on a very old EPS laptop running Xubuntu 7.10 gutsy. Installation was from an alternate CD because it has very low memory. Adjusting color depth to 16 in xorg.conf seems to have solved it.

KIAaze (zohn-joidberg) wrote :

This bug still exists on Xubuntu 8.04... :(
I just switched my cousins computer from Ubuntu to Xubuntu because it was too slow and noticed this.

This is a really strange bug. And changing color depth fixes it? O.o
I think I'll change the shortcut to xterm in the meanwhile.

Sergio Zanchetta (primes2h) wrote :

Yes, setting color depth to 16 works.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers