Attempting to open terminal in Xubuntu cause gdm restart

Bug #81512 reported by Dougie on 2007-01-25
18
Affects Status Importance Assigned to Milestone
xfce4-terminal (Ubuntu)
Undecided
Jani Monoses
xorg (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

Xubuntu-Feisty - When attempting to open terminal via Applications>System, or from Desktop Launcher-computer goes to login screen(restart) every time. Can only do update through "Update Manager" in which I really have no control over what is installed/removed No terminal access.

Sebastien Bacher (seb128) wrote :

Thank you for your bug. Do you have anything to /var/log about that? If xorg is crashing that's probably an xorg bug. Do you use a composite manager?

Changed in gnome-terminal:
status: Unconfirmed → Needs Info

Sebastien Bacher wrote:
> Thank you for your bug. Do you have anything to /var/log about that? If
> xorg is crashing that's probably an xorg bug. Do you use a composite
> manager?
>
> ** Changed in: gnome-terminal (Ubuntu)
> Status: Unconfirmed => Needs Infow
>
>
What would you like from the var/log as there is all kind of folders
there. Sorry for not being so bright Also I do not believe that I use
'composite manager. I have installed the gnome-terminal in my
Xubuntu-Feisty and that is working ok but the terminal in
Applications>System is still causing restarts when I click to open it.

Hum, the gnome-terminal menu entry is in 'accessories' in feisty. Are you sure you're using the gnome-terminal, not the xfce4 one?

Sebastien Bacher (seb128) wrote :

you can have a look to /var/log/messages /var/log/syslog /var/log/Xorg.0.log for informations about that

Gauvain Pocentek wrote:
> Hum, the gnome-terminal menu entry is in 'accessories' in feisty. Are
> you sure you're using the gnome-terminal, not the xfce4 one?
>
>
gnome terminal works fine. It's the one that's in Applications>System-
that's causing the system crash

run an xterm (via alt-f2) and from that run xfce4-terminal maybe there are more hints on why it misbehaves
also ~/.xsession-error contents may be helpful

Joseph Wyckoff (joseph-wyckoff) wrote :

I have had the same problem and open a but report on it becuase I didn't see this one.

If I hit alt+f2 and type in xterm I get a terminal that works, but clicking on the terminal in applications>system sends the user to the log-in screen everytime.

Jani Monoses (jani) wrote :

works for me. Please look at the log files mentioned above see if there are crash related messages. Is this on 32 or 64 bit archs?

Dougie wrote:
> Gauvain Pocentek wrote:
>
>> Hum, the gnome-terminal menu entry is in 'accessories' in feisty. Are
>> you sure you're using the gnome-terminal, not the xfce4 one?
>>
>>
>>
> gnome terminal works fine. It's the one that's in Applications>System-
> that's causing the system crash
>
>
thanks, yes I am aware of the 2 terminal and I am now using gnome
terminal as the xfce is the crasher

Dougie (dougiesta) wrote :

Jani Monoses wrote:
> run an xterm (via alt-f2) and from that run xfce4-terminal maybe there are more hints on why it misbehaves
> also ~/.xsession-error contents may be helpful
>
>
thanks for your reply. I am just gonna stick with gnome terminal and
leave that xfce one alone as it is the crasher

Dougie (dougiesta) wrote :

Joseph Wyckoff wrote:
> I have had the same problem and open a but report on it becuase I didn't
> see this one.
>
> If I hit alt+f2 and type in xterm I get a terminal that works, but
> clicking on the terminal in applications>system sends the user to the
> log-in screen everytime.
>
>
exactly my point, so now I stick with the gnome terminal

with no further input this cannot be fixed so rejecting

Changed in xfce4-terminal:
status: Needs Info → Rejected
monarch508 (monarch508) wrote :

<<From ver/log/messages>>
Jun 10 01:47:18 nixServer gconfd (monarch508-4800): Received signal 15, shutting down cleanly
Jun 10 01:47:18 nixServer gconfd (monarch508-4800): Exiting
Jun 10 01:47:42 nixServer gconfd (monarch508-5088): starting (version 2.18.0.1), pid 5088 user 'monarch508'
Jun 10 01:47:42 nixServer gconfd (monarch508-5088): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Jun 10 01:47:42 nixServer gconfd (monarch508-5088): Resolved address "xml:readwrite:/home/monarch508/.gconf" to a writable configuration source at position 1
Jun 10 01:47:42 nixServer gconfd (monarch508-5088): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Jun 10 01:47:42 nixServer gconfd (monarch508-5088): Resolved address "xml:readonly:/var/lib/gconf/debian.defaults" to a read-only configuration source at position 3
Jun 10 01:47:42 nixServer gconfd (monarch508-5088): Resolved address "xml:readonly:/var/lib/gconf/defaults" to a read-only configuration source at position 4

<<From ver/log/syslog>>
Jun 10 01:47:18 nixServer gconfd (monarch508-4800): Received signal 15, shutting down cleanly
Jun 10 01:47:18 nixServer gconfd (monarch508-4800): Exiting
Jun 10 01:47:19 nixServer gdm[4421]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
Jun 10 01:47:42 nixServer gconfd (monarch508-5088): starting (version 2.18.0.1), pid 5088 user 'monarch508'
Jun 10 01:47:42 nixServer gconfd (monarch508-5088): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Jun 10 01:47:42 nixServer gconfd (monarch508-5088): Resolved address "xml:readwrite:/home/monarch508/.gconf" to a writable configuration source at position 1
Jun 10 01:47:42 nixServer gconfd (monarch508-5088): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Jun 10 01:47:42 nixServer gconfd (monarch508-5088): Resolved address "xml:readonly:/var/lib/gconf/debian.defaults" to a read-only configuration source at position 3
Jun 10 01:47:42 nixServer gconfd (monarch508-5088): Resolved address "xml:readonly:/var/lib/gconf/defaults" to a read-only configuration source at position 4

Changed in xfce4-terminal:
assignee: nobody → jani
status: Rejected → Needs Info
monarch508 (monarch508) wrote :

I am a brand new user to ubuntu and linux in general, so excuse any ignorance i show. I ran into this same bug and it seem rather large just to leave unsolved, so i will help in any way i can.

monarch508 (monarch508) wrote :

Sorry for the second post.

The /var/log/Xorg.0.log had a ton of info that was all labeled as part of the the restart involving the terminal selected from Application>Accessories. If there is a specific section that would be useful, i can paste that, other wise i can attach the whole log if needed.

Ohh, and this is on a 32 bit system.

Martin (viiieighte) wrote :

I have the same problem on an old (1999) Toshiba Satellite laptop.
VAR:LOG:MESSAGES
Jun 24 14:00:25 djc-laptop gconfd (djc-4903): starting (version 2.18.0.1), pid 4903 user 'djc'
Jun 24 14:00:25 djc-laptop gconfd (djc-4903): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Jun 24 14:00:25 djc-laptop gconfd (djc-4903): Resolved address "xml:readwrite:/home/djc/.gconf" to a writable configuration source at position 1
Jun 24 14:00:25 djc-laptop gconfd (djc-4903): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Jun 24 14:00:25 djc-laptop gconfd (djc-4903): Resolved address "xml:readonly:/var/lib/gconf/debian.defaults" to a read-only configuration source at position 3
Jun 24 14:00:25 djc-laptop gconfd (djc-4903): Resolved address "xml:readonly:/var/lib/gconf/defaults" to a read-only configuration source at position 4
Jun 24 14:02:03 djc-laptop gconfd (djc-4903): Received signal 15, shutting down cleanly
Jun 24 14:02:03 djc-laptop gconfd (djc-4903): Exiting
Jun 24 14:02:23 djc-laptop gconfd (djc-5029): starting (version 2.18.0.1), pid 5029 user 'djc'

You can see the crash happened at 14:02.
VAR:LOG:SYSLOG
Jun 24 14:00:25 djc-laptop gconfd (djc-4903): starting (version 2.18.0.1), pid 4903 user 'djc'
Jun 24 14:00:25 djc-laptop gconfd (djc-4903): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Jun 24 14:00:25 djc-laptop gconfd (djc-4903): Resolved address "xml:readwrite:/home/djc/.gconf" to a writable configuration source at position 1
Jun 24 14:00:25 djc-laptop gconfd (djc-4903): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Jun 24 14:00:25 djc-laptop gconfd (djc-4903): Resolved address "xml:readonly:/var/lib/gconf/debian.defaults" to a read-only configuration source at position 3
Jun 24 14:00:25 djc-laptop gconfd (djc-4903): Resolved address "xml:readonly:/var/lib/gconf/defaults" to a read-only configuration source at position 4
Jun 24 14:02:03 djc-laptop gconfd (djc-4903): Received signal 15, shutting down cleanly
Jun 24 14:02:03 djc-laptop gconfd (djc-4903): Exiting
Jun 24 14:02:03 djc-laptop gdm[4826]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
Jun 24 14:02:23 djc-laptop gconfd (djc-5029): starting (version 2.18.0.1), pid 5029 user 'djc'

~:XSESSION-ERRORS is attached.

Martin (viiieighte) wrote :

From reading the comments at Bug #91849 it's clear that my video card is the problem. It doesn't support 24-bit mode, even though it reports that it does! Changing to 16-bit mode solved the problem.

michael m (plantwater) wrote :
Download full text (25.5 KiB)

I'm having identical desktop crashes on multiple computers in my classroom (I'm a teacher in elementary school) Xterm works fine but Terminal (/usr/bin/Terminal) crashes X everytime. I'm unsure of how to change the bitmode of my video card as a workaround as suggested by Martin. I'm also unsure as to whether the applications menu is editable to remove or repoint the Terminal launcher to xterm or another alternative.

Here's my /var/log/messages from the point I invoked the command 'Terminal' in xterm... As you can see it caused a full crash and I had to hard-reset the machine.

Aug 2 14:40:06 friendship gconfd (teacher-4841): Received signal 15, shutting down cleanly
Aug 2 14:40:07 friendship gconfd (teacher-4841): Exiting
Aug 2 14:43:25 friendship syslogd 1.4.1#20ubuntu4: restart.
Aug 2 14:43:26 friendship kernel: Inspecting /boot/System.map-2.6.20-15-generic
Aug 2 14:43:26 friendship kernel: Loaded 24975 symbols from /boot/System.map-2.6.20-15-generic.
Aug 2 14:43:26 friendship kernel: Symbols match kernel version 2.6.20.
Aug 2 14:43:26 friendship kernel: No module symbols loaded - kernel modules not enabled.
Aug 2 14:43:26 friendship kernel: [ 0.000000] Linux version 2.6.20-15-generic (root@palmer) (gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)) #2 SMP Sun Apr 15 07:36:31 UTC 2007 (Ubuntu 2.6.20-15.27-generic)
Aug 2 14:43:26 friendship kernel: [ 0.000000] BIOS-provided physical RAM map:
Aug 2 14:43:26 friendship kernel: [ 0.000000] sanitize start
Aug 2 14:43:26 friendship kernel: [ 0.000000] sanitize end
Aug 2 14:43:26 friendship kernel: [ 0.000000] copy_e820_map() start: 0000000000000000 size: 00000000000a0000 end: 00000000000a0000 type: 1
Aug 2 14:43:26 friendship kernel: [ 0.000000] copy_e820_map() type is E820_RAM
Aug 2 14:43:26 friendship kernel: [ 0.000000] copy_e820_map() start: 00000000000f0000 size: 0000000000010000 end: 0000000000100000 type: 2
Aug 2 14:43:26 friendship kernel: [ 0.000000] copy_e820_map() start: 0000000000100000 size: 000000000fdae000 end: 000000000feae000 type: 1
Aug 2 14:43:26 friendship kernel: [ 0.000000] copy_e820_map() type is E820_RAM
Aug 2 14:43:26 friendship kernel: [ 0.000000] copy_e820_map() start: 000000000feae000 size: 0000000000152000 end: 0000000010000000 type: 2
Aug 2 14:43:26 friendship kernel: [ 0.000000] copy_e820_map() start: 00000000ffb00000 size: 0000000000500000 end: 0000000100000000 type: 2
Aug 2 14:43:26 friendship kernel: [ 0.000000] BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
Aug 2 14:43:26 friendship kernel: [ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
Aug 2 14:43:26 friendship kernel: [ 0.000000] BIOS-e820: 0000000000100000 - 000000000feae000 (usable)
Aug 2 14:43:26 friendship kernel: [ 0.000000] BIOS-e820: 000000000feae000 - 0000000010000000 (reserved)
Aug 2 14:43:26 friendship kernel: [ 0.000000] BIOS-e820: 00000000ffb00000 - 0000000100000000 (reserved)
Aug 2 14:43:26 friendship kernel: [ 0.000000] 0MB HIGHMEM available.
Aug 2 14:43:26 friendship kernel: [ 0.000000] 254MB LOWMEM available.
Aug 2 14:43:26 friendship kernel: [ 0.000000] Zone PFN ranges:
Aug 2 1...

Goyo (goyodiaz) wrote :

Same problem here. Xubuntu Feisty i386 installed on a Qemu virtual machine using the alternate CD. Launching XFCE Terminal causes X to restart. It works fine if XFCE is not running (for example running FVWM). The 16 bits video workaround works fine too.

Attached .xsession-errors, and messages, syslog and Xorg.0.log in /var/log. XFCE Terminal was invoked at 11:39:30.

I suggest change the status to confirmed and importance to as last medium as newbbies hardly can figure out how to launch a terminal emulator.

Goyo (goyodiaz) wrote :
Goyo (goyodiaz) wrote :
Goyo (goyodiaz) wrote :

After finally having got some advice how to install (reported bug in instalment end April) I managed yesterday to get installed Xubuntu on my old Toshiba Satellite 4000 CDT with 96 mb ram. It took 5½ hours.

I also found out, that if I try to open a terminal, system logs me out and I have to login again. After reading the above messages it looks like there is no solution to this problem except doing something that I do not know how to do being novice to Linux.

Before installing some of the other things I would like to install I would like to hear if anything is happening with this bug. Otherwise I probably go looking for other solutions.

This is a pretty significant bug. It is still present in Xubuntu 7.10, herd 5. I do hope it will be fixed before the official release.
This is really important. When any average user enters commands, as suggested from online guides or elsewhere, their sessions will just end. This will only add to user frustration. This really, really, needs fixing.

Has gone back to 6.06 Dapper Drake as I cannot use 7.04, so if you are going to fix this even ½ year after the version came out I probably has to give up using Xubuntu when the version is no longer updated.

Actually, I find Dapper far better than Edgy or Feisty. In Feisty, they killed off the spinning Xubuntu logo splash screen, and many other little tweeks that I do not like. The only thing is, I do not know how to put new things on the old Dapper. I can't get Firefox 2 on it, nor several other updated applications. I don't want to be running old software, so I am stuck (unsatisfied) with the new releases.

I had this same problem on a computer with the Intel 82815 graphics chipset, running Xubuntu 7.04. I commented out the 24-bit colour mode in xorg.conf, made 16-bit the default, and it no longer crashes.

Sergio Zanchetta (primes2h) wrote :

Same problem here, Intel 82815 graphics chipset, Gutsy 7.10.

Sergio Zanchetta (primes2h) wrote :

This bug is even WORSE.

Launch xfce4-terminal from Application Launcher pressing Alt + F2.

Screen get black with a lot of of quite horizontal lines (artefacts) freezing PC.

Bryce Harrington (bryce) wrote :

Closing xorg task as it's also filed against -intel

Changed in xorg:
status: New → Invalid
Bryce Harrington (bryce) on 2007-10-20
Changed in xserver-xorg-video-intel:
importance: Undecided → High
status: New → Confirmed
Peter Clifton (pcjc2) wrote :

Does this bug still occur with the intel video drivers in the final 7.10 release?

If so, can someone reproduce it, and post the /var/log/Xorg.0.log.old (as after the crash, and X restarts we want the old logfile from the X server which crashed)

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
Sergio Zanchetta (primes2h) wrote :
Peter Clifton (pcjc2) on 2007-10-24
Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Here's the backtrace from Segio's log:

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x81) [0x80c9581]
1: [0xffffe420]
2: /usr/lib/xorg/modules//libxaa.so [0xb7b6101d]
3: /usr/bin/X [0x811e0a9]
4: /usr/bin/X [0x817be77]
5: /usr/bin/X [0x8176ee0]
6: /usr/bin/X(ValidateGC+0x25) [0x809d1c5]
7: /usr/bin/X [0x817c64c]
8: /usr/bin/X [0x817ca7f]
9: /usr/bin/X [0x81780f1]
10: /usr/bin/X(compPaintWindowBackground+0x6d) [0x810a77d]
11: /usr/bin/X(miWindowExposures+0xfa) [0x81265ea]
12: /usr/bin/X [0x80debbc]
13: /usr/bin/X(miHandleValidateExposures+0x78) [0x813e168]
14: /usr/bin/X(MapWindow+0x3e7) [0x807b857]
15: /usr/bin/X(ProcMapWindow+0x59) [0x808edb9]
16: /usr/bin/X [0x81575b1]
17: /usr/bin/X(Dispatch+0x1aa) [0x808f47a]
18: /usr/bin/X(main+0x495) [0x8076f05]
19: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7d91050]
20: /usr/bin/X(FontFileCompleteXLFD+0x1e1) [0x8076241]

Fatal server error:
Caught signal 11. Server aborting

Bryce Harrington (bryce) wrote :

Sergio, could you also try this git snapshot of -intel from a couple weeks ago, to see if the problem still occurs?

http://people.ubuntu.com/~bryce/Testing/intel/xserver-xorg-video-intel_2.1.1~git20071004-0ubuntu1_i386.deb

Changed in xfce:
status: Unknown → Confirmed
aletheianalex (aletheianalex) wrote :

I can confirm this also. I reformatted and did a clean install from the most recent .iso. Even with the raw, unaltered install, Terminal crashes gdm and sends me back to the login. Also, I cannot bring up a text console on any other tty via ctrl+alt+(function key). I get a blank black screen with a blinking underscore cursor.

Hitting alt+f2 to bring up "run" and them launching xterm works, but typing "xfce4-terminal" has the same effect.

display (email8723200) wrote :

same here, ultra fresh install, xfce4-terminal crashes whole xserver
solved by setting in default display depth to 16 bits xorg.conf
it says it has a Silicon Integrated Systems [SiS] 86C326 5598/6326
might be true, :P its an old pci video card, 8mb
the rest? PIII800, 384mb, asus cuv4x

im not sure what info would be useful for you, ill just paste some of the lines i found in the logs

>>a line in syslog (the others refer to dhcp)
Oct 29 01:08:35 xubuntu710 gdm[6172]: WARNING: gdm_slave_xioerror_handler: Fatal X error - Restarting :0

>>gdm/0log
0: /usr/bin/X(xf86SigHandler+0x81) [0x80c9581]
1: [0xffffe420]
2: /usr/lib/xorg/modules//libxaa.so [0xb791201d]
3: /usr/bin/X [0x811e0a9]
4: /usr/bin/X [0x817be77]
5: /usr/bin/X [0x8176ee0]
6: /usr/bin/X(ValidateGC+0x25) [0x809d1c5]
7: /usr/bin/X [0x817c64c]
8: /usr/bin/X [0x817ca7f]
9: /usr/bin/X [0x81780f1]
10: /usr/bin/X(compPaintWindowBackground+0x6d) [0x810a77d]
11: /usr/bin/X(miWindowExposures+0xfa) [0x81265ea]
12: /usr/bin/X [0x80debbc]
13: /usr/bin/X(miHandleValidateExposures+0x78) [0x813e168]
14: /usr/bin/X(MapWindow+0x3e7) [0x807b857]
15: /usr/bin/X(ProcMapWindow+0x59) [0x808edb9]
16: /usr/bin/X [0x81575b1]
17: /usr/bin/X(Dispatch+0x1aa) [0x808f47a]
18: /usr/bin/X(main+0x495) [0x8076f05]
19: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7d43050]
20: /usr/bin/X(FontFileCompleteXLFD+0x1e1) [0x8076241]

Fatal server error:
Caught signal 11. Server aborting

>>.xsession-errors
(process:5958): Gtk-WARNING **: This process is currently running setuid or setgid.
[blabla] Refusing to initialize GTK+.
[not sure what this might mean. it continues...]
Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
                  Ignoring extra symbols
Warning: No symbols defined for <SYRQ> (keycode 92)
[and more undefined symbols...]
xfce-mcs-manager: Fatal IO error 104 (Connection reset by peer) on X server :0.0.
The application 'xfwm4' lost its connection to the display :0.0; most likely the X server was shut down or you killed/destroyed the application.
xfce4-panel: Fatal IO error 104 (Connection reset by peer) on X server :0.0.
The application 'xfce4-menu-plugin' lost its connection to the display :0.0; most likely the X server was shut down or you killed/destroyed the application.
The application 'xfdesktop' lost its connection to the display :0.0; most likely the X server was shut down or you killed/destroyed the application.
The application 'thunar-tpa' lost its connection to the display :0.0; most likely the X server was shut down or you killed/destroyed the application.
xfce4-terminal: Fatal IO error 104 (Connection reset by peer) on X server :0.0.
nm-applet: Fatal IO error 104 (Connection reset by peer) on X server :0.0.
The application 'x-session-manager' lost its connection to the display :0.0; most likely the X server was shut down or you killed/destroyed the application.

Ill check back later, anything else you might need just ask...
For now, ill use 16b

Changed in xfce:
status: Confirmed → Invalid

Please try the patch I posted at:

https://bugs.launchpad.net/ubuntu/+source/xfce4-terminal/+bug/194769

Perhaps this will help

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.