Unable to launch xdiagnose through the Activities Overview in the normal way

Bug #1483276 reported by Nikita Yerenkov-Scott on 2015-08-10
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Critical
Ubuntu GNOME
High
Unassigned
xdiagnose (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

Impact
======
Clicking the icon in GNOME Shell's Activities Overview for xdiagnose fails silently. Nothing happens. xdiagnose is a default app in Ubuntu GNOME so this is a major papercut.

Another bug being fixed in this upload is that xdiagnose hard-coded its app icon location making it impossible for icon themes to override it.

Test Case
=========
1. From Ubuntu GNOME 16.04, install the update.
2. Note that GNOME Shell caches app icons so the xdiagnose icon will probably disappear. You can fix this by logging out and logging back or by running Alt-F2 and entering the letter r in the popup. Wait a few moments for gnome-shell to reload.
3. Open the Activies Overview. Search for xdiagnose and click the app in the results.
4. Does xdiagnose run? Does its icon display ok?

Regression Potential
====================
Low. The primary change basically just copies what Synaptic does with its synaptic-pkexec launcher. Except for the minor glitch with the icon disappearing until GNOME Shell is reloaded, the icon switch is simple.

Original Bug Report
===================
I am in need of doing some diagnostics work with "xdiagnose", however when searching for it in the Activities Overview, and then clicking on it, absolutely nothing happens, when in the past it would ask me for my password so that I could run it as root.

I looked further into the issue and when trying to run it through Terminal:

    xdiagnose

This was the output I got:

    Error: Must run as superuser

But when running it in Terminal like so:

    pkexec xdiagnose

It prompted for the password as it normally would and should (so pkexec is not the issue).

There was also no output from the command:

    grep -r 'xdiagnose' ~/.local/share/applications

And the output of this command "grep -r 'xdiagnose' /usr/share/applications" was:

    /usr/share/applications/xdiagnose.desktop:Name=xdiagnose
    /usr/share/applications/xdiagnose.desktop:Exec=pkexec xdiagnose
    /usr/share/applications/xdiagnose.desktop:Icon=/usr/share/xdiagnose/icons/microscope.svg
    /usr/share/applications/xdiagnose.desktop:X-Ubuntu-Gettext-Domain=xdiagnose

The contents of the file is this:

    [Desktop Entry]
    Name=xdiagnose
    GenericName=Diagnose Graphics Issues
    Comment=X.org Diagnostic and Repair Utility
    Exec=pkexec xdiagnose
    Icon=/usr/share/xdiagnose/icons/microscope.svg
    Terminal=false
    Type=Application
    Categories=System;Settings;
    X-Ubuntu-Gettext-Domain=xdiagnose

I have reinstalled it with "sudo apt-get install --reinstall xdiagnose", however this seems to have made no difference at all to anything.

I have also attempted to launch another application via the Activities Overview that uses 'pkexec' to start, and it works fine as normal.

I initially experienced this issue on Ubuntu GNOME 15.04 with GNOME 3.16, then on Ubuntu GNOME 15.10 with GNOME 3.18, and now on Ubuntu GNOME 16.04 with GNOME 3.20. Though I remember a time when this issue wasn't present (probably when I was running Ubuntu GNOME 15.04 with GNOME 3.14).

tags: added: vivid
description: updated

This issue is still present on Ubuntu GNOME 15.10 with GNOME 3.18 and a fresh install.

tags: added: wily
description: updated

I have also tested it in Ubuntu GNOME 16.04 with GNOME 3.19 and the issue is still present.

tags: added: xenial
summary: - Unable to launch xdiagnose through the GUI in the normal way
+ Unable to launch xdiagnose through the Activities Overview in the normal
+ way
description: updated

I have now also reported this issue upstream: https://bugzilla.gnome.org/show_bug.cgi?id=763531

description: updated
description: updated
Changed in gnome-shell:
importance: Unknown → Critical
status: Unknown → Confirmed

I still experience this issue with Ubuntu GNOME 16.04 with GNOME 3.20.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in xdiagnose (Ubuntu):
status: New → Confirmed
Changed in ubuntu-gnome:
status: New → Confirmed
description: updated

Does it happen under Unity?

If it does, set status for "xdiagnose" as "confirmed", and status for "gnome-shell" as "invalid".
If it does not, do the other way around.

Thank you.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Incomplete
Changed in xdiagnose (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → High
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
Changed in xdiagnose (Ubuntu):
importance: High → Medium
importance: Medium → High

Though I have not tested yet myself on Unity, I have asked a few people to and it all works as expected for them.

Changed in xdiagnose (Ubuntu):
status: Incomplete → Invalid
Changed in gnome-shell (Ubuntu):
status: Incomplete → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1483276

tags: added: iso-testing
Jeremy Bicha (jbicha) on 2016-08-20
Changed in xdiagnose (Ubuntu):
status: Invalid → Triaged
Changed in ubuntu-gnome:
status: Confirmed → In Progress
importance: Undecided → High
Jeremy Bicha (jbicha) on 2016-08-20
no longer affects: gnome-shell (Ubuntu Xenial)
Changed in xdiagnose (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
status: Triaged → In Progress
Changed in xdiagnose (Ubuntu):
status: Triaged → Fix Committed
Jeremy Bicha (jbicha) on 2016-08-20
description: updated
Jeremy Bicha (jbicha) wrote :

The bug does not seem to affect Ubuntu GNOME 14.04 LTS.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 3.8.5

---------------
xdiagnose (3.8.5) yakkety; urgency=medium

  * Use xdiagnose-pkexec helper script (like synaptic-pkexec) to
    fix xdiagnose not starting from GNOME's Activities Overview
    (LP: #1483276)
  * Install app icon in standard location (making it themeable)

 -- Jeremy Bicha <email address hidden> Sat, 20 Aug 2016 00:55:14 -0400

Changed in xdiagnose (Ubuntu):
status: Fix Committed → Fix Released

Glad to see a fix has been released, when will it be backported into Xenial?

Jeremy Bicha (jbicha) wrote :

I uploaded a Stable Release Update for this issue, but it has to be manually accepted.

See https://wiki.ubuntu.com/StableReleaseUpdates

https://launchpad.net/ubuntu/xenial/+queue?queue_state=1

Hello Nikita, or anyone else affected,

Accepted xdiagnose into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xdiagnose/3.8.4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xdiagnose (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed

I have tested this package (version 3.8.4.1) in an Ubuntu GNOME 16.04.1 VM with the default 3.18 and can confirm that it fixes the issue.

tags: added: verification-done yakkety
removed: verification-needed
Ty Young (bluegoliath) wrote :

Oddly enough, after doing a reinstall of 16.04 xdiagnose does properly prompt me for a password and starts.

The password prompt reads "Authentication is needed to diagnose graphical issues".

Gnome shell is 3.18 while dpkg -s outputs 3.8.4 as the version number.

Any idea why it is working for me? Will installing the updated package break anything as its already working?

Christopher (soft-kristal) wrote :

I don't have this problem either and haven't going back several versions up to 16.04.

I've been running Ubuntu Gnome for a few years and it seems less susceptible to bugs.

I know it's strange, but I'm almost certain that the version of Ubuntu where I first had the issue, it only came after doing a fresh install, previously it had worked on a fresh install as well. But this update definitely fixes it for me. Seems it doesn't affect all though, but if you can test that the updated version in -proposed doesn't break the functionality for you then I don't see a problem in releasing it if it fixes the problem for those who have it.

It is even stranger that in all my GNOME VMs it doesn't work without the version in -proposed, but in my Unity VMs it works fine with the version we have currently and you say it works for you on.

Changed in gnome-shell:
status: Confirmed → Unknown
Changed in gnome-shell:
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdiagnose - 3.8.4.1

---------------
xdiagnose (3.8.4.1) xenial; urgency=medium

  * Use xdiagnose-pkexec helper script (like synaptic-pkexec) to
    fix xdiagnose not starting from GNOME's Activities Overview
    (LP: #1483276)
  * Install app icon in standard location (making it themeable)

 -- Jeremy Bicha <email address hidden> Sat, 20 Aug 2016 00:55:14 -0400

Changed in xdiagnose (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xdiagnose has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in ubuntu-gnome:
status: In Progress → Fix Released
Jeremy Bicha (jbicha) on 2017-03-24
no longer affects: gnome-shell (Ubuntu)
Changed in gnome-shell:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.