xdiagnose's shortcut launched nothing

Bug #1183771 reported by Alberto Salvia Novella on 2013-05-24
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
xdiagnose
Undecided
Unassigned
xdiagnose (Ubuntu)
Low
Unassigned
Nominated for Xenial by Alberto Salvia Novella

Bug Description

****************
HOW TO REPRODUCE
****************
- Click-on the xdiagnose icon in the dash.

*********
BEHAVIOUR
*********
- EXPECTED: xdiagnose to be launched.
- REAL: Nothing happens.

***********
WORK-AROUND
***********
- Write into the Terminal "sudo xdiagnose".
- Use "ubuntu-bug" or "apport-bug" commands instead.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xdiagnose 3.5.1
ProcVersionSignature: Ubuntu 3.8.0-22.33-generic 3.8.11
Uname: Linux 3.8.0-22-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Fri May 24 12:40:53 2013
InstallationDate: Installed on 2013-05-21 (2 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: xdiagnose
UpgradeStatus: No upgrade log present (probably fresh install)

Changed in xdiagnose (Ubuntu):
importance: Undecided → Low
Changed in hundredpapercuts:
importance: Undecided → Low
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
Changed in xdiagnose (Ubuntu):
status: New → Confirmed
summary: - xdiagnose shortcut launched nothing
+ xdiagnose's shortcut launched nothing
Changed in xdiagnose (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: New → Triaged
Ma Hsiao-chun (mahsiaochun) wrote :

I think we should hide xdiagnose icon by default. What do you think Alberto?

This bug seems to have been fixed. When I run xdiagnose from the dash, I get an authentication dialog asking for my password. I enter it, and xdiagnose is run.

Ma Hsiao-chun (mahsiaochun) wrote :

Not working on my raring box. And even if it runs, I still feel that it is useless to end users.

Does not work on my installation of Ubuntu 13.04.

Does the file /usr/share/applications/xdiagnose.desktop correspond to the dash
entry for xdiagnose? If so, then xdiagnose is launched via [pkexec xdiagnose]
command which does not work with dash for me:
* When I launch xdiagnose using dash icon nothing happens.
* When I type [pkexec xdiagnose] into Alt-F2 dash prompt nothing happens too.
* But when I run this command from the terminal, it shows me a window asking
  for a password and launches xdiagnose succesfully.

I think the "xdiagnose" icon is useless for the end user, since its usage appears to be very uncommon. Nearly any bug in X appears to be capable of being reported successfully without using this tool.

On the other hand, I have the same behaviour here as Anatoly under Ubuntu 13.04: xdiagnose only runs from the terminal.

Note that this bug, although the "xdiagnose" icon is removed, shall be fixed for the "Alf + F2" action.

Thank you

There is similar discussion about [pkexec <command>] in .desktop file and Alt-F2:
https://bugs.launchpad.net/unity/+bug/957641

Possible solution is simple wrapper script like one of GParted (/usr/bin/gparted-pkexec).
In case .desktop file will be removed it still solves problem with launching from dash.

Changed in hundredpapercuts:
assignee: Papercuts Ninjas (papercuts-ninja) → nobody
warren (wkclemmons) wrote :

This bug is in Ubuntu Gnome 16.04.1 Daily
Ubuntu Gnome Desktop amd64 version 20160808

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1183771

tags: added: iso-testing
tags: added: xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers