Ubuntu

Dash and launcher appear underneath windows

Reported by Manfred Herrmann on 2011-07-03
This bug affects 254 people
Affects Status Importance Assigned to Milestone
Unity
Critical
Sam Spilsbury
unity (Ubuntu)
Critical
Sam Spilsbury
Oneiric
Critical
Sam Spilsbury

Bug Description

main problem:
  unity launcher and dash always hidden (behind displayed application-windows)

more details and symptoms:
  docky behaves like unity-launcher/dash.
  press "super" button and type "terminal+enter" (nothing displayed) ... a terminal-window starts/pop-up

conclusion:
  the "input-stack/focus" is o.k.
  the "windows-display-stack/focus" is wrong

more symptoms:
  After docky-stop and docky-start (restart) the docky-bar shows as "top-level-window" => o.k.
  This is reproducable with firefox windows by moving/maximise/move to desktop XY.
  Sometimes other windows (like terminal-window/google-chrome-window) are hiding the launcher/dash/docky too.
  This problem is reproducable on a T60p with ATI-FireGL video-card.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.16-0ubuntu1~natty1
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Sun Jul 3 13:58:33 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 tp-smapi, 0.40, 2.6.38-10-generic, x86_64: installed
 tp-smapi, 0.40, 2.6.38-8-generic, x86_64: installed
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21d1]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: LENOVO 428449G
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic root=UUID=be0937c9-8117-4833-a50b-1b5c391c9b69 ro quiet splash i915.semaphores=1 vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-10.46-generic 2.6.38.7
ProcVersionSignature__: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 04/19/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8BET42WW (1.22 )
dmi.board.asset.tag: Not Available
dmi.board.name: 428449G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8BET42WW(1.22):bd04/19/2011:svnLENOVO:pn428449G:pvrThinkPadW520:rvnLENOVO:rn428449G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 428449G
dmi.product.version: ThinkPad W520
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

affects: ubuntu → unity (Ubuntu)

Hi,

Can you try to rephrase this bug report so that it includes:

1.) Step by step instructions to reproduce
2.) What you expected to happen
3.) What actually happened

Please also avoid reporting more than one issue in the same bug report (for example I don't see what the role of docky is in this bug report)

Changed in unity (Ubuntu):
status: New → Incomplete

1.) Step by step instructions to reproduce
It happens after moving and resizing multiple Firefox-Windows.
(...This is reproducible with firefox windows by moving/maximize/move to desktop XY.)

2.) What you expected to happen
I would like to use the unity launcher and dash. I press "super-button" and would like to see launcher and dash. Instead i can only see part of the launcher behind a firefox window.
It should never hidden/behind other application-windows.

3.) What actually happened
After moving and resizing Firefox-Windows the unity launcher+dash are hidden by all the Firefox-Windows.
(... main problem: unity launcher and dash always hidden (behind displayed application-windows)

4.) Please also avoid reporting more than one issue in the same bug report (for example I don't see what the role of docky is in this bug report)
NOT a second issue ... only a symptom and related?!
Docky shows the same behavior as launcher/dash with the exception that "docky-mouse-over-text" is visible. Docky-Panel+Icons are not visible (hidden/behind firefox-window). Docky-Icons-Text is visible like firefox-window-content.

Michael (idmer) wrote :

Confirm, have same problem but with Blender (with 2-windows set).
Unity panel loses "stay on top" focus after starting blender and starts to falls behind focused windows. Can return opened dash on top only if press middle mouse button on all opend windows (send them on back)

Damiön la Bagh (kat-amsterdam) wrote :

This incident needs screenshots. If someone is faster than me in making a screenshot of this error please attach it. I saw this behaviour yesterday on a friends Ubuntu machine using Google Chrome and Banshee. Will try to obtain screenshots from my friend.

Damiön la Bagh (kat-amsterdam) wrote :

Does the problem exist for the original bug initiator after a reboot of the system? My friend rebooted his system and is now no longer able to reproduce this bug.

Michael (idmer) wrote :

While trying to catch this error, i found some interesting things.

(blender have 2 identical windows, but one of them, (launching on right screen) have "start-up image")

1) if I launch blender from dash, problem appears only if I press on right window first.

2) if I launch blender from launcher, problem appears, but if I don't touch other windows, I can restore this.
    -- so, i minimize and maximize left blender window - and all is ok.

Iain Farrell (iain-farrell) wrote :

This also happens in Chromium.

Lukáš Chmela (lukaschmela) wrote :

Me too, I am able to reproduce this bug. I think it may also happen sometimes with wine.

Omer Akram (om26er) wrote :

I still am not seeing any steps to reproduce this bug. When you comment just please keep the comment precise, we are aware what should not happen we just want the step to cause the problem.

Changed in unity:
status: New → Incomplete
summary: - hidden unity launcher+dash after moving around multiple firefox windows
+ Dash and launcher appear underneath windows
Ingo Gerth (igerth) wrote :

This bug occurs on my computer, too. Funnily, my system takes it to another level. When I try to take a screenshot of the situation, the dash and the launcher appear to be on top of the other windows again, although they actually are not. Unity is haunted....

Mario Vukelic (mario-vukelic) wrote :

May be a duplicate of bug #803831

Joel Leclerc (lkjoel) wrote :

I have the same problem on my computer. When I log out, and back in, it works for a while, then it breaks again.

Omer Akram (om26er) wrote :

In Oneiric this bug is occuring to a much larger extent.

Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Omer Akram (om26er) on 2011-09-05
tags: added: oneiric
Omer Akram (om26er) on 2011-09-06
Changed in unity:
milestone: none → 4.14.0
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
milestone: 4.14.0 → 4.16.0
Matthias Gehre (m-gehre) wrote :

After this bug occurs, restarting unity by "unity& disown" in a terminal fixes the problem.

Didier Roche (didrocks) on 2011-09-14
tags: added: didrocks-oneiric-list
Neil J. Patel (njpatel) on 2011-09-14
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
importance: High → Critical
status: Confirmed → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
importance: High → Critical
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-09-15
Changed in unity:
milestone: 4.16.0 → 4.18.0
Omer Akram (om26er) on 2011-09-16
Changed in unity (Ubuntu):
milestone: none → ubuntu-11.10-beta-2
pablomme (pablomme) wrote :

I get this with google chrome, and I've also seen it with ardour2 and ardour3 (ardour2 used to cause a very similar problem in gnome2 where it would end up stacked above gnome-panel, so perhaps the problem with ardour is of a different nature).

tags: added: rls-mgr-o-tracking
omarly666 (omarly666) wrote :

i got this problem running dual screen. gotta go back to launcher panel - often twice - or the workspace shifter - to get the focus right again

omarly666 (omarly666) wrote :

tried workaround #15 and got two more bug reports??

dueSouth (totayfun) wrote :

workaround #15 did not do the trick for me. After unity restarts it is still behaving in the same way.

pablomme (pablomme) wrote :

This is, if I'm not mistaken, a side effect of bug #845719, which according to http://smspillaz.wordpress.com/2011/09/18/braindump-how-to-get-window-stacking-right/ is being worked on with dedication and should have a fix in the archives this week (probably just after beta 2, due out this Thursday).

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu Oneiric):
status: In Progress → Fix Committed
JarekJ83 (jarekj83) wrote :

^cool, now waitin for updates:)

i confirm, a little late... that unity does in fact lose focus and remains under any window type when called upon (Super key).

Michael Moorman (tensorpuddin) wrote :

After installing updates, I can confirm the focus problem still affects user applications as in bug #805630 though it seems that Dash and Launcher and the alt+tab switcher are no longer affected.

JarekJ83 (jarekj83) wrote :

^yep, but fix aint released yet right?

Justin (justin-wzy) wrote :

is this fix released yet please?

Adolfo Jayme (fitoschido) wrote :

No. See the status of this bug: “Fix committed”. Be patient...

Dave Walker (davewalker) on 2011-09-23
Changed in unity (Ubuntu):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
status: Fix Committed → Fix Released

For me, after update to compiz 1:0.9.5.94+bzr20110919-0ubuntu1 I did not have the problem described in this bug anymore. Is there a separate fix in unity?

Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 4.18.0-0ubuntu1

---------------
unity (4.18.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Screen corruption when resuming from suspend/hibernate (LP: #676166)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #764024)
    - Dash and launcher appear underneath windows (LP: #805087)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #811401)
    - [Oneric] unity-panel-service crashed with SIGSEGV in getenv()
      (LP: #817691)
    - compiz crashed with SIGSEGV in unity::FilterBar::RemoveFilter()
      (LP: #845732)
    - crash on closing a window (LP: #856015)
    - Cannot open a window that starts iconified (LP: #732997)
    - Launcher - When useing Alt F1 launcher keyboard navigation, Launcher
      should not scroll until top or bottom of Launcher is reached
      (LP: #765749)
    - Stacking problem when switching between apps with multiple windows
      (LP: #802527)
    - Pull panel to de-maximize window occasionally not working in a secondary
      screen (LP: #802651)
    - Window under Dash gets focused if it opened later (LP: #830730)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - A minimized window 'remains' behind on the desktop if
      /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows
      is set to true (LP: #847967)
    - a11y support on Unity is broken (LP: #851103)
    - compiz crashed with SIGSEGV in dee_model_get_tag() (LP: #840758)
    - crash when looping paint list in preparePaint (on closing windows)
      (LP: #853807)
    - Alt-Tab should not preview windows at excessively large sizes
      (LP: #854740)
    - Clicking on a tweet/message link sometimes does not work (LP: #790565)
    - Dragging a launcher icon makes it squashed (LP: #855761)
    - unable to unminimize gedit windows where more than one window where one
      has a dialog open (LP: #856030)
    - (oneiric) alt-tab UX doesn't work well on multi-monitor (LP: #855364)
    - Launcher shows on the primary monitor instead of the left most monitor
      (LP: #857668)
    - Keynav - pressing down key causes launcher items to jump up and down
      (LP: #858469)
    - Windows creep cross the screen with ALT+TAB (LP: #722830)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - All unity windows are invisible (panel, launcher, dash) (LP: #745996)
    - Dash "See 97 more results" has ~1 second of latency (LP: #731158)
    - Windows cannot be dragged down from panel if banshee closed to sound
      menu (LP: #781215)
    - no menu bar on top, compositing bug? (LP: #806358)
    - Launcher - a spread can accidentally be triggered during the 'dragging
      and dropping behind the Launcher' interaction (LP: #832988)
    - Impossible to navigate between panel menus when the mouse cursor is over
      the panel (LP: #834065)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - Application name drawn under Dash controls when window opens under Dash
      (LP: #838176)
    - Start ...

Read more...

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released

This is not fixed with Unity 4.20.0-0ubuntu2 and Compiz 1:0.9.6+bzr20110929-0ubuntu1.

I've just restarted and opened a few windows (Nautilus, Firefox, Totem, Gnome-Terminal). All of them appear above the launcher.

I am experiencing this bug with a Dell Mini 9 which I just upgraded to Oneiric today. All unity components (launcher, dash, application switcher) are underneath application windows.

JarekJ83 (jarekj83) wrote :

its still aint fixed well, but its better than it was

Download full text (4.5 KiB)

Can you all run with compiz --debug --replace ccp and post the output ?

On Sun, Oct 2, 2011 at 6:07 PM, JarekJ83 <email address hidden> wrote:
> its still aint fixed well, but its better than it was
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/805087
>
> Title:
>  Dash and launcher appear underneath windows
>
> Status in Unity:
>  Fix Released
> Status in “unity” package in Ubuntu:
>  Fix Released
> Status in “unity” source package in Oneiric:
>  Fix Released
>
> Bug description:
>  main problem:
>    unity launcher and dash always hidden (behind displayed application-windows)
>
>  more details and symptoms:
>    docky behaves like unity-launcher/dash.
>    press "super" button and type "terminal+enter" (nothing displayed) ... a terminal-window starts/pop-up
>
>  conclusion:
>    the "input-stack/focus" is o.k.
>    the "windows-display-stack/focus" is wrong
>
>  more symptoms:
>    After docky-stop and docky-start (restart) the docky-bar shows as "top-level-window" => o.k.
>    This is reproducable with firefox windows by moving/maximise/move to desktop XY.
>    Sometimes other windows (like terminal-window) are hiding the launcher/dash/docky too.
>    This problem is reproducable on a T60p with ATI-FireGL video-card.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: unity 3.8.16-0ubuntu1~natty1
>  ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
>  Uname: Linux 2.6.38-10-generic x86_64
>  Architecture: amd64
>  CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
>  CompositorRunning: compiz
>  Date: Sun Jul  3 13:58:33 2011
>  DistUpgraded: Fresh install
>  DistroCodename: natty
>  DistroVariant: ubuntu
>  DkmsStatus:
>   tp-smapi, 0.40, 2.6.38-10-generic, x86_64: installed
>   tp-smapi, 0.40, 2.6.38-8-generic, x86_64: installed
>  GraphicsCard:
>   Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
>     Subsystem: Lenovo Device [17aa:21d1]
>  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
>  InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
>  InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
>  MachineType: LENOVO 428449G
>  ProcEnviron:
>   LANGUAGE=de_DE:en
>   LANG=de_DE.UTF-8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic root=UUID=be0937c9-8117-4833-a50b-1b5c391c9b69 ro quiet splash i915.semaphores=1 vt.handoff=7
>  ProcVersionSignature_: Ubuntu 2.6.38-10.46-generic 2.6.38.7
>  ProcVersionSignature__: Ubuntu 2.6.38-10.46-generic 2.6.38.7
>  Renderer: Unknown
>  SourcePackage: unity
>  UpgradeStatus: No upgrade log present (probably fresh install)
>  XorgConf:
>   Section "Device"
>        Identifier      "Default Device"
>        Option  "NoLogo"        "True"
>   EndSection
>  dmi.bios.date: 04/19/2011
>  dmi.bios.vendor: LENOVO
>  dmi....

Read more...

JarekJ83 (jarekj83) wrote :
Download full text (6.1 KiB)

u mean this?

jarek@jarek:~$ compiz --debug --replace ccp
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libcore.so : Nie ma takiego pliku ani katalogu
compiz (core) - Debug: Could not stat() file /usr/lib/compiz/libcore.so : Nie ma takiego pliku ani katalogu
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libccp.so : Nie ma takiego pliku ani katalogu
Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend : gconf
Integration : true
Profile : unity
Adding plugins
Skipping upgrade com.canonical.unity.unity.01.upgrade
Skipping upgrade com.canonical.unity.unity.02.upgrade
Initializing core options...done
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libbailer.so : Nie ma takiego pliku ani katalogu
Initializing bailer options...done
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libdetection.so : Nie ma takiego pliku ani katalogu
Initializing detection options...done
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libcomposite.so : Nie ma takiego pliku ani katalogu
Initializing composite options...done
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libopengl.so : Nie ma takiego pliku ani katalogu
Initializing opengl options...done
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libcompiztoolbox.so : Nie ma takiego pliku ani katalogu
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libdecor.so : Nie ma takiego pliku ani katalogu
Initializing decor options...done
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libimgpng.so : Nie ma takiego pliku ani katalogu
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libresize.so : Nie ma takiego pliku ani katalogu
Initializing resize options...done
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libsnap.so : Nie ma takiego pliku ani katalogu
Initializing snap options...done
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libobs.so : Nie ma takiego pliku ani katalogu
Initializing obs options...done
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libregex.so : Nie ma takiego pliku ani katalogu
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libmousepoll.so : Nie ma takiego pliku ani katalogu
Initializing mousepoll options...done
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libwall.so : Nie ma takiego pliku ani katalogu
Initializing wall options...done
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libgnomecompat.so : Nie ma takiego pliku ani katalogu
Initializing gnomecompat options...done
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libunitymtgrabhandles.so : Nie ma takiego pliku ani katalogu
Initializing unitymtgrabhandles options...done
compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libvpswitch.so : Nie ma takiego pliku ani katalogu
Initializing vpswitch option...

Read more...

Sam Spilsbury (smspillaz) wrote :
Download full text (10.7 KiB)

Right, but keep it running until you are able to reproduce the bug,
and then post it.

On Sun, Oct 2, 2011 at 6:48 PM, JarekJ83 <email address hidden> wrote:
> u mean this?
>
> jarek@jarek:~$ compiz --debug --replace ccp
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libcore.so : Nie ma takiego pliku ani katalogu
> compiz (core) - Debug: Could not stat() file /usr/lib/compiz/libcore.so : Nie ma takiego pliku ani katalogu
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libccp.so : Nie ma takiego pliku ani katalogu
> Checking if settings need to be migrated ...no
> Checking if internal files need to be migrated ...no
> Backend     : gconf
> Integration : true
> Profile     : unity
> Adding plugins
> Skipping upgrade com.canonical.unity.unity.01.upgrade
> Skipping upgrade com.canonical.unity.unity.02.upgrade
> Initializing core options...done
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libbailer.so : Nie ma takiego pliku ani katalogu
> Initializing bailer options...done
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libdetection.so : Nie ma takiego pliku ani katalogu
> Initializing detection options...done
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libcomposite.so : Nie ma takiego pliku ani katalogu
> Initializing composite options...done
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libopengl.so : Nie ma takiego pliku ani katalogu
> Initializing opengl options...done
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libcompiztoolbox.so : Nie ma takiego pliku ani katalogu
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libdecor.so : Nie ma takiego pliku ani katalogu
> Initializing decor options...done
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libimgpng.so : Nie ma takiego pliku ani katalogu
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libresize.so : Nie ma takiego pliku ani katalogu
> Initializing resize options...done
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libsnap.so : Nie ma takiego pliku ani katalogu
> Initializing snap options...done
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libobs.so : Nie ma takiego pliku ani katalogu
> Initializing obs options...done
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libregex.so : Nie ma takiego pliku ani katalogu
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libmousepoll.so : Nie ma takiego pliku ani katalogu
> Initializing mousepoll options...done
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libwall.so : Nie ma takiego pliku ani katalogu
> Initializing wall options...done
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libgnomecompat.so : Nie ma takiego pliku ani katalogu
> Initializing gnomecompat options...done
> compiz (core) - Debug: Could not stat() file /home/jarek/.compiz-1/plugins/libunitymtgrabhand...

Matthias Schmidt (mschmidt) wrote :

Bug also bites me. Running oneiric amd64 from today with unity 4.20.0-0ubuntu2. See attached screenshot. Unfortunately, I cannot reproduce it. Maybe its related to suspend2ram ... sometimes I see it after a suspend/resume cycle on my Laptop.

Mario Vukelic (mario-vukelic) wrote :

I had run "compiz --debug --replace ccp > windowstacking.log 2>&1" from a gnome-terminal right after logging in.

I did not go through a suspend/resume cycle during this particular X session. Applications running included Thunderbird and Firefox plus a bunch of background stuff (like indicators) without open windows, and gmplayer. I watched a video fullscreen in gmplayer. I think no other application windows were open at the time, but am not 100% sure and I cannot totally rule out gnucash, liferea, and revelation.

I paused the video, exited fullscreen mode to make a bunch of screenshots in gmplayer. Using the gnome-terminal, copied them to the desktop. I may have moved a file to trash using nautilus, I'm not sure.

In any case I noticed a full Trash icon, opened it from the launcher, and clicked the "Delete" button. At this point the window decorations suddenly vanished as compiz had crashed. The resulting log file is attached like I found it, after restarting lightdm and logging in again. I assume that it belongs to this bug, as it mentions "windows are stacked incorrectly".

Matthijs ten Kate (igadget) wrote :

Just when I thought this bug had been fixed, I'm experiencing it once again, using unity 4.22.0-0ubuntu2.

Joel Leclerc (lkjoel) wrote :

Still have the same problem.

pablomme (pablomme) wrote :
JarekJ83 (jarekj83) wrote :

its still there, its a major bug, how can devs cant release a proper update?

Sam Spilsbury (smspillaz) wrote :
Download full text (4.6 KiB)

On Sat, Oct 8, 2011 at 12:27 AM, JarekJ83 <email address hidden> wrote:
> its still there, its a major bug, how can devs cant release a proper
> update?
>

You have to understand that fixing these kinds of bugs is an immensely
complicated task[1] :) So please have patience.

[1] http://smspillaz.wordpress.com/2011/09/18/braindump-how-to-get-window-stacking-right/
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/805087
>
> Title:
>  Dash and launcher appear underneath windows
>
> Status in Unity:
>  Fix Released
> Status in “unity” package in Ubuntu:
>  Fix Released
> Status in “unity” source package in Oneiric:
>  Fix Released
>
> Bug description:
>  main problem:
>    unity launcher and dash always hidden (behind displayed application-windows)
>
>  more details and symptoms:
>    docky behaves like unity-launcher/dash.
>    press "super" button and type "terminal+enter" (nothing displayed) ... a terminal-window starts/pop-up
>
>  conclusion:
>    the "input-stack/focus" is o.k.
>    the "windows-display-stack/focus" is wrong
>
>  more symptoms:
>    After docky-stop and docky-start (restart) the docky-bar shows as "top-level-window" => o.k.
>    This is reproducable with firefox windows by moving/maximise/move to desktop XY.
>    Sometimes other windows (like terminal-window) are hiding the launcher/dash/docky too.
>    This problem is reproducable on a T60p with ATI-FireGL video-card.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: unity 3.8.16-0ubuntu1~natty1
>  ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
>  Uname: Linux 2.6.38-10-generic x86_64
>  Architecture: amd64
>  CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
>  CompositorRunning: compiz
>  Date: Sun Jul  3 13:58:33 2011
>  DistUpgraded: Fresh install
>  DistroCodename: natty
>  DistroVariant: ubuntu
>  DkmsStatus:
>   tp-smapi, 0.40, 2.6.38-10-generic, x86_64: installed
>   tp-smapi, 0.40, 2.6.38-8-generic, x86_64: installed
>  GraphicsCard:
>   Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
>     Subsystem: Lenovo Device [17aa:21d1]
>  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
>  InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
>  InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
>  MachineType: LENOVO 428449G
>  ProcEnviron:
>   LANGUAGE=de_DE:en
>   LANG=de_DE.UTF-8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic root=UUID=be0937c9-8117-4833-a50b-1b5c391c9b69 ro quiet splash i915.semaphores=1 vt.handoff=7
>  ProcVersionSignature_: Ubuntu 2.6.38-10.46-generic 2.6.38.7
>  ProcVersionSignature__: Ubuntu 2.6.38-10.46-generic 2.6.38.7
>  Renderer: Unknown
>  SourcePackage: unity
>  UpgradeStatus: No upgrade log present (probably fresh install)
>  XorgConf:
>   Section "Dev...

Read more...

JarekJ83 (jarekj83) wrote :

^Sam, i am ;) but i hope its gonna be fixed well in a final version.

I wasn't affected by this until just this morning after letting my desktop run overnight. Dash, launcher, and Alt+Tab all appear underneath windows, forcing the use of Ctrl+Alt+arrow keys to switch to an empty desktop for any real window management.

unity 4.22.0-0ubuntu3.

Peterson Silva (petersonsilva) wrote :

Guys, this still affects me too. If fix released means it shouldn't happen, well, it's happening all the time.

seanlano (seanlano) wrote :

I am able to reproduce this bug by doing the following:

-> Open a document in Document Viewer.
-> Make it fullscreen.
-> Close fullscreen.

Now the Unity dash will always appear underneath all of the windows until a reboot.

u-foka (ufooka) wrote :

I can confirm that this still triggers the bug :(

Tiago Neiva (tneiva) wrote :

I am testing Oneiric Beta 2 (laptop testing) an in a Live Oneiric Beta 2 the Alt-Tab switcher stays behind the other windows.
Same machine 11.04 works ok.

Bug still present with latest updates (latest meaning the time of this message)

falkon (pocztafalkona) wrote :

After a few actualizations, launcher coverred by a fullscreen window can be revealed by pressing super key which was impossible some time ago. That's a progress.
What's more, today I've activated hot right upper and bottom corners in unity settings. Upper corner does not his work as well as right edge of the screen but moving cursor to the right bottom corner shows launcher correctly.

Karl Frisk (karl-frisk) wrote :

not fixed for me. if all desktops are crowded this bug renders ubuntu unusable. also, that is the situation where a reboot is the last thing you want to do.

Hossein Atashi (atashi.h) wrote :

This bug affects me too on the final release of Oneiric. It is really annoying, and I cannot get the launcher even by pressing super key. When this problem happens "unity &disown" temporarily solves it. But it will happen again. I'm not sure exactly how to reproduce it. It "just happens."

Hossein Atashi (atashi.h) wrote :

Just out of curiosity, why is the status for this bug set to "Fix Released?" Has it been fixed before and came back recently?

u-foka (ufooka) wrote :

If I understand the situation correctly, one bug that caused this behavior was fixed, and yes before it happened to me all the time, but now it's way better.

One thing is known to cause this if you close the document viewer (evince) in full screen mode.

I mark this now as Confirmed, to make more attention, since the bug is exactly the same, just has more triggers.

Anyway, if the devs think we should open a new report, please tell us, but it's a known problem for a long time, and no one told us to open a separate bug for this.

Thanks!

u-foka (ufooka) wrote :

Heh... launchpad updated since I last tryed and seems to refuse the status change :P

RickB (rick-777) wrote :

Just upgraded to 11.10 and this bug now affects me. There's no sign of the fix.
R. :)

@smspillaz: All these “me too” messages are probably not really helpful. So maybe you could a) confirm if this issue is beeing worked on, and b) change the bug status to show what is actually going on (“Fix Released” is just not the case, so “In Progress” or “Triaged” might be better candidates).

This would help us being patient and not flood this bug with “me too” messages. Thanks!

David Barth (dbarth) wrote :

FYI, we have opened this master bug to track the remaining problems related to the overall stacking issues.

See https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/859405

We are considering that this particular bug was indeed fixed by the code changes in the current version of Compiz, as it is not systematically reproducible. However we acknowledge that there are still cases where this can happen, mostly becaiuse of the complexitiy and asynchronous nature of the WM protocol.

Id2ndR (id2ndr) wrote :

Sorry for my "me too" comment, but I've encountred the trouble right now and I don't know exactly what where the condition to repport a new bug. I'd like to know if there is a way to get some "debug informations" it after it occurs if compiz wasn't started with "--debug" or things like that. Any idea ?

Hossein Atashi (atashi.h) wrote :

I don't know exactly what changed, but I haven't had this problem in the past few days (I used to have it 4-5 times a day in the first 3 days of the release). I don't know whether it was an update to Compiz, Unity or what, but it seems to have been resolved for me now.

Mario Vukelic (mario-vukelic) wrote :

Same for me like for Hossein in the previous comment, it seems to have disappeared.

Rob Speer (rspeer) wrote :

I just got the bug shortly after upgrading to Oneiric. I've run Chrome, Decibel, and a few terminal windows since logging in. The application launcher, icon context menus, and even the alt-tab switcher appear behind all active windows. If I type "unity& disown" it fixes it.

I see there are software updates available (which I'm installing now), but none to unity, so it appears to me that this bug is not in fact fixed in the current version.

If this is relevant, I have changed my settings so that maximized windows do not hide the dock.

Coert van Gemeren (0-cj) wrote :

Still affected by this, also unity/compiz/gtk-window-decorator seems to crash at random ('unity &> /dev/null & disown' fixes stuff... but I believe I ended up with the bug described here then). Everything's upgraded to latest packages.
dmesg output:
[57186.414368] gtk-window-deco[12531]: segfault at 118 ip 000000000040fc50 sp 00007fffe7276bb0 error 4 in gtk-window-decorator[400000+1c000]
[58080.808870] compiz[13398] general protection ip:7f1ab4dcac1d sp:7fffaf573670 error:0 in libunityshell.so[7f1ab4c6b000+225000]
[58093.878274] compiz[20080]: segfault at 688 ip 00007f43feb2fc30 sp 00007ffff7b774a0 error 4 in libunityshell.so[7f43fe990000+225000]
[58114.100402] ccsm[20060]: segfault at 18 ip 00007f3ace82c1c7 sp 00007fff5ca4a6a0 error 6 in libcompizconfig.so.0.0.0[7f3ace808000+42000]
[58270.644255] compiz[20923]: segfault at 58 ip 00007f4b846486d1 sp 00007fffe3a07a98 error 4 in libnvidia-glcore.so.280.13[7f4b8359a000+15f4000]

Coert van Gemeren (0-cj) wrote :

More info restarting unity in verbose (unity 4.24.0) on a nvidia twinview setup:
....
compiz (core) - Debug: received event:
compiz (core) - Debug: - event serial: 12303
compiz (core) - Debug: - event window 0x3200201
compiz (core) - Debug: - x: 0 y: 24 width: 66 height: 1026 border: 0, sibling: 0x0
compiz (stackdebugger) - Warn: 0x1200005 requested invalid layer 0x7ffffff
compiz (core) - Debug: windows are stacked incorrectly
WARN 2011-10-27 16:34:48 unity.glib.dbusproxy GLibDBusProxy.cpp:255 Cannot call method InfoRequest proxy /com/canonical/unity/lens/commands does not exist
WARN 2011-10-27 16:34:48 unity.glib.dbusproxy GLibDBusProxy.cpp:255 Cannot call method SetActive proxy /com/canonical/unity/lens/commands does not exist
WARN 2011-10-27 16:34:48 unity.glib.dbusproxy GLibDBusProxy.cpp:255 Cannot call method InfoRequest proxy /com/canonical/unity/lens/music does not exist
WARN 2011-10-27 16:34:48 unity.glib.dbusproxy GLibDBusProxy.cpp:255 Cannot call method SetActive proxy /com/canonical/unity/lens/music does not exist
WARN 2011-10-27 16:34:48 unity.glib.dbusproxy GLibDBusProxy.cpp:255 Cannot call method InfoRequest proxy /com/canonical/unity/lens/applications does not exist
WARN 2011-10-27 16:34:48 unity.glib.dbusproxy GLibDBusProxy.cpp:255 Cannot call method SetActive proxy /com/canonical/unity/lens/applications does not exist
WARN 2011-10-27 16:34:48 unity.glib.dbusproxy GLibDBusProxy.cpp:255 Cannot call method InfoRequest proxy /com/canonical/unity/lens/files does not exist
WARN 2011-10-27 16:34:48 unity.glib.dbusproxy GLibDBusProxy.cpp:255 Cannot call method SetActive proxy /com/canonical/unity/lens/files does not exist
WARN 2011-10-27 16:34:50 unity.iconloader IconLoader.cpp:509 Unable to load contents of file:///usr/share/icons/unity-icon-theme/places/svg/category-installed.svg: Error opening file: No such file or directory
WARN 2011-10-27 16:34:50 unity.iconloader IconLoader.cpp:509 Unable to load contents of file:///usr/share/icons/unity-icon-theme/places/svg/category-available.svg: Error opening file: No such file or directory

hope this is of use to someone...

Coert van Gemeren (0-cj) wrote :

ha! more stuff from unity ... it's actually telling me file this now :P

compiz (core) - Debug: received event:
compiz (core) - Debug: - event serial: 102659
compiz (core) - Debug: - event window 0x5e002d8
compiz (core) - Debug: - x: 1680 y: 24 width: 1280 height: 1000 border: 76369320, sibling: 0x5e00099
compiz (stackdebugger) - Warn: 0x1200005 requested invalid layer 0x7ffffff
compiz (core) - Debug: windows are stacked incorrectly
compiz (core) - Warn: unhandled ConfigureNotify on 0x5e002d8!
compiz (core) - Warn: this should never happen. you should probably file a bug about this.

Shock (mmiron) wrote :

Just another "me too". Here's my package versions:

$ dpkg -l unity\* compiz\* | egrep '^ii.*'
ii compiz 1:0.9.6+bzr20110929-0ubuntu5 OpenGL window and compositing manager
ii compiz-core 1:0.9.6+bzr20110929-0ubuntu5 OpenGL window and compositing manager
ii compiz-gnome 1:0.9.6+bzr20110929-0ubuntu5 OpenGL window and compositing manager - GNOME window decorator
ii compiz-plugins 1:0.9.6+bzr20110929-0ubuntu5 OpenGL window and compositing manager - plugins
ii compiz-plugins-default 1:0.9.6+bzr20110929-0ubuntu5 OpenGL window and compositing manager - default plugins
ii compiz-plugins-main 1:0.9.6-0ubuntu4 Compiz plugins - main collection
ii compiz-plugins-main-default 1:0.9.6-0ubuntu4 Compiz plugins - main default collection
ii compizconfig-backend-gconf 0.9.5.92-0ubuntu2 Compiz Fusion configuration system - gconf backend
ii compizconfig-settings-manager 0.9.5.92-0ubuntu1 Compiz configuration settings manager
ii unity 4.24.0-0ubuntu2b1 Interface designed for efficiency of space and interaction.
ii unity-2d 4.12.0-0ubuntu1 Unity interface for non-accelerated graphics cards
ii unity-2d-launcher 4.12.0-0ubuntu1 Unity 2D Launcher
ii unity-2d-panel 4.12.0-0ubuntu1 Unity 2D Panel
ii unity-2d-places 4.12.0-0ubuntu1 Unity 2D Places
ii unity-2d-spread 4.12.0-0ubuntu1 Unity 2D Spread
ii unity-asset-pool 0.8.22-0ubuntu1 Unity Assets Pool
ii unity-common 4.24.0-0ubuntu2b1 Common files for the Unity interface.
ii unity-greeter 0.1.1-0ubuntu1 Unity Greeter
ii unity-lens-applications 0.4.12-0ubuntu2 Application lens for unity
ii unity-lens-files 0.6.12-0ubuntu1 File lens for unity
ii unity-lens-music 0.2.6-0ubuntu2 Music lens for unity
ii unity-scope-musicstores 0.2.6-0ubuntu2 Store music lens for unity
ii unity-services 4.24.0-0ubuntu2b1 Services for the Unity interface

david6 (andrew-dowden) wrote :

Unknown what causes this, appears to occur randomly. Not associated with Wine.

david6 (andrew-dowden) wrote :
Jay S (topdownjimmy) wrote :

Attaching output from `compiz --debug --replace ccp`

I can confirm that this bug is NOT fixed.

I get this issue constantly with all updates applied as of today:
(1) Start a new desktop session
(2) Open a full-screen Thunderbird on workspace 4
After doing those steps there is about 50% that Unity renders it's windows below all other windows.

Also, it not only affects the launcher, but also the dash/lenses and the task switcher (ALT-Tab). If those get constantly rendered below all other windows it renders Unity unusable.

description: updated
Mickey (roaddogmm) wrote :

I see this bug on my Dell Dimension 9100 desktop.

the bug is different than the recent screenshot. In my case, the only indication that dash is launched somewhere is the max/min/close icons in the panel area

For me, it is unrelated to going full screen in applications. It happens immediately at startup, even with no other applications open. It seems to be stacking behind the desktop. The problem is not intermittent, it never goes away.

Also, this bug occurs with an updated install, or even when running from the ubuntu 11.10 live cd. the unity &disown command others mention has no affect on it.

Dylan McCall (dylanmccall) wrote :

For me, too, this happens immediately, absolutely every time I log in to a Unity 3D session in Ubuntu 11.10. Really, it's like this: “Log in to Unity. Open any application from the launcher. (Try to) open the dash.” With that process, the dash in the third step reliably appears beneath any toplevel window.

Here are a few details of my setup. I hope they can help a little to find the source of the remaining problems:
 * I have an ATI Radeon 6870 GPU. I am using the free driver that comes by default in Ubuntu, not fglrx.
 * Since I usually run Gnome Shell, I also usually have the Adwaita theme enabled. I haven't noticed this affecting things, but who knows?
 * I have removed appmenu-*, so the global menu feature is disabled in Unity on my system.
 * I have turned off Nautilus managing my desktop.

If I have any open windows and then run unity --reset in the terminal, when Unity comes back up the dash _will_ properly appear over open windows. If I run unity --reset with all windows either minimized or closed (nothing open) then Unity will behave as when I log in fresh: the dash will appear beneath open windows.

In the first case, with the dash behaving properly, if I proceed to _close_ every open window, then open another window, Unity's dash will appear beneath that window again.

Dylan McCall (dylanmccall) wrote :

Okay, the trigger here is disabling Nautilus managing the desktop. If you head to gnome-tweak-tool and turn on “Have file manager handle the desktop,” the problem should go away. (In place of a new problem, of course, but we're getting somewhere).

This does seem to line up with the behaviour I noted above, with Nautilus being that one open window that keeps the dash from breaking. As well as the setting in gnome-tweak-tool, Nautilus crashing (or being force killed) triggers this. And I'd bet there's a race condition at login, too.

This might prove enlightening:
With Nautilus handling the desktop, if I close all open windows, then force kill Nautilus, then open another application that is not Nautilus, the dash will appear beneath that window. (As before).
If I then open Nautilus (which automatically starts handling the desktop again) the dash will begin to appear on top of open windows.

You can reproduce this absolutely reliably, on any computer, by opening gnome-tweak-tool, turning off “file manager handles the desktop,” and logging in again.

Hopefully that makes it a little clearer what's going on here :)

Would you like me to open a new bug report, or are these indeed the same problems?

This bug just happened on my Ubuntu 11.10
Unity dockbar hiding behind other application windows
The Alt+Tab bar also hiding behind other application windows

apogee@apogee-desktop:~$ uname -a
Linux apogee-desktop 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux

apogee@apogee-desktop:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric

In order to get out from this situation, I use this command:
$ unity& disown

then unity restarts and I can see it

ericc (eric-cheminot) wrote :

I'm also affected. To add on various configuration listed in this thread, I'm up to date and using fglrx 11.11. So far, it is the case after each boot and compiz --replace seems to work around this.

Sasa Stamenkovic (umpirsky) wrote :

This happens to me on every boot. It's really annoying. I have all latest updates installed.

Please check screens attached.

Col Hathi (colhathi) wrote :

I'm sure i was able to work around this issue by having compiz draw the wallpaper by checking the plugin box in ccsm. Fglrx and compiz couldn't seem to co-ordinate that well but when i got compiz to draw the wall paper, the unity lenses were always on top when i pressed the super button.

I have all the latest updates installed (I mean through update-manager) and I'm still seeing the issue. What does "fix released" mean then?

Joel Leclerc (lkjoel) wrote :

is this fixed in 4.26?

schaze (schaze) wrote :

Still getting this issue with the latest updates. This is really annoying. How hard can it be to have unity on top of all the windows!?

Although I have installed all available updates through Update-Manager, the problem still remains.

The attached screen-shots show 3 problems arising from this bug:

    1- Dash appears behind open windows
    2- Windows-switcher (Alt+Tab) appears behind open windows
    3- Launcher-icon tool-tips appear behind open-windows

Shadar (zxlmm) wrote :

I'm still having same issues, though fix have been released. Dash is hiding behind firefox. Staying on Unity-2d right now.

Roman Yepishev (rye) wrote :

I can reproduce this on Precise (unity 4.24.0-0ubuntu3) by having 1 gnome-terminal window open and launching gimp. Toolbar gimp window appears in front of dash. Later on dash and launcher move to background completely when called.
http://ubuntuone.com/7gpKE9gb3qwBz4LAsxGLFu

Roman Yepishev (rye) wrote :

seb128 asked me to file a separate bug - LP:912181 - looks like something becomes wrong when an application quits unexpectedly.

I had this problem repeatedly on Oneiric; couldn't see the trigger which caused it. However I appear to have found a solution following the suggestion above from Dylan McCall.

First, though a feature of my problem I didn't see noted above: when the launcher slides underneath the windows in the viewport, if they're not maximised, then clicking on the topmost overlying window, still launches the application from the launcher as if the launcher were the topmost window. Visually displayed at the back of the stack, but still at the front from the point of view of viewport events. (If an overlying window is maximised, then clicking on over the area where the launcher should be doesn't produce this effect.)

I noticed Dylan's comments about nautilus. I checked gnome-tweak and found I had "have file manager handle the desktop" turned off. However, rather than turn it on, I fired up gconf-editor and I found that "show desktop" and "show desktop as home" in the nautilus preferences were still enabled (the things you used to tweak to get nautilus to draw the desktop, and enable right-click on desktop). I disabled both - useless now as they don't bring the right-click on the desktop back - and since then I haven't seen the problem. With this, even killall nautilus doesn't precipitate the problem anymore and the launcher is well behaved.

Perhaps it's possible to arrive at incompatible gconf options at this point in the transition to Unity? I guess this shouldn't produce the effects above still, but I'm just happy to have a solution. Thanks Dylan! Anyone else experienced similar?

Efrain Valles (effie-jayx) wrote :

This issue has reappeared in Ubuntu 12.10 Quantal

Omer Akram (om26er) wrote :

for 12.10 see bug 906231

Sidarth Dasari (sirsid) wrote :

I can confirm this bug has reappeared in 12.10 on two of my systems

aleandro (aleandrodasilva) wrote :

12.10 bug still present. I did noticed that cause I had an open window between the dash and the desktop area. I saw indeed that the window covers the dash.

Bachi (m-bachmann) wrote :

Confirmed, still happens in 12.10. 64bit, fresh install.

Sam Spilsbury (smspillaz) wrote :
Download full text (4.6 KiB)

On Thu, Jan 17, 2013 at 11:23 PM, Bachi <email address hidden> wrote:
> Confirmed, still happens in 12.10. 64bit, fresh install.

I have a work in progress branch which should fix another category of
these bugs, but I am waiting on the release managers to release
0.9.9.0 before moving forward with it.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/805087
>
> Title:
> Dash and launcher appear underneath windows
>
> Status in Unity:
> Fix Released
> Status in “unity” package in Ubuntu:
> Fix Released
> Status in “unity” source package in Oneiric:
> Fix Released
>
> Bug description:
> main problem:
> unity launcher and dash always hidden (behind displayed application-windows)
>
> more details and symptoms:
> docky behaves like unity-launcher/dash.
> press "super" button and type "terminal+enter" (nothing displayed) ... a terminal-window starts/pop-up
>
> conclusion:
> the "input-stack/focus" is o.k.
> the "windows-display-stack/focus" is wrong
>
> more symptoms:
> After docky-stop and docky-start (restart) the docky-bar shows as "top-level-window" => o.k.
> This is reproducable with firefox windows by moving/maximise/move to desktop XY.
> Sometimes other windows (like terminal-window/google-chrome-window) are hiding the launcher/dash/docky too.
> This problem is reproducable on a T60p with ATI-FireGL video-card.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity 3.8.16-0ubuntu1~natty1
> ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
> Uname: Linux 2.6.38-10-generic x86_64
> Architecture: amd64
> CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
> CompositorRunning: compiz
> Date: Sun Jul 3 13:58:33 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> DkmsStatus:
> tp-smapi, 0.40, 2.6.38-10-generic, x86_64: installed
> tp-smapi, 0.40, 2.6.38-8-generic, x86_64: installed
> GraphicsCard:
> Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
> Subsystem: Lenovo Device [17aa:21d1]
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
> InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
> InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
> MachineType: LENOVO 428449G
> ProcEnviron:
> LANGUAGE=de_DE:en
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic root=UUID=be0937c9-8117-4833-a50b-1b5c391c9b69 ro quiet splash i915.semaphores=1 vt.handoff=7
> ProcVersionSignature_: Ubuntu 2.6.38-10.46-generic 2.6.38.7
> ProcVersionSignature__: Ubuntu 2.6.38-10.46-generic 2.6.38.7
> Renderer: Unknown
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
> XorgConf:
> Se...

Read more...

Ulrik Høyer Kold (ulrikkold) wrote :

I confirm the bug is still present in 12.10, too. But I found a workaround.

Alt+F2 and run the command 'unity --replace' - this works for me at least.

mdo (manfred-dohmen) wrote :

I was hit by this bug today after doing a full-upgrade for the first time since 2013-03-15 for 12.10 64bit. There was no compiz update involved but there were some Gnome and Unity packages.

ulrikkold's workaround brings the Dash back on top.

Colin Law (colin-law) wrote :

I am seeing this on Raring occasionally, but is there any point adding to this bug, which is marked fixed. Should we be using a new bug, such as #1161291 ?

Michael Tanner (thonixx) wrote :

I think it would be better to use bug https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1161291 since this one is marked as fixed and the other one is confirmed but unfixed.
It happens in Raring too but more seldom than before. I still don't know how to reproduce, it still happens randomly.

Izidor Matušov (izidor) wrote :

Do you have some application to start immediately after you log in? I noticed that sometimes it does it because of loading Anki on startup.

Sridhar Dhanapalan (sridhar) wrote :

Still happening for me on Ubuntu 13.10 amd64.

Tommy_CZ (t-kijas) wrote :

Occured in 14.04 MacbookAir

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers