Ubuntu

ubiquity crashed with InstallStepError in configure_user()

Reported by keithlm on 2008-08-16
604
This bug affects 71 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Andrea Maio
Nominated for Intrepid by digitalice
Nominated for Jaunty by digitalice

Bug Description

Binary package hint: ubiquity

Installing 8.10 official release trying to keep my home configuration. So I did one partition for boot, other for system and other for home plus to for windows (win vista + win vista recovery). Happen the same with ubuntu 9.04 official release

keithlm (keithlm003) wrote :
Colin Watson (cjwatson) wrote :

Here's the immediate cause:

Aug 16 17:15:22 ubuntu klogd: [ 687.145269] bash[29391] general protection ip:462920 sp:7fffcf3b0d28 error:0 in bash[400000+c2000]
Aug 16 17:15:23 ubuntu user-setup: Segmentation fault (core dumped)

I think the only real way that can happen in this context is if there's been a problem reading from the CD. This is generally due to a faulty CD/DVD disk or drive, rather than being an installer bug as such. It may help to clean the CD/DVD, to burn the CD/DVD at a lower speed, or to clean the CD/DVD drive lens (cleaning kits are often available from electronics suppliers).

There's also a chance that it may be something wrong with your hard disk (though I don't see a definite sign of that), in which case moving it to a cooler environment or replacing it might help.

Changed in ubiquity:
status: New → Invalid
meatychunks (dan-meatychunks) wrote :

Also having this problem during an install of mythbuntu 8.04.1 alpha 6. Installing onto a clean hard drive. I'd also experienced the same issue installing from the 8.04.1 release.

Tim (willc0de4food) wrote :

I've had this problem probably 5 times now. I reburned the disk and redownloaded the iso and the problem still occurs. The system finished installing once, but didn't install the bootloader and I was incapable of installing the bootloader from the disk.

Tim (willc0de4food) wrote :

I forgot to mention that I've been trying to install from the ubuntu beta iso that's currently available for download.

Tim (willc0de4food) wrote :

After making one modification the install was a complete success. Originally I was trying to have /dev/sda5 be my root partition and /dev/sda6 be my /home partition. The home partition contained my user folder from my 8.04.1 installation. I wondered if this was causing the error, so I simply told ubuntu to use /dev/sda5 for root without specifying any other partitions to have any other function (so everything is on that partition) and the install went fine.

Andrew Hamblin (lextori) wrote :

I'm having the same issue, it seems to be caused by my previous home directory files. I do find it kinda ridiculous that I can't upgrade and keep my home partition. Isn't that the point of the home partition.

Tim (willc0de4food) wrote :

Yes, it would be nice to be able to do an upgrade installation while maintaining the home partition.

Mats Taraldsvik (meastp) wrote :

Yeah, I agree with Tim.

A dialog that tells you this is probably related to your home directory, would be nice.

In my case, I had renamed my /home/username to /home/usernamebak, to backup my settings, and start afresh with Intrepid. However, I also did mkdir /home/username, which triggered this bug. A silly mistake by me. Still, a dialog pointing me in the right direction would be nice.

digitalice (snipedhead) wrote :

same problem ...
got amd64 X2 and the installer crashes while creating user :( ...
y tryed manual and automatic install and the problem persists ...

regards,
digitalice

digitalice (snipedhead) wrote :

forget: im doing fresh install

digitalice (snipedhead) wrote :

Users cannot install ubuntu!

Changed in ubiquity:
status: Invalid → Confirmed
digitalice (snipedhead) wrote :

Aug 16 17:15:24 ubuntu ubiquity[8310]: Exception in GTK frontend (invoking crash handler):
Aug 16 17:15:24 ubuntu ubiquity[8310]: Traceback (most recent call last):
Aug 16 17:15:24 ubuntu ubiquity[8310]: File "/usr/lib/ubiquity/bin/ubiquity", line 229, in <module>
Aug 16 17:15:24 ubuntu ubiquity[8310]: main()
Aug 16 17:15:24 ubuntu ubiquity[8310]: File "/usr/lib/ubiquity/bin/ubiquity", line 224, in main
Aug 16 17:15:24 ubuntu ubiquity[8310]: install(args[0])
Aug 16 17:15:24 ubuntu ubiquity[8310]: File "/usr/lib/ubiquity/bin/ubiquity", line 68, in install
Aug 16 17:15:24 ubuntu ubiquity[8310]: ret = wizard.run()
Aug 16 17:15:24 ubuntu ubiquity[8310]: File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 429, in run
Aug 16 17:15:24 ubuntu ubiquity[8310]: self.progress_loop()
Aug 16 17:15:24 ubuntu ubiquity[8310]: File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 808, in progress_loop
Aug 16 17:15:24 ubuntu ubiquity[8310]: (ret, realtb))
Aug 16 17:15:24 ubuntu ubiquity[8310]: RuntimeError: Install failed with exit code 1
Aug 16 17:15:24 ubuntu ubiquity[8310]: Traceback (most recent call last):
Aug 16 17:15:24 ubuntu ubiquity[8310]: File "/usr/share/ubiquity/install.py", line 1977, in <module>
Aug 16 17:15:24 ubuntu ubiquity[8310]: install.run()
Aug 16 17:15:24 ubuntu ubiquity[8310]: File "/usr/share/ubiquity/install.py", line 366, in run
Aug 16 17:15:24 ubuntu ubiquity[8310]: self.configure_user()
Aug 16 17:15:24 ubuntu ubiquity[8310]: File "/usr/share/ubiquity/install.py", line 1164, in configure_user
Aug 16 17:15:24 ubuntu ubiquity[8310]: raise InstallStepError("UserSetupApply failed with code %d" % ret)
Aug 16 17:15:24 ubuntu ubiquity[8310]: InstallStepError: UserSetupApply failed with code 1

always crashes there: "/usr/share/ubiquity/install.py", line 1164

I have same bug, it's not fun...

I'll try with the text installer...

I solved it. I tried to install OS with ,ounting some additional partitions,
one ntfs partition and two ext3 partitions, and I wanted to mount one of the
ext3 partitions as /home/. Then I installed without mounting them. Dunno
what the problem was =)

2009/1/2, popi31 <email address hidden>:
>
> I have same bug, it's not fun...
>
> I'll try with the text installer...
>
> ** Attachment added: "_usr_lib_ubiquity_bin_ubiquity.0.crash"
>
> http://launchpadlibrarian.net/20867341/_usr_lib_ubiquity_bin_ubiquity.0.crash
>
> --
> ubiquity crashed with InstallStepError in configure_user()
> https://bugs.launchpad.net/bugs/258603
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "ubiquity" source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: ubiquity
>
> installing 8.10 alpha 4 from AMD desktop CD to a secondary hard disk. I do
> have 8.04.1 on another the first and also boot disk. (But this doesn't seem
> to be a boot loader issue... it seems to be the user/password.)
>
> NOTE:
>
> Tried using the same username used on the primary 8.4.01 partition so I
> thought that might be a problem.
>
> So I ran it again using a different username just to make sure that was not
> the problem and the same problem happened in the same place.
>
> ProblemType: Crash
> Architecture: amd64
> DistroRelease: Ubuntu 8.10
> ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
> InterpreterPath: /usr/bin/python2.5
> Package: ubiquity 1.9.9
> ProcAttrCurrent: unconfined
> ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
> ProcEnviron: Error: [Errno 13] Permission denied: '/proc/8310/environ'
> PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
> SourcePackage: ubiquity
> Title: ubiquity crashed with InstallStepError in configure_user()
> Uname: Linux 2.6.26-5-generic x86_64
> UserGroups:
>

--
С уважением, Иван.

Hooya (tjbassoon) wrote :

Just confirming this bug. I'm actually doing it in an 8.04.2 install. But the problem was existent with 8.10 as well. Attempting to use my /home partition as that mount point through the Ubiquity wizard crashes the installer when attempting to create a user.

Did you solve the problem? I installed without mounting /home, but now I
really have a problem 'cause I need to remount /home any time I reboot.
Dunno why, but system doesn't mount ext3 partitions (excepting /) to mount
points I want them to. Tried to feed UUIDs and full paths as /dev/sdb1 to
/etc/fstab, nothing changes. Maybe I'm a damned lamer, lol.

Sorry for bad english.

2009/1/25 Hooya <email address hidden>

> Just confirming this bug. I'm actually doing it in an 8.04.2 install.
> But the problem was existent with 8.10 as well. Attempting to use my
> /home partition as that mount point through the Ubiquity wizard crashes
> the installer when attempting to create a user.
>
> --
> ubiquity crashed with InstallStepError in configure_user()
> https://bugs.launchpad.net/bugs/258603
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "ubiquity" source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: ubiquity
>
> installing 8.10 alpha 4 from AMD desktop CD to a secondary hard disk. I do
> have 8.04.1 on another the first and also boot disk. (But this doesn't seem
> to be a boot loader issue... it seems to be the user/password.)
>
> NOTE:
>
> Tried using the same username used on the primary 8.4.01 partition so I
> thought that might be a problem.
>
> So I ran it again using a different username just to make sure that was not
> the problem and the same problem happened in the same place.
>
> ProblemType: Crash
> Architecture: amd64
> DistroRelease: Ubuntu 8.10
> ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
> InterpreterPath: /usr/bin/python2.5
> Package: ubiquity 1.9.9
> ProcAttrCurrent: unconfined
> ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
> ProcEnviron: Error: [Errno 13] Permission denied: '/proc/8310/environ'
> PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
> SourcePackage: ubiquity
> Title: ubiquity crashed with InstallStepError in configure_user()
> Uname: Linux 2.6.26-5-generic x86_64
> UserGroups:
>

--
С уважением, Иван.

i've the problem with jaunty 9.04. sda2 on "/" as ext4 and sda4 as "/home" with xfs. but i don't know if that's the cause, but seems similar to other reports above.

update to my above comment: selecting just sda2 on "/" and no "/home" and the installation worked.

and in case somebody else has this problem:
I just had to fiddle around in the /etc/fstab to get my /home on first startup (I did this immediately in recovery as root) and changing the ownership of all my files to the one of my first user (i.e. 1000) using "chown -R 1000:1000 /home/<username>"

Sense Egbert Hofstede (sense) wrote :

I had the same crash. It could be caused by the homedirectory, which I copied, was owned by a different userid, but the same user.

Marstein (clmar) wrote :

I had done exactly the same as Sense Hofstede.

description: updated
akasico1 (akasico1-gmail) wrote :

The problem is not from cd I test it 8 times, from different original ubuntu , I localizate a problem with ubuquity in home directory

I reinstalled same cd same version, same user and same password. If home exist (even in different partition will give a problem) the only option is to format everything, and later copy the home if you want to have the same configuration. but you need to format or you will have a ubuquity problem. This happend with differents Ubuntu x86 version including the official last release 9.04

There is another problem is possible to keep same home configuration in the same version, but when you do an upgrade you can have problem with the home configuration when this is in other partition.

Another thing ext4 is not working properly in ubuntu 9.04 giving some errors storing passwords and some data missing I do not recomended
<email address hidden>
www.linux-sur.org

nucleuskore (doctorjohn2) wrote :

Had same problems as above. Had old /home mounted on the FS tree, apparently Jaunty does not like that :)
Am trying formatting /home and installing.

nucleuskore (doctorjohn2) wrote :

Successfully installed Ubuntu 9.04 !

Now let me elaborate. The first problem I was facing is ubiquity crashing while copying files during install. It told me that my cd or hard disk was probably bad. I knew my cd was ok as I had verified my data, as for my drive it's a brand new sony, only two days old.

So I booted Ubuntu live and made a USB start up disk. I then got past the file copy stage, and ubiquity crashed on creating new user. I realised that this probably was because of my old /home directory after reading the above posts. I then proceeded to start the install again making the /home too for formatting, along with /. Two ntfs partitions were also mounted on partitioning. Install went through like a breeze. I'll have to restore my home files form my external hard disk that's all.

bug still happens... i'm trying to reinstall and keep my home folder and it crashes if i try to use the same username as my old install. Using a different username fixes it.

I have tried to re-install several times. Even re-formatting / partition.
not only does ubiquity crash, it screws up GRUB somehow
Grub says it cannot find the map file and one other similarly named file (suffer from crs)
Using Live CD I searched the disc and could not find either file.
 I hate to say this but this is reminding me too much of windows,
Do not get me wrong, I am sold on Ubuntu and would rather lose my left nut than have to go back to windows on a regular basis :)
I certainly hope you folk find the cure.... well back to the salt mines and try to get 8.10 to re-istall

Guerin (dguer133) wrote :

Désolé mais je ne parle pas anglais ...
J'ai mis un post ici: http://forum.ubuntu-fr.org/viewtopic.php?pid=3032698#p3032698
Depuis l'upgrade d'Ubuntu vers la version 9.10 je rencontre des soucis avec Warzone.

J'ai suivi le lien qui mène aux dépendances.
S'il s'agit des éléments indispensables au bon fonctionnement du logiciel alors il m'en manque:

cryptsetup (version 2:1.0.6+20090405.svn49-1ubuntu7) sera installé
ecryptfs-utils (version 81-0ubuntu3) sera installé
keyutils (version 1.2-10) sera installé
libdebconfclient0 (version 0.145) sera installé
libdebian-installer4 (version 0.63ubuntu2) sera installé
libecryptfs0 (version 81-0ubuntu3) sera installé
libntfs10 (version 2.0.0-1ubuntu3) sera installé
lzma-alone (version 4.43-14ubuntu1) sera installé
ntfsprogs (version 2.0.0-1ubuntu3) sera installé
python-pyicu (version 0.8.1-3ubuntu2) sera installé
rdate (version 1:1.2-1) sera installé
ubiquity-casper (version 1.206) sera installé

Dois-je installer tout ça SVP ?

Guerin (dguer133) wrote :

I attracted these installations but result is always so discouraging.
What must I make S.V.P .?
Excuse the quality of translation but I used IMTRANSLATOR.

In french:

J'ai tenté ces installations mais le résultat est toujours aussi décevant.
Que dois-je faire S.V.P. ?
Excusez la qualité de la traduction mais j'ai utilisé IMTRANSLATOR.

Sense Egbert Hofstede (sense) wrote :

It seems Guerin has got problems with Warzone, which can't fulfil its dependencies. I'm asking him to ask someone to file a separate bug report.

Excusé moi ma Français, s'il vous plaît.
Si vous ne pouvez pas installer Warzone, il est une erreur de Warzone et je voudrais vous demander de déposer un rapport différent. Mais parce que vous avez dit que vous ne parlez pas Anglais, je suggère que vous demande à quelqu'un de Ubuntu-FR pour écrire le rapport.

tags: added: bugpattern-needed
jack (n8ivearchangel) on 2010-08-04
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → In Progress
Vish (vish) wrote :

Seems to be an accidental status change by jack , reverting back to confirmed

Changed in ubiquity (Ubuntu):
status: In Progress → Confirmed
Changed in ubiquity (Ubuntu):
assignee: nobody → Andrea Maio (andrea-maio)
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.