Language packages are not installed properly

Bug #1514938 reported by Jung-Kyu Park on 2015-11-10
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
ubiquity (Ubuntu)
High
Unassigned

Bug Description

In Ubuntu 16.04 Unity
language support (language-selector-gnome) doesn't contain language Korean(한국어)
thus, it makes wrong language settings
please, see the screenshot

it can be solved simply add language Korean(한국어) from the language support
if then, all other allocated packages will be installed automatically
and also, we don't use Spanish(스페인어) and Chinese(중국어) by default
There should be Korean(한국어) and English(영어) by default in language support

it begins from the ubiquity to installed OS

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: language-selector-gnome 0.152
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
ApportVersion: 2.19.2-0ubuntu5
Architecture: amd64
CasperVersion: 1.365
CurrentDesktop: Unity
Date: Tue Nov 10 18:00:58 2015
LiveMediaBuild: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151110)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=ko_KR.UTF-8
 SHELL=/bin/bash
SourcePackage: language-selector
UpgradeStatus: No upgrade log present (probably fresh install)

Jung-Kyu Park (bagjunggyu) wrote :
Jung-Kyu Park (bagjunggyu) wrote :

The same issue has found in

Ubuntu 16.04 MATE
Xubuntu 16.04
Lubuntu 16.04

and also its solution is same as Unity , to remove other languages and add Korean(한국어) from language support.

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report. To be honest, it's not clear to me what the problem is. If Korean wasn't selected when installing the system, you can install it afterwards using language-selector-gnome. Korean is available on the updated 16.04 system which I'm currently using.

Or are you actually talking about ubiquity (the installer)?

Please try to clarify.

Changed in language-selector (Ubuntu):
status: New → Incomplete
Jung-Kyu Park (bagjunggyu) wrote :

Thank you for reviewing it quickly.
its symptom is too complicated but solution is simple
The solution is adding right language pack by their region and nations to language support.

in case of Korea , we need Korean not Chinese, Spanish, and lots of other languages.

1)
When selecting the language Korean in live mode
all the language in system should be displayed in Korean, but Xenial distributions show me English and Korean together.
and after installation ,from the first boot
the same issue accurs in system as you can see it in screenshot

2)
but, although fcitx-hangul was not installed by default in OS
fcitx config tool shows Hangul(한글)

3)
we don't use Spanish, Chinese, and other lots of other Nations language
but Xenial's distribution has a lot of other nations language by default ,and even Korean(한국어)was not installed by default.
so, To operate Xenial Xerus in Korean,
we need to remove all the other nations languages except English(영어)
and should install Korean(한국어)

it happens from installation process to fresh installed state together.
Shortly to say,
* language pack of Korean was missed in language support
* Too many languages was installed in OS, Except English and Korean, we don't use other languages by default.

I assume this language issue would happens to other Asian Nations distribution too.

Jung-Kyu Park (bagjunggyu) wrote :

Add it to those OSes which affected this issue, I assume that Ubuntu GNOME has the same issue with it.
I leave this link for note.
https://bugs.launchpad.net/bugs/1514929

affects: language-selector (Ubuntu) → ubiquity (Ubuntu)
Jung-Kyu Park (bagjunggyu) wrote :

I would start it from the beginning, the live mode
* I started to install it from select language in live usb
* I chose Korean(한국어) -> live mode -> but all the languages were not a Korean , some of them are English
* but, ubiquity slide show worked good in Korean.
* after installation, it had the same issue with installation process

if the language was correctly selected for Asian/Seoul
it shoud have shown to me a Korean and input method fcitx-hangul
but,it didn't, and even more, Korean was missed and other nations languages were installed instead.

I don't know where to afftects so that I changed it to ubiquity where I met this issue first because of the above reason.

Tim Lunn (darkxst) wrote :

lindol, have you seen this?

LinDol (lindolsang) wrote :

Tim, I have not seen this yet.
because I have not installed 16.04 yet.

When you install its to your machine,
Did you connect internet for downloading language packs?

Sorry, if you are ok,
I will try to replicate this issue on this weekend.

summary: - The language Korean dropped from the language-selector-gnome in Ubuntu
- 16.04 Unity
+ Language packages are not installed properly
Jung-Kyu Park (bagjunggyu) wrote :

I have already installed and check this issue several times,
all the way through, internet connection was fully connected with ethernet,
and, It happens all the time
but, weird thing is sometimes language support shows properly Korean(한국어) and English though,
actually, There was no installed Korean language package (language-pack-ko and gnome-ko)

bagjunggyu@Xenial:~$ sudo dpkg -l | grep language-pack
[sudo] password for bagjunggyu:
ii language-pack-en 1:15.10+20151016 all translation updates for language English
ii language-pack-en-base 1:15.10+20151016 all translations for language English
ii language-pack-gnome-en 1:15.10+20151016 all GNOME translation updates for language English
ii language-pack-gnome-en-base 1:15.10+20151016 all GNOME translations for language English

anyhow, during this test , there was no proper installation,
It was always installed without Korean language packages.

There has been same issue happened in Ubuntu 15.10
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1475812

but it was resolved after tzsetup was corrected
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1462688

Does this daily build iso was build before release of Ubuntu 15.10?

Jung-Kyu Park (bagjunggyu) wrote :

I will install it one more time in "Try ubuntu without installation"
I would switch the server to the Main Server instead of default local server and will find out more about it.

Jung-Kyu Park (bagjunggyu) wrote :

Unfortunately, Nothing changed, but
After installation, I found that local server's Hash Sum mismatch

W:Failed to fetch http://kr.archive.ubuntu.com/ubuntu/dists/xenial/main/source/Sources Hash Sum mismatch
, W:Failed to fetch http://kr.archive.ubuntu.com/ubuntu/dists/xenial/universe/source/Sources Hash Sum mismatch
, W:Failed to fetch http://kr.archive.ubuntu.com/ubuntu/dists/xenial/main/binary-amd64/Packages Hash Sum mismatch
, W:Failed to fetch http://kr.archive.ubuntu.com/ubuntu/dists/xenial/universe/binary-amd64/Packages Hash Sum mismatch
, W:Failed to fetch http://kr.archive.ubuntu.com/ubuntu/dists/xenial/main/binary-i386/Packages Hash Sum mismatch
, W:Failed to fetch http://kr.archive.ubuntu.com/ubuntu/dists/xenial/universe/binary-i386/Packages Hash Sum mismatch
, E:Some index files failed to download. They have been ignored, or old ones used instead.

But I am still curious of it , I selected server manually as Main Server at Software & Updates before installation.
then it should be installed the correct language packs during installation process I guess, but it was not.
The language package, Is it restricted to the local server?
I hope not so.
Please, check it.

Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed
LinDol (lindolsang) wrote :

Hello, sorry for late my testing.
and I tried to replicate it,
but I can not replicate it,
because My test machine and Virtual box had some problem.

by the way,
When i Install Ubuntu GNOME 15.04, 15.10, some testing release version,
I has selected 'Install update package during installing' option on Installer with Installing 3rd party package option,

After finishing to install Ubuntu GNOME,
When i checked my machine,
all language pack was installed on my laptop.

If you are ok,
Could you check that options when you try to install again?
Thanks.
Juyeon Park (LinDol)

Jung-Kyu Park (bagjunggyu) wrote :

Ubuntu GNOME 15.10 is fine, even without that option, it is installed fine.
Actually, I use Ubuntu GNOME 15.10 as My Main OS now dual booting with Ubuntu 16.04 Development Branch.
The similar issue which accurred in Ubuntu 15.10 Distributions are resolved when tzsetup was corrected.
There is no issue in Ubuntu GNOME 15.10, but Ubuntu 16.04's distributions are not, include of Ubuntu GNOME 16.04.

This issue happens only in Ubuntu 16.04 distributions and I already have tested it pretty much over 10 times...
and it happens all the time.

I created installer usb with dcfldd command.

and, this is my system
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation C220 Series Chipset Family H81 Express LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

and OK
I will install and test it again

Jung-Kyu Park (bagjunggyu) wrote :

By the way,
It doesn't happen to Kubuntu 16.04
as far as I know, Kubutu uses different language packages with Ubuntu
Ubuntu uses language-pack-ko , language-pack-gnome-ko for Korean
but, kubuntu doesn't use it.
It might be a mean clue, I think.

Jung-Kyu Park (bagjunggyu) wrote :

Until now, I have tested Xenial's distribuions each of them one by one for twice time, daily build of 18-Nov-2015 08:07 iso
For Unity , GNOME, MATE, Xubuntu , Lubuntu

ko and en language packakges are installed properly at this time.

I think this issue is resolved but I am not sure if it is really resolved.
So, I hope to see and check this issue until alpha one released , December 31st.

Tim Lunn (darkxst) wrote :

Thanks for the comprehensive testing, I will close this bug. Feel free to re-open if you find the issue comes back.

Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
Jung-Kyu Park (bagjunggyu) wrote :

Thank you, I would check it out from time to time during development branch.

Jung-Kyu Park (bagjunggyu) wrote :

Hello, developers
Unfortunately, it happened again.
I installed 16.04 today, and it still doesn't show me a proper language
it still happens that system or ubiquity doesn't install locale language-package , for me, it was language-pack-ko
and it makes system shows English as default, but partially shows Korean even it is not installed language-pack-ko
I hope it to be fixed soon.

Changed in ubiquity (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → New
Jung-Kyu Park (bagjunggyu) wrote :

I assume that it is related to this local server's Hash Sum mismatch.
hash mismatch made the ubiquity couldn't download packages from the server.
from this results, system doesn't contain local language packaes like language-pack-ko , language-pack-gnome-ko
and it makes the system shows English as default

but I still don't understand this language-support, it shows Korean although it is not installed those language packages like language-pack-ko, language-pack-gnome-ko

Anyhow, I think so.

LinDol (lindolsang) wrote :

Hello Jung-Kyu Park.
I am juyeon Park.

I have tried to Install Ubuntu GNOME daily build (Ubuntu GNOME Desktop amd64 0/5 None None 20160119)
But when I have put Ubuntu GNOME daily build on My Virtual box.
Korean languages installed properly.

I have attached some screenshots during installing daily build.
Could you check my screenshot whether it is your reporting.

Thanks.
Juyeon Park.

Jung-Kyu Park (bagjunggyu) wrote :

Hello, juyeon Park.
I tried to install it by the same bootable USB Ubuntu 16.04 right after seeing your mention.
and this time it was installed properly.
and also there was no hash sum mismatch report in the terminal

Now I am sure that it was derived from the servers's Hash Sum mismatch.
And also,during installation process, I didn't check the third party software and others
I tried it as normal.

but, in this case, it may not be a bug of the ubiquity or system though,
we should remember which was happened, although it was not a local mirror server as I already mentioned before, it happened when I switched the server to the main server at the softwarte and update in the ubiquity though.

I don't know where to affect this report but we could probably meet this bug by the same reason in the future or soon by happens I guess.

Thanks.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers