ubi-timezone failed exit code 1 error when installing UbuntuStudio Wily-15.10 32bit version

Bug #1462688 reported by rue on 2015-06-06
128
This bug affects 30 people
Affects Status Importance Assigned to Milestone
tzsetup (Ubuntu)
High
Mathieu Trudel-Lapierre
Wily
High
Mathieu Trudel-Lapierre
ubiquity (Ubuntu)
Critical
Mathieu Trudel-Lapierre
Wily
Critical
Mathieu Trudel-Lapierre

Bug Description

When installing Ubuntu Studio 15.10 32 bit Version, it boots into live mode fine, when I go through the install process I select erase entire disk and click next then I get an error Saying ubi-timezone failed exit code 1.
I try re entry but still get this error. when I click cancel it crashes the installer
I have tested with a Live USB and A DVD version and redownloaded the iso image but still get the same error.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: ubiquity 2.21.27 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.19.0-20.20-lowlatency 3.19.8
Uname: Linux 3.19.0-20-lowlatency i686
ApportVersion: 2.17.3-0ubuntu4
Architecture: i386
CasperVersion: 1.361
Date: Sat Jun 6 21:45:16 2015
InstallCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntustudio.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash ---
LiveMediaBuild: Ubuntu-Studio 15.10 "Wily Werewolf" - Alpha i386 (20150605)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

rue (ruenoak) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Jackson Doak (noskcaj) wrote :

Found on ubuntu-gnome amd64 15.10 daily. Testing in KVM

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1462688

tags: added: iso-testing
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
Cliff Carson (ccarson1) wrote :

Had this error with the Wily Gnome 64bit daily build dated 7/30.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1462688

tags: added: package-qa-testing
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
amjjawad  (amjjawad) wrote :

Hi, this bug is still alive for Ubuntu GNOME Wily Werewolf (15.10) amd64 Beta 1 or 20150826.1 build.

Sean Davis (bluesabre) wrote :

Also affects Xubuntu Wily Werewolf Beta 1.

tags: added: xubuntu
Tim (darkxst) wrote :

This is mostly due to missing image file for the new North Korean Timezone

They were updated in gnome-control-center here:
https://git.gnome.org/browse/gnome-control-center/commit/?id=cc600a918b2a6c34ae81cf85ef7b49a8e3f02ee6

And need to be added to ubiquity also.

Changed in ubiquity (Ubuntu):
status: Triaged → In Progress

Doesn't seem to make Xubuntu or Ubuntu-GNOME crash anymore (tested here in live mode); I haven't tested Kubuntu yet which appears like it would be a little more affected...

We should still update the timezone files, but at least it's not crippling for the installer; so I'm reducing the priority to Medium.

Changed in ubiquity (Ubuntu):
importance: Critical → Medium
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.21.28

---------------
ubiquity (2.21.28) wily; urgency=medium

  [ Sean Davis ]
  * bin/ubiquity-dm: Draw the ubiquity desktop with feh under
    Xfce environments (LP: #1437180)

  [ Mathieu Trudel-Lapierre ]
  * Automatic update of included source packages: apt-setup
    1:0.80ubuntu8, base-installer 1.144ubuntu2, flash-kernel
    3.0~rc.4ubuntu55, hw-detect 1.95ubuntu7, partconf 1.48, partman-base
    187ubuntu1, partman-basicmethods 60, partman-jfs 46, partman-lvm
    110, partman-newworld 33, partman-xfs 56, user-setup 1.48ubuntu6.
  * Update timezone map to add North Korea (Pyongyang time). (LP: #1462688)
  * Fix instances of PEP8 warning: W503 line break before binary operator.
  * Ignore the PEP8 error E402 (imports at beginning of file). There are a few
    instances where we need to set sys.path to where ubiquity files are.
  * Fix some more style errors from PEP8.
  * autogen.sh: Use any available version of automake/aclocal.

  [ Luke Yelavich ]
  * ubiquity/frontend/gtk_ui.py: We do not want to be able to focus labels
    with Orca at all. It negatively affects the install experience and
    tab/shift tab flow through the installer pages, and prevents Orca
    presenting label relationships with other widgets

  [ Max Brustkern ]
  * Update the automated autopilot installation in the vm: get the updated
    sources.list picked up by hooks by being in the right location.

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 08 Sep 2015 10:58:17 -0400

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
Doug Smythies (dsmythies) wrote :

I am getting this error while trying to install Ubuntu desktop using the 64 bit daily of 2015.09.21.

Doug Smythies (dsmythies) wrote :

Given that there have now been 3 installation failures today, I'll set this back to critical and to not fixed.

Changed in ubiquity (Ubuntu):
status: Fix Released → Confirmed
importance: Medium → Critical
amjjawad  (amjjawad) wrote :

Apparently, this bug has been around even before Beta 1 for Wily Werewolf cycle.
I have done many tests and none of these has failed. All the installations were just fine. However, the only way for me to do that is to click "Continue anyway" and then a successful installation. I talked to Martin from Ubuntu MATE team and he was unable to produce it. I see here some people had failed installations. I am not sure why it is giving different results but all my tests were fine as long as I click on "Continue anyway" and nothing crashed at all - tests done in Oracle Virtualbox 5.0.2 not a real hardware.

I am testing Beta 2 now (Ubuntu GNOME) and this bug is still alive.

To me, it is not critical as of now as long as I can skip it. Just thought to share my experience with this bug so far :)

Thank you!

Changed in ubiquity (Ubuntu Wily):
status: Confirmed → In Progress
amjjawad  (amjjawad) wrote :

Hi, for those who are trying to help to fix this bug, I thought to copy-paste this information from IRC (#ubuntu-release channel):
------------
<cyphermox> amjjawad: ianorlin: if you manage to reproduce it, it would be great if you could add a traceback to the bug
<cyphermox> running ubiquity with --debug might help there.

<cyphermox> amjjawad: ianorlin: if you manage to reproduce, I'd be interested if you could modify ./usr/lib/ubiquity/tzsetup/post-base-installer to add a 'set -x' near the top and go back/forward again in the installer to get the crash to happen again (hopefully), then add syslog to the bug report
-----------

Also, I'll try to do the installation while the machine is OFFLINE. Let's see if that will change anything at all.

Hopefully we can manage to fix it before the final release :)

Thanks!

amjjawad  (amjjawad) wrote :

Hi again, this is an updated :)

I turned off the network connection and tried to install Ubuntu GNOME Wily Werewolf Beta 2 (amd64) on Oracle Virtualbox 5.0.2 and finally, the error message did not show up at all :)
Also, I got the world map to choose my timezone.

So, in short: if you turn off your connection (you're offline), you should not see that bug. It seems (not 100% sure yet) it is happening when Ubiquity is detecting the timezone based on the Internet connection of the machine that you're using to install the system.

I'll try to do more tests ;)

amjjawad  (amjjawad) wrote :

Hi, I did as request by cyphermox (IRC - #ubuntu-release) to run:

"ubiquity --debug"

but to my surprise, there was absolutely nothing whatsoever on the terminal when the error showed up.

---
Turing off the network connection before installing the system = Bug 1462688 will not show up.
Installing the system while the machine is connected to the Internet = bug 1462688 will show up and in order to carry on, you need to select "Continue anyway"

Installation is done successfully.
---

I don't think I have more time to try new things. I did my best to do some tests. Hope this information is helpful :)

SeijiSensei (ubuntuforums-2) wrote :

This bug persists in the current beta release of Kubuntu 15.10. I encountered it this morning.

Jung-Kyu Park (bagjunggyu) wrote :

I think it is strongly related to this wrong locale setting bug
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1475812

Looks like I thought I had commented here, but it never got registered:

What happens if you open http://geoip.ubuntu.com/lookup in a web browser, assuming you can reliably reproduce this every time you're trying to install with a network connection?

Please make sure to include as much information as possible from the result of that web page (an XML document), but I really don't need your IP address or lat/lon coordinates -- in other words, we don't need any really private information, it would just help to have one example of which country code / timezone instance as detected by the geoip server causes the crashes.

I have all the information I need now, looks like this is probably caused by "None" entries for the timezone.

Changed in tzsetup (Ubuntu Wily):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

Hello rue, or anyone else affected,

Accepted tzsetup into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/tzsetup/1:0.66ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in tzsetup (Ubuntu Wily):
status: In Progress → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzsetup - 1:0.66ubuntu2

---------------
tzsetup (1:0.66ubuntu2) wily; urgency=medium

  * Correctly handle None in detected TimeZone. (LP: #1462688)

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 01 Oct 2015 13:23:10 -0400

Changed in tzsetup (Ubuntu Wily):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.21.33

---------------
ubiquity (2.21.33) wily; urgency=medium

  * Automatic update of included source packages: tzsetup 1:0.66ubuntu2.
    (LP: #1462688)

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 01 Oct 2015 15:50:33 -0400

Changed in ubiquity (Ubuntu Wily):
status: In Progress → Fix Released
Jason Gerard DeRose (jderose) wrote :

confirmed that this bug is fixed in the latest daily 20151002 ISO (sha1sum 8c9228963e3884183a9ca8a712bb4aa6d66dd65f).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers