Ubuntu

Out-of-disk-space is not reported to the user when installing/updating packages fails

Reported by kjeremy on 2008-12-30
650
This bug affects 58 people
Affects Status Importance Assigned to Milestone
computer-janitor
New
Undecided
Unassigned
apt (Ubuntu)
Undecided
Unassigned
dpkg (Debian)
New
Unknown
synaptic (Ubuntu)
Undecided
Unassigned

Bug Description

when volume becomes full, no programs can be removed because updates and previous attempted installs try to reassert themselves, then the package handler closes itself.

ProblemType: Package
Architecture: i386
Dependencies:
 libgcc1 1:4.3.2-1ubuntu11
 gcc-4.3-base 4.3.2-1ubuntu11
 findutils 4.4.0-2ubuntu3
 libc6 2.8~20080505-0ubuntu7
DistroRelease: Ubuntu 8.10
ErrorMessage: failed in buffer_write(fd) (10, ret=-1): backend dpkg-deb during `./usr/lib/perl/5.10.0/IO.pm'
NonfreeKernelModules: nvidia
Package: perl-base 5.10.0-11.1ubuntu2
SourcePackage: perl
Title: package perl-base 5.10.0-11.1ubuntu2 failed to install/upgrade: failed in buffer_write(fd) (10, ret=-1): backend dpkg-deb during `./usr/lib/perl/5.10.0/IO.pm'
Uname: Linux 2.6.27-9-generic i686

kjeremy (kjeremy2002) wrote :
Colin Watson (cjwatson) wrote :

dpkg is behaving as promised here: that is, it's failing since the operation requested cannot be performed. It seems to me that it's the job of frontends to deal with this gracefully.

I'm reassigning this to apt, but the problem may in fact be higher up than that. Michael should be able to advise.

I just closed a bunch of bugs that show the exact same thing, the GUI installer does not show anything about the out-of-space-problem and therefore many bugs get reported to Ubuntu about a thing that is not a problem in the code at all.

See e.g. the following list of tickets closed invalid right now with the same explanation in each of them:
Bug #324149, Bug #326813, Bug #333147, Bug #336160, Bug #360879, Bug #361775, Bug #365364, Bug #365983, Bug #366530, Bug #370239, Bug #402250, Bug #473258, Bug #479924, Bug #320945, Bug #400457

I spent a few more minutes to wade through a list of similar bug reports and duplicated most of them to this one. This shows that this is a very common problem. The install/update of some package fails because of out of space, but the user does not know about it and is just presented the "package install failed" message which leads to many unnecessary bug reports.

I think the current list of duplicates warrants setting the importance for this bug to something like "high", can somebody with enough rights do this?

I also adjusted the title to show the intent of the bug a bit better.

summary: - Failure to update add/ or remove programs
+ Out-of-disk-space is not reported to the user when installing/updating
+ packages fails

Hi Dominik Stadler,

Thanks!! I partitioned my disk space and allocated 10 GB for the ubutu. I
believe,
i believe, i need to increase the space and re-install the software.

Thanks for your suggestion!!

Regards,
*Shanmuga sundaram M.K
*
On Sun, Nov 22, 2009 at 9:37 PM, Dominik Stadler <email address hidden>wrote:

> I spent a few more minutes to wade through a list of similar bug reports
> and duplicated most of them to this one. This shows that this is a very
> common problem. The install/update of some package fails because of out
> of space, but the user does not know about it and is just presented the
> "package install failed" message which leads to many unnecessary bug
> reports.
>
> I think the current list of duplicates warrants setting the importance
> for this bug to something like "high", can somebody with enough rights
> do this?
>
> I also adjusted the title to show the intent of the bug a bit better.
>
> ** Summary changed:
>
> - Failure to update add/ or remove programs
> + Out-of-disk-space is not reported to the user when installing/updating
> packages fails
>
> ** Also affects: synaptic (Ubuntu)
> Importance: Undecided
> Status: New
>
> --
> Out-of-disk-space is not reported to the user when installing/updating
> packages fails
> https://bugs.launchpad.net/bugs/312491
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “apt” package in Ubuntu: New
> Status in “synaptic” package in Ubuntu: New
>
> Bug description:
> when volume becomes full, no programs can be removed because updates and
> previous attempted installs try to reassert themselves, then the package
> handler closes itself.
>
> ProblemType: Package
> Architecture: i386
> Dependencies:
> libgcc1 1:4.3.2-1ubuntu11
> gcc-4.3-base 4.3.2-1ubuntu11
> findutils 4.4.0-2ubuntu3
> libc6 2.8~20080505-0ubuntu7
> DistroRelease: Ubuntu 8.10
> ErrorMessage: failed in buffer_write(fd) (10, ret=-1): backend dpkg-deb
> during `./usr/lib/perl/5.10.0/IO.pm'
> NonfreeKernelModules: nvidia
> Package: perl-base 5.10.0-11.1ubuntu2
> SourcePackage: perl
> Title: package perl-base 5.10.0-11.1ubuntu2 failed to install/upgrade:
> failed in buffer_write(fd) (10, ret=-1): backend dpkg-deb during
> `./usr/lib/perl/5.10.0/IO.pm'
> Uname: Linux 2.6.27-9-generic i686
>

A comment that I received via eMail:
synaptic should not even start the installation/update if not enough space is available. It normally says how much more space will be needed, and I had a little more free space than needed, but it was not enough, as the update itself required more space then it would occupy after completed update, I suppose.
two: old states of packages should always be kept as a fall-back in case update fails. Only if update completed successfully the old packages should be deleted, for only freeing space did not solve the problem for me. After I had run into too little free space, I was left with some broken packages I could not reinstall or uninstall.

damaine (damaine-one) on 2009-11-23
Changed in apt (Ubuntu):
status: New → Incomplete
status: Incomplete → Fix Released
sebastian-s (sebastian-s) wrote :

I've reported one of the duplicated. On upgrading the installer told me I had insufficient free space. Once I've provided more space via a folder mount the installer went along. Then later during the package installation I received the reported bug #289775

Tony T (tonytovar) wrote :

Why is this marked 'Fix Released' ? Was there an update to one of the components? Also, the fact that Update Manager sometimes reports insufficient disk-space beforehand is not the same thing as all these bug reports. The problem is that Update Manager will also report sufficient disk-space, start the install, then silently fail because -- despite it's initial estimation -- it still ran out of space.

Lulzim (lglulzim) on 2010-01-08
description: updated
Anzenketh (anzenketh) wrote :

Tony I agree with you there is a fix released for this but the core issue is not solved. I have been going though and a lot of bug reports. While the current patch for karmic install does lessen the impact of the issue the core issue is still not solved. Apt fails when there is low disk space. Dereck Wonnacott in bug 126774 had a good point on this issue though. It is a difficult problem to solve perhaps even impossible due to the nature lack of communication between the application wanting to install and apt. It would require a new flag set on all the .deb packages telling apt how much space on install it would require.

Perhaps a better way to solve this issue better is to have a applet watch the disk space and when it is less then say 1gb of free space(On some installs that may still not be enough so might be a good idea to make it adjustable) give a warning when the user logs in informing them to free up space removing unnecessary programs perhaps launch the computer janitor. I do not know if there is already a system in place that does this though due to I have not ever run out of space on a desktop install but have on a server install and had monitor programs watching that.

Anzenketh (anzenketh) on 2010-02-26
Changed in synaptic (Ubuntu):
status: New → Confirmed

>> Perhaps a better way to solve this issue better is to have a applet watch the disk space

Sorry, but I have to disagree. In my opinion this will just create another place where something is configured without actually solving the problem. What default do you use? What if the user installs some very big packets that quickly exhaust the remaining space? What if the user does not log out/in at all, but rather hibernates the machine all the time like I do (I have uptime 50+ days although I shut down the machine every day), therefore I never log out/in and that is what many people do nowadays.

The really important thing I see is to tell the user that the installation failed because of low disk space and that it will solve the situation if he can clean up some space. This will tell the user what to do and will avoid the high number of bug reports. Just look at the list of duplicates of this bug.

I have to admit I don't know anything about the internas of the installation tools, but if there is no way between apt/synaptics to transport such information than that's what probably needs to be added.

If there is additionally an application that helps the user with making space available by showing how much space is used where, fine, but don't rely on that as solution for this problem.

It would also be a useful thing if "apt-get clean" were a default, and run after every apt-get install.

The rationale for not deleting debs that are downloaded is from the days when network bandwidth was very expensive. These days, bandwidth is cheap, but disk space often isn't (think SSDs which are usually 32 - 64 GB). Once a deb has been installed, it's very unlikely that the user will want it again.

Alexander Rødseth (alexanro) wrote :

If a package that is essential for network connectivity needs to be downgraded, it's likely that the user wants the previous package to be available.

Changed in dpkg (Debian):
status: Unknown → New
To post a comment you must log in.