[regression] [gen3] Mesa 9.2 makes Unity unusable on Atom class hardware and 943/945 graphics controllers

Bug #1222602 reported by rottame on 2013-09-08
350
This bug affects 69 people
Affects Status Importance Assigned to Milestone
Mesa
Confirmed
Medium
Nux
Fix Released
Undecided
Unassigned
Release Notes for Ubuntu
Undecided
Unassigned
mesa (Ubuntu)
High
Timo Aaltonen
nux (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

After the upgrade to Mesa 9.2.0 unity is barely usable.
Dash, Alt+Tab switcher and Alt+F2 command line shows in more than 1 minute, using 100% cpu.

A downgrade to mesa 9.1.6-2ubuntu2 restores full performance.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: libgl1-mesa-glx 9.2-1ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-5.11-generic 3.11.0
Uname: Linux 3.11.0-5-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.12.1-0ubuntu3
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Mon Sep 9 01:51:45 2013
DistUpgraded: 2013-09-08 20:36:47,811 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Mobile 945GSE Express Integrated Graphics Controller [8086:27ae] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. Device [1462:0110]
   Subsystem: Micro-Star International Co., Ltd. Device [1462:0110]
InstallationDate: Installed on 2013-09-07 (1 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release i386 (20130424)
MachineType: MICRO-STAR INTERNATIONAL CO., LTD U90/U100
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-5-generic root=UUID=674329c8-d0a6-4954-89c0-72821cfa0ba8 ro quiet splash vt.handoff=7
SourcePackage: mesa
UpgradeStatus: Upgraded to saucy on 2013-09-08 (0 days ago)
dmi.bios.date: 12/01/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.3
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: U90/U100
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.board.version: Ver.001
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 10
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO., LTD
dmi.chassis.version: Ver.001
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.3:bd12/01/2009:svnMICRO-STARINTERNATIONALCO.,LTD:pnU90/U100:pvrVer.001:rvnMICRO-STARINTERNATIONALCO.,LTD:rnU90/U100:rvrVer.001:cvnMICRO-STARINTERNATIONALCO.,LTD:ct10:cvrVer.001:
dmi.product.name: U90/U100
dmi.product.version: Ver.001
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO., LTD
version.compiz: compiz 1:0.9.10+13.10.20130828.2-0ubuntu1
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.14.2.901-2ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu6
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.14-4ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9-2ubuntu1
xserver.bootTime: Mon Sep 9 01:46:55 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 1001
 vendor HSD
xserver.version: 2:1.14.2.901-2ubuntu4

Just tried the latest mesa from git with commit 97217a40f97cdeae0304798b607f704deb0c3558 on an Asus Eeepc 1000H with Intel gen3 graphics. Indeed I now see opengl 2.1 and shading language 1.2 advertised. Yet, this unfortunately completely breaks the Ubuntu's Unity desktop.

I believe that the issue is that the window manager thinks that it can rely on the hardware for some operations (effects). However, these are so painfully slow that the machine appears to hang. For instance, the log out operation is meant to show a log-out panel. When the graphics hardware supports it, the panel fades in. However, this operation now takes about 1.5 minutes and the machine seems to hang. Trying to show the "search your computer" panel is so slow that I had to reboot the machine.

How about reverting this option until desktop managers learn that they should not play effects on gen3 even if it advertises some capabilities? Or at least how about making the opengl level configurable via xorg.conf? Just like Unity, some other desktop managers may he bitten by this issue, as well as other pieces of software.

I did not realize that the opengl conformance level is /already/ configurable via the MESA_GL_VERSION_OVERRIDE environment variable.

Setting it to 1.4 in /etc/environment is actually sufficient to restore the unity desktop functionality on the EEEPC (and - I guess - on machines with < gen4 hardware)

This is good news, because the environment setting is a sufficient hack to make latest mesa work with gen3 hardware in todays DMs.

However, I wonder, why is the advertised opengl 2.1 functionality so unberably slow on gen3? Is mesa rendering on the CPU for this (seems so, as the cpu load goes extremely high when unity tries to open the logout panel)? Is it sensible to do so by default, since machines with gen3 cannot be expected to have strong CPUs?

rottame (ennegielle) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) on 2013-09-09
summary: - Bad performance on GMA950
+ [gen3]Bad performance on i945
Changed in mesa (Ubuntu):
importance: Undecided → High
status: Confirmed → New

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed

Ok I have the same symptoms on a Pineview (GMA3150), confirmed that downgrading mesa also restores these three functions to normal. Dupped my bug against this if you need specific H/W information.

summary: - [gen3]Bad performance on i945
+ Bad performance on GMA950 and GMA3150
Timo Aaltonen (tjaalton) on 2013-09-09
summary: - Bad performance on GMA950 and GMA3150
+ [gen3] Bad performance on GMA950 and GMA3150
Changed in mesa (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)

ubuntu has 9.2 now, and it's indeed utterly broken for gen3:

https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1222602

Just to confirm that the work-around described in the upstream bug (set MESA_GL_VERSION_OVERRIDE=1.4 in /etc/environment) works on my GMA950 based netbook).

Andy Whitcroft (apw) wrote :

Confirming that adding the below to /etc/environment sorted my system out with the latest mesa 9.2 installed:

    MESA_GL_VERSION_OVERRIDE=1.4

Changed in mesa:
importance: Unknown → Medium
status: Unknown → Confirmed

There is another issue with latest mesa, that goes with 2 monitors setup.

Gen 3 can manage up to 4096x4096. However, it can only manage opengl contexts up to 2048x2048. I think that there were attempts at going up to 4096x4096 via software tricks, but they were never completed to work.

The limit on opengl contexts means that if you want two screens, they must appear as one below (or above) the other, not one to the left or to the right of the other. In fact, horizontal resolution is typically much larger than vertical one. By putting things one above/below the other, it is possible to fit in 2048x2048 while putting things one left/right of the other, you easily go above 2048 pixels.

Unfortunately, latest mesa does not prevent unity from putting the second screen to the side of the first one. Since unity does this automatically, as soon as a second screen is attached, the machine becomes unusable.

Andy Whitcroft (apw) wrote :

@Sergio -- that is back, gah.

Timo Aaltonen (tjaalton) wrote :

adding unity to the mix, in case this should be worked around there until a proper fix is available

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Colin Law (colin-law) wrote :

This problem also seen on graphics card
Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03) (prog-if 00 [VGA controller])

The workaround in comment #6 works.

manny (estelar57) wrote :

I have this problem, but I've also seen the UI freezing or locking up (most of the time) when you minimize applications. If you press Alt + Ctrl + Del and get the shutdown diag, it goes back to normal.

I wonder if it's part of the same bug or a different one?

Reiner Jung (prefec2) wrote :

I have tried the solution from comment #6 and it works. It would be helpful to understand why this works. Digging through the comments it looks like mesa uses not the GPU acceleration when the variable is not set. This looks like a design error in mesa. Maybe mesa developers should be asked about this. However, I have tried gnome-shell (before adding the environment setting) and it worked like a charm indicating that gnome-shell sets this variable on its own or initializes mesa differently. Considering gnome-shell was freaking slow compared to unity in 13.04. there must have been a not so wise change in unity.

Colin Law (colin-law) wrote :

@manny that is a different bug.

manny (estelar57) wrote :

@Colin Law

Ok, thanks.

I was able to confirm the lockups happening also on an AMD/ATI laptop.

However, I get much more lockups on the Intel.

So anyone else experienced this or reported it? Else I'll go my way and report this soon.

Andy Whitcroft (apw) wrote :

This issue is still present at Beta.

Changed in unity (Ubuntu):
importance: Undecided → High
summary: - [gen3] Bad performance on GMA950 and GMA3150
+ [gen3] Huge delays and Bad performance on GMA950 and GMA3150

If this doesn't get fixed it will need a release note, so adding task now so we do not forget.

tags: added: regression-release
summary: - [gen3] Huge delays and Bad performance on GMA950 and GMA3150
+ [regression] [gen3] Huge delays and Bad performance on GMA950 and
+ GMA3150
summary: - [regression] [gen3] Huge delays and Bad performance on GMA950 and
- GMA3150
+ [regression] [gen3] Mesa 9.2 makes Unity unusable on Atom class hardware
Colin Law (colin-law) on 2013-10-01
summary: [regression] [gen3] Mesa 9.2 makes Unity unusable on Atom class hardware
+ and 943/945 graphics controllers

got a word from a unity dev about what's happening with opengl 2.x

"Yes, the non-working codepath invokes a much more heavyweight Gaussian blur convolution function. The working codepath also downscales the image before blurring.

An example of the shader code for the broken pass is as follows.

    "varying vec4 v_tex_coord;
     uniform sampler2D tex_object;
     uniform vec2 tex_size;
     #define NUM_SAMPLES %d
     uniform float weights[NUM_SAMPLES];
     uniform float offsets[NUM_SAMPLES];
     void main()
     {
      vec3 acc = texture2D(tex_object, v_tex_coord.st).rgb*weights[0];
      for (int i = 1; i < NUM_SAMPLES; i++)
      {
        acc += texture2D(tex_object, (v_tex_coord.st+(vec2(0.0, offsets[i])/tex_size))).rgb*weights[i];
        acc += texture2D(tex_object, (v_tex_coord.st-(vec2(0.0, offsets[i])/tex_size))).rgb*weights[i];
      }
      gl_FragColor = vec4(acc, 1.0);
     }";

The NUM_SAMPLES in this case is 10."

Robert Hooker (sarvatt) on 2013-10-02
Changed in mesa (Ubuntu):
status: Confirmed → Fix Committed
Laryllan (laryllan) wrote :

@Rober Hooker:
What's the fix about?
The bug is still present on my system (with all the newest packages installed).

Colin Law (colin-law) wrote :

@laryllan, the fix has been committed but needs to work its way through the system. It will be marked released at some point and should appear in the repository shortly after that.

Can you try the i915 gallium driver? Is it better in this regard?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
TekWiz (tekwiz) wrote :

What is the Q35 graphics? I also experienced this on a Dell OptiPlex 755 Intel Core 2 Duo CPU E6550 @ 2.33GHz x 2. Graphics: Intel Q35. RAM: 1.9 GiB. I didn't try the workaround though...

Traumflug (mah-jump-ing) wrote :

Q35 is one of the successors of the 945, too. More to the higher end, if not the top model, of this family at some point.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 4.0.2+13.10.20131004-0ubuntu1

---------------
nux (4.0.2+13.10.20131004-0ubuntu1) saucy; urgency=low

  [ Stephen M. Webb ]
  * precomputed tap invariants for bilinear Gaussian blur shaders (lp:
    #1222602). (LP: #1222602)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 821
 -- Ubuntu daily release <email address hidden> Fri, 04 Oct 2013 05:22:28 +0000

Changed in nux (Ubuntu):
status: Confirmed → Fix Released
Stephen M. Webb (bregma) on 2013-10-04
Changed in unity (Ubuntu):
status: Confirmed → Invalid
TekWiz (tekwiz) wrote :

So it was a math problem I understand? Great! I'll try the new one! :)

Erik (erik65536) wrote :

After the patch there is a small improvement in performance, but it is still unusably slow.

Atom N550
GMA 3150

TekWiz (tekwiz) wrote :

Well, I just tried the Oct. 4th daily build and still measured a 30 second hang after clicking the home button. :(

TekWiz (tekwiz) wrote :

Yeah Erik, I noticed it's a bit more stable, it doesn't crash now, but the lag seems the same, a 30 second lag to get the home menu is not acceptable. It even takes time to get out of it!

TekWiz (tekwiz) wrote :

I am also confirming that adding MESA_GL_VERSION_OVERRIDE=1.4 to the /etc/environment file does fix the problem.

fixing the math didn't fix the issue, it's still slow.

we don't build i915g so no idea.

Stephen M. Webb (bregma) wrote :

Folks, the Nux change was a small change suggested by some Mesa devs to improve performance. While I hoped it would be enough, the real fix is in the Mesa package and is still filtering through the system.

TekWiz (tekwiz) wrote :

So is this fix actually in the 10/4 build? "This bug was fixed in the package nux - 4.0.2+13.10.20131004-0ubuntu1"

I got the 10/4 earlier, and I just did the software update. Removed the line I added earlier to see if it helped but no, the problem still exists....

Erik (erik65536) wrote :

TekWiz, he is saying that the fix is in a mesa build that has not been released yet. The nux patch only partially addresses this bug. Thanks for the clarification Stephen.

TekWiz (tekwiz) wrote :

Oops my bad, thanks Erik, when I posted my question it was 5 minutes after Stephen replied and I guess I didn't refresh the page so I wasn't aware of it! Sorry!

Well at least that line does fix the problem for now so all seems fine. I wonder what that line "downgrades" everything looks great . I don't notice any difference.

jerrylamos (jerrylamos) wrote :

Acer Aspire 1 D255E Intel Atom N455 Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller

MESA_GL_VERSION_OVERRIDE=1.4 to the /etc/environment

is a big help on restoring desktop action. This netbook + external monitor has been running ubuntu fine since 10.10.

Still have a bug1234839 which is launcher unhide/hide leaves the launcher background as a big vertical black stripe instead of restoring the wallpaper.

Stephen M. Webb (bregma) wrote :

The "downgrade to 1.4" workaround causes a different code path in Unity to be executed, and that uses a much simpler blur function. It looks OK, but to the expert eye it doesn't look near as good. Don't ask me what the difference is: it all looks blurry to me even with my bifocals on.

The root of the problem is that the newer Mesa claims it supports OpenGL 2.1 functions, but it's doing that by emulating GPU functions on the CPU in software. So it's technically correct, but practically unusable.

jerrylamos (jerrylamos) wrote :

Their choice. My choice is sharp and clear and quick. I take sharp high res digital pictures, not fuzzy out of focus. Fuzzy blurred reminds me of 1982 when I started on pc's.

Oibaf (oibaf) wrote :

I attach a 32 bit version of i915 gallium driver. If someone want to test if this is better than the default non-gallium driver, copy the file in /usr/lib/i386-linux-gnu/dri , overwriting the existing one (save the original before, to be safe). Then restart X and make sure to verify you are running the new gallium driver (type in a shell glxinfo | grep OpenGL ). Note that this was build under raring, hopefully it should work on saucy also.

Colin Law (colin-law) wrote :

Olibaf: the new driver is a great improvement, but it is still not good enough I am afraid. For example, with the new driver the Dash still takes about 4 seconds to show, coming up in several steps. With the workaround setting MESA_GL_VERSION_OVERRIDE=1.4 it comes up in about than 0.5 seconds. Before the new driver and without the workaround the Dash took tens of seconds to come up.

Erik (erik65536) wrote :

i915 Gallium driver on an Atom N270.

-Opening the dash, shut down window, etc. is much faster.

-The overall performance of this driver is much slower. Even fade effects on context menus cause stuttering. This is not improved by setting MESA_GL_VERSION_OVERRIDE=1.4.

-Some visual effects don't seem to work correctly. For example the background on the dash is not blurred or transparent. It is a solid color with a gradient.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 9.2.1-1ubuntu1

---------------
mesa (9.2.1-1ubuntu1) saucy; urgency=low

  [ Robert Hooker ]
  * Add i915-dont-default-to-2.1.patch: Stop defaulting to OpenGL 2.1 that is not
    fully implemented in hardware on gen3 GPUs, the software fallbacks make Unity
    unusably slow. (LP: #1222602)
  [ Maarten Lankhorst ]
  * New upstream bugfix release. (LP: #1232940)

mesa (9.2.1-1) experimental; urgency=low

  * New upstream release.
 -- Maarten Lankhorst <email address hidden> Mon, 07 Oct 2013 10:39:18 +0200

Changed in mesa (Ubuntu):
status: Fix Committed → Fix Released
Erik (erik65536) wrote :

Confirming that the bug is fixed in the updated mesa package.

Colin Law (colin-law) wrote :

Could someone clarify exactly which package this is please. When I do
apt-cache policy mesa
I get Unable to locate package mesa

Timo Aaltonen (tjaalton) wrote :

libgl1-mesa-dri

Colin Law (colin-law) wrote :

Thanks Timo

Those updated packages are available only in the proposed repository.

Colin Law (colin-law) wrote :

Fix working fine on i943/945 graphics.

Colin Law (colin-law) wrote :

Mateusz:
$ apt-cache policy libgl1-mesa-dri
libgl1-mesa-dri:
  Installed: 9.2.1-1ubuntu1
  Candidate: 9.2.1-1ubuntu1
  Version table:
 *** 9.2.1-1ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
        100 /var/lib/dpkg/status

Traumflug (mah-jump-ing) wrote :

Can report success for the Intel G33, too. Now the system menu is gone and the dash searches forever without results - different story.

Berat Alp Erbil (beratalp) wrote :

Solved for me but dash background is too dark. Is it a feature or a bug? :P

Download full text (4.4 KiB)

Its a bug, I've already reported it :)

On Mon, Oct 7, 2013 at 12:58 PM, Berat Alp Erbil <<email address hidden>
> wrote:

> Solved for me but dash background is too dark. Is it a feature or a bug?
> :P
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1219539).
> https://bugs.launchpad.net/bugs/1222602
>
> Title:
> [regression] [gen3] Mesa 9.2 makes Unity unusable on Atom class
> hardware and 943/945 graphics controllers
>
> Status in Mesa:
> Confirmed
> Status in Release Notes for Ubuntu:
> New
> Status in “mesa” package in Ubuntu:
> Fix Released
> Status in “nux” package in Ubuntu:
> Fix Released
> Status in “unity” package in Ubuntu:
> Invalid
>
> Bug description:
> After the upgrade to Mesa 9.2.0 unity is barely usable.
> Dash, Alt+Tab switcher and Alt+F2 command line shows in more than 1
> minute, using 100% cpu.
>
> A downgrade to mesa 9.1.6-2ubuntu2 restores full performance.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: libgl1-mesa-glx 9.2-1ubuntu1
> ProcVersionSignature: Ubuntu 3.11.0-5.11-generic 3.11.0
> Uname: Linux 3.11.0-5-generic i686
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.12.1-0ubuntu3
> Architecture: i386
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> Date: Mon Sep 9 01:51:45 2013
> DistUpgraded: 2013-09-08 20:36:47,811 DEBUG enabling apt cron job
> DistroCodename: saucy
> DistroVariant: ubuntu
> ExtraDebuggingInterest: Yes
> GraphicsCard:
> Intel Corporation Mobile 945GSE Express Integrated Graphics Controller
> [8086:27ae] (rev 03) (prog-if 00 [VGA controller])
> Subsystem: Micro-Star International Co., Ltd. Device [1462:0110]
> Subsystem: Micro-Star International Co., Ltd. Device [1462:0110]
> InstallationDate: Installed on 2013-09-07 (1 days ago)
> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release i386
> (20130424)
> MachineType: MICRO-STAR INTERNATIONAL CO., LTD U90/U100
> MarkForUpload: True
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=it_IT.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-5-generic
> root=UUID=674329c8-d0a6-4954-89c0-72821cfa0ba8 ro quiet splash vt.handoff=7
> SourcePackage: mesa
> UpgradeStatus: Upgraded to saucy on 2013-09-08 (0 days ago)
> dmi.bios.date: 12/01/2009
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 4.6.3
> dmi.board.asset.tag: To be filled by O.E.M.
> dmi.board.name: U90/U100
> dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
> dmi.board.version: Ver.001
> dmi.chassis.asset.tag: To Be Filled By O.E.M.
> dmi.chassis.type: 10
> dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO., LTD
> dmi.chassis.version: Ver.001
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvr4.6.3:bd12/01/2009:svnMICRO-STARINTERNATIONALCO.,LTD:pnU90/U100:pvrVer.001:rvnMICRO-STARINTERNATIONALCO.,LTD:rnU90/U100:rvrVer.001:cvnMICRO-STARINTERNATIONALCO....

Read more...

Edwin Pujols (edwinpm5) wrote :
Download full text (4.6 KiB)

If you change the desktop wallpaper, the Dash color fixes itself.

On Mon, Oct 7, 2013 at 3:23 PM, Edwin Pujols <email address hidden> wrote:

> Its a bug, I've already reported it :)
>
>
> On Mon, Oct 7, 2013 at 12:58 PM, Berat Alp Erbil <
> <email address hidden>> wrote:
>
>> Solved for me but dash background is too dark. Is it a feature or a bug?
>> :P
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (1219539).
>> https://bugs.launchpad.net/bugs/1222602
>>
>> Title:
>> [regression] [gen3] Mesa 9.2 makes Unity unusable on Atom class
>> hardware and 943/945 graphics controllers
>>
>> Status in Mesa:
>> Confirmed
>> Status in Release Notes for Ubuntu:
>> New
>> Status in “mesa” package in Ubuntu:
>> Fix Released
>> Status in “nux” package in Ubuntu:
>> Fix Released
>> Status in “unity” package in Ubuntu:
>> Invalid
>>
>> Bug description:
>> After the upgrade to Mesa 9.2.0 unity is barely usable.
>> Dash, Alt+Tab switcher and Alt+F2 command line shows in more than 1
>> minute, using 100% cpu.
>>
>> A downgrade to mesa 9.1.6-2ubuntu2 restores full performance.
>>
>> ProblemType: Bug
>> DistroRelease: Ubuntu 13.10
>> Package: libgl1-mesa-glx 9.2-1ubuntu1
>> ProcVersionSignature: Ubuntu 3.11.0-5.11-generic 3.11.0
>> Uname: Linux 3.11.0-5-generic i686
>> .tmp.unity.support.test.0:
>>
>> ApportVersion: 2.12.1-0ubuntu3
>> Architecture: i386
>> CompizPlugins: No value set for
>> `/apps/compiz-1/general/screen0/options/active_plugins'
>> CompositorRunning: compiz
>> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
>> CompositorUnredirectFSW: true
>> Date: Mon Sep 9 01:51:45 2013
>> DistUpgraded: 2013-09-08 20:36:47,811 DEBUG enabling apt cron job
>> DistroCodename: saucy
>> DistroVariant: ubuntu
>> ExtraDebuggingInterest: Yes
>> GraphicsCard:
>> Intel Corporation Mobile 945GSE Express Integrated Graphics Controller
>> [8086:27ae] (rev 03) (prog-if 00 [VGA controller])
>> Subsystem: Micro-Star International Co., Ltd. Device [1462:0110]
>> Subsystem: Micro-Star International Co., Ltd. Device [1462:0110]
>> InstallationDate: Installed on 2013-09-07 (1 days ago)
>> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release i386
>> (20130424)
>> MachineType: MICRO-STAR INTERNATIONAL CO., LTD U90/U100
>> MarkForUpload: True
>> ProcEnviron:
>> TERM=xterm
>> PATH=(custom, no user)
>> XDG_RUNTIME_DIR=<set>
>> LANG=it_IT.UTF-8
>> SHELL=/bin/bash
>> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-5-generic
>> root=UUID=674329c8-d0a6-4954-89c0-72821cfa0ba8 ro quiet splash vt.handoff=7
>> SourcePackage: mesa
>> UpgradeStatus: Upgraded to saucy on 2013-09-08 (0 days ago)
>> dmi.bios.date: 12/01/2009
>> dmi.bios.vendor: American Megatrends Inc.
>> dmi.bios.version: 4.6.3
>> dmi.board.asset.tag: To be filled by O.E.M.
>> dmi.board.name: U90/U100
>> dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
>> dmi.board.version: Ver.001
>> dmi.chassis.asset.tag: To Be Filled By O.E.M.
>> dmi.chassis.type: 10
>> dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO., LTD
>> dmi.chassis...

Read more...

Mace (xmacex) wrote :

Beautiful, i had this problem as well and it is now fixed. I have had blur disabled via CompizConfig which was a successful workaround, but now i turned it back on and everything is fine. Also the Dash background with Edwin's tip. Thanks people! :) I'm using Asus EeePC 901 with Intel 945GME graphics.

TekWiz (tekwiz) wrote :

Yeah the dash becomes very dark, and if you change the wallpaper it does fix itself. However it returns to the dark color later on... So I guess another bug lol.

Andy Whitcroft (apw) wrote :

The mesa version hold is now set by default in mesa. No release note needed.

Changed in ubuntu-release-notes:
status: New → Invalid
Carl Johan (carljohanja) wrote :

I have used the workaround successfully, but now the problem has returned. Compiz CPU usage is high (around 30%) and the Dash is extremely sluggish. I have tested without the workaround in /etc/environment, but with the same result. Disabling blur does not solve the problem either. Anyone else experiencing the same issue?

Colin Law (colin-law) wrote :

For me with up to date Saucy it is still working fine.
apt-cache policy libgl1-mesa-dri
shows 9.2.1-1ubuntu3

Carl Johan (carljohanja) wrote :

Ok, thanks for your reply. I haven't had any issues up until today. My system is up to date and apt-cache policy libgl1-mesa-dri shows
Installed: 9.2.1-1ubuntu3
Candidate: 9.2.1-1ubuntu3

Edwin Pujols (edwinpm5) wrote :
Download full text (4.5 KiB)

@CarlJohan Maybe, its a new bug? For me its working perfectly.

On Sat, Oct 19, 2013 at 7:52 AM, Carl Johan <email address hidden> wrote:

> Ok, thanks for your reply. I haven't had any issues up until today. My
> system is up to date and apt-cache policy libgl1-mesa-dri shows
> Installed: 9.2.1-1ubuntu3
> Candidate: 9.2.1-1ubuntu3
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1219539).
> https://bugs.launchpad.net/bugs/1222602
>
> Title:
> [regression] [gen3] Mesa 9.2 makes Unity unusable on Atom class
> hardware and 943/945 graphics controllers
>
> Status in Mesa:
> Confirmed
> Status in Release Notes for Ubuntu:
> Invalid
> Status in “mesa” package in Ubuntu:
> Fix Released
> Status in “nux” package in Ubuntu:
> Fix Released
> Status in “unity” package in Ubuntu:
> Invalid
>
> Bug description:
> After the upgrade to Mesa 9.2.0 unity is barely usable.
> Dash, Alt+Tab switcher and Alt+F2 command line shows in more than 1
> minute, using 100% cpu.
>
> A downgrade to mesa 9.1.6-2ubuntu2 restores full performance.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: libgl1-mesa-glx 9.2-1ubuntu1
> ProcVersionSignature: Ubuntu 3.11.0-5.11-generic 3.11.0
> Uname: Linux 3.11.0-5-generic i686
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.12.1-0ubuntu3
> Architecture: i386
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> Date: Mon Sep 9 01:51:45 2013
> DistUpgraded: 2013-09-08 20:36:47,811 DEBUG enabling apt cron job
> DistroCodename: saucy
> DistroVariant: ubuntu
> ExtraDebuggingInterest: Yes
> GraphicsCard:
> Intel Corporation Mobile 945GSE Express Integrated Graphics Controller
> [8086:27ae] (rev 03) (prog-if 00 [VGA controller])
> Subsystem: Micro-Star International Co., Ltd. Device [1462:0110]
> Subsystem: Micro-Star International Co., Ltd. Device [1462:0110]
> InstallationDate: Installed on 2013-09-07 (1 days ago)
> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release i386
> (20130424)
> MachineType: MICRO-STAR INTERNATIONAL CO., LTD U90/U100
> MarkForUpload: True
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=it_IT.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-5-generic
> root=UUID=674329c8-d0a6-4954-89c0-72821cfa0ba8 ro quiet splash vt.handoff=7
> SourcePackage: mesa
> UpgradeStatus: Upgraded to saucy on 2013-09-08 (0 days ago)
> dmi.bios.date: 12/01/2009
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 4.6.3
> dmi.board.asset.tag: To be filled by O.E.M.
> dmi.board.name: U90/U100
> dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
> dmi.board.version: Ver.001
> dmi.chassis.asset.tag: To Be Filled By O.E.M.
> dmi.chassis.type: 10
> dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO., LTD
> dmi.chassis.version: Ver.001
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvr4.6.3:bd12/01/2009:svnMICRO-...

Read more...

Carl Johan (carljohanja) wrote :

@Edwin
Yes, seems likely. Since it works both for you and Colin, it is probably a new bug. Also, now that i have had more time to explore, the problem on my system is a bit different than what is described in this bug report. Visual effects are sluggish but not to as slow as described in this report. I will have to do a clean install and keep my fingers crossed.

Btw, my system is an Asus 1215n with Intel GMA 3150 and Nvidia Ion 2.

@CarlJohan #60

I'm experiencing a very similiar--possibly the same--issue: Ubuntu 13.10,high compiz cpu, MESA_GL_VERSION_OVERRIDE doesn't help, Installed: 9.2.1-1ubuntu3.

Did reinstallation fix your issue?
Should this be a new bug report?

I'm on Asrock H61M, Intel HD3000, i915 kernel driver, I got here because bug #1219366 is marked a duplicate of this one. Typically on my cpu the system doesn't slow down much, but cpu use goes into >250% when moving windows and fans are at high speed continuously. Also transparancy of dash has gone.

Colin Law (colin-law) wrote :

@Danny, this bug caused the Dash to take tens of seconds to appear and some other graphics to be slow, however the basic operation of the machine was little affected. Your problem appears to be different so I suggest reporting a new bug.

Carl Johan (carljohanja) wrote :

@Danny
My bug turned out to be a different one, but it manifested itself similar to this bug. The problem came from having an external monitor connected via the VGA port at startup. For some reason that caused compiz to respond very slowly. I have solved the problem by connecting the monitor after booting into ubuntu.

Carlo (woddy68) wrote :

On asus eeepc 11.10 atom cpu, I continue to have problems, the background of the dash is black, if I change my wallpaper is displayed correctly, there is no solution to this vexing probema?

Edwin Pujols (edwinpm5) wrote :
Download full text (4.5 KiB)

@Carlo There's a bug report for that: Bug 1232726

On Sun, Nov 10, 2013 at 10:08 AM, Carlo <email address hidden> wrote:

> On asus eeepc 11.10 atom cpu, I continue to have problems, the
> background of the dash is black, if I change my wallpaper is displayed
> correctly, there is no solution to this vexing probema?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1219539).
> https://bugs.launchpad.net/bugs/1222602
>
> Title:
> [regression] [gen3] Mesa 9.2 makes Unity unusable on Atom class
> hardware and 943/945 graphics controllers
>
> Status in Mesa:
> Confirmed
> Status in Release Notes for Ubuntu:
> Invalid
> Status in “mesa” package in Ubuntu:
> Fix Released
> Status in “nux” package in Ubuntu:
> Fix Released
> Status in “unity” package in Ubuntu:
> Invalid
>
> Bug description:
> After the upgrade to Mesa 9.2.0 unity is barely usable.
> Dash, Alt+Tab switcher and Alt+F2 command line shows in more than 1
> minute, using 100% cpu.
>
> A downgrade to mesa 9.1.6-2ubuntu2 restores full performance.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: libgl1-mesa-glx 9.2-1ubuntu1
> ProcVersionSignature: Ubuntu 3.11.0-5.11-generic 3.11.0
> Uname: Linux 3.11.0-5-generic i686
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.12.1-0ubuntu3
> Architecture: i386
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> Date: Mon Sep 9 01:51:45 2013
> DistUpgraded: 2013-09-08 20:36:47,811 DEBUG enabling apt cron job
> DistroCodename: saucy
> DistroVariant: ubuntu
> ExtraDebuggingInterest: Yes
> GraphicsCard:
> Intel Corporation Mobile 945GSE Express Integrated Graphics Controller
> [8086:27ae] (rev 03) (prog-if 00 [VGA controller])
> Subsystem: Micro-Star International Co., Ltd. Device [1462:0110]
> Subsystem: Micro-Star International Co., Ltd. Device [1462:0110]
> InstallationDate: Installed on 2013-09-07 (1 days ago)
> InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release i386
> (20130424)
> MachineType: MICRO-STAR INTERNATIONAL CO., LTD U90/U100
> MarkForUpload: True
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=it_IT.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-5-generic
> root=UUID=674329c8-d0a6-4954-89c0-72821cfa0ba8 ro quiet splash vt.handoff=7
> SourcePackage: mesa
> UpgradeStatus: Upgraded to saucy on 2013-09-08 (0 days ago)
> dmi.bios.date: 12/01/2009
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: 4.6.3
> dmi.board.asset.tag: To be filled by O.E.M.
> dmi.board.name: U90/U100
> dmi.board.vendor: MICRO-STAR INTERNATIONAL CO., LTD
> dmi.board.version: Ver.001
> dmi.chassis.asset.tag: To Be Filled By O.E.M.
> dmi.chassis.type: 10
> dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO., LTD
> dmi.chassis.version: Ver.001
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvr4.6.3:bd12/01/2009:svnMICRO-STARINTERNA...

Read more...

Marco Ivaldi (blu-ivaldi) wrote :

I have the same issue by Danny in #65

Workaround suggested in #6 worked for me until I upgraded linux imag 3.11.0-17

Then compiz returned requiring too much resources to the system (cpu and ram)

I tried to fix with a intel graphic workaround but without benefits.

For me solution suggested in # 67 works.

Do anyone know why?

M.

nope, I must correct myself. Same problem as described by Marco in #70. The issue remains when a external monitor is connected at startup even it isn't used and the Mesa environment variable is set.

/usr/lib/nux/unity_support_test -p
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) 945GM x86/MMX/SSE2
OpenGL version string: 1.4 Mesa 10.1.0

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes

Stefan Thielscher (stth) wrote :

I'm not sure if this fits into this particular bug, but maybe it helps to locate the problem...

I have a netbook with Intel Atom N455 and GMA3150. The netbook has an external monitor attached to it via a KVM switch (USB mouse and keyboard, VGA) and has run Ubuntu since 11.10 (13.10 upto yesterday and now 14.04). The dual monitor setup has worked for nearly 2,5 years without any real issues.

A few days ago, the external monitor broke. It was an old Samtron CRT which I ran at 1152x864/75 Hz. I got a new monitor, a LCD flatscreen with 1366x768, to replace it.

Booting with the new monitor works. It shows the plymouth screen, LightDM's login screen and also Unity. But compiz now eats roughly 50% of the CPU as reported by top, and all graphical effects are utterly slow. This happened under 13.10 and now with 14.04 as well, with all updates installed.

I've tried the things mentioned above and some others I've found while searching for this bug:

- Renamed ~/.compiz folder. That actually worked once, but the high CPU usage was back after a reboot. Didn't do anything when I tried it again.

- Disabled "sync to vblank" in CCSM. Didn't do anything.

- CCSM -> Preferences -> Reset Unity profile. Worked, but high CPU usage was back after a reboot.

- Set MESA_GL_VERSION_OVERRIDE=1.4 in /etc/environment. Didn't do anything.

- Installed the latest packages from Oibaf's PPA. Didn't do anything.

- Guest session instead of my regular account. Had high CPU usage as well.

I then decided to install 14.04, hoping the bug would be fixed. Unfortunately, it's still there.

BTW, "/usr/lib/nux/unity_support_test -p" shows (under 14.04):

--------8<--------
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) IGD
OpenGL version string: 1.4 Mesa 10.1.0

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes
--------8<--------

I had "yes" everywhere under 13.10 as well, with both default mesa from the Ubuntu repositories and the version from Oibaf's PPA.

Yesterday, after installing 14.04 and re-installing my favourite software packages, I got a few updates. Two dozen packages or so, including the "3.13.0-20-generic #42" kernel. I installed those and rebooted. After logging in, THE HIGH CPU USAGE WAS GONE. But after another reboot, compiz ate half the CPU again. Huh???

Anyway, I've now found a "solution". Well, not really, but it works for now until the problem is properly fixed. I simply unplug the KVM switch's USB cable before booting to prevent the external monitor from being seen by the system. Once I'm logged in into Unity, I plug the KVM switch back in, then the external monitor turns on, the internal one turns off (as it should), and everything works as expected, without high CPU usage or slow graphical effects.

I hope this helps someone.

@Stephan you are now the 3. or 4. who has this issue when an external screen is connected at booting. That seems to call for a new ticket. But I installed todays updates (14.04), rebooted and all good. Currently compiz does not use 50% of cpu power any longer.

Stefan Thielscher (stth) wrote :

Good to hear it's solved for you!

The strange thing is that I just replaced that broken CRT with the new LCD monitor. Just disconnected the old monitor and connected the new one. Boom, high CPU usage :-(. I didn't install any new software, etc.

I never had this before in 2,5 years and as I said I still have this problem under 14.04, even though the CPU usage there seems to be a bit lower than under 13.10 (I assume due to optimizations in the whole graphics stack).

The funny thing is that I have high CPU usage even when the external monitor is in stand-by/powered off, but when I physically disconnect it (by either removing the VGA cable from the VGA port or unplugging the KVM switch's USB cable which also provides the power for that thing), everything is okay. Makes me wonder what's going on there.

For your crt/lcd monitor -> maybe this issue depends on the resolution of the external screen.

Does appear that issue if you have connected your screen at boot-time, then disconnected when the lightdm login screen is showing and you logged in (without connected external screen)?

Today I had the problem again. Booted and did login (external monitor connected over vga but not used for output)-> high compiz cpu usage
logged out and in again -> high cpu
disonnected monitor, logged out, logged in -> normal compiz cpu usage
again logged out/in -> normal compiz cpu usage
connected monitor again, logged out/in -> high compiz cpu usage again (still the external monitor is not used for output)

Stefan Thielscher (stth) wrote :

Okay, I did a few more tests...

- the external monitor is connected at boot time, I disconnected it when the login screen is displayed, logged in, no high cpu usage

- logged out, connected the monitor, logged in, HIGH CPU USAGE

- logged out, disconnected the monitor, logged in, no high cpu usage

So, up to and including LightDM's login screen, everything is fine. (The date/time indicator on the login screen pops up the calender immediately for example; when I'm logged into Unity with high cpu usage, the calender only pops up in super slow motion.)

When I log into Unity and the external monitor is connected at the time, I get high cpu usage. When I log into Unity with the monitor disconnected, I do not get high cpu usage. When I connect the monitor once Unity is up, everything works fine, too.

BTW, I also have KDE Plasma Workspaces installed, and I don't see any signs of high cpu usage or graphical slowdowns when I log into that one, even when the external monitor is connected the whole time.

Colin Law (colin-law) wrote :

A note for all those commenting on this, my understanding is that if the fix in comment #6 does not work around the problem then you are seeing a different bug.

OK you are right. I opened a ticket for those the fix in comment #6 does not work and the issue appears when a external monitor is connected when login (e.g. as described in #77 and 76):
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1300393

Changed in nux:
status: New → Fix Released
To post a comment you must log in.