Connected external monitor causes very high cpu usage by compiz

Bug #1300393 reported by Christian S. on 2014-03-31
66
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
compiz (Ubuntu)
Medium
Unassigned

Bug Description

When a external monitor is connected at login, cpu usage of compiz is very high and the system is not usable.

There is no difference whether the external monitor is used for output or not. It just have to be connected when login. There are no problems when the monitor is not connected when login and connected afterwards.

$ lsb_release -rd
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04

$ apt-cache policy compiz
compiz:
  Installed: 1:0.9.11+14.04.20140328-0ubuntu1
  Candidate: 1:0.9.11+14.04.20140328-0ubuntu1
  Version table:
 *** 1:0.9.11+14.04.20140328-0ubuntu1 0
        500 http://de.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
        100 /var/lib/dpkg/status

$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) 945GM x86/MMX/SSE2
OpenGL version string: 1.4 Mesa 10.1.0

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: compiz 1:0.9.11+14.04.20140328-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-18.38-generic 3.13.6
Uname: Linux 3.13.0-18-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.13.3-0ubuntu1
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Mon Mar 31 21:07:35 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.3.6, 3.13.0-18-generic, i686: installed
 virtualbox, 4.3.6, 3.13.0-19-generic, i686: installed
 virtualbox, 4.3.6, 3.13.0-20-generic, i686: installed
GraphicsCard:
 Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:01bd]
   Subsystem: Dell Device [1028:01bd]
InstallationDate: Installed on 2013-10-24 (157 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Dell Inc. MM061
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-18-generic root=UUID=7796fb02-f0a7-4355-988f-94862a77bffa ro quiet splash
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/13/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A17
dmi.board.name: 0KD882
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA17:bd06/13/2007:svnDellInc.:pnMM061:pvr:rvnDellInc.:rn0KD882:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MM061
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.11+14.04.20140328-0ubuntu1
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Mon Mar 31 21:00:53 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 43264
 vendor LPL
xserver.version: 2:1.15.0-1ubuntu7

Christian S. (christian-stein2) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed

It renders the system temporarily or permanently unusable.

Changed in compiz (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
description: updated
Aloys (aloys-baillet) wrote :

Also happening here using latest nvidia drivers (331.113), CPU usage of compiz climbs when using the TV out on my GeForce GTS 250. I've been using this setup for years and this high CPU usage making the whole Unity almost unusable is very recent, a few weeks at most.

Running sudo perf top -p $COMPIZ_PID:

Single monitor: (compiz cpu% in top is around 2-3%)

  21.40% [kernel] [k] _nv013274rm
   4.07% [kernel] [k] rm_check_pci_config_space
   1.26% libc-2.19.so [.] _int_malloc
   0.85% libc-2.19.so [.] _int_free
   0.68% libc-2.19.so [.] malloc
   0.65% libc-2.19.so [.] __memmove_ssse3_back
   0.55% libnux-core-4.0.so.0.7.0 [.] _ZN3nux18NThreadSafeCounter9In
   0.52% libopengl.so [.] _ZN15PrivateGLScreen17paintOut

Second monitor turned on in display settings (compiz jumps to 18%):

  13.20% [kernel] [k] _nv013274rm
   3.80% [kernel] [k] rm_check_pci_config_space
   1.44% libc-2.19.so [.] _int_malloc
   1.34% libc-2.19.so [.] _int_free
   0.91% libc-2.19.so [.] malloc
   0.82% libc-2.19.so [.] __memmove_ssse3_back
   0.59% [kernel] [k] _nv008722rm
   0.56% libopengl.so [.] _ZN15PrivateGLScreen17paintOut
   0.55% libc-2.19.so [.] __GI___strcmp_ssse3
   0.53% libnux-core-4.0.so.0.7.0 [.] _ZN3nux18NThreadSafeCounter9De

Cheers,

Changed in compiz:
status: New → Confirmed
Changed in compiz (Ubuntu):
importance: Critical → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers