Dell Inspiron 530 SATA drive not detected in IDE mode

Bug #153702 reported by Marc Tardif
180
This bug affects 7 people
Affects Status Importance Assigned to Milestone
module-init-tools
Invalid
Undecided
Unassigned
Ubuntu
Invalid
Undecided
Unassigned
Nominated for Hardy by Thorsten Glaser
linux (Ubuntu)
Fix Released
High
Unassigned
Nominated for Hardy by Thorsten Glaser
linux-source-2.6.20 (Ubuntu)
Invalid
Undecided
Unassigned
Nominated for Hardy by Thorsten Glaser
linux-source-2.6.22 (Ubuntu)
Won't Fix
High
Unassigned
Nominated for Hardy by Thorsten Glaser

Bug Description

When configuring the SATA drive in IDE mode for the Dell Inspiron 530, the Gutsy 20071016.1 alternate installer doesn't detect the drive. So, it just fails with the error message: No root file system is defined.

As mentionned in the syslog file, I tried booting with the irqpoll kernel parameter and the disk is still not detected.

When configuring the SATA drive in RAID mode, the installation completes successfully.

**Update

Current Dell workaround/customization for their Inspiron 530n :
http://linux.dell.com/wiki/index.php/Ubuntu_7.04/Issues/USB-SATA_race_condition_causes_hang

All Vostro 200 and Inspiron 530 are configured to use IDE instead of RAID by default. The Dell inspiron 530n includes a customized ubuntu that includes the Dell workaround for that issue, however any attempt to install a new ubuntu version without dell customization leads to computers that does not boot.

Configuring the computer BIOS to use RAID instead of IDE is not a valuable solution since other operating systems like Windows won't boot without pre-installed SATA drivers unless BIOS is set back to IDE. IDE is the default "compatible" mode.

Revision history for this message
Marc Tardif (cr3) wrote :
Revision history for this message
Marc Tardif (cr3) wrote :
Revision history for this message
Marc Tardif (cr3) wrote :
Revision history for this message
Tim Gardner (timg-tpi) wrote :

Marc - I have an Inspiron 530 configured for IDE. It boots and installs the alternate correctly. How about attaching the output of 'sudo dmidecode' ?

Revision history for this message
Marc Tardif (cr3) wrote :

Here is the dmidecode output after having changed the BIOS configuration to IDE mode and booting my installation which was done in SATA mode.

Revision history for this message
Marc Tardif (cr3) wrote :

Sorry about that, I meant RAID mode rather than SATA mode in my previous comment.

Revision history for this message
Saivann Carignan (oxmosys) wrote :

I can confirm that Dell inspiron 530 and Dell Vostro 200 Desktop computers, half of the time, doesn't boot at all when they use the IDE mode rather than the RAID mode ( which always works flawlessly ). When trying to install with the live CD, I get a busybox shell half of the time too. It seems to be a matter of SATA/IDE Controller. Tested on Gutsy final release.

Revision history for this message
Olivier Guéry (nemolivier) wrote :

Same here on a Dell inspiron 530 DT
Yesterday I’ll be able to do the install with the alternate cd (normal install cd didn’t work, I should be suspicious).

After the install the « reboot » function don’t work. But the « Halt » and, then, boot work.

This morning, same error as the other.
The « safemode » boot work.

I change the bios setup to RAID and I’ll be able to boot… Hope it still work tomorrow ! Thank’s everybody.
(congrats to my brother to choose beeing a linux user, and sorry for this beginning…).

Revision history for this message
Saivann Carignan (oxmosys) wrote :

Since it's confirmed and that it affects essential hardware, setting importance to High and Status to Confirmed.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Hi Marc,

Can you confirm if this is an issue with the latest Hardy Alpha release?

Changed in linux:
status: New → Incomplete
Revision history for this message
Saivann Carignan (oxmosys) wrote :

I can confirm that this issue persist on Dell Vostro 200 (which is based on the same hardware). I attached a screenshot of the errors on Hardy when booting with BIOS default IDE mode. Exception Emask appears repetitively and endlessly. Marc Tardiff : Do you confirm that the issue is reproducible on Hardy?

Revision history for this message
Samir Nassar (snassar) wrote :

I can confirm this is still an issue on my Dell Vostro 200. Whether upgrading from Gutsy or attempting to boot from Hardy.

Revision history for this message
pnr (rusyaev-gmail) wrote :

I can confirm that the issue still exists on Dell Inspiron 530 with the current Hardy LiveCD. I am not able to boot from LiveCD in IDE mode.

Revision history for this message
Saivann Carignan (oxmosys) wrote :

According to last 3 comments that state that the bug persist, I set back the status to confirmed for current 2.6.24.12 linux kernel.

Changed in linux:
importance: Undecided → High
status: Incomplete → Confirmed
Revision history for this message
Andrew (andrew-t) wrote :

Adding the boot option all_generic_ide worked for me to bring the system up properly.

Issue 206635 seems to be a duplicate of this one.

Revision history for this message
LuisMendes (luismendes) wrote :

I can confirm this issue, running Ubuntu 7.10. SATA doesn't work but RAID does. I'm searching around for the effects of using the computer in RAID mode instead of default SATA.

Revision history for this message
pnr (rusyaev-gmail) wrote :

I can confirm that using the boot option all_generic_ide allowed me to boot from the latest Hardy AMD64 Desktop CD on Inspiron 530. Thanks, Andrew!

Revision history for this message
Stack (sgerstacker) wrote :

I can confirm I am having the same issues as shown by Saïvann Carignan above.

I'm running:

Dell Vostro 200
BIOS 1.0.11
Hardy Heron updated daily
Kernel 2.6.24-14-generic
Hard drive in SATA mode

I can get the system to boot on the kernel, but it's random. It will fail to boot 5 times and then it will work just fine.

This system was upgraded from a current Gutsy, which didn't have the boot problem at all.

Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix
Revision history for this message
Stack (sgerstacker) wrote :

I did notice a strange crash when I rebooted my computer this morning. I had seen something similar to this, but this is a much more verbose error. I can't really decipher it, but the crash does reference 'ata' a lot, so hopefully this is helpful.

Revision history for this message
Stack (sgerstacker) wrote :
Revision history for this message
Stack (sgerstacker) wrote :
Revision history for this message
mrbean71 (m-marti) wrote :

I can confirm: inspiron 530 formatted and installed kubuntu 7.04, then upgrade to 7.10 then to 8.04 beta and update daily.
Untill I read this page SATA was in EIDE mode and I had many boot failure, after boot everithing work fine.
I changed bios to raid, in few days i'll update comment with result on boot process.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

I'm just removing the linux-source-2.6.24 task. Beginning with the Hardy development cycle the ubuntu kernel source package naming convention changed from linux-source-2.6.xx to just linux. Sorry for any confusion. Thanks.

Changed in linux-source-2.6.24:
status: New → Invalid
Revision history for this message
apt-drink (apt-drink) wrote :

For me, it works in IDE mode with module ata_piix, but not ahci (which supposedly would bring better performance..)

Revision history for this message
Blake (blakelives0312) wrote :

I can confirm this as well, if it will do any good. i noticed this around a month ago and hoped that it would be fixed before the Hardy release, but seeing as we are 3 days away, i dont think that will happen. i am running a Dell Inspiron 530 with a SATA drive. The boot process begins and as it reaches the "loading hardware drivers" stage, i get these error messages:

[timestamp] ata1.00 revalidation failed (errno=-5)
[timestamp] ata1.00 revalidation failed (errno=-5)
then these repeat over and again:
[timestamp] ata2.00 exception Emask 0x0 SAct 0x0 action 0x2 frozen
[timestamp] cmd a0/00:00:00:24:00/00:00:00:00:00/a0 tag 0 pio 36 in
[timestamp] Status {DRDY}

( i typed those from a written account because I dont know how to get the actual report...)

i filed a bug report a couple days ago because i was getting fed up with waiting. i will mark it as a duplicate of this bug.

Changed in linux:
status: Confirmed → Triaged
Revision history for this message
Laurent Claessens (moky-math) wrote :

I confirm the bug on live-CD Ubuntu and Kubuntu RC-1.
By changing IDE -> RAID,it works well.

(Dell Inspiron 530, lspci in attachement)

Revision history for this message
peterl (ubuntu-linguamix) wrote : 8.04 RC1 20080417 fails on Dell Vostro 200 BIOS 1.0.13

Just updated my Dell Vostro 200's BIOS from 1.0.11 to 1.0.13 and the same "ATA1.00 revalidation failed (errno=-5)" still happens while launching 8.04 RC1 20080417 LiveCD.

The BIOS is in IDE mode. Before I updated the BIOS I did try "generic.all_generic.ide=1" but it was still failing to boot the CD, even though the error might have been different.

I currently have Gutsy running on it fine, so I didn't try to enable RAID mode.

Is there a way to save those boot logs (upload them from the shell) instead of using those ridiculous digicam shots???

Revision history for this message
Saivann Carignan (oxmosys) wrote :

Thanks for your confirmation. This bug is actually confirmed so we should not comment here except to provide new relevant informations about the bug.

peterl : It's sometime possible to put log files in USB drives or other external medias, but this is probably not necessary here since the bug is confirmed and triaged. You should not experience any problem if you enable RAID with Gutsy, and if you have some, you can always go back to IDE without side-effects.

Revision history for this message
F.H. (fheinsen) wrote :

I can confirm this problem with the latest release candidate.

Changed in linux-source-2.6.24:
status: New → Invalid
Revision history for this message
Blake (blakelives0312) wrote :

I used the Release candidate to test this out once more and noticed on GRUB that the linux kernel version is 2.6.24. 2.6.24-12 and 2.6.24-16 both dont work. it is the same bug.

Revision history for this message
Blake (blakelives0312) wrote :

i just looked up the version i am using now on 7.10, i use 2.6.22-14 and have no problems in booting. but 2.6.24-12 and 2.6.24-16 both have this bug.

Revision history for this message
axel (ax-public) wrote :

"This bug is not recorded as needing to be fixed in linux-source-2.6.24 (Ubuntu)" - that means, I won't be able to run ubuntu on my computer, right? Setting the drive to raid is not an option, since I have windows installed, two identical drives, and no confidence the data would survive switching to raid mode...
So, will I really have to wait for 8.10?

("me too" - 8.04 final, amd64)

Revision history for this message
peterl (ubuntu-linguamix) wrote :

I am in the same hardware situation as "axel" except I also have a working 7.10 setup in IDE mode with very important data on the 2nd drive (a Perforce depot). I am not sure but won't the RAID mode wipe the 2nd HDD with a mirror of the 1st?

Other newbie question: how can we check if this bug has been properly filed?

Revision history for this message
detayls (davidt-detayls) wrote :

Yes, count me in as a potential brand new Ubuntu user that has been stopped dead in my tracks. My Inspiron 530s came loaded with Vista and I have it all nicely configured.

This sounds like a fixable issue. Given that I have no running version of Ubuntu to update, I will have to wait for a fix and a full description of how to create a new CD to boot from.

Thanks for supporting this. I have to imagine this architecture is fairly common and that we are not alone but part of a large number of frustrated people.

Changed in linux:
milestone: none → ubuntu-8.04.1
Revision history for this message
Greg Lund-Chaix (gchaix) wrote :

I can confirm this bug on my Dell Inspiron 530n (the FreeDOS version). Booted happily on Gutsy, but would not boot after upgrading to Hardy release version via update-manager.

Either adding "all_generic_ide" to GRUB *or* switching the SATA mode in the BIOS from "IDE" to "RAID" allowed it to boot normally.
kernel: 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux
dmidecode output: attached

Revision history for this message
Prinknash (colin-colinandjenny) wrote :

As Greg says above, there are 2 ways round this problem: adding "all_generic_ide" to GRUB or switching from IDE to RAID. Both work for me, whereas if I do neither my Inspiron 530 won't boot with Hardy. But are there any advantages/disadvantages to doing one rather than the other? I've settled on the switching IDE to RAID solution but would like to know if that's the optimum solution.

Revision history for this message
Konom (konomios) wrote :

I don't know if this is the exact same issue but I managed to "fix" Ubuntu 8.04 on my Dell Inspiron 530 by first switching to RAID, so I could boot into Ubuntu, then forcing the SATA driver to load before USB driver by following the instructions at this site:

http://linux.dell.com/wiki/index.php/Ubuntu_7.04/Issues/USB-SATA_race_condition_causes_hang

Although it's for 7.04 it worked for me on 8.04.

Revision history for this message
Konom (konomios) wrote :

Oops, I forgot to say that it worked after I switched back to IDE after doing the above

Revision history for this message
apt-drink (apt-drink) wrote :

@Konom: that recipe forces loading ata_piix before USB. But the thing is that inspirons 530 (at least mine) comes with ICH9 chipset, so the right driver should be the more advanced AHCI, which will use all the advanced capabilities in the ICH9...

Revision history for this message
Haz (haz2a) wrote :

I can confirm a similar problem with 8.04 Hardy (LTSP Server) on Dell Vostro 200.
Had to use the 'all-generic-ide' boot option to boot.
I used hyphens - does it work the same with underscores (as quoted above) rather than hyphens?

koma (ubuntu-zeno1)
Changed in linux-source-2.6.22:
status: Won't Fix → Confirmed
Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix
Tim Gardner (timg-tpi)
Changed in linux:
status: Triaged → Won't Fix
Changed in linux:
milestone: ubuntu-8.04.1 → none
status: Won't Fix → Triaged
milestone: none → ubuntu-8.10
description: updated
31 comments hidden view all 111 comments
Revision history for this message
Saivann Carignan (oxmosys) wrote :

Fabián Rodríguez : It is only the case when Windows is not pre-configured from the installation to support SATA and AHCI. If windows is not properly installed and don't have the drivers to support it, then it crashes on a BSOD because it is not able to access the drives.

Dell computers with pre-installed Windows XP correctly supports SATA, but they will crash with a BSOD if you install a clean Windows XP on them. Dell computers with pre-installed Windows Vista does not support SATA correctly and always crash with BSOD.

Revision history for this message
fidojones (fidojones) wrote :

I have the same error with a new DELL Vostro 401. I couldn't boot with any Live CD. No boot with ubuntu, and knoppix in any version. But at six time Ubuntu boot, but on new reboot fails again. I put "all_generic_ide floppy=off irqpoll" after -- in boot options and my Dell Vostro boot perfect all time, with live cd, and with hard disk.

Revision history for this message
Mario Limonciello (superm1) wrote :

A root cause to this issue has been found; The BIOS Is leaving an interrupt open to be serviced when handing off control to the OS. The uhci_hcd module shares the same interrupt line and disables the handler before the IDE interrupt is serviced.

In kernel 2.6.26 this issue doesn't occur in the exact same fashion, as it passes through, but the number of interrupts is now very large.

Changed in dell:
status: New → Confirmed
Revision history for this message
fidojones (fidojones) wrote :

Yes, I tried Ubuntu Intrepid live cd, and works fine. Kernel says in my Dell Vostro 401 that there is a problem in IRQ19 and recommend use irqpoll in grub boot options, but boot fine without problems.

Revision history for this message
Colin Ian King (colin-king) wrote :

Mario: I'm not seeing a large number of interrupts with 2.6.26-5-server on my DELL Inspiron 530 with the BIOS mode set to RAID - does the large number of interrupts occur in the non-RAID BIOS configuration?

Revision history for this message
Saivann Carignan (oxmosys) wrote :

I booted a Dell Vostro 200 with BIOS set to IDE 7 times with 2.6.26 kernel and it booted without problems each time. I can't say if there is a lot of interrupt, but I can't reproduce the initial bug which prevented the computer from booting.

Revision history for this message
Evan Huus (eapache) wrote :

Saïvann: I have a Hardy install that only failed once every 15 or 20 boots. It hasn't failed since adding the all_generic_ide option.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Revision history for this message
Traumflug (mah-jump-ing) wrote :

Intrepid Ibex on a Vostro 200 here. I just got the 2.6.27-1-generic kernel via update-manager, no special action taken. This kernel, as well as the 2.6.26 kernel boots fine with disks set to IDE mode. I tried only once before going back to RAID and didn't check the install CD.

Revision history for this message
schwaang (schwaang) wrote :

Leann Ogasawara: 2.6.27 seems to fix this bug for me.

The system is a Dell Inspiron 530s with Dell BIOS 1.0.5 which exhibits this bug in Hardy when using the 2.6.24 kernels.
I couldn't find 2.6.27 in official repos, but found release candidate 3 of 2.6.27 for hardy here: http://kernel.ubuntu.com/pub/next/2.6.27-rc3/hardy/

I installed it (sudo dpkg -i linux-image-2.6.27-1-generic_2.6.27-1.1_i386.deb) and edited /boot/grub/menu.lst to remove the all_generic_ide kernel option.

2.6.27 booted successfully[*] twice, and I verified that the all_generic_ide option was not used (grep "Kernel command line" /var/log/messages).

[*] Both times I booted 2.6.27, my hard disk made unusual "chattering" noises during boot and during the initial activity after gdm login. I rebooted 2.6.24 and confirmed it doesn't make those noises (neither does Vista on his same machine). I don't have non-subjective information to file a meaningful bug against 2.6.27, but it's not my imagination.

Revision history for this message
Colin Ian King (colin-king) wrote :

Testing with Linux 2.7.26-2 i386 on Dell 530 with latest BIOS (version 1.0.15 (06/20/2008) in BIOS IDE mode shows up tens of thousands of interrupts on IRQ 19, shared by uhci_hcd and ata_piix during kernel initialization. Debugging this clearly shows that these are IDE specific interrupts which are not handled until ata_piix is loaded. This is not an issue once ata_piix is loaded, and system behaves totally normally there after.

Suggested remedy is to re-order the loading of these two modules in initramfs, loading ata_piix first. Attached is a depdiff to patch the options file in module_init_tools.

This patch will reduce the number of unhandled IDE interrupts at kernel startup.

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

This should not be handled in modprobe options, since those modules may well be compiled in in future.

In particular, your patch would mean that anybody with a UHCI USB device will end up with ata_piix loaded!

You can express exactly the same requirement with a dependency in the module, though I'm sure you realise it's entirely bogus.

Changed in dell:
status: Confirmed → Fix Released
Revision history for this message
tikky (piotr-fuz) wrote :

Hello, I have downloaded Ubuntu 8.10 Alpha 6 and tried to run my Dell Vostro 200 tower from Live CD, however still is not possible to run Ubuntu.
I've got an error - Buffer I/O error (see attachment)
Any solution?

Revision history for this message
Saivann Carignan (oxmosys) wrote :

tikky : Can you use the "Check CD For Defects" menu of the LiveCD to verify if your CD damaged?

Revision history for this message
tikky (piotr-fuz) wrote :

I have tried to use this option to check my cd however it is the same error message.

Revision history for this message
Saivann Carignan (oxmosys) wrote :

tikky : Mmh, I'm not sure how you can verify if your CD (or CD drive) is damaged, but that really sounds like a hardware issue rather than a bug, though nothing proves it. Typically, to test devices bad blocks, badblocks can be used. I don't know if that can make sense for a CD drive but if you want to give a try, here's something you can do to verify if your CD or if your CD drive has problem :

1. Start your computer normally on the currently installed ubuntu version.
2. Insert your CD in your CD drive
3. launch this in a terminal : sudo badblocks -sv /dev/scd0 (scd0 might be scd1 if you have more than one drive)

If badblocks can read ALL sectors of the CD, it should not list any number. However if it fails to read any sector, it will list the sectors numbers that can't be read due to hardware errors, one by one.

Revision history for this message
tikky (piotr-fuz) wrote :

Hello,

I have checked cd for defects - no error found.
On laptop everything is ok. Have tried to butn another cd but still I am having the same problem, so still seems to be something wrong with Alpha 6.

Revision history for this message
Saivann Carignan (oxmosys) wrote :

tikky : If you tested the CD on another computer, that proves that the CD is OK, but that does not tell us if your CD drive has a hardware problem. What operating system do you have installed on that computer? It would be very important to do the test on that computer so we can know if it's bug or a hardware problem. I remember that Dell computers has a diagnostic utility partition. If you didn't erase that partition, it would be interesting to put your ubuntu CD in the CD drive, and then launch all Dell tests for that drive in the dell diagnostic utility.

Revision history for this message
tikky (piotr-fuz) wrote :

Have checked everything. This is definitely not a broken cd issue. Have tried few diffrent cd burned on diffrent drives from 2 separetly downloaded images and I am having still the same error.

Revision history for this message
Saivann Carignan (oxmosys) wrote :

tikky : Yes, we already discovered that it's not a CD issue, that's what I was asking you now to verify the drive. Can you re-read my last comment?

Revision history for this message
tikky (piotr-fuz) wrote :

Yes I can confirm that this is not a cd-drive fail. The computer is just 2 months old and is havin DVD+drive + additiona DVD reader. Have tried from both and I am having the same error message. I am just having one Dell machine so can't verify if the same problem is on other machine. Is there someone else I can do to help discovering the nature of the problem?

Revision history for this message
Saivann Carignan (oxmosys) wrote :

tikky : In case you didn't test the drive with dell diagnostic utility or with any other utility, you should definitively try this first. The fact that your computer is brand new does not mean that the drive is free from any defect. If your drives pass the dell diagnostic tests, can you go in the BIOS options of your computer, change controller mode from "IDE" to "RAID" and try to boot ubuntu again to see if it fixes the issue? Thanks for your feedback.

Revision history for this message
tikky (piotr-fuz) wrote :

After I change in BIOS hdd mode to RAID instead of IDE I am still having error. Also I've tried to run (in RAID mode) Kubuntu 7.04 feisty fawn but also I am having an error.
Please find attached files, maybe this can help.
I do not have Dell partition cause if I good remember I've deleted but I will double check.
I am not saying that my computer is good but I'never noticed any problem with optical drive.

As an addition I run my Windows XP with VirtualBOX installed and tried to boot Ubuntu from the same cd as a virtual machine and everythiong is working fine, so optical drive seems to be ok.

Revision history for this message
Saivann Carignan (oxmosys) wrote :

tikky : Thanks, we now have the confirmation that you really hit a bug. However, this is for sure another bug than the one described here. Can you open a new detailed bug report for "linux" that would mention globally what you tried so further work on this bug can take place? Thanks for the time you spent on this issue so far.

Revision history for this message
tikky (piotr-fuz) wrote :

As per your above advice I am opening new bug:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/275742

Revision history for this message
Jacques Le Roux (jacques-le-roux) wrote :

I gave a try to "sudo dpkg -i linux-image-2.6.27-1-generic_2.6.27-1.1_i386.deb" and it seamed to work without all_generic_ide. But I was unable to set the right resolution for my Dell 2005FPW flat screen. So I reverted to previous kernel using all_generic_ide
I use 8.04 LTS freshly updated, XP dual boot, with 2 SATA disk and an external USB.

I did not notice a loss of performance using all_generic_ide. Is this really a problem ?

Thanks

Revision history for this message
joe nowicki (jjoeandjo) wrote : Re: [Bug 153702] Re: Dell Inspiron 530 SATA drive not detected in IDE mode

had so many problems with dell inspiron 530 just purchased,returned unit to dell,not using ubuntu at this time.

----- Original Message -----
From: Jacques Le Roux
Date: Tuesday, October 14, 2008 4:47 pm
Subject: [Bug 153702] Re: Dell Inspiron 530 SATA drive not detected in IDE mode
To: <email address hidden>

> I gave a try to "sudo dpkg -i linux-image-2.6.27-1-
> generic_2.6.27-1.1_i386.deb" and it seamed to work without
> all_generic_ide. But I was unable to set the right resolution
> for my Dell 2005FPW flat screen. So I reverted to previous
> kernel using all_generic_ide
> I use 8.04 LTS freshly updated, XP dual boot, with 2 SATA disk
> and an external USB.
>
> I did not notice a loss of performance using all_generic_ide. Is this
> really a problem ?
>
> Thanks
>
> --
> Dell Inspiron 530 SATA drive not detected in IDE mode
> https://bugs.launchpad.net/bugs/153702
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Revision history for this message
Joris (jsnel) wrote :

I have a Ubuntu 8.10 Live Installer CD, from which I am trying to boot and I am experiencing the aforementioned error, best described by "ATA revalidation failed". The detailled message is:

ata3.00: status: {DRDY}
ata3.00: revalidation failed (errno=-2)
ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
ata3.00: cmd (etc)
             cdb
             res

This message repeats indefinitely.

The specification of this notebook are:
Fujitsu Siemens
Amilo Xa 2528
http://www.fujitsu-siemens.com/home/products/notebooks/amilo_xa_2528.html

As of now it is *impossible* to install Ubuntu 8.10 on this notebook using the Live CD (haven't tried the alternate installer but I assume it suffers from the same issue).

Revision history for this message
Mario Limonciello (superm1) wrote :

Joris:

Please open a different bug for your issues as its entirely different hardware.

> -----Original Message-----
> From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
> Joris
> Sent: Wednesday, November 05, 2008 8:03 AM
> To: <email address hidden>
> Subject: [Bug 153702] Re: Dell Inspiron 530 SATA drive not detected in
> IDE mode
>
> I have a Ubuntu 8.10 Live Installer CD, from which I am trying to boot
> and I am experiencing the aforementioned error, best described by "ATA
> revalidation failed". The detailled message is:
>
> ata3.00: status: {DRDY}
> ata3.00: revalidation failed (errno=-2)
> ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
> ata3.00: cmd (etc)
> cdb
> res
>
> This message repeats indefinitely.
>
> The specification of this notebook are:
> Fujitsu Siemens
> Amilo Xa 2528
> http://www.fujitsu-
> siemens.com/home/products/notebooks/amilo_xa_2528.html
>
> As of now it is *impossible* to install Ubuntu 8.10 on this notebook
> using the Live CD (haven't tried the alternate installer but I assume
> it
> suffers from the same issue).
>
> --
> Dell Inspiron 530 SATA drive not detected in IDE mode
> https://bugs.launchpad.net/bugs/153702
> You received this bug notification because you are a member of The Dell
> Team, which is subscribed to Dell Ubuntu Project.

Revision history for this message
tikky (piotr-fuz) wrote :

To: Marc Tardif

Hello,

My Dell machine (Vostro 200) have had the same problem, but Ubuntu 8.10 final release seems to be working fine.
Take a look here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/275742

Please chceck your Dell Inspiron 530 with final release.

Regards,

Tikky

Revision history for this message
Jacques Le Roux (jacques-le-roux) wrote :

Thanks For update Tikky,

Then I guess it should also work on 8.04 soon as it's an LTS version

Revision history for this message
Launchpad Janitor (janitor) wrote : Kernel team bugs

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Revision history for this message
Mario Limonciello (superm1) wrote :

This appears to be fixed in both 8.10 and 9.04. I'm closing the linux task

Changed in linux:
status: Triaged → Fix Released
Changed in module-init-tools:
status: New → Invalid
Revision history for this message
Jacques Le Roux (jacques-le-roux) wrote :

Do we need to upgrade to them or is 8.04 also fixed (I guess for a LTS it should but... ?)

Revision history for this message
tikky (piotr-fuz) wrote :

It is already fixed in 8.04

Revision history for this message
Bob Gotthardt (dell-gotthardt) wrote :

Confirmation:
I've upgraded my Dell Vostro 200 to 8.10 with no problem [or modifications].

Revision history for this message
Jacques Le Roux (jacques-le-roux) wrote :

I upgraded my Inspiron 530 to 8.10 but got an issue with nvidia driver (173.14.12) seems to be a known bug (conflict with kernel 2.6.27-11). I will wait to see if DKMS auto installation will work one day, using generic (not nvidia proprietary driver) is ok for now

Revision history for this message
candtalan (aeclist) wrote :

vostro 200

I tried the fix using the edit of menu.lst, however It did not work.

I have a thread in ubuntu forums:
http://ubuntuforums.org/showthread.php?t=1066139

However I then used the fix derived from the dell site information explained here:
Fixing the Vostro hang issue:
http://johnbokma.com/mexit/2008/08/05/fixing-the-vostro-hang-issue.html
which relates to a race condition.
this fix has worked.

Revision history for this message
Thorsten Glaser (mirabilos) wrote :

Nominating for hardy because RAID mode seems to have a capacity limit for
the discs of less than 1 TiB. I wonder, do all_generic_ide or the Dell workaround
have performance implications? This is also an issue for the hardy d-i which
won’t work in IDE mode – and large discs won’t work in RAID mode…

Changed in somerville:
status: New → Fix Released
no longer affects: dell
Revision history for this message
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305518

no longer affects: somerville
Displaying first 40 and last 40 comments. View all 111 comments or add a comment.
This report contains Public information  
Everyone can see this information.

Other bug subscribers