ATA Revalidation Failed

Bug #206635 reported by Stack on 2008-03-25
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6.24-12-generic

The system in question is a Dell Vostro 200. It originally ran Gutsy AMD64 and has been upgraded to Hardy AMD64 Beta. The system will not boot with the linux-image-2.6.24-12-generic kernel, but the old Gutsy linux-image-2.6.22-14-generic kernel will boot.

The errors I see are the following:

ata1.00: revalidation failed (errno=-5)

ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.00: cmd a0/00:00:00:24:00/00:00:00:00:00/a0 tag 0 pio 36 in
ata2.00: status: { DRDY }

The 'ata1.00' line will appear twice followed by many lines of the 'ata2.00' line.

Attached is my 'lspci -v'

Stack (sgerstacker) wrote :
Stack (sgerstacker) wrote :

I attempted to boot the amd64 install cd in live mode and came up with the same results.

I then booted the kernel from GRUB without the "quiet splash" options at the end, and the kernel booted correctly.

I also built the 2.6.24.4 kernel via the Git Kernel Build instructions. This kernel also exhibits the same problems. I get the errors with the "quiet splash" options and I can boot correctly without them.

Stack (sgerstacker) wrote :

Okay, ignore the "quiet splash" comment. This seems to happen randomly. Some times I can boot and some times I cannot.

I was able to catch more of the messages when the error occurs:

ata1.00 qc timeout (cmd 0x27)
ata1.00 failed to read native max address (err_mask=0x4)
ata1.00 failed to recover some devices, retrying in 5 sec
ata1.00 failed to read native max address (err_mask=0x4)
ata1.00: revalidation failed (errno=-5)

The point that this occurs in the boot is right before the line "* Reading files needed to boot" is displayed.

Also, this is BIOS 1.0.3 for the Dell Vostro 200 desktop

Just curious what happens if you try booting with "all_generic_ide". Also just curious what your dmesg output looks like when it does randomly boot successfully.

Changed in linux:
status: New → Incomplete
Andrew (andrew-t) wrote :

all_generic_ide seems to work for me on a Dell Inspiron 530 (Intel Q6660, G33/31 motherboard with SATA DVD and SATA HD)

Previous I was seeing these errors on boot:
[22,046581] irq 19: nobody cared (try booting with the "irqpoll" option)
[22.046669] handlers:
[22.046678] [<ffffffff880552c0?] (usb_hcd_irq+0x0/0x60 [usbcore])
[22.046692] [<ffffffff880552c0?] (usb_hcd_irq+0x0/0x60 [usbcore])
[22.411254] Disabling IRQ #19
[22.411647] usb 3-1: device not accepting address 2, error -71
[87.369892] ata1.00: revalidation failed (errno=-5)
[122.497506] ata1.00: revalidation failed (errno=-5)
[127.497562]ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
[127.497611]ata2.00: cmd a0/00:00:00:24:00/00:00:00:00:00/a0 tag 0 pio 35 in
[127.497674]ata2.00: status: { DRDY }
...
ata2: WARNING: synchronous SCSI scan failed without making any progress,

Stack (sgerstacker) wrote :

Here is the dmesg from a successful boot. Before this successful boot, it failed three times with error I reported above.

Stack (sgerstacker) wrote :

all_generic_ide gave me successful boots. I was able to start the system up 5 times without problems.

I then rebooted without all_generic_ide and noticed an error that was scrolling through the screen that I missed. It seems as though every time this error occurs, the system will not boot. I had to take a picture of it because there was no way I could write it all down.

The error suggested using the irqpoll option, which gave me 3 successful boots. No failures yet.

Stack (sgerstacker) wrote :

Upgraded to 1.0.11 BIOS. Nothing has changed.

I tried to see if there was a difference between a cold boot and a reboot, but it is still random. It took 5 failed boots before I got a successful one.

Stack (sgerstacker) wrote :

Kernel 2.6.24-14 has the same problem

Hamsterbacke (meistere2000) wrote :

Just a newbie but with AB9 Pro SATA1 & 2 (HDD and DVD) i got the same error like mentioned above.
But failures occour only for SATA Ports, where no devices are connected. Begins with:

ata3.00: revalidation failed (errno=-5)

Kernel version was 2.6.24-12. Perhaps this helps, i will try all_generic_ide.

stef33560 (stef33560) wrote :

This morning I had a ata1.00 : revalidation failed (errno=5)
I've set all_generic_ide and it solved my pb.

1 hour ago, I've rebooted my workstation, and booting stopped after probing USB, without any kind of message
I've set all_generic_ide + irqpoll => nothing
i've set irqpoll => nothing

Nothing works with kernel 2.6.24-16, but it's ok with 2.6.22-14

My station is a Dell Vostro 200

stef33560 (stef33560) wrote :

OK I found what was my problem : in /boot/grub/menu.lst, i've wrote :
# kopt_2_6_24=all_generic_ide

This is not enough ! this is right :

# kopt_2_6_24=root=UUID=f5f20edc-6383-4d7c-b360-ddbed78b03d3 ro irqpoll all_generic_ide

Bingo Tailspin (bingotailspin) wrote :

I have the same intermittent boot error on Hardy live CD and now that it's installed. This is a Dell Inspiron 530, bought with Ubuntu pre-installed :) This was not a problem on Gutsy. Oh well, I'll add the all_generic_ide and see if that works.

Bingo Tailspin (bingotailspin) wrote :

The all_generic_ide line seems to work for me on Inspiron 530. It's kind of sad that someone who bought a Linux box from Dell will have this issue, then have to edit the grub menu to get their computer back. Is this a Ubuntu bug or Linux bug?

Henning Sprang (henning) wrote :

I have the same error, also on the Dell Inspiron 530, after an upgrade from Gutsy to hardy.
But I cannot confirm that trying to boot the 2.6.22 Kernel which is still on the system after the upgrade works.
Adding all_generic_ide to the Kernel command line does the job.

What I find interesting is that I am quite sure that at first, even after the upgrade the system did at least one reboot quite well, as I did the upgrade some days ago, and rebooted after it as recommended. And the error only started to occur today, after I changed partitioning a bit.
But even resetting partitions to the previous state did not help - until I find this bug here.

Probably this came in parallel with another package update - so _maybe_ some changes in a security update in the last week did break the problematic things?!

Let me know if you need more data or info.

Henning Sprang (henning) wrote :

I found something interesting:

After adding the kernel-option all_generic_ide in the menu.lst to make this boot style persistent, I ran update-grub.

Here, I've been notified that if I want to keep the maintainer's version, or mine - the proposal was to keep mine.
Looking at the diff's it seems as the so-called maintainer version contained "all_generic_ide option.

I vaguely remember that after some of the upgrades last week I have seen that question before, but chosen the default "keep own version" without looking at what the maintainer's version had to offer.
(BTW, the menu.lst wasn't really changed).

Don't know how to classify this bug and what to do against it - definitely I'd expect a product bought with Ubuntu by a large manufacturer to have a better tested upgrade process to newer versions.

Chris Cotter (sirclown82) wrote :

Here is a screenshot of this bug. This was taken right after startup, but kept going. This error showed up with the latest kernels in both 32 and 64 bit versions.

http://ping.fm/p/vJAO5

TanaT (anatole-ng) wrote :

Hello ! Thank you steph33560.

Here is my experience, just to help finding this post while looking for " ata2.00 etc." in crawlers.

My Ubuntu 8.04 (hardy heron) kernel 2.6.24-19-generic didn't startup properly about 4 times per 5.
Hardware : Dell Vostro 200 (SATA disk).
It worked fine with 2.6.22-14-generic kernel version. And usually, it started up properly after one boot with that older kernel first.

Here is the busybox I got when it failed :
[code]
[...]ata1.00: revalidation failed (errno = -5)
[...]ata2.00: exception Emask 0x0 SAct 0x0 Serr 0x0 action 0x2 frozen
[...]ata2.00: cmd a0/00:00:00:24:00/00:00:00:00/a0 tag 0 pio 36 in
[...]ata2.00: satus { DRDY }
[...]ata2.00: WARNING synchronous SCSI scan failed
[/code]

What steph33560 wrote solve it, THANKS A LOT !

Help for beginners :
To apply the change in /boot/grub/menu.lst
Launch a Terminal (Application/accessories/Terminal)
Type the following commands :
$ cd /boot/grub
$ sudo cp menu.lst menu.lst.backup
(Type your own password when asked and go on.)
$ sudo vi menu.lst
-> You enter in vi editor to apply changes in the file menu.lst
-> Move forward until the first line begining with "kernel" (without any #)
-> Type i to begin inserting text
-> Delete "quiet splash" at the end of the line and replace it by "irqpoll all_generic_ide" as steph33560 said
-> Press Echap to finish insert mode
-> Type :wq and Enter to save and exit.
$ exit
You may now reboot your computer, it should work.

dedi (cndedicated) wrote :

I got this Problem with Hardy as soon as I boot with a realtime kernel. There are 2 different disks affected. With all_generic_ide the system did not boot anymore and irqpoll made no difference.

I dont know if this is related because it runs ok with the generic kernel. But thats all i found about this problem, nowhere any rt related topics.

NVIDIA® 750i, 2.6.24-19-rt

Parameswaran.K (paramesm-s-c) wrote :

Hey everyone,
 I have Dell Vostro 200 desktop with 2 GB RAM and 160 GB harddrive. During first boot after the installation

ata1.00: revalidation failed (errno=-5) error occurs so i attempted to boot in recovery mode. After the recover mode i selected the boot normally on the recovery mode choice and it booted without any error. Then i rebooted the machine in the normal mode it went smoothly without any errors.

Desktop : Dell Vostro 200
OS: Ubuntu 8.04.1 Server i386
Kernel: 2.6.24-19-server

Endolith (endolith) wrote :

I'm getting errors like this, but I assumed it was a flaw in the (brand new) hard drive. Is this a software error or hardware problem? What do you get when you run smartctl or your drive manufacturer's test tools? (SeaTools, for instance)

John (jptemp2001) wrote :

I have a Dell Vostro 200 and Ubuntu 8.04 LTS server and I've seen the same problem.

At first I thought it was a hard drive error but now seeing this thread (and it's only 10 months old) I'm thinking it's a software issue.

[...]ata1.00: revalidation failed (errno = -5)
[...]ata2.00: exception Emask 0x0 SAct 0x0 Serr 0x0 action 0x2 frozen
[...]ata2.00: cmd a0/00:00:00:24:00/00:00:00:00/a0 tag 0 pio 36 in
[...]ata2.00: status { DRDY }

I've tried SystemRescueCD e2fsck -c -v -f /dev/sda1 but it didn't help "normal boot". Strangely sometimes I do manage to get the system to boot using "recovery mode".

Kernel 2.6.24-19 and -24 (I upgraded once)

it's interesting that "recovery mode" /boot/grub/menu.lst has only "single"... but following the advice of
nano /boot/grub/menu.lst

find the first line with kernel (not #kernel).... it should be under title Ubuntu 8.0...
root (hd0,0)
kernel ...
delete the "quiet splash" bit and replace it with "irqpoll all_generic_ide"

Exit and Save (ctrl+x)

I also ran update-grub just in case...

THANKS! this SOLUTION WORKED for me!

Acetone (hormone) wrote :

 I using ubuntu 9.10 and the file /boot/grub/menu.lst doesn't exists... what is that I can do?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers