Ubuntu

Logitech webcam not working

Reported by Jono Bacon on 2012-06-26
126
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
High
Joseph Salisbury
Quantal
High
Joseph Salisbury

Bug Description

I have two cameras on my system (one internal webcam and in my screen and a USB Logitech C270). The internal camera works fine but the external USB camera does not work - it does not display in cheese or Google+ hangouts.

lsbusb device:

Bus 002 Device 016: ID 046d:0825 Logitech, Inc. Webcam C270

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-1-generic 3.5.0-1.1
ProcVersionSignature: Ubuntu 3.5.0-1.1-generic 3.5.0-rc3
Uname: Linux 3.5.0-1-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.2.5-0ubuntu1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: jono 1823 F.... pulseaudio
 /dev/snd/controlC0: jono 1823 F.... pulseaudio
 /dev/snd/pcmC0D0p: jono 1823 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf2520000 irq 45'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:14f1506e,17aa21cf,00100003 HDA:80862805,80860101,00100000'
   Controls : 38
   Simple ctrls : 13
Card1.Amixer.info:
 Card hw:1 'U0x46d0x825'/'USB Device 0x46d:0x825 at usb-0000:00:1d.0-1.1.3, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0825'
   Controls : 2
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 6144
   Mono: Capture 4190 [68%] [22.36dB] [on]
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Tue Jun 26 09:34:55 2012
HibernationDevice: RESUME=UUID=c393e27b-dbde-45a2-b4ad-173dc6b0fd94
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
MachineType: LENOVO 4239CTO
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-1-generic root=UUID=e2344bde-f7a5-45a6-9ea5-c99bb4243ae1 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-1-generic N/A
 linux-backports-modules-3.5.0-1-generic N/A
 linux-firmware 1.82
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/06/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8AET56WW (1.36 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4239CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8AET56WW(1.36):bd12/06/2011:svnLENOVO:pn4239CTO:pvrThinkPadT520:rvnLENOVO:rn4239CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4239CTO
dmi.product.version: ThinkPad T520
dmi.sys.vendor: LENOVO

Jono Bacon (jonobacon) wrote :
Joseph Salisbury (jsalisbury) wrote :

HI Jono,

Can you test the latest mainline kernel, to see if the bug is already fixed upstream? The latest mainline kernel is available at:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc4-quantal/

You will need to install both the linux-image and linux-image-extra .deb packages.

Thanks in advance!

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

One other quick question. Do you happen to know if the C270 webcam worked in earlier releases, such as Precise, Oneiric or Lucid?

Nicholas Skaggs (nskaggs) wrote :

I have the same issue with a Logitech C910 webcam. It *appears* like the 3.5 kernel regressed. My machine still sees the UVCcamera, but the driver fails to turn it on or make it usable. The older kernels work fine. Indeed, the webcam worked fine in precise and quantal, until the first 3.5 kernel landed.

@jsalisbury, note this thread:

http://<email address hidden>/msg47868.html

What should be do to help out here?

Joseph Salisbury (jsalisbury) wrote :

@Jono and @Nicholas,

I'd like to perform a kernel bisect to identify the commit that caused this regression. I would first like to confirm that you both are hitting the same bug.

@Jono, did your webcam work in Precise?

Clay Weber (claydoh) wrote :

Adding a "me-to" for my Logitech C510 webcam. It works in Precise (and previous versions), as well as in my previous Quantal install some weeks previously. Will test the mainline kernel shortly.

Ari Torres (kuvanito) wrote :

+Me
Logitech C500 does not work
Creative Live Cam VF0690 does not work

Steve Langasek (vorlon) wrote :

same issue on the Logitech C310.

Steve Langasek (vorlon) on 2012-06-28
tags: added: rls-q-incoming
Joseph Salisbury (jsalisbury) wrote :

I'd like to perform a bisect to identify the commit that caused this regression. We first need to identify the kernel version that introduced the regression. Can folks affected by this bug test the following kernels and report back the results:

v3.3: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/
v3.4: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-quantal/

It would be great if the latest mainline kernel can also be tested to see if this is fixed upstream:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc4-quantal/

Changed in linux (Ubuntu Quantal):
importance: Medium → High
Joseph Salisbury (jsalisbury) wrote :

If the bug does not exist in either v3.3 or v3.4, please test the following kernel:

v3.5-rc1: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc1-quantal/

Changed in linux (Ubuntu Quantal):
status: Confirmed → Incomplete

On Thu, Jun 28, 2012 at 02:59:40PM -0000, Joseph Salisbury wrote:
> I'd like to perform a bisect to identify the commit that caused this
> regression. We first need to identify the kernel version that
> introduced the regression. Can folks affected by this bug test the
> following kernels and report back the results:

> v3.3: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/
> v3.4: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-quantal/

I can tell you that I was using linux-image-3.4.0-5-generic version
3.4.0-5.11 in quantal without hitting this issue. So 3.5.0-1.1 is the first
quantal kernel package with this problem.

Joseph Salisbury (jsalisbury) wrote :

Thanks for the feedback, Steve. Can you test v3.5-rc1[0] to see if that's when it was introduced? I can then perform a bisect to find the offending commit.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc1-quantal/

Steve Langasek (vorlon) wrote :
Download full text (7.7 KiB)

So strangely, the camera has spontaneously started working for me again. No reboot, no nothing. Earlier, I was seeing the same kind of errors as Jono:

[51977.676130] 5:-1:4: cannot set freq 48000 to ep 0x86
[51977.680258] 5:-1:4: cannot set freq 48000 to ep 0x86
[51977.684611] 5:-1:4: cannot set freq 48000 to ep 0x86
[51977.688987] 5:-1:4: cannot set freq 48000 to ep 0x86
[51977.693848] 5:-1:4: cannot set freq 48000 to ep 0x86
<snip>
[51978.605699] uvcvideo: Failed to query (GET_DEF) UVC control 2 on unit 2: -71 (exp. 2).
[51978.609799] 5:-1:4: cannot set freq 48000 to ep 0x86
[51978.613916] uvcvideo: Failed to set UVC probe control : -71 (exp. 26).
[51978.618030] 5:-1:4: cannot set freq 48000 to ep 0x86
[51978.622147] uvcvideo: Failed to query (GET_DEF) UVC control 2 on unit 2: -71 (exp. 2).
[51978.626259] 5:-1:4: cannot set freq 48000 to ep 0x86
<snip>
[52035.239485] uvcvideo: Failed to query (GET_DEF) UVC control 2 on unit 2: -71
(exp. 2).
[52035.243607] uvcvideo: Failed to set UVC probe control : -71 (exp. 26).
[52035.247719] uvcvideo: Failed to query (GET_DEF) UVC control 2 on unit 2: -71 (exp. 2).
[52035.251833] uvcvideo: Failed to query (GET_DEF) UVC control 3 on unit 2: -71 (exp. 2).
[52035.255946] uvcvideo: Failed to query (GET_DEF) UVC control 7 on unit 2: -71 (exp. 2).
[52035.260063] uvcvideo: Failed to query (GET_DEF) UVC control 11 on unit 2: -71 (exp. 1).
[52035.264176] uvcvideo: Failed to query (GET_DEF) UVC control 4 on unit 2: -71 (exp. 2).
[52035.268292] uvcvideo: Failed to query (GET_DEF) UVC control 5 on unit 2: -71 (exp. 1).
[52035.272412] uvcvideo: Failed to query (GET_CUR) UVC control 11 on unit 2: -71 (exp. 1).
[52035.276521] uvcvideo: Failed to query (GET_DEF) UVC control 8 on unit 2: -71 (exp. 2).
[52035.280635] uvcvideo: Failed to query (GET_DEF) UVC control 1 on unit 2: -71 (exp. 2).
[52035.284777] uvcvideo: Failed to set UVC probe control : -71 (exp. 26).
[52035.288863] uvcvideo: Failed to query (GET_DEF) UVC control 2 on unit 2: -71 (exp. 2).
[52035.292997] uvcvideo: Failed to query (GET_DEF) UVC control 3 on unit 2: -71 (exp. 2).
[52035.297096] uvcvideo: Failed to query (GET_DEF) UVC control 7 on unit 2: -71 (exp. 2).
[52035.301208] uvcvideo: Failed to query (GET_DEF) UVC control 11 on unit 2: -71 (exp. 1).
[52035.305334] uvcvideo: Failed to query (GET_DEF) UVC control 4 on unit 2: -71 (exp. 2).
[52035.309697] uvcvideo: Failed to query (GET_DEF) UVC control 5 on unit 2: -71 (exp. 1).
[52035.313689] uvcvideo: Failed to query (GET_CUR) UVC control 11 on unit 2: -71 (exp. 1).
[52035.317811] uvcvideo: Failed to query (GET_DEF) UVC control 8 on unit 2: -71 (exp. 2).
[52035.321927] uvcvideo: Failed to query (GET_DEF) UVC control 1 on unit 2: -71 (exp. 2).
[52035.326038] uvcvideo: Failed to set UVC probe control : -71 (exp. 26).
[52035.330147] uvcvideo: Failed to query (GET_DEF) UVC control 2 on unit 2: -71 (exp. 2).
[52035.334261] uvcvideo: Failed to query (GET_DEF) UVC control 3 on unit 2: -71 (exp. 2).
[52035.338379] uvcvideo: Failed to query (GET_DEF) UVC control 7 on unit 2: -71 (exp. 2).
[52035.342480] uvcvideo: Failed to query (GET_DEF) UVC control 11 on unit 2: -71 (exp. 1).
[52035.346596] uvcvideo: Failed ...

Read more...

Joseph Salisbury (jsalisbury) wrote :

Interesting. And you are running the latest Quantal kernel? Can you post the output of uname -a

@Jono, is your webcam still not working?

Steve Langasek (vorlon) wrote :

On Thu, Jun 28, 2012 at 07:12:04PM -0000, Joseph Salisbury wrote:
> Interesting. And you are running the latest Quantal kernel? Can you
> post the output of uname -a

$ uname -a
Linux virgil 3.5.0-1-generic #1-Ubuntu SMP Tue Jun 19 14:24:43 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
$

Tessa Lau (tlau) wrote :

Me too. My Logitech C270 does not work with this kernel:

% uname -a
Linux amor 3.5.0-2-generic #2~precise1-Ubuntu SMP Tue Jun 26 15:00:18 UTC 2012 i686 i686 i386 GNU/Linux

Joseph Salisbury (jsalisbury) wrote :

@Tessa,

Can you test v3.5-rc1[0] to see if that's when this regression was introduced? I can then perform a bisect to find the commit that caused the regression.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc1-quantal/

Pete Graner (pgraner) wrote :

Same thing here for me, I filed 1021261 which I duped to this bug. I have a Logitech C910 Web cam

tags: added: regression
Nicholas Skaggs (nskaggs) wrote :

Sorry, somehow I wasn't subbed to this bugthread :-) I can bisect away now.

@Joseph, I tried the mainline kernel you linked. My USB is completely useless so therefore the webcam doesn't work. But then again, neither does mouse, keyboard, networking, or video ;-)

Joseph Salisbury (jsalisbury) wrote :

@Tessa,

Were you able to test the v3.5-rc1[0] kernel?

@Nicholas,

Did you test the -rc1 kernel?

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc1-quantal/

Changed in linux (Ubuntu Quantal):
status: Incomplete → Confirmed
tags: added: kernel-key
Nicholas Skaggs (nskaggs) wrote :

@Joesph, yes I tested -rc1. I installed this exact kernel;

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc1-quantal/linux-image-3.5.0-030500rc1-generic_3.5.0-030500rc1.201206022335_amd64.deb

And yes, lots of drivers were missing for my hardware, but apparently USB support is completely broken for me on that kernel, so sadly I can't even use my mouse and keyboard. No matter, the webcam is also USB so therefore it wouldn't work. Since no USB devices work however, it's unclear what value we can derive from it. Send me a list of kernels, I can walk through them.

Joseph Salisbury (jsalisbury) wrote :

Thanks for the feedback, Nicholas.

Can you give v3.4[0] a try(To confirm the webcam works) Then give v3.5-rc2[1] a try. I'd like to find the first kernel version that causes the regression. I can then perform a kernel bisect.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-quantal/
[1] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc2-quantal/

I believe I have a Logitech external cam somewhere. I'll see if I can find it, so I can test here.

Nicholas Skaggs (nskaggs) wrote :

This bug also might be coming into play here as a seperate issue, or not..

https://bugzilla.kernel.org/show_bug.cgi?id=35922

However, like pete I'm getting "cannot set freq 32000 to ep 0x86" over and over and over on the command line.

Joseph Salisbury (jsalisbury) wrote :

Hi All,

I was able to reproduce this bug with a Logitec C250. It's going to be a little difficult to bisect since I ran into the same USB bug mentioned in comment #21.

The USB bug was fixed in v3.5-rc3, and I was able to reproduce the webcam bug in that kernel.

So to recap testing:

v3.4 does not have this bug.
v3.5-rc1 has a separate USB bug preventing testing of the webcam.
v3.5-rc2 has a separate USB bug preventing testing of the webcam.
v3.5-rc3 the USB bug is fixed and the webcam bug is reproduced.
v3.5 daily still has the webcam bug.

It looks like I would first have to bisect between v3.5-rc2 and v3.5-rc3 to find the commit that fixes the USB bug. I can then use that patch to fix up rc1 and rc2 to find if either of them introduced the webcam bug for this bug report.

I'll review the git logs and see if anything sticks out.

Jono Bacon (jonobacon) wrote :

Apologies for the delay in helping with this, Joe. Let me know if you want me to run a kernel to test.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Joseph Salisbury (jsalisbury) wrote :

May be affecting the installer: bug 875297

Joseph Salisbury (jsalisbury) wrote :

This bug still exists in latest mainline -rc6. I'm continuing to bisect.

Joseph Salisbury (jsalisbury) wrote :

I've bisected down to the commit that is causing this bug:

edcd3633e72a1590c4cf46befe5e6cd03b5aec3e - ALSA: snd-usb: switch over to new endpoint streaming logic

However, the logic that caused this regression is in the following commit:
 8fdff6a319e7dac757c558bd283dc4577e68cde7 - ALSA: snd-usb: implement new endpoint streaming model

I attempted a simple revert, but it is not possible. The following commit is also involved:
d399ff9593e088d33fb38f5206c6427825892baa - ALSA: snd-usb: remove old streaming logic

This last commit just removes the obsolete unused code, which was causing a kernel compile error.

I'll continue to work on this bug and send details upstream.

Joseph Salisbury (jsalisbury) wrote :

Message sent upstream: https://lkml.org/lkml/2012/7/9/658

Changed in linux (Ubuntu Quantal):
status: Confirmed → In Progress
assignee: nobody → Joseph Salisbury (jsalisbury)
Joseph Salisbury (jsalisbury) wrote :

I created a test kernel for this bug. The test kernel can be downloaded from:
http://people.canonical.com/~jsalisbury/lp1018020/

Can folks affected by this bug test this kernel and report if you webcam works or not?

Thanks in advance

The attachment "0001-ALSA-snd-usb-fix-calls-to-usb_set_interface.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Clay Weber (claydoh) wrote :

This fixes the webcam issue for me, I detect no other issues so far.

Rattatoue (programcode) wrote :

Same here, Logitech C210 webcam. Just tested your kernel out and kept a close eye on Dmesg. Works great no issues at all and fixes all my issues I had with 3.2 as well. Thanks for the hard work Joseph. Appreciate it.

Joseph Salisbury (jsalisbury) wrote :

@Clay and @Rattatoue

Thanks for testing. There still may be an issue with this patch. Can you test with the webcam on for an extended period of time and report back if it fails?

Pete Graner (pgraner) wrote :

@Joseph,

Works for me on my two affected systems, as a side affect my USB headset now starts working again.

Pete Graner (pgraner) wrote :

@Joe

It stopped working:

[ 214.960361] usb 1-1.2.1: new high-speed USB device number 6 using ehci_hcd
[ 215.762966] uvcvideo: Found UVC 1.00 device <unnamed> (046d:0821)
[ 215.775812] input: UVC Camera (046d:0821) as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2.1/1-1.2.1:1.2/input/input17
[ 239.611327] uvcvideo: Failed to set UVC probe control : -71 (exp. 26).
[ 239.615457] uvcvideo: Failed to set UVC probe control : -71 (exp. 26).
[ 239.619332] uvcvideo: Failed to set UVC probe control : -71 (exp. 26).

pgraner@zorak:~$ uname -a
Linux zorak 3.5.0-4-generic #4~lp1018020v1 SMP Tue Jul 10 23:59:47 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

That was using cheese, it worked for a few sec then went black and the errors hit dmesg.

Joseph Salisbury <email address hidden> wrote:

>@Clay and @Rattatoue
>
>Thanks for testing. There still may be an issue with this patch. Can
>you test with the webcam on for an extended period of time and report
>back if it fails?
>
>--
>You received this bug notification because you are subscribed to the
>bug
>report.
>https://bugs.launchpad.net/bugs/1018020
>
>Title:
> Logitech webcam not working
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/linux/+bug/1018020/+subscriptions

I used my webcam for approximately an hour and a half on Skype with no issues, though I did not monitor any logs while doing so.
--
Clay Weber

Jono Bacon (jonobacon) wrote :

Joe, is there any x86 kernels to test this instead of AMD64?

--
Jono Bacon
Ubuntu Community Manager
www.ubuntu.com / www.jonobacon.org
www.identi.ca/jonobacon www.twitter.com/jonobacon

Joseph Salisbury (jsalisbury) wrote :

Hi Jono,

I just uploaded an x86 test kernel.

Just so folks know, there will be another new test kernel coming soon.

Thanks all for testing!

Rattatoue (programcode) wrote :

I have an update unfoturnately. It was working great on first boot. Then randomly after about 19 hours, it randomly just stopped working. Reboot even, still same problem and it this is in the dmesg logs.

[ 101.391416] usb 1-4.3: new high-speed USB device number 8 using ehci_hcd
[ 101.644490] uvcvideo: Found UVC 1.00 device <unnamed> (046d:0819)
[ 101.745423] input: UVC Camera (046d:0819) as /devices/pci0000:00/0000:00:12.2/usb1/1-4/1-4.3/1-4.3:1.0/input/input17
[ 101.857030] 8:3:1: cannot get freq at ep 0x86
[ 101.870356] 8:3:2: cannot set freq 24000 to ep 0x86
[ 101.894575] 8:3:3: cannot set freq 32000 to ep 0x86
[ 101.918803] 8:3:4: cannot set freq 48000 to ep 0x86
[ 101.931806] usb 1-4.3: USB disconnect, device number 8

So it was working great, then stopped.

Joseph Salisbury (jsalisbury) wrote :

Version 2 of patch to prevent crash after extended webcam use.

Rattatoue (programcode) wrote :

By any chance, if its not to big of a problem. Could you do the debs again with this one as well? I don't know how to apply patches and that. I just used the deb files last time.

Joseph Salisbury (jsalisbury) wrote :

I created a second test kernel for this bug. The test kernel can be downloaded from:
http://people.canonical.com/~jsalisbury/lp1018020/

This new kernel should fix the issue with the webcam crashing after a period of time.

Can folks affected by this bug test this kernel and report if you webcam works or not?

Thanks in advance

Joseph Salisbury (jsalisbury) wrote :

Just a reminder, please install both the linux-image and linux-image-extra .debs.

Rattatoue (programcode) wrote :

Its working as of right now, took a few times to get it to detect it again after reinstalling the .deb and restarting the computer. Had to unplug and replug back in a few times. Now its being detected and working good. Will post an update in the morning if its still working or times out again.

Rattatoue (programcode) wrote :

Still working here, so far no drop. All good.

Pete Graner (pgraner) wrote :

@Joe,

So far so good, cheese has been running for about 20 min with no issues. Tried a quick google hangout and it worked perfectly.

Joseph Salisbury (jsalisbury) wrote :

I created a third(Should be final) test kernel for this bug. The test kernel can be downloaded from:
http://people.canonical.com/~jsalisbury/lp1018020/

The third test kernel has the string 'v3' in the .deb file name.

Can folks affected by this bug test this kernel and report back?

Thanks in advance

Joseph Salisbury (jsalisbury) wrote :

Can folks that test the v3 kernel report back if they see any delay at the login screen while testing the kernel?

Rattatoue (programcode) wrote :

No drop in webcam for me and the login didn't really look delayed to me, but might just be because im use to a little longer in login as normal.

tags: removed: rls-q-incoming
Joseph Salisbury (jsalisbury) wrote :

@Rattataoue,

Thanks for testing.

Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Joseph Salisbury (jsalisbury) wrote :

It looks like the fix for this bug has been accepted into the latest mainline kernel. If you are affected by this bug, please test the v3.5-rc7 kernel, which can be downloaded from:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc7-quantal/

You will need to install both the linux-image and linux-image-extra .debs

Rattatoue (programcode) wrote :

Its hard to say if the audio with the webcam issue is fixed. As of that kernel update. My audio is messed up. Any sounds through my speakers sound far away and static. I can faintly hear people with sound maxed up. Just booted back into the previous kernel, no issues there at all. No can't set freq messages in the dmesg like before. No errors in the log at all. Its just my audio now on the machine is messed up on this kernel. I can hear myself when I test it out on audacity the audio from the webcam. So it does seem to be working, just seems like something else messed up in the process.

Volume MAXED out, sounds as if its on 1% level. Alsamixer also shows it maxed out as well.

Rattatoue (programcode) wrote :

Joseph, by chance can you remove my above post. I found out the issue, some how between the two kernels, pulse audio was switching my outputs. From my headphones to my speakers then back to my headphones. So 3.5 rc4 was speakers, 3.5 rc7 was headphones. My headphones are right next to my speakers. Hence the audio problem. I checked 3.5 rc7 once I realized this and sound works great and webcam so far no issue. Have yet to run it for the 14 hrs like did before about to start that. Again sorry for the bug report. Was user error not kernel.

Tessa Lau (tlau) wrote :

Sorry, I thought I was subscribed to this bug's email, but apparently I wasn't. I also experienced the same USB bug with the earlier kernels which prevented me from bisecting the error. But I can confirm that the webcam works with the 3.5-rc7 kernel in #54. Thanks Joseph!

Joseph Salisbury (jsalisbury) wrote :

The latest Quantal kernel has be re-based to upstream v3.5-rc7. Can folks affected by this bug upgrade, and report back if this bug is fixed?

Thanks in advance

Miguel Rodríguez (migrax) wrote :

It works now for me.

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in linux:
status: Confirmed → Fix Released
obitori (junk-taiotoshi) wrote :

I was experiencing similar problems to those described above. Both Skype and PulseAudio see my VF0380 Live! Cam Optia Pro (Creative), but I get neither working microphone or working video in Skype. I have sound and I have verified my settings in Skype. I changed video to the Optia Pro. I have an HDTV card too that Skype originally mistakenly selected, but that was an easy fix. I get know microphone input response from the Skype call testing call.

I installed the below kernel:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc7-quantal/

This did not fix the problem for me. Please let me know if you would like additional information/diagnostic data.

Thanks for your effort for us users!

Bud

Gramler (maxf) wrote :

HI

Running a Logitech, Inc. Webcam C310 on latest Quantal mainline kernel.

I see lots of " cannot set freq 48000 to ep 0x86" in log
Also microphone on cam stops working intermittently
Behaviour was identical in Precise.

I found that a workaround for this that works (mostly) is to keep camera unpluged during boot or "wake from suspend" and repluging it in after boot.

owever this is not a surefire fix as I have seen it "triggred" random.

Unplugging and replugging the Cam helps, but tends to crash things like skype

This seems to be issue that occurs widely .
There are several references that claim that this is due to something in snd-usb-audio going wrong see here for one:
https://bugzilla.redhat.com/show_bug.cgi?id=663583

Here is a claimed workaround:
http://www.techytalk.info/logitech-e3500-webcam-and-cannot-set-freq-16000-to-ep-0x86/

I will try it...

Claude PESTY (claude-pesty) wrote :

Hi,

Like in previous post, seems I am still affected by the bug, although I run the latest Quantal kernel, supposed to have integrated for a while the fix released in v3.5-rc7 :

$ uname -a
Linux COYOTE 3.5.0-21-generic #32-Ubuntu SMP Tue Dec 11 18:51:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

$ lsusb
Bus 001 Device 002: ID 046d:0825 Logitech, Inc. Webcam C270

I have tons of "cannot set freq 48000 to ep 0x86" in Syslog, and the boot randomly hangs very often, more than 50% of times. The login screen appears, but without the background theme : it's all blue-purple, and the mouse and keyboard (both USB, like the webcam) are unresponsive. Sometimes it suddenly unfreezes after a while (10 to 30 seconds or so), but most of the times never : I have to hard reset the PC.
The problem disappears if I uninstall the "indicator-sound" package, which confirms, like the "unplug during boot" workaround, that the issue with Logitech USB webcam is only in startup sequence.

I am sorry but I think the bug should be reopened rather than let in the "Fix Released" status ...

The original issue is, at least for me and other testers, solved.

Please bisect your issue or test a few kernel version like one before v3.5, v3.5-rc7 (where some found the issue to be solved) and maybe the current stable kernel v3.7. They should be all available from the ubuntu repositories.

I would also suggest that you open a new bug report with your findings.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.