xul-ext-lightning is only available in English

Bug #545778 reported by YannUbuntu on 2010-03-24
556
This bug affects 131 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Invalid
Medium
One Hundred Papercuts
Medium
Unassigned
Ubuntu Translations
Medium
Unassigned
lightning-sunbird (Ubuntu)
Medium
Unassigned
thunderbird (Ubuntu)
High
Olivier Tilloy
Xenial
High
Olivier Tilloy
Bionic
High
Olivier Tilloy
Disco
High
Olivier Tilloy

Bug Description

*******
 ISSUE
*******

HOW TO REPRODUCE

1. Change the user session language to other different than English.
2. In Thunderbird, open the calendar

EXPECTED BEHAVIOUR

- The calendar interface to be in the session language.

REAL BEHAVIOUR

- The calendar is in English.

RELEVANT DETAILS

- None.

**********
 SOLUTION
**********

WORK-AROUND

- None known.

FIX

- <http://www.smoose.org/blog/ubuntu-localized-lightning-extension>.

REGRESSION POTENTIAL

- Since no code needs to be modified, the regression potential is very low.

****************
 TECHNICAL INFO
****************

Binary package hint: lightning-extension

John Vivirito (gnomefreak) wrote :

The Sunbird task is not needed since the source package is lightning-sunbird and this task was opened as an upstream bug however this is not an upstream bug but ours.

Changed in sunbird:
status: New → Invalid
John Vivirito (gnomefreak) wrote :

We should look at this more when we start packaging 1.0 for Lucid. Sunbird will also stop support once 1.0b1 is released (it has been upstream but we have not yet) only Lightnting will be supported after 1.0b1

Still not sure if we will leave sunbird to build same version after EOS but at this time i think we will package it through the 1.0 series for Lightning. Maybe re think this once TB3.1 is released to package it with 3.1

Changed in lightning-locales:
status: New → Confirmed
Changed in lightning-sunbird (Ubuntu):
status: New → Confirmed
tags: added: translations
tags: added: maverick natty
David F. (malteworld) wrote :

I used the old debian build scripts of lightning-extension-locales to build a new package at https://launchpad.net/~malteworld/+archive/xul-ext/

Nick (nick222-yandex) wrote :

But what about Ubuntu 11.04-64, Thunderbird 5.0b1, Lightning 1.0b4pre ?

tigroo (tigronet) wrote :

One more: I'm under ubuntu natty 11.04. The package at https://launchpad.net/~malteworld/+archive/xul-ext/ (for oneiric) can be used for natty?

David F. (malteworld) wrote :

I uploaded a new source package for Lightning 1.0b5 to https://launchpad.net/~malteworld/+archive/xul-ext/ . I don't know, if it's going to be built any time soon, because translation packages have lowest priority.
You can still download the source package and build it by yourself. Ask me for help, if you need any. Alternatively I could upload the pre-built packages somewhere else.

Nick (nick222-yandex) wrote :

Ubuntu 11.04-64 - I cannot see it by Synaptic. May be it for i386?

David F. (malteworld) wrote :

As I said, launchpad hasn't built the package yet (see https://launchpad.net/~malteworld/+archive/xul-ext/+build/2716946 ). Only the source is available until then.

tigroo (tigronet) wrote :

Cool..but I'm on holidays :).
i'll be able to compile and provide it only on september... Anybody else?

David F. (malteworld) wrote :

Good news, folks. Launchpad built the translation packages in https://launchpad.net/~malteworld/+archive/xul-ext/ .

Mikołaj Lechtański (mikolec) wrote :

I can't install the package... I have added the PPA to the sources, and then I tried installing the xul-ext-lightning-locale-pl (polish) package. It says something like that "I should repair the package first". I use natty amd64 architecture... any clue?

David F. (malteworld) wrote :

Which package does that repair request relate to? Could you post/attach the output of "dpkg -i xul-ext-lightning-locale-pl_1.0~b5-0ubuntu0~malteworld4_all.deb"? If you don't have the package somewhere already, download it from https://launchpad.net/~malteworld/+archive/xul-ext/+files/xul-ext-lightning-locale-pl_1.0%7Eb5-0ubuntu0%7Emalteworld4_all.deb first or look for it in your /var/apt/cache (or something like that). Could you do the same with xul-ext-lightning-locale-de_1.0~b5-0ubuntu0~malteworld4_all.deb for comparability, because that's the one I'm using?
Series and architecture shouldn't matter, because there's no native code in the localization packages.

David F. (malteworld) wrote :

Ah, please add the "--debug=433" switch to the dpkg call, and of course you need super user privileges to install packages, so use "sudo dpkg --debug=433 -i xul-ext-lightning-locale-pl_1.0~b5-0ubuntu0~malteworld4_all.deb".

Jbyvosges (j-lbarbry) wrote :

It is because of many small things like that that many people still prefer Windows ...

Torsten Krah (tkrah) wrote :

Same does still apply at the moment to the 1.2.x xul-ext-lightning package into the oneiric-proposed tree, guess it will merge to oneiric-updates tree soon.

tags: added: oneiric
Mossroy (mossroy) wrote :

Same issue on Ubuntu 12.04 beta 1.
It's a big problem since it looks like the easiest way to handle calendars on this version of Ubuntu :
- Sunbird is not supported any more
- Evolution has been replaced by Thunderbird on the Ubuntu CD

Lightning works quite well in my opinion, and is well integrated with Thunderbird.
But users will expect it to be translated in their own language, by default...

Attila Hammer (hammera) wrote :

I now tryed installing xul-ext-lightning-locale-hu package in my Precise system with ppa:malteworld/xul-ext repository.
Unfortunately installation is impossible now, because in Ubuntu Precise factory have xul-ext-lightning 1.3+build1-0ubuntu1 version, but the PPA repository containing xul-ext-lightning-locale-hu 1.4 version with depending xul-ext-lightning 1.4 or 1.5 version.
Future will be awailable official Precise repositories the Lightning extension locale packages?
This is important when oftener will be upgrading Thunderbird version with newest version the central repository. Will be follow up the xul-ext-lightning and xul-ext-lightning-locale-xx packages the actual Thunderbird version with awailable the central repository to not happen Lightning extension is incompatible the actual Thunderbird version?

Attila

David F. (malteworld) wrote :

You can still use https://launchpad.net/~ubuntu-mozilla-security/+archive/ppa/+sourcepub/2395551/+listing-archive-extra in that case or rebuild xul-ext-lightning-locales 1.3 from the source package.

David, I doed 1.3 version rebuild your source package, me works fine.
Possible I not choosed right way, but I Changed dependencies with
following in debian/control file:
Depends: xul-ext-lightning (>= 1.3), xul-ext-lightning (<< 1.5)
Of course, I edited the debian/changelog file, and renamed with
lightning-1.4.locales.xpi file with lightning-1.3.locales.xpi in the
toplevel source directory.
Installation is works good for my system, and I using Lightning 1.3
Ubuntu 12.04 awailable version with hungarian locale.

If I used a horrible method the 1.3 Lightning localization packages
generation, can you describe me officialy how can possible generating a
new localization package if have a new stable version of
xul-ext-lightning package in the official Ubuntu repository? I newer
created Mozilla localization packages, but very interesting how works
this type packaging.

Attila

Attila, your method will leave strings untranslated, that have been removed from the newer version of Lightning. I wrote a short, sketched description on how I intended it to work: http://pastebin.com/2qiEir7x

Problem still in precise and lightning 1.7

tags: added: precise

Added mozilla-thunderbird.

Rationale:
Thunderbird replaces evolution as default mail client since 11.10
This localisation problem makes the calendar component unusable to non English users and doesn't allow the usage as PIM replacement for evolution.

Mossroy (mossroy) wrote :

A workaround for me was to install the Lightning plugin via the extension manager of Thunderbird.
It's slightly different because this plugin is installed specifically for the current user, and not for all users on the machine.
And the upgrades are handled by Thunderbird itself, instead of Ubuntu.
But it works quite well, and is in my language

I might be proven wrong, but why don't you just quit trying to hunt the extensions (aka add-ons) of Thunderbird (and Firefox, btw)?

It's much more reliable, much more user-friendly to not handle add-ons for those products at all in the package management system, when handling is not done in a timely fashion. And it is never - neither on Debian, nor on Ubuntu, as we see in this case.

Given that this bug derives(ok...) from 2010, it is nothing more than kind of ridiculous to even discuss it in 2012(!). Easy to fix, but noone willing/free to do: Let it be, hm?

So, give up trying to keep up with add-ons in TB or FF, you would not succeed, as history tells.

If you do, I myself would no longer notice it on my desktop, as I switched to XFCE from the U-style some time ago.

Have a nice day,

Rob

The problem with this workaround is the roll out for all users in an organizational environment (e.g. company).

Name the companies that roll-out U and are above 50+-, please.

Sorry to have trolled, but be serious: What do you intend to say, a company sticking with a non-localized Lightning living for years? This can't be true, give hands.

So, it might be noone is using the U-style extension, even in larger installations, or noone cares about it, especially in low-scalings.

The third option? I cannot think of.

Rob

Changed in mozilla-thunderbird (Ubuntu):
status: New → Confirmed
Fabián Rodríguez (magicfab) wrote :

It seems there are no longer lightning-extension-locale-* packages in Ubuntu.

In Debian such packages are under icewowl-l10n-*.

tags: added: trusty utopic
removed: maverick natty oneiric

It impacts accessibility of a non-core package.

description: updated
summary: - Lightning-extension is not localized
+ lightning-extension is not localized
Changed in lightning-sunbird (Ubuntu):
importance: Undecided → Medium
Changed in mozilla-thunderbird (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
tags: added: i18n

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 Iceweasel/31.1.0
Build ID: 20140903072827

Steps to reproduce:

On vanilla versions of Ubuntu 12.04 LTS and Ubuntu Gnome 14.04 (in English), I installed Thunderbird and Lightning standard packages and I added support for French language, which installed the appropriate language packs for the OS and applications. I also expected this to be the case for Lightning.

Actual results:

When starting Thunderbird and accessing the calendar, the interface for Thunderbird is in French as expected, however in LIghtning it remains in English. Upon closer examination, there were no localization-specific packages installed for Lightning, so they were not installed.

Expected results:

It seems at some point there were lightning-extension-locale-* localization packages in Ubuntu and those should have been installed.

In Debian, such packages can be found as iceowl-l10n-*.

A bug report in Ubuntu describes this problem since 2010:
https://bugs.launchpad.net/ubuntu/+source/lightning-sunbird/+bug/545778

Perhaps Mozilla and Ubuntu contributors could collaborate in importing the Debian packages under the appropriate names used in Ubuntu.

no longer affects: hundredpapercuts/utopic
no longer affects: hundredpapercuts/trusty
Changed in lightning-sunbird (Ubuntu):
status: Confirmed → Triaged
Changed in mozilla-thunderbird (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: Confirmed → Triaged
description: updated
Fabián Rodríguez (magicfab) wrote :

I am sorry, a small typo made it into my previous comment:

In Debian such packages are under iceowl-l10n-* (not icewowl-l10n-*).

Changed in sunbird:
importance: Undecided → Unknown
status: Invalid → Unknown

You can download the official Lightning releases here: <https://addons.mozilla.org/de/thunderbird/addon/lightning/versions/> They include all localizations.

For problems with third-party packages I'd suggest to contact the third-party package creator.

Changed in sunbird:
importance: Unknown → Medium
status: Unknown → New
Changed in lightning-sunbird (Ubuntu):
status: Triaged → Invalid
affects: sunbird → thunderbird
affects: mozilla-thunderbird (Ubuntu) → thunderbird (Ubuntu)
affects: lightning-locales → ubuntu-translations
summary: - lightning-extension is not localized
+ xul-ext-lightning is only available in English
Changed in ubuntu-translations:
importance: Undecided → Medium
status: Confirmed → Triaged
Narcis Garcia (narcisgarcia) wrote :

Did someone tried with Debian's packages iceowl-l10n-* ?

Changed in thunderbird:
status: New → Invalid
Whoopie (whoopie79) wrote :

This gets more urgent as the workaround to install the xpi addon to get locale support doesn't work anymore with thunderbird 60.2.1.

Please add locale support, thanks!

Rolando Gorgs (rolandogorgs) wrote :

The Thunderbird people don't provide current Lightning versions in their AddOn repository anymore because they integrated Lightning in their Thunderbird builds. It is a real shame that this localization issue persists for nearly one decade now. Because of this shortcoming (missing translations for xul-ext-lightning) the old "workaround" is present in a lot of local language ubuntu community wikis. At this moment you only have the choice between using outdated Thunderbird with localized (old) Calendar or using current Thunderbird without calendar localization. So PLEASE fix this bug asap and don't wait another 8 years!

Rolando Gorgs (rolandogorgs) wrote :

https://ftp.mozilla.org/pub/calendar/lightning/candidates/6.2b6-candidates/build1/linux-x86_64/

here you only get betas of Lightning and not the final versions. And also no automated updates at all. So this can only be a temporary limited workaround.

Jeffery To (jefferyto) wrote :

I've extracted all of the language/locale versions of Lightning 6.2.2.1 from the Thunderbird 60.2.1 Linux (binary) release tarballs, they are available at:

https://www.dropbox.com/sh/w84dtrc73e90j3p/AABC5CeNN-ZwoNgq9m1hQUs4a/thunderbird-60.2.1?dl=0&lst=&subfolder_nav_tracking=1

If you are reluctant to install an extension from some random Internet person (I wouldn't blame you), you can also download the release tarball for your locale from the Thunderbird homepage (https://www.thunderbird.net/), then extract the .xpi file from the thunderbird/distribution/extensions directory (inside the archive).

Coeur Noir (coeur-noir) wrote :

@Rolando Gorgs : I totally agree with you, it's a temporary limited workaround and I did not pretend anything else ;-)

Rolando Gorgs (rolandogorgs) wrote :

I don't see any progress here. Meanwhile some corresponding Bugs at Thunderbird's Bugzilla have been closed because this localization issue is a packaging problem and they decided not to provide any new (localized) Lightning versions via AddOn functionality because they already ship it with thunderbird. But ubuntu doesn't. Fact is that there is no way (aside from extracting lightning from the official Thunderbird distributioin) to have Thunderbird with localized calendar in ubuntu.

This package bug should have been resolved 8,5 years ago but the users were pushed to install lightning from AddOns instead (a dirty workaround in my eyes). Now this option finally disappeared and nobody seems to care because this is such an old bug?!?

This is so frustrating. :(

Here a link to one of the bugs at bugzilla:
https://bugzilla.mozilla.org/show_bug.cgi?id=1484532

You can find Workarounds here:
(https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1797945)

If you want the english Version of Lightning, type into a Terminal:
sudo apt update
sudo apt install xul-ext-lightning

If you want a localized Version of Lightning, at the Moment, you cannot use the normal Add-On-Search in Thunderbird (incompatible).
Download manually the latest Beta-Version of Lightining for your System- and Language-Version from:
https://archive.mozilla.org/pub/calendar/lightning/candidates/

Open Thunderbird > Add-Ons > Extensions > (Remove unwanted english Version of Lightining) >
  > At the top of the page, click the Gear-Wheel-Button next to the Search-Box to open a menu
  > Install Add-on From File
  > Select Download-Folder and the .xpi-File > Install
=> All your Calendar-Data should be back

Note: This may be fixed in some Weeks, Months, or Years, so maybe you can try first:
 > Thunderbird > Add-Ons > Extensions > Search for: Lightning > Install.
If you use Ubuntu-Linux or a Derivative, Lightning is not included in Thunderbird 60+ and the Update will break your Calendar (incompatible, not compatible). xul-ext-lightning is not international. Search for Add-On leads to incompatible Version. Someone told, the Beta is not recommended.

Workaround:
 > Download latest Version of Thunderbird fitting for you from here:
https://www.thunderbird.net/en-US/thunderbird/all/
 > Open File with Archive-Program(Unzipper)
 > Goto > thunderbird > distribution > extensions >
 > {e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi (=Lightning) > Extract
 > Open your installed Thunderbird > Add-Ons > Extensions
 > (Remove unwanted english Version of Lightning)
 > Gear-Wheel-Button next to the Search-Box
 > Install Add-on From File
 > Select Download-Folder and the .xpi-File > Install
 => All your Calendar-Data should be back

Coeur Noir (coeur-noir) wrote :

So, in other words, does it mean for non-english Ubuntu users that Lightning from canonical's repo will be broken forever ?

The workaround in https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/545778/comments/45 relies on official package and so far so good works nicely and also plays nice with provider for google agenda.

But.

What will happen on next official TB+Lightning release ?

Since Lighting is no longer seen as a separate extension and therefore no longer available on ATN, I can't see a way for « auto-updating » there.

Rolando Gorgs (rolandogorgs) wrote :

As nobody seems to care for this bug, I also think Lightning translation will be broken forever. :-(

Lukas (lukas-wringer) wrote :

As far as my Debian (testing) installations go, there is no issue with the locale of lightning so this may only be just an Ubuntu packaging Problem? Maybe a switch to debian "stock" version would help?

Lukas (lukas-wringer) wrote :

ups - my bad - I forgot that on Debian the lightning-l10n... packages exist for translation...

So we are just missing some additions l10n packages on ubuntu...

Rolando Gorgs (rolandogorgs) wrote :

All relevant Lightning versions for current Thunderbird 60.x have been uploaded to Thunderbird addons page:

https://addons.thunderbird.net/thunderbird/addon/lightning

So localized Lightning can be downloaded and installed again.
I can confirm this workaround is working!

Let this never ending story take its next round ...
(Is it good or bad news?)

Downloaded lightning-6.2.5-sm+tb.xpi from your link : "NOT COMPATIBLE" !!!!

Le 09/02/2019 à 02:01, Rolando Gorgs a écrit :
> All relevant Lightning versions for current Thunderbird 60.x have been
> uploaded to Thunderbird addons page:
>
> https://addons.thunderbird.net/thunderbird/addon/lightning
>
> So localized Lightning can be downloaded and installed again.
> I can confirm this workaround is working!
>
> Let this never ending story take its next round ...
> (Is it good or bad news?)
>

Rolando Gorgs (rolandogorgs) wrote :

Use your Eyes, Elbarbudo!!! :-)

Newest Thunderbird version in Ubuntu 18.04 is 60.4.0 and lightning-6.2.5-sm+tb.xpi requires at least 60.5. You need lightning-6.2.4-sm+tb.xpi (or an older one depending on your Thunderbird) - all aviable on the same website.

Two ways to get it right:
- Check your Thunderbird version and Download the right Lightning using your Browser.
OR
- Use Thunderbird>Menu>Addons>search to download it. Then the right version is chosen automatically.

I'd use the second way for convenience. The link I provided was just for reference.

UlfZibis (ulf-zibis) wrote :

This bug is a real pain.
Browser, E-Mail and a calendar are the most important applications on a computer system for most users, and there is no update proof way for the localisation.
Canonical, please provide a solution soon.

Rolando Gorgs (rolandogorgs) wrote :

As long as the Thunderbird people provide Lightning-Updates as Addon, this method IS update proof. (But nobody knows, how long they will do that because officially Lightning is shipped as part of Thunderbird now.)

This method may work for the next months(years?) but you are right: We finally need a real solution for this localization f**kup. :-/

UlfZibis (ulf-zibis) wrote :

Thanks Ronaldo, please see also my comment: https://bugzilla.mozilla.org/show_bug.cgi?id=1484532#c54

Olivier Tilloy (osomon) on 2019-04-05
Changed in thunderbird (Ubuntu):
importance: Medium → High
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) wrote :

I'm looking at how this works upstream, and in Debian.

Upstream: the xpi that can be downloaded from https://addons.thunderbird.net/thunderbird/addon/lightning/ includes all locales. I don't know how this xpi is built though, given that the upstream build system insists on building a localized xpi that contains only one language at a time.

Debian: the extension is unpacked and installed in /usr/share/lightning, and each langpack package installs the corresponding translations in /usr/share/lightning/chrome/lightning/AB_CD/…
This works only because the extension is installed unpacked. Note that in Debian there's a separate source tarball for lightning translations (see https://packages.debian.org/source/buster/thunderbird), but maybe that predates the inclusion of lightning in the central repository?

Olivier Tilloy (osomon) wrote :

Upstream uses a couple of scripts that assemble an unpacked extension with all locales and repack it into a suitable xpi, see https://github.com/kewisch/mozscripts/tree/master/lightning/release.

This is not integrated with the mozilla build system at all.

Olivier Tilloy (osomon) wrote :

One obvious downside of the Debian approach is the size occupied by the extension when installed unpacked. With all available language packs, /usr/share/lightning occupies 24MB, versus 4.8MB for the corresponding zipped xpi.

Coeur Noir (coeur-noir) wrote :

aheum... When talking about snap anybody says size does not matter, but here it does ? - well I understand why it does but is this an issue ? The issue here for years is non English speaking people have a broken lightning package in official repo.

What's more important ?

Le 9 août 2019 11:51:50 GMT+02:00, Olivier Tilloy <email address hidden> a écrit :
>One obvious downside of the Debian approach is the size occupied by the
>extension when installed unpacked. With all available language packs,
>/usr/share/lightning occupies 24MB, versus 4.8MB for the corresponding
>zipped xpi.
>
>--
>You received this bug notification because you are subscribed to a
>duplicate bug report (1798102).
>https://bugs.launchpad.net/bugs/545778
>
>Title:
> xul-ext-lightning is only available in English
>
>Status in One Hundred Papercuts:
> Triaged
>Status in Mozilla Thunderbird:
> Invalid
>Status in Ubuntu Translations:
> Triaged
>Status in lightning-sunbird package in Ubuntu:
> Invalid
>Status in thunderbird package in Ubuntu:
> Triaged
>
>Bug description:
> *******
>  ISSUE
> *******
>
> HOW TO REPRODUCE
>
> 1. Change the user session language to other different than English.
> 2. In Thunderbird, open the calendar
>
> EXPECTED BEHAVIOUR
>
> - The calendar interface to be in the session language.
>
> REAL BEHAVIOUR
>
> - The calendar is in English.
>
> RELEVANT DETAILS
>
> - None.
>
> **********
>  SOLUTION
> **********
>
> WORK-AROUND
>
> - None known.
>
> FIX
>
> - <http://www.smoose.org/blog/ubuntu-localized-lightning-extension>.
>
> REGRESSION POTENTIAL
>
> - Since no code needs to be modified, the regression potential is very
> low.
>
> ****************
>  TECHNICAL INFO
> ****************
>
> Binary package hint: lightning-extension
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/hundredpapercuts/+bug/545778/+subscriptions

--
Envoyé depuis Lenovo K6 Note via le courrieleur K9-mail.

UlfZibis (ulf-zibis) wrote :

The XPI at https://addons.thunderbird.net/thunderbird/addon/lightning/ is again pretty old and for TB version 60.0.
The latest is also such old and for TB version 60.5, but currently we have TB version 60.8, see: https://addons.thunderbird.net/de/thunderbird/addon/lightning/versions/

Nobody needs *all* language packs on his system. What is the size of the unpacked lightning with only one additional language pack?

Olivier Tilloy (osomon) wrote :

The overhead with only one (or just a few) additional language pack would be minimal indeed. The Debian approach requires significantly more work to integrate with the current packaging in Ubuntu, so I'm going ahead with the upstream approach, re-packing the lightning xpi (built from source, so the version matches) with all available locales.

Changed in thunderbird (Ubuntu):
status: Triaged → In Progress
Changed in ubuntu-translations:
status: Triaged → Invalid
Changed in hundredpapercuts:
status: Triaged → Invalid
UlfZibis (ulf-zibis) wrote :

When I unpack the latest XPI it only occupies 17 MB (including 12 MB for the locales), so I'm wondering, why the Debian approach needs 24 MB.
Anyway I understand, that packaging with separate language packs is a lot of work.
Thanks for re-packaging lightning with locales after many years of waiting. :-)

no longer affects: lightning-sunbird (Ubuntu Trusty)
no longer affects: lightning-sunbird (Ubuntu Utopic)
no longer affects: thunderbird (Ubuntu Trusty)
no longer affects: thunderbird (Ubuntu Utopic)
Olivier Tilloy (osomon) on 2019-08-10
Changed in thunderbird (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 1:68.1.1+build1-0ubuntu1

---------------
thunderbird (1:68.1.1+build1-0ubuntu1) eoan; urgency=medium

  * New upstream stable release (68.1.1build1)

  * Build thunderbird against the system-wide version of sqlite3 (LP: #1845929)
    - update debian/config/mozconfig.in
    - update debian/control{,.in}

 -- Olivier Tilloy <email address hidden> Tue, 01 Oct 2019 14:47:00 +0200

Changed in thunderbird (Ubuntu):
status: Fix Committed → Fix Released
Peter (doob) wrote :

This also affects 16.04 LTS.
Latest available version for this release is: 1:60.8.0+build1-0ubuntu0.16.04.2
from: http://de.archive.ubuntu.com/ubuntu xenial-updates/main

Will the fix become available for 16.04 LTS too?

Olivier Tilloy (osomon) wrote :

Yes, I'm working on bringing 60.9.0+build1 to all supported releases (xenial, bionic, disco).

Changed in thunderbird (Ubuntu Xenial):
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
status: New → Fix Committed
Changed in thunderbird (Ubuntu Bionic):
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
status: New → Fix Committed
Changed in thunderbird (Ubuntu Disco):
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightning-sunbird (Ubuntu Bionic):
status: New → Confirmed
Changed in lightning-sunbird (Ubuntu Disco):
status: New → Confirmed
Changed in lightning-sunbird (Ubuntu Xenial):
status: New → Confirmed
Olivier Tilloy (osomon) on 2019-10-07
no longer affects: lightning-sunbird (Ubuntu Xenial)
no longer affects: lightning-sunbird (Ubuntu Bionic)
no longer affects: lightning-sunbird (Ubuntu Disco)
Peter (doob) wrote :

Ok. Great! Thanks a lot.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 1:60.9.0+build1-0ubuntu0.18.04.1

---------------
thunderbird (1:60.9.0+build1-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream stable release (60.9.0+build1)

  * Do not attach Wi-Fi syslog to apport reports (LP: #1801383)
    - update debian/apport/source_thunderbird.py.in
  * Install the WeTransfer FileLink provider by default (LP: #1823361)
    - update debian/thunderbird.install.in
  * Do not exclude calendar translations from the source tarball, and repack
    the lightning xpi with all available locales (LP: #545778)
    - update debian/config/tarball.conf
    - update debian/build/rules.mk
    - update debian/rules

 -- Olivier Tilloy <email address hidden> Mon, 07 Oct 2019 10:03:16 +0200

Changed in thunderbird (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 1:60.9.0+build1-0ubuntu0.16.04.2

---------------
thunderbird (1:60.9.0+build1-0ubuntu0.16.04.2) xenial; urgency=medium

  * Enclose the path to the lightning extension XPI in double quotes to ensure
    dh_install finds it
    - update debian/rules

 -- Olivier Tilloy <email address hidden> Mon, 07 Oct 2019 10:59:57 +0200

Changed in thunderbird (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 1:60.9.0+build1-0ubuntu0.19.04.1

---------------
thunderbird (1:60.9.0+build1-0ubuntu0.19.04.1) disco; urgency=medium

  * New upstream stable release (60.9.0build1)

  * Do not attach Wi-Fi syslog to apport reports (LP: #1801383)
    - update debian/apport/source_thunderbird.py.in
  * Install the WeTransfer FileLink provider by default (LP: #1823361)
    - update debian/thunderbird.install.in
  * Do not exclude calendar translations from the source tarball, and repack
    the lightning xpi with all available locales (LP: #545778)
    - update debian/config/tarball.conf
    - update debian/build/rules.mk
    - update debian/rules

 -- Olivier Tilloy <email address hidden> Mon, 07 Oct 2019 10:32:00 +0200

Changed in thunderbird (Ubuntu Disco):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.