Lightning incompatible with Thunderbird 60.2.1

Bug #1797945 reported by Ettore Atalan on 2018-10-15
210
This bug affects 42 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
High
Unassigned

Bug Description

Hi

Today I got the update from Thunderbird 52 to 60.2.1. Unfortunately Lightning doesn't work anymore.

Thunderbird reports that Lightning is incompatible with Thunderbird 60.2.1.

Regards,

Ettore

--

WORKAROUNDS:

Until this is fixed (as per the problems listed in #25), pick an answer that works best for you (English vs. other languages) at https://askubuntu.com/questions/1084059/latest-update-to-thunderbird-60-2-1-on-18-04-lightning-calendar-missing .

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
GrzesiekC (grzesiekc) wrote :

Hi all,

according to this site https://developer.mozilla.org/en-US/docs/Mozilla/Calendar/Calendar_Versions#Development_Snapshots - TB 60.2.1 requires 6.2.2.1 version of Lightning

Also. I found this info:
"... If you are using Linux and installed Thunderbird and/or Lightning by using the package manager of your distribution, then these how-tos are not applicable - please contact the support of your Linux distribution to get help. ..."
from here:
https://support.mozilla.org/en-US/kb/calendar-updates-issues-thunderbird

Cheers

Brian Campbell (bacam) wrote :

I found switching from the add-on version to the xul-ext-lightning Ubuntu package worked, giving me the latest version.

Brain, thanks, installing xul-ext-lightning package from the package manager worked for me. I may have needed to restart thunderbird as well.

felipunk (fenieves) wrote :

Brian's solutions works!

Same Problem today after "sudo apt upgrade" => from Thunderbird 52 to 60.2.1 (64-bit)
In all my 3 Profiles Lightning had stopped working / disappeared.
The First Profile had Lightning 5.4 installed as Add-On and now showed: incompatible .. deaktivated
Second and third Profile: In the Past, Lightning had been automatically integrated by clicking "keep it" and now it had disappeared.
Trying to install via search Add-Ons in Thunderbird only led to the incompatible 5.4.

Also NOT helpful was:
https://support.mozilla.org/en-US/kb/calendar-updates-issues-thunderbird
(Entry in Config did not exist at all)

There was also no change, when i started Ubuntu-Languages or so (DE: Sprachen) and let install additional Language-Packages including one for Thunderbird-EN automatically. (DE, which i use, did not show up as missing).

What then helped in all 3 Profiles, was the manual Download and Install of a Lightning-Beta-XPI into Thunderbird:
https://archive.mozilla.org/pub/calendar/lightning/candidates/6.2b6-candidates/build1/linux-x86_64/lightning-6.2b6.de.xpi

Above is the direct Link to the German Version (DE).
Maybe you will have to chose your Language-Version from:
https://archive.mozilla.org/pub/calendar/lightning/candidates/6.2b6-candidates/build1/

Comment to the former Solution:
I did not have installed and did not try xul-ext-lightning.
You cannot find it in the new (Gnome-)Software. It only will show up in the old Ubuntu-Software-Center. However, there is a Comment, that this will only install the English Version (EN). You can also find this via Terminal > apt list xul-ext-lightning
If you want the english Version of Lightning, type: sudo apt install xul-ext-lightning

Jan Wester (j-vester) wrote :

Solution in #6 worked for me. So thanks piraten-kris. I use swedish localization of thunderbird so it is not perfect since "Termine und Aufgaben" in the menu is definitively not Swedish but German.

Jan Wester (j-vester) wrote :

I update myself: I used #7 and used the swedish localization of instead. So now it says "Händelser och uppgifter" in the menu, which is correct Swedish. So problem solved!

eMKi (mkisovec) wrote :

One (temporary) option is also to downgrade Thunderbird back to the previous version (in my case 52.7).
I used 'Synaptic Package Manager' to downgrade and lock in the old version. I'll wait a while before updating.

There may be better solutions posted already but this is also one possibility for those who don't mind to wait a while.

Kósa Lajos (lajos-p) wrote :

The solution with installing the package xul-ext-lightning definitely works, having one issue: the only language it contains is English, which looks very uncool to have a mixed language Thunderbirds for users using that in other language than English.

Solution B:

As we have already learnt, on the official add-on page of lightning there is only a version being 18 months old. This is strange, when you look at the new homepage of the add-on:

https://developer.mozilla.org/en-US/docs/Mozilla/Calendar/Calendar_Versions

There you see the list of the add-ons for each new thunderbirds. At least their bug list references.

If you continue searching, you find this link: https://archive.mozilla.org/pub/calendar/lightning/

You may think, wow, we're done. No, not really.

Check out releases: https://archive.mozilla.org/pub/calendar/lightning/releases/

The latest release is the one being on their add-on page in Mozilla (4.0.3.1).

Check out the candidates:

https://archive.mozilla.org/pub/calendar/lightning/candidates/

Candidates there for all new versions. Even 6.2.2.1 there for each language! Ok, we're done, since there is the 6.2.2.1-hu what I need.

No, we're not done.

There you only find the candidates. Stop searching for the releases, they are not there, and even not there the latest candidates which are listed on the projects home page (remember? the first link I showed).

So, download the beta6, then you have a version which is usable - and having 'only' 21 bugs.

https://archive.mozilla.org/pub/calendar/lightning/candidates/6.2b6-candidates/build1/linux-i686/

I'm using it, it's _quite_ OK, and Hungarian.

I may say something is really screwed up here at Thunderbird.

Jeffery To (jefferyto) wrote :

Recent versions of Thunderbird (at least the version packaged / distributed by Mozilla) has come pre-installed with Lightning; this is why the extension hasn't been updated on addons.mozilla.org.

The version of Thunderbird installable from the standard Ubuntu repositories is packaged by Ubuntu. They have chosen to package the extension as a separate package (xul-ext-lightning), so the most "correct" solution to this issue is to install that package.

(xul-ext-lightning being English-only appears to be long-standing issue (#545778); if this affects you I suggest contributing to that bug report.)

If you would still like to install the .xpi file (perhaps because of the locale issue):

1. Visit the Thunderbird site (https://www.thunderbird.net/) and download the Linux / Linux 64-bit version of Thunderbird, matching your installed version (60.2.1 in this case) and locale. It should be a .tar.bz2 archive.
2. Extract the archive, then inside thunderbird/distribution/extensions there should be one .xpi file. That should be the corresponding version of Lightning (6.2.2.1).

Jeffery To (jefferyto) wrote :

The bug report for "xul-ext-lightning is only available in English" is at https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/545778 .

Jan Wester (j-vester) wrote :

Tested comment #12. Yes, it works! And it displays Lightning 6.2.2.1. I add it as attachment

Jeffery To (jefferyto) wrote :

Instead of everyone having to download and extract their own .xpi file, I decided to do it myself and upload all the language/locale versions of the extension to here:

https://www.dropbox.com/sh/w84dtrc73e90j3p/AABC5CeNN-ZwoNgq9m1hQUs4a/thunderbird-60.2.1?dl=0&lst=&subfolder_nav_tracking=1

yoyoma2 (sinbad-4273) wrote :

I'm lucky enough to use english so installing xul-ext-lightning from the ubuntu software center worked as post #12 calls the "correct" solution. I did however have to remove the old lightning addon using the thunderbird add-ons menu to get the new xul-ext-lightning one to show up. Luckily the lightning tasks and events were preserved.

Changed in thunderbird (Ubuntu):
importance: Undecided → High
Chris Coulson (chrisccoulson) wrote :

There is an updated lightning package in the archive, but there isn't a compatible version of lightning on addons.thunderbird.net for users who have installed it from there as opposed to installing the one in the archive. There's not really anything we can do about that, other than advise you to install the one from the archive instead.

Changed in thunderbird (Ubuntu):
status: Confirmed → Invalid

Hi Chris Coulson,

you changed it to Invalid which means; "This is not a Bug."
That implies, the Bug does not show up in the Search or in any Users Subscription any longer.
Now, nobody can find the Solution anymore for the Problem, which is definitly a Bug and no Feature-Request. Duplicate Bug-Entrys are provoked by this.

Wouldn't it be more appropriate to change the Status to "Won't fix"?
So that Users looking for the Problem will at least find Something and get Help by the Workarounds?

Kris

This is ridiculous: If you go to https://bugs.launchpad.net
and search for: "Lightning incompatible Thunderbird"
you will only find two many years old bugs, which have never been closed.

How can launchpad be helpful in any way? I really want to know.

Adrian Limmi (adrifromhh) wrote :

Where do I put the .xpi file to be recognized by Thunderbird?

Jeffery To (jefferyto) wrote :

@Adrian Limmi:

1. Open the Add-ons Manager in Thunderbird, and go to the Extensions page/tab (if it isn't already open).
2. At the top of the page, click the gear button next to the search box to open a menu, then select "Install Add-on From File".
3. From here you can select the .xpi file and it should install without issue.

Adrian Limmi (adrifromhh) wrote :

It worked like a charme. Thank you!

As defined it is not invalid, because it _is_ a Bug.
It will be resolved later, when a compatible Version of Lightning will be made available at Thunderbird-Add-On-Search.
(I could not chose "Won't fix")
So i changed its Status to "In Progress"

Changed in thunderbird (Ubuntu):
status: Invalid → In Progress
Sebastien Bacher (seb128) wrote :

It's a bug but not in Ubuntu, which is what this bug tracker is about

Changed in thunderbird (Ubuntu):
status: In Progress → Invalid

It _is_ a Bug in Ubuntu, because they do not deliver the Standard-Thunderbird-Version with Lightning includes.
It _is_ a Bug in Ubuntu, because Ubuntus xul-ext-lightning is english-only and not international (localized).
A compatibel Release-Version of Lightning is already available, it is just, that Ubuntu does not include it or offer it.

Changed in thunderbird (Ubuntu):
status: Invalid → In Progress

I have to correct myself:
I think, this is a Bug, Ubuntu should care about immediately, because it breaks Peoples already installed Calendar by an Ubuntu-Update.

Changed in thunderbird (Ubuntu):
status: In Progress → Confirmed
Henry Goldstein (henryg) wrote :

I found it really hard to find good answers to this problem - It was such a shock, and so important, that I was surprised this site was not no.1 in a Google search.

After hours of trying different things and searching, I reverted to 57.2 and locked that in.

Then, I accidentally came across https://addons.thunderbird.net/en-us/ which contained the https://ftp.mozilla/pub/calendar/lightning/candidates/ solution - in French. That worked for me.

I know it's free software, and I've been using it for years, quite contentedly, but .... This is not the first time that a Ubuntu Thunderbird update has broken something important.

If this is not a bug, what it is?

Note: This may be fixed in some Weeks, Months, or Years, so maybe you can try first:
 > Thunderbird > Add-Ons > Extensions > Search for: Lightning > Install.
If you use Ubuntu-Linux or a Derivative, Lightning is not included in Thunderbird 60+ and the Update will break your Calendar (incompatible, not compatible). xul-ext-lightning is not international. Search for Add-On leads to incompatible Version. Someone told, the Beta is not recommended.

Workaround:
 > Download latest Version of Thunderbird fitting for you from here:
https://www.thunderbird.net/en-US/thunderbird/all/
 > Open File with Archive-Program(Unzipper)
 > Goto > thunderbird > distribution > extensions >
 > {e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi (=Lightning) > Extract
 > Open your installed Thunderbird > Add-Ons > Extensions
 > (Remove unwanted english Version of Lightning)
 > Gear-Wheel-Button next to the Search-Box
 > Install Add-on From File
 > Select Download-Folder and the .xpi-File > Install
 => All your Calendar-Data should be back

ubuntuone (zubuntuuser) wrote :

Got the same problem too, which I found very annoying.
I was very surprised to have such a blocking bug with regular Ubuntu updates.

Here is my fix :
- go to https://www.thunderbird.net/fr/ (yes, I use french version)
- download latest Thunderbird tarball (v 60.2.1)
- extract it to a dir
- then use it : $ ./thunderbird

Now Thunderbird and Lightning just work !

This means not using the Ubuntu package anymore as it is broken.
Now I can wait and see if the next Ubuntu updates fix the problem.
Else I'll use Mozilla packages directly, as they update smoother.

Harald Nikolisin (hochglanz) wrote :

I'm affected too and thanks to the users here - especially piraten-kris - we got an overview about the workarounds.

It was a bad suprise to start Thunderbird after regular Ubuntu update with missing core-functionality. And it is very hard and time consuming for an user to discover which SW-part is responsible for the misfunction (normally you start with the plugin or the host program).

Therefore it was a surprise that Ubuntu is responsible for the error and it is pretty annoying that automatically the responsibility will be denied ("it's not our bug...").

Ubuntu must really asap correct this bug, because it breaks core functionality of an application which Ubuntu take care of!

Colan Schwartz (colan) wrote :

I believe that this should be set back to Confirmed, but the tracker's not letting me do that. Or did someone actually start working on the issues in #25?

Colan Schwartz (colan) on 2018-10-23
description: updated
Rafson (rafson) wrote :

Hey, in my case the steps to fix it were as follows:
1. Download thunderbird tar.bz2 from https://www.thunderbird.net/
2. Extract it wherever you want
3. In extracted thunderbird folder you will find lightning xpi file compatible with TB 60.2.1: distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi
4. Open your Thunderbird 60.2.1 installed from Ubuntu repo
5. Go to Addons -> Install addon from file and choose xpi file from point 3
6. Restart Thunderbird and enjoy Lightning once again :)

Hope this helps.

Niranjan Rao (nhrdls) wrote :

It was broken for me also and comments from #3 and #4 helped. Calendar is very important functionality and sudden disappearance was very problematic. May be work with Mozilla and ask them to update documentation for Ubuntu so that others facing this problem will have a quick solution.

I certainly did not know about the lightning package and always have installed from thunderbird. Another alternative could be update manager to warn people that it can break functionality.

When I tried installing xul-ext-lightning , I got blocked, whether via the Synaptic Package manager or Software Center or using apt from the command-line. The essence of the error message was:

xul-ext-lightning: Depends: thunderbird (= 1:38.6.0+build1-0ubuntu1) but 1:60.2.1+build1-0ubuntu0.16.04.4 is to be installed

I think I noticed that 1:38.6.0 was the version number of xul-ext-lightning; maybe somehow that got copied over into some field that describes the version of Thunderbird? I don't know, but in any case, that did not work for me.

I followed Jeffery To (jefferyto)'s advice in #12, #15 and #21 (which are repeated in #28 and #32 (except step 5 is not as explicit as Jeffery's) and, I'm relieved to say, that worked.

This is really a dreadfully convoluted way to handle the matter. I'm sure only a very persistent few will find it, and the rest will be bemoaning loss of important functionality.

So, yes, please, let's get this to be part of the automatic upgrade.

boskicinek (boski-cinek) wrote :

Did anyone manage to synchronize NextCloud (DAV) calendar with any of workaround mentioned in this thread?

EN:Correction (DE:Korrektur)
----------------------------
EN: Note:
This may be fixed in some Weeks, Months, or Years, so maybe you can try first:
 > Thunderbird > Add-Ons > Extensions > Search for: Lightning > Install.
Problem:
If you use Ubuntu-Linux or another Debian-Derivative, Lightning is not included in Thunderbird 60+ and the Update will break your Calendar (incompatible, not compatible). xul-ext-lightning is not international. There is no Language-Pack for Lightning available. The normal Search for Add-On leads to an incompatible Version. Someone told me, the Beta was not recommended.
---
Workaround:
 1.> Lookup your Version of Thunderbird:
   > =Menu > Help > About Mozilla Thunderbird
 2.> Download the same Version of Thunderbird fitting for you from here:
https://ftp.mozilla.org/pub/thunderbird/releases/
 3.> Open File with an Archive-Program(Unzipper)
   > (Usually just > Double-Click or > Right-Click > open ..)
 4.> Goto > thunderbird > distribution > extensions >
 5.> {e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi (=Lightning) > Extract
 6.> Open your installed Thunderbird > Add-Ons > Extensions
 7.> (Remove unwanted english Version of Lightning: )
   > (Terminal > sudo apt remove xul-ext-lightning)
 8.> Gear-Wheel-Button next to the Search-Box
 9.> Install Add-on From File
 10.> Select Download-Folder and the .XPI-File > Install
=> All your Calendar-Data should be back. :-)
---------------------------------------------
DE: Hinweis:
Dies mag in einigen Wochen, Monaten oder Jahren behoben sein. Probiere zuerst
 > Thunderbird > Add-Ons > Erweiterungen > Suche nach: Lightning > Installieren.
Problem:
Wenn du Ubuntu-Linux oder einen anderen Debian-Abkömmling benutzt, ist Lightning nicht in Thunderbird 60+ enthalten und ein Update wird den Kalender abschalten (inkompatibel, nicht kompatibel). xul-ext-lightning ist nicht international. Es ist kein Sprach-Paket für Lightning verfügbar. Die normale Suche nach Add-On führt zu einer inkompatiblen Version. Jemand sagte mir, die Beta sei nicht empfohlen.
---
Hilfs-Lösung:
 1.> Sieh nach, welche Version von Thunderbird du hast:
   > =Menü > Hilfe > Über Mozilla Thunderbird
 2.> Lade die selbe Version von Thunderbird passend für dich von dort:
https://ftp.mozilla.org/pub/thunderbird/releases/
 3.> Öffne die Datei mit einem Archiv-Programm(Unzipper)
   > (normalerweise nur > Doppelklick oder > Rechtsklick > öffnen ..)
 4.> Gehe dort zu > thunderbird > distribution > extensions >
 5.> {e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi (=Lightning) > Entpacken
 6.> Öffne dein installiertes Thunderbird > Add-Ons > Erweiterungen
 7.> (Entferne die unerwünschte englische Version von Lightning:)
   > (Terminal > sudo apt remove xul-ext-lightning)
 8.> Zahnrad-Knopf neben dem Suchfeld
 9.> Add-on aus Datei installieren
 10.> Wähle den Download-Ordner und die .XPI-Datei > Installieren
=> Alle deine Kalender-Daten sollten wieder da sein. :-)

Magnus Melin (mkmelin+ubuntu) wrote :

Hey, Thunderbird maintainer here.

While Ubuntu can of course keep the packages for thunderbird and lightning separate, please make sure to at least add "Recommends: xul-ext-lightning" to the thunderbird package as this is the expected configuration. (Or whatever makes it install lightning at the same time by default.)

Paul White (paulw2u) wrote :

Comments #17 and #24 closed this bug report as being invalid but it was reopened as many users required a version of Lightning in a language other than English which could at the time of reporting only be obtained from the Thunderbird web-site.

There have been no comments here for almost a year. The release of Thunderbird 60.9.0 includes translations in the Lightning package (xul-ext-lightning). This package is updated each time Thunderbird itself receives an update.

Bug #545778, referring to Lightning being in English only, has been closed as being fixed so this bug report should be closed as being fixed too.

Changed in thunderbird (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers