LibreOffice Menus Stop Working even with libreoffice>=1:3.6.2~rc2-0ubuntu4 and indicator-appmenu>=12.10.3-0ubuntu2.1

Bug #1085169 reported by Ed Hill on 2012-11-30
322
This bug affects 67 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
indicator-appmenu (Ubuntu)
Undecided
Unassigned
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

When using LibreOffice with Ubuntu 12.10, the menus will stop working. That is, the menu is showing at the top of the screen, and you can select a menu item, however nothing happens. Once the behaviour starts, none of the menu items work, including File Exit. The only way to get the menus to work again, is to quit LibreOffice and restart the program.

This has been reported in Writer and Calc so far.

This happens regardless of the video driver, and on 32 or 64 bits.

This is with libreoffice version >= 1:3.6.2~rc2-0ubuntu4 and indicator-appmenu 12.10.3-0ubuntu2.1 (currently in quantal-proposed) ONLY. If you do not have these installed, you are hitting bug 1064962 or bug 1075263 resp..

WORKAROUND:
- Use right-click menus, toolbar buttons or keyboard shortcuts, or
- Close and reopen the document

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1085169/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed

Going back to because of the related bugs. Please reconfirm with those versions installed. Also a good reproduction scenario would be nice.

description: updated
summary: - LibreOffice Menus Stop Working
+ LibreOffice Menus Stop Working even with
+ libreoffice>=1:3.6.2~rc2-0ubuntu4 and indicator-
+ appmenu>=12.10.3-0ubuntu2.1
Changed in ubuntu:
status: Confirmed → New

Also:
1) If the menu stops working, does Alt-Alt bring them back alive as per: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1064962/comments/78 ?
2) If the menu stops working, does the command 'pkill unity-panel' bring the menu back alive?

Changed in ubuntu:
status: New → Incomplete
affects: ubuntu → libreoffice (Ubuntu)
Ed Hill (hill-ed-h) wrote :

No. Alt + Alt does not bring the menus back.
"If the menu stops working, does Alt-Alt bring them back alive as per: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1064962/comments/78 ?"

No. pkill unity-panel does not make the menus work. Interestingly, that just grays out all the menu options making them all unavailable.
"If the menu stops working, does the command 'pkill unity-panel' bring the menu back alive?"

Ed Hill (hill-ed-h) wrote :

@Ubuntu Foundations Team Bug Bot....the URL you sent me to is not working.
https://bugs.launchpad.net/ubuntu/+bug/1085169/+editstatus

I do not know how to report a bug for the bug reporting system.

Ed Hill (hill-ed-h) wrote :

Steps to reproduce.

Work with LibreOffice Writer as a normal user would. There is no apparent specific action which triggers the loss of menu functionality. I just am working on the document as normal, and need to go to Format Paragraph, or File Open, etc. and it just does not work. Closing Libre-Office and opening it again cause the menus to work again.

Tried it here for half an hour, couldnt reproduce. Could you please provide as much info about your install as possible:
- amd64 or i386
- dpkg-query -l libreoffice-core
- dpkg-query -l indicator-appmenu

Ed Hill (hill-ed-h) wrote :

amd64. Standard install.
Only extension being used is Mendeley (www.mendeley.com) which is a toolbar, not menu.
Additional Driver: Nvidia
2 monitors (laptop internal, HDMI external) with TwinView

dpkg-query -l libreoffice-core
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-============-============-=================================
ii libreoffice-co 1:3.6.2~rc2- amd64 office productivity suite -- arch

dpkg-query -l indicator-appmenu
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-============-============-=================================
ii indicator-appm 12.10.3-0ubu amd64 Indicator for application menus.

Ed Hill (hill-ed-h) wrote :

Menus were working fine.
Opened up Thunderbird on another desktop to check e-mail.
Went back to LibreOffice and menus were not working.
Not sure if this is related.

Ed Hill (hill-ed-h) wrote :

Also, shortcut keys that would bring up a dialog do not work. For example Format Styles Dialog has F11 shorcut. The shortcut key does not work either.

@comment 11: please dont mix https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/739184 into this one
@comment 10: thats interesting (and suggests the error is in indicator-appmenu, not in libreoffice.
@comment 9: The interesting bit (the full version number) is missing on that one (a bigger terminal window should help) ...

Ed Hill (hill-ed-h) wrote :

Switching to Nouveau driver to see if that has any impact on the issue. Will try that for a few days.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
Lem (lem-jjr) wrote :

Happens here with Calc. Working on things as usual in Calc, nothing fancy: changing text and background cell colours, adjusting row heights, cut/copy/paste, saving, search/replace.. after some time the menus stop working.

AMD64, using quantal-proposed, same package versions as listed in the description (libreoffice 1:3.6.2~rc2-0ubuntu4 and indicator-appmenu 12.10.3-0ubuntu2.1), nVidia binary driver

Russell Faull (rfaull) wrote :

Could this bug relate to libreoffice-gtk, remove it and the problem disappears? Although, of course, you won't have unity integration. I can live with that, in preference to randomly inoperative menus.

Marius B. Kotsbak (mariusko) wrote :

Of course it is. This bug is caused by the integration of Unity to Libreoffice introduced in Quantal. Removing that package is a workaround, but removes a lot of other gtk integrations like the file dialogs.

Ed Hill (hill-ed-h) wrote :

My system was using the proprietary Nvidia driver prior to the upgrade to 12.10, and after the upgrade continued to use the proprietary driver.
I switched to the open source nouveau driver, and so far, I have not seen the menu problem come up. I also have not seen the problem where the latop screen (not the external one) stays at dimmest brightness setting after resume from suspend. It now returns to full brightness.
It looks like the nouveau driver may be better tested/more stable?

Ed Hill (hill-ed-h) wrote :

Well, the non-working menus are back, even with the nouveau drivers instead of Nvidia proprietary drivers.

Russell Faull (rfaull) wrote :

@ Marius, I think you missed my point. I am suggesting that another package, other than the two mentioned in this bug report, might be implicated in this problem.

Marius B. Kotsbak (mariusko) wrote :

The -gtk package is created from libreoffice source package, see https://launchpad.net/ubuntu/+source/libreoffice so this bug's data is right.

bug 1085169 was possibly a dupe of this one.

eh, sorry: bug 1086198 was possibly a dupe of this one.

Bug affects me too.
Sometimes when I'm editing two documents at the same time, the bug affects only one of them, while global menu for the other document works properly.
I haven't found a way to reproduce this. Seems to happen randomly, but persistenly.

Running Ubuntu 12.10 amd64 on a Macbook4,1

LibreOffice 3.6.2.2 (current)

dpkg-query -l libreoffice-core

Deseado=Desconocido/Instalar/Eliminar/Purgar/Retener
| Estado=No/Instalado/Config-files/Desempaquetado/Medio-conf/Medio-inst/espera-disparo/pendiente-disparo
|/ Err?=(ninguno)/Requiere-reinst (Estado,Err: mayúsc.=malo)
||/ Nombre Versión Arquitectura Descripción
+++-==============-============-============-=================================
ii libreoffice-co 1:3.6.2~rc2- amd64 office productivity suite -- arch

dpkg-query -l indicator-appmenu

Deseado=Desconocido/Instalar/Eliminar/Purgar/Retener
| Estado=No/Instalado/Config-files/Desempaquetado/Medio-conf/Medio-inst/espera-disparo/pendiente-disparo
|/ Err?=(ninguno)/Requiere-reinst (Estado,Err: mayúsc.=malo)
||/ Nombre Versión Arquitectura Descripción
+++-==============-============-============-=================================
ii indicator-appm 12.10.3-0ubu amd64 Indicator for application menus.

SRoesgen (s-roesgen) wrote :

Same here,

happens when more than one office document is opened.

I also have a 2 monitors (laptop internal, DVI external) with TwinView setup. (so quite similar to Ed Hill's setup).

I'm also seeing this. Running Ubuntu 12.10 amd64 like the others, but with NVidia's nvidia-experimental-310 binary blob driver through a GTX 560 Ti to drive a single monitor.

Info on libreoffice-core and indicator-appmenu follows:

~$ dpkg-query -l libreoffice-core
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===================================-======================-======================-============================================================================
ii libreoffice-core 1:3.6.2~rc2-0ubuntu4 amd64 office productivity suite -- arch-dependent files

~$ dpkg-query -l indicator-appmenu
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===================================-======================-======================-============================================================================
ii indicator-appmenu 12.10.3-0ubuntu2.1 amd64 Indicator for application menus.

This Bug also affects me. Graphics Driver is Intel. The menu just doesn't react sometimes in LO writer, and i have to restart the program.

John D Marsden (jdmarsden) wrote :

This bug is also affecting me and my wife. Running on amd64 laptop with no special video drivers. Confirm I am have amd64 versions of libreoffice-core 1:3.6.2~rc2-0ubuntu4 and indicator-appmenu 12.10.3-0ubuntu2.1 installed.

It happens on both my and my wife's computers (same amd64 software configuration but I have full Libreoffice metapackage while she has just standard install from quantal upgrade).

How to reproduce the bug:

Use Libre Office Writer for some variable time ranging from a very few minutes upwards.
Work using mouse to select a menu item from the menu bar (on the top line in the indicator menu area).
Suddenly, for no apparent reason, the menu items stop functioning. Libreoffice can still be controlled using the icons but actions for which no item exists cannot be performed. The HUD display, despite showing a picture of Libreoffice writer to the left, also stops working. It does not give any Libreoffice actions in response to typing. It offers only items from the indicator panel, e.g. Skype, Dropbox & Network.

If a second Libreoffice document is opened it does not display the bug.

Work-round:
Close and re-open the file.

Today my wife worked for about five hours on LibreOffice writer and had the problem five times. I worked a similar period of time and today didn't have it at all, though did yesterday.

If there is any tracking software we could run to help track down what is triggering this please let us know.

John D Marsden (jdmarsden) wrote :

I spoke to soon. Got back in this evening and did another half-hour's work tonight and it happened twice on my computer.

will this bug be fixed in 12.10? Because I'm thinking of going back to 12.04- i have to reopen the files i'm working on very often. This happens on both machines with amd 64 installation - one with intel graphics, one with ati.
Since this Bug isn't even assigned, there doesn't seem to be much care about it.

Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed
Ed Guenter (edgue) wrote :

For me, this bug is solid. I start LibreOffice, and ALT-xxx will not work. Never ever.
Running 12.10; 64 bit; with LibreOffice 3.6.2.2

This is VERY annoying to say the least.

Colin Law (colin-law) wrote :

I am seeing the bug as described (menus initially ok but then stop working) on Quantal 32 bit with Intel graphics. Libreoffice-core 1:3.6.2~rc2-0ubuntu4, indicator-appmenu 12.10.3-0ubuntu2.1. I am seeing it in calc specifically but that may just be that I use calc more than writer.
I also use a dual screen setup - is this becoming more than just a co-incidence?
Alt-Alt does not make it go away (and the menu items are not accessible via theHUD).
pkill unity panel made the menus completely disappear for all libroffice windows open (not just the one that had failed) but other app's menus continuted to function (firefox and nautilus).
I have not managed to find any pattern to what triggers the problem.

Colin Law (colin-law) wrote :

I tried running libreoffice from a terminal in case any diagnostics appeared when it failed. Calc still failed after about ten minutes of operation but nothing appeared in the terminal when it failed.

I do get the following messages on libreoffice startup but I guess these are not related to the problem here:

javaldx: Could not find a Java Runtime Environment!
Please ensure that a JVM and the package libreoffice-java-common is installed.
If it is already installed then try removing ~/.libreoffice/3/user/config/javasettings_Linux_*.xml
Warning: failed to read path from javaldx
Fontconfig warning: "/usr/lib/libreoffice/share/fonts/truetype/fc_local.conf", line 13: Having multiple <family> in <alias> isn't supported and may not works as expected

Colin Law (colin-law) wrote :

The dual display issue appears to be a red herring, I have tried with only a single monitor and it still fails for me.

Colin Law (colin-law) wrote :

I have to withdraw my note in comment #32 that menu items are not accessible via the HUD once this bug cuts in. In fact the HUD is not working reliably at all with libreoffice for me and others. See bug #1045353. Is this possibly a related issue?

Hartwig Kolbe (kolbeb) wrote :

This bug is really annoying, I sometimes have to re-start LO after each menu action, at other times it would run for an hour or more.
I am on i386, with only one monitor, old Radeon 200 graphic.
dpkg-query -l libreoffice-core
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-=========================-=================-=================-=======================================================
ii libreoffice-core 1:3.6.2~rc2-0ubun i386 office productivity suite -- arch-dependent files

dpkg-query -l indicator-appmenu
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-=========================-=================-=================-=======================================================
ii indicator-appmenu 12.10.3-0ubuntu2. i386 Indicator for application menus.

Any chance that this will get solved in foreseeable time?
This bug is around since more than a month, with no visible progress.
Seems the only way to overcome (and be able to work with 12.10 and LO) requires to turn-off the global menu altogether:
sudo apt-get remove indicator-appmenu appmenu-gtk appmenu-gtk3 appmenu-qt
If some lucky day someone finds a solution, we can try the global menu again:
sudo apt-get install indicator-appmenu appmenu-gtk appmenu-gtk3 appmenu-qt

Hartwig Kolbe (kolbeb) wrote :

update for #37: the version info was not displayed completely.

dpkg-query -l libreoffice-core
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-=========================================-==========================================-============-==============================================================================
ii libreoffice-core 1:3.6.2~rc2-0ubuntu4 i386 office productivity suite -- arch-dependent files

dpkg-query -l indicator-appmenu
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-=========================================-==========================================-============-==============================================================================
ii indicator-appmenu 12.10.3-0ubuntu2.1 i386 Indicator for application menus.

I am affected by this on my Samsung N310 with Intel drivers, with Ubuntu 12.10 and LO 3.6.4.3

I noticed I can have several documents open (with Calc at the moment) and have the problem only with one document. Closing and reopening the document brings the working menus back.

Let me know if I can test anything.

Is bug #1052124 a duplicate?

Georg Ramer (georg-ramer) wrote :

I see the same thing in writer. I'm on 12.10, having done a dist-upgrade from 12.04. There doesn't seem to be a system to when it happens. I've had to docs open at the same and one working and one not. For me keyboard shortcuts that do not depend on ALT still work even when the menu stops working (e.g. F11 for Styles and Formatting).

Is there any diagnostic I could run to help fix the problem?

Roman Yepishev (rye) wrote :

I got this on current Raring.
dbus-monitor shows that the menu is actually sending a signal but there is an error:

method call sender=:1.43 -> dest=:1.283 serial=12975 path=/window/106954808; interface=org.gtk.Actions; member=Activate
   string ".uno:PrintPreview"
   array [
   ]
   array [
   ]
error sender=:1.283 -> dest=:1.43 error_name=org.freedesktop.DBus.Error.UnknownMethod reply_serial=12975
   string "No such interface `org.gtk.Actions' on object at path /window/106954808"

:1.43 is unity-panel-service and :1.283 is /usr/lib/libreoffice/program/soffice.bin

Jorge Juan (jjchico) wrote :

Same problem here. Some times menu entries do not work but keybord shortcuts do. E.g. this mornig "Save as" did not work from the menu but "Ctrl-Shift-S" displayed the "Save As" dialog.

description: updated

Bug #1052124 is very similar but has been reported with a previous version of LO.
Can anyone here say that they are/were experiencing this with an older version of LO or indicator-appmenu?

description: updated
Claude Durocher (claude-d) wrote :

I also have the same problem with 12.04 and LO 3.6.4 installed from the ppa (lo-menubar not installed).

JEROME (jerome-borowiak) wrote :

Workaround !
(work for me)
As mentioned it seems to be an Unity integration bug...
So I had...
- removed ALL libreoffice packages with Synaptic
- downloaded all required libreOffice 4 deb (via torrent, must faster)
- installed them as written in "readMe"

And now it's running like a charm!
(much better as it was before in any case...)
J.

Does this still persist with the LibreOffice 4 beta2 version (or later) in raring? The unity integration was upstreamed for LibreOffice 4 and comment 45 suggests this bug was fixed along the way ...

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete
Russell Faull (rfaull) wrote :

LO 4 installed as described in #45 is also working very well in 12.10, integration with unity is as expected.

Colin Law (colin-law) wrote :

It is looking good so far for me using calc 4 from Raring daily build.
Sadly bug #1045353 (Commands are not displayed in the HUD) and bug #739184 (Mnemonics do not work in Unity) still seem to be present.

I'm using LibreOffice 4 installed from the original DEB files from the official TDF page.
Currently, there is not Unity's Global Menu integration. Each window has its own menus.

Sorry, I forgot to mention, I'm using Quantal 64 bit.

Russell Faull (rfaull) wrote :

Star Man Aquarius, have you install libreoffice-debian-menus?

You mean the DEB file included inside the "desktop-integration" folder? Yes, I did.

Russell Faull (rfaull) wrote :

Oops, I was wrong at #47. Integration not as expected. I meant that menus are working without the this bug but within the application window and not integrated into unity. Star Man Aquarius at #49 is correct. (You can't expect TDF to provide unity integration for Ubuntu.)

Rudi von Staden (rudi) wrote :
Download full text (4.3 KiB)

Still happening for me (reporting here instead of #1083532, which seems to be a duplicate). Here follows the dbus output when I select Page Preview from the File menu (seems to be the most likely way to isolate the issue so far). Error seems similar to comment #41 above.

The crux seems to be
error sender=:1.154 -> dest=:1.62 error_name=org.freedesktop.DBus.Error.UnknownMethod reply_serial=8415
   string "No such interface `org.gtk.Actions' on object at path /window/75497569"

=========[dbus output]=========
method call sender=:1.62 -> dest=:1.154 serial=8413 path=/window/75497569; interface=org.gtk.Actions; member=SetState
   string ".uno:PickList"
   variant boolean false
   array [
   ]
signal sender=:1.62 -> dest=(null destination) serial=8414 path=/com/canonical/Unity/Panel/Service; interface=com.canonical.Unity.Panel.Service; member=EntryActivated
   string ""
   struct {
      int32 0
      int32 0
      uint32 0
      uint32 0
   }
method call sender=:1.34 -> dest=org.ayatana.bamf serial=5682 path=/org/ayatana/bamf/matcher; interface=org.ayatana.bamf.matcher; member=ActiveWindow
method return sender=:1.38 -> dest=:1.34 reply_serial=5682
   string "/org/ayatana/bamf/window75497569"
method call sender=:1.34 -> dest=org.ayatana.bamf serial=5683 path=/org/ayatana/bamf/window75497569; interface=org.ayatana.bamf.window; member=WindowType
method return sender=:1.38 -> dest=:1.34 reply_serial=5683
   uint32 0
method call sender=:1.34 -> dest=org.ayatana.bamf serial=5684 path=/org/ayatana/bamf/window75497569; interface=org.ayatana.bamf.view; member=Name
method return sender=:1.38 -> dest=:1.34 reply_serial=5684
   string "GIC Project Report.odt - LibreOffice Writer"
error sender=:1.154 -> dest=:1.62 error_name=org.freedesktop.DBus.Error.UnknownMethod reply_serial=8413
   string "No such interface `org.gtk.Actions' on object at path /window/75497569"
method call sender=:1.62 -> dest=:1.154 serial=8415 path=/window/75497569; interface=org.gtk.Actions; member=Activate
   string ".uno:SaveAs"
   array [
   ]
   array [
   ]
error sender=:1.154 -> dest=:1.62 error_name=org.freedesktop.DBus.Error.UnknownMethod reply_serial=8415
   string "No such interface `org.gtk.Actions' on object at path /window/75497569"
method call sender=:1.62 -> dest=org.freedesktop.DBus serial=8416 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=AddMatch
   string "type='signal',interface='ca.desrt.dconf.Writer',path='/ca/desrt/dconf/Writer/user',arg0path='/com/canonical/indicator/datetime/'"
method call sender=:1.62 -> dest=org.freedesktop.DBus serial=8417 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=RemoveMatch
   string "type='signal',interface='ca.desrt.dconf.Writer',path='/ca/desrt/dconf/Writer/user',arg0path='/com/canonical/indicator/datetime/'"
method call sender=:1.62 -> dest=org.freedesktop.DBus serial=8418 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=AddMatch
   string "type='signal',interface='ca.desrt.dconf.Writer',path='/ca/desrt/dconf/Writer/user',arg0path='/com/canonical/indicator/datetime/'"
method call sender=:1.62 -> dest=org.freedesktop.DBus serial=8419 path=/org/freedesktop/DBus; inte...

Read more...

tags: added: regression-release
Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed
tags: removed: regression-release

I think I cornered the issue. A version with a tentative hotfix has been copied to the LibreOffice PPA for raring as 1:4.0.2-0ubuntu2~raring1~ppa2 -- please test this one viciously. At least for my test scenario of "Startcenter->New Document->Print Preview->Quit LibreOffice" it seems to work now.

I will in the meantime try to find a more proper solution.

https://launchpad.net/~libreoffice/+archive/ppa/+sourcepub/3108947/+listing-archive-extra

Changed in libreoffice (Ubuntu):
status: Confirmed → In Progress

The fixed package above has seen some ~995 downloads so far without any complaints. Can someone report back that this is fixed for him with that I might consider pushing that for a SRU.

Changed in libreoffice (Ubuntu):
status: In Progress → Fix Committed
Colin Law (colin-law) wrote :

I am confused as, for me, the problem disappeared when LO 4 appeared in Raring. (comment #48), version 1:4.0.2-0ubuntu1.

tags: added: raring

Problem description:
Using Ubuntu 13.04 and LibreOffice 4.0.2.2, the menu items in unity do not highlight.

Also, sometimes it is not possible to send commands by clicking on the menu items. This seems to happen at random.

Steps to reproduce:
1. Install Ubuntu 13.04 and LO 4.0.2.2
2. Click on a unity menu item like "edit"
3. See if the sub-items highlight

Current behavior:
No highlights on the menu items

Expected behavior:
highlights.

Operating System: Ubuntu
Version: 4.0.2.2 release

Hi,

Thanks for your report. Is it possible to attach screenshots that describes the problem? I don't use Ubuntu right now (so I can't test), but I think this'll increase the 'confirmation' speed of this bug.

Kind regards,
Joren

Hartwig Kolbe (kolbeb) wrote :

Is this fixed in 13.04? If so, I'll upgrade (despite other showstoppers like bug #1075923).
Alternatively, will installing LO 4 solve the issue?
Or, will there be an official update on 12.10 (for LO 3.6)?

Moritz Winter (winter-moritz) wrote :

I cant reproduce it in 13.04! Whole UI became uglier tough ;)

Bjoern - Mr. Ubuntu this one appears to be for you, I suspect it's not our bug but perhaps it is

So the menu sometimes doesnt work is fixed on master and on the version in the libreoffice ppa 1:4.0.2-0ubuntu2~raring1~ppa2 or later:
https://launchpad.net/~libreoffice/+archive/ppa
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1085169

The does not hightlight bug is a unity one:
https://bugs.launchpad.net/ubuntu/+source/indicator-appmenu/+bug/1153350

Next time, please dont mix multiple issues into one report, thanks.

Sorry, I am new to this whole bug-reporting business. Thanks for your effort!

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Bracken (abdawson) wrote :

Every time I use LibreOffice, after about 5 minutes, can't open any dialog. Have to close it and open it again. How can this fix not be released on supported versions of Ubuntu? LibreOffice is simply broken as it is.

Fixed in saucy. If you find a new cornercase with unity integration, please file a _NEW_ bug (and reference this one).

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released

Closing this as invalid in indicator-appmenu as the fix in LibreOffice seems to have solved all remaining issues.

Changed in indicator-appmenu (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.