Ubuntu

Screen refresh problems with nvidia cards

Reported by David Prieto on 2008-09-13
622
This bug affects 77 people
Affects Status Importance Assigned to Milestone
Compiz
In Progress
Unknown
compiz (Ubuntu)
Medium
Unassigned
Nominated for Hardy by numberxiii
Nominated for Jaunty by enubuntu
Intrepid
Medium
Unassigned
compiz-fusion-plugins-main (Debian)
Fix Released
Unknown
compiz-fusion-plugins-main (Ubuntu)
Undecided
lynda scheidt
Nominated for Hardy by numberxiii
Nominated for Jaunty by enubuntu
Intrepid
Undecided
Unassigned
nvidia-graphics-drivers-177 (Ubuntu)
Medium
Unassigned
Nominated for Hardy by numberxiii
Nominated for Jaunty by enubuntu
Intrepid
Medium
Unassigned
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by numberxiii
Nominated for Jaunty by enubuntu
Intrepid
Undecided
Unassigned

Bug Description

== Proposed compiz-fusion-plugins-main patch ==
See comment 234 by Anders Kaseorg and attached compiz-fusion-plugins-main_0.8.2-0ubuntu2.debdiff.

== Original report ==
Binary package hint: compiz

I'm using latest compiz on intrepid.

Since jockey-gtk does not work on my box (I already filed a bug), I manually installed nvidia-glx-177 and added the "driver → nvidia" line to xorg.conf.

Now I seem to be having some screen refresh problems when using compiz: parts of the screen are refreshed, but others aren't. That means nautilus doesn't show files or folders until I move the cursor over them, firefox doesn't show webpages properly until I scroll down, and so on.

Please, tell me if there is any additional info I can provide to find out the cause.

I also have this problem, running Intrepid with latest updates. For me, the problem is worst in Firefox. Under Metacity, everything looks fine.

Saivann Carignan (oxmosys) wrote :

I also confirm this problem. Setting status to confirmed and importance to medium.

Changed in compiz:
importance: Undecided → Medium
status: New → Confirmed

Is everyone here using the nvidia-glx-177 drivers? Does this problem occur when using the nvidia-glx-173 drivers?

It sounds like a problem with Compiz's damage system, but it'd be worth ruling out the drivers. I don't see this problem myself.

Reverting to 173 seems to have solved the problem here. I could only test it for a few minutes so I'll update if it shows up again, but it seems like it's gone so far.

For me, reverting to -173 does not help.

Martin Arver (martin-arver) wrote :

Reverting to 173 solved the problem for me.

lefthand (lefthand) wrote :

I'm having the same problem with an Intel GM965. I am using the Vesa driver, so that may be the problem. It seems like it's happening less in the last few days, not sure what has changed though.

I take back my earlier comment. -173 fixes the problem for me too.

Saivann Carignan (oxmosys) wrote :

Yes, I also confirm, this bug only happens with nvidia-graphics-drivers-177

Changed in nvidia-graphics-drivers-177:
importance: Undecided → Medium
status: New → Confirmed

I'm currently using 177, but when i used 173, I remeber having the same problem.

Alexander Jones (alex-weej) wrote :

Of note, Metacity's compositor does not have any problems.

Yes Alex, previous comments already noted that Metacity is fine...

Alexander Jones (alex-weej) wrote :

It's important to know that Metacity's *COMPOSITOR* (enable it in gconf) does not have any problems. That's the difference.

Martin Arver (martin-arver) wrote :

I ran the nvidia-bug-report tool, to see if there were something strange with my installation.
That tool scanned /var/log/messages for NVRM messages.
Several API-mismatch messeges were reported, wonder why 173.14.12 is still present in my system.

Sep 15 19:43:22 martin-laptop kernel: [ 280.996545] NVRM: API mismatch: the client has the version 173.14.12, but
Sep 15 19:43:22 martin-laptop kernel: [ 280.996546] NVRM: this kernel module has the version 177.70. Please
Sep 15 19:43:22 martin-laptop kernel: [ 280.996547] NVRM: make sure that this kernel module and all NVIDIA driver
Sep 15 19:43:22 martin-laptop kernel: [ 280.996548] NVRM: components have the same version.
Sep 15 19:45:05 martin-laptop kernel: [ 15.172429] NVRM: loading NVIDIA UNIX x86 Kernel Module 173.14.12 Thu Jul 17 18:11:36 PDT 2008

I'll attach the output from var/log/messages

Rocko (rockorequin) wrote :

I can reproduce this frequently just by switching between images in GQView that have different widths: the sides of the wider image are often left behind next to the narrower image (see attached screenshot. The nvidia driver put the black bars in on the side).

This doesn't happen with the nvidia 173.14.12 driver, only with the 177.70 driver. I'm running 2.6.27-3 amd64 and GQView 2.0.4-3.

Martin Arver (martin-arver) wrote :

It looks like the 177.76 update fixed the issue for me. I haven't been able to recreate the rendering problems after I updated.

Rocko (rockorequin) wrote :

I still get the corruption problems in GQView with the 177.76 driver.

Also, if I make a blank document in GIMP, make the mouse the paintbrush and move the mouse around, bits of the mouse cursor still get left randomly on the screen image with this driver.

Neither problem happens in the 173.14.12 driver.

Oli (oli) wrote :

I still get the problem with 177.76, albeit less frequently.

Martin Arver (martin-arver) wrote :

I can confirm that the gimp-problem that Rocko describes is still there for me, using 177.76.

henriq (henriq) wrote :

I had this problem on kernel 2.6.27.3 but after the update to 2.6.27.4 it seems to have gone away. I'm using the 177 nvidia drivers on a nvidia mobile 8400gs

Oli (oli) wrote :

I'm still getting the problem, though I think it's happening less often than before.

Most GTK+ things are redrawing fine now with the exception of Firefox and webkit loading images (sometimes the image loads as black until I either scroll it off the page and back on again, or force a whole-screen refresh using Compiz' desktop cube effect)

I'm still getting a lot of issues with Qt apps - the most notable being Amarok. It's easily reproducable here by selecting a menu and skimming over all the entries. Some are left selected when they shouldn't be.

Oli (oli) wrote :

That's with a 8800GTS, 177.76 and 2.6.27-4-generic (2.6.27.4.4)

jking2100 (laptop-jck-family) wrote :

I am using the latest updates as of 12:51pm Oct-04-2008. Nvidia 177.78 Driver, Nvidia Quadro 135m and Kernel 2.6.27-4 32bit. I receive the problem with 177.70, 177.76 and 177.78. Sits at Searching for Driver and will not proceed. Once i choose cancel compiz effects are present. But screen refresh problems exist in many tabbed applications such as Firefox or Avant Window Manager Preferences.

JKing

Andrew Tamoney (tamoneya) wrote :

I can confirm this problem with 177.80.
Nvidia Quadro 140m, 2.6.27-6 64 bit.
The system is fully updated at the moment.
I notice it primarily with firefox since I am not using awn or gimp at the moment.

Nick B. (futurepilot) wrote :

Confirming this still happens with 177.80. In fact it seems to have gotten worse.

Nick A (nickalleyne) wrote :

I agree with Nick B. above me, it is a LOT worse, actually un-useable to some extent so I will be going to 173 until I hear something is fixed with this.

Dell D630

As I posted in ubuntu forums:
I have been using intrepid since sunday and had no problems, but with the new version, every time I go to a screen in firefox that has any pictures, if I Page down, it looks as if nothing has changed, but then if I click the down button from there the screen will appear (or if I roll over any links that change colour with the mouse, they will appear).

Rocko (rockorequin) wrote :

For me this bug is present in 177.80 in exactly the same way as with the previous 177.76 drivers. (Dell XPS 1530 laptop, NVidia mobile 8600 card.)

The easiest way is to confirm it is to run GIMP, create a blank drawing, select the drawing tool so you get a circular cursor, and move the cursor around a blank drawing. Bits of the cursor remain behind on the blank drawing.

GCView also has the same problem as I reported before - it sometimes only redraws the new image, leaving parts of the old behind.

Occasionally I get other problems like Firefox not refreshing properly but they are relatively rare.

Andrew Tamoney (tamoneya) wrote :

It seems to have gotten worse on my hardware. I didnt even notice it until i switched to 177.80.

hrushikesh (hrushikesh) wrote :

Confirm it on a Dell XPS M1330 with the Nvidia 177 drivers.

If I enable 'scale' plugin in compiz, and then 'scale' by moving the mouse pointer to the edge of the screen, the firefox (and possibly other) windows refresh.

Aaron Plattner (aplattner) wrote :

This sounds a lot like this problem, which is unfortunately a fundamental problem in the way the Damage extension is currently designed: http://lists.freedesktop.org/archives/xorg/2008-August/038022.html

The quick summary is that the X server sends damage events to compiz before sending the rendering commands to the hardware, and compiz can respond to those events before the damage has actually occurred. Some solutions have been proposed, but nothing has been implemented yet.

morryis (morryis) wrote :

I see different refreshing problems with intrepid:
- Everytime a new window or menu opens, for a short time I see artifacts of the background image or an old window.
- When viewing pictures with gthumb or gqview in fullscreen mode, the old image ist left behind when drawing a new one (even appears sometimes later when opening a new window, see above).
- In Ooo and Evolution while writing text or a new email, when I manually move the cursor with the arrow keys it leaves black bars on every position. The screen is refreshed correctly when i point and click somewhere else with the mousepointer. Especially this is really annoying!

I noticed one interesting thing: when I start compiz manually on startup, using FusionIcon, these problems do not occur. When compiz is started by ubuntu i.e. the visual effects settings, i get refresh problems. After disabling them by visual effect settings and reactivating them again, I still experience artifacts. But when i use FusionIcon, all refreshing problems are gone. I could not figure out, what the difference between starting compiz via FusionIcon or by visual effects settings is.

Kuba Górski (saiyan-iv) wrote :

I confirm this on Dell XPS M1330 with nvidia 177.80. Running Intrepid with latest updates.

enubuntu (enubuntu) wrote :

I confirm this on Asus Z53S with nvidia 177.80 driver installed with envy. I try the driver proposed by ubuntu, same result. 173 driver too....
I use Intrepid with all update.
please help :(

Ciso (cisoprogressivo) wrote :

Same problem with Dell XPS M1330 in intrepid.
I have problem with Firefox and emesene.

James Lambert (jms-lambert) wrote :

This seems to have gotten a lot worse with the latest set of nvidia updates, Firefox now doesn't update properly whenever I open a tab, this used to only happen occasionally.

®om (rom1v) wrote :

Same problem for me : https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/281065
Ubuntu Intrepid 64 bits beta + nvidia 177

Joakim Andersson (jocke) wrote :

With an Nvidia mobile 8400GS (on a Dell XPS M1330 running Intrepid 64-bit), it happens for me with both the 177 and 173 drivers.

I have almost a 100% reproducibility rate in CompizConfig Settings Manager (clicking a plugin to show its settings), but the worst thing is Firefox, since I use it more often...

Changed in compiz:
milestone: none → ubuntu-8.10
Changed in nvidia-graphics-drivers-177:
milestone: none → ubuntu-8.10
Changed in compiz:
status: Confirmed → Fix Released
Martin Pitt (pitti) on 2008-10-17
Changed in nvidia-graphics-drivers-177:
milestone: ubuntu-8.10 → none
status: Confirmed → Won't Fix
Changed in nvidia-graphics-drivers-177:
status: Confirmed → Invalid
enubuntu (enubuntu) on 2009-02-27
Changed in compiz:
status: Fix Released → Confirmed
enubuntu (enubuntu) on 2009-02-27
Changed in nvidia-graphics-drivers-180:
status: New → Confirmed
Changed in compiz:
milestone: ubuntu-8.10 → ubuntu-9.04
status: Confirmed → Triaged
Changed in compiz-fusion-plugins-main:
status: Unknown → New
Changed in compiz:
status: Unknown → In Progress
description: updated
Changed in compiz-fusion-plugins-main (Ubuntu):
status: New → Fix Released
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → christian-wilhelmsen87
status: Fix Committed → Confirmed
Michael Rooney (mrooney) on 2009-04-16
Changed in nvidia-graphics-drivers-180 (Ubuntu):
assignee: sinnadyr (christian-wilhelmsen87) → nobody
246 comments hidden view all 326 comments

@selkovjr:

Like you, I still have refresh issues when using Firefox. For example, when I'm reading an e-mail in Evolution containing an HTTP link, if I click on the link it opens in a Firefox tab, the Firefox window "tries" to put on top, but the tab contents is not shown. If I minimize the Firefox window and then maximize it again (using the task bar), then the problem disappears.

tankdriver (stoneraider) wrote :

Hello,

I didn't read all 200+ comments, but I think I have a similar problem:

The "worst" application is OpenOffice (all menues&windows, parts of the sheet) (partly UNUSABLE)
And the Qt Applications:
                       Skype (partly everything)
                        VLC (menu & Settings, playlist)
                        Virtualbox (Buttons, menus)
sometimes nautilus (Detail view)

My System:
HP HDX-18 Premuim Laptop, Nvidia GeForge 9600M GT
OS: Jaunty 64-bit, nvidia 180.44 prop. driver provided by Ubuntu (COMPIZ ON)
I recognized some minor Problems in the last month with intrepid too.

If you need more Data from my side (screenshots/casts) let me know.

Skeletonix (tomaskloucek) wrote :

lspci | grep VGA

01:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GS] (rev a1)
---
lspci -n | grep 300

01:00.0 0300: 10de:0392 (rev a1)

tankdriver (stoneraider) wrote :

lspci | grep VGA

01:00.0 VGA compatible controller: nVidia Corporation GeForce 9600M GT (rev a1)
-----------
lspci -n | grep 300

01:00.0 0300: 10de:0649 (rev a1)

Sebastien Bacher (seb128) wrote :

unsubscribing the sponsor team since the debdiff has been uploaded before jaunty

Robert Ancell (robert-ancell) wrote :

Closing Compiz component as this is correctly solved in compiz-fusion-plugins-main

Changed in compiz (Ubuntu):
status: Triaged → Invalid
hkais (r-2) wrote :

Hello all,

maybe I can visualize the problem with my screenshots. It is more than anoying. In my opinion it isn't usable any more!

screenrefresh-problem1.png:
Here you see the Thunderbird, which should be ontop of Firefox. You see a mixup of Thunderbitd and Firefox! You can see, you cannot use it.

screenrefresh-problem2.png:
Here you see the screen of a Terminal Server Session. The buttons, and the contents of the Internetexplorer is nearly completly missing!

screenrefresh-problem3.png:
Here you see a freshly opened and already completly started OpenOffice-Writer. The text in there is a editorwindow on an other desktop! And the slash is already closed!

As you can see, the current state of Ubuntu is pretty unusable.
I would like to help as far as a user can. I cannot see any workaround to fix temporarily this problem. Speed/Performance is not the issue, my major point is to be again productive on my ubuntu.

2 comments hidden view all 326 comments
Rob Hasselbaum (rhasselbaum) wrote :

The bug has already been fixed in Jaunty. Go to Workarounds in CompizConfig-Settings-Manager and turn on "Force synchronization between X and GLX".

tankdriver (stoneraider) wrote :

@hkais:
try the latest stable drivers from the ubuntu-x-swat team:
https://launchpad.net/~ubuntu-x-swat/+archive/x-updates
It should be better.
But be careful, the drivers are not as well tested as the default ones.
(I came across some crashes with this PPA and HP-HDX Notebook)

Luke12 (luca-venturini) wrote :

Rob_H is absolutely right. I came across the solution yesterday night, and lo and behold, it is finally perfect! :-)

Konrad Materka (kmaterka) wrote :

Turning on "Force synchronization between X and GLX" fixes all problems.

NVidia 9600 M, Ubuntu Jauntu 9.10 with all updates.

I haven't noticed any slowdowns.

On another machine with NV 7900 and KDE4 I haven't noticed any problems, probably kwin is turning synchronization by default...

hkais (r-2) wrote :

Hello all,

the problem isn't solved with the "Force synchronization between X and GLX".
It helped a litte bit, so the screen gets rerendered, but only if you click on any window-decoration or the gnome menu.

Here an additional screenshot with activated "Force synchronization between X and GLX".
I cannot reproduce the issue, but it often happens if I switch back or into vmware-player/workstation.

I haven't installed any other drivers as the default once, which are published with the usual ubuntu repos. This is my business notebook, therefore it must stay available.

Here more infos:
lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 140M (rev a1)

lspci -n|grep 01:00.0
01:00.0 0300: 10de:0429 (rev a1)

I am running on Lenovo T61 with the latest default provided proprietary nvidia drivers ver 180.

uname -a
Linux ntp-dp 2.6.28-13-server #45-Ubuntu SMP Tue Jun 30 20:51:10 UTC 2009 i686 GNU/Linux

Ubuntu 9.04 (32bit)

I hope someone can help me?
Maybe it is correlated with the Bug #393176 ?

hkais (r-2) wrote :

Hello all,
really no workaround/bugfix for my problem?

hkais (r-2) wrote :

Hello all,
as nobody replyed, I had the nerve to install the newest nvidia drivers.
So far the crappy display is gone. That's the good part.
The bad part, my X-Server dies regularly now. (about 3-4 times a day)
This is a big pain right now, because I run often my vmware. If the x-server dies, the vmware-instance dies also...

How can I help to find the error? Which logs do you need?
Do I have to increase the trace-level? If so how?

hkais, how did you install the latest nvidia drivers? From a PPA? If
so, which? https://launchpad.net/~ubuntu-x-swat/+archive/x-updates is
the best place that I am aware of. Downloading and installing from
nvidia directory is likely to cause problems and is not recommended.
As with Ubuntu in general, it is best to stick with the package
manager.

Micheal,

thanks for the quick reply.
I installed the following files from the x-swat team
https://launchpad.net/%7Eubuntu-x-swat/+archive/x-updates/+sourcepub/652654/+listing-archive-extra

ii nvidia-173-modaliases 173.14.16-0ubuntu1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-180-kernel-source 185.18.14-0ubuntu1 NVIDIA binary kernel module source
ii nvidia-180-libvdpau 185.18.14-0ubuntu1 Video Decode and Presentation API for Unix
ii nvidia-180-modaliases 185.18.14-0ubuntu1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-71-modaliases 71.86.08-0ubuntu1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-96-modaliases 96.43.10-0ubuntu1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-common 0.2.11 Find obsolete NVIDIA drivers
ii nvidia-glx-180 185.18.14-0ubuntu1 NVIDIA binary Xorg driver
ii nvidia-settings 180.25-0ubuntu1 Tool of configuring the NVIDIA graphics driv

I have only installed the nvidia files. Should I install more?

That might work, I'm not sure. The important thing is to remove the
manually installed version from nvidia if you had done that, and
install nvidia-glx-180, then restart. If that doesn't work, I'd try
aptitude purge nvidia-glx-180, then reinstalling, and seeing if that
helps. Having various parts of different drivers lying around can
cause issues.

Hello Michael,

sorry for my maybe stupid questions. It is my first time I am patching my graphics-driver. The last experiences there pretty aweful and I killed my X-Setup

I installed the packages manually, but now, if I try to deinstall it via aptitude/synaptic I get the warning, that a deinstall of any modalias version whats to deinstall also nvidia-common.
Therefore, what should I do to keep my system alive and to have an updated nvidia-driver?

Additionally there are many other packages in ppa for 9.04 byside the nvidia one. Should I install also any additional of them?
fglrx-installer - 2:8.620-0ubuntu3~jaunty
libdrm - 2.4.9-1ubuntu1~xup~1
nvidia-graphics-drivers-180 - 185.18.14-0ubuntu1
xfree86-driver-synaptics - 0.99.3-2ubuntu5
xserver-xorg-input-vmmouse - 1:12.6.4-0ubuntu1~xup~1
xserver-xorg-video-nv - 1:2.1.13-1ubuntu1~xup~1
xserver-xorg-video-openchrome - 1:0.2.903+svn741-1build1

hkais (r-2) wrote :

Hello,

I had again the nerve to uninstall and install blind the packages.
I deinstalled and purged all nvidia-* package
now I have only
ii nvidia-180-kernel-source 185.18.14-0ubuntu1 NVIDIA binary kernel module source
ii nvidia-180-libvdpau 185.18.14-0ubuntu1 Video Decode and Presentation API for Unix
ii nvidia-180-modaliases 185.18.14-0ubuntu1 Modaliases for the NVIDIA binary X.Org drive
ii nvidia-glx-180 185.18.14-0ubuntu1 NVIDIA binary Xorg driver
ii nvidia-settings 180.25-0ubuntu1 Tool of configuring the NVIDIA graphics driv

I hope the system will get much more stability. (I will report)

Additionally I am not sure, if one othe the other X-SWAT-Packages should be installed.

And is it possible to pin packages from the PPA in apt/preferences? If so how?

hkais (r-2) wrote :

sorry for spamming with my infos.

My X-Server crashes also after the purge/install again.
So the x-server crash is my biggest pain currently!
I cannot be sure, that I can properly work.

How can I help to reproduce the error and further more to trace it. Currently my x-server dies and I cannot see any errors in the syslog. Often it also happens, that the x-server isn't able anymore to restart. It tries to restart 3 or 4 times and tells me that I have to change to a low-res mode.

Dennis Dirdjaja (dcd-ditsch) wrote :

hkais, I suggest you open a question on https://answers.launchpad.net/ or the forums because you obviously won't get support here and I doubt your current issue is related to the original bug.

hkais (r-2) wrote :

Dennis Dirdjaja,

the problems occured with the update to the new version of the driver

Bryce Harrington (bryce) on 2009-08-13
tags: added: intrepid
hkais (r-2) wrote :

Hello,

sorry for getting rude. I am working now since weeks with a crappy unsable X-Server under 9.04 32bit.
Today I have lost about 4 hours of work. And I have to finish the work tomorrow until 12pm. I had never worked on such a crappy linux-distribution since the 8.10 and especially the 9.04 updates!
I have never had such a crappy x-server, there the server dies regularly! Usually I had to setup the x-server one time (sometimes with pain) and only one time. And the complete work on the desktop/notebook was done. Since 8.10 the x-server seems to be a pretty crap from the point of stability.

To my history. I work with linux since 10 years. With Ubuntu since 2005. I switched our servers 2006 with the availability of LTS to ubuntu. Therefore I am not a noob from the point of ubuntu-server. From the point of ubuntu-desktop. I never had a problem to fix a unstable x-server.

I have asked multiple times how I could support here, to get the error fixed. For now I have got pretty few answers.

I tried all proposed solutions and none of them fixed my problem. The bugs in the screenrefreshes have been eased but not fixed. I sometimes get further screenrefresh-errors on the x-screen. Now with the PPA-drivers my x-server dies pretty regularly.

So am I really forced to switch to back to redhat/novell(suse)? I hope not.

So again I ask you how can I support you to figure out there the problem is.
I cannot see anything in the logs, which give my a clue. How can I increase the verbosity of the x-server logs and maybe the verbosity of the nvidia-driver?

hkais (r-2) wrote :

The amount of users seems to increase.
Again I am willing to help, but give me instructions how to help..

Bug #342980

hkais (r-2) wrote :

Forgot: it now also affects 9.10/karmic

®om (rom1v) wrote :

hkais, even the option "Force synchronisation between X and GLX" in compizconfig doesn't solve the problem for you?

For me it resolves completely…

The "Force synchronisation between X and GLX" option solves the problem for me in Jaunty, but it doesn't work very well on Karmic. Now I have a big screen refresh problem when I minimize the aMSN window to tray (bug #465644). I tried enabling and disabling the "Force synchronisation between X and GLX" option without luck, as well as using other nvidia-glx versions.

Changed in compiz-fusion-plugins-main (Ubuntu Intrepid):
status: New → Won't Fix
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → Invalid
Changed in nvidia-graphics-drivers-180 (Ubuntu Intrepid):
status: New → Invalid
Travis Watkins (amaranth) wrote :

Just FYI, this was actually a bug in compiz but nvidia was the first to trigger it. The open source drivers will most likely trigger it in lucid so in karmic we've got a patch that does the same thing as the "Force sync between X and GLX" option but it does it all the time and that option has no effect on it.

hkais (r-2) wrote :

Under intrepid I tried:
- "Force sync between X and GLX"
- multiple upgrades of the nvidia drivers
- upgrades of compiz and xorg from ppa
- in the meanwhile I do not know what I have already tried. but it have been multiple of hour of investigation. Until now no success.

Now I hopefully switched to karmic, and the problems are still there, that is frustrating for me. Especially if you remind, that I tried all suggestions on the topic.
So the "Force sync between X and GLX" is already activated.

@Travis: how can I fix it, if there is already a patch?

"Force synchronization between X and GLX" doesn't help for me (it was already checked). I've always had this problem on my current hardware, but now it's much worse under Karmic.

This really needs to be fixed!

I'm on Karmic with nvidia-glx-185 185.18.36-0ubuntu9+ppa2 and seeing this quite a bit. I have to manually refresh windows using the title bar to roll them up and then down again.

Is this supposed to be fixed in Karmic or is it still a known issue?

Having skimmed the comments in this bug, I will add that I already have the "Force synchronization between X and GLX" workaround enabled.

Changed in compiz-fusion-plugins-main (Debian):
status: New → Fix Released
Changed in compiz-fusion-plugins-main (Ubuntu):
assignee: nobody → lynda scheidt (lyndastill007)
1 comments hidden view all 326 comments

I've attached a patch that fixes the problem.

To give a little more detail on the race condition:

The problem is that when the X server receives a request to do some drawing, it will send the drawing commands to the video driver and then it immediately sends out the damage event. That works as long as the GPU only processes one command at a time, in the order they were given.

But, an Nvidia GPU can handle multiple command streams at the same time. If the X11 rendering takes long enough, then Compiz will try to redraw the screen while the application's rendering is still in progress.

The GL_EXT_x11_sync_object extension was created to fix this exact problem. It lets you use an X11 fence as an OpenGL sync object, so you can make Compiz's rendering wait until any X11 rendering has finished.

Margarita Manterola (marga-9) wrote :

Hi, for some reason the patch added by Kyle doesn't show in the comment history as normally, although it's on the patch list on the right. His patch is:
Add an option to use GL_EXT_x11_sync_object to synchronize updates with X11 drawing

I have tested this patch using Unity in precise and I was unable to reproduce the screen refresh issue. It would be great if this patch could be applied for the compiz version in precise, as well as to the latest version, of course.

summary: - Screen refresh problems with nvidia on intrepid
+ Screen refresh problems with nvidia cards

I've attached a patch with the same fix that should work with compiz 0.9.7.12 in Precise.

Stephen M. Webb (bregma) wrote :

The patches seem to be copyrighted by nVidia and authord by one James Jones. Where do they come from?

James Jones is the original author of the patch. I made a couple modifications to it before attaching it -- some minor simplifications, adding the config option, slightly better error resilience, and updating it to work against the latest compiz source tree.

Displaying first 40 and last 40 comments. View all 326 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.