Nautilus 3 not supported?

Bug #841381 reported by Novetica Services on 2011-09-04
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nautilus Terminal
Fix Released
Wishlist
Fabien LOISON
nautilus-terminal (Fedora)
Fix Released
Medium

Bug Description

I'm testing oneiric... is nautilus 3 supported? will it be?

Description of problem:

After reboot nautilus-terminal does not start when a nautilus session is opened.

Version-Release number of selected component (if applicable):

0.7-2.fc15

How reproducible:

Every time

Steps to Reproduce:
1. Install nautilus-terminal
2. Restart
3. Open a nautilus session

Actual results:

Does not appear

Expected results:

A terminal emvedded in nautilus

Additional info:

Fabien LOISON (flozz) wrote :

Hello,

I'm working on Nautilus Terminal 1.0 that will support Nautilus 3.x :)

Changed in nautilus-terminal:
assignee: nobody → Fabien LOISON (flozz)
importance: Undecided → Wishlist
milestone: none → 1.0
status: New → In Progress
Novetica Services (novetica) wrote :

Great news! ;)

God bless yoss (you & open source software)! :D :D :D

Same problem for me. Actually the Ctrl+Shift+T shortcut should bring up the terminal, but it doesn't happen anything. Even when I start nautilus from a terminal, I don't get any info while using the shortcut.

However, a new version 0.7.1 has been released recently (2011-08-20). Perhaps it solves the problem.

According to upstream, 1.0 will support nautilus3.

0.7.1 is an update supporting nautilus2 only.

(In reply to comment #2)
> According to upstream, 1.0 will support nautilus3.
>
> 0.7.1 is an update supporting nautilus2 only.

This means, the package is actually unusable on F15 and F16 systems. Is there a convenient way to drop the package from the package database? The current state is somewhat annoying for the users.

(In reply to comment #3)
> (In reply to comment #2)
> > According to upstream, 1.0 will support nautilus3.
> >
> > 0.7.1 is an update supporting nautilus2 only.
>
> This means, the package is actually unusable on F15 and F16 systems. Is there a
> convenient way to drop the package from the package database? The current state
> is somewhat annoying for the users.

Package won't be removed until it is officially dead upstream, which it isn't. I may try to help with the port to nautilus 3.

Alin Andrei (nilarimogard) wrote :

I can't wait for this! :D

Fabien LOISON (flozz) wrote :

Hello,

If you really can't wait, you can install the devel version manually:

mkdir ~/.local/share/nautilus-python/extensions
cd ~/.local/share/nautilus-python/extensions
wget "http://bazaar.launchpad.net/~flozz/nautilus-terminal/1.x/download/head:/nautilus_terminal.py-20110821120001-cufq4xjvn6fhdshs-5/nautilus_terminal.py"

and then restart nautilus. :)

NOTE : The dependences are listed here: http://bazaar.launchpad.net/~flozz/nautilus-terminal/1.x/view/head:/README

Alin Andrei (nilarimogard) wrote :

Thank you!

Hicham HAOUARI (funnylife-ma) wrote :

I will track bzr on fedora 15+, so no manual install is needed

nautilus-terminal-1.0-0.1.8bzr.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/nautilus-terminal-1.0-0.1.8bzr.fc16

nautilus-terminal-1.0-0.1.8bzr.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/nautilus-terminal-1.0-0.1.8bzr.fc15

Fabien LOISON (flozz) wrote :

@Hicham HAOUARI:

I added the install script in the branch... For packaging you can use it with the -p option:

./install.sh -p /output/folder

see "./install.sh -h" for more informations

Vincent Untz (vuntz) wrote :

This patch is needed, as mentioned in http://www.j5live.com/2011/08/14/announce-pygobject-2-90-1-released-3-0-pre-release/ :

import gobject must be ported as from gi.repository import GObject – this was the recommended way of importing GObject but some code may still have used import gobject. Having both will cause applications to fail because it will load the older 2.28 bindings alongside the 3.0 bindings.

Fabien LOISON (flozz) wrote :

@Vincent Untz:

I already tried to use the GObject from gi.repository... but there is an issue with Nautilus Python... but you're already aware :p
https://bugzilla.gnome.org/show_bug.cgi?id=660348

Vincent Untz (vuntz) wrote :

After cheating a bit in nautilus-python, I see this:

Traceback (most recent call last):
  File "/usr/share/nautilus-python/extensions/nautilus_terminal.py", line 355, in <module>
    class NautilusTerminalProvider(GObject, Nautilus.LocationWidgetProvider):
TypeError: Error when calling the metaclass bases
    __init__() takes exactly 1 argument (4 given)

Fabien LOISON (flozz) wrote :

@Vincent Untz:

I have the same error without cheating in nautilus-python :)

Package nautilus-terminal-1.0-0.1.8bzr.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nautilus-terminal-1.0-0.1.8bzr.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/nautilus-terminal-1.0-0.1.8bzr.fc16
then log in and leave karma (feedback).

Vincent Untz (vuntz) wrote :

Okay, I fixed everything, and here's the nautilus-terminal part. I'll add the nautilus-python patches to https://bugzilla.gnome.org/show_bug.cgi?id=660348

Fabien LOISON (flozz) wrote :

Patch applied, it works :)

comete (comete) wrote :

Thanks for working on this.

I tried installing the extension but I'm having a problem. I still got the error "__could not import GObject__".

I made sure the patch was applied, but the bzr branch has it already.

It seems to come from **python-nautilus** and affecting many projects[1].

[1] https://bugs.launchpad.net/ubuntu/+source/nautilus-python/+bug/859104

Vincent Untz (vuntz) wrote :

comete: you need the nautilus-python patch mentioned in comment 12.

nautilus-terminal-1.0-0.1.8bzr.fc15 has been pushed to the Fedora 15 stable repository. If problems still persist, please make note of it in this bug report.

nautilus-terminal-1.0-0.1.8bzr.fc16 has been pushed to the Fedora 16 stable repository. If problems still persist, please make note of it in this bug report.

comete (comete) wrote :

A new nautilus-python is out : https://launchpad.net/ubuntu/oneiric/amd64/python-nautilus/1.0-0ubuntu2
It should be available soon as an update.

The terminal is active and usable, but I can't hide it.
I tried "Ctrl + Shift + t" but nothing happened.

Also there is no preferences panel.

Otherwise it's great to have it back ! Thanks.

comete (comete) wrote :

Sorry I had to read the source code to see it : the default shortcut for showing/hidding the terminal is "F4".

Fabien LOISON (flozz) wrote :

@comete:

Yes it's now F4... :)

Nautius Terminal 1.0 is not an update of the 0.7.x, but a "new" extension rewrote from scratch... So functionalities like preferences or drag&drop will be available later :)

Fabien LOISON (flozz) on 2011-10-17
Changed in nautilus-terminal:
status: In Progress → Fix Released

Hello, I am using Fedora 16 x86_64 and have 1.0-0.1.8bzr.fc16 version of nautilus-terminal installed. The problem still persist.

@Denis:

War are your versions of Nautilus and Nautilus Python ?

For Nautilus 3.0, you need:
  * Nautilus Terminal (old bzr revision of the 1.x branch or 1.0)
  * Nautilus Python 1.0

For Nautilus 3.2, you need:
  * Nautilus Terminal 1.0
  * Nautilus Python 1.1

nautilus:

Arch : x86_64
Version : 3.2.1
Release : 2.fc16

nautilus-python:

Arch : x86_64
Version : 1.0
Release : 1.fc16

In which repository is nautilus-python 1.1? Rawhide?

I have fedora-updates-testing enabled, and the bug is closed 24 days ago...

(In reply to comment #12)
> nautilus:
>
> Arch : x86_64
> Version : 3.2.1
> Release : 2.fc16
>
> nautilus-python:
>
> Arch : x86_64
> Version : 1.0
> Release : 1.fc16
>
> In which repository is nautilus-python 1.1? Rawhide?
>
> I have fedora-updates-testing enabled, and the bug is closed 24 days ago...

The new bug is :

https://bugzilla.redhat.com/show_bug.cgi?id=744534

I am gonna try to fix it ASAP.

Changed in nautilus-terminal (Fedora):
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.