Ubuntu

Nautilus extensions written in Python do not work in Oneiric

Reported by Emilien Klein on 2011-09-25
42
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus Pastebin
High
Alessio Treglia
RabbitVCS
Unknown
Unknown
arista (Ubuntu)
Undecided
Unassigned
arkose (Ubuntu)
Undecided
Unassigned
bzr-gtk (Ubuntu)
High
Jelmer Vernooij
groundcontrol (Ubuntu)
Undecided
Unassigned
kupfer (Ubuntu)
Undecided
Unassigned
nautilus-clamscan (Ubuntu)
Undecided
Unassigned
nautilus-image-manipulator (Ubuntu)
Undecided
Emilien Klein
nautilus-pastebin (Debian)
Fix Released
Unknown
nautilus-pastebin (Ubuntu)
Medium
Alessio Treglia
nautilus-python (Debian)
Fix Released
Unknown
nautilus-python (Ubuntu)
Undecided
Unassigned
postr (Debian)
Fix Released
Unknown
postr (Ubuntu)
Undecided
Unassigned
rabbitvcs (Ubuntu)
Undecided
Unassigned
sparkleshare (Ubuntu)
Undecided
Unassigned
tortoisehg (Ubuntu)
Undecided
Unassigned

Bug Description

This bug report is intended to serve as a meta to survey the state of the different Nautilus extensions written in Python in Ubuntu 11.10.

I have first noted that nautilus-image-manipulator does not show up when right-clicking on an image in Ubuntu 11.10, which it should (and does in Debian testing, where the package comes from).

Looking at the release notes, significant changes have been made to Nautilus-Python in versions 0.7 and 1.0 that change the paths where the extensions are to be looked in. Ubuntu 11.10 is the first Ubuntu version to use Nautilus-Python > 0.7, so I'm suspecting this affects all Nautilus extensions written in Python.

I have opened 2 bug reports that are relevant to this issue [0] and [1]. I suspect the problem is related to 2 things:
- The extensions are not looked for anymore in the familiar /usr/lib/nautilus/extensions-2.0/python
- Importing the module `nautilus` is not valid anymore

Please mark your project/package as affect by this bug so that we can keep track of the affected packages, and share the solution to fix this. Don't forgot to add a comment to this bug when doing so.

[0] https://bugs.launchpad.net/ubuntu/+source/nautilus-image-manipulator/+bug/849361
[1] https://bugs.launchpad.net/ubuntu/+source/nautilus-python/+bug/858925

Emilien Klein (emilien-klein) wrote :

Use the "Also affects distribution" link to add your package.

I just added nautilus-image-manipulator.

I will soon send out an email to all the maintainers/developers (at least those I can find contact info for) to spread this message and hopefully we will be able to find a solution together.

Emilien Klein (emilien-klein) wrote :

I originally planned to send the following email to all the projects listed at the bottom, but it turns out to be more complicated than I thought, between the larger projects that have maintainer groups, and individuals without a public email address. I am thus going to add the projects as being affected by this bug, if not you can change the status of this bug for your own program.

Subject: About your Nautilus extension being [probably] broken in Ubuntu 11.10
To: All developers of Nautilus scripts written in Python

Body:
Hi all,

I'm sending you this email since you are developing a Nautilus extension in Python that is available in Ubuntu 11.10 (list of such packages at the end of this email).
I have created such an extension myself and packaged it for Debian. It is available there in the "testing" version [0]. The extension installs correctly in Debian. However, the extension does not show up in Nautilus in Ubuntu 11.10 (beta 2 for now) (exact same version as in Debian).

These are the version of Nautilus-Python/Python-Nautilus that are packaged:
- In Debian: 0.6.1 [1]
- In Ubuntu 11.10: 1.0 [2]

Looking at the release notes, significant changes have been made in versions 0.7 and 1.0 that change the paths where the extensions are to be looked in.

I have opened 2 bug reports that are relevant to this issue [3] and [4]. I suspect the problem is related to 2 things:
- The extensions are not looked for anymore in the familiar /usr/lib/nautilus/extensions-2.0/python
- Importing the module `nautilus` is not valid anymore

I have installed various of your extensions, all of which failed to display in Nautilus. I suspect that a lot (all?) of the Nautilus extensions written in Python are currently broken in Ubuntu 11.10. Have you tested your packages in the latest Ubuntu Beta, before your regular users start opening bug reports? This is the reason for the broad list of recipients.

I have opened a bug report against Nautilus-Python [5] for us to track the extent of this issue, and hopefully find a solution for it. Please mark your project/package as affected by this bug (by using the "Also affects distribution" link) so that we can keep track of the affected packages, and share the solution to fix this. Don't forgot to add a comment to this bug when doing so.

Sorry for the "spam", let's fix this!
Cheers,
    +Emilien

[0] http://packages.qa.debian.org/n/nautilus-image-manipulator.html
[1] http://packages.qa.debian.org/n/nautilus-python.html
[2] https://launchpad.net/ubuntu/+source/nautilus-python
[3] https://bugs.launchpad.net/ubuntu/+source/nautilus-python/+bug/858925
[4] https://bugs.launchpad.net/ubuntu/+source/nautilus-image-manipulator/+bug/849361
[5] https://bugs.launchpad.net/ubuntu/+source/nautilus-python/+bug/859104

emilien@ubuntu1110b2:~$ apt-cache rdepends python-nautilus
python-nautilus
Reverse Depends:
  tortoisehg-nautilus
  sparkleshare
  rabbitvcs-nautilus
  postr
  nautilus-pastebin
  nautilus-image-manipulator
  nautilus-clamscan
  nautilus-bzr
  nautilus-arista
  kupfer
  groundcontrol
  arkose-nautilus
  libnautilus-extension1

Emilien Klein (emilien-klein) wrote :

I should now have added all source packages depending on nautilus-python in Ubuntu 11.10. Please add a post and update the status of the bug for your project if you determine it is not affected. Oh, and sorry for the eventual spam...

Changed in nautilus-image-manipulator (Ubuntu):
assignee: nobody → Emilien Klein (emilien-klein)
status: New → Confirmed
Julian Taylor (jtaylor) wrote :

could this also be related to bug 857348?

Changed in nautilus (Ubuntu):
status: New → Invalid
Changed in nautilus-python (Debian):
status: Unknown → New
Emilien Klein (emilien-klein) wrote :

Andrew, just to make sure there's no misunderstanding, I marked Nautilus (itself) affected because the libnautilus-extension1 package (part of Nautilus) depends on python-nautilus. Are you sure this package is not affected?

David R. Hedges (p14nd4) on 2011-10-12
Changed in tortoisehg (Ubuntu):
status: New → Confirmed
Fabien LOISON (flozz) wrote :

Summary of the situation with Nautilus Python:
============================================

Moving to Nautilus 3.0 => Nautilus Python 1.0.0:

  All the extensions have to be rewritten in GTK3 because Nautilus is
  GTK3 now (so no more PyGTK). But we must continue to
  use GObject 2.x (import gobject) because Nautilus Python still uses
  gobject 2 ...
  There is also a change to make for the path where the extension goes.

Move to Nautilus 3.2 (the one in Oniric) => [no Compatible version of
Nautilus Python]

  The use of GObject 2 is no longer possible in Nautilus
  because it conflicts with GObject 3... We must therefore modify Nautilus
  Python (this is what Vincent Untz did in his patch). And we must
  also modify the Python extensions (from gi.repository import
  GObject,...).

So we have currently different problems to solve:
==================================================

  * Nautilus Python must be patched or we can not
    do anything. [The work is in progress for this part]

  * Extensions must all be changed in one way or
    another to make them work again (it is necessary to warn
    the developers of the various extensions, and hope they
    are willing to adapt their extensions (because it can be a huge
    work for some extensions). I think that this will take
    the most time...

Changed in nautilus-python (Debian):
status: New → Confirmed
Changed in nautilus-python (Debian):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kupfer - 0+v206-2

---------------
kupfer (0+v206-2) unstable; urgency=low

  * debian/patches/rhythmbox.patch:
    - rhythmbox-client has been temporarily removed upstream, kupfer
      plugin is no longer able to process playlist. Work-around this by
      invoking dbus-send utility directly.
  * debian/control:
    - Drop python-nautilus from Suggests.
  * debian/rules:
    - Pass --no-install-nautilus-extension to waf to avoid installing
      nautilus extension, it needs to be ported to PyGI in order to work
      with nautilus 3.x (Closes: #645857) (LP: #859104).
 -- Luca Falavigna <email address hidden> Wed, 19 Oct 2011 22:42:38 +0200

Changed in kupfer (Ubuntu):
status: New → Fix Released
Changed in nautilus-python (Debian):
status: Fix Committed → Fix Released
Emilien Klein (emilien-klein) wrote :

Marking rabbitvcs as affected, see bug #876514 (No rabbitvcs context menu in nautilus 3)

Changed in rabbitvcs (Ubuntu):
status: New → Confirmed
Emilien Klein (emilien-klein) wrote :

Marking arista as affected, see bug #846803 (context menu not showing)

Changed in arista (Ubuntu):
status: New → Confirmed
Emilien Klein (emilien-klein) wrote :

Marking bzr-gtk as affected, see bug #870782 ([nautilus-bzr] Needs porting for nautilus 3)

Changed in bzr-gtk (Ubuntu):
status: New → Confirmed
Emilien Klein (emilien-klein) wrote :

tortoisehg will not be ported to GTK+ 3, and the extension has already been dropped in Debian, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=612574

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus-image-manipulator - 0.4-1

---------------
nautilus-image-manipulator (0.4-1) unstable; urgency=low

  * New upstream release
    - Transition to Nautilus 3 and GObject introspection
      (Closes: #644694) (LP: #859104 and LP: #849361).
  * debian/control:
    - Require python-nautilus 1.1 or higher
    - Depend on gir1.2-gtk-3.0, gir1.2-glib-2.0, gir1.2-nautilus-3.0
    - Remove build dependency on pkg-config and python-nautilus
  * debian/watch:
    - Add `debian uupdate` after the URL
  * debian/copyright:
    - Conform to DEP-5: Machine-readable debian/copyright

 -- Emilien Klein <email address hidden> Wed, 26 Oct 2011 22:00:22 +0200

Changed in nautilus-image-manipulator (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tortoisehg - 2.1.4-1

---------------
tortoisehg (2.1.4-1) unstable; urgency=low

  * New upstream release.
  * Drop Nautilus extension as it does not support Gtk 3 (Closes: #644697,
    #612574, LP: #859104).
  * No longer remove config.py, as it will be removed by unapplying patches.
  * Add NEWS file reporting removal of toirtoisehg-nautilus.
  * Use system underscore.js instead of a private copy.
 -- Ludovico Cavedon <email address hidden> Mon, 07 Nov 2011 19:35:32 +0000

Changed in tortoisehg (Ubuntu):
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

 nautilus-python (1.1-1) unstable; urgency=low
 .
   * New upstream release.
     - Transition to nautilus 3 (Closes: #637315)
   * debian/control.in:
     - Adjusts {build-}dependencies
     - Bump Standards-Version to 3.9.2 (no further changes)
     - Add Vcs-* fields
   * Switch to dpkg-source 3.0 (quilt) format
   * debian/dirs: Create system-wide extensions directory to new location
   * debian/watch: Switch to .xz tarballs
   * debian/README.Debian: Update to new locations
   * debian/lintian-overrides: Add an override for the empty system-wide
     extensions directory
   * debian/copyright: Add missing copyright statements

Changed in nautilus-python (Ubuntu):
status: New → Fix Released
Jelmer Vernooij (jelmer) on 2011-12-17
Changed in bzr-gtk (Ubuntu):
assignee: nobody → Jelmer Vernooij (jelmer)
importance: Undecided → High
status: Confirmed → Fix Released
Alessio Treglia (quadrispro) wrote :

Fixed in Nautilus Pastebin 0.7.0

Changed in nautilus-pastebin:
assignee: nobody → Alessio Treglia (quadrispro)
importance: Undecided → High
status: New → Fix Released
Changed in nautilus-pastebin (Ubuntu):
assignee: nobody → Alessio Treglia (quadrispro)
importance: Undecided → Medium
status: New → In Progress
Changed in nautilus-pastebin (Debian):
status: Unknown → Fix Released
Alessio Treglia (quadrispro) wrote :

This bug was fixed in the package nautilus-pastebin - 0.7.1-1

---------------
nautilus-pastebin (0.7.1-1) unstable; urgency=low

  * New upstream release:
    - Changes in nautilus-pastebin 0.7.1:
      + Regression fix: the configuration didn't reflect changes to
        'author', 'username' and 'password'.
      + Remove "askconfirmation" feature, needs more work.
      + Fix libnotify integration.
    - Changes in nautilus-pastebin 0.7.0:
      + Port to GObject Introspection. (Closes: #644692)
      + Migrate from GConf to GSettings.
      + Port configurator's UI from libglade to GtkBuilder.
      + Now depends on pastebinit at runtime;
      + Fix Debian bug#570131, desktop file missed the "Exec" key.
  * Refresh 01-default_pastebin.diff.
  * Drop 02-desktop_file.patch, applied upstream.
  * Drop python-pastebin, not provided anymore.
  * Drop python-support, build with dh_python2.
  * Refresh Depends,Recommends to reflect pytgtk->gobject-introspection
    migration.
  * Update debian/copyright.
  * Bump Standards.

 -- Alessio Treglia <email address hidden> Wed, 01 Feb 2012 20:48:14 +0100

Changed in nautilus-pastebin (Ubuntu):
status: In Progress → Fix Released
Changed in postr (Debian):
status: Unknown → New
Bryce Harrington (bryce) wrote :

The postr task should now be fixed due to the sync for bug #1050484

Changed in postr (Ubuntu):
status: New → Fix Released
Changed in postr (Debian):
status: New → Fix Released
no longer affects: nautilus (Ubuntu)
Changed in rabbitvcs (Ubuntu):
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.