[OS X] copy & paste inserts a bitmap copy instead of the vector object

Bug #307005 reported by Mark Buckingham on 2008-12-10
442
This bug affects 71 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

I am using inkscape 0.46, which I built on Mac OSX 10.5.5, using the 'building inkscape using macports' directions.

I am using XQuartz-2.3.2_rc2.

Anyway, when I use the copy command, either from the menu or via Ctrl-C, and then use paste either via the edit menu or Ctrl-V, I am always getting a bitmap copy. Additionally, I am seeing files called 'inkscape_pasted_image_2008...png' on my Destkop when this happens.

It seems like the duplicate command works ok, but it doesn't use paste to work.

Update: this bug happens on
- Mac OS X 10.5 Leopard with X11 2.1.6
- Mac OS X 10.5 Leopard with X11/Xquartz 2.3.2 and later
- Mac OS X 10.6 Snow Leopard with X11 2.3.4
- Mac OS X 10.7 Lion with X11 2.6.4
- OS X 10.8 Mountain Lion with XQuartz 2.7.4
and can be worked around by changing the pasteboard preferences of X11/Xquartz.

Details about the changed X11 preferences:
<http://wiki.inkscape.org/wiki/index.php/FAQ#Copying_and_pasting_in_Inkscape_creates_pixellated_images_instead_of_copying_the_vector_objects>
screenshot of changed X11 preferences:
<http://launchpadlibrarian.net/60342730/X11-pasteboard-preferences.png>
<http://www.inkscapeforum.com/viewtopic.php?f=22&t=3627#p17000>

-Zeus- (matthew-momjian) wrote :

what are you expecting to see? Thanks for reporting this bug.

I guess I would think it would paste a normal, editable object...

I'm copying from Inkscape into Inkscape, not even moving between windows. After the paste operation, the pasted object is a bitmap, and doesn't act at all like the original object. (So, I'm getting an imported .png file, apparently.)

For example, if I copy & paste an ellispe, I would think that clicking on the pasted copy after picking the ellispe tool would let me change the elispe.

If it helps any, I notice when I click on the original, the status bar says 'Segment in Layer 1', which clicking on the copy says 'Image 242x100: /path_to_file'.

I can try to install a different version of XQuartz, if needed. I kind of hope that's not the fix, because the latest one finally makes my wacom tablet work properly in inkscape & gimp.

Thanks.

I noticed in 296778, that it's mentioned that this bug only happens in gdb, not inkscapec.

On the mac at least, the bug is happening when I just compile it via the mac instructions in the wiki. I'm not running under gdb at all.

su_v (suv-lp) wrote :

This bug is not a duplicate of bug #296778, it is OS X specific.

Mark Buckingham wrote on 2008-12-11:
> I am using XQuartz-2.3.2_rc2.

Newer versions of X11/Quartz have an improved sync-feature to allow clipboard exchange with native OS X apps.

Turn off the 'Update Pasteboard when CLIPBOARD changes' option in X11 preferences, now cut&paste inside Inkscape works again as expected.

References:
inkscape-user mailinglist:
<http://www.nabble.com/-OS-X--X11-clipboard-vs.-OS-X-pasteboard-to23653031.html>
Inkscape FAQ [updated]:
<http://wiki.inkscape.org/wiki/index.php/FAQ#Copying_and_pasting_in_Inkscape_creates_pixellated_images_instead_of_copying_the_vector_objects>

tags: added: osx
su_v (suv-lp) wrote :

Changing bug status to 'Invalid' because this is an issue in X11/XQuartz that can't be fixed in Inkscape (unless the internal system clipboard support is changed or backed out).

If you don't agree please add a comment and revert the bug status.

Changed in inkscape:
status: New → Invalid
birdsaregood (ariel36) wrote :

Using the pre-release 0.47pre1 copy of Inkscape on OSX Tiger.

This same thing happens to me. Didn't happen in 0.46.

Here's what happens: When I make a copy, I can paste it as vector. However, when I copy and then undo (which I frequently do after messing up an object but wanting to keep the new result too), the pasted object is bitmap. Totally useless.... like you have to make a whole new document now.

su_v (suv-lp) wrote :

@birdsaregood - there's a separate bug about this issue on Tiger:
Bug #396754 “Erratic copy/paste in OSX 10.4 0.47pre1”: <https://bugs.launchpad.net/inkscape/+bug/396754>

On Tiger it seems to be a different issue than with Leopard and recent XQuartz versions. Please add a comment to the other bug report, it could be helpful to figure out what causes this bug on OS X 10.4.

su_v (suv-lp) on 2009-11-28
tags: added: clipboard
su_v (suv-lp) wrote :

Changing the Status back to 'Confirmed' so that when new reports are filed about this issue this one will show up in the search for related bugs.

summary: - copy command always does bitmap copy
+ [OS X] copy & paste inserts a bitmap copy instead of the vector object
Changed in inkscape:
status: Invalid → Confirmed
su_v (suv-lp) wrote :

…attaching the screenshot of the changed X11 preferences here as well, for easier reference.

description: updated
description: updated
su_v (suv-lp) on 2010-02-19
Changed in inkscape:
importance: Undecided → Medium
ciradrak (linux-dracoquies) wrote :

This bug does not seem to occur with Xquartz 2.1.5 (xorg-server 1.3.0-apple22). So it appears to have been introduced in Xquartz 2.1.6

G. Steel (germsteel) wrote :

Using Inkscape 0.47pre4 r22446, built Oct 16 2009 on Mac OS X 10.6.2.
The behavior is still as described here. Copy and pasting an object results in an image. Using suv's comment #4 above worked as expected. Thanks

G. Steel (germsteel) wrote :

continued from #11
Using Inkscape download from inkscape.org, XQuartz 2.3.4 (xorg-server 1.4.2-apple45)

su_v (suv-lp) wrote :

adding remote bug watch for

XQuartz Ticket 403: Copy/Paste in Inkscape pastes bitmaps
<http://xquartz.macosforge.org/trac/ticket/403>

puck nolas (dr-klettermax) wrote :

one workaround i found is to duplicate the object (apple + D). this gives you an exact "editable"-copy in the same document. enjoy duplicating!

taylor morgan (taylor-morgan) wrote :

I am using Quartz 2.1.6 and Inkscape .47 and having this problem as well.

I have tried every combination of the "Update PASTEBOARD..." options in X11 without any success. If I have text opened up in Word, copy it, and then paste it in Inkscape, it makes a bitmap copy. In .46 this was avoidable...if you just hit ctrl-v with nothing selected, it made a bitmap copy. If you hit ctrl-v AFTER going into the text-edit mode of a textbox, then it would copy the text as text.

I'm going back to .46 for now.

@taylor: the problem you have is a bit different from what is described here:
word puts a bitmap copy of the copied text into the clipboard.

you can work around that by pasting the text into TextEdit first (or your favourite text editor which cannot possibly be word ;) ), then copy it again and paste to inkscape. so no need to step back to ink.46

but it sure might be related to this issue.. text in the clipboard should always take precedence over bitmaps.

su_v (suv-lp) wrote :

Issues with the clipboard content copied from MS Word are more related to bug #491716 “Text copy-paste problem in 0.47” <https://bugs.launchpad.net/inkscape/+bug/491716> even though it seems to manifest differently on Windows platforms.

No problem pasting text from OpenOffice.org into Inkscape - as mentioned in comment #15 the text tool needs to be active with the blinking text cursor on-canvas (tested with OpenOffice.org 3.2.1, Inkscape 0.47 and 0.47+devel r9515 on OS X 10.5.8, Xquartz 2.4.0).

Esben (esbenbugge) wrote :

Using Inkscape 0.47, XQuartz 2.3.5 on Mac OS X 10.6.4 I am also experiencing that non-bitmap objects that are copied with Ctrl+C are pasted as bitmap objects.

su_v (suv-lp) wrote :
description: updated
Alejandra Medina (amedina-j) wrote :

Hi,
sorry I just posted a new question #173095 with this same problem.
The solution of changing the preference on the X11 pasteboard worked perfectly, sorry for posting before it really took me a loooong time to find this discussion, may be this should be included in the installation instructions as something to be checked.

Thanks

Alejandra Medina

Chris Pickett (cpicke) wrote :

This also affects "paste style" per duplicate bug #931941.

Two suggestions:
1) I searched for "paste style" but did not find this bug, it would be good to remedy that with tags and/or a title change.
2) It might be worth scanning the X11 .plist and displaying the pasteboard screenshot when Inkscape starts up if settings need to be changed for things to work properly, along with a don't warn me again checkbox.

Thanks for your help ~suv.

Kevin Murphy (murphyke) wrote :

I second Chris Pickett's suggestion of warning the user. Lots of person-hours wasted with this bug ....

Chris Pickett (cpicke) wrote :

~suv and I identified a possible way to do this. I was going to file a follow-up feature request and then life happened. If I get around to it then I will post again here.

jus (jus) wrote :

As a side effect, the Edit → Clone → Relink to Copied command does not work unless the X11 settings are as pictured in post #19. I put it here just in case anybody else goggles for the issue. Inkscape 0.48.2 r9819 MacOSX 10.8.2 XQuartz 2.3.6

su_v (suv-lp) on 2012-12-31
description: updated
description: updated

Confirming bug on OS X 10.8.3 / XQuartz 2.7.4 / Inkscape 0.48.2

paul beard (paulbeard) wrote :

Looks like this is still in .4.8.4 RC4, as well 4.8.2 in X11 on OS X 10.8.4.

This is a serious time waster if you can't get back to the version before you got bitten by this.

This is a major problem for me! I'm using Ubuntu 13.04, Inkscape 0.48, and paste in place consistently places the new object down and to the right of the original object, no matter what I do. The new object is not converted to a bitmap as described in the "duplicate" bug.

Oops, meant to comment on https://bugs.launchpad.net/inkscape/+bug/436282 , not this one.

Cory Albrecht (bytor) wrote :

I just encountered this problem now on the OS X version running under X Quartz. Copying line and then trying to paste in place or normal paste turn it into a bitmap and paste that.

Hi Cory, try going into XQuartz's Preferences, click the Pasteboard tab, and uncheck "Enable Syncing"—this should allow you to copy from an Inkscape window and paste it into an inkscape window, creating a copy that is vector (instead of making a bitmap copy).

Something I do frequently is copy text outside of inkscape and paste it into inkscape. To do this, I have to check Enable Syncing (and I also have all the other boxes checked underneath the Enable Syncing check box). So, to copy and paste from inkscape to inkscape, I uncheck Enable Syncing. But to copy outside of inkscape and paste into inkscape, I uncheck Enable Syncing

Oops, I meant to write the last sentence like this: " "But to copy outside of inkscape and paste into inkscape, I *check* Enable Syncing."

Just stumbled upon this bug. Was going to report it and found this bug report. +1 for it.

Terry Thrift (tthrift) wrote :

bug: copy/paste implicitly converting vector to bitmap

All users can miss this bug's conversion until well after it happens.
New users can be disoriented and discouraged. "What did I do wrong? And when?"

Please fix this basic UX mis-behavior
or
warn the user when paste is about to do the wrong thing.

bug confirmed in
     Inkscape 0.91 r13725
     OS X 10.11.6
     XQuartz 2.7.11 (xorg-server 1.18.4)

Thx for working on Inkscape
and any relief you can muster wrt to this bug.
-Terry-

PS.
8 year old bug. wow.
copy/paste must not a very glamorous task ;)

Mitch Curtis (mitchdevs) wrote :

Another +1 here for seeing it fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.