Wubi grub prompt on install

Bug #742967 reported by bcbc on 2011-03-26
94
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Wubi
High
Colin Watson
grub2 (Ubuntu)
High
Colin Watson
Lucid
High
Colin Watson
Maverick
High
Colin Watson
Natty
High
Colin Watson

Bug Description

Installed Wubi Natty Alpha daily-live for the last day or so - it works fine when I install to the same partition as Windows (/dev/sda2) but if I install on /dev/sda3 (other NTFS partition) it fails as follows:
1. WIndows install completes successfully
2. Reboot and selecting Ubuntu, to run the Ubiquity Ubuntu install completes successfully
3. After install, reboot and selecting Ubuntu boots to grub prompt.

I can't see any difference between the installs on /dev/sda2 and /dev/sda3 except...
Running "set" from the grub prompt on the /dev/sda3 install shows:
?=0
color_highlight=black/white
color_normal=white/black
lang=
pager=
prefix=(memdisk)/boot/grub
root=loop0
show_panic_message=false

whereas running it from the /dev/sda2 install shows:
?=0
color_highlight=black/white
color_normal=white/black
default=
gfxmode=auto
lang=
menu_color_highlight=black/light-gray
menu_color_normal=white/black
prefix=(memdisk)/boot/grub
root=loop0
show_panic_message=false

One thing strange is that (memdisk)/boot/grub does not exist. ls (memdisk)/ shows "wubildr.cfg" and ls (memdisk) "Device memdisk: Filesystem type tarfs - Total size 20 sectors"

After manually booting the install:
linux /vmlinuz root=/dev/sda3 loop=/ubuntu/disks/root.disk ro quiet splash
initrd /initrd.img
boot
it runs fine, and then sudo update-grub and it reboots and shows the grub menu the same as the same-partition install does. Note, that the regenerated grub.cfg shows no differences between the old one, but if I hit 'c' and enter "set" again it shows the variables matching that of the /dev/sda2 initial install.

All the "set" info may be a red-herring. I'm just trying to provide any information that might help diagnose this. I've installed other versions of Wubi to /dev/sda3 without a problem.

bcbc (bcbc) wrote :
bcbc (bcbc) wrote :
bcbc (bcbc) wrote :

Ruled out ntfs corruption with CHKDSK. Then I installed 10.04.2 wubi and it boots fine on /dev/sda3. So there appears to be something about the Natty where /host is not the main Windows partition.

PS before I removed the Natty install, I ran updates and it stopped booting again - dropping at the grub prompt.

This is the section of grub.cfg that differs from a lucid 10.04.2 grub:
function load_video {
true
}

insmod part_msdos
insmod ntfs
set root='(/dev/sda,msdos3)'
search --no-floppy --fs-uuid --set=root 8654915254914639
loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
fi
terminal_output gfxterm

Colin Watson (cjwatson) on 2011-03-31
Changed in grub2 (Ubuntu Natty):
status: New → Triaged
importance: Undecided → High
status: Triaged → In Progress
milestone: none → ubuntu-11.04-beta-2
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

I can reproduce this and I've been working on it with a debugger for the last day or so. The crash occurs when trying to read a line from grub.cfg after executing the 'if loadfont ... fi' block. 'set root=(loop0)' has been a source of trouble in the past, although I was fairly sure we'd fixed that; but I suspect that it may well be unrelated to that, and that it's either memory corruption somewhere deep inside GRUB, or else is a bug related to the specific layout of the NTFS filesystem (there's a "read out of range" error being thrown in the depths of the NTFS driver, although this could be a knock-on failure from something else; however, grub-fstest can read the whole of /ubuntu/disks/root.disk correctly, so it doesn't seem as simple as a straightforward filesystem driver bug).

When I've seen things like this in the past, they've gone away when I tried to build modified versions of GRUB to debug them. Thus, I'm using entirely non-invasive techniques here.

Colin Watson (cjwatson) wrote :

Incidentally, I reproduced this with Wubi on the same filesystem as Windows. I suspect this was just down to chance, e.g. what the offsets on disk happened to be.

summary: - Natty Wubi grub prompt on non-windows partition install
+ Natty Wubi grub prompt on install

One question here,
I have install Ubuntu 10.10 using WUBI and if I upgrade to 11.04 will I hit the same problem?

--
Madhava N

Colin Watson (cjwatson) wrote :

It's quite possible, yes. Verifying this for sure would take time that I would rather spend fixing the problem. :-)

Maddy (nmadhava) wrote :

Thanks, I agree, was about to upgrade to 11.04 from 10.10 so wanted to be sure :)
Anyway will probably wait for beta 2 since I am having Ubuntu on my Office laptop.

--
Madhava

Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package grub2 - 1.99~rc1-8ubuntu1

---------------
grub2 (1.99~rc1-8ubuntu1) natty; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Adjust for default Ubuntu boot options ("quiet splash").
    - Default to hiding the menu; holding down Shift at boot will show it.
    - Set a monochromatic theme and an aubergine background for Ubuntu.
    - Apply Ubuntu GRUB Legacy changes to legacy update-grub script: title,
      recovery mode, quiet option, tweak how memtest86+ is displayed, and
      use UUIDs where appropriate.
    - Fix backslash-escaping in merge_debconf_into_conf.
    - Remove "GNU/Linux" from default distributor string.
    - Add crashkernel option.
    - Bypass menu unless other OSes are installed or Shift is pressed.
    - Allow Shift to interrupt 'sleep --interruptible'.
    - Reduce visual clutter in normal mode.
    - Remove verbose messages printed before reading configuration.
    - Suppress kernel/initrd progress messages, except in recovery mode.
    - Handle filesystems loop-mounted on file images.
    - Ignore devices loop-mounted from files in Linux grub.d scripts.
    - Show the boot menu if the previous boot failed.
    - Don't generate device.map during grub-install or grub-mkconfig.
    - Adjust upgrade version checks for Ubuntu.
    - Suppress "GRUB loading" message unless Shift is held down.
    - Adjust versions of grub-doc and grub-legacy-doc conflicts.
    - Fix LVM/RAID probing in the absence of /boot/grub/device.map.
    - Look for .mo files in /usr/share/locale-langpack first.
    - Build-depend on qemu-kvm rather than qemu-system for grub-pc tests.
    - Add a grub-rescue-efi-amd64 package.
    - On Wubi, don't ask for an install device, but just update wubildr
      using the diverted grub-install.
    - Check hardware support before using gfxpayload=keep.
    - Build part_msdos and vfat into EFI boot images.
    - Put second and subsequent Linux menu entries in a submenu.
    - Preferred resolution detection for VBE.
    - Set vt.handoff=7 for smooth handoff to kernel graphical mode.
  * Drop patch to use qemu rather than qemu-system-i386, now that qemu-kvm
    ships a symlink.
  * Rewrite hwmatch.lua in C. Drop lua grub-extras module.
  * Update ubuntu_vbe_autodetect.patch, bringing GRUB_GFXMODE documentation
    up to date.
  * Fix use of freed memory when replacing existing loopback device
    (LP: #742967).

grub2 (1.99~rc1-8) unstable; urgency=low

  * Cherry-pick from upstream:
    - Fix FreeBSD compilation problem.

grub2 (1.99~rc1-7) unstable; urgency=low

  * Add /proc/mdstat, LVM information, and listings of /dev/disk/by-id/ and
    /dev/disk/by-uuid/ to bug reports, by request of upstream.
  * Cherry-pick from upstream:
    - Use libgeom on FreeBSD to detect partitions (closes: #612128).
    - Copy the partition table zone if floppy support is disabled, even if
      no partition table is found (LP: #741867).
    - Fix an ext2 overflow affecting inodes past 2TiB.
    - Fix RAID-0 disk size calculation for metadata 1.x (LP: #743136).
  * Merge from Ubuntu:
    - Build with gcc-4.5 on ppc64.
    - Add apport hook for ProblemType = 'Package', thanks to...

Read more...

Changed in grub2 (Ubuntu Natty):
status: In Progress → Fix Released
bcbc (bcbc) wrote :

Good work!

It seems likely this is the same problem that's caused boot problems on 10.04 after grub updates and the upgrade from 10.04 to 10.10 (bug 653134, bug 682337).

Any chance that - if there is a grub update on 10.04 and/or 10.10 in the future - this can be included?

Colin Watson (cjwatson) wrote :

The grub2 loopback code in 10.04 is structured differently and doesn't have this particular bug, so any issues in 10.04 are due to something else. It should be possible to backport this to 10.10, yes (although I imagine it will be a right pain to validate).

bcbc (bcbc) wrote :

Yes, I imagine it would be a pain. Most 10.04.x wubi users have already locked grub-* packages by now anyway.

I've tested the fix and it works... with some caveats because my installs were from a daily-live image with grub prior to version -8ubuntu1.

In previous releases, updating grub on Wubi would regenerate the wubildr (this only worked when Wubi was on the same partition as Windows). In 11.04 beta it does not attempt to update the wubildr. Therefore, I was still being dropped at the grub prompt and had to manually recreate wubildr by running: sudo grub-install /dev/sda2
This fixed the problem, but note that it populates all the grub modules in /boot/grub which is not standard for a Wubi install. But the end result was that it worked as indicated by your notes.

It was a slightly different story for my install on the non-windows partition. The one positive was that it does not prompt you to install grub to the MBR (the grub-install trigger has been suppressed? due to grub-install devices being empty?)

So that's a positive that takes care of bug 610898 (at least in Natty). But the issue is, there is no easy way to upgrade wubildr to -8ubuntu1. If I try the method that worked on the Windows-partition install, it fails:
bcbc@ubuntu:~$ sudo grub-install /dev/sda3
[sudo] password for bcbc:
/usr/sbin/grub-setup: warn: Attempting to install GRUB to a partitionless disk or to a partition. This is a BAD idea..
/usr/sbin/grub-setup: error: embedding is not possible, but this is required for cross-disk install.

I can fool it as follows:
bcbc@ubuntu:~$ touch /host/wubildr
bcbc@ubuntu:~$ sudo grub-install /dev/sda3
Installation finished. No error reported.
bcbc@ubuntu:~$ ls -l /host/wubildr
-rwxrwxrwx 1 root root 143810 2011-04-02 13:02 /host/wubildr
bcbc@ubuntu:~$

But then I still have to mount and copy the generated wubildr to /dev/sda2 (as that's the one that wubildr.mbr finds first). Instead I deleted the one on /dev/sda2 and it boots fine now.

So... in summary, the fix works. But not sure how it will work on upgrade from 10.10 to 11.04 (I guess we'll find out soon enough). But that's good work finding those tricky errors.

As always, thanks for testing.

Populating /boot/grub when it isn't populated by an initial install is
untidy, and I suppose with some contortions it might be possible to do
something about it, but it shouldn't matter if everything else is
working properly. Actually, I might argue that the real bug there is
that an initial install of Wubi doesn't populate /boot/grub! It is
occasionally useful to have access to modules that aren't built into
wubildr, and ultimately it would be nice not to have to build a giant
monolithic wubildr; obviously things like ntfs.mod have to be built-in,
but much of it could perfectly well be loaded at run-time instead.

I don't think bug 610898 is truly fixed yet, although I still hope to
squeeze in a fix for that before the Natty release, once I construct a
test case for myself. The no-more-confusing-prompt change you mention
was for bug 581760, fixed in Maverick. If wubildr is not being
regenerated on upgrade then that is definitely a bug - I know it has
been problematic, but if we don't regenerate wubildr then running an
upgraded version of update-grub may well break things since there's no
guarantee of compatibility between old GRUB core images and modules and
new configuration files, so it has to be done if grub-pc and grub-common
are upgraded at all.

The fact that grub-install didn't work on your install to a non-Windows
partition is just the same as bug 610898. The prompt is a side issue;
the real underlying issue is that '/usr/share/lupin-support/grub-mkimage
--test' doesn't know how to detect that it's a Wubi system in that
environment, and that explains why grub-install is trying to do a real
install rather than regenerating wubildr.

In your installation where Wubi was on the same partition as Windows, is
the lupin-support package installed? What do these commands print:

  sudo /usr/share/lupin-support/grub-mkimage --test; echo $?
  sudo grub-probe --target=device /boot
  sudo losetup "$(sudo grub-probe --target=device /boot)"
  cat /proc/mounts

Yes lupin-support is installed. I believe that's always included with wubi - you could previously prevent it by hitting the skip button during the ubiquity install (bug 620028), but the latest ubiquity doesn't have a skip button (that I've noticed). I've got version 0.33 installed.

bcbc@ubuntu:~$ sudo /usr/share/lupin-support/grub-mkimage --test; echo $?
[sudo] password for bcbc:
0
bcbc@ubuntu:~$ sudo grub-probe --target=device /boot
/dev/loop0
bcbc@ubuntu:~$ sudo losetup "$(sudo grub-probe --target=device /boot)"
/dev/loop0: [0802]:119065 (/host/ubuntu/disks/root.disk)
bcbc@ubuntu:~$ cat /proc/mounts
rootfs / rootfs rw 0 0
none /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
none /proc proc rw,nosuid,nodev,noexec,relatime 0 0
none /dev devtmpfs rw,relatime,size=505408k,nr_inodes=126352,mode=755 0 0
none /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
/dev/sda2 /host fuseblk rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096 0 0
/dev/loop0 / ext4 rw,relatime,errors=remount-ro,commit=600,barrier=1,data=ordered 0 0
none /sys/kernel/debug debugfs rw,relatime 0 0
none /sys/kernel/security securityfs rw,relatime 0 0
none /dev/shm tmpfs rw,nosuid,nodev,relatime 0 0
none /var/run tmpfs rw,nosuid,relatime,mode=755 0 0
none /var/lock tmpfs rw,nosuid,nodev,noexec,relatime 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
gvfs-fuse-daemon /home/bcbc/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0
bcbc@ubuntu:~$

I confirmed a fresh wubi install on today's daily live desktop image, but
using wubi.exe rev206 (separately downloaded) works. I'll test the upgrade
soon.

bcbc (bcbc) wrote :

The upgrade worked. I did a fresh Maverick install on the windows partition
and used today's alternate image to run the upgrade. The upgrade worked
successfully.

1. the /host/wubildr was not modified at all (I used diff to compare before
an after). The Grub Menu showed version 1.98+20100804-5ubuntu2.
2. /boot/grub remained empty except for three files: grubenv, grub.cfg and
unicode.pf
3. Despite differences in grub.cfg with maverick it booted fine.
4. Ran sudo update-grub - rebooted fine
5. Ran sudo dpkg-reconfigure grub-pc - no change to /host/wubildr or
/boot/grub and rebooted fine
6. Reinstalled same version of grub-pc using synaptic - no change to
/host/wubildr or /boot/grub. This time I was interrupted and windows booted
in the meantime. On rebooting into Ubuntu it ended up at the grub prompt.

So... in summary: grub-install does not run anymore as a postinst trigger
when installing or reconfiguring grub-pc, and /host/wubildr is not updated.

Maddy (nmadhava) wrote :

Cool,

Let me upgrade now and see.

--
Madhava N

On Tue, Apr 5, 2011 at 12:25 PM, bcbc <email address hidden> wrote:

> The upgrade worked. I did a fresh Maverick install on the windows partition
> and used today's alternate image to run the upgrade. The upgrade worked
> successfully.
>
> 1. the /host/wubildr was not modified at all (I used diff to compare before
> an after). The Grub Menu showed version 1.98+20100804-5ubuntu2.
> 2. /boot/grub remained empty except for three files: grubenv, grub.cfg and
> unicode.pf
> 3. Despite differences in grub.cfg with maverick it booted fine.
> 4. Ran sudo update-grub - rebooted fine
> 5. Ran sudo dpkg-reconfigure grub-pc - no change to /host/wubildr or
> /boot/grub and rebooted fine
> 6. Reinstalled same version of grub-pc using synaptic - no change to
> /host/wubildr or /boot/grub. This time I was interrupted and windows booted
> in the meantime. On rebooting into Ubuntu it ended up at the grub prompt.
>
> So... in summary: grub-install does not run anymore as a postinst trigger
> when installing or reconfiguring grub-pc, and /host/wubildr is not updated.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/742967
>
> Title:
> Natty Wubi grub prompt on install
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/wubi/+bug/742967/+subscribe
>

Maddy, maybe i wasn't clear. It worked (initially) but the wubildr wasn't updated and finally it dropped me at a grub prompt. (That was buried a bit in my analysis).

Anyway... to continue:
I ran "sudo grub-install /dev/sda2" (My /host is /dev/sda2) and it regenerated the /host/wubildr (also populated the files in the /boot/grub)...

and now it's booting again.

So... it looks like it's a manual regeneration of wubildr that's required on both 'windows-partition' installs as well as 'non-windows-partition' installs.

Ok, thanks for the info, I have the N/W connectivity so will check it out.
So seems like it still drops to grub prompt.

Let me wait for Ubuntu beta 2 otherwise.

--
Madhava N

On Tue, Apr 5, 2011 at 12:56 PM, bcbc <email address hidden> wrote:

> Maddy, maybe i wasn't clear. It worked (initially) but the wubildr
> wasn't updated and finally it dropped me at a grub prompt. (That was
> buried a bit in my analysis).
>
> Anyway... to continue:
> I ran "sudo grub-install /dev/sda2" (My /host is /dev/sda2) and it
> regenerated the /host/wubildr (also populated the files in the
> /boot/grub)...
>
> and now it's booting again.
>
> So... it looks like it's a manual regeneration of wubildr that's
> required on both 'windows-partition' installs as well as 'non-windows-
> partition' installs.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/742967
>
> Title:
> Natty Wubi grub prompt on install
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/wubi/+bug/742967/+subscribe
>

bcbc: It seems to be being regenerated fine in my tests (although those are by installing natty with Wubi on the Windows partition and installing the same version again). Could you attach /var/log/apt/term.log, along with the output of 'sudo debconf-show grub-pc'?

Colin Watson (cjwatson) wrote :

(I'll try a maverick->natty upgrade next.)

Colin Watson (cjwatson) wrote :

Ah, never mind. I made my test a bit more realistic and now I see the problem.

Changed in grub2 (Ubuntu Natty):
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.99~rc1-8ubuntu2

---------------
grub2 (1.99~rc1-8ubuntu2) natty; urgency=low

  * Make sure to reinstall GRUB on upgrade if Wubi is in use (LP: #742967).
 -- Colin Watson <email address hidden> Tue, 05 Apr 2011 19:30:09 +0100

Changed in grub2 (Ubuntu Natty):
status: In Progress → Fix Released
Colin Watson (cjwatson) wrote :

Incidentally, my note in comment 11 that 10.04 doesn't have this bug was in error. It's just that in that version the problematic code was in an Ubuntu-specific patch rather than upstream ...

summary: - Natty Wubi grub prompt on install
+ Wubi grub prompt on install
Changed in grub2 (Ubuntu Lucid):
importance: Undecided → High
Changed in grub2 (Ubuntu Maverick):
importance: Undecided → High
Changed in grub2 (Ubuntu Lucid):
status: New → Triaged
Changed in grub2 (Ubuntu Maverick):
status: New → Triaged
Changed in grub2 (Ubuntu Lucid):
assignee: nobody → Colin Watson (cjwatson)
Changed in grub2 (Ubuntu Maverick):
assignee: nobody → Colin Watson (cjwatson)
Changed in grub2 (Ubuntu Lucid):
milestone: none → ubuntu-10.04.3
Colin Watson (cjwatson) wrote :

I've queued up lucid and maverick versions of these two patches for after we get bug 687501 validated. With any luck I can use that time to figure out how to make things work when Wubi is on a different partition from Windows, and include that too.

OK glad to hear you've reproduced this - I couldn't get to my test computer
for a few hours anyway to get you that info.

Also great that you've identified the issues in 10.04 as well. Thanks for
the hard work.

On Tue, Apr 5, 2011 at 11:37 AM, Colin Watson <email address hidden>wrote:

> Incidentally, my note in comment 11 that 10.04 doesn't have this bug was
> in error. It's just that in that version the problematic code was in an
> Ubuntu-specific patch rather than upstream ...
>
>

bcbc (bcbc) wrote :

I just did an upgrade from 10.10 (fresh install on the same partition as Windows) and it successfully upgraded and updated the /host/wubildr. Reboot showed the latest version of grub 1.99_rc1-8ubuntu2.
Perfect.

I'm going to test the non-windows partition upgrade next.

bcbc (bcbc) wrote :

Upgrade on non-windows partition worked perfectly as well. No prompts regarding installing Grub and it updated the wubildr on the windows partition. Excellent job!

Hi bcbc,

So you installed 11.04 on top of 10.10 installed and it worked right.
Did you have to do any updates on 10.10 before doing so?

I am planning to do upgrade to 11.04 as well by running
"update-manager -d" and hoping it works.

--
Madhava

On Thu, Apr 7, 2011 at 11:11 AM, bcbc <email address hidden> wrote:

> Upgrade on non-windows partition worked perfectly as well. No prompts
> regarding installing Grub and it updated the wubildr on the windows
> partition. Excellent job!
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/742967
>
> Title:
> Wubi grub prompt on install
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/wubi/+bug/742967/+subscribe
>

Colin Watson (cjwatson) wrote :

On Thu, Apr 07, 2011 at 07:01:12AM -0000, Maddy wrote:
> So you installed 11.04 on top of 10.10 installed and it worked right.
> Did you have to do any updates on 10.10 before doing so?

No updates to 10.10 should be necessary, and in this specific case it
may be harmful to apply 10.10 updates first. I do intend to get this
set of fixes rolled out as 10.10 updates, but it will take a few weeks
because there's already something else in that particular pipeline.

Maddy (nmadhava) wrote :

Hmmm, interesting then. Maybe I will backup my Ubuntu and then
install fresh 11.04, though I should say I am itching to test GNOME3
as well, Unity looks a bit more polished in Ubuntu for me to try :)

--
Madhava N

On Thu, Apr 7, 2011 at 4:48 PM, Colin Watson <email address hidden> wrote:

> On Thu, Apr 07, 2011 at 07:01:12AM -0000, Maddy wrote:
> > So you installed 11.04 on top of 10.10 installed and it worked right.
> > Did you have to do any updates on 10.10 before doing so?
>
> No updates to 10.10 should be necessary, and in this specific case it
> may be harmful to apply 10.10 updates first. I do intend to get this
> set of fixes rolled out as 10.10 updates, but it will take a few weeks
> because there's already something else in that particular pipeline.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/742967
>
> Title:
> Wubi grub prompt on install
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/wubi/+bug/742967/+subscribe
>

Changed in grub2 (Ubuntu Maverick):
milestone: none → maverick-updates
tags: added: iso-testing
Mussen (robertely) wrote :

Just did a clean install of 11.04 BETA 2 Using Wubi. It completed with out issue, and booted just fine.

Accepted grub2 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in grub2 (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in grub2 (Ubuntu Maverick):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Accepted grub2 into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Colin Watson (cjwatson) wrote :

Verified in the logs of bug 610898.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.98-1ubuntu12

---------------
grub2 (1.98-1ubuntu12) lucid-proposed; urgency=low

  * Fix use of freed memory when replacing existing loopback device
    (LP: #742967).
  * Make sure to reinstall GRUB on upgrade if Wubi is in use (LP: #742967).
  * Enable grub-fstest, so that we can use it to help find wubildr
    (LP: #610898).
  * Make NTFS UUIDs uppercase (LP: #695290).

grub2 (1.98-1ubuntu11) lucid-proposed; urgency=low

  * Backport multipath probing fixes (LP: #687501).
 -- Colin Watson <email address hidden> Wed, 27 Apr 2011 10:39:15 +0100

Changed in grub2 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 1.98+20100804-5ubuntu3.3

---------------
grub2 (1.98+20100804-5ubuntu3.3) maverick-proposed; urgency=low

  * Fix use of freed memory when replacing existing loopback device
    (LP: #742967).
  * Make sure to reinstall GRUB on upgrade if Wubi is in use (LP: #742967).
  * Enable grub-fstest, so that we can use it to help find wubildr
    (LP: #610898).
  * Make NTFS UUIDs uppercase (LP: #695290).

grub2 (1.98+20100804-5ubuntu3.2) maverick-proposed; urgency=low

  * Backport multipath probing fixes (LP: #687501).
 -- Colin Watson <email address hidden> Wed, 27 Apr 2011 10:32:26 +0100

Changed in grub2 (Ubuntu Maverick):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) on 2011-06-17
Changed in wubi:
status: New → Fix Released
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Christian Wenz (chwenz) wrote :

does not seem to be fixed for me on a machine where I have two physical hard disks and install Ubuntu on the second one; Windows is on the first one. On the same machine installing 10.04 and 10.10 w/ wubi worked like a charm, but installing 11.04 (both from scratch and via upgrading from within 10.10) lead to the behavior described above: Wubi prompts to reboot the machine, Ubuntu install then competes, asks for another reboot, and then I get to a prompt including a message like "ALERT! /host/ubuntu/disks/root.disk does not exist". Is there any diagnostic information I can provide?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers