Comment 12 for bug 742967

Yes, I imagine it would be a pain. Most 10.04.x wubi users have already locked grub-* packages by now anyway.

I've tested the fix and it works... with some caveats because my installs were from a daily-live image with grub prior to version -8ubuntu1.

In previous releases, updating grub on Wubi would regenerate the wubildr (this only worked when Wubi was on the same partition as Windows). In 11.04 beta it does not attempt to update the wubildr. Therefore, I was still being dropped at the grub prompt and had to manually recreate wubildr by running: sudo grub-install /dev/sda2
This fixed the problem, but note that it populates all the grub modules in /boot/grub which is not standard for a Wubi install. But the end result was that it worked as indicated by your notes.

It was a slightly different story for my install on the non-windows partition. The one positive was that it does not prompt you to install grub to the MBR (the grub-install trigger has been suppressed? due to grub-install devices being empty?)

So that's a positive that takes care of bug 610898 (at least in Natty). But the issue is, there is no easy way to upgrade wubildr to -8ubuntu1. If I try the method that worked on the Windows-partition install, it fails:
bcbc@ubuntu:~$ sudo grub-install /dev/sda3
[sudo] password for bcbc:
/usr/sbin/grub-setup: warn: Attempting to install GRUB to a partitionless disk or to a partition. This is a BAD idea..
/usr/sbin/grub-setup: error: embedding is not possible, but this is required for cross-disk install.

I can fool it as follows:
bcbc@ubuntu:~$ touch /host/wubildr
bcbc@ubuntu:~$ sudo grub-install /dev/sda3
Installation finished. No error reported.
bcbc@ubuntu:~$ ls -l /host/wubildr
-rwxrwxrwx 1 root root 143810 2011-04-02 13:02 /host/wubildr
bcbc@ubuntu:~$

But then I still have to mount and copy the generated wubildr to /dev/sda2 (as that's the one that wubildr.mbr finds first). Instead I deleted the one on /dev/sda2 and it boots fine now.

So... in summary, the fix works. But not sure how it will work on upgrade from 10.10 to 11.04 (I guess we'll find out soon enough). But that's good work finding those tricky errors.