Wubi based Maverick no longer boots after automatic security update 2010-10-20

Bug #664106 reported by a.strotmann on 2010-10-20
This bug report is a duplicate of:  Bug #742967: Wubi grub prompt on install. Edit Remove
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Wubi
Undecided
Unassigned

Bug Description

My Ubuntu 10.10, recently upgraded from a 10.04 Wubi install (AMD64), worked fine this morning. I noticed the red turn-off button informing me that I should reboot to finish installation of (in this case automatic security) updates. Upon reboot, the following happens:

 - the Wubi boot menu appears (choice between Windows and Ubuntu)
 - I select Ubuntu as usual
 - a notice including words like "hard disk" and "NTFS" (prior to loading Grub??) appears as usual
 - instead of a choice of Ubuntu kernel versions appearing, the machine simply reboots

This happens every time - tried several times.

This is CRITICAL - I can no longer boot into my system after an automatic update!

[[I have a single partition on my laptop - Ubuntu is installed on that one.]]

a.strotmann (andreas-strotmann) wrote :

PS: I do daily updates - whatever caused this must have been released as a security update during the past 24 hours.

pauls (paulatgm) wrote :

Same problem here .. all was fine until latest update. Can get normal boot screen and select "ubuntu" ,but when it boots an error message flashes very quickly and then it reboots.

Message looks something like (2 lines):

Try (hd0,0) NTFS
Try (hd0,1) NTFS <something else after>

Then a second page flashes something like (2 lines):

Error, File not found
Error, File not found

But, the words may not be exactly correct, since it passes by so fast.

Amd-64 maverick wubi on win 7 32-bit here.

a.strotmann (andreas-strotmann) wrote :

These are the final entries from /var/log/unattended-upgrades/unattended-upgrades.log on that system (read via loop-mounting root.disk into a VirtualBox based Ubuntu installation):

2010-10-20 10:29:26,636 INFO Initial blacklisted packages:
2010-10-20 10:29:26,637 INFO Starting unattended upgrades script
2010-10-20 10:29:26,637 INFO Allowed origins are: ["('Ubuntu', 'stable')", "('Ubuntu', 'maverick-security')"]
2010-10-20 10:29:38,325 INFO Packages that are upgraded: libpoppler-glib5 libpoppler-qt4-3 libpoppler7 libwebkit-1.0-2 libwebkit-1.0-common linux-headers-2.6.35-22 linux-headers-2.6.35-22-generic linux-image-2.6.35-22-generic linux-libc-dev poppler-utils
2010-10-20 10:29:38,326 INFO Writing dpkg log to '/var/log/unattended-upgrades/unattended-upgrades-dpkg_2010-10-20_10:29:38.325839.log'
2010-10-20 10:31:29,854 INFO All upgrades installed

bcbc (bcbc) wrote :

Marked as duplicate - copy the c:\ubuntu\winboot\wubildr over c:\wubildr to get it booting.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers