Unity Launcher corruption when resuming from suspend/hibernate

Bug #676166 reported by Jorge Castro on 2010-11-16
568
This bug affects 111 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Unity
Fix Released
Critical
Jason Smith
nvidia-graphics-drivers (Ubuntu)
Critical
Alberto Milone
unity (Ubuntu)
Medium
Jason Smith

Bug Description

When resuming I get oddness on the top around my panel, and oddly enough, an image of my old panel.

Clicking on the area shows that I'm running the unity panel (I can interact with the application indicators and application menu even though I can't see them) however it looks as if unity is drawing my old gnome panel.

Jorge Castro (jorge) wrote :
Alex Launi (alexlauni) on 2010-11-18
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Neil J. Patel (njpatel) wrote :

Hey Jorge, do you still have gnome-panel running below the Unity one? I'm wondering if it's a rendering error because of stacked windows there...

Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
importance: Undecided → High
milestone: none → 3.2.6
Changed in unity (Ubuntu):
importance: Undecided → High
Jay Taoko (jaytaoko) wrote :

This looks like a corruption of the fbo supporting the panel, launcher, tooltip... They should be recreated after identifying the proper X signal corresponding to a "resume". Or could it be possible to detect when the system is going into sleep mode?

Neil J. Patel (njpatel) wrote :

Jay we can figure that out through console kit at least. There might be a less heavy way, though, I'll investigate...

Neil J. Patel (njpatel) on 2010-12-09
Changed in unity:
importance: High → Critical
milestone: 3.2.6 → 3.2.8
David Barth (dbarth) on 2011-01-03
Changed in unity:
milestone: 3.2.8 → 3.2.12
Changed in unity (Ubuntu):
milestone: none → natty-alpha-2
assignee: nobody → Jay Taoko (jaytaoko)
KJ4OHH (kj4ohh) wrote :

I have simular problems on resuming from standby/hibernate. The unity bar on the left and the panel on the top appears bleached.

Also when the screen saver kicks in, the unity bar on the left never hides.

Using nVidia's proprietary drivers.

On my Intel video card, the computer turns unusable. Almost all the screen turns black and I need to reboot in order to get it back.

Neil J. Patel (njpatel) wrote :

Jay, can we have an update on what happened from the platform sprint about this bug please?

Marco, can you please be more specific about your video card and the exact problem? So far this has happened on nvidia graphics cards.

Changed in unity:
milestone: 3.2.12 → 3.2.16

No, I can't :)

I got this issue last week. Now (with system up to date), it no longer happens. Sometimes, when wireless radio is on, the whole system crashes when resuming, but it looks like a driver bug. I'll fill this bug separated.

David Barth (dbarth) wrote :

Well, since there is not reproducible way so far, and it obviously seems like a driver issue, i'll mark that one invalid. If that ever happens again, we can reopen the bug.

As a workaround, there is some old code from Netbook Launcher that was flushing GL textures after a resume. We could resort to that kind of tactics if the bug resurfaces for some systems close to the beta freeze.

Let's try to have drivers fixed while we still can for this cycle.

Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Jay Taoko (jaytaoko) wrote :

Compiz has some API to detect Resume events. We have to consider how functional it is and it we can plug Nux to it. We would then try to re-create on screen surfaces and textures.

David Barth (dbarth) wrote :

Right, after re-reading the comments, it sounds like having invalid textures after resume could be a legitimate state for a GL driver.
So I agree, we should either use the compiz API or port the old Netbook Launcher code.

Changed in unity:
importance: Critical → Medium
milestone: 3.2.16 → 3.4
status: Invalid → Confirmed
Changed in unity (Ubuntu):
status: Invalid → Triaged
milestone: natty-alpha-2 → natty-alpha-3
Neil J. Patel (njpatel) wrote :

Moving to a couple of weeks away so we get a chance to test with the latest xorg and nvidia drivers, which aren't available just yet.

Changed in unity:
milestone: 3.4 → 3.4.6
importance: Medium → High
Didier Roche (didrocks) on 2011-02-21
Changed in unity:
status: Confirmed → Triaged
Jay Taoko (jaytaoko) on 2011-02-24
Changed in unity:
milestone: 3.4.6 → 3.6
Didier Roche (didrocks) on 2011-03-01
Changed in unity:
milestone: 3.6 → 3.6.2
Neil J. Patel (njpatel) on 2011-03-07
Changed in unity:
milestone: 3.6.2 → 3.6.6
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
Mike (bild85) wrote :

I see this too after waking from suspend. The retained image was pixelated - it looks similar to TV noise. Mousing over the Ubuntu symbol caused the menu to come out again, which redrew the menu and it retracted normally.

I caught a photo of the pixelization. It happens pretty repeatedly after waking from suspend.
Pic attached.

Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
Changed in unity (Ubuntu):
milestone: natty-alpha-3 → ubuntu-11.04-beta-2
Didier Roche (didrocks) on 2011-04-11
Changed in unity:
milestone: 3.8.6 → 3.8.8
David Barth (dbarth) wrote :

The problem is limited to users of the nvidia drivers now. We can't fix the problem directly. A workaround would be to force a refresh on all textures, but that would be a significant change and not possible without an ABI change.

We should try to address that with Nvidia upstream next cycle.

tags: added: too-late
Changed in unity:
milestone: 3.8.8 → backlog
Changed in unity (Ubuntu):
milestone: ubuntu-11.04-beta-2 → none
Changed in unity:
importance: High → Medium
Changed in unity (Ubuntu):
importance: High → Medium
David Barth (dbarth) wrote :

Lowering the priority, considering it's limited to only one of the GPU vendors.

larini (paulo-larini) wrote :

Hi, this is terrible bug. NVidia corresponds to a very high number of users in linux. There is a light for this bug?

Stefan Sommer (stefan-nefan) wrote :

I have the same problem with radeon drivers.

yamzz (j-yamut) wrote :

I'll just put this in here since it seems like a similar case. I hope you don't mind.

The description is like this:

After suspend, everything works but the Unity launcher is distorted (no icons can be seen, everything is a mix of colors) and sometimes invisible. I noticed that the longer it's on suspend distortion is likely to happen but a few minutes, say 1 minute to 3 minute suspend will make the launcher invisible.

A fix is to move the mouse over the launcher or bring out the dash. That appears to work all the time. It would seem this bug is not of critical importance but it really looks odd with the launcher distorted or invisible whenever my desktop comes out from suspend.

Using Nvidia proprietary driver.

Holger Seelig (holger-seelig) wrote :

This does not happen with Nouveau graphics driver.

appas (matias-wilkman) wrote :

This problem also exists on my Asus VX2Se with NVidia 9500M GS, using NVidia driver version 173.14.30. After suspend/resume, the whole screen or the Unity bar will be garbled.

Why not redraw the screen once after resume?

On Mon, 2011-08-15 at 22:13 +0000, dep wrote:
> Why not redraw the screen once after resume?
. . it is a minor inconvenience, moving the mouse over the launcher
immediately redraws it. Though it's not a slick way to present a
desktop, I agree.

If I do as you suggest, how might I do that? Is there a configuration
file I can alter to do this after in my case, hibernate. Suspend doesn't
seem to work well on this laptop, the HP DV4.

Mike

--
Linux powered laptop

This seems to be the contents of FBOs being trashed across as suspend/resume cycle. It seems that nvidia fixed a similar problem for GNOME Shell in http://www.nvidia.com/object/linux-display-amd64-275.09.07-driver.html - we should ask if this can be generalised, or a similar fix put in for Unity.

affects: unity (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
Changed in nvidia-graphics-drivers (Ubuntu):
assignee: Jay Taoko (jaytaoko) → Alberto Milone (albertomilone)
assignee: Alberto Milone (albertomilone) → Chris Halse Rogers (raof)
Alberto Milone (albertomilone) wrote :

Can you try disabling Grub's fb, please?

Please give me step by step instructions to disable Grub's fb.

Thanks,
Wil

>________________________________
>From: Alberto Milone <email address hidden>
>To: <email address hidden>
>Sent: Tuesday, August 23, 2011 10:59 AM
>Subject: [Bug 676166] Re: Screen corruption when resuming from suspend
>
>Can you try disabling Grub's fb, please?
>
>--
>You received this bug notification because you are subscribed to the bug
>report.
>https://bugs.launchpad.net/bugs/676166
>
>Title:
>  Screen corruption when resuming from suspend
>
>Status in Unity:
>  Triaged
>Status in “nvidia-graphics-drivers” package in Ubuntu:
>  Triaged
>
>Bug description:
>  When resuming I get oddness on the top around my panel, and oddly
>  enough, an image of my old panel.
>
>  Clicking on the area shows that I'm running the unity panel (I can
>  interact with the application indicators and application menu even
>  though I can't see them) however it looks as if unity is drawing my
>  old gnome panel.
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/unity/+bug/676166/+subscriptions
>
>
>

Here's how you can disable grub's framebuffer for nvidia cards:

1) copy the attached file to /usr/share/grub-gfxpayload-lists/blacklist/

2) type:
sudo update-grub-gfxpayload

3) reboot

4) try to reproduce the problem

Mike Birchley (mbirchley) wrote :

Have just tried this fix, but problem remains on this HP Dv4 laptop with current NVidia module, no different

Have just tried this fix, -- problem remains on this Gateway GT5426E desktop with NVIDIA Gforce 6150 SE

I experience this very reproducibly on a brand-new System76 Serval Professional with the base GPU (NVIDIA GeForce GTX 560M). Not a great way to welcome people to the world of Ubuntu. :/

Loris Zinsou (nepenthes) wrote :

I experienced this bug in Natty, but the situation changed in Oneiric. The desktop now shows corruption after a suspend/resume cycle : the Unity Launcher and Panel are not pixelated, but the desktop is.
If I open a new window, the window seems to appear behind the pixelated layer.
If I use the expo plugin in compiz, the effect appears behind this layer too.
The only way to get rid of this is to restar Xorg.

I use a nvidia 8400m gs, drivers : 280 on a Dell xps m1330 laptop.

Vladimir Scherbaev (zemik) wrote :

I have this bug on Asus k43sj.

Description: Ubuntu oneiric (development branch)
Release: 11.10
nvidia-current:
  Installed: 280.13-0ubuntu1
  Candidate: 280.13-0ubuntu1
  Version table:
 *** 280.13-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/restricted amd64 Packages
        100 /var/lib/dpkg/status

Jason Smith (jassmith) wrote :

The contents of the FBO are not corrupted it seems, but the act of painting the FBO to the backbuffer is for some reason broken on nvidia after a suspend/resume cycle...

dino99 (9d9) wrote :

on Oneiric i386 + nvidia 280

get corruption too while resuming, but not only: get it if i first logout of gnome-classic and see that corruption of the 1/5 bottom screen when i shutdown (so can is it a plymouth conflict ?)

douham (dougg) wrote :

Get screen corruption on resuming. Geforce 8400GS card and nvidia 280.13 driver. Logging out and then log back in ¨fixes¨ the problem for that session only

Omer Akram (om26er) on 2011-09-01
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Mathieu Pellerin (nirvn-asia) wrote :

Wondering whether https://bugs.launchpad.net/ubuntu/+source/unity/+bug/830299 is somehow a duplicate of this bug.

Jorge Suárez de Lis (ys) wrote :

Yep Mathieu, I'd mark it as duplicate of this bug.

Same here, Nvidia GTS250 with Nvidia 280.13 drivers. Attached screenshot of corruption.

Mathieu Pellerin (nirvn-asia) wrote :

Glad we're moving forward and finding duplicates.

That being said, I suggest for the bug's importance to be elevated to critical. When this bug was initially filed, only the top bar and/or launcher was suffering from screen corruption but the main desktop area was left unscrambled. In the upcoming 11.10, the whole screen gets corrupted.

Jacopo Moronato (jmoronat) wrote :

+1 for Mathieu.

Eylem (eylemkoca) wrote :

It seems the bug I just reported (https://bugs.launchpad.net/unity/+bug/843460) is a duplicate of this one. Just to show how my screen looks like after resume: https://launchpadlibrarian.net/79192397/Screenshot%20at%202011-09-06%2021%3A44%3A59.png

Cas (calumlind) wrote :

While testing Oneiric beta I encountered the same whole desktop corruption when resuming from suspend with 280.13 nvidia driver. It looks identical to Jorge Suárez de Lis's screenshot. I should add that everything is fine when resuming from hibernate.

I tried testing with 173 nvidia driver but found when resuming, 4 our of 5 times, resulted in blank screen with only the mouse cursor. However the times it did work properly there was no graphical corruption.

I have been using Natty since its release and have seen similar corruption but limited only to the dock area.

I think the new desktop corruption in Oneiric should result in this bug being changed to high/critical priority.

Cory Maccarrone (darkstar6262) wrote :

This is affecting me as well on Oneiric, using the proprietary nvidia drivers. Upon resume, the desktop is completely filled with static and most things won't work. I can blindly open a terminal and run 'compiz --replace &', and things come back to normal. This happens on every resume, 100% repeatable.

I agree with previous posts, this should be elevated to high/critical, as it seems to affect lots of nvidia users.

David Barth (dbarth) on 2011-09-12
Changed in unity:
milestone: backlog → 4.16.0
summary: - Screen corruption when resuming from suspend
+ Screen corruption when resuming from suspend/hibernate
Jason Smith (jassmith) on 2011-09-13
Changed in unity:
importance: Medium → Critical
Changed in nvidia-graphics-drivers (Ubuntu):
importance: Medium → Critical
Bryce Harrington (bryce) on 2011-09-13
Changed in nvidia-graphics-drivers (Ubuntu):
assignee: Chris Halse Rogers (raof) → Alberto Milone (albertomilone)
David Barth (dbarth) on 2011-09-14
Changed in unity:
assignee: Jay Taoko (jaytaoko) → nobody
milestone: 4.16.0 → none
status: Triaged → Invalid
Changed in nvidia-graphics-drivers (Ubuntu):
milestone: none → ubuntu-11.10
Jason Smith (jassmith) on 2011-09-21
Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Invalid
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Changed in unity:
status: Invalid → Fix Committed
Changed in unity (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
28 comments hidden view all 108 comments

It's nice that this has been finally pinned down. Let's hope there will be an update in due time, too. :)

Arpad Borsos (swatinem) wrote :

Thanks a lot for the fix and also the explanation.

I have another question however: Why does unity need a fullscreen texture (1280x800x4 bytes) at all for this invisible window. Does this contribute to the high memory usage of unity? Isnt it better to just create geometry (for the events and such) but without needing an invisible texture that wastes 4M of my precious memory?

Jason Smith (jassmith) wrote :

It doesn't need it and will be removed when someone gets the chance (the toolkit creates teh texture to go with the input window, so we would have to bypass the toolkit for this)

Omer Akram (om26er) on 2011-09-24
Changed in unity:
milestone: none → 4.18.0
Changed in nvidia-graphics-drivers (Ubuntu):
milestone: ubuntu-11.10 → none
Changed in unity (Ubuntu):
milestone: none → ubuntu-11.10
Wayne Davison (wayned) wrote :

For those experiencing this bug, here's an easier work-around when coming out of suspend:

Press Alt-F2 and type "compiz --replace" and press Enter. That will get rid of the corruption and let you continue using your programs.

Didier Roche (didrocks) on 2011-09-26
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 4.18.0-0ubuntu1

---------------
unity (4.18.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Screen corruption when resuming from suspend/hibernate (LP: #676166)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #764024)
    - Dash and launcher appear underneath windows (LP: #805087)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #811401)
    - [Oneric] unity-panel-service crashed with SIGSEGV in getenv()
      (LP: #817691)
    - compiz crashed with SIGSEGV in unity::FilterBar::RemoveFilter()
      (LP: #845732)
    - crash on closing a window (LP: #856015)
    - Cannot open a window that starts iconified (LP: #732997)
    - Launcher - When useing Alt F1 launcher keyboard navigation, Launcher
      should not scroll until top or bottom of Launcher is reached
      (LP: #765749)
    - Stacking problem when switching between apps with multiple windows
      (LP: #802527)
    - Pull panel to de-maximize window occasionally not working in a secondary
      screen (LP: #802651)
    - Window under Dash gets focused if it opened later (LP: #830730)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - A minimized window 'remains' behind on the desktop if
      /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows
      is set to true (LP: #847967)
    - a11y support on Unity is broken (LP: #851103)
    - compiz crashed with SIGSEGV in dee_model_get_tag() (LP: #840758)
    - crash when looping paint list in preparePaint (on closing windows)
      (LP: #853807)
    - Alt-Tab should not preview windows at excessively large sizes
      (LP: #854740)
    - Clicking on a tweet/message link sometimes does not work (LP: #790565)
    - Dragging a launcher icon makes it squashed (LP: #855761)
    - unable to unminimize gedit windows where more than one window where one
      has a dialog open (LP: #856030)
    - (oneiric) alt-tab UX doesn't work well on multi-monitor (LP: #855364)
    - Launcher shows on the primary monitor instead of the left most monitor
      (LP: #857668)
    - Keynav - pressing down key causes launcher items to jump up and down
      (LP: #858469)
    - Windows creep cross the screen with ALT+TAB (LP: #722830)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - All unity windows are invisible (panel, launcher, dash) (LP: #745996)
    - Dash "See 97 more results" has ~1 second of latency (LP: #731158)
    - Windows cannot be dragged down from panel if banshee closed to sound
      menu (LP: #781215)
    - no menu bar on top, compositing bug? (LP: #806358)
    - Launcher - a spread can accidentally be triggered during the 'dragging
      and dropping behind the Launcher' interaction (LP: #832988)
    - Impossible to navigate between panel menus when the mouse cursor is over
      the panel (LP: #834065)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - Application name drawn under Dash controls when window opens under Dash
      (LP: #838176)
    - Start ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Cory Maccarrone (darkstar6262) wrote :

This seems to have resolved the corruption issues for me -- I've suspended/resumed many times, with no corruption.

Cas (calumlind) wrote :

The full desktop corruption has been resolved however the corruption of the launcher bar is still occurring which I think returns this bug to the original reported problem.

I would now rate this bug as low/medium as you can mouse over the launcher causing a refresh and the corruption to disappear.

I am having the same experience as Cas. Agree with low/medium rating as work around is easy to manage.

Cas (calumlind) on 2011-09-28
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Omer Akram (om26er) on 2011-09-29
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Cas (calumlind) wrote :

@Omar How can you set this to fix released if it is not completely fixed? There is still an issue that affects both Natty and Oneiric with corruption of the launcher bar.

Arpad Borsos (swatinem) wrote :

Right.
The whole-screen corruption in oneiric was fixed, but I still have artifacts in the place where the launcher should be, which go away once I hover over the left and the launcher appears.

Jacopo Moronato (jmoronat) wrote :

Or maybe we could open a new bug, actual description of this is a bit inaccurate.
And as far as I know, the actual bug (corruption of "launcher area") has to be addressed to Nvidia upstream.

Cas (calumlind) wrote :

@Jacopo I don't think a new bug should be opened because there are a lot of people signed up for this bug and I can imagine they all use the nvidia propriety driver and experience the same issue. Also reviewing the history of this bug it seems that from comment #13 onwards it had solidified into the Launcher corruption issue on Natty with a recent deviation for the additional desktop issue on Oneiric.

Can we be certain that the Launcher corruption is an nVidia issue as the whole-desktop corruption ended up being fixed in Unity.
However if this is an nVidia issue surely there should already be an upstream report because this Launcher issue was reported while Natty was still in beta.

I thought it was clear from above that it's NOT an Nvidia issue but
rather a Compiz problem. Let's not mix things here. If there was a
problem with Nvidia, Gnome-Shell, Kwin and all the rest would have the
same corruption problem.

On Thu, Sep 29, 2011 at 8:09 PM, Cas <email address hidden> wrote:
> @Jacopo I don't think a new bug should be opened because there are a lot
> of people signed up for this bug and I can imagine they all use the
> nvidia propriety driver and experience the same issue. Also reviewing
> the history of this bug it seems that from comment #13 onwards it had
> solidified into the Launcher corruption issue on Natty with a recent
> deviation for the additional desktop issue on Oneiric.
>
> Can we be certain that the Launcher corruption is an nVidia issue as the whole-desktop corruption ended up being fixed in Unity.
> However if this is an nVidia issue surely there should already be an upstream report because this Launcher issue was reported while Natty was still in beta.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (843460).
> https://bugs.launchpad.net/bugs/676166
>
> Title:
>  Screen corruption when resuming from suspend/hibernate
>
> Status in Unity:
>  Fix Released
> Status in “nvidia-graphics-drivers” package in Ubuntu:
>  Invalid
> Status in “unity” package in Ubuntu:
>  Fix Released
>
> Bug description:
>  When resuming I get oddness on the top around my panel, and oddly
>  enough, an image of my old panel.
>
>  Clicking on the area shows that I'm running the unity panel (I can
>  interact with the application indicators and application menu even
>  though I can't see them) however it looks as if unity is drawing my
>  old gnome panel.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/676166/+subscriptions
>

I am no longer experiencing any screen corruption, either at the desktop or the launcher. So this bug appears to be fixed for me. I also changed to running the Nvidia Version-Current drivers (not the post-release driver). Not sure if this is part of the fix but everything looks good now.

Cas (calumlind) on 2011-09-30
summary: - Screen corruption when resuming from suspend/hibernate
+ Unity Launcher corruption when resuming from suspend/hibernate
Rainer Rohde (rainer-rohde) wrote :

For me, the screen corruption now only affects the launcher. I am looking forward for a fix. :)

MarcoBertolini (bertolini) wrote :

I confirm. With unity 4.22.0, the screen corruption affecting the launcher is still present. I'm using Nvidia with proprietary driver. I wouldn't rate this as a high priority, but still it is quite annoying.

Emmanuel Tychon (etychon) wrote :

When resumed from sleep, the launcher bar at the left appears corrupted. Simply mousing over will redraw it, no bid deal. This has been reported by many users already.

Another interesting artifact is the window "shadow". The darker zone undernearth windows is not completely black, but filled with garbage data or even sometimes content of a web-page I closed earlier.

Using various nVidia drivers (current, port-release or edgers) leads to the same results.

Using Unity 4.22.0-0ubuntu3

Let me know if I can be of any help and thanks in advance for your support.

Vladimir Scherbaev (zemik) wrote :

This bug not fixed for me in 11.10:

unity:
  Installed: 4.24.0-0ubuntu2
  Candidate: 4.24.0-0ubuntu2
  Version table:
 *** 4.24.0-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     4.22.0-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
compiz:
  Installed: 1:0.9.6+bzr20110929-0ubuntu5
  Candidate: 1:0.9.6+bzr20110929-0ubuntu5
  Version table:
 *** 1:0.9.6+bzr20110929-0ubuntu5 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:0.9.6+bzr20110929-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages

Colin (dentarthurdent) wrote :

still happening to me too

Jancis (beaver-inbox) wrote :

I solved this by switching to open source driver. Have to use DVI now, VGA doesn't work, but at least it's WAY easier to switch screens using ubuntu built-in switcher (it happens automatically!).
Actually, screen switching is why I don't like nvidia driver. It's complicated and requires to open configurator manually :(

Still happens to me as well

@developers/triagers
Should we set this bug's status in unity in Ubuntu back to New, since there are multiple reports that it is not fixed? Or should a separate bug be opened? Or something else?

Adolfo Jayme (fitojb) wrote :

It's better to open a new bug, please.

I'm not actually affected by this bug, but perhaps someone who (still) is can submit a new bug report (and post here indicating which bug it is), in accordance with Fitoschido's recommendation.

Lino Barreca (linobarreca) wrote :

lots of new bugs are filed for this problem (look at "duplicate bugs" up the page and the dates) but it doesn't have sense because someone continues to link them to this one (and they get ignored!)
reopen this bug instead or tell people there to NOT link the bugs to this one.
btw..I'm one of the affected user... :(

Cas (calumlind) wrote :

In a recent comment I made a clear point as to why this bug is still open and I even altered the title to prevent further confusion.

https://bugs.launchpad.net/unity/+bug/676166/comments/80

The point was also made that it was a Compiz and not a Unity nor Nvidia bug.

Tomodachi (tomodachi) wrote :

have anyone else noticed the same issue when you switch users?
I used to get this issue when i suspend/ resumed.
Its not happening anymore
But just noticed that it also happens when i switch into a guest session and back

I have a nvidia9400M
dpkg tells me unity is version: 4.22.0-0ubuntu3

Zordid (zordid-gmx) wrote :

This bug is still present in the new 11.10!

Rainer Rohde (rainer-rohde) wrote :

Still have this issue as well.

As a side note, simply hovering over the launcher when coming out of suspend or hibernation when a window is maximized doesn't always clear the corruption. I then have to first minimize the window and then touch the launcher with the mouse cursor and it clears up.

Rufus (balaenoptera-rufus) wrote :

This bug affects my machine too, running Ubuntu 11.10 Oneiric. Video card is nVidia 9600GT with recommended nVidia driver 280.13. The launcher bar is corrupted after suspend and resume, as well as the top panel. The top panel sometimes stays corrupted even after hovering the mouse over it and after clicking menu items.

Rufus (balaenoptera-rufus) wrote :

After manually installing nVidia display driver 290.10 the problem persists. Screen corruption issue is still the same with the new driver.

Steve Magoun (smagoun) wrote :

Bug 915265 describes the launcher corruption issue that is still present after the Unity 4.18 release.

Bolick (alexey-brodkin) wrote :

Still persists in 11.10 32-bit even with:
nvidia-current 290.10-0ubuntu1~oneiric~xup1 from "ppa:ubuntu-x-swat/x-updates"
unity 5.0.0~+bzr1825ubuntu0+611 from "ppa:unity-team/ppa"

1 comments hidden view all 108 comments
Wolter Hellmund (wolterh) wrote :

This problem is still present in Ubuntu 13.04 (amd64) with nVidia 8600M GT.

Changed in compiz:
status: New → Invalid
Tammy Yang (wanchingy) wrote :

The issue can still be re-produced with Nvidia prime driver 331.20, private bug reported as lp:1278294, corresponding to Nvidia bug #1464852.

Tammy Yang (wanchingy) wrote :

$uname -r

Linux u-HP-ENVY-15-Notebook-PC 3.11.0-17-generic #31~precise1-Ubuntu SMP Tue Feb 4 21:25:43 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$dpkg -l | grep unity
ii unity 5.20.0-0ubuntu3

$lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller [8086:0c04] (rev 06)
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller [8086:0c01] (rev 06)
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
00:03.0 Audio device [0403]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller [8086:0c0c] (rev 06)
00:14.0 USB controller [0c03]: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI [8086:8c31] (rev 05)
00:16.0 Communication controller [0780]: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 [8086:8c3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 [8086:8c2d] (rev 05)
00:1b.0 Audio device [0403]: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller [8086:8c20] (rev 05)
00:1c.0 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 [8086:8c14] (rev d5)
00:1c.2 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 [8086:8c10] (rev d5)
00:1c.3 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #4 [8086:8c16] (rev d5)
00:1c.6 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #7 [8086:8c1c] (rev d5)
00:1d.0 USB controller [0c03]: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 [8086:8c26] (rev 05)
00:1f.0 ISA bridge [0601]: Intel Corporation HM87 Express LPC Controller [8086:8c4b] (rev 05)
00:1f.2 SATA controller [0106]: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] [8086:8c03] (rev 05)
00:1f.3 SMBus [0c05]: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller [8086:8c22] (rev 05)
01:00.0 3D controller [0302]: NVIDIA Corporation Device [10de:1391] (rev a2)
07:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01)
09:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device [10ec:5227] (rev 01)
0f:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)

Rainer Rohde (rainer-rohde) wrote :

I can confirm this issue still persisting on Trusty, after all these years.
FYI - I usually hide my Launcher; coming out of suspend shows a garbled mess where the launcher normally would be. See screenshot attached.

Tammy Yang (wanchingy) wrote :

For the symptom I mentioned in comment #104, it is found a Nvidia issue. Please check https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-
drivers-331/+bug/1210077

Close oem-priority task

no longer affects: oem-priority
Displaying first 40 and last 40 comments. View all 108 comments or add a comment.