package tex-common 4.04 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1

Bug #1236951 reported by Dac Chartrand on 2013-10-08
This bug affects 166 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
tex-common (Ubuntu)
High
Unassigned
Trusty
High
Unassigned

Bug Description

While updating from 13.04 to 13.10, I was prompted with a crash dialog, then a "will automatically revert (?)" dialogue...

ProblemType: Package
DistroRelease: Ubuntu 13.10
Package: tex-common 4.04
ProcVersionSignature: Ubuntu 3.8.0-31.23-lowlatency 3.8.13.8
Uname: Linux 3.8.0-31-lowlatency x86_64
ApportVersion: 2.12.5-0ubuntu1
Architecture: amd64
Date: Tue Oct 8 12:11:33 2013
DuplicateSignature: package:tex-common:4.04:ErrorMessage: subprocess installed post-installation script returned error exit status 1
ErrorMessage: ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2012-06-12 (482 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: tex-common
Title: package tex-common 4.04 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to saucy on 2013-10-08 (0 days ago)

Dac Chartrand (conner-bw) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tex-common (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Brian Murray (brian-murray) wrote :

From Aptterlog.gz:

Running updmap-sys. This may take some time... ^M
updmap-sys failed. Output has been stored in^M
/tmp/updmap.HSx22zeL^M
Please include this file if you report a bug.^M
^M
Sometimes, not accepting conffile updates in /etc/texmf/updmap.d^M
causes updmap-sys to fail. Please check for files with extension^M
.dpkg-dist or .ucf-dist in this directory^M
^M
dpkg: error processing tex-common (--remove):^M
 subprocess installed post-installation script returned error exit status 1^M
Errors were encountered while processing:^M
 tex-common^M

Changed in tex-common (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Behrooz Nobakht (nobeh) wrote :

Hi,

When can it be expected that this bug will be reacted upon for a fix or resolution? Is there already a workaround to use tex-common or TexLive distro on Ubuntu 13.10?

Peter Flynn (peter-silmaril) wrote :

I experienced the same updating from 13.04 to 13.10 but it just put up an error message that the package install had failed. I clicked OK and the update continued, although it spat out a few more errors at the end. The system works, everything seems to have been upgraded OK, including TeX, which appears to work correctly (modulo the apparent continued presence of hal).

I ran apt-get autoremove as usual after an update and it got rid of a bunch of outdated stuff, but because that included a couple of old LaTeX packages, it triggered tex-common to remake the indexes and generate fresh formats.

This wasn't a show-stopper, and in any case I am not updating production machines away from LTS yet. I know the Ubuntu and TeX devs are overstretched, but if there is anything a regular user like me can do to help, shout.

MATilley (matilley) wrote :

Affected me on first package update after installing 14.04 Beta 1.

MATilley (matilley) wrote :

Apologies, above comment associated with another issue. Please disregard.

tags: added: trusty
Jan Groenewald (jan-aims) wrote :
Download full text (3.8 KiB)

The error seems to be udpmap-sys is not found:

0 root@waseem-desktop:/tmp#more updmap.K5mR0Nsi
warning: kpathsea: configuration file texmf.cnf not found in these directories: /usr/share/texmf/web2c:/usr/share/texmf-texlive/web2c:/usr/local/share/tex
mf/web2c.
warning: kpathsea: configuration file texmf.cnf not found in these directories: /usr/share/texmf/web2c:/usr/share/texmf-texlive/web2c:/usr/local/share/tex
mf/web2c.
/usr/bin/updmap: 1096: .: Can't open /usr/share/tex-common/debianize-updmap
===================================================================================
0 root@waseem-desktop:~#locate debianize-updmap
/usr/share/tex-common/debianize-updmap
root@waseem-desktop:~#ls -l /usr/share/tex-common/
total 4
-rw-r--r-- 1 root root 283 Jun 15 2013 mktex.cnf
0 root@waseem-desktop:~#

====================================================================================

On precise, pre-upgrade, this file belonged to texlive-binaries, not tex-common:
0 root@muizenberg:/usr/bin#dpkg -S /usr/bin/updmap
texlive-binaries: /usr/bin/updmap
0 root@muizenberg:/usr/bin#dpkg -S /usr/bin/updmap-sys
texlive-binaries: /usr/bin/updmap-sys
0 root@muizenberg:/usr/bin#

On a trusty, post upgrade, this file belongs to texlive-base, not tex-common:
0 jan@hilaire-desktop:~$dpkg -S /usr/bin/updmap
texlive-base: /usr/bin/updmap

Possibly the file is missing during the upgrade as texlive-binaries has just been removed in the upgrade.

=================================================================================

From tex-common postinst:

This looks OK
            if which updmap-sys >/dev/null; then
                    # we also have to check that texlive-base is installed
                    # and configured, otherwise we cannot be sure that
                    # all necessary basic files are present
                    #
                    # dpkg-query has two defects wrt not existing packages
                    # - it is noisy to stderr
                    # - it returns 1
                    # so shut both errors up
                    stat=$(dpkg-query -W -f='${Status}' texlive-base 2>/dev/null || true)
                    case "$stat" in
                        "install ok installed")
                            do_it=1
                            ;;
                        *)
                            do_it=0
                            ;;
                    esac
                    if [ "$do_it" = 0 ] ; then
                        echo "texlive-base is not ready, delaying updmap-sys call" >&2
                    else
but is maybe failing??? Perhaps the OLD texlive-base without updmap-sys is still installed OK, but the OLD texlive-binaries containing updmap-sys is already removed??? Though I would have thought the earlier conditional "if which updmap-sys" would have exited already if updmap-sys was already removed.

On a related note: This does not look OK, is it checking for texlive-base or for context?? Does this stanza perhaps also trigger updmap?

run_mtxrun_if_possible()
{
    # code from postinst-tex
    if dhit_libkpathsea_configured; then
        if which mtxrun >/dev/null; then
            # we also have to check that texlive-b...

Read more...

Jan Groenewald (jan-aims) wrote :

Note this bug also breaks LTS to LTS (12.04 to 14.04) do-release-upgrades when tex-common is installed.

Robert Schroll (rschroll) wrote :

I also had this problem after upgrading from 12.04 to 14.04. My TeX install was broken afterwards. I eventually got it working by uninstalling all tex-related packages, deleting /etc/texmf/texmf.d/, and reinstalling the tex packages.

Mark Kittisopikul (markkitt) wrote :

After reading the updmap log file that was mentioned in the errors, I found that it said:

"ERROR: The following map file(s) couldn't be found:
        zpeu.map (in /var/lib/texmf/web2c/updmap.cfg)

        Did you run mktexlsr?

        You can disable non-existent map entries using the option
          --syncwithtrees."

I commented out the following line in /var/lib/texmf/web2c/updmap.cfg:
Map zpeu.map

zpeu.map was located in the package texlive-fonts-recommended in precise, but not in subsequent releases at the following location:
/usr/share/texmf-texlive/fonts/map/dvips/eurofont/zpeu.map

Suggested work around:
1. Locate updmap.* error log in /tmp according to dpkg output
2. Comment out corresponding lines in /var/lib/texmf/web2c/updmap.cfg
3. Run apt-get or other package management interface software to continue with configuration

Same problem on upgrade from 12.04 LTS to 14.04 LTS.

As inspired by the comments #9 and #10 I worked around with

    sudo apt-get remove --purge tex-common texlive-*
    sudo rm /etc/texmf/
    sudo apt-get install tex-common
    sudo apt-get install texlive-base
    sudo apt-get install texlive-latex-recommended

Run without any errors.

Jan Groenewald (jan-aims) wrote :

To do the LTS upgrade if you know about this before, this is enough:

sudo apt-get purge tex-common
sudo -E do-release-upgrade -d
sudo -E apt-get -y install tex-common texlive-base texlive-latex-recommended

(last packages added back as you need)

CSRedRat (csredrat) wrote :
aj duncan (a-duncan) wrote :

Update from 13.10 to 14.04 caused me this problem too: the upgrade failed to
install tex-common and emacsen-common and reinstalling did not work.
Combining the comments above with instructions on
http://tug.org/texlive/
this is what worked for me.
If someone can say how this should really be done, I'd be happy to see it.

1. Uninstall everything to do with emacs and xemacs
(I used synaptic package manager, to find what to remove and to completely remove)

2. Uninstall tex-common and all texlive-* files and

sudo rm -rf /etc/texmf

as in comment 12 above.

3. Remove all texlive files (if any) e.g.

sudo rm -rf /usr/local/texlive/2014
rm -rf ~/.texlive2014

4. Install emacs24 then auctex using synaptic package manager

5. Install tex-common using synaptic package manager

6. Install texlive following the instructions on http://tug.org/texlive/
(Installation from dpkg or Ubuntu software centre or synaptic package manager don't work for me.)

7. Add paths to /etc/environment as suggested by the installation program in 6.
That is, for the version I installed,
to the end of the PATH line add

:/usr/local/texlive/2014/bin/x86_64-linux

just before the closing"
and add 2 new lines

INFOPATH=":/usr/local/texlive/2014/texmf-dist/doc/info"
MANPATH=":/usr/local/texlive/2014/texmf-dist/doc/man"

(without the colon, the manpath to everything except tex will be broken)

8. Edit /etc/manpath.config
by adding line

MANPATH_MAP /usr/local/texlive/2014/bin/x86_64-linux /usr/local/texlive/2014/texmf-dist/doc/man

after the last MANPATH_MAP line that already exists.

Changed in tex-common (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High
tags: added: rls-u-incoming
Changed in tex-common (Ubuntu Trusty):
milestone: none → ubuntu-14.04.2
peredur (peredur-peredur) wrote :

I have this problem after upgrading from 12.04LTS to 14.04LTS. Will a solution be forthcoming via an upgrade in the near future, or will I have to take some manual steps?

Matt Joyce (matt-nycresistor) wrote :

This affected me today on a 12.04 upgrade to 14.04 both LTS obviously.

Staggering such a huge bug is still in effect after so long a time.

Matt Joyce (matt-nycresistor) wrote :

Got around my foul up in a REALLY ugly manner.

started with a couple iterations of :

 dpkg -l | grep texlive | awk '{print $2}' | sort | xargs dpkg -r

this cleared out a lot of the easy to hit cruft with no dependency issues.

Then I finished off by hitting what i could with specific called out dependencies listed as well. Ended up with a short set of packages that COULD NOT BE REMOVED.

I think I spotted a circular dependency in texlive / latex:

http://paste.openstack.org/show/116132/

would not be the first time ubuntu has fucked up and let one of those into their mainline.

Anyway I ended up hitting all four of those with a scary ass

dpkg --force-depends -P for the four of those packages.

That left me ready to resume with an apt-get -f install

I was able to get rid of the amount of error messages during every update by just purging and reinstalling the packages.

sudo aptitude purge tex-common kile texlive
sudo aptitude install tex-common
sudo aptitude install kile
sudo aptitude install texlive

Hope this helps other people as well.

Kyoung Eun Lee (kelee25) on 2015-02-11
Changed in tex-common (Ubuntu Trusty):
status: Triaged → Confirmed
Changed in tex-common (Ubuntu):
status: Triaged → Confirmed
assignee: nobody → Kyoung Eun Lee (kelee25)
Changed in tex-common (Ubuntu Trusty):
assignee: nobody → Kyoung Eun Lee (kelee25)
Richard Hansen (rhansen) on 2015-02-11
Changed in tex-common (Ubuntu):
assignee: Kyoung Eun Lee (kelee25) → nobody
Changed in tex-common (Ubuntu Trusty):
assignee: Kyoung Eun Lee (kelee25) → nobody
Leo (leorolla) wrote :

Thanks Matt and Hugo! I didn't try removing tex-common, which makes sense.

What worked for me was:

sudo apt-get purge texlive*
sudo update-updmap
sudo updmap-sys --syncwithtrees
sudo updmap-sys
sudo apt-get install --reinstall texlive-base tex-common
sudo apt-get install texlive

Adam Conrad (adconrad) on 2015-08-06
Changed in tex-common (Ubuntu Trusty):
milestone: ubuntu-14.04.2 → ubuntu-14.04.4
tags: removed: rls-u-incoming
Changed in ubuntu-release-notes:
status: New → Fix Released
Changed in tex-common (Ubuntu Trusty):
status: Confirmed → Triaged
Changed in tex-common (Ubuntu):
status: Confirmed → Triaged
tags: added: dist-upgrade
Erel Segal (erelsgl) wrote :

I just did:

    sudo apt-get remove tex-common

Surprisingly, latex works fine after the removal. And the error is gone.

Simplehuman (simplehuman) wrote :

Tested this bug with different supported Ubuntu versions. Texlive, tex-common installed.

Cases:

1. Upgrading Ubuntu 15.10 > 16.04. Can't confirm.
2. Upgrading Ubuntu 14.04.4 > 15.10. Upgrade hangs on VirtualBox and on real hardware.
3. Upgrading Ubuntu 14.04.4 > 16.04. Can't confirm.
4. Upgrading Ubuntu 12.04.4 > 14.04.4. Can't confirm.

tags: removed: saucy
teo1978 (teo8976) wrote :

I just tried to upgrade from 15.10 to 16.04 and I'm left with an unusable system.

i2000s (i2000s) wrote :

Encountered this error when I tried reinstalling the texlive 2015 from the official source. TeX-common stopped me to reinstall, but I have tried removing tex-common completely, I think.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers