Lock screen is unusable when some windows have a keyboard/mouse grab

Bug #1305586 reported by Iain Lane on 2014-04-10
306
This bug affects 64 people
Affects Status Importance Assigned to Milestone
Compiz
High
Marco Trevisan (Treviño)
0.9.11
High
Marco Trevisan (Treviño)
Unity
Fix Released
High
Marco Trevisan (Treviño)
7.2
Fix Released
High
Marco Trevisan (Treviño)
compiz (Ubuntu)
High
Marco Trevisan (Treviño)
Trusty
High
Unassigned
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Trusty
High
Unassigned

Bug Description

[Impact]
Some windows will grab the keyboard/mouse and when the lockscreen kicks in, this window will still have the grab and thusly, you can't enter your password in the lockscreen.

[Test case]
This will work only in the case that your lockscreen is set (from unity control center, lock pane) to lock immediately (when screen turns off).

1. Open a window that will hold the grab, such as the ssh password dialog or a virtual
   machine (such as virtualbox in fullscreen).
2. Wait for the lock screen to activate [1].
3. The screen won't be locked, since it's not possible to steal drag to another window.

[Regression potential]
For the same reason of lp:49579, we can't lock the screen (yet) if something takes the grab in X, or we won't able to get input back. This is not a regression because it has never been possible in Ubuntu before, while when we tried that, it caused this bug.

A possible source of regression might be that we now try to grab/ungrab the screen (the only X reliable way for grab checking), when showing the dash/hud or the lockscreen itself, and this might slow things down a little, but from measurements done this slow down is generally about 2ms, so nothing to worry about.

* Compiz Debdiff is found at https://launchpadlibrarian.net/178439518/compiz-trusty-sru-2.debdiff *

[1] You can use this to reduce the locking delay:
      gsettings set org.gnome.desktop.session idle-delay 5
    and resetting it with:
      gsettings reset org.gnome.desktop.session idle-delay

-----------

Original Description:

My screen just timed out and locked when a password prompt which had a grab was displaying.

I couldn't type my password or interact with the indicators.

gnome-screensaver just refuses to lock in this situation, perhaps unity could do the same unless it's possible to remove and readd the grabs yourself, but I don't think XLib lets you do that (you can only remove your own grabs AFAIK).

TEMPORARY WORKAROUND TO LOGIN AGAIN:
Click on the guest session
Once the guest session is started log out
This takes you back to the lightdm session screen you can then login to your user session and it be in the same state

ProblemType: BugDistroRelease: Ubuntu 14.04
Package: unity 7.2.0+14.04.20140409-0ubuntu1 [origin: unknown]
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
ApportVersion: 2.14.1-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CrashDB: unity
CurrentDesktop: Unity
Date: Thu Apr 10 09:39:45 2014
InstallationDate: Installed on 2012-10-07 (549 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20121007)SourcePackage: unity
UpgradeStatus: Upgraded to trusty on 2013-05-07 (338 days ago)

Related branches

Iain Lane (laney) wrote :
tags: added: lockscreen
Changed in unity:
importance: Undecided → High

This happens just with the ssh password dialog. With other grabs the lock fails to start.

summary: - Lock screen is unusable when a client has a keyboard/mouse grab
+ Lock screen is unusable when a ssh dialog has a keyboard/mouse grab
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Confirmed

When I reported this bug I'd just had it with a prompt for an account password from e-d-s.

Andrea Azzarone <email address hidden> wrote:

>This happens just with the ssh password dialog. With other grabs the
>lock fails to start.
>
>** Also affects: unity (Ubuntu)
> Importance: Undecided
> Status: New
>
>** Summary changed:
>
>- Lock screen is unusable when a client has a keyboard/mouse grab
>+ Lock screen is unusable when a ssh dialog has a keyboard/mouse grab
>
>** Changed in: unity
> Status: New => Triaged
>
>** Changed in: unity (Ubuntu)
> Status: New => Confirmed
>
>--
>You received this bug notification because you are subscribed to the bug
>report.
>https://bugs.launchpad.net/bugs/1305586
>
>Title:
> Lock screen is unusable when a ssh dialog has a keyboard/mouse grab
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/unity/+bug/1305586/+subscriptions
>

Andrea Azzarone (azzar1) wrote :

Eds?
On Apr 13, 2014 4:50 PM, "Iain Lane" <email address hidden> wrote:

> When I reported this bug I'd just had it with a prompt for an account
> password from e-d-s.
>
> Andrea Azzarone <email address hidden> wrote:
>
> >This happens just with the ssh password dialog. With other grabs the
> >lock fails to start.
> >
> >** Also affects: unity (Ubuntu)
> > Importance: Undecided
> > Status: New
> >
> >** Summary changed:
> >
> >- Lock screen is unusable when a client has a keyboard/mouse grab
> >+ Lock screen is unusable when a ssh dialog has a keyboard/mouse grab
> >
> >** Changed in: unity
> > Status: New => Triaged
> >
> >** Changed in: unity (Ubuntu)
> > Status: New => Confirmed
> >
> >--
> >You received this bug notification because you are subscribed to the bug
> >report.
> >https://bugs.launchpad.net/bugs/1305586
> >
> >Title:
> > Lock screen is unusable when a ssh dialog has a keyboard/mouse grab
> >
> >To manage notifications about this bug go to:
> >https://bugs.launchpad.net/unity/+bug/1305586/+subscriptions
> >
>
> --
> You received this bug notification because you are subscribed to Unity.
> https://bugs.launchpad.net/bugs/1305586
>
> Title:
> Lock screen is unusable when a ssh dialog has a keyboard/mouse grab
>
> Status in Unity:
> Triaged
> Status in "unity" package in Ubuntu:
> Confirmed
>
> Bug description:
> My screen just timed out and locked when a password prompt which had a
> grab was displaying.
>
> I couldn't type my password or interact with the indicators.
>
> gnome-screensaver just refuses to lock in this situation, perhaps
> unity could do the same unless it's possible to remove and readd the
> grabs yourself, but I don't think XLib lets you do that (you can only
> remove your own grabs AFAIK).
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: unity 7.2.0+14.04.20140409-0ubuntu1 [origin: unknown]
> ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
> Uname: Linux 3.13.0-23-generic x86_64
> ApportVersion: 2.14.1-0ubuntu1
> Architecture: amd64
> CompizPlugins: No value set for
> `/apps/compiz-1/general/screen0/options/active_plugins'
> CrashDB: unity
> CurrentDesktop: Unity
> Date: Thu Apr 10 09:39:45 2014
> InstallationDate: Installed on 2012-10-07 (549 days ago)
> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20121007)
> SourcePackage: unity
> UpgradeStatus: Upgraded to trusty on 2013-05-07 (338 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/1305586/+subscriptions
>

Iain Lane (laney) wrote :

On Sun, Apr 13, 2014 at 05:07:18PM -0000, Andrea Azzarone wrote:
> Eds?

evolution-data-server. My point was that it isn't specific to prompts
from the SSH agent.

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Dave Morley (davmor2) on 2014-04-22
description: updated
Andrea Azzarone (azzar1) on 2014-04-23
summary: - Lock screen is unusable when a ssh dialog has a keyboard/mouse grab
+ Lock screen is unusable when a password dialog has a keyboard/mouse grab
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
milestone: none → 7.2.1
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

Probably this bug happens with any window that has keyboard/mouse grab (not only password dialogs). I've noticed the same problem when using virtualbox in fullscreen mode (reported as bug #1311036).

summary: - Lock screen is unusable when a password dialog has a keyboard/mouse grab
+ Lock screen is unusable when some windows have a keyboard/mouse grab
Andrea Azzarone (azzar1) wrote :

@Marco, it does not happen for all the windows having the grab. Just few of them: e.g. ssh password dialog and vbox. But it works for menu and other applications.

Andrea,

That's why I've written "some"...
Basically it happens for the windows that don't emit a NotifyGrab event to the server.
And the problem is that X doesn't guarantee that this happens when a grab is set.

So, while in some cases (like the gnome-keyring box) we can still get an NotifyWhileGrabbed event that is enough for us to know that it's grabbing, in other ones (like vbox), there's not much other way than trying to grab/ungrab the root window to check if the screen is already grabbed or not. :(

NoBugs! (luke32j) wrote :

When this happened to me, I could choose switch-account from the upper right menu, then log back in to my session.

Is this the same behavior you see?

I am usually in a windows VM full screen.  So first I have to hit the nix attention button, then alt-ctrl-up to get to a nix desktop.  This still doesn't give me keyboard control, but if I mouse over to the upper right like you're describing, but all I have to do is get the calendar icon to pop open, or the switch user menu or something.  Don't actually have to click on anything, just get those things to respond.  Then, finally, the login password prompt will respond.  Clumsy but it works.

Sent via the Samsung Galaxy Note® II, an AT&T 4G LTE smartphone

<div>-------- Original message --------</div><div>From: NoBugs! <email address hidden> </div><div>Date:05/02/2014 2:45 PM (GMT-06:00) </div><div>To: <email address hidden> </div><div>Subject: [Bug 1305586] Re: Lock screen is unusable when some windows have a
  keyboard/mouse grab </div><div>
</div>When this happened to me, I could choose switch-account from the upper
right menu, then log back in to my session.

Is this the same behavior you see?

--
You received this bug notification because you are subscribed to a
duplicate bug report (1311036).
https://bugs.launchpad.net/bugs/1305586

Title:
  Lock screen is unusable when some windows have a keyboard/mouse grab

Status in Unity:
  Triaged
Status in “unity” package in Ubuntu:
  Confirmed

Bug description:
  My screen just timed out and locked when a password prompt which had a
  grab was displaying.

  I couldn't type my password or interact with the indicators.

  gnome-screensaver just refuses to lock in this situation, perhaps
  unity could do the same unless it's possible to remove and readd the
  grabs yourself, but I don't think XLib lets you do that (you can only
  remove your own grabs AFAIK).

  TEMPORARY WORKAROUND TO LOGIN AGAIN:
  Click on the guest session
  Once the guest session is started log out
  This takes you back to the lightdm session screen you can then login to your user session and it be in the same state

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: unity 7.2.0+14.04.20140409-0ubuntu1 [origin: unknown]
  ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
  Uname: Linux 3.13.0-23-generic x86_64
  ApportVersion: 2.14.1-0ubuntu1
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CrashDB: unity
  CurrentDesktop: Unity
  Date: Thu Apr 10 09:39:45 2014
  InstallationDate: Installed on 2012-10-07 (549 days ago)
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20121007)
  SourcePackage: unity
  UpgradeStatus: Upgraded to trusty on 2013-05-07 (338 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/unity/+bug/1305586/+subscriptions

kylea (kylea) wrote :

Affects me when running Windows 7 in a Virtualbox VM. I use change user and the re-login as me

Distributor ID: Ubuntu
Description: Ubuntu 14.04 LTS
Release: 14.04
Codename: trusty

Linux 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Mark Petryk (mcrk) wrote :

Try hitting the host key (right-ctrl) then ctrl-alt-arrow to switch to a different desktop other that your Windows vm desktop.  Then click around on the calendar/login widgets in the upper right, just get them to pop. Then click on the password dialog, keyboard should be active then.

It's honkey, but I've been successful. Though, I've just turned off my luck screen for now.

Sent via the Samsung Galaxy Note® II, an AT&T 4G LTE smartphone

<div>-------- Original message --------</div><div>From: kylea <email address hidden> </div><div>Date:05/03/2014 7:57 PM (GMT-06:00) </div><div>To: <email address hidden> </div><div>Subject: [Bug 1305586] Re: Lock screen is unusable when some windows have a
  keyboard/mouse grab </div><div>
</div>Affects me when running Windows 7 in a Virtualbox VM. I use change user
and the re-login as me

Distributor ID: Ubuntu
Description: Ubuntu 14.04 LTS
Release: 14.04
Codename: trusty

Linux  3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

--
You received this bug notification because you are subscribed to a
duplicate bug report (1311036).
https://bugs.launchpad.net/bugs/1305586

Title:
  Lock screen is unusable when some windows have a keyboard/mouse grab

Status in Unity:
  Triaged
Status in “unity” package in Ubuntu:
  Confirmed

Bug description:
  My screen just timed out and locked when a password prompt which had a
  grab was displaying.

  I couldn't type my password or interact with the indicators.

  gnome-screensaver just refuses to lock in this situation, perhaps
  unity could do the same unless it's possible to remove and readd the
  grabs yourself, but I don't think XLib lets you do that (you can only
  remove your own grabs AFAIK).

  TEMPORARY WORKAROUND TO LOGIN AGAIN:
  Click on the guest session
  Once the guest session is started log out
  This takes you back to the lightdm session screen you can then login to your user session and it be in the same state

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: unity 7.2.0+14.04.20140409-0ubuntu1 [origin: unknown]
  ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
  Uname: Linux 3.13.0-23-generic x86_64
  ApportVersion: 2.14.1-0ubuntu1
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CrashDB: unity
  CurrentDesktop: Unity
  Date: Thu Apr 10 09:39:45 2014
  InstallationDate: Installed on 2012-10-07 (549 days ago)
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20121007)
  SourcePackage: unity
  UpgradeStatus: Upgraded to trusty on 2013-05-07 (338 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/unity/+bug/1305586/+subscriptions

I also have this issue; that I have no interaction with keyboard to type password ater the screen is locked from time-out. But for me this always occur. It doesn't have to be a window with a keyboard/mouse grab.

Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
milestone: 7.2.1 → 7.3.0
Graeme Pietersz (fgpietersz) wrote :

I appear to have the same problem when playing Battle for Wesnoth in full screen mode. Its fairly clear that the Battle for Wesnoth window has grabbed the mouse because some clicks produce game sounds.

The mouse pointer cannot be moved to the top of the screen, so I cannot interact with switch user or anything else in that bar.

Fuujuhi (fuujuhi) wrote :

As a work-around I usually go in one of the virtual console, and kill compiz:
- Ctrl-Alt-F1
- login, then:
$ pkill -9 compiz
- Ctrl-D (logout)
- Ctrl-Alt-F7

This should kill the lock screen, restart compiz. Applications should not be affected.

Jan C. P. (jan-c-p) wrote :

The easiest workaround seems to be to click on “Switch account” and then log in as the same user as before.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.10.20140606-0ubuntu1

---------------
compiz (1:0.9.11+14.10.20140606-0ubuntu1) utopic; urgency=low

  [ Chris Townsend ]
  * Only ungrab the Mod2Mask modifier on buttons 4-7 to allow scrolling
    in unfocused Gtk windows while still allowing keybinding modifiers
    to other scroll wheel actions. (LP: #1311788)
  * Fix issue where window decorations would be placed under the Panel
    when opening a new window from an already open window. This is due
    to the already open window being taller or just as tall without be
    maximized than the workspace. (LP: #1303462)
  * Only constrain the non-modifier scrolling to the vertical scrolling
    buttons - buttons 4 & 5. (LP: #1311303)
  * Fix issue where maximized windows would get moved to different
    workspaces when disconnecting/connecting an external monitor.
    Windows should stay in the same workspace they are in when the
    monitor event occurs. (LP: #1304531)
  * Fix issue where custom keyboard shortcuts would get reset to
    defaults when rebooting or restarting Compiz. (LP: #1063617)
  * Fixes issue in the Expo plugin where a gap is shown in the place
    where the Launcher and Panel should be when windows are maximized.
    This was originally removed in rev. 3481. (LP: #1087090)
  * Fix issue where horizontal and vertical keyboard resizing could not
    happen at the same time. (LP: #347390)

  [ Marco Trevisan (Treviño) ]
  * Scale: use XShape extension to exclude dnd input in the screen-parts
    outside workArea This will work property also in multi-monitor,
    without requiring multiple X windows for each output device. Also
    don't terminate the scale unless a drag-n-drop action is not really
    over. Add a spinner that shows up over a window, during the DnD
    timeout. Plus, make sure we terminate the scale without focusing the
    selected icon when cancelling it and some code cleanup (LP: #607796)
  * Event: set the screen grabbed also when we get a NotifyWhileGrabbed
    Focus{In,Out} event (LP: #1305586)
 -- Ubuntu daily release <email address hidden> Fri, 06 Jun 2014 09:43:06 +0000

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Changed in compiz:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 0.9.12.0
Changed in compiz (Ubuntu):
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
CSRedRat (csredrat) wrote :
Jon (jonpad) wrote :

I get this also, with 14.10 LTS as a host and 14.04 as a VirtualBox guest. My solution is to programmatically minimise VB by selecting another TTY (via Ctrl-Alt-F1) and running this script:

    WID=`DISPLAY=:0 xdotool search --name "\[Running\]"`
    DISPLAY=:0 xdotool windowminimize $WID

That gets the window ID of the VB window and then minimises it. I then Ctrl-Alt-F7 back to the desktop, click on the sound/clock menu or something (it seems to free up the focus) and then the password field will work again.

It's a faff, but at least it works.

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
description: updated
description: updated

Hello Iain, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.11.1+14.04.20140617-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed

I'm marking it as verification-done because there are no more problems with unusable lockscreen. However there are some things which don't work entirely as expected.

I've tested three programs VMware, VirtualBox and gksudo window summoned by gdebi. In case of VirtualBox everything worked, the screen turned off and it was locked and I had no problems unlocking it.

In case of VMware and gksudo the screen turned off but it didn't lock until I released the keyboard/mouse grab in case of VMware, dismissed the window in case of gksudo. Until I released the keyboard/mouse grab I saw the desktop. When I released the grab lockscreen kicked in immediately and I was able to type my password and unlock.

Hi Mateusz,

Thanks for validating this. You're correct in that this one fix doesn't address everything. There is still some fixes to go into the next Unity SRU that will make this better. We included this fix in this Compiz SRU in preparation for that Unity SRU. We are in the process of preparing the next Unity SRU, so keep an eye out for it in the not-too-distant future.

Thanks!

Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Trusty):
status: New → Confirmed
description: updated
Chris J Arges (arges) wrote :

Hello Iain, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.11.1+14.04.20140623-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed

Hello Iain, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.11.1+14.04.20140701-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
removed: verification-done
tags: added: verification-done
removed: verification-needed
Simon Buchan (simon-buchan-nz) wrote :

The proposed fix doesn't seem to work for me:
- Enable trusty-proposed, with /etc/apt/preferences pin
- Update compiz with aptitude -t trusty-proposed
- dpkg --status compiz gives: "Status: install ok installed" and "Version: 1:0.9.11.1+14.04.20140701-0ubuntu1"
- Restart, relogin
- Start VirtualBox (ver 4.3.10-dfsg-1) my Windows 8.1 update 1 VM, fullscreen
- Wait for Unity lockscreen (timeout set to 1 minute for testing)
- Keyboard input does not seem to respond, mouse works fine.
- Switch accounts..., log in as myself again succeeds, returns to existing session
- Keyboard input has been going to the windows VM

This is a dual monitor system which might be important.
Apt is otherwise up to date with released packages.

The mentioned workarounds to get focus back to the login screen don't seem to work for me either (unity --replace, host key etc...). Only switch user, which seems to do a video reset.

Any logs etc... I could attach that would be useful? This isn't a huge blocker, but it's quite annoying.

I confirm what Simon Buchan wrote in his comment.

- I start VirtualBox with Ubuntu 12.04.4 LTS as guest, fullscreen
- Wait for Unity lockscreen (timeout set to 1 minute for testing)
- Keyboard input does not seem to respond, mouse works fine.

Now there is other workaround to get input not going to the VM but to lockscreen text box. I just need to switch off fullscreen for the VM with keyboard shortcut Host + F (by default Right Ctrl + F) and then open indicators and finally switch to the lockscreen password text box.

I have only one monitor.

@Simon this particular problem might be resolved with the Unity SRU update. Christopher Townsend mentioned in comment #23 that the Compiz SRU doesn't resolve all the problems and that Unity SRU has still some fixes which should make this bettter.

@Simon,

that's exactly what Mateusz says: the problem you're talking about is fixed in the unity SRU, the verification process we're currently doing is only for Compiz, which has a change that improves us to solve this issue, in some cases (like the one mentioned in verification process), but not in all the ones.
For all the cases to be handled, you'll need to update unity with the proposed version that will be available in few days.

Simon Buchan (simon-buchan-nz) wrote :

Ahh, missed comment #23, thrown off by the verification-needed tags :). Sorry for the noise, I'll keep watching.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11.1+14.04.20140701-0ubuntu1

---------------
compiz (1:0.9.11.1+14.04.20140701-0ubuntu1) trusty; urgency=medium

  [ Chris Townsend ]
  * Bump version to 0.9.11.1.

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Tue, 01 Jul 2014 11:51:26 +0000

Changed in compiz (Ubuntu Trusty):
status: Fix Committed → Fix Released
description: updated
hector (mailbox-deandreis) wrote :

Hi
I have the same problem.
But for he 2 past months i've haven't seen any problem (al lot of problems before, on May)
From last 2 days the problem is appared again, more times at day.
Just some days ago i've installed tcplay and truecrypt, now i had remove them to test.
I have 2 monitors and Virtualbox installed, but the problem still alive also if i don't have any VBox client / machine opened.

Changed in unity (Ubuntu Trusty):
status: Confirmed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released

I'm still seeing this issue when Google Chrome is the last open ( and focused ) application upon suspend. When I typed my password in it didn't work - so I did the "switch account" hack and logged in - and found my password sitting in the Chrome address bar.

I've installed the latest proposed updates and have the following compiz version:
$ apt-cache policy compiz
compiz:
  Installed: 1:0.9.11.2+14.04.20140714-0ubuntu1

Let me know if I'm missing anything.

This also happens in Chromium.

And my Unity version:

$ apt-cache policy unity
unity:
  Installed: 7.2.2+14.04.20140714-0ubuntu1

dovercrash: I'm having that issue with chrome as well.

$ sudo apt-cache policy google-chrome-stable
google-chrome-stable:
  Installed: 36.0.1985.125-1

Same versions of unity and compiz that you have.

Tried to reproduce it with other applications (gedit, gnome-terminal, firefox), but it does only happen in Google Chrome.

My workaround is to click some of the icons on the taskbar (the battery icon, or the keyboard layout selector i.e).

Erik Axelsson (erikaxelsson1) wrote :

I also have this bug with chromium:

chromium-browser:
  Installed: 34.0.1847.116-0ubuntu2

compiz:
  Installed: 1:0.9.11.2+14.04.20140714-0ubuntu1

unity:
  Installed: 7.2.2+14.04.20140714-0ubuntu1

A work around is to suspend and wake up the computer one more.

Gao Shichao (xgdgsc) wrote :

I also have this bug with google-chrome 36.0.1985.125-1, so this bug is not fixed, please someone take a look. Also workaround by clicking some of the icons on the panel.

Vincent Thiele (vincentthiele) wrote :

Bug is still there.

Seems like it is fixed now, in the unity package:

$ sudo apt-cache policy unity
unity:
  Installert: 7.2.2+14.04.20140714-0ubuntu1.1

See changelog: https://launchpad.net/ubuntu/+source/unity/7.2.2+14.04.20140714-0ubuntu1.1
And the associated bug: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1349128

Make sure you all have installed the unity package version
7.2.2+14.04.20140714-0ubuntu1.1 (use "apt-cache policy unity" to
check), and you've restarted your session.

anigel (sarah-anigel) wrote :

This bug is not resolved.

Using two monitors with Virtual Box on seamless mode on one of those screens the same problem still exhibits.

unity:
  Installed: 7.2.2+14.04.20140714-0ubuntu1.1

compiz:
  Installed: 1:0.9.11.2+14.04.20140714-0ubuntu1

Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
Changed in compiz (Ubuntu Trusty):
importance: Undecided → High
Changed in unity (Ubuntu Trusty):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers