No option to continue from install type screen

Bug #1172572 reported by Paul Larson on 2013-04-25
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Andy Whitcroft
ubiquity (Ubuntu)
Medium
Unassigned
Saucy
Medium
Unassigned

Bug Description

Image is raring rc - i386 desktop
The test system I'm on is a dell inspiron with a windows partition, and a previous install of raring rc - amd64.

On the screen that allows me to select the install type, for any option I select, the button at the bottom to continue with the install is grayed out.

See attached screenshot

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: ubiquity 2.14.6 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic i686
ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
CasperVersion: 1.331
Date: Thu Apr 25 04:20:04 2013
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --
LiveMediaBuild: Ubuntu 13.04 "Raring Ringtail" - Release i386 (20130424)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

== Release Notes Text ==

 * In rare circumstances the 'Next' button on the installer 'Install Type' screen is non-functional. This is intermittent and may be resolved by hitting 'Back' and retrying. ([[https://bugs.launchpad.net/bug/1172572 | LP: #1172572]])

Paul Larson (pwlars) wrote :
Paul Larson (pwlars) wrote :
Paul Larson (pwlars) wrote :

pressing back, then going back to the install type screen again allows me to continue at least this time

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1172572

tags: added: iso-testing
Dimitri John Ledkov (xnox) wrote :

Very interesting combination. I am not sure if cross-grading from one arch to another was ever reliable enough.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Dimitri John Ledkov (xnox) wrote :

On the second look, the machine in question already has maximum number of primary partitions used and possibly simply the calculation to "activate install button" maybe regressed in the corner case of all primary partitions used.

Andy Whitcroft (apw) on 2013-04-25
description: updated
Changed in ubuntu-release-notes:
status: New → Fix Released
assignee: nobody → Andy Whitcroft (apw)
Kate Stewart (kate.stewart) wrote :

Since this was mentioned in the release notes for Raring, and there doesn't seem to have been much activity, marking this explicitly against saucy so it doesn't get overlooked.

tags: added: saucy
CSRedRat (csredrat) wrote :

When this fixed in 14.04 Trusty Tahr for 14.04.1 (24 July)?

Phillip Susi (psusi) on 2014-06-11
no longer affects: ubiquity (Ubuntu Raring)
tags: added: trusty
removed: ubuntu
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in ubiquity (Ubuntu Saucy):
status: Confirmed → Won't Fix
tags: removed: saucy
tags: removed: trusty
tags: added: wily
removed: rls-r-incoming
Simplehuman (simplehuman) wrote :

Actual for Xenial

tags: added: amd64 xenial
tags: removed: raring
tags: removed: wily
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers