Dual screen greeter can break 3D acceleration

Bug #1292467 reported by Stefan Bader on 2014-03-14
114
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Andy Whitcroft
unity-greeter (Ubuntu)
Medium
Unassigned

Bug Description

When booting with two screens (internal LVDS and VGA), lightdm comes up in a mode where it displays separate screen content on both displays (so no mirror mode). These screens seem to be arranged side-by-side regardless of the fact that (like in my case) the combined width can be greater than 2048 and that is not supported with 3D acceleration at least on that older i945GME graphics.

This results in very poor graphics performance and compiz using a lot of cpu cycles (which are rather limited on this Atom N270 anyways). Even worse, this does not get resolved when changing the setup in system settings to either only having one screen active or arranging them on top of each other).

WORKAROUND:
 * Plug in external monitor after login (1)
 * Boot with "video=LVDS-1:d" (2)

(1) Booting with only the internal screen and then plugging in the external one after login seems to handle this better (although I probably need to remove any previous config to get into a kind of vanilla state again). Also it seems to be ok when I had the dual monitor boot and lightdm coming up side-by-side, when unplugging the external monitor before logging in.

(2) This will completely disable the internal screen for that boot. It cannot be enabled through the settings dialogue.

Stefan Bader (smb) on 2014-03-17
Changed in lightdm (Ubuntu):
importance: Undecided → High
affects: lightdm (Ubuntu) → unity-greeter (Ubuntu)
summary: - Lightdm on dual-screens can break 3D acceleration
+ Duel screen greeter can break 3D acceleration
Changed in unity-greeter (Ubuntu):
importance: High → Medium
status: New → Triaged
Stefan Bader (smb) on 2014-04-15
summary: - Duel screen greeter can break 3D acceleration
+ Dual screen greeter can break 3D acceleration
Stefan Bader (smb) wrote :

Should we add something to the release notes? Maybe like this:

Some laptops or netbooks with older graphics can experience bad graphical performance when starting with a high resolution external monitor attached. The reason for this is that some graphics cards (like the Intel 945GSE for example) cannot support accelerated 3D graphics when the combined width of both screens exceeds a certain threshold (2048 pixels in the example above).

Stefan Bader (smb) on 2014-04-16
description: updated
Andy Whitcroft (apw) on 2014-04-17
Changed in ubuntu-release-notes:
assignee: nobody → Andy Whitcroft (apw)
status: New → Fix Released
CSRedRat (csredrat) wrote :

When this fixed in 14.04 Trusty Tahr for 14.04.1 (24 July)?

Hi Andy,

You changed the status of this bug from "New" to "Fix Released" on April 17. Are you referring to the workaround you documented in the description, or was a fix for this bug actually implemented? I do not see this bug (1292467) listed in the change summary for Ubuntu 14.04.1 at https://wiki.ubuntu.com/TrustyTahr/ReleaseNotes/ChangeSummary/14.04.1.

Thanks,

Pat

Stefan Bader (smb) wrote :

Hi Patricia, that was only the release-notes task. So we just noted wrote down there that this can happen and how to work around it. I have not seen or heard anyone fixing (or even looking at) the problem.

Henry Yei (henry-yei) wrote :

This exact bug seems to happen on a Dell M3800 Laptop with Haswell graphics.

WinEunuchs2Unix (ricklee518) wrote :

"This exact bug seems to happen on a" Toshiba Satellite L-300 with Intel Centrino 2 Core Duo T5750 with GME965 GPU using i915 driver under Linux Kernel's 3.13.xx and 3.15.xx with Ubuntu 14.04. Work around to unplug the external TV on every reboot is a minor inconvience.

When Henry in comment #5 made his post I was automatically e-mailed the message along with his e-mail address. This is an EVEN BIGGER BUG on this website.

Eric Fournie (ef-adressebidon) wrote :

Same here with an i915. Unity was completely unusable after upgrading 12.04 -> 14.04, the internal display which I never used was breaking 3d acceleration. I had the problem with both the Ubuntu default package and the Intel drivers from 01.org. The computer is a low-end PC used as a server, so unplugging the monitor on each reboot is quite inconvenient and using two displays could be useful. In my opinion, this is quite a serious bug.

The "video=LVDS-1:d" workaround fixed the issue, in order to have it permanently, I added the option in /etc/default/grub to the GRUB_CMDLINE_LINUX_DEFAULT variable and ran update-grub.

Andrew (recman700) wrote :

Disabling a monitor through the system settings also seems to fix this, and it doesn't require a reboot. The issue returns once the monitor is re-enabled.

WinEunuchs2Unix (ricklee518) wrote :

Comment #8 seems out of context. Once booted there is no problem plugging in and unplugging monitors, changing resolution and scan frequencies. Additionally there is no problem suspending and resuming--which is a good reason to never reboot unless resume fails or a boot into windows / different distro is required.

The problem is that when booting the system compiz in my case and lightdm is other posters cases gets confused. I get error messages and from then on Flash Player under Google Chrome doesn't effectively use the GPU so burns up CPU cycles. For other users 3D acceleration (which also uses a GPU or discrete graphics card/chip) degrades.

Ideally users should be able to boot their machines with 2 or 3 active monitors and not have to worry about unplugging this screen or that screen each time. I think with extensions users can have up to 6 or 7 screens.

Just as kernel modules have dependencies (as shown by modprobe) xrandr needs to reveal a dependency that xorg must be up and running before it is loaded. The kernel scheduler (when it is written) needs to put xrandr to sleep in 1/10th second loops until xorg is running along with compiz and whatever else it needs.

Similar issues might exist with udev, btrfs, acpi, usb devices, etc. etc. Pardon my poor analysis with only 100 hours or so of Linux education time so far.

Fabiano Brites (fbrites) wrote :

Same problem here. So another user affected by this bug.

Rael Gugelmin Cunha (rael-gc) wrote :

Interesting. My previous version was 12.04. And I spent a huge time wondering why I'm facing bad performance when enabling the 3D card + external monitor.

Wondering if every people complaining about the poor 3D accel + external monitor get to know about this bug, the size of "affects X people" will increase a lot.

bigley.ling (bigley-ling) wrote :

Does anyone know when an update may be fixing this issue? Having to disable LVDS (GRUB_CMDLINE_LINUX="video=LVDS-1:d") to get descent performance from an external VGA display is not ideal, as I would call it a temporary fix, as when one wants to use the internal LVDS, it has to be reenabled each time and a restart performed.

Turning off the LVDS using only VGA in "system settings/displays", did not make any difference to the slow GPU performance unless I booted up with VGA unplugged or use external VGA with LVDS disabled in GRUB

tags: added: trusty

Why is showing up in my google in box?

More

*1* of *635*

[image: Expand all]
[image: Print all]
[image: In new window]
[Bug 1292467] Re: Dual screen greeter can break 3D acceleration
Inbox
x
Fabiano Brites
Same problem here. So another user affected by this bug. -- You received
this...
10/16/14
Rael
Interesting. My previous version was 12.04. And I spent a huge time
wondering...
Jan 4
bigley.ling
Does anyone know when an update may be fixing this issue? Having to disable
L...
Jun 29
Mathew Hodson <email address hidden> via
<https://support.google.com/mail/answer/1311182?hl=en> canonical.com
4:31 PM (2 hours ago)
to me
** Tags added: trusty

On Fri, Aug 7, 2015 at 4:31 PM, Mathew Hodson <email address hidden>
wrote:

> ** Tags added: trusty
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1292467
>
> Title:
> Dual screen greeter can break 3D acceleration
>
> Status in Release Notes for Ubuntu:
> Fix Released
> Status in unity-greeter package in Ubuntu:
> Triaged
>
> Bug description:
> When booting with two screens (internal LVDS and VGA), lightdm comes
> up in a mode where it displays separate screen content on both
> displays (so no mirror mode). These screens seem to be arranged side-
> by-side regardless of the fact that (like in my case) the combined
> width can be greater than 2048 and that is not supported with 3D
> acceleration at least on that older i945GME graphics.
>
> This results in very poor graphics performance and compiz using a lot
> of cpu cycles (which are rather limited on this Atom N270 anyways).
> Even worse, this does not get resolved when changing the setup in
> system settings to either only having one screen active or arranging
> them on top of each other).
>
> WORKAROUND:
> * Plug in external monitor after login (1)
> * Boot with "video=LVDS-1:d" (2)
>
> (1) Booting with only the internal screen and then plugging in the
> external one after login seems to handle this better (although I
> probably need to remove any previous config to get into a kind of
> vanilla state again). Also it seems to be ok when I had the dual
> monitor boot and lightdm coming up side-by-side, when unplugging the
> external monitor before logging in.
>
> (2) This will completely disable the internal screen for that boot. It
> cannot be enabled through the settings dialogue.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-release-notes/+bug/1292467/+subscriptions
>

Cvetan Simsic (cvetan-simsic) wrote :

This bug affects me on Ubuntu 14.04 LTS, also tried 15.04.

I have two benq gl2450. If i boot with both plugged in, i have performance issues, window drag lag etc... I unplug hdmi one, and plug it in after login, don't have issue, as suggested here, as workaround.

Is it possible that still isn't solved? :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers