Ubuntu

Regression: Multiple Keyboard Layouts unusable: continuously changes layout + 100% CPU usage [updated]

Reported by Yura Tolstik on 2010-08-28
This bug affects 399 people
Affects Status Importance Assigned to Milestone
Application Indicators
Undecided
Karl Lattimer
Nominated for 0.1 by hendeby
Nominated for 0.2 by Yura Tolstik
Release Notes for Ubuntu
Undecided
Unassigned
gnome-settings-daemon
Invalid
Undecided
Unassigned
Baltix
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Critical
Unassigned
Maverick
Critical
Chris Coulson

Bug Description

== General description ==

On some Ubuntu installs with two or more keyboard layouts (e.g. Russian and US English), after some time the keyboard layouts start switching in an endless loop and gnome-settings-daemon starts using more and more CPU until it reaches 100%.

== Known information ==

1) Some people here confirm that this happens with non-GTK (Java or Qt) windows more often then with native GTK. (probably, might be a coincidence)
2) Possible fixes are killing and restarting gnome-settings-daemon or disabling the "Separate layout for each window" option in keyboard preferences window.
3) The second fix, however didn't work for most people, though it might really reduce the probability of the bug appearing.
4) The bug happens both on upgrade installs and clean installs of Ubuntu, confirmed with RC and Alpha 3.
5) The bug is specific to Ubuntu, not existing in Arch Linux and AgiliaLinux.
6) There are users who experience this problem with Russian, Slovakian, Macedonian, Hebrew, Georgian layots. Having such a problem in final release will make keyboard use very problematic for users from these countries, so Ubuntu can lose many users.
7) The bug is still not fixed in GNOME 2.32, which again proves that it's an Ubuntu-specific issue.
8) For some users, the bug disappears after 2 to 15 minutes of use.
9) Confirmed for almost any key set for switching layouts (Shift+Alt, Shift+Ctrl, CapsLock, Alt, Ctrl)
10) Confirmed for both Latin and non-Latin layouts.
11) Permanent fix is to disable g-s-d keyboard plugin in gconf, not fully confirmed though.
12) Confirmed as a g-s-d issue, both with and without indicators.

== Debug ==

APPORT DATA here: https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/633167
and here: https://bugs.launchpad.net/ubuntu/+source/indicator-application/+bug/633346
MORE LOGS: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/636619
GDB DATA: https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/629444
XSESSIONERRORS: https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/630712
RANDOM LOGS: https://bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/64082

XEV OUTPUT: infinite loop of
PropertyNotify event, serial 30, synthetic NO, window 0x6000001, atom 0x174 (XKLAVIER_STATE), time 11886812, state PropertyNewValue

[NEW] GSD output:
(gnome-settings-daemon:2057):
libappindicator-CRITICAL **: app_indicator_set_label: assertion `IS_APP_INDICATOR (self)' failed

P.S. Do. Not. Touch. This. Please. There's more info here, which can make the devs remove the Incomplete status. Не трогайте это, пожалуйста. Здесь намного больше информации, чем во всех предыдущих описаниях, может снимут Incomplete.

TO DEVELOPERS: Please, comment on what logs and other info you need to get this problem solved.

Vladislav Rovda (filincrew) wrote :

I have the same problem

Yura Tolstik (yltsrc) wrote :

I attached video with login screen where you can see this bug.
Language changing without my activity.
And i can't login because of this bug.

Yura Tolstik (yltsrc) wrote :

I can see this behavior after language applet added in maverick.

Karl Lattimer (karl-qdh) wrote :

Can either of you determine the trigger for the bug? Does it seem to be doing it without a trigger? That would be impossible I think, but the indicator applet does respond to certain X events so I could investigate those.

Unfortunately I can't seem to watch the video, will try with some other players.

Changed in indicator-application:
assignee: nobody → Karl Lattimer (karl-qdh)
Karl Lattimer (karl-qdh) wrote :

The video locks up my system, could you re-encode it to another format using something like transmageddon

Yura Tolstik (yltsrc) wrote :

I don't know what's happend, but it appears few times every day on all my computers.

Karl Lattimer (karl-qdh) wrote :

It appears as if this is a gnome-screensaver dialog, I'll reassign this to gnome-settings-daemon as it's not related to the indicator itself.

Changed in gnome-settings-daemon:
assignee: nobody → Karl Lattimer (karl-qdh)
Karl Lattimer (karl-qdh) wrote :

@Yura, could you also tell me what your current keyboard shortcut for changing layouts is?

You can find out by going to; Preferences > Keyboard > Layouts > Options > Key(s) to change layout

Yura Tolstik (yltsrc) wrote :

right win key

Karl Lattimer (karl-qdh) wrote :

@Yura, could you change it to left + right alt, or another combination of two keys and see if it keeps happening.

It could be a few things, possibly a keyboard error, possibly an accidental press of the key, if the shortcut is changed we'll have a better idea of what might be causing it.

Yura Tolstik (yltsrc) wrote :

ok, i changed it, and i'll update this bug when it appears again

Karl Lattimer (karl-qdh) on 2010-08-31
Changed in indicator-application:
status: New → Incomplete
Changed in gnome-settings-daemon:
status: New → Incomplete
Vladislav Rovda (filincrew) wrote :

I use right alt for layout switching, but this bug as I posted above affects me to

Yura Tolstik (yltsrc) wrote :

i сhanged it to alt+shift, but it appears agaшn

Yura Tolstik (yltsrc) wrote :

because on macbook2.1 no second alt and ctrl keys

Karl Lattimer (karl-qdh) wrote :

Well, I can't see what of my work might have made this happen, so I think this *might* be an upstream bug.

Yura Tolstik (yltsrc) wrote :

when we run gnome-setting-daemon with enabled debug:
we can see:
(gnome-settings-daemon:4037): Gtk-WARNING **: Failed to load type module:(null) `menu_proxy_module_load': gnome-settings-daemon: undefined symbol: menu_proxy_module_load

i think this is the the reason which caused this error

Changed in indicator-application:
status: Incomplete → Invalid
Pedro Villavicencio (pedro) wrote :

If this is an upstream bug, could somebody having the issue send it to bugzilla.gnome.org ? Thanks in advance.

Yura Tolstik (yltsrc) wrote :

it is still reproduced with gnome-settings-daemon 2.31.91-0ubuntu2

Yura Tolstik (yltsrc) wrote :

I haven't gnome bugzilla account and i can't post it, please send this bug to bugzilla

Sebastien Bacher (seb128) wrote :

do you still have this issue?

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

ignore that I didn't read the new comments before posting, do you have steps to trigger the bug?

Yura Tolstik (yltsrc) wrote :

no i haven't
but it always happened when i didn't expect it :)
and i need to kill gnome-settings-daemon, but i can't enter this words in terminal(reboot is faster)

warder (warderbox) wrote :

Have the same problem

It happens over 10 times in a day. The keyboard layouts change themselves over 10 times in a second. I have the English and Macedonian layouts, and I switch the layouts with ALT+Shift. Switching the layouts seems to trigger this bug, and killing the gnome-settings-daemon process is solving it. I can properly switch between my two layouts when the gnome-settings-daemon process isn't running.

We use the Cyrillic alphabet like the Russians too and maybe that too matters something, because I don't see any non-Cyrillic user who is affected by this bug.

Btw, I use Maverick x32 Beta (the bug had the alpha3 version too).

summary: - sometimes keyboard layout automatically changed
+ Keyboard layout automatically changes
Karl Lattimer (karl-qdh) wrote :

Comment #24 seems to be the CPU hogging bug, this should have been fixed and a the fix released.

i.e. the layout starts changing rapidly and hogging CPU

Changed in gnome-settings-daemon:
assignee: Karl Lattimer (karl-qdh) → nobody
importance: Undecided → Unknown
status: Incomplete → Unknown
Changed in gnome-settings-daemon:
importance: Unknown → Critical
status: Unknown → New
Vandal (vandal1983) on 2010-09-14
description: updated
Extender (msveshnikov) on 2010-09-30
Changed in gnome-settings-daemon (Ubuntu):
status: Incomplete → Confirmed
Karl Lattimer (karl-qdh) wrote :

Can someone confirm what is exactly happening here?

Does it suddenly change to a different layout and remain at that layout?

Does it continuously change quite rapidly?

shoo_ash (ash-mail) wrote :

It changes continuously vary rapidly (e.g. I see gxneur country flags changing very rapidly).
At the same time the process gnome_settings_daemon is shown in system monitor to use more and more memory (I saw up to 800-900 mb).
It doesn't stop without killing the gnome-settings-daemon.

shoo_ash (ash-mail) wrote :

ADD: And I don't see how to reproduce it. But I feel like it has more chances to occur if you work with editors and enter a lot of text.
ADD2: When it happens, you can-not change or launch anything through popdown kb-menu (but you can see it with no lags). I.e. keyboard preferences get also blocked.

Karl Lattimer (karl-qdh) wrote :

shoo what version of gnome-settings-daemon do you have?

I reproduced this once, fixed what I thought was the bug and released the fix.

divan (ivan-daniluk) wrote :

Yes, not only indicator text/flags does switch, but also layouts are switching, so if you have, for example two layouts - English and Russian, with letters 'q' and 'й' on the same key - and want to enter 'qqqqqqqqqq', the output will be 'qйqййqqййqйqq`. The indicator image(I use country flags images) also change it's image about 10-30 times per second, sometimes faster, sometimes slower - I guess it depends on system CPU usage.

When the option 'Separate layout for each window' is disabled, the bug doesn't occur. (I tested it on two machines with latest Maverick beta).

Karl, I can provide any info that will help to find the source of the problem, just tell me what info is needed.

LGB [Gábor Lénárt] (lgb) wrote :

As I've reported in bug #636619

It happens for me too. It's still there, I've just checked. It's triggered by switching layout. After that, it goes crazy and layouts are switched cycling between my previously configured ones rapidly. Scroll lock led flashes as well (it's configured to show the non-primary layout). I can't even type since pressing the same key generates random character based on the fact which layout was active at the moment when I pressed the key. xev reports things like this without stopping (even without toucing the keyboard or the mouse after I managed to launch xev in a terminal window):

PropertyNotify event, serial 30, synthetic NO, window 0x6000001,
    atom 0x174 (XKLAVIER_STATE), time 11886504, state PropertyNewValue

PropertyNotify event, serial 30, synthetic NO, window 0x6000001,
    atom 0x174 (XKLAVIER_STATE), time 11886505, state PropertyNewValue

PropertyNotify event, serial 30, synthetic NO, window 0x6000001,
    atom 0x174 (XKLAVIER_STATE), time 11886562, state PropertyNewValue

PropertyNotify event, serial 30, synthetic NO, window 0x6000001,
    atom 0x174 (XKLAVIER_STATE), time 11886634, state PropertyNewValue

PropertyNotify event, serial 30, synthetic NO, window 0x6000001,
    atom 0x174 (XKLAVIER_STATE), time 11886635, state PropertyNewValue

PropertyNotify event, serial 30, synthetic NO, window 0x6000001,
    atom 0x174 (XKLAVIER_STATE), time 11886694, state PropertyNewValue

PropertyNotify event, serial 30, synthetic NO, window 0x6000001,
    atom 0x174 (XKLAVIER_STATE), time 11886695, state PropertyNewValue

PropertyNotify event, serial 30, synthetic NO, window 0x6000001,
    atom 0x174 (XKLAVIER_STATE), time 11886756, state PropertyNewValue

PropertyNotify event, serial 30, synthetic NO, window 0x6000001,
    atom 0x174 (XKLAVIER_STATE), time 11886811, state PropertyNewValue

PropertyNotify event, serial 30, synthetic NO, window 0x6000001,
    atom 0x174 (XKLAVIER_STATE), time 11886812, state PropertyNewValue

My system was upgraded from the previous version of Ubuntu (lucid lynx) I am wondering if it can cause the problem and it works with a 'clean' install (ie: new home directory with gnome/etc settings created by the current development version of ubuntu). I have four layouts configured, one of them (USA) is the primary, the others are configured to be signaled by the scoll lock led, and I switch layouts by key "scroll lock".

shoo_ash (ash-mail) wrote :

I have version 2.32.0-0ubuntu1 installed.
I found how to reproduce the bug. You should have several layouts and any open window with text-input (eg gedit).
So try to minimize and restore the window, at the same time change the layout with a key combination (several times) - il will reproduce the same bug, the layout change will come to infinite loop.
I can make a video for you, if it is needed, with this bug reproduced.

shoo_ash (ash-mail) wrote :

> I am wondering if it can cause the problem and it works with a 'clean' install (ie: new home directory with gnome/etc settings created by the current development version of ubuntu).

I've got clean install since last alfa or beta.

Yura Tolstik (yltsrc) wrote :

I've submit new bug report with apport after i had to kill g-s-d again.
I hope additional information from apport help you to fix this bug.
https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/652015

Rich Wales (richw) wrote :

@divan: Could you clarify exactly how you set up your keyboard layout indicator to show country flags?

One problem I've been having (at the same time as this random layout switching bug) is that I am no longer seeing any indication of my current keyboard layout at all. All I am now seeing is an icon that looks like a keyboard, with a cable trailing off into the distance behind it — and this icon stays the same no matter which layout I am using.

I'm not certain if this indicator problem is related to the random layout switching problem or not, but (at least for me) both issues arose at the same time, so I'm suspicious. I've reported the indicator problem separately as bug #650166.

divan (ivan-daniluk) wrote :

@Rich Wales, copied flag icons(from internet) to ~/.icons/flags and set the option /desktop/gnome/peripherals/keyboard/indicator/showFlags to true, but I don't think it matters, cause people reported this bug with text indicator as well.

Dmitry Shachnev (mitya57) wrote :

I use Ubuntu 10.10 with default text indicator. When this occurs,
indicator displays 'USA', but I can't change it. I have russian as
second layot.

//Duplicate bug 633167 has apport information, it may be helpful

Happens with clear install of 10.10 RC too. Layouts keep changing very quickly but then stops in 2-10 minutes, shortly this problem appears again.

pashazz (pzinin) wrote :

This bug affects me too

Yura Tolstik (yltsrc) on 2010-10-01
Changed in indicator-application:
status: Invalid → Incomplete
al3xandre (al3xandre) on 2010-10-01
description: updated
K900 (k0009000) on 2010-10-01
description: updated
summary: - Keyboard layout automatically changes
+ Keyboard layout automatically changes + 100% CPU usage [updated]
K900 (k0009000) on 2010-10-01
description: updated
description: updated
description: updated
description: updated
K900 (k0009000) on 2010-10-01
description: updated
Changed in indicator-application:
status: Incomplete → Invalid
Sergey Klimov (nbdarvin) on 2010-10-02
Changed in indicator-application:
status: Invalid → Confirmed
Changed in indicator-application:
status: Confirmed → Invalid
K900 (k0009000) on 2010-10-02
description: updated
Changed in gnome-settings-daemon:
importance: Critical → Undecided
status: New → Invalid
K900 (k0009000) on 2010-10-02
description: updated
K900 (k0009000) on 2010-10-02
description: updated
description: updated
Karl Lattimer (karl-qdh) on 2010-10-04
Changed in indicator-application:
status: Invalid → Incomplete
Karl Lattimer (karl-qdh) on 2010-10-04
Changed in indicator-application:
status: Incomplete → Confirmed
status: Confirmed → In Progress
description: updated
description: updated
Paul Sladen (sladen) on 2010-10-10
Changed in ubuntu-release-notes:
status: New → Confirmed
Changed in gnome-settings-daemon (Ubuntu):
importance: Low → Critical
milestone: none → maverick-updates
Paul Sladen (sladen) on 2010-10-10
summary: - Keyboard layout automatically changes + 100% CPU usage [updated]
+ Regression: Multiple Keyboard Layouts unusable: continuiously changes
+ layout + 100% CPU usage [updated]
summary: - Regression: Multiple Keyboard Layouts unusable: continuiously changes
+ Regression: Multiple Keyboard Layouts unusable: continuously changes
layout + 100% CPU usage [updated]
Changed in ubuntu-release-notes:
status: Confirmed → Won't Fix
Changed in gnome-settings-daemon (Ubuntu Maverick):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in gnome-settings-daemon (Ubuntu Maverick):
assignee: Canonical Desktop Team (canonical-desktop-team) → Chris Coulson (chrisccoulson)
status: Confirmed → Triaged
Changed in gnome-settings-daemon (Ubuntu Maverick):
status: Triaged → Confirmed
Changed in gnome-settings-daemon (Ubuntu Maverick):
status: Confirmed → Triaged
Evgeniy (godlike-devil) on 2010-10-11
Changed in gnome-settings-daemon (Ubuntu Maverick):
status: Triaged → Confirmed
Changed in gnome-settings-daemon (Ubuntu Maverick):
status: Confirmed → Triaged
Changed in gnome-settings-daemon (Ubuntu Maverick):
status: Triaged → In Progress
188 comments hidden view all 268 comments
Yura Tolstik (yltsrc) wrote :

I confirm, that bug still in 0ubuntu4 and attach gdb trace, hope it will help you

Chris Coulson (chrisccoulson) wrote :

Ok, I *can* upload this, so I've just uploaded it to maverick-proposed.

The version is 2.32.0-0ubuntu3, so people running the version from Karl's PPA will need to downgrade first

Karl Lattimer (karl-qdh) wrote :

Great, thanks Chris. This bug was proving illusive to me.

waster (waster2007) wrote :

Had this bug too. Is this reproducible on the system without Compiz enabled?

MaksimKa (netvin) wrote :

I don't see this update. How much time should pass after you upload it? (Maverick-proposed enabled, and i tried local update server and global update server)

Alexey Ivanov (alexey-ivanov) wrote :

@Karl Lattimer

Hello Karl, I'm using your repository, you delete gsd from it, what does this mean?

Accepted gnome-settings-daemon into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-settings-daemon (Ubuntu):
milestone: maverick-updates → natty-alpha-1
Changed in gnome-settings-daemon (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
MaksimKa (netvin) wrote :

Thanks Chris, right now i've download the fixed GSD. Will test tomorrow and will update the ticket

Vladimir Yakovlev (nagos) wrote :

Package from maverick-proposed fixed problem, thank you!

Changed in gnome-settings-daemon (Ubuntu Maverick):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Dmitry Shachnev (mitya57) wrote :

@Andrey Voronov @shoo_ash @geek @Skai Falkorr @Mehdi Fattahi
You all say that you still experience this with 2.32.0-0ubuntu4.
Can you please try it with proposed package? You can get it by running:
sudo apt-get update && sudo apt-get install gnome-settings-daemon/maverick-proposed
Please write if it still exists. Don't forget to restart your session first.

shoo_ash (ash-mail) wrote :

This time I was unable to reproduce the bug =)
I will see if it suddenly reappears, but I believe it won't.
Thanks!

Vladimir Yakovlev (nagos) wrote :

@Dmitry Shachnev i was able reproduce bug in 2.32.0-0ubuntu4 (and ubuntu3 , ubuntu2 from Chris Coulson).
gnome-settings-daemon_2.32.0-0ubuntu3 from maverick-proposed work fine, no bug.

Martin Pitt (pitti) on 2010-10-13
tags: added: verification-done
removed: verification-needed
Andrey Voronov (voronov84) wrote :

gnome-settings-daemon_2.32.0-0ubuntu3 from maverick-proposed work fine, no bug, for six hours =)

discont (discont) wrote :

Just updated from lutsid. Bug is missing. Thank you for fixing.

In general, it is a strange situation, which has received less attention than it should.

discont (discont) wrote :

Lucid of course

pfgx (pfgx) wrote :

Reproduce bug BEFORE update:
- install gxneur
- set key for change (rotate) layout, i.e. "k"
- press "k" and hold, then release
That always get a bug in my Maverick.
AFTER update no bug, thanks.

Mehdi Fattahi (mehdifattahi) wrote :

‌Bug still here after enabling proposed repo and running sudo apt-get install gnome-settings-daemon/maverick-proposed (2.32.0-0ubuntu3).

Simos Xenitellis (simosx) wrote :

@Mehdi: You need to either logout and re-login, or just restart your computer. In this way, the updated gnome-settings-daemon will be used.

Can you confirm whether you still get the regression, even after you re-login (or restart)?

I rebooted the system and I have been working for 30 minutes now without any
bug. But I still need more time to confirm the bug is completely gone. In
some cases it appeared after 3 or 4 hours of use.

On Wed, Oct 13, 2010 at 11:58 PM, Simos Xenitellis <
<email address hidden>> wrote:

> @Mehdi: You need to either logout and re-login, or just restart your
> computer. In this way, the updated gnome-settings-daemon will be used.
>
> Can you confirm whether you still get the regression, even after you re-
> login (or restart)?
>
> --
> Regression: Multiple Keyboard Layouts unusable: continuously changes layout
> + 100% CPU usage [updated]
> https://bugs.launchpad.net/bugs/625793
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (656988).
>

geek (igor-boulliev) wrote :

@Dmitry Shachnev

bug is not reproduced

(gnome-settings-daemon 2.32.0-0ubuntu3 from maverick-proposed)

Kai (ilya.skorik) wrote :

Bug still here.

g-s-d 2.32.0-0ubuntu4 from karl repo

Anton Gladky (gladky-anton) wrote :

I do not see this bug any more after maverick-proposed.

But I noticed the next: after reloading the system, indicator shows the layout "USA", but really it is german layout. I need to switch the layout several time to get it USA again. Not sure, it is related to this bug.

Thanks

Karl Lattimer (karl-qdh) wrote :

@Kai, you need to remove my repository and run with maverick proposed

@Anton, can you experiment and find more detail here, I think it's not cycling through them correctly.

MaksimKa (netvin) wrote :

@Anton, Same here it often happens when screen is locked. I see layot is USA and tape my pass, but it says wrong password. Then i should change layot again until i see USA. After this i can login.

Anton Gladky (gladky-anton) wrote :

I have a German system, but default language is USA. When the system is loaded, indicator shows right layout - USA, but it is not really USA, it is DE. I think it is possible to reproduce the bug using another languages as well: RU + USA or others.

Dmitry Shachnev (mitya57) wrote :

Ok. So the package from maverick-proposed works fine for all.
I change status in AppIndicator to invalid because it doesn't need fix.

Changed in indicator-application:
status: In Progress → Invalid
Said Babayev (phoenix49) wrote :

@MaksimKa
I didn't install this patch, waiting for update repo, but regarding "Same
here it often happens when screen is locked" it happens for me too (I didn't
apply this patch), so I think it is not related with bugfix. P.S. I avoid
this bug by turning off "Separate layout for each window"

Almas (almasd) on 2010-10-14
Changed in gnome-settings-daemon (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in gnome-settings-daemon (Ubuntu Maverick):
status: Fix Released → Fix Committed
rlomkkko (rlomko) on 2010-10-16
Changed in gnome-settings-daemon (Ubuntu Maverick):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Bobba Fett (bobba-fett) on 2010-10-17
Changed in gnome-settings-daemon (Ubuntu Maverick):
status: Fix Committed → Fix Released
Dmitry Shachnev (mitya57) wrote :

This package is still in maverick-proposed now.
https://edge.launchpad.net/ubuntu/maverick/+source/gnome-settings-daemon

Changed in gnome-settings-daemon (Ubuntu Maverick):
status: Fix Released → Fix Committed

Release of the fix will be tomorrow?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 2.32.0-0ubuntu3

---------------
gnome-settings-daemon (2.32.0-0ubuntu3) maverick-proposed; urgency=low

  * Fix LP: #625793 - Multiple Keyboard Layouts unusable: continuously
    changes layout + 100% CPU usage. Don't call xkl_engine_lock_group in
    response to XKB events, as XkbLockGroup generates another event
    - update debian/patches/06_use_application_indicator.patch
  * Fix LP: #658777 - In popup_menu_set_group() - after adding new entries to
    the hash table, don't free the keys else we end up with a hash table full
    of keys pointing to invalid memory. Instead, create the hash table with
    g_hash_table_new_full, and have the keys freed when the hash table is
    destroyed
    - update debian/patches/06_use_application_indicator.patch
 -- Chris Coulson <email address hidden> Tue, 12 Oct 2010 11:03:40 +0100

Changed in gnome-settings-daemon (Ubuntu Maverick):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to natty.

Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-settings-daemon (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → braulioareis (braulioareis)
Changed in gnome-settings-daemon (Ubuntu Maverick):
assignee: Chris Coulson (chrisccoulson) → braulioareis (braulioareis)
Changed in baltix:
status: New → Opinion
Changed in indicator-application:
assignee: Karl Lattimer (karl-qdh) → braulioareis (braulioareis)
status: Invalid → Fix Released
C de-Avillez (hggdh2) on 2010-11-05
Changed in baltix:
status: Opinion → New
Changed in gnome-settings-daemon (Ubuntu Maverick):
assignee: braulioareis (braulioareis) → nobody
Changed in gnome-settings-daemon (Ubuntu):
assignee: braulioareis (braulioareis) → nobody
Paul Sladen (sladen) on 2010-11-05
Changed in indicator-application:
assignee: braulioareis (braulioareis) → Karl Lattimer (karl-qdh)
Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in gnome-settings-daemon (Ubuntu Maverick):
assignee: nobody → Chris Coulson (chrisccoulson)
xcape77 (xcape77) wrote :

Is there a solution?

K900 (k0009000) wrote :

@xcape77 Fixed, just dist-upgrade.

Xion (xionx) wrote :

Yeah, the same problem =(
I have Ubuntu 10.04 LTS, I'v just upgraded from proposed repository and it's not helped to me =(
Please fix this problem

Changed in gnome-settings-daemon:
status: Invalid → Incomplete
Changed in gnome-settings-daemon:
status: Incomplete → Invalid
Krastanov (krastanov-stefan) wrote :

First: The bug is invalid for the upstream gnome-settings-daemon because it was introduced only in ubuntu's patched version.

Second: It was fixed in gnome-settings-daemon - 2.32.0-0ubuntu3. Check your version (using synaptic for example). If it's older, update.

Third: The bug was introduced on 10.10 not 10.04. As far as I know it was never experienced on 10.04. Make sure you are not experiencing another (new) bug.

As all 300 people who have been originally affected do not complain anymore, it may be better to fill new bug report. That will keep this report clean.

It will also help you because the devs will have easier time tracing and fixing it (here we already have ~300 comment, no one can find the useful information here). If you are sure the two bugs are connected, add a link to this one in you new bug report.

Patch for Baltix is already released?

Changed in baltix:
status: New → Fix Released
sugrob (d-snezhinskiy) on 2011-03-01
Changed in gnome-settings-daemon (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → sugrob (d-snezhinskiy)
Changed in gnome-settings-daemon (Ubuntu):
assignee: sugrob (d-snezhinskiy) → nobody
Sergey (sergeyzsg) wrote :

Also this bug affect's me. I have ubuntu precise 12.04 amd64.
E.g. some process use to many memory. After killing this process I get gnome-settings-daemon that uses 100% cpu.
But I have num lock swtching instead of kb layout switching.

chochis (chochis) wrote :

Installed cinammon on ubuntu 12.10 and now it started to happend.

chochis (chochis) wrote :

Sorry, meant 12.04

Amir Eldor (amireldor) wrote :

That's weird, it did not happen to me when I installed 12.04. Did happen on 11.10 but it was fixed after an upgrade (when the fix was released).

Displaying first 40 and last 40 comments. View all 268 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.